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1
PART 1

Introduction to Dreamweaver
Part One of this book introduces you to Macromedia Dreamweaver 8, and 
includes installation information and a workspace overview. It also 
provides a list of available resources for learning Dreamweaver.

This part contains the following sections:
Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Learning Dreamweaver. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Dreamweaver Basics. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
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Introduction
Macromedia Dreamweaver 8 is a professional HTML editor for designing, 
coding, and developing websites, web pages, and web applications. 
Whether you enjoy the control of hand-coding HTML, or prefer to work 
in a visual editing environment, Dreamweaver provides you with helpful 
tools to enhance your web creation experience.

This guide introduces you to using Macromedia Dreamweaver 8 if you’re 
unfamiliar with any major aspect of it.The tutorials in this guide lead you 
through the process of creating a simple but functional website.

This chapter covers the following topics:
What you can do with Dreamweaver 8 . . . . . . . . . . . . . . . . . . . . . . . . 11

What's new in Dreamweaver 8 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Installing Dreamweaver 8. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Registering Dreamweaver 8 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Typographical conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

What you can do with 
Dreamweaver 8
The visual editing features in Dreamweaver let you quickly create web 
pages without writing a line of code. You can view all your site elements or 
assets and drag them from an easy-to-use panel directly into a document. 
You can streamline your development workflow by creating and editing 
images in Macromedia Fireworks or another graphics application, and then 
import them directly into Dreamweaver. Dreamweaver also provides tools 
that make it easy to add Flash assets to web pages.
11



In addition to drag-and-drop features that help you build web pages, 
Dreamweaver provides a full-featured coding environment that includes 
code-editing tools (such as code coloring, tag completion, a coding toolbar, 
and code collapse) and language reference material on Cascading Style 
Sheets (CSS), JavaScript, ColdFusion Markup Language (CFML), and 
other languages. Macromedia Roundtrip HTML technology imports your 
hand-coded HTML documents without reformatting the code; you can 
then reformat code with your preferred formatting style.

Dreamweaver also lets you build dynamic, database-driven web 
applications using server technologies such as CFML, ASP.NET, ASP, JSP, 
and PHP. If your preference is for working with XML data, Dreamweaver 
provides tools that let you easily create XSLT pages, attach XML files, and 
display XML data on your web pages.

Dreamweaver is fully customizable. You can create your own objects and 
commands, modify keyboard shortcuts, and even write JavaScript code to 
extend Dreamweaver capabilities with new behaviors, Property inspectors, 
and site reports.

For more information on the resources available for learning Dreamweaver, 
see Chapter 1, “Learning Dreamweaver,” on page 15.

What's new in Dreamweaver 8
Dreamweaver 8 includes many new features that help you build websites 
and applications with a minimal amount of time and effort. Dreamweaver 
makes complex technologies simple and accessible, helping you accomplish 
more in less time.

Following are a few of the key new features in Dreamweaver 8:

■ Zoom tool and guides
■ Visual XML data binding
■ New CSS Styles panel
■ CSS layout visualization
■ Code collapse
■ Coding toolbar
■ Background file transfer
■ Insert Flash Video command
12 Introduction



For a complete list and description of new features in Dreamweaver 8, see 
“What’s new in Dreamweaver 8” in Using Dreamweaver (Help > Using 
Dreamweaver).

Installing Dreamweaver 8
This section explains how to install Dreamweaver.

Be sure to read the release notes on the Macromedia website at 
www.macromedia.com/go/dw_documentation for late-breaking 
information or instructions.

To install Dreamweaver:

1. Insert the Dreamweaver CD into your computer’s CD-ROM drive.

2. Do one of the following:

■ In Windows, the Dreamweaver installation program starts 
automatically.

■ In Macintosh, double-click the Dreamweaver installer icon that 
appears on the desktop. 

3. Follow the onscreen instructions. 

The installation program prompts you to enter the required 
information.

4. If prompted to do so, restart your computer.

Registering Dreamweaver 8
To get additional Macromedia support, it’s a good idea to register your 
copy of Macromedia Dreamweaver 8 electronically or by mail.

When you register, you can sign up to receive up-to-the-minute notices 
about upgrades and new Macromedia products. You can also sign up for 
timely e-mail notices about product updates and new content appearing on 
both the www.macromedia.com and the www-euro.macromedia.com 
websites.
Registering Dreamweaver 8 13
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To register Macromedia Dreamweaver 8, do one of the 
following: 

■ Select Help > Online Registration and fill out the electronic form.
■ Select Help > Print Registration, print the form, and mail it to the 

address shown on the form.

Typographical conventions
The following typographical conventions are used in this guide:

■ Menu items are shown in this format: menu name > menu item name. 
Items in submenus are shown in this format: menu name > submenu 
name > menu item name.

■ Code font indicates HTML tag and attribute names as well as literal 
text used in examples.

■ Italic code font indicates replaceable items (sometimes called 
metasymbols) in code. 

■ Bold roman text indicates text that you enter verbatim.
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1
CHAPTER 1

Learning Dreamweaver 
Macromedia Dreamweaver 8 includes a variety of resources to help you 
learn the program quickly and become proficient in creating your own web 
pages. All of the Dreamweaver documentation is available in both 
electronic help and PDF format.

This chapter contains the following topics:
Where to start . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Getting the most from the Dreamweaver documentation. . . . . . . 19

Using the Dreamweaver help system  . . . . . . . . . . . . . . . . . . . . . . . . 24

Where to start
The Dreamweaver documentation includes information for readers from a 
variety of backgrounds. This section helps you understand how to 
approach the documentation, depending on what your background is, and 
what you want to accomplish with Dreamweaver.

This section covers the following topics:

■ “Web-design novices” on page 15
■ “Experienced web designers” on page 16
■ “Experienced hand-coders” on page 18
■ “Web application developers” on page 18

Web-design novices
If you are relatively new to web design, this section will point you to 
sections of the Dreamweaver documentation that are most appropriate for 
your background.
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For web-design novices:

1. Begin by reading Chapter 2, “Dreamweaver Basics,” on page 27. Then 
continue by doing the tutorials in this book. The tutorials are divided 
into two sections. The first five tutorials are for beginners, and take you 
through the process of developing a small but functional website from 
start to finish. The second section of tutorials introduces you to more 
advanced concepts. You might want to wait to do the more advanced 
tutorials until you’ve developed some experience building web pages.

2. In Using Dreamweaver (Help > Using Dreamweaver), you get a more 
comprehensive idea of what you learned in this Getting Started with 
Dreamweaver guide by reading Chapter 1, “Exploring the Workspace,” 
Chapter 2, “Setting Up a Dreamweaver Site,” Chapter 3, “Creating and 
Opening Documents” and Chapter 4, “Managing Your Files,”.

3. Learn about page layout by reading Chapter 7, “Laying Out Pages with 
CSS,” and Chapter 8, “Presenting Content with Tables” in Using 
Dreamweaver.

4. To learn about formatting text and including images in your pages, read 
Chapter 13, “Inserting and Formatting Text,” and Chapter 14, 
“Inserting Images” in Using Dreamweaver.

5. That’s all you really need to begin producing high-quality websites, but 
when you’re ready to learn how to use more advanced tools, you can 
proceed through the rest of the static-page chapters in Using 
Dreamweaver. You might want to wait to read the dynamic-page 
chapters until you’re more familiar with creating web pages.

Experienced web designers
If you are an experienced web designer, this section will point you to 
sections of the Dreamweaver documentation that are most appropriate for 
your background. There are two different approaches: one for designers 
who are new to Dreamweaver and one for designers who are familiar with 
Dreamweaver but would like to learn more about creating dynamic pages.
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For experienced web designers who are new to Dreamweaver:

1. Begin by reading the tutorials in this Getting Started with Dreamweaver 
guide.

2. In Using Dreamweaver (Help > Using Dreamweaver), read Chapter 1, 
“Exploring the Workspace” to learn more about the Dreamweaver user 
interface.

3. Although much of the material in Chapter 2, “Setting Up a 
Dreamweaver Site” and Chapter 4, “Managing Your Files” is probably 
familiar to you, skim those chapters to see how these familiar concepts 
are implemented in Dreamweaver. Pay particular attention to the 
sections about setting up a Dreamweaver site.

4. For useful information on the details of using Dreamweaver to create 
basic HTML pages, read Chapter 13, “Inserting and Formatting Text” 
and Chapter 14, “Inserting Images”.

5. For information about coding in Dreamweaver, see Chapter 19, 
“Setting Up Your Coding Environment,” Chapter 20, “Coding in 
Dreamweaver,” Chapter 21, “Optimizing and Debugging Your Code,” 
and Chapter 22, “Editing Code in Design View”.

6. Read the overview at the beginning of each of the other chapters in 
Using Dreamweaver to determine whether its topics are of interest to 
you.

For experienced web designers, familiar with Dreamweaver, 
who want to learn about creating dynamic pages:

1. Begin by reading Appendix A, “Understanding Web Applications,” on 
page 217 and Chapter 11, “Tutorial: Developing a Web Application,” 
on page 197.

2. In Using Dreamweaver (Help > Using Dreamweaver), skim Chapter 1, 
“Exploring the Workspace” to learn about new aspects of the 
Dreamweaver user interface, and then read Chapter 30, “Optimizing 
the Workspace for Visual Development”.

3. Become familiar with the Dreamweaver workflow for dynamic pages by 
reading Chapter 31, “The Workflow for Dynamic Page Design”.

4. Set up a web server and application server. (See Chapter 23, “Setting Up 
a Web Application”.)
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5. Connect to a database. (See “Connecting to a database” in Chapter 23, 
“Setting Up a Web Application”.)

6. Read the overview at the beginning of each chapter in Using 
Dreamweaver to determine whether its topics are of interest to you.

Experienced hand-coders
If you are an experienced hand-coder, this section will point you to sections 
of the Dreamweaver documentation that are most appropriate for your 
background.

For experienced hand-coders:

1. Begin by reading Chapter 8, “Tutorial: Working with Code” in this 
Getting Started with Dreamweaver guide.

2. In Using Dreamweaver (Help > Using Dreamweaver), read Chapter 1, 
“Exploring the Workspace” to learn more about the Dreamweaver user 
interface.

3. Although much of the material in Chapter 2, “Setting Up a 
Dreamweaver Site” and Chapter 4, “Managing Your Files” is probably 
familiar to you, skim those chapters to see how these familiar concepts 
are implemented in Dreamweaver. Pay particular attention to the 
sections on setting up a Dreamweaver site.

4. Read more about coding with Dreamweaver in Chapter 19, “Setting Up 
Your Coding Environment,” Chapter 20, “Coding in Dreamweaver,” 
Chapter 21, “Optimizing and Debugging Your Code,” and Chapter 22, 
“Editing Code in Design View”.

5. Read the overview at the beginning of each chapter in Using 
Dreamweaver to determine whether its topics are of interest to you.

Web application developers
If you are a web application developer, this section will point you to 
sections of the Dreamweaver documentation that are most appropriate for 
your background. There are two different approaches, depending on 
whether you’ve used Dreamweaver before.
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For web application developers who have not used 
Dreamweaver: 

1. Begin by quickly reading this Getting Started with Dreamweaver guide to 
familiarize yourself with the basics of using Dreamweaver.

2. In Using Dreamweaver (Help > Using Dreamweaver), read Chapter 1, 
“Exploring the Workspace” to learn more about the Dreamweaver user 
interface.

3. Although much of the material in Chapter 2, “Setting Up a 
Dreamweaver Site” and Chapter 4, “Managing Your Files” is probably 
familiar to you, skim those chapters to see how these familiar concepts 
are implemented in Dreamweaver. Pay particular attention to the 
sections on setting up a Dreamweaver site.

4. Set up a web server and application server using Dreamweaver. (See 
Chapter 23, “Setting Up a Web Application”.)

5. Connect to a database. (See “Connecting to a database” in Chapter 23, 
“Setting Up a Web Application”.)

6. Read the overview at the beginning of each of the chapter in Using 
Dreamweaver to determine whether its topics are of interest to you.

For experienced web application developers who have used 
Dreamweaver:

1. Begin by reading “What’s new in Dreamweaver 8” in Using 
Dreamweaver (Help > Using Dreamweaver). The “What’s new” section 
is in “Introduction”.

2. Skim Chapter 1, “Exploring the Workspace” to learn about new aspects 
of the Dreamweaver user interface.

Getting the most from the 
Dreamweaver documentation
Dreamweaver includes a variety of media to help you learn the program 
quickly and become proficient in creating web pages. The Dreamweaver 
help system includes several documents that help you learn about 
Dreamweaver, Dreamweaver Extensibility, and ColdFusion. You can also 
consult a number of additional online resources as you learn how to build 
web pages.
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Accessing the Dreamweaver 
documentation
The following table summarizes the documentation included in the 
Dreamweaver help system.

You can purchase printed versions of select titles. For more information, 
see www.macromedia.com/go/buy_books.

Title Description/
Audience

Where to Find It

Getting Started 
with Dreamweaver

Basic introduction 
to Dreamweaver 
concepts and the 
interface, with 
detailed beginner 
tutorials. Intended 
for beginning 
users, as well as 
intermediate and 
advanced users 
who want to learn 
about new 
features.

• View in Dreamweaver: Select 
Help > Getting Started with 
Dreamweaver

• View online: http://
livedocs.macromedia.com/go/
livedocs_dreamweaver/

• Get the PDF: 
www.macromedia.com/go/
dw_documentation

Using 
Dreamweaver

Comprehensive 
information about 
all Dreamweaver 
features. Intended 
for all 
Dreamweaver 
users.

• View in Dreamweaver: Select 
Help > Dreamweaver Help, or 
Help > Using Dreamweaver

• View online: http://
livedocs.macromedia.com/go/
livedocs_dreamweaver/

• Get the PDF: 
www.macromedia.com/go/
dw_documentation
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Extending 
Dreamweaver

Description of the 
Dreamweaver 
framework and 
application 
programming 
interface (API). 
Intended for 
advanced users 
who want to build 
extensions or 
customize the 
Dreamweaver 
interface.

• View in Dreamweaver: Select 
Help > Extending Dreamweaver

• View online: http://
livedocs.macromedia.com/go/
livedocs_dreamweaver/

• Get the PDF: 
www.macromedia.com/go/
dw_documentation

Dreamweaver API 
Reference

Descriptions of 
the utility API and 
the JavaScript 
API, both of which 
let you perform 
various 
supporting tasks 
when developing 
Dreamweaver 
extensions. 
Intended for 
advanced users 
who want to build 
extensions or 
customize the 
Dreamweaver 
interface.

• View in Dreamweaver: Select 
Help > Dreamweaver API 
Reference

• View online: http://
livedocs.macromedia.com/go/
livedocs_dreamweaver/

• Get the PDF: 
www.macromedia.com/go/
dw_documentation

Title Description/
Audience

Where to Find It
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Using ColdFusion A selection of the 
most important 
books in the 
ColdFusion 
documentation 
set. (The full set is 
available on 
LiveDocs.) 
Intended for 
anyone interested 
in ColdFusion, 
from beginners to 
advanced 
developers.

• View in Dreamweaver: Select 
Help > Using ColdFusion

• View online: http://
livedocs.macromedia.com/go/
livedocs_coldfusion/

• Get the PDF: 
www.macromedia.com/go/
cf_documentation

Reference HTML, server 
model, and other 
types of reference 
manuals, mainly 
published by 
O’Reilly. Intended 
for anyone 
needing more 
information about 
coding syntax, 
concepts, and so 
on.

• View in Dreamweaver: Select 
Help > Reference. For a full list of 
manuals, click the Book pop-up 
menu in the Reference panel.

Title Description/
Audience

Where to Find It
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Accessing additional online Dreamweaver 
resources
The following table summarizes additional online resources for learning 
Dreamweaver.

Resource Description/
Audience

Where to Find It

Dreamweaver 
Support Center

TechNotes, plus 
support and 
problem-solving 
information for 
Dreamweaver 
users.

www.macromedia.com/go/
dreamweaver_support

Dreamweaver 
Developer Center 

Articles and 
tutorials to help 
you improve your 
skills and learn 
new ones.

www.macromedia.com/go/
dreamweaver_devcenter

Dreamweaver 
Documentation 
Resource Center

Product manuals 
in PDF format, 
errata, tutorials, 
and release notes.

www.macromedia.com/go/
dw_documentation

Macromedia 
Online Forums

Discussion and 
problem-solving 
information by 
Dreamweaver 
users, technical 
support 
representatives, 
and the 
Dreamweaver 
development 
team.

www.macromedia.com/go/
dreamweaver_newsgroup

Macromedia 
Training

Courses featuring 
hands-on tasks 
and real-world 
scenarios.

www.macromedia.com/go/
dreamweaver_training
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Using the Dreamweaver help 
system 
The online help system available in the Help menu provides detailed 
information on all tasks you can perform with Dreamweaver. To see a list 
of documents available in Help, see “Accessing the Dreamweaver 
documentation” on page 20.

This section covers the following topics:

■ “Opening Help” on page 24
■ “Searching help” on page 24
■ “Using the index” on page 25
■ “Changing the font size” on page 25
■ “Using the Start Page” on page 25
■ “Printing the Dreamweaver Documentation” on page 26
■ “Discussing the Dreamweaver documentation with LiveDocs” 

on page 26

Opening Help
You can access in-product help while you work in Dreamweaver.

To open Dreamweaver Help: 

■ Select Help > Dreamweaver Help.

Searching help
You can do a full text search of Dreamweaver Help.

To search in-product help (Windows):

1. In Dreamweaver Help, click the Search tab.

2. Type a word or phrase in the text box, and then click List Topics.

3. Double-click a topic in the list of results to display it.

To search in-product help (Macintosh):

1. In Dreamweaver Help, type a word or phrase in the Ask a Question text 
box, and then press Enter.

2. Double-click a topic in the list of results to display it.

T
IP To search for a 

specific phrase, 
enclose it in double 
quotes.
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Using the index
You can find information quickly with the index.

To use the index (Windows):

1. In Dreamweaver Help, click the Index tab.

2. Scroll to an index entry in the alphabetized list and double-click it to 
display the indexed information.

To use the index (Macintosh):

1. In Dreamweaver Help, click the Index link in the table of contents.

2. Click a letter and scroll to an index entry in the list.

3. Click a number beside the entry to display the indexed information.

Changing the font size
You can change the size of the font used by the help system.

To change the font size in the Windows help viewer:

1. Open Internet Explorer. 

The font size in the Windows help viewer is set in Internet Explorer.
2. Select View > Text Size, and then select a size. 

To change the font size in the Apple help viewer:

■ In help, select Edit > Decrease Font Size, or Edit > Increase Font Size. 

Using the Start Page 
When you start Dreamweaver without opening a document, the 
Dreamweaver Start page appears in the work environment. The Start page 
gives you quick access to Dreamweaver tutorials, recent files, and 
Dreamweaver Exchange, where you can add new capabilities to some 
Dreamweaver features. Use the Start page much like a web page. Click any 
of the features you see to use them.

To disable the Start page:

1. Run Dreamweaver without opening a document. 

The Start page is displayed.
2. Click Don’t Show Again.

T
IP You can start typing 

a keyword in the text 
box to quickly scroll 
to an index entry.
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Printing the Dreamweaver Documentation 
The following books are available in PDF format on the Macromedia 
website at www.macromedia.com/go/dw_documentation:

■ Using Dreamweaver
■ Getting Started with Dreamweaver
■ Extending Dreamweaver
■ Dreamweaver API Reference

You can print all or part of the PDF on your own printer or you can bring 
the PDF to a copy shop.

Discussing the Dreamweaver 
documentation with LiveDocs
The Dreamweaver documentation is also available online in LiveDocs 
format. The LiveDocs version of the Dreamweaver Help looks very similar 
to the in-product help, but it allows you to comment on the contents of 
individual help pages. You can add useful information on a specific 
Dreamweaver topic based on your own experience, or solicit advice from 
fellow Dreamweaver designers and developers.

The Dreamweaver LiveDocs are available at http://
livedocs.macromedia.com/go/livedocs_dreamweaver/
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2
CHAPTER 2

Dreamweaver Basics
To get the most out of your Macromedia Dreamweaver 8 experience, you 
should understand the basic elements of the Dreamweaver workspace. This 
chapter introduces you to the most important and commonly used 
workspace elements, and tells you how to accomplish some basic tasks in 
Dreamweaver.

This chapter contains the following sections:
Getting to know the Dreamweaver 8 workspace . . . . . . . . . . . . . . 27

Customizing the Dreamweaver 8 workspace  . . . . . . . . . . . . . . . . . 39

Accomplishing basic tasks in Dreamweaver 8  . . . . . . . . . . . . . . . . 42

Getting to know the 
Dreamweaver 8 workspace
The Dreamweaver workspace lets you view documents and object 
properties. The workspace also places many of the most common 
operations in toolbars so that you can quickly make changes to your 
documents.

This section is designed to give you an overview of the Dreamweaver 8 
workspace. For more comprehensive information about any of the 
workspace elements introduced in this section, see Chapter 1, “Exploring 
the Workspace” in Using Dreamweaver.

This section contains the following topics:

■ “The workspace layout” on page 28
■ “The Document window” on page 30
■ “The Document toolbar” on page 30
■ “The status bar” on page 32
■ “The Insert bar” on page 33
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■ “The Coding toolbar” on page 35
■ “The Property inspector” on page 36
■ “The Files panel” on page 37
■ “The CSS Styles panel” on page 38

The workspace layout
In Windows, Dreamweaver provides an all-in-one-window integrated 
layout. In the integrated workspace, all windows and panels are integrated 
into a single larger application window.

Files panelProperty inspectorTag selector

Document toolbar

Insert bar

Document window Panel groups

N
O

T
E

The Windows workspace also has a Coder option, which docks the panel 
groups on the left side and displays the Document window in Code view 
by default. For more information, see “Using the coder-oriented 
workspace (Windows only)” in Using Dreamweaver. To use this option, 
see “Choosing the workspace layout (Windows only)” on page 39.
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On the Macintosh, Dreamweaver can display multiple documents in a 
single window with tabs that identify each document. Dreamweaver can 
also appear as part of a floating workspace in which each document appears 
in its own individual window. Panel groups are initially docked together, 
but can be undocked into their own windows. Windows “snap” 
automatically to each other, to the sides of the screen, and to the 
Document window as you drag or resize them.

You can switch between different layouts in both Windows and Macintosh. 
For more information, see “Choosing the workspace layout 
(Windows only)” on page 39, and “Displaying tabbed documents 
(Macintosh)” on page 40.

Insert bar

Document toolbar

Property inspector

Document window

Tag selector

Panel groups

Files panel
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The Document window
The Document window shows the current document. You can select any of 
the following views:

Design view is a design environment for visual page layout, visual editing, 
and rapid application development. In this view, Dreamweaver displays a 
fully editable, visual representation of the document, similar to what you 
would see viewing the page in a browser.

Code view is a hand-coding environment for writing and editing HTML, 
JavaScript, server-language code—such as PHP or ColdFusion Markup 
Language (CFML)—and any other kind of code. For more information, 
see Chapter 20, “Coding in Dreamweaver” in Using Dreamweaver.

Code and Design view lets you view both Code view and Design view for 
the same document in a single window.

When the Document window has a title bar, the title bar displays the page 
title and, in parentheses, the file’s path and filename. After the filename, 
Dreamweaver displays an asterisk if you’ve made changes that you haven’t 
saved yet.

When the Document window is maximized in the integrated workspace 
layout (Windows only), it has no title bar; in that case the page title and 
the file’s path and filename appear in the title bar of the main workspace 
window.

Additionally, when a Document window is maximized, tabs appear at the 
top of the Document window area showing the filenames of all open 
documents. To switch to a document, click its tab.

For more information about using the Document window, see Chapter 1, 
“Exploring the Workspace” in Using Dreamweaver.

The Document toolbar 
The Document toolbar contains buttons that let you toggle between 
different views of your document quickly: Code, Design, and a split view 
that shows both Code and Design view. 
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The toolbar also contains some common commands and options related to 
viewing the document and transferring it between the local and remote 
sites.

The following options appear in the Document toolbar:

Show Code View displays only the Code view in the Document window.

Show Code and Design Views displays Code view in part of the 
Document window and Design view in another part. When you select this 
combined view, the option Design View on Top becomes available in the 
View Options menu. Use this option to specify which view appears at the 
top of your Document window.

Show Design View displays only the Design view in the Document 
window.

Server Debug displays a report to help you debug the current ColdFusion 
page. The report includes errors, if any, in your page.

Document Title allows you to enter a title for your document, to be 
displayed in the browser’s title bar. If your document already has a title, it 
appears in this field.

No Browser/Check Errors enables you to check cross-browser 
compatibility.

Validate Markup lets you validate the current document or a selected tag.

File Management displays the File Management pop-up menu.

Preview/Debug in Browser allows you to preview or debug your 
document in a browser. Select a browser from the pop-up menu.

Refresh Design View refreshes the document’s Design view after you 
make changes in Code view. Changes you make in Code view don’t 
automatically appear in Design view until you perform certain actions, 
such as saving the file or clicking this button.

Show Code View

Show Design View

Document Title

Refresh Design View

No Browser/Check Errors

View Options

Show Code and Design Views

Preview/Debug in Browser

File Management

Server Debug
Visual Aids

Validate Markup
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View Options allows you to set options for Code view and Design view, 
including which view should appear above the other. Options in the menu 
are for the current view: Design view, Code view, or both.

Visual Aids lets you use different visual aids to design your pages.

For more information about using the Document toolbar, see Chapter 1, 
“Exploring the Workspace” in Using Dreamweaver.

The status bar
The status bar at the bottom of the Document window provides additional 
information about the document you are creating.

The tag selector shows the hierarchy of tags surrounding the current 
selection. Click any tag in the hierarchy to select that tag and all its 
contents. Click <body> to select the entire body of the document. To set 
the class or id attributes for a tag in the tag selector, right-click 
(Windows) or Control-click (Macintosh) the tag and select a class or ID 
from the context menu. The tag selector is the preferable method for 
selecting tags because it ensures that you are always selecting the tag with 
accuracy.

The Hand tool lets you click the document and drag it in the Document 
window. Click the Select tool to disable the Hand tool.

The Zoom tool and Set Magnification pop-up menu let you set a 
magnification level for your document. For more information, see 
“Zooming in and out” in Using Dreamweaver.

Document size and 
estimated download time

Tag selector
Window Size pop-up menu

Set magnification
Zoom tool

Hand tool
Select tool
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The Window Size pop-up menu (visible in Design view only) lets you 
resize the Document window to predetermined or custom dimensions. For 
more information, see “Resizing the Document window” in Using 
Dreamweaver.

To the right of the Window Size pop-up menu are the estimated document 
size and estimated download time for the page, including all dependent 
files such as images and other media files. For more information, see 
“Setting download time and size preferences” in Using Dreamweaver.

For more information about using the status bar, see Chapter 1, “Exploring 
the Workspace” in Using Dreamweaver.

The Insert bar
The Insert bar contains buttons for creating and inserting objects such as 
tables, layers, and images. When you roll the pointer over a button, a 
tooltip appears with the name of the button.

The buttons are organized into several categories, which you can switch on 
the left side of the Insert bar. Additional categories appear when the current 
document contains server code, such as ASP or CFML documents. When 
you start Dreamweaver, the category you were last working in opens. 

Some categories have buttons with pop-up menus. When you select an 
option from a pop-up menu, it becomes the default action for the button. 
For example, if you select Image Placeholder from the Image button’s pop-
up menu, the next time you click the Image button, Dreamweaver inserts 
an image placeholder. Anytime you select a new option from the pop-up 
menu, the default action for the button changes.

The Insert bar is organized in the following categories:

The Common category enables you to create and insert the most 
commonly used objects, such as images and tables.

The Layout category enables you to insert tables, div tags, layers, and 
frames. You can also you choose among three views of tables: Standard 
(default), Expanded Tables, and Layout. When Layout mode is selected, 
you can use the Dreamweaver layout tools: Draw Layout Cell and Draw 
Layout Table. 
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The Forms category contains buttons for creating forms and inserting 
form elements. 

The Text category enables you to insert a variety of text- and list-
formatting tags, such as b, em, p, h1, and ul. 

The HTML category enables you to insert HTML tags for horizontal 
rules, head content, tables, frames, and scripts. 

Server-code categories are available only for pages that use a particular 
server language, including ASP, ASP.NET, CFML Basic, CFML Flow, 
CFML Advanced, JSP, and PHP. Each of these categories provides server-
code objects that you can insert in Code view. 

The Application category enables you to insert dynamic elements such as 
recordsets, repeated regions, and record insertion and update forms.

The Flash elements category enables you to insert Macromedia Flash 
elements.

The Favorites category enables you to group and organize the Insert bar 
buttons you use the most in one common place.

For more information about using the Insert bar, see Chapter 1, “Exploring 
the Workspace” in Using Dreamweaver.
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The Coding toolbar
The Coding toolbar contains buttons that let you perform many standard 
coding operations, such as collapsing and expanding code selections, 
highlighting invalid code, applying and removing comments, indenting 
code, and inserting recently used code snippets. The Coding toolbar is 
visible only in Code view and appears vertically on the left side of the 
Document window.

You cannot undock or move the Coding toolbar, but you can hide it. For 
more information, see “Displaying toolbars” in Using Dreamweaver.

For more information about using the Coding toolbar, see “Inserting code 
quickly with the Coding toolbar” in Using Dreamweaver.
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The Property inspector
The Property inspector lets you examine and edit the most common 
properties for the currently selected page element, such as text or an 
inserted object. The contents of the Property inspector vary depending on 
the element selected. For example, if you select an image on your page, the 
Property inspector changes to show properties for the image (such as the 
file path to the image, the width and height of the image, the border 
around the image, if any, and so on).

The Property inspector is at the bottom of the workspace by default, but 
you can dock it at the top of the workspace if you want. Or, you can make 
it a floating panel in the workspace. For more information about moving 
the Property inspector, see “Docking and undocking panels and panel 
groups” in Using Dreamweaver.

For more information about using the Property inspector, see “Using the 
Property inspector” in Using Dreamweaver.
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The Files panel
You use the Files panel to view and manage the files in your Dreamweaver 
site. 

When you view sites, files, or folders in the Files panel, you can change the 
size of the viewing area, as well as expand or collapse the Files panel. When 
the Files panel is collapsed it displays the contents of the local site, the 
remote site, or the testing server as a list of files. When expanded, it 
displays the local site and either the remote site or testing server. The Files 
panel can also display a visual site map of the local site.

For Dreamweaver sites, you can also customize the Files panel by changing 
the view—either your local or remote site—that appears by default in the 
collapsed panel.

For more information about using the Files panel to manage your site, see 
Chapter 4, “Managing Your Files” in Using Dreamweaver.
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The CSS Styles panel
The CSS Styles panel lets you track the CSS rules and properties affecting a 
currently selected page element (Current mode), or the rules and properties 
affecting an entire document (All mode). A toggle button at the top of the 
CSS Styles panel lets you switch between the two modes. The CSS Styles 
panel also lets you modify CSS properties in both All and Current mode.

You can resize any of the panes by dragging the borders between the panes.

In Current mode, the CSS Styles panel displays three panes: a Summary for 
Selection pane that displays the CSS properties for the current selection in 
the document, a Rules pane that displays the location of selected properties 
(or a cascade of rules for the selected tag, depending on your selection), and 
a Properties pane that lets you edit CSS properties for the rule defining the 
selection.
38 Dreamweaver Basics



In All mode, the CSS Styles panel displays two panes: an All Rules pane 
(on top), and a Properties pane (on bottom). The All Rules pane displays a 
list of rules defined in the current document as well as all rules defined in 
style sheets attached to the current document. The Properties pane lets you 
edit CSS properties for any selected rule in the All Rules pane.

Any changes you make in the Properties pane are applied immediately, 
letting you preview your work as you go.

For more information about the CSS Styles panel, see “About the CSS 
Styles panel” in Using Dreamweaver.

Customizing the Dreamweaver 8 
workspace
There are some basic techniques you can use to customize Dreamweaver to 
suit your needs without knowing complex code or editing text files.

This section contains the following topics:

■ “Choosing the workspace layout (Windows only)” on page 39
■ “Displaying tabbed documents (Macintosh)” on page 40
■ “Hiding and displaying the Start page” on page 41

Choosing the workspace layout 
(Windows only)
In Windows, you can choose between the Designer and Coder workspace 
layouts. The first time you start Dreamweaver, a dialog box lets you choose 
a workspace layout. You can switch to a different workspace at any time.
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To choose a workspace layout the first time you start 
Dreamweaver:

1. Select one of the following layouts:

Designer is an integrated workspace using MDI (Multiple Document 
Interface), in which all Document windows and panels are integrated 
into one larger application window, with the panel groups docked on 
the right. 
Coder is the same integrated workspace, but with the panel groups 
docked on the left, in a layout similar to that used by Macromedia 
HomeSite and Macromedia ColdFusion Studio, and with the 
Document window showing Code view by default.

2. Click OK.

To switch to a different workspace after you’ve chosen one:

■ Select Window > Workspace Layout, and select the workspace layout 
you prefer.

In addition to selecting Coder and Designer, you can select Dual Screen 
Right or Dual Screen Left. If you have a secondary monitor to the right of 
your primary monitor, Dual Screen Right puts all panels on the right 
monitor, and keeps the Document window on the primary monitor. If you 
have a secondary monitor to the left of your primary monitor, Dual Screen 
Left puts all panels on the left monitor, and keeps the Document window 
on the primary monitor.

Displaying tabbed documents (Macintosh)
On the Macintosh, Dreamweaver can display multiple documents in a 
single Document window by using tabs to identify each document. 
Dreamweaver can also display them as part of a floating workspace, in 
which each document appears in its own window.

To open a tabbed document in a separate window:

■ Right-click or Control-click the tab and select Move to New Window 
from the context menu.
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You can dock panel groups on either side of the workspace in either 
layout.
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To combine separate documents into tabbed windows:

■ Select Window > Combine as Tabs.

To change the default tabbed document setting:

1. Select Dreamweaver > Preferences, and then select the General category.

2. Select or deselect Open Documents in Tabs, and click OK.

Hiding and displaying the Start page
The Dreamweaver Start page appears when you start Dreamweaver and 
anytime that you do not have any documents open. You can choose to hide 
the Start page, and then later display it again. When the Start page is 
hidden and there are no documents open, the Document window is blank.

To hide the Start page:

■ Select the Don’t Show Again checkbox on the Start page.
The Start page will not appear when you start Dreamweaver, or after 
you open and close a document.

To display the Start page:

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences 
(Macintosh).

The Preferences dialog box appears displaying the General preferences 
category.

2. Select the Show Start Page checkbox.

The Start page appears when you start Dreamweaver, or after you open 
and close a document.

Dreamweaver does not alter the display of documents that are currently 
open when you change preferences. Documents opened after you select 
a new preference, however, will display according to the preference you 
selected.
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Accomplishing basic tasks in 
Dreamweaver 8
This section describes how to accomplish basic tasks such as creating, 
opening, and saving files. For more detailed information, see Chapter 3, 
“Creating and Opening Documents” in Using Dreamweaver.

This section contains the following topics:

■ “About Dreamweaver files” on page 42
■ “Creating new files in Dreamweaver” on page 43
■ “Saving files in Dreamweaver” on page 44
■ “Opening files in Dreamweaver” on page 45

About Dreamweaver files 
You can work with a variety of file types in Dreamweaver. The primary 
kind of file you will work with is the HTML file. HTML files—or 
Hypertext Markup Language files—contain the tag-based language 
responsible for displaying a web page in a browser. You can save HTML 
files with either the .html or .htm extension. Dreamweaver saves files using 
the .html extension by default.

Following are some of the other common file types you might use when 
working in Dreamweaver:

CSS, or Cascading Style Sheet files, have a .css extension. They are used to 
format HTML content and control the positioning of various page 
elements. For more information on working with these types of files, see 
“Understanding Cascading Style Sheets” in Using Dreamweaver.

GIF, or Graphics Interchange Format files, have a .gif extension. GIF 
format is a popular web graphic format for cartoons, logos, graphics with 
transparent areas, and animations. GIFs contain a maximum of 256 colors.

JPEG, or Joint Photographic Experts Group files (named after the 
organization that created the format), have a .jpg extension, and are usually 
photographs or high-color images. The JPEG format is best for digital or 
scanned photographs, images using textures, images with gradient color 
transitions, and any images that require more than 256 colors.
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XML, or Extensible Markup Language files, have a .xml extension. They 
contain data in a raw form that can be formatted using XSL (Extensible 
Stylesheet Language). For more information on working with these types 
of files, see Chapter 36, “Displaying XML Data in Web Pages” in Using 
Dreamweaver.

XSL, or Extensible Stylesheet Language files, have a .xsl or .xslt extension. 
They are used to style XML data that you want to display on a web page. 
For more information on working with these types of files, see Chapter 36, 
“Displaying XML Data in Web Pages” in Using Dreamweaver.

CFML, or ColdFusion Markup Language files, have a .cfm extension. 
They are used to process dynamic pages. For more information on working 
with these types of files, see Chapter 40, “Building ColdFusion 
Applications Rapidly” in Using Dreamweaver.

ASPX, or ASP.NET files, have a .aspx extension. They are used to process 
dynamic pages. For more information on working with these types of files, 
see Chapter 41, “Building ASP.NET Applications Rapidly” in Using 
Dreamweaver.

PHP, or PHP: Hypertext Preprocessor files, have a .php extension. They 
are used to process dynamic pages. For more information on working with 
these types of files, see Chapter 43, “Building PHP Applications Rapidly” 
in Using Dreamweaver.

Creating new files in Dreamweaver
This section tells you how to create a new blank document in 
Dreamweaver.

You can also create new documents in Dreamweaver that are based on a 
Dreamweaver design file or on an existing template. For more information, 
see “Creating new documents” in Using Dreamweaver.
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To create a new blank document:

1. Select File > New.

The New Document dialog box appears. The General tab is already 
selected.

2. From the Category list, select Basic Page, Dynamic Page, Template 
Page, Other, or Framesets; then, from the list on the right, select the 
type of document you want to create. 

For example, select Basic Page to create an HTML document, or select 
Dynamic page to create a ColdFusion or ASP document, and so on.
For more information about options in this dialog box, click the Help 
button in the dialog box. 

3. Click the Create button.

The new document opens in the Document window.
4. Save the document (see “Saving files in Dreamweaver” on page 44).

Saving files in Dreamweaver
When you create a new document, you need to save it.

To save a new document:

1. Select File > Save.

2. In the dialog box that appears, navigate to the folder where you want to 
save the file.

3. In the File Name text box, type a name for the file.

Avoid using spaces and special characters in file and folder names and 
do not begin a filename with a numeral. In particular, do not use 
special characters (such as é, ç, or ¥) or punctuation (such as colons, 
slashes, or periods) in the names of files you intend to put on a remote 
server; many servers change these characters during upload, which will 
cause any links to the files to break. 

4. Click Save.

T
IP It’s a good idea to 

save your file in a 
Dreamweaver site. 
For more 
information, see 
Chapter 3, “Tutorial: 
Setting Up Your Site 
and Project Files,” 
on page 49.
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Opening files in Dreamweaver
In Dreamweaver, you can easily open and edit your documents.
To open a file:

1. Select File > Open. 

2. In the Open dialog box, select the file and click Open. 
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PART 2

Tutorials
Part Two of this book contains five basic tutorials that take you through 
the steps of building a web page. The web page you’ll create is the home 
page for Cafe Townsend, a fictional restaurant.

This part contains the following sections:
Tutorial: Setting Up Your Site and Project Files  . . . . . . . . . . . . . . .49

Tutorial: Creating a Table-based Page Layout  . . . . . . . . . . . . . . . .55

Tutorial: Adding Content to Pages . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Tutorial: Formatting Your Page with CSS. . . . . . . . . . . . . . . . . . . . .99

Tutorial: Publishing Your Site. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
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CHAPTER 3

Tutorial: Setting Up Your 
Site and Project Files
This tutorial introduces you to the concept of a Macromedia Dreamweaver 
8 site and shows you how to set up the project files for the Cafe Townsend 
sample website. In Dreamweaver, a site generally consists of two parts: a 
collection of files on a local computer (the local site), and a location on a 
remote web server that you upload the files to when you’re ready to make 
them publicly available (the remote site). You use the Dreamweaver Files 
panel to manage the files for your site.

The most common approach to creating a website with Dreamweaver is to 
create and edit pages on your local disk, and then upload copies of those 
pages to a remote web server for viewing on the web. In this tutorial you’ll 
only learn how to set up the local site so that you can begin building web 
pages right away. Later, after you’ve completed the website, you’ll learn how 
to create a remote site so that you can upload your files to a web server.

In this tutorial, you will complete the following tasks:
Learn about Dreamweaver sites. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Set up your project files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50

Define a local folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Learn about Dreamweaver sites
In Dreamweaver, the term “site” can refer either to a website or to a local 
storage location for the documents that belong to a website. The latter is 
what you need to establish before you begin building your website. A 
Dreamweaver site organizes all of the documents associated with your 
website and lets you track and maintain links, manage files, share files, and 
transfer your site files to a web server.

Macromedia HomeSite and ColdFusion Studio users can think of a 
Dreamweaver site as being like a HomeSite or Studio project.
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A Dreamweaver site consists of as many as three parts, depending on your 
computing environment and the type of website you are developing:

Local folder is your working directory. Dreamweaver refers to this folder as 
your local site. The local folder is usually a folder on your hard disk.

Remote folder is where you store your files, depending on your 
environment, for testing, production, collaboration, and publication. 
Dreamweaver refers to this folder as your remote site. The remote folder is a 
folder on the computer that’s running your web server. The computer 
running the web server is often (but not always) the computer that makes 
your site publicly available on the web.

Folder for dynamic pages (Testing Server folder) is the folder where 
Dreamweaver processes dynamic pages. This folder is often the same folder 
as the remote folder. You do not need to worry about this folder unless you 
are developing a web application. For more information about the Testing 
Server folder, see “Specifying where dynamic pages can be processed” in 
Using Dreamweaver.

You can set up a Dreamweaver site by using the Site Definition Wizard, 
which guides you through the setup process, or by using the Site 
Definition Advanced settings, which let you set up local, remote, and 
testing folders individually, as necessary. In this tutorial you’ll use the Site 
Definition Advanced settings to set up a local folder for your project files. 
Later in this book, you’ll learn how to set up a remote folder so that you 
can publish your pages to a web server and make them publicly available.

For more information about how to use the Site Definition Wizard to set 
up a Dreamweaver site, see “Setting up a new Dreamweaver site” in Using 
Dreamweaver.

For more information about how to set up a remote site, see Chapter 7, 
“Tutorial: Publishing Your Site”.

For more information about Dreamweaver sites in general, see “Setting Up 
a Dreamweaver Site” in Using Dreamweaver.

Set up your project files
When you create a local site, you can place any existing assets (images or 
other pieces of content) in the local site’s root folder (the main folder for 
the site). Then when you’re ready to add content to your pages, the assets 
are there and ready for you to use.
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The sample files included with Dreamweaver contain assets for the sample 
website you’ll build using these Getting Started with Dreamweaver tutorials. 
The first step in creating the site is to copy the sample files from the 
Dreamweaver application folder to an appropriate folder on your hard 
disk.

1. Create a new folder called local_sites on your hard disk.

For example, create a folder called local_sites in either of the following 
two locations:
■ In Windows: C:\Documents and Settings\your_user_name\My 

Documents\local_sites
■ On the Macintosh: Macintosh HD/Users/your_user_name/

Documents/local_sites

2. Locate the cafe_townsend folder in the Dreamweaver application folder 
on your hard disk.

If you installed Dreamweaver to its default location, the path to the 
folder is as follows:
■ In Windows: C:\Program Files\Macromedia\Dreamweaver 

8\Tutorial_assets\cafe_townsend\.
■ On the Macintosh: Macintosh HD/Applications/Macromedia 

Dreamweaver 8/Tutorial_assets/cafe_townsend.

On the Macintosh, there’s a folder called Sites already in your user folder. 
Don’t use that Sites folder as your local folder; the Sites folder is where 
you place your pages to make them publicly accessible when you’re using 
the Macintosh as a web server.

About local and remote “root” folders The local “root” folder of your Dreamweaver site is often the 
main or top-level folder for your website. It usually corresponds to an identical folder on the remote site 
(web server). The root folder also usually defines the first part of your website’s URL, following the 
domain name. For example, if your local root folder is called mywebsite, and you have an identical root 
folder defined on the remote site, the URL for your website would be something like http://
www.yahoo.com/mywebsite.
In some cases, the local root folder may not have an exact name equivalent on the remote site. For 
example, if you own the domain name www.mywebsite.com, with a remote root directory of public_html, 
your local root folder could still be called mywebsite. The files in both the local and remote root directories 
would be identical; only the folder names (public_html on the remote site, and mywebsite on the local 
computer) would be different.
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3. Copy the cafe_townsend folder into the local_sites folder. 

The cafe_townsend folder is the folder that you will use as the root 
folder (main folder) for your Dreamweaver site.

Define a local folder
You must define a Dreamweaver local folder for each new website you 
create. The local folder is the folder that you use to store working copies of 
site files on your hard disk. If you don’t define a local folder, certain 
features in Dreamweaver cannot work properly.

Defining a local folder also allows you to manage your files and to transfer 
files to and from your web server by using a number of file-transfer 
methods.

Now you’ll define the cafe_townsend folder that you copied into the 
local_sites folder as your local folder.

1. Start Dreamweaver and select Site > Manage Sites.

The Manage Sites dialog box appears.
2. Click the New button and select Site.

The Site Definition dialog box appears.
3. If the wizard (Basic tab) appears, click the Advanced tab and select Local 

Info from the Category list (it should be the default).

4. In the Site Name text box, enter Cafe Townsend as the name of the site.

5. In the Local Root Folder text box, specify the cafe_townsend folder that 
you copied to the local_sites folder in the previous section. 

You can click the folder icon to browse to and select the folder, or enter 
a path in the Local Root Folder text box.
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6. In the Default Images Folder text box, specify the images folder that 
already exists in the cafe_townsend folder. 

You can click the folder icon to browse to and select the folder, or enter 
a path in the Default Images Folder text box.
The Site Definition dialog box should now look as follows:

7. Click OK.

The Manage Sites dialog box appears, showing your new site.
8. Click Done to close the Manage Sites dialog box.
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The Files panel now shows the new local root folder for your current site. 
The file list in the Files panel acts as a file manager, allowing you to copy, 
paste, delete, move, and open files just as you would on a computer 
desktop.

For more information about how the Files panel works, see “The Files 
panel” on page 37.

You’ve now defined a local root folder for your site. The local root folder is 
the place on your local computer where you keep the working copies of 
your web pages. Later, if you want to publish your pages and make them 
publicly available, you’ll need to define a remote folder—a place on a 
remote computer, running a web server, that will hold published copies of 
your local files.

You can follow the rest of the tutorials in this guide to create the Cafe 
Townsend sample site, or you can work on your own web pages. When 
you’re finished creating and editing pages, proceed to define a remote 
folder on a server and publish your pages. For more information, see 
Chapter 7, “Tutorial: Publishing Your Site”.
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CHAPTER 4

Tutorial: Creating a Table-based 
Page Layout
This tutorial explains how to create a table-based page layout in 
Macromedia Dreamweaver 8. A page layout determines how your page will 
appear in the browser, showing, for example, the placement of menus, 
images, and Macromedia Flash content.

Tables are a powerful tool for presenting tabular data and for laying out 
text and graphics on an HTML page. You can use tables to create your 
layout quickly and easily. In this tutorial you’ll create a number of tables in 
a new Dreamweaver document. The rows and cells of the tables effectively 
act as container boxes for the content you’ll add later.

In this tutorial, you will complete the following tasks:
Examine the design comp  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

Create and save a new page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Insert tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

Set table properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Insert an image placeholder. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

Add color to the page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Examine the design comp
Typically, you don’t begin building a website by opening Dreamweaver and 
laying out pages right away. The first steps to creating a website begin on a 
piece of paper, or in a graphics-editing application like Macromedia 
Fireworks. Graphic designers usually sketch out a piece of comprehensive 
artwork (also known as a “comp”) for the website in order to show it to the 
client and make sure that the initial ideas for the site meet with their 
client’s approval.
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A comp consists of any number of page elements that the client has 
requested for their website. For example, the client might say, “I want to 
have a logo at the top of the page, a navigation that links to these other 
pages, a section for an online store, and a place where I can insert video 
clips.” Based on that discussion, the designer begins planning the layout of 
the site, and makes sketches of sample pages that fulfill the client’s 
requirements.

This tutorial provides you with the completed and approved comp for Cafe 
Townsend, a fictional restaurant that has requested a website. As the web 
designer, it’s your job to transform the comp into a working web page 
(most likely with the help of other graphics designers and Flash 
developers).
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You’ll notice that the graphic designer has provided you with a web page 
comp that includes a number of content areas, as well as some graphic 
ideas. In the next sections, you’ll use Dreamweaver to lay out this design.

You can also open the original comp file if you want to see it on the 
computer screen. You can find the comp, homepage-mockup.jpg, in the 
fireworks_assets folder of the cafe_townsend folder that you copied to your 
hard drive in Chapter 3, “Tutorial: Setting Up Your Site and Project Files.” 
You might even want to print out the comp so that you can have it in front 
of you as you build your page.

Create and save a new page
After you set up a site and examine any comps, you are ready to begin 
building web pages. You’ll start by creating a new page, and saving it in the 
cafe_townsend local root folder of your website. The page eventually 
becomes the home page for Cafe Townsend, a fictional restaurant.

If you haven’t created the cafe_townsend local root folder, you must do so 
before you proceed. For instructions, see Chapter 3, “Tutorial: Setting Up 
Your Site and Project Files.”

1. In Dreamweaver, select File > New.

2. On the General tab of the New Document dialog box, select Basic Page 
from the Category list, select HTML from the Basic Page list, and click 
Create.

3. Select File > Save As.

4. In the Save As dialog box, browse to and open the cafe_townsend folder 
that you defined as the site’s local root folder. 

In Chapter 3, “Tutorial: Setting Up Your Site and Project Files”, you 
created this folder within a folder called local_sites.

5. Enter index.html in the File Name text box and click Save.

The filename now appears in the title bar at the top of the application 
window.
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6. In the Document Title text box at the top of your new document, type 
Cafe Townsend.

This is the title of your page (different from the filename). Your site 
visitors will see this title in the browser window title bar when they 
view the page in a web browser.

7. Select File > Save to save your page.

Insert tables
Next you’ll add a table that will hold text, graphics, and Macromedia Flash 
assets.

1. Click once on the page to place the insertion point in the upper-left 
corner of the page.

2. Select Insert > Table.

3. In the Insert Table dialog box, do the following:

■ Enter 3 in the Rows text box.
■ Enter 1 in the Columns text box. 
■ Enter 700 in the Table Width text box. 
■ Select Pixels from the Table Width pop-up menu.
■ Enter 0 in the Border Thickness text box.
■ Enter 0 in the Cell Padding text box. 
■ Enter 0 in the Cell Spacing text box. 
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4. Click OK.

A table with three rows and one column appears in your document. 
The table is 700 pixels wide with no border, cell padding, or cell 
spacing.
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5. Click once to the right of the table to deselect it.

6. Select Insert > Table to insert another table.

7. In the Insert Table dialog box, do the following for the second table:

■ Enter 1 in the Rows text box.
■ Enter 3 in the Columns text box.
■ Enter 700 in the Table Width text box.
■ Select Pixels from the Table Width pop-up menu.
■ Enter 0 in the Border Thickness text box.
■ Enter 0 in the Cell Padding text box.
■ Enter 0 in the Cell Spacing text box.

More about tables Tables are a powerful tool for presenting tabular data and for laying out text and 
graphics on an HTML page. A table consists of one or more rows; each row consists of one or more cells. 
When you create multiple rows with multiple cells, the cells form columns. Technically, a cell is a division 
within a horizontal row, and a column is the vertical accumulation of those cell divisions. 
Dreamweaver displays the table width and the width for each table column in the Table selector 
(indicated by green lines) when the table is selected or when the insertion point is in the table.

Next to the widths are arrows for the table header menu and the column header menus. You can use the 
menus for quick access to common table-related commands. You can also enable or disable the display 
of the widths and menus by selecting View > Visual Aids > Table Widths.
Tables can have borders, and the cells of a table can have padding, spacing, or both. Cell padding refers 
to the number of pixels between the cell’s content and the cell’s boundaries. Cell spacing refers to the 
number of pixels between adjacent table cells. 
If you don’t explicitly assign values for cell padding and cell spacing, most browsers display the table as if 
cell padding were set to 1 and cell spacing were set to 2. If you want to ensure that browsers display the 
table with no padding or spacing, set cell padding and cell spacing to 0.
For more information about tables, see Chapter 8, “Presenting Content with Tables” in Using 
Dreamweaver.
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8. Click OK. 

A second table with one row and three columns appears below your 
first table.

9. Click to the right of the table to deselect it.

10. Insert a third table by selecting Insert > Table and entering the following 
values in the Insert Table dialog box:

■ Enter 1 in the Rows text box.
■ Enter 1 in the Columns text box.
■ Enter 700 in the Table Width text box.
■ Select Pixels from the Table Width pop-up menu.
■ Enter 0 in the Border Thickness text box.
■ Enter 0 in the Cell Padding text box.
■ Enter 0 in the Cell Spacing text box.

11. Click OK. 

A third table, with one row and one column, appears below your 
second table.

Click to the right of the table to deselect it. Your page should now look 
as follows:
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Set table properties
Now you’ll set precise table properties, using Expanded Tables mode, a 
feature that temporarily adds cell padding and spacing to tables and 
increases the borders of the tables to simplify editing. Specifically, it lets 
you position the insertion point precisely without accidentally selecting the 
wrong table or other table content.

1. Select View > Table Mode > Expanded Table Mode.

N
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You may see the Table selector (indicated by green lines) after you insert a 
table. You can always make the Table selector disappear by clicking 
outside the table. You can also disable the Table selector by selecting 
View > Visual Aids > Table Widths. 

N
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After you finish setting table properties in Expanded Tables mode, always 
return to Standard mode. Expanded Tables mode is not a WYSIWYG 
(what you see is what you get) environment, so some operations, such as 
resizing, do not display the expected results

N
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If you see the Getting Started with Expanded Tables Mode dialog box, 
click OK.
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2. Click once inside the first row of the first table.

3. In the Property inspector (Window > Properties), enter 90 in the Cell 
Height (H) text box and press Enter (Windows) or Return (Macintosh).

4. Click once inside the second row of the first table.

5. In the Property inspector, enter 166 in the Cell Height text box and 
press Enter (Windows) or Return (Macintosh).

6. Click once inside the third row of the first table.

If you cannot see the Cell Height text box, click the expander arrow in the 
lower-right corner of the Property inspector.
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7. In the Property inspector, enter 24 in the Cell Height text box and press 
Enter (Windows) or Return (Macintosh).

You should now have three rows of differing heights in the first table.

Next you’ll set properties for the second table (the table that contains 
three columns).

8. Click once inside the first column of the second table.
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9. In the Property inspector, enter 140 in the Cell Width (W) text box and 
press Enter (Windows) or Return (Macintosh).

10. Click once inside the second column of the second table.

11. In the Property inspector, enter 230 in the Cell Width text box and 
press Enter (Windows) or Return (Macintosh)

12. Set the width of the third column to 330 pixels. 

If you have the Table selector enabled (View > Visual Aids > Table 
Widths), you’ll see all three of the pixel values you just entered above 
the respective table columns.
You won’t enter any height values for the cells in this table because the 
height of those cells will vary depending on the content you add later.

13. Finally, click once inside the last table (the table with one row and one 
column).
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14. In the Property inspector, enter 24 in the Cell Height text box and press 
Enter (Windows) or Return (Macintosh).

Your layout should now look as follows:

15. Click the Exit Expanded Tables Mode link at the top of the Document 
window to return to Standard mode. 

16. Save your page.
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Insert an image placeholder
An image placeholder is a graphic that you use until final artwork is ready 
to be added to a web page. An image placeholder is useful when you lay out 
web pages because it allows you to position an image on a page before you 
actually create the image.

1. In the Document window, click once inside the first row of the first 
table.

2. Select Insert > Image Objects > Image Placeholder.

3. In the Image Placeholder dialog box, do the following:

■ Type banner_graphic in the Name text box.
■ Enter 700 in the Width text box.
■ Enter 90 in the Height text box.
■ Click the color box and select a color from the color picker. For this 

tutorial, select a reddish brown (#993300).
■ Leave the Alternate Text text box blank.

A note on alternative text Alternative text is a textual description of an image on a web page. It is part 
of the HTML code and does not appear on the page. It’s important to provide alternative text for most of 
your images so that people who use screen readers or text-only browsers can receive the information 
provided by the image. In the case of a banner graphic, which merely displays a logo for a website, it is not 
essential to provide alternative text. When you leave the Alternate Text text box blank in the Image 
Placeholder dialog box, Dreamweaver adds an alt="" attribute to the img tag. Later, if you want to add 
alternative text to an image, you can select the image and enter the alternative text in the Property 
inspector. For example, if you later change the logo to include a phone number or address, you would 
want to provide that information as alternative text.
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4. Click OK.

The image placeholder appears inside the first table. The image 
placeholder displays a label and the size attributes of the image that 
you’ll eventually place there.

5. Save your page.
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When viewed in a browser the label and size text for an image placeholder 
do not appear.

About image placeholders An image placeholder is a graphic you use until final artwork is ready to be 
added to a web page; it is not a graphic image that displays in a browser. Before you publish your site, 
replace any image placeholders you’ve added with web-friendly graphic files such as GIFs or JPEGs. 
If you have Macromedia Fireworks, you can create a new graphic from a Dreamweaver image 
placeholder. When you select the image placeholder and click the Create button in the Property 
inspector, Fireworks opens and presents you with a new canvas. The new image dimensions are set to 
the same size as the placeholder image. You can then create and edit the image as you like, and replace 
the placeholder image in Dreamweaver. For information about creating an image in Fireworks from an 
image placeholder, see “Using Fireworks to modify Dreamweaver image placeholders” in Using 
Dreamweaver.
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Add color to the page
Now you’ll add more color to the page by setting colors for some of the 
table cells and for the background of the page.

1. Click once inside the first cell of the three-columned table.

2. Click the <td> tag (cell tag) in the tag selector to select the cell.

3. In the Property inspector (Window > Properties), click once inside the 
Background Color text box. 

The text box is located directly next to the Background Color (Bg) 
color box.

If you cannot see the Background Color text box, click the expander arrow 
in the lower-right corner of the Property inspector.
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4. In the Background Color text box, enter the hexadecimal value 
#993300 and press Enter (Windows) or Return (Macintosh).

The color of the table cell turns to reddish-brown.
5. Click once inside the second cell of the three-columned table.

6. Click the <td> tag (cell tag) in the tag selector to select the cell.

7. In the Property inspector, click once inside the Background Color text 
box, enter the hexadecimal value #F7EEDF, and press Enter (Windows) 
or Return (Macintosh).

The color of the table cell turns to light tan.
8. Repeat steps 5 through 7 to change the color of the third table cell to 

light tan as well.

9. After you have all three cell colors set, click once outside the table to 
deselect it.

Next you’ll change the background color for the entire page by modifying 
page properties. The Page Properties dialog box lets you set a number of 
page properties, including the size and color of page fonts, the colors of 
visited links, page margins, and much more.
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1. Select Modify > Page Properties.

2. In the Appearance category of the Page Properties dialog box, click the 
Background Color color box and select black (#000000) from the color 
picker.

Picking colors In HTML, colors are expressed either as hexadecimal values (for example, #FF0000) or 
as color names (red). A web-safe color is one that appears the same in Netscape Navigator and Microsoft 
Internet Explorer on both Windows and Macintosh systems when using 256-color mode. There are 216 
common colors, and that any hexadecimal value that combines the pairs 00, 33, 66, 99, CC, or FF (RGB 
values 0, 51, 102, 153, 204, and 255, respectively) represents a web-safe color.
You can select colors in Dreamweaver by entering hexadecimal values in the appropriate text boxes, or 
by selecting a color from the color picker. The color picker uses the 216-color web-safe palette; selecting 
a color from this palette displays the color’s hexadecimal value. To use the color picker, click on the color 
box and use the eyedropper to select a color.
You can also use the color picker to match colors. For example, if an image on your page contains a 
certain shade of blue and you want the background color of a table cell to match it, you can select the 
table cell, click on the color box to open the color picker, move the eyedropper over the blue in the image, 
and click the mouse button. The color picker fills the selected area with the closest match possible to the 
color you clicked with the eyedropper. If you select colors by this method, however, the color that the 
color picker chooses for you may not be a web-safe color.
Add color to the page 71



3. Click OK.

Your page background turns to black.

4. Save your work.

Your page layout is now complete. The layout contains a number of tables 
that can hold assets such as images, text, and Flash Video (FLV) files. In the 
next tutorial, Chapter 5, “Tutorial: Adding Content to Pages,” you’ll learn 
how to add assets to the page using the various insertion features that 
Dreamweaver provides.
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CHAPTER 5

Tutorial: Adding Content 
to Pages
This tutorial shows you how to add content to web pages in Macromedia 
Dreamweaver 8. You can add many different kinds of content to web 
pages, including graphics, Macromedia Flash files, Macromedia Flash 
Video files, and text, to name a few. After you’ve added content to your 
pages, you can preview your work in a browser so that you can see what it 
will look like on the web.

In this tutorial, you will complete the following tasks:
Locate your files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Review your task  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Insert images. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Insert and play a Flash file  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

Insert Flash Video  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86

Insert text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89

Create links . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94

Preview your page in a browser  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

Locate your files
In this tutorial, you’ll begin with the table-based page layout (index.html) 
that you created in Chapter 4, “Tutorial: Creating a Table-based Page 
Layout.” If you did not complete that tutorial, you can either complete it 
before proceeding, or you can open the finished version of the tutorial and 
begin with that. 
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The finished version of the tutorial, table_layout.html, is located in the 
completed_files/dreamweaver folder, within the cafe_townsend folder that 
you copied to your hard disk in Chapter 3, “Tutorial: Setting Up Your Site 
and Project Files.”
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If you begin this tutorial with the completed table_layout.html file, instead 
of the index.html file from Chapter 4, “Tutorial: Creating a Table-based 
Page Layout,” some steps and illustrations in the tutorial will not match 
what you see on your screen. 
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Review your task
In this tutorial you’ll add assets to the home page for Cafe Townsend, a 
fictional restaurant. You’ll learn how to add images, a Macromedia Flash 
file, a Macromedia Flash Video file, and text. When you’re finished, the 
page will look like this:

You’ll notice that the text on the page is not yet formatted. That’s because 
you’ll learn how to format the text by using Cascading Style Sheets (CSS) 
in the next tutorial.
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You can find the required assets for this tutorial in the cafe_townsend root 
folder that you copied to your hard drive in Chapter 3, “Tutorial: Setting 
Up Your Site and Project Files.” If you didn’t complete that tutorial, you 
must do so before you proceed. The tutorial lets you know exactly where to 
find the assets as you go along.

Insert images
After you create your page layout, you are ready to add assets to the page. 
You’ll start by adding images. You can use several methods to add images to 
a web page in Dreamweaver. In this section, you’ll add four different 
images to the index page for Cafe Townsend, using various methods.

Replace the image placeholder
1. In Dreamweaver, open the index.html file that you created in Chapter 

4, “Tutorial: Creating a Table-based Page Layout.” 

2. Double-click the image placeholder, banner_graphic, at the top of the 
page.

3. In the Select Image Source dialog box, navigate to the images folder 
inside the cafe_townsend folder that you defined as your site root folder.
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If you did not complete Chapter 4, “Tutorial: Creating a Table-based Page 
Layout,” see “Locate your files” on page 73 for how to proceed. 
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4. Select the banner_graphic.jpg file and click OK.

Dreamweaver replaces the image placeholder with the banner graphic 
for Cafe Townsend.

5. Click once outside the table to deselect the image.

6. Save the page (File > Save).
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Insert an image by using the Insert menu
1. Click once inside the third row of the first table (two rows below the 

banner graphic you just inserted, just above the colored table cells).

2. Select Insert > Image.

3. In the Select Image Source dialog box, navigate to the images folder 
inside the cafe_townsend folder, select the body_main_header.gif file, 
and click OK.

A long colored graphic appears in the table row. This might look more 
like background color for the table cell than a graphic, but if you look 
closely, you’ll see that the graphic has rounded corners. The rounded 
corner effect gives the lower portion of your page an interesting 
appearance after you’ve finished adding all of the assets.

N
O

T
E

If the Image Tag Accessibility Attributes dialog box appears, click OK.
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Insert an image by dragging
1. Click once inside the last row of the last table on the page (just below 

the colored table cells).

2. In the Files panel (Window > Files), locate the body_main_footer.gif 
file (it’s inside the images folder), and drag it to the insertion point in 
the last table.

3. Click once outside the table and save the page (File > Save).

If the Image Tag Accessibility Attributes dialog box appears, click OK.
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Insert an image from the Assets panel
1. Click once inside the center column of the three-columned table (the 

first table cell that is colored light tan).

2. In the Property inspector (Window > Properties), select Center from the 
Horz pop-up menu, and select Top from the Vert pop-up menu. This 
aligns the contents of the table cell in the middle of the cell, and pushes 
the cell’s contents to the top of the cell.

3. Press Enter (Windows) or Return (Macintosh) once to create more 
space.
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If you cannot see the Vert or Horz pop-up menus, click the expander arrow 
in the lower-right corner of the Property inspector.
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4. Click the Assets tab in the Files panel, or select Window > Assets.

Your site assets appear.

5. If Images view isn’t selected, click Images to view your image assets.

6. In the Assets panel, select the street_sign.jpg file. 

Images button

The Assets panel You can use the Assets panel to view and manage assets in your current site. The 
Assets panel displays assets for the site associated with the active document in the Document window.
You must define a local site before you can view assets in the Assets panel. For more information, see 
Chapter 3, “Tutorial: Setting Up Your Site and Project Files,” or Using Dreamweaver.
The Assets panel provides two views: 
The Site list shows all of the assets in your site, including colors and URLs that are used in any document 
in your site.
The Favorites list shows only the assets you’ve explicitly chosen. To add an asset to the Favorites list, 
select the asset in the Site list, and then select Add to Favorites from the Options menu in the upper-right 
corner of the Files panel.
When you click an asset in the Assets panel, the preview area displays the asset you selected. To change 
the size of the preview area, drag the line that separates the preview area from the asset column 
headings.
For more information, see “Working with assets” in Using Dreamweaver.
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7. Do one of the following:

■ Drag the street_sign.jpg file to the insertion point in the center 
table cell.

■ Click Insert at the bottom of the Assets panel.

The street_sign.jpg graphic appears on the page.

8. Click once outside the table to deselect the image.

9. Save the page.
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If the Image Tag Accessibility Attributes dialog box appears, click OK.
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Insert and play a Flash file
Next, you’ll insert a Flash file that plays a photographic slide show of Cafe 
Townsend’s featured food items. The Flash file you’ll insert is a flexible 
messaging area—or FMA—file. An FMA is a common type of Flash 
application that displays an informational message to the audience. The 
message can change based on the needs of the business. For example, if 
Cafe Townsend is holding a special event, the FMA could easily change 
(without affecting the rest of the web page) to display information about 
the event, instead of featured food items.

To insert the Flash FMA file, you need to insert HTML code that embeds 
the file in the Dreamweaver page. The easiest way to do this is to insert the 
SWF file (the exported Flash Movie file) into the page. When you insert a 
SWF file in Dreamweaver, Dreamweaver writes all of the necessary Flash 
HTML code for you.

1. With the index.html page open in the Dreamweaver Document 
window, click once inside the second row of the first table. 

This is the table row immediately below the banner graphic you 
inserted in the previous section.

2. In the Property inspector (Window > Properties), select Center from the 
Horz pop-up menu, and select Middle from the Vert pop-up menu. 

This places the contents of the table cell in the middle of the cell.

If you cannot see the Vert or Horz pop-up menus, click the expander arrow 
in the lower-right corner of the Property inspector.
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3. Select Insert > Media > Flash.

In the Select File dialog box, browse to the flash_fma.swf file (it’s in the 
cafe_townsend root folder of your site), select the file, and click OK.
If the Object Tag Accessibility Attributes dialog box appears, click OK.

A Flash content placeholder, rather than a scene from the FMA itself, 
appears in the Document window. This is because the HTML code is 
“pointing” to the SWF file flash_fma.swf. When a user loads the 
index.html page, the browser plays the SWF file.

4. The Flash content placeholder should remain selected after you insert 
the SWF file, as long as you don’t click anywhere else on the page. 

If it’s not selected, select the Flash content placeholder by clicking it.

About Flash files When you build assets in Macromedia Flash, you work in FLA files, the default file 
type for the Flash application. FLA files are designated by a .fla extension. For example, if you are working 
on an animated logo for a website, the filename of the Flash file might be animated_logo.fla.
When you’ve finished working on a FLA file in Flash, you must export the file to a format that can be 
played on the web in Flash Player. When you export FLA files in Flash, they are converted to SWF files 
and designated by a .swf extension. SWF files (not FLA files) play Flash content in a web browser and are 
the file type you must insert into a web page that you are building with Dreamweaver.
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5. In the Property inspector (Window > Properties), click Play.

Dreamweaver plays the Flash file in the Document window, showing 
you what site visitors will see when they view the page in a browser.

6. In the Property inspector, click Stop to stop playing the Flash file.

7. Save the page.

If you cannot see the Flash Play button, click the expander arrow in the 
lower-right corner of the Property inspector.
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Insert Flash Video
Next you’ll insert a Flash Video file, using the asset provided.

1. With the index.html page open in the Dreamweaver Document 
window, click once above the graphic that you placed in the center 
column of the three-columned table. 

In the previous section, you created some space before you inserted the 
graphic—this is where you should click.

2. Select Insert > Media > Flash Video.

3. In the Insert Flash Video dialog box, select Progressive Download Video 
from the Video type pop-up menu.

About Flash Video The Insert Flash Video command in Dreamweaver lets you insert Flash Video 
content in your web pages without using the Flash authoring tool. The command inserts a Flash 
component, which displays the Flash Video content you select, as well as a set of playback controls, 
when viewed in a browser.
The Insert Flash Video command gives you the following options for delivering video content to your site 
visitors:
Progressive Download Video downloads the Flash Video (FLV) file to the site visitor’s hard disk and 
then plays it. Unlike traditional “download and play” methods of video delivery, however, progressive 
download allows the video file to start playing before the download is complete.
Streaming Video streams the Flash Video content and plays it on a web page immediately. To enable 
streaming video on your web pages, however, you must have access to Macromedia Flash 
Communication Server, the only server that can stream Flash Video content.
For more information about using Flash Video, see “Inserting Flash Video content” in Using 
Dreamweaver.
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4. In the URL text box, specify a relative path to the 
cafe_townsend_home.flv file by clicking Browse, navigating to the 
cafe_townsend_home.flv file (located in cafe_townsend root folder of 
your site), and selecting the FLV file.

5. Select Halo Skin 2 from the Skin pop-up menu. 

A preview of the selected skin appears below the Skin pop-up menu. 
The Skin option specifies the look and feel for the Flash Video 
component that will contain the Flash Video content. 
For more information on how to select different skins for Flash Video 
components, see www.macromedia.com/go/flv_tutorial.
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6. In the Width and Height text boxes, do the following:

■ In the Width text box, type 180.
■ In the Height text box, type 135 and press Enter (Windows) or 

Return (Macintosh).

The value in the Width and Height text boxes specifies the width and 
height in pixels of the FLV file. You can adjust these values arbitrarily to 
change the size of the Flash Video on your web page. When you 
increase the dimensions of a video, the picture quality of the video 
usually decreases.

7. Leave the default selections for the remaining options:

Constrain maintains the same aspect ratio between the width and 
height of the Flash Video component. This option is selected by 
default.
Auto play specifies whether to play the video when the web page is 
opened. This option is deselected by default.
Auto rewind specifies whether the playback control returns to starting 
position after the video finishes playing. This option is deselected by 
default.

T
IP You can click Detect 

Size to determine 
the exact width and 
height of the FLV 
file. Sometimes, 
however, 
Dreamweaver 
cannot determine 
the dimensions of 
the FLV file. In such 
cases, you must 
manually enter the 
width and height 
values.
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“Total with skin” is the width and height of the FLV file plus the width and 
height of the selected skin.
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8. Click OK to close the dialog box and add the Flash Video content to 
your web page.

The Insert Flash Video command generates a video player SWF file 
and a skin SWF file that are used to display your Flash Video content 
on a web page. (You may need to click the Refresh button in the Files 
panel to see the new files.) These files are stored in the same directory 
as the HTML file to which you’re adding Flash Video content (in this 
case, the cafe_townsend root folder). When you upload the HTML 
page containing the Flash Video content, Dreamweaver uploads these 
files as dependent files (as long as you click Yes in the Put Dependent 
Files dialog box).

9. Save the page.

Insert text
Now you’ll add some text to the page. You can type text directly in the 
Dreamweaver Document window, or you can copy and paste text from 
other sources (such as Microsoft Word or plain text files). Later, you’ll use 
Cascading Style Sheets (CSS) to format the text.
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Insert body text
1. In the Files panel, locate the sample_text.txt file (in the cafe_townsend 

root folder) and double-click the file’s icon to open it in Dreamweaver.

You’ll notice that this window is in Code view, and cannot be switched 
to Design view (the view you’ve been working in until now) because 
the file is not an HTML file.

2. In the sample_text.txt Document window, press Control+A (Windows) 
or Command+A (Macintosh) to select all of the text, and then select 
Edit > Copy to copy the text.

3. Close the sample_text.txt file by clicking the X in the top-right corner 
of the document.

4. In the index.html Document window, click once inside the third table 
cell of the three-columned table (the cell to the right of the column that 
contains the graphic and the Flash video).

5. Select Edit > Paste.

The text from the text file appears in the selected table cell.
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Depending on your monitor resolution, the three-columned table 
widens to accommodate the text. Don’t worry about how this looks 
right now. In the next tutorial, you’ll learn how to use CSS to format 
the text so that everything fits in the table appropriately.

6. Make sure the insertion point is still inside the table cell where you just 
pasted the text. If it isn’t, click inside the table cell.

7. In the Property inspector (Window > Properties), select Top from the 
Vert pop-up menu. This aligns the text you just pasted to the top of the 
table cell. If you cannot see the Vert pop-up menu, click the expander 
arrow in the lower-right corner of the Property inspector.

8. Save the page.
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Insert text for a navigation bar
Next you’ll insert text for a navigation bar. However, the text won’t look 
like a navigation bar until you format it in the next tutorial.

1. Click once in the first column of the three-columned table (the column 
that is colored reddish-brown).

2. Type the word Cuisine.

3. Press the Spacebar and type Chef Ipsum.
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4. Repeat the previous step until you’ve entered the following words with 
a space between each one: Articles, Special Events, Location, Menu, 
Contact Us.

Do not press Enter (Windows) or Return (Macintosh) when you type. 
Use only the Spacebar to separate words, and let the words wrap 
naturally. The fixed width of the table cell determines how many words 
fit on a line.

5. With the insertion point still in the first cell of the three-columned 
table, click the <td> tag in the tag selector.
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6. In the Property inspector (Window > Properties), select Top from the 
Vert pop-up menu. 

This aligns the text you just typed to the top of the table cell.

7. Save your page.

Create links
A link is a reference, inserted in a web page, that points to another 
document. You can turn almost any kind of asset into a link, but the most 
common kind of link is a text link.

You can create links at any stage of the site-creation process. In this section, 
you’ll create links for the navigation bar, even though you haven’t 
formatted the text into the form of a navigation bar yet.

The cafe_townsend site root folder contains a finished HTML page that 
you can link to (a menu page for Cafe Townsend). You’ll use this page for 
all of the links in the navigation, even though you would have distinct 
pages for each of these links if you were building a real site.
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If you cannot see the Vert pop-up menu, click the expander arrow in the 
lower-right corner of the Property inspector.
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1. With the index.html page open in the Document window, select the 
word Cuisine that you typed in the first cell of the three-columned table. 
Be careful to select the word Cuisine only, and not the space after it.

2. In the Property inspector (Window > Properties), click the folder icon 
next to the Link text box.

3. In the Select File dialog box, browse to the menu.html file (which is in 
the same folder as the index.html file), and click OK (Windows) or 
Choose (Macintosh).

4. Click once on the page to deselect the word Cuisine. The Cuisine text 
is underlined and blue, indicating that it’s now a link.
Create links 95



5. Repeat the previous steps to link each word or set of words that you 
typed for the navigation. You want to create six more links: one for Chef 
Ipsum, Articles, Special Events, Location, Menu, and Contact Us.

Link each word or set of words to the menu.html page, and be careful 
to avoid the space before and after the words or set of words when you 
create your links. This is only a set of dummy links; in a real-world site, 
you would link each word in the navigation to its own distinct page.

6. Save your page.

Preview your page in a browser
The Design view gives you a rough idea of what your page will look like on 
the web, but you must preview the page in a browser to see the definitive 
end result. Though browsers in general produce the same results, each 
browser version can display HTML pages somewhat differently. 
Dreamweaver attempts to produce HTML that will look as similar as 
possible from one browser to another; but sometimes differences can’t be 
avoided. Thus, previewing your work in a browser is the only way for you 
to see what your site visitors will see after you publish your pages.
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Links don’t work when you click them in the Document window in 
Dreamweaver; links work only in a browser. To make sure your links work 
correctly, preview your page in a browser. For instructions about how to 
do this, continue to “Preview your page in a browser” on page 96.
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1. Make sure the index.html file is open in the Document window.

2. Press the F12 key (Windows) or Option+F12 (Macintosh).

Your primary browser starts if it’s not running already and displays the 
index page.

3. (Optional) Switch back to Dreamweaver to make any necessary 
changes. 

Then save your work and press the F12 key again to make sure your 
changes took effect.

Dreamweaver automatically detects your primary browser and uses that 
for previewing. If the preview doesn’t appear, or if it doesn’t appear in the 
browser you expect, switch back to Dreamweaver (if necessary) and 
select File > Preview in Browser > Edit Browser List. When the Preview in 
Browser Preferences dialog box appears, add the correct browser to the 
list. For more information, click the Help button in the Preferences dialog 
box.
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You now have a web page full of content. The next step is to format some 
of the content to make it more appealing. In the next tutorial, you’ll learn 
how to use CSS to format the text that you added.
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CHAPTER 6

Tutorial: Formatting 
Your Page with CSS
This tutorial shows you how to format text on your page using Cascading 
Style Sheets (CSS) in Dreamweaver. CSS provides you with greater control 
over the appearance of your page by letting you format and position text in 
ways that HTML cannot. 

In this tutorial, you will complete the following tasks:
Locate your files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Review your task  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .101

Learn about CSS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Create a new style sheet. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104

Explore the CSS Styles panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109

Attach a style sheet . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Create a new CSS rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

Apply a class style to text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .113

Format the navigation bar text  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .114

(Optional) Center the contents of the page . . . . . . . . . . . . . . . . . . 125
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Locate your files
In this tutorial, you’ll begin with the Cafe Townsend index page to which 
you added content in Chapter 5, “Tutorial: Adding Content to Pages.” If 
you did not complete that tutorial, you can either complete it before 
proceeding, or you can open the finished version of the tutorial and begin 
with that. The finished version of the tutorial, add_content.html, is located 
in the completed_files/dreamweaver folder, within the cafe_townsend 
folder that you copied to your hard drive in Chapter 3, “Tutorial: Setting 
Up Your Site and Project Files.”
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If you begin this tutorial with the completed add_content.html file, instead 
of the index.html file from Chapter 5, “Tutorial: Adding Content to Pages,” 
certain steps and illustrations in the tutorial will not match what you see on 
your screen.
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Review your task
In this tutorial, you’ll use Cascading Style Sheets (CSS) to format the text 
on the home page for Cafe Townsend, a fictional restaurant. You’ll create 
different kinds of CSS rules to format the body text. You’ll also format the 
link text on the left side of the page to create a navigation bar. When you’re 
finished, your page will look like the following example:
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For more information about CSS, proceed to the next section. To start 
creating CSS right away, proceed to “Create a new style sheet” 
on page 104.

Learn about CSS
Cascading Style Sheets (CSS) are a collection of formatting rules that 
control the appearance of content on a web page. When you use CSS to 
format a page, you separate content from presentation. The content of 
your page—the HTML code—resides in the HTML file itself, while the 
CSS rules that define the presentation of the code reside in another file (an 
external style sheet) or in another part of the HTML document (usually 
the <head> section). With CSS you have flexibility and control over the 
exact appearance of your page, from precise positioning of layout to 
specific fonts and styles.

CSS lets you control many properties that cannot be controlled with 
HTML alone. For example, you can specify different font sizes and units 
(pixels, points, and so on) for selected text. By using CSS to set font sizes in 
pixels, you can also ensure a more consistent treatment of your page layout 
and appearance in multiple browsers.

A CSS formatting rule consists of two parts—the selector and the 
declaration. The selector is a term (such as P, H1, a class name, or an id) 
that identifies the formatted element, and the declaration defines what the 
style elements are. In the following example, H1 is the selector, and 
everything that falls between the braces ({}) is the declaration:
H1 { 
font-size: 16 pixels; 
font-family: Helvetica; 
font-weight: bold; 
}

The declaration consists of two parts, the property (such as font-family), 
and the value (such as Helvetica). The preceding example creates a style 
for H1 tags: The text for all H1 tags linked to this style is 16 pixels in size, 
and uses Helvetica font and bold.
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The term cascading refers to your ability to apply multiple styles to the 
same element or web page. For example, you can create one CSS rule to 
apply color and another rule to apply margins, and apply them both to the 
same text on a page. The defined styles “cascade” to the elements on your 
web page, ultimately creating the design you want.

A major advantage of CSS is that it can be updated easily; when you 
update a CSS rule in one place, the formatting of all of the documents that 
use the defined style are automatically updated to the new style.

You can define the following types of rules in Dreamweaver:

■ Custom CSS rules, also called class styles, let you apply style attributes 
to any range or block of text. All class styles begin with a period (.). For 
example, you could create a class style called .red, set the color 
property of the rule to red, and apply the style to a portion of already-
styled paragraph text.

■ HTML tag rules redefine the formatting for a particular tag, such as p 
or h1. When you create or change a CSS rule for the h1 tag, all text 
formatted with the h1 tag is immediately updated.

■ CSS selector rules (advanced styles) redefine the formatting for a 
particular combination of elements, or for other selector forms as 
allowed by CSS (for example, the selector td h2 applies whenever an 
h2 header appears inside a table cell.) Advanced styles can also redefine 
the formatting for tags that contain a specific id attribute (for example, 
the styles defined by #myStyle apply to all tags that contain the 
attribute-value pair id="myStyle").

For more information, see “About text formatting in Dreamweaver” in 
Using Dreamweaver.
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Create a new style sheet
First, you’ll create an external style sheet that contains a CSS rule that 
defines a style for paragraph text. When you create styles in an external 
style sheet, you can control the appearance of multiple web pages from a 
central location, instead of setting styles on each individual web page.

1. Select File > New.

2. In the New Document dialog box, select Basic page in the Category 
column, select CSS in the Basic Page column, and click Create.

A blank style sheet appears in the Document window. The Design view 
and Code view buttons are disabled. CSS style sheets are text-only 
files—their contents are not meant to be viewed in a browser.
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3. Save the page (File > Save) as cafe_townsend.css. 

When you save the style sheet, make sure you save it in the 
cafe_townsend folder (the root folder of your website).

4. Type the following code in the style sheet:
p{
font-family: Verdana, sans-serif;
font-size: 11px;
color: #000000;
line-height: 18px;
padding: 3px;
}

As you type, Dreamweaver uses code hints to suggest options for 
completing your entry. Press Enter (Windows) or Return (Macintosh) 
when you see the code you want to let Dreamweaver finish the typing 
for you.

More about CSS rules
CSS rules can reside in the following locations:
External CSS style sheets are collections of CSS rules stored in a separate, external .css file (not an 
HTML file). The .css file is linked to one or more pages in a website by using a link in the head section of a 
document. 
Internal (or embedded) CSS style sheets are collections of CSS rules that are included in a style tag in 
the head portion of an HTML document. For example, the following example defines the font size for all 
text in the document formatted with the paragraph tag:
<head>
<style> 
   p{
   font-size:80px
   }
</style>
</head>

Inline styles are defined within specific instances of tags throughout an HTML document. For example, 
<p style=“font-size: 9px”> defines the font size for only the paragraph formatted with the tag that 
contains the inline style.
Dreamweaver renders most style attributes that you apply and displays them in the Document window. 
You can also preview the document in a browser window to see styles applied. Some CSS style attributes 
render differently in Microsoft Internet Explorer, Netscape Navigator, Opera, and Apple Safari.
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Don’t forget to include a semicolon at the end of each line, after the 
property values.
When you’re finished, the code should look like following example:

5. Save the style sheet.

Next you’ll attach the style sheet to the index.html page.

Attach a style sheet
When you attach a style sheet to a web page, the rules defined in the style 
sheet are applied to the corresponding elements on the page. For example, 
when you attach the cafe_townsend.css style sheet to the index.html page, 
all paragraph text (text formatted with the <p> tag in the HTML code) is 
formatted according to the CSS rule you defined.

T
IP For more information 

about any CSS 
property, check the 
O’Reilly reference 
guide included with 
Dreamweaver. To 
display the guide, 
select Help > 
Reference and 
select O’Reilly CSS 
Reference from 
the pop-up menu in 
the Reference panel.
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1. In the Document window, open the Cafe Townsend index.html file. 
(You can click its tab if it’s already open.)

2. Select the text of the first paragraph that you pasted into the page in 
Chapter 5, “Tutorial: Adding Content to Pages”.

3. Look in the Property inspector and make sure that the paragraph is 
formatted with the paragraph tag. 

If the Format pop-up menu in the Property inspector says “Paragraph,” 
the paragraph is formatted with the paragraph tag. If the Format pop-
up menu in the Property inspector says “None,” or something else, 
select Paragraph to format the paragraph.

4. Repeat step 3 for the second paragraph. 
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5. In the CSS Styles panel (Window > CSS Styles), click the Attach Style 
Sheet button in the lower-right corner of the panel.

6. In the Attach External Style Sheet dialog box, click Browse and browse 
to the cafe_townsend.css file that you created in the previous section.

7. Click OK.

The text in the Document window is formatted according to the CSS 
rule in the external style sheet.
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Explore the CSS Styles panel
The CSS Styles panel lets you track the CSS rules and properties that affect 
a currently selected page element, or the rules and properties that affect an 
entire document. It also lets you modify CSS properties without opening 
an external style sheet.

1. Make sure the index.html page is open in the Document window.

2. In the CSS Styles panel (Window > CSS Styles), click All at the top of 
the panel and examine your CSS rules. 

In All mode, the CSS panel shows you all of the CSS rules that apply to 
the current document, whether those rules are in an external style 
sheet, or in the document itself. You should see two main categories in 
the All Rules pane: a <style> tag category and a cafe_townsend.css 
category. 

3. Click plus (+) to expand the <style> tag category if it isn’t already 
expanded.

4. Click the body rule.

The background-color property with a value of #000000 appears in 
the Properties pane below. 

You may need to collapse another panel, such as the Files panel, to see 
the full length of the CSS Styles panel. You can also alter the length of the 
CSS Styles panel by dragging the borders between the panes.
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You set the background color for the page in Chapter 4, “Tutorial: 
Creating a Table-based Page Layout” by using the Modify Page 
Properties dialog box. When you set page properties in this manner, 
Dreamweaver writes a CSS style that is internal to the document.

5. Click plus (+) to expand the cafe_townsend.css category.

6. Click the p rule.

All of the properties and values that you defined in the external style 
sheet for the p rule appear in the Properties pane below.

7. In the Document window, click once anywhere in either of the two 
paragraphs that you just formatted.

8. In the CSS Styles panel, click Current at the top of the panel and 
examine your CSS styles. In Current mode, the CSS panel shows you a 
summary of properties for the current selection. The properties shown 
correspond to the properties for the p rule in the external style sheet.

In the next section, you’ll use the CSS Styles panel to create a new rule. 
Using the CSS Styles panel to create a new rule is much easier than typing 
the rule out by hand, as you did when you initially created the external 
style sheet.
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Create a new CSS rule
In this section you’ll use the CSS Styles panel to create a custom CSS rule, 
or class style. Class styles let you set style attributes for any range or block 
of text, and can be applied to any HTML tag. For more information on 
different types of CSS rules, see “Learn about CSS” on page 102.

1. In the CSS Styles panel, click New CSS Rule in the lower-right corner 
of the panel.

2. In the New CSS Rule dialog box, select Class from the Selector Type 
options. It should be selected by default.

3. Enter .bold in the Name text box.

Make sure that you type the period (.) before the word “bold.” All class 
styles must start with a period
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4. Select cafe_townsend.css from the Define In pop-up menu. It should be 
selected by default.

5. Click OK.

The CSS Rule Definition dialog box appears, indicating that you are 
creating a class style called .bold in the cafe_townsend.css file.

6. In the CSS Rule Definition dialog box, do the following:

■ In the Font text box, enter Verdana, sans-serif.
■ In the Size text box, enter 11 and select pixels from the pop-up 

menu immediately to the right.
■ In the Line Height text box, enter 18 and select pixels from the 

pop-up menu immediately to the right.
■ Select bold from the Weight pop-up menu.
■ Enter #990000 in the Color text box
.
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7. Click OK.

8. Click All at the top of the CSS Styles panel.

9. Click the plus (+) button next to the cafe_townsend.css category if the 
category isn’t already expanded.

You’ll see that Dreamweaver added the .bold class style to the list of 
rules defined in the external style sheet. If you click the .bold rule in the 
All Rules pane, the rule’s properties appear in the Properties pane. The 
new rule also appears in the Style pop-up menu in the Property 
inspector.

Apply a class style to text
Now that you’ve created a class rule, you’ll apply it to some paragraph text.

1. In the Document window, select the first four words of text in the first 
paragraph: Cafe Townsend’s visionary chef.

2. In the Property inspector (Window > Properties), select bold from the 
Styles pop-up menu.

The bold class style is applied to your text.

T
IP For more information 

about any CSS 
property, check the 
O’Reilly reference 
guide included with 
Dreamweaver. To 
display the guide, 
select Help > 
Reference and 
select O’Reilly CSS 
Reference from 
the pop-up menu in 
the Reference panel.
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3. Repeat step 2 to apply the bold class style to the first four words of the 
second paragraph.

4. Save your page.

Format the navigation bar text
Next you’ll use CSS to apply styles to the link text for the navigation bar. 
Many web pages use images of colored rectangles with text inside them to 
create a navigation bar, but with CSS, all you need is linked text and some 
formatting. By using the display: block property and setting a width to 
the block, you can effectively create the rectangles without the use of 
separate images.
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Create a new rule for the navigation
1. Open the cafe_townsend.css file if it isn’t already open, or click on its 

tab to see it.

2. Define a new rule by typing the following code in the file, after the .bold 
class style:
.navigation {
}

This is an empty rule.
The code in the file should look something like the following example:

3. Save the cafe_townsend.css file.

Next you’ll use the CSS Styles panel to add properties to the rule.
4. Open the index.html file if it isn’t already open.
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5. In the CSS Styles panel, make sure All mode is selected, select the new 
.navigation rule and click Edit Style in the lower-right corner of the 
panel.

6. In the CSS Rule Definition dialog box, do the following:

■ Enter Verdana, sans-serif in the Font text box.
■ Select 16 from the Size pop-up menu, and select pixels from the 

pop-up menu immediately to the right of the Size pop-up menu.
■ Select Normal from the Style pop-up menu.
■ Select None from the Decoration list.
■ Select Bold from the Weight pop-up menu.
■ Enter #FFFFFF in the Color text box
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7. Click OK.

Now you’ll use the CSS Styles panel to add a few more properties to the 
.navigation rule.

T
IP For more information 

about any CSS 
property, check the 
O’Reilly reference 
guide included with 
Dreamweaver. To 
display the guide, 
select Help > 
Reference and 
select O’Reilly CSS 
Reference from 
the pop-up menu in 
the Reference panel.
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8. In the CSS Styles panel, make sure the .navigation rule is selected and 
click Show List View.

List view reorganizes the Properties pane to display an alphabetical list 
of all available properties (in contrast to Set Properties view, the 
previous view, which shows only those properties you’ve already set).

9. Click in the column to the right of the background-color property.

To see the full wording of a property, hold the mouse over the property.
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10. Enter #993300 as the hexadecimal value and press Enter (Windows) or 
Return (Macintosh).

11. Locate the display property (you might need to scroll down), click 
once in the column to the right, and select block from the pop-up menu.

12. Locate the padding property, click once in the column to the right, 
enter 8px as the value, and press Enter (Windows) or Return 
(Macintosh).

13. Locate the width property, click once in the column to the right, enter 
140 in the first text box, select pixels from the pop-up menu, and press 
Enter (Windows) or Return (Macintosh).

T
IP To see how your 

work affects the 
external style sheet, 
keep the 
cafe_townsend.css 
file open in the 
Document window 
while you work. 
When you make a 
selection in the CSS 
Styles panel, you’ll 
see that 
Dreamweaver writes 
the CSS code in the 
style sheet at the 
same time.
Format the navigation bar text 119



14. Click Show Set Properties so that only your set properties appear in the 
Properties pane.

15. Click on the cafe_townsend.css file to display it. You’ll see that 
Dreamweaver has added all of the properties you specified to the file.

16. Save the cafe_townsend.css file and close it.

You’ve now created a rule to format the navigation bar text. Next you’ll 
apply the rule to the selected links.
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Apply the rule
1. With the index.html page open in the Document window, click the 

word Cuisine so that the insertion point is somewhere in the word.

2. In the tag selector, click the rightmost <a> tag. 

This action selects all of the text for the specified <a> tag, or link.

3. In the Property inspector (Window > Properties), select navigation from 
the Style pop-up menu.

In the Document window, the appearance of the Cuisine text changes 
entirely. The text is now formatted as a navigation bar button, 
according to the properties of the .navigation rule that you defined in 
the previous section.
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4. Repeat step 1 through 3 for each of the individual links in the navigation 
bar. 

You must assign a navigation class style to each <a> tag or link, so it’s 
important that you use the tag selector to select each link individually, 
and then assign the class styles one at a time.

If you’re having trouble formatting the link text, make sure that a space 
(not a return) is between each linked word or words. Also make sure 
that the space between two links is not itself linked. If it is, carefully 
select the linked space, clear the Link text box in the Property 
inspector, and press Enter (Windows) or Return (Macintosh).

5. When you’ve finished formatting all of the words for the navigation bar, 
save the page, and then preview your work in a browser (File > Preview 
in Browser). 

You can click on the links to make sure they work.
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Add a rollover effect
Now you’ll add a rollover effect so that the background color of the 
navigation bar blocks change whenever the mouse pointer passes over one 
of the links. To add a rollover effect, add a new rule that contains the 
:hover pseudo-class.

1. Open the cafe_townsend.css file.

2. Select the entire .navigation rule.

3. Copy the text (Edit > Copy).

About the :hover pseudo-class A pseudo-class is a means of affecting certain elements in an HTML 
document, based not on the HTML code of the document itself, but on other external conditions applied 
by the web browser. Pseudo-classes can be dynamic, in the sense that an element on the page may 
acquire or lose the pseudo-class while a user interacts with the document.
The :hover pseudo-class affects a change in a formatted page element when the user holds the mouse 
over the element. For example, when the :hover pseudo-class is added to the .navigation class style 
(.navigation:hover) to create a new rule, all text elements that the .navigation rule formats change 
according to the .navigation:hover rule’s properties.
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4. Click once at the end of the rule and press Enter (Windows) or Return 
(Macintosh) a few times to create some space.

5. Paste (Edit > Paste) the copied text in the space you just created.

6. Add the :hover pseudo-class to the pasted .navigation selector, as 
follows:
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7. In the new .navigation:hover rule, replace the current background-color 
(#993300) with #D03D03.

8. Save the file and close it.

9. Open the index.html file in the Document window and preview the 
page in a browser (File > Preview in Browser).

When you hold the mouse over any of the links, you can see the new 
rollover effect.

(Optional) Center the contents of 
the page
Lastly, you’ll use the tag selector to select all of the HTML in the 
document, and center the document’s contents.

Some browsers (such as Internet Explorer 6), center the page’s text within 
the context of the table cells when you use the method described in this 
section. If you don’t like how this looks when you preview the page in the 
browser, you might want to skip this section, and leave the contents of 
your page aligned left.
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1. With the index.html page open in the Document window, click the 
<body> tag in the tag selector.

Clicking the <body> tag selects everything between the open and close 
<body> tags in the Document window. To see the selection, click Code 
view at the top of the Document window.
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2. In the Property inspector (Window > Properties), click the Align Center 
button.

Dreamweaver inserts CSS <div> tags that center the body content of 
the page. In Design view, a dotted line borders the area that the <div> 
tags center.

3. Save the page.

Your page is now finished. The last task of building your website is to 
publish the page. To publish the page, you must define a folder on a 
remote site and upload your files to that folder. For instructions, continue 
to the next tutorial.
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CHAPTER 7

Tutorial: Publishing 
Your Site
This tutorial shows you how to set up a remote site with Macromedia 
Dreamweaver 8 and publish your web pages. A remote site is usually a 
place on a remote computer, running a web server, that holds copies of 
your local files. Users access the remote site running on the web server 
when they view your pages in a browser.

In this tutorial, you will complete the following tasks:
Learn about remote sites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Define a remote folder  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 130

Upload your local files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Troubleshoot the remote folder setup (optional). . . . . . . . . . . . . . 134

Learn about remote sites
After you create a website, the next step is to publish it by uploading the 
files to a remote folder. A remote folder is where you store your files for 
testing, production, collaboration, and publication (depending on your 
environment). Dreamweaver refers to this folder as your remote site.

Before you can proceed, you must have access to a remote web server—
such as your ISP’s server, a server owned by the client you’re working for, an 
intranet server within your company, or an Internet Information Services 
(IIS) server on a Windows computer. If you don’t already have access to 
such a server, contact your ISP, your client, or your system administrator.

Alternatively, you can run a web server such as IIS (Windows) or Apache 
(Macintosh) on your local computer. For more information about setting 
up a web server on your local computer, see Appendix B, “Installing a Web 
Server,” on page 231.
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The procedures described in this tutorial work best if your remote root 
folder is empty. If your remote site already contains files, create an empty 
folder in your remote site (on the server), and use that empty folder as your 
remote root folder.

You also need to have a local site defined before you proceed. For more 
information, see “Tutorial: Setting Up Your Site and Project Files” 
on page 49.

For more information about Dreamweaver sites, see Chapter 2, “Setting 
Up a Dreamweaver Site” in Using Dreamweaver.

Define a remote folder
Now you’ll set up a remote folder so that you can publish your web pages. 
The remote folder often has the same name as the local folder because your 
remote site is usually an exact duplicate of your local site. That is, the files 
and subfolders that you post to your remote folder are copies of the files 
and subfolders that you create locally.

1. On your remote server, create an empty folder inside the web root folder 
for the server. 

Name the new empty folder cafe_townsend (the same name as your 
local root folder).
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2. In Dreamweaver, select Site > Manage Sites.

3. In the Manage Sites dialog box, select the Cafe Townsend site. 

If you did not define the Cafe Townsend site, create a local folder for 
the site before you proceed. For more information, see “Tutorial: 
Setting Up Your Site and Project Files” on page 49.

4. Click Edit.

5. In the Site Definition dialog box, click the Advanced tab if the 
Advanced settings aren’t showing.

6. Select Remote Info from the Category list on the left.

Creating a remote folder with Dreamweaver If Dreamweaver is your only means of access to the 
remote server, you won’t be able to create an empty folder on the remote server until you’ve completed 
the remote settings in Dreamweaver and established a connection. If that’s the case, you can either 
define your host directory as your remote folder, or you can create a remote folder after you’ve 
established a connection with the server. In either case, continue with the instructions in this tutorial until 
you’re connected to a remote server. After you’ve established a connection, you can use the 
Dreamweaver Files panel to create a new remote folder.
When you establish a connection with a remote server, the Files panel displays all of the files on the 
remote server in Remote view (just as it displays all of the local files on your computer in Local view). To 
display Remote view, select Remote view from the pop-up menu at the top of the Files panel, or click 
Expand/Collapse in the Files panel toolbar. When you click Expand/Collapse, the Files panel displays 
both Local view and Remote view simultaneously.
To add an empty folder in Remote view, first display Remote view using one of the methods described 
earlier. (If you don’t see your connection initially, click Refresh in the Files panel toolbar.) After you see 
that you’re connected to your web server, right-click (Windows) or Control-click (Macintosh) in Remote 
view and select New Folder.

For more information, see Chapter 4, “Managing Your Files” in Using Dreamweaver.

Expand/Collapse buttonRefresh button
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7. Select an Access option.

The most common methods for connecting to a server on the Internet 
are FTP and SFTP; the most common method for connecting to a 
server on your intranet, or to your local computer if you’re using that as 
a web server, is Local/Network. If you aren’t sure what to select, ask the 
server’s system administrator.
For more information, click Help in the dialog box.

8. If you selected FTP, enter the following options:

■ Enter the host name of the server (such as ftp.macromedia.com).
■ In the Host directory text box, enter the path on the server from the 

FTP root folder to the remote site’s root folder (cafe_townsend). If 
you’re not sure of the path, consult your system administrator.
In many cases, this text box should be left blank.

■ Enter your user name and password in the appropriate text boxes.
■ If your server supports SFTP, select the Use Secure FTP (SFTP) 

option.
■ Click Test to test your connection.
■ If the connection is unsuccessful, consult your system 

administrator.
For more information, click Help in the dialog box.

9. If you selected Local/Network, click the folder icon next to the text box 
and browse to the remote site’s root folder. 

For more information, click Help in the dialog box.
10. Click OK.

Dreamweaver creates a connection to the remote folder.
11. Click Done to close the Manage Sites dialog box.
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Upload your local files
After you set up your local and remote folders, you can upload your files 
from your local folder to the web server. To make your pages publicly 
accessible, you must upload them even if the web server is running on your 
local computer.

1. In the Files panel (Window > Files), select the site’s local root folder 
(cafe_townsend).

2. Click the blue Put Files arrow icon in the Files panel toolbar
.

3. When Dreamweaver asks if you want to put the entire site, click OK.

Dreamweaver copies all of the files to the remote folder you defined in 
“Define a remote folder” on page 130. This operation may take some 
time, as Dreamweaver must upload all of the files in the site.

4. Open your remote site in a browser to make sure all of the files uploaded 
correctly.
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Troubleshoot the remote folder 
setup (optional)
A web server can be configured in many ways. The following list provides 
information about some common issues you may encounter in setting up a 
remote folder, and how to resolve them:

■ The Dreamweaver FTP implementation may not work properly with 
certain proxy servers, multilevel firewalls, and other forms of indirect 
server access. 
If you encounter problems with FTP access, ask your local system 
administrator for help.

■ For the Dreamweaver FTP implementation, you must connect to the 
remote system’s root folder. (In many applications, you can connect to 
any remote directory, and then navigate through the remote file system 
to find the directory you want.) 
Be sure that you indicate the remote system’s root folder as the host 
directory.
If you have problems connecting, and you’ve specified the host 
directory using a single slash (/), you might need to specify a relative 
path from the directory you are connecting to and the remote root 
folder.
For example, if the remote root folder is a higher-level directory, you 
may need to use ../../ to specify the host directory.

■ File and folder names that contain spaces and special characters often 
cause problems when transferred to a remote site. 
Use underscores in place of spaces, and avoid special characters in file 
and folder names wherever possible. In particular, colons (:), slashes (/), 
periods (.), and apostrophes (‘) in file or folder names can cause 
problems. Special characters in file or folder names may also sometimes 
prevent Dreamweaver from creating a site map.

■ If you encounter problems with long filenames, rename them with 
shorter names. On Macintosh, filenames cannot be more than 
31 characters long. 
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■ Many servers use symbolic links (UNIX), shortcuts (Windows), or 
aliases (Macintosh) to connect a folder on one part of the server’s disk 
with another folder elsewhere.
For example, the public_html subdirectory of your home directory on 
the server may really be a link to another part of the server entirely. In 
most cases, such aliases have no effect on your ability to connect to the 
appropriate folder or directory; however, if you can connect to one part 
of the server but not to another, there may be an alias discrepancy.

■ If you encounter an error message such as “cannot put file,” your 
remote folder may be out of space. For more detailed information, look 
at the FTP log.

In general, when you encounter a problem with an FTP transfer, examine 
the FTP log by selecting Site > Advanced > FTP Log.
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PART 3

Advanced Tutorials
Part Three of this book contains tutorials that introduce you to more 
advanced features in Dreamweaver. You do not need previous knowledge of 
HTML or other languages to complete these tutorials, but be aware that 
the tutorials in this part are more complex than the tutorials in the previous 
part.

This part contains the following sections:
Tutorial: Working with Code. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

Tutorial: Creating a CSS-based Page Layout . . . . . . . . . . . . . . . . 153

Tutorial: Displaying XML Data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 173

Tutorial: Developing a Web Application . . . . . . . . . . . . . . . . . . . . . 197
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CHAPTER 8

Tutorial: Working 
with Code
As you add text, images, and other content to a web page, Dreamweaver 8 
generates HTML code. This tutorial explains how to use Code view to 
display a document’s underlying code, and how to add and edit code 
manually.

If you’ve already set up your site and completed the previous tutorials, you 
can continue working in the same index.html file.

If you haven’t completed the previous tutorials, you can still complete this 
tutorial. First, set up your site by following the instructions in “Tutorial: 
Setting Up Your Site and Project Files” on page 49. Next, use the 
index_code.html file in the cafe_townsend/completed_files/dreamweaver 
folder to complete this tutorial. The index_code.html is a duplicate copy of 
the finished index.html file from Chapter 6, “Tutorial: Formatting Your 
Page with CSS,” on page 99.

In this tutorial, you will complete the following tasks:
Look at the code  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140

Switch to the coding workspace (Windows only). . . . . . . . . . . . . 142

Add a tag with the Tag Chooser . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Edit a tag  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145

Look up information about a tag. . . . . . . . . . . . . . . . . . . . . . . . . . . . 147

Add an image with code hints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148

Check your changes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .151

Print your code . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 152

If you begin this tutorial with the completed index_code.html file, instead of 
the index.html file from Chapter 6, “Tutorial: Formatting Your Page with 
CSS,” on page 99 certain steps and illustrations in the tutorial will not 
match what you see on your screen.
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Look at the code
Dreamweaver lets you view your page in either of two ways: Design view 
(where the document looks much like it would look in a browser), or Code 
view (where you can see the underlying HTML code). You can also use a 
split view that shows both Code and Design views simultaneously.

1. Make sure the index.html file is open in the Document window.

2. In the Document toolbar, click Show Code and Design Views (which is 
labeled Split).
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If you did not complete the index.html file by doing the previous tutorials, 
see the introduction of this tutorial for how to proceed.
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If the Document toolbar isn’t already visible, select View > Toolbars > 
Document.
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The window splits, showing both the Design view and the underlying 
HTML code.

You can edit the code in Code view. Changes you make to the code 
don’t appear in Design view until you either click Refresh in the 
Document toolbar, or click anywhere in Design view.

3. (Optional) To show Design view only, click Design view.

4. (Optional) To show Code view only, click Code view.

When you’re working on your own pages, you can use whichever view is 
most comfortable for you. Most of the tutorials in this guide assume that 
you’re using Design view.

Refresh button
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Switch to the coding workspace 
(Windows only)
If you didn’t already do so during installation, you can (optionally) make 
your Windows workspace look and feel more like the popular coding 
environments of Macromedia HomeSite and ColdFusion Studio.

To switch to the coding workspace: 

■ Select Window > Workspace Layout > Coder.

Add a tag with the Tag Chooser
Next, you’ll use the Tag Chooser to wrap a div tag around one of the 
images on the page. You can then assign margins, borders, or colors to the 
image as you desire. There are a variety of ways to wrap a div tag around 
an image; this section explains how to use the Tag Chooser, which helps 
you insert any tag and add appropriate attribute values.

1. Open the index.html file, if it’s not already open.

2. In Design view, click the Cafe Townsend banner graphic 
(banner_graphic.jpg) to select it. 
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Macintosh users cannot change the workspace.
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3. Switch to Code view by clicking Code view in the Document toolbar, 
or by selecting View > Code View.

You’ll see that the code for the selected image is selected in Code view. 
Make sure the entire img tag is selected, including the opening and 
closing angle brackets.

4. If it isn’t already enabled, select View > Code View Options > Word 
Wrap to enable word wrap.

5. Right-click (Windows) or Control-click (Macintosh) the selected text, 
and then select Insert Tag from the pop-up menu. 

The Tag Chooser appears.
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6. In the Tag Chooser, expand the HTML Tags category, followed by the 
Formatting and Layout subcategory; then select General. 

A list of tag names appears in the right pane; select div from that list.

7. Click Insert.

A tag editor for the div tag appears.
8. In the tag editor, select the Style Sheet/Accessibility category and enter 

banner in the ID text box.
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You can also select the HTML Tags category, and then select the div tag in the 
right pane, without first expanding Formatting and Layout.
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9. Click OK to close the tag editor and insert the tag.

Dreamweaver inserts the div tag in your page, wrapping it around the 
image tag.

10. Click Close to close the Tag Chooser.

11. Save your page.

Edit a tag
Next, you’ll use the Tag inspector to quickly make changes to a tag’s 
attributes. The Tag inspector displays the attributes of the tag that’s 
selected in the Document window.

1. Open the index.html page in Code view, if it’s not already open.

2. Open the Tag inspector, if it’s not already open, by selecting Window > 
Tag Inspector. 

3. Select the Attributes tab.

4. Click Show List View in the Tag inspector to view all of a selected tag’s 
attributes in alphabetical order.

5. In the Document window’s Code view, click anywhere between the 
opening and closing brackets of any tag.

The Attributes tab of the Tag inspector shows information about the 
tag’s HTML attributes.
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6. Still in Code view, find and click in the img tag for the 
banner_graphic.jpg image at the top of the page.

The Attributes tab of the Tag inspector shows information about the 
img tag’s attributes.

7. In the Tag inspector, click in the empty text box beside the alt 
attribute, and type Cafe Townsend; then press Enter (Windows) or 
Return (Macintosh).

Dreamweaver displays the new value in the Tag inspector and changes 
the code in the Document window.

8. Save your page.
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Look up information about a tag
If you need help with a tag’s attributes and attribute values, you can look 
up reference information within Dreamweaver.

1. Open the index.html page in Code view, if it’s not already open.

2. In the Document window, select the alt attribute name (not the 
attribute value) in an img tag.

3. Right-click (Windows) or Control-click (Macintosh) the selected text, 
and then select Reference from the pop-up menu.

The Reference panel opens and displays information about the alt 
attribute.

You can also select Window > Reference to display the Reference panel.
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4. For information about another tag or attribute, select the tag or 
attribute from the appropriate pop-up menu in the Reference panel.

Add an image with code hints
To add code to the page manually, click in Code view and start typing. You 
can use the code hints feature to speed up your work.

In this section, you’ll use code hints to add the street sign image to the Cafe 
Townsend index page.

1. Open the index.html page, if it’s not already open. 

2. In Design view, select the street_sign.jpg image (it’s below the Flash 
Video placeholder) and press Delete.

Now you’ll use code hints to reinsert the image, instead of dragging it 
from the Assets panel as you did in Chapter 5, “Tutorial: Adding 
Content to Pages,” on page 73.
148 Tutorial: Working with Code



3. Switch to Code view by clicking Code view in the Document toolbar, 
or by selecting View > Code View.

In Code view, the insertion point should be between an open and a 
close paragraph tag, as follows:

If you don’t see an open and a close paragraph tag before the closing 
table cell </td> tag, type them in as follows:

Place the insertion point between the opening <p> tag and the closing 
<p> tag.

4. Delete anything that might be between the opening <p> tag and the 
closing <p> tag, for example, a nonbreaking space (&nbsp;).
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5. With the insertion point between the opening <p> tag and the closing 
<p> tag, type an opening angle bracket (<).

A list of tags appears at the insertion point.

6. Select the img tag from the list, and then press Enter (Windows) or 
Return (Macintosh) to insert the first part of the tag.

7. Press Spacebar to display a list of attributes for the tag.

8. Begin to type src, and press Enter (Windows) or Return (Macintosh) 
when the src attribute is selected in the hints menu.

The word Browse appears, selected, below the code you just typed.

9. Press Enter (Windows) or Return (Macintosh) to browse to a file.
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You can set the length of the delay before the list appears by selecting 
Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), 
and then selecting Code Hints from the category list on the left. In Code 
view, you can display a code hints menu at any time by pressing 
Control+Spacebar, and you can close a code hints menu at any time by 
pressing Escape.

T
IP To quickly scroll to a 

tag, start to type the 
tag name.
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10. In the Select File dialog box, navigate to the street_sign.jpg file (it’s in 
the images folder in the cafe_townsend root folder), and click OK 
(Windows) or Choose (Macintosh).

The URL of the image file is inserted as the value of the src attribute, 
and the insertion point appears after the closing quotation mark.

11. Press the Spacebar, select the alt attribute from the hints menu, and 
press Enter (Windows) or Return (Macintosh).

12. Leave the quotation marks empty, because this image is only an 
illustration. 

Use the Right Arrow key to move the insertion point to the right of the 
quotation marks.

13. Type a closing angle bracket (>) to complete the tag.

14. Save your page.

Check your changes
After making any change to your code, you can get immediate visual 
feedback.

To see a visual representation of your code, do either of the 
following:

■ Click Design view, or Code and Design views (labeled Split) in the 
Document toolbar.

■ Preview the page in a web browser by pressing F12 (Windows) or 
Option+F12 (Macintosh). To close the browser and return to your 
code, press Alt+F4 (Windows only).

T
IP To add an attribute 

to an existing tag, 
place the insertion 
point just after the 
tag’s final attribute 
value and press the 
Spacebar. When a 
list of attributes 
appears, add an 
attribute and specify 
a value, if any.
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Print your code
You can print your code to edit it offline, archive it, or distribute it.

To print code:

1. View a page in Code view.

2. Select File > Print Code.

3. Specify printing options, and then click OK (Windows) or Print 
(Macintosh).
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CHAPTER 9

Tutorial: Creating a CSS-based 
Page Layout
In Chapter 4, “Tutorial: Creating a Table-based Page Layout,” you learned 
how to use Dreamweaver’s table design features to create a page layout. In 
this tutorial, you’ll learn how to use Cascading Style Sheets (CSS) to create 
a similar layout. Many designers prefer CSS-based layouts because CSS 
gives you greater control over the positioning of elements, reduces the 
amount of code you need, and lets you format layout blocks with margins, 
borders, colors, and so on.

If you haven’t defined a Dreamweaver site and created the cafe_townsend 
local root folder, you must do so before you proceed. For instructions, see 
Chapter 3, “Tutorial: Setting Up Your Site and Project Files.”

In this tutorial you will complete the following tasks:
Learn about CSS-based page layout  . . . . . . . . . . . . . . . . . . . . . . . 153

Examine the design comp  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 154

Create and save a new page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 156

Insert layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157

Add color to the page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 171

Learn about CSS-based page 
layout
Many websites use table-based layouts to display information on their 
pages. Tables are useful for presenting tabular data (such as rows and 
columns of repeating elements) and are extremely easy to create on a page. 
But tables also tend to generate a great deal of code that is difficult to read 
and maintain. Additionally, because of the amount of tags required, and 
the potential for “nesting,” tables can cause problems for disabled people 
who are using screen readers to view web pages.
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A CSS-based layout—that is, a layout that uses block elements instead of 
table rows and columns—contains much less code than a table-based 
layout of the same nature. CSS-based layouts generally use <div> tags 
instead of <table> tags to create CSS layout blocks used for layout. You 
can position these CSS layout blocks anywhere on the page, and assign 
properties to them such as borders, margins, background colors, and so on. 
Additionally, people using screen readers to view web pages have a much 
easier time browsing pages built with CSS because the code is simpler and 
shorter.

Dreamweaver lets you create layers. A Dreamweaver layer is an HTML 
page element that you can position anywhere on your page. More 
specifically, it is a <div> tag (or any other tag) with an absolute position. 
You use Dreamweaver to drag layers on your page and then position the 
layers where you want them. The layers act as content blocks that hold 
assets like images, Flash files, text, and so on.

Dreamweaver layers are absolutely positioned elements. That is, they have 
a specific position that is set relative to the top and left margins of the page. 
You cannot create a CSS-based layout with layers and then center the 
contents of the page. Thus, the layout in this tutorial is slightly different 
than the one you created in Chapter 4, “Tutorial: Creating a Table-based 
Page Layout”.

For more information about Dreamweaver layers, see Chapter 7, “Laying 
Out Pages with CSS” in Using Dreamweaver.

Examine the design comp

Typically, you don’t begin building a website by opening Dreamweaver and 
laying out pages right away. The first steps to creating a website begin on a 
piece of paper, or in a graphics-editing application like Macromedia 
Fireworks. Graphic designers usually sketch out a piece of comprehensive 
artwork (also known as a “comp”) for the website in order to show it to the 
client and make sure that the initial ideas for the site meet with their 
client’s approval.
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If you already completed Chapter 4, “Tutorial: Creating a Table-based 
Page Layout” and examined the design comp, you can proceed to the 
next section to immediately begin creating your CSS-based layout.
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A comp consists of any number of page elements that the client has 
requested for their website. For example, the client might say, “I want to 
have a logo at the top of the page, a navigation that links to these other 
pages, a section for an online store, and a place where I can insert video 
clips.” Based on that discussion, the designer begins planning the layout of 
the site, and makes sketches of sample pages that fulfill the client’s 
requirements.

This tutorial provides you with the completed and approved comp for Cafe 
Townsend, a fictional restaurant that requested a website. As the web 
designer, it’s your job to transform the comp into a working web page 
(most likely with the help of other graphics designers and Flash 
developers).
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You’ll notice that the graphic designer provided you with a web page comp 
that includes a number of content areas, as well as some graphic ideas. In 
the next sections, you’ll use Dreamweaver to lay out this design.

You can also open the original comp file if you want to see it on the 
computer screen. You can find the comp, homepage-mockup.jpg, in the 
fireworks_assets folder of the cafe_townsend folder that you copied to your 
hard drive in Chapter 3, “Tutorial: Setting Up Your Site and Project Files.” 
You might even want to print out the comp so that you can refer to it as 
you build your page.

Create and save a new page
After you set up a site and examine any comps, you are ready to begin 
building web pages. You’ll start by creating a new page, and saving it in the 
cafe_townsend local root folder of your website. The page eventually 
becomes the home page for Cafe Townsend, a fictional restaurant.

If you haven’t created the cafe_townsend local root folder, you must do so 
before you proceed. For instructions, see Chapter 3, “Tutorial: Setting Up 
Your Site and Project Files.”

1. In Dreamweaver, select File > New.

2. On the General tab of the New Document dialog box, select Basic Page 
from the Category list, select HTML from the Basic Page list, and click 
Create.

3. Select File > Save As.

4. In the Save As dialog box, browse to and open the cafe_townsend folder 
that you defined as the site’s local root folder.

In Chapter 3, “Tutorial: Setting Up Your Site and Project Files”, you 
created this folder within a folder called local_sites.

5. Enter index_css.html in the File Name text box and click Save.

The filename now appears in the title bar at the top of the application 
window, in parentheses.
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6. In the Document Title text box at the top of your new document, type 
Cafe Townsend.

This is the title of your page (different from the filename). Your site 
visitors will see this title in the browser window title bar when they 
view the page in a web browser.

7. Select File > Save to save your page.

Insert layers
Next you’ll add layers to the page. A layer is an absolutely positioned 
element that you can use to hold images, text, Flash files, and other 
content. For more information about layers, see “Learn about CSS-based 
page layout” on page 153.

Draw a new layer
1. With the index_css.html page open in the Document window, select 

Layout mode from the Insert bar.
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2. Click Draw Layer.

The mouse pointer changes to a cross when you move it over the page.
3. Drag a layer of any size onto the page and release the mouse button.

4. Click the selection handle at the upper-left corner of the layer to make 
sure that it is selected.

5. With the new layer selected, do the following in the Property inspector 
(Window > Properties):

■ Click in the Layer ID text box and rename the layer 
banner_graphic.

■ In the Width (W) text box, enter 700px.

■ In the Height (H) text box, enter 90px.

■ In the Left (L) text box, enter 20px.

■ In the Top (T) text box, enter 20px.

■ Press Enter (Windows) or Return (Macintosh) to apply your last 
entry.

Dreamweaver sizes and positions the new banner_graphic layer. The 
banner_graphic layer is 700 pixels wide by 90 pixels high. It is also 
positioned 20 pixels from the left margin of the page, and 20 pixels 
from the top margin of the page.
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6. Open the Layers panel (Window > Layers). You’ll see that Dreamweaver 
has added the new layer (banner_graphic) to the list of layers.

7. Click once outside the new layer to deselect it.

8. Save your page.

Add more layers
Now you’ll add more layers to the page. You’ll use the first layer 
(banner_graphic) as a reference point for positioning the other layers. 
You’ll also use the CSS Layer Backgrounds feature to help you position and 
distinguish between layers.

1. In the Layout category of the Insert bar, click Draw Layer and drag 
another layer of any size on the page.

2. Click the new layer’s selection handle to select it.

T
IP You positioned the 

banner_graphic layer 
by using precise 
pixel values in the 
Property inspector, 
but you can position 
a layer anywhere on 
the page by dragging 
the selection handle 
in the upper-left 
corner of a selected 
layer.
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3. With the new layer selected, do the following in the Property inspector:

■ Click in the Layer ID text box and rename the layer flash_fma.

■ In the Width (W) text box, enter 700px.

■ In the Height (H) text box, enter 166px.

■ In the Left (L) text box, enter 20px.

■ In the Top (T) text box, enter 111px.

■ Press Enter (Windows) or Return (Macintosh) to apply your last 
entry.

Dreamweaver sizes and positions the new flash_fma layer.
.

The flash_fma layer is 700 pixels wide by 166 pixels high. It is also 
positioned 20 pixels from the left margin of the page, and 111 pixels 
from the top margin of the page. You positioned this layer 111 pixels 
from the top margin of the page so that it would not overlap with the 
banner_graphic layer.
When layers overlap, you’ll notice that the border of one of layers 
(specifically, the underlying layer) is represented by a dotted a line.
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4. Click once outside the new layer to deselect it.

5. Select View > Visual Aids > CSS Layout Backgrounds.

Dreamweaver adds background colors to your layers. These colors are 
randomly selected and do not appear on the published web page. They 
are merely visual aids that Dreamweaver provides to help you see where 
layers and other kinds of block elements appear on the page.
You can optionally disable CSS Layout Backgrounds again by selecting 
View > Visual Aids and deselecting CSS Layout Backgrounds.
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6. Next, drag three more layers onto the page, underneath the 
banner_graphic layer and the flash_fma layer. 

Remember to click Draw Layers in the Insert bar each time before you 
drag a new layer.
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7. After you have three more layers on the page, use the Property inspector 
to do the following:

■ Select the first layer, name it header, and size it to 700 pixels wide 
by 24 pixels high.

■ Press Enter (Windows) or Return (Macintosh) to apply your last 
entry.

■ Select the second layer, name it center_content, and size it to 700 
pixels wide by 350 pixels high. 

■ Press Enter (Windows) or Return (Macintosh) to apply your last 
entry.

■ Select the third layer, name it footer, and size it to 700 pixels wide 
by 24 pixels high. Press Enter (Windows) or Return (Macintosh) to 
apply your last entry.

When you’re finished, your page should look something like this:

T
IP When you select a 

layer, be sure to click 
somewhere on the 
layer border or the 
layer’s selection 
handle, and not 
inside the layer. You 
can be sure the layer 
is selected if you see 
resize handles on the 
borders of the layer, 
and width and height 
properties in the 
Property inspector. 
You can also select a 
layer by clicking its 
name in the Layers 
panel (Window > 
Layers).

When you resize the center_content layer to 350 pixels high, it will overlap 
the remaining layer on the page. Before you proceed with the next step, 
move the remaining layer below the center_content layer by selecting the 
remaining layer and dragging the selection handle to the bottom of the 
page.
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8. Next, select the header layer and drag the selection handle until the 
header layer is positioned directly beneath the flash_fma layer.

You can check your position from time to time as you drag the layer by 
clicking outside the layer to deselect it.

9. Select and drag the center_content layer and the footer layer, or use the 
arrow keys on your computer to position the layers, as the following 
example shows:

T
IP You can also move 

selected layers one 
pixel at a time by 
pressing the arrow 
keys on your 
keyboard. Try using 
the Property 
inspector to align the 
header layer 20 
pixels from the left 
margin of the page. 
Then use the Up 
Arrow key to move 
the layer up until it 
touches the bottom 
border of the 
flash_fma layer.
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10. After your layers are in position, disable CSS Layout Backgrounds (if it 
isn’t already) by selecting View > Visual Aids and deselecting CSS 
Layout Backgrounds.

Add layers inside a layer
The last layers you’ll draw will be inside the large center_content layer. 
These layers act as the equivalent of the table cells you added to the page if 
you completed Chapter 4, “Tutorial: Creating a Table-based Page Layout.”

1. Click once to the right of your layers to make sure everything is 
deselected.

2. In the Layout category of the Insert bar, click Draw Layer and drag 
another layer inside the center_content layer as the following example 
shows:

3. Click the new layer’s selection handle to make sure the layer selected.

T
IP You can also use the 

Visual Aids button on 
the Document 
toolbar to enable or 
disable CSS Layout 
Backgrounds.
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4. With the new layer selected, do the following in the Property inspector:

■ Click in the Layer ID text box and rename the layer navigation.

■ In the Width (W) text box, enter 140px.

■ In the Height (H) text box, enter 350px.

■ In the Left (L) text box, enter 20px.

■ Press Enter (Windows) or Return (Macintosh) to apply your last 
entry.

5. Use the Up Arrow key on your keyboard to move the navigation layer 
until it fits perfectly within the center_content layer, as the following 
example shows:
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6. Create another layer in the center_content layer by clicking Draw Layer 
and dragging another layer, as the following example shows:

7. Click the new layer’s selection handle to make sure the layer is selected.

8. With the new layer selected, do the following in the Property inspector:

■ Click in the Layer ID text box and rename the layer flash_video.

■ In the Width (W) text box, enter 230px.

■ In the Height (H) text box, enter 350px.

■ Press Enter (Windows) or Return (Macintosh) to apply your last 
entry.
Insert layers 167



9. Drag the flash_video layer or use the arrow keys on your keyboard to 
position the layer as the following example shows:
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10. Create one more layer in the center_content layer by clicking Draw 
Layer and dragging another layer as the following example shows:

11. Click the new layer’s selection handle to make sure the layer is selected.

12. With the new layer selected, do the following in the Property inspector:

■ Click in the Layer ID text box and rename the layer text.

■ In the Width (W) text box, enter 330px.

■ In the Height (H) text box, enter 350px.

■ Press Enter (Windows) or Return (Macintosh) to apply your last 
entry.
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13. Drag the text layer or use the arrow keys on your keyboard to position 
the layer as the following example shows:

14. Save your page.
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It’s OK if you see dotted lines on the borders of a layer. It means that your 
layers are overlapping by a pixel or two.
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Add color to the page
Now you’ll add color to the page by setting background colors for some of 
the layers, and for the background of the entire page.

1. Select the navigation layer by clicking its name in the Layers panel 
(Window > Layers).

2. In the Property inspector, click once inside the Background Color text 
box. 

The text box is located directly next to the Background Color (Bg) 
color box.

3. In the Background Color text box, enter the hexadecimal value 
#993300 and press Enter (Windows) or Return (Macintosh).

The background color of the navigation layer turns to reddish-brown.
4. Select the flash_video layer by clicking its name in the Layers panel.

5. In the Property inspector, click once inside the Background Color text 
box, enter the hexadecimal value #F7EEDF, and press Enter (Windows) 
or Return (Macintosh).

The color of the flash_video layer turns to light tan.
6. Repeat the previous steps to change the color of the text layer to light 

tan as well.

T
IP You can change the 

width of the Name 
column in the Layers 
panel by dragging 
the right border of 
the column title to 
the left or right.
Add color to the page 171



7. Once you’ve set the background colors for all three layers, click once to 
the right of all of your layers to make sure nothing is selected.

Next you’ll change the background color for the entire page by 
modifying page properties. The Page Properties dialog box lets you set 
a number of page properties, including the size and color of page fonts, 
the colors of visited links, page margins, and much more.

8. Select Modify > Page Properties.

9. In the Appearance category of the Page Properties dialog box, click the 
Background Color color box and select black (#000000) from the color 
picker.

10. Click OK.

Your page background turns to black.
11. Save your page.

Your CSS page layout is now complete. The layout contains a number of 
layers that can hold assets such as images, text, and Flash Video files. Your 
next step is to add the content.

If you completed Chapter 5, “Tutorial: Adding Content to Pages,” you 
know that you can use Dreamweaver to easily insert assets in your page. If 
you didn’t complete that tutorial, you can use the illustrations as a reference 
while adding content to the CSS-based page layout you just completed.

You can find the completed version of this tutorial in the cafe_townsend/
completed_files/dreamweaver folder.
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CHAPTER 10

Tutorial: Displaying 
XML Data 
This tutorial shows you how to create a web page that displays XML data. 
Displaying XML data involves retrieving information stored in a local or 
remote XML file and rendering that information on the page. The key 
benefit to using XML data on web pages is separating content from 
presentation. That is, the content of your page (the data) is kept 
completely separate from the page’s presentation (the layout, text styling, 
and so forth). As such, anyone can work in the XML file without having to 
alter the presentation page, and vice versa.

Although it’s not necessary, you should have some familiarity with 
Cascading Style Sheets (CSS) before completing this tutorial. If you don’t, 
you might want to complete Chapter 6, “Tutorial: Formatting Your Page 
with CSS,” on page 99.

In this tutorial you will complete the following tasks:
Locate your files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174

Review your task  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 175

Learn about using XML and XSL with web pages . . . . . . . . . . . . 176

Learn about XSLT pages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 178

Convert an HTML page to an XSLT page . . . . . . . . . . . . . . . . . . . 179

Attach an XML data source to the XSLT page . . . . . . . . . . . . . . . 180

Alter the XSLT page layout . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .181

Bind XML data to the XSLT page  . . . . . . . . . . . . . . . . . . . . . . . . . . 183

Apply styles to the XML data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 185

Create a dynamic link  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 186

Add a Repeat Region XSLT object . . . . . . . . . . . . . . . . . . . . . . . . . 188

Attach the XSLT page to the XML page. . . . . . . . . . . . . . . . . . . . . .191

Learn about other deployment options . . . . . . . . . . . . . . . . . . . . . . 194
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Locate your files
The files you’ll need to complete this tutorial are located in the xml folder, 
inside the cafe_townsend root folder that you copied to your computer in 
Chapter 3, “Tutorial: Setting Up Your Site and Project Files.” If you did 
not complete that tutorial, you must do so before proceeding.

The xml folder contains the main file you’ll be working with in this tutorial 
(xml_menu.html), the CSS style sheet for the menu page (xml_menu.css), 
a file containing your XML data (specials.xml), an images folder, and a 
number of other HTML pages.

The finished version of the tutorial, xml_menu.xsl, is located in the 
cafe_townsend/completed_files/dreamweaver/xml directory.
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Review your task
Cafe Townsend, a fictional restaurant, currently posts a list of daily specials 
on their website. They use an HTML table with a series of table rows to 
display the information. The left column of each row displays the name of 
the item and the item’s description. The right column of each row displays 
the item’s price. All of the information on the page is hand-coded (i.e., it is 
not coming from a dynamic data source), and the text is formatted with an 
external style sheet.

The owners of Cafe Townsend have decided to “go dynamic,” and use data 
from an XML file to display their daily specials. Using XML allows for a 
separation between the content of the page (the menu specials) and the 
presentation (the layout, text styling, and so forth). An employee who 
doesn’t know anything about HTML or web page maintenance can easily 
update the information by editing the XML file, while the page displaying 
the menu information remains stylistically untouched.
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In this tutorial you’ll convert the existing specials page (an HTML page) to 
an XSLT page so that you can display XML data on the page. You’ll also 
apply styles to the XML data so that the appearance of the data is in 
keeping with the rest of the page.

If you’re comfortable working with XML, XSLT, and client-side 
transformations, you can skip to “Convert an HTML page to an XSLT 
page” on page 179. If you are new to any of these concepts, read the next 
sections.

Learn about using XML and XSL 
with web pages
Extensible Markup Language (XML) is a language that lets you structure 
information. Like HTML, XML lets you structure your information using 
tags, but XML tags are not predefined as HTML tags are. Instead, XML 
lets you create tags that best define your data structure. Tags are nested 
within others to create a schema of parent and child tags. Like most 
HTML tags, all tags in an XML schema have an opening and closing tag.

The following example illustrates the basic structure of an XML file:
<?xml version=“1.0”>
<mybooks>

<book bookid=“1”>
<pubdate>03/01/2004</pubdate>
<title>Displaying XML Data with Macromedia Dreamweaver</

title>
<author>Charles Brown</author>

</book>
<book bookid=“2”>

<pubdate>04/08/2004</pubdate>
<title>Understanding XML</title>
<author>John Thompson</author>

</book>
</mybooks>

In this example, each parent <book> tag contains three child tags: 
<pubdate>, <title>, and <author>. But each <book> tag is also a child 
tag of the <mybooks> tag, which is one level higher in the schema. You can 
name and structure XML tags in any way you like, provided that you nest 
tags accordingly within others, and assign each opening tag a 
corresponding closing tag.
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XML documents do not contain any formatting—they are simply 
containers of structured information. (You’ll notice that the sample code 
contains no font, table, or heading tags.) Once you have an XML schema, 
you can use Extensible Stylesheet Language (XSL) to display the 
information. In the way that Cascading Style Sheets (CSS) let you format 
HTML, XSL lets you format XML data. You can define styles, page 
elements, layout, and so forth in an XSL file and attach it to an XML file so 
that when a user views the XML data in a browser, the data is formatted 
according to whatever you’ve defined in the XSL file. The content (the 
XML data) and presentation (defined by the XSL file) are entirely separate, 
providing you with greater control over how your information appears on a 
web page. In essence, XSL is a presentation technology for XML, where the 
primary output is an HTML page.

Extensible Stylesheet Language Transformations (XSLT) is a subset 
language of XSL that actually lets you display XML data on a web page, 
and “transform” it, along with XSL styles, into readable, styled information 
in the form of HTML. You can use Dreamweaver to create XSLT pages 
that let you perform XSL transformations using an application server or a 
browser. When you perform a server-side XSL transformation, the server 
does the work of transforming the XML and XSL, and displaying it on the 
page. When you perform a client-side transformation, a browser (such as 
Internet Explorer) does the work.

The approach you ultimately take (server-side transformations versus 
client-side transformations) depends on what you are trying to achieve as 
an end result, the technologies available to you, the level of access you have 
to XML source files, and other factors. Both approaches have their own 
benefits and limitations. For example server-side transformations work in 
all browsers while client-side transformations are restricted to modern 
browsers only (Internet Explorer 6, Netscape 8, Mozilla 1.8, and Firefox 
1.0.2). Server-side transformations let you display XML data dynamically 
from your own server or from anywhere else on the web, while client-side 
transformations must use XML data that is locally hosted on your own web 
server. Lastly, server-side transformations require that you deploy your 
pages to a configured application server, while client-side transformations 
only require access to a web server.
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This tutorial takes you through the steps of creating an XSLT page and 
performing a client-side transformation (mainly because the client-side 
workflow is much easier to execute, and doesn’t require the use of an 
application server.) For more information about other ways to deploy 
XSLT pages, see “Learn about other deployment options” on page 194.

Learn about XSLT pages
When working with server-side XSL transformations, you can use 
Dreamweaver to create XSLT pages that generate full HTML documents 
(entire XSLT pages), or XSLT fragments that generate a portion of an 
HTML document.

An entire XSLT page is similar to a regular HTML page. It contains a 
<body> tag and a <head> tag, and lets you display a combination of 
HTML and XML data on the page. An XSLT fragment is a piece of code, 
used by a separate document, that displays formatted XML data. Unlike an 
entire XSLT page, it is an independent file that contains no <body> or 
<head> tag. 

If you want to display XML data on a page of its own, you would create an 
entire XSLT page, and bind your XML data to it. If, on the other hand, 
you wanted to display XML data in a particular section of an existing 
dynamic page—for example, a dynamic home page for a sporting goods 
store, with sports scores from an RSS feed displayed on one side of the 
page—you would create an XSLT fragment and insert a reference to it in 
the dynamic page. Creating XSLT fragments, and using them in 
conjunction with other dynamic pages to display XML data is the more 
common scenario when working with server-side transformations.

In this tutorial, you’ll create an entire XSLT page and use it to transform a 
sample XML file. The transformation will be a client-side transformation 
that uses a modern browser (Internet Explorer 6, Netscape 8, Mozilla 1.8, 
or Firefox 1.0.2). Server-side transformations are beyond the scope of this 
tutorial as they require that you have an application server configured with 
a transformation engine.

For a comprehensive overview of server-side and client-side XSL 
transformations, see “About server-side XSL transformations” and “About 
client-side XSL transformations” in Using Dreamweaver (Help > Using 
Dreamweaver).
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For additional resources, including tutorials that teach you more about 
server-side transformations, see www.macromedia.com/go/dw_xsl.

Convert an HTML page to an 
XSLT page
You’ll begin by converting the existing specials page for Cafe Townsend—
an HTML page—into an XSLT page that can display XML data.

1. In the Files panel (Window > Files), locate the xml_menu.html, and 
double-click the file to open it. The xml_menu.html file is located in the 
xml folder, inside the cafe_townsend root folder. For more information, 
see “Locate your files” on page 174.

2. Select File > Convert > XSLT 1.0.

Dreamweaver opens a copy of the xml_menu page in the Document 
window. The new page is an XSL style sheet, saved with the .xsl 
extension.

3. Click on the xml_menu.html page and close it so that only the new 
xml_menu.xsl page is displayed in the Document window.
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Attach an XML data source to 
the XSLT page
Next you’ll attach an XML data source to the page using the Bindings 
panel.

1. In the Bindings panel (Window > Bindings), click the XML link.

2. Select Attach a Local File (it should be selected by default), click the 
Browse button, browse to the specials.xml file on your computer (it’s 
also located in the cafe_townsend/xml folder), and click OK.

3. Click OK to close the Locate XML Source dialog box.

Dreamweaver populates the Bindings panel with the schema of your 
XML data source.
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You can also click the Source link at the upper-right corner of the Bindings 
panel to add an XML data source.
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For a guide to the symbols in the schema, see “Creating XSLT pages” in 
Using Dreamweaver (Help > Using Dreamweaver).

Alter the XSLT page layout
Now that you’re going to use XML data on the page instead of static text, 
you won’t need all the table rows. Next you’ll delete all but one of the table 
rows, and use the one remaining row to display the data.

1. Click once in the last table row (the New York Cheesecake row) and 
click the rightmost <tr> tag in the tag selector to select the row.

2. Press Delete.

3. Repeat the previous steps to delete the Grilled Pacific Salmon row, and 
the Thai Noodle Salad row. When you’re finished, you should have one 
row left on the page—the Summer Salad row.

4. Select all of the text in the left table cell.
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5. In the Property inspector (Window > Properties), select None from the 
Style pop-up menu.

This step removes the menu class style from the selected text. In a 
normal workflow, you might not do this. You’re removing all styles here 
so that you can learn to apply styles to XML data later on.

6. With the text still selected, press Delete.

7. Save your work (File > Save).
182 Tutorial: Displaying XML Data



Bind XML data to the 
XSLT page
Now you’re ready to bind XML data to the page.

1. In the Bindings panel (Window > Bindings), select the item element 
and drag it to the empty table cell.

An XML data placeholder appears on the page. The placeholder is 
highlighted and in curly brackets. It uses the XPath (XML Path 
language) syntax to describe the hierarchical structure of the XML 
schema.

2. Press the Right Arrow key on your keyboard to move the insertion point 
to the right of the XML data placeholder.

3. Press the Spacebar, type a hyphen, and press the Spacebar again.
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4. In the Bindings panel, select the description element and drag it to the 
insertion point.

Another XML data placeholder appears on the page. Depending on 
your monitor resolution, the placeholder may move to the next line. 
Don’t worry about this now. When you display the page in a browser 
later on, the data will populate the table accordingly.

5. Lastly, select the price (7) in the right table cell.

6. In the Bindings panel, double-click the price element.

Again, the XML data placeholder affects the layout of the page. Don’t 
worry about this now.

7. Save the page, and then preview your work in a browser by pressing F12 
(Windows) or Option+F12 (Macintosh).

The browser displays the page showing one row of data from the XML 
file.
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The price XML data placeholder remains formatted with the menu class 
style because you did not remove the styles as you did for the left table 
cell.
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Apply styles to the XML data
Now you’ll apply styles to the item and description XML data 
placeholders. When you apply styles to an XML data placeholder, the text 
of the placeholder itself displays the styles. Later, when you preview the 
page in a browser, the resulting XML data will also display the assigned 
styles.

1. Click once in the left table cell, and click the rightmost <td> tag in the 
tag selector to select the cell.

You are selecting the cell so that you can format the entire contents of 
the cell at once, including the hyphen.

2. In the Property inspector, select menu from the list of class styles in the 
Style pop-up menu.

3. Click once inside the left table cell to deselect it.

4. Click once on the item XML data placeholder to select it.
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5. In the Property inspector, click the Italic button.

6. Save the page, and then preview your work in a browser by pressing F12 
(Windows) or Option+F12 (Macintosh).

For more information about applying styles to XML data, see “Applying 
styles to XSLT fragments” in Using Dreamweaver (Help > Using 
Dreamweaver).

Create a dynamic link
Next you’ll create a dynamic link so that the item name on the specials 
menu links to a page containing a picture of the item.

1. In the Document window, click the item XML data placeholder to 
select it.

2. In the Property inspector, click the Browse for File icon next to the Link 
text box.
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3. In the Select File dialog box, select Data Sources.

If you’re on a Windows computer, the option is located at the top of 
the dialog box. If you’re on a Macintosh computer, the option is 
located at the bottom of the dialog box.

4. When the XML schema appears in the dialog box, select the link 
element.
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5. Click OK.

Dreamweaver creates a dynamic link. In the XML file, each link 
element points to an HTML page containing a picture of the respective 
menu item.

6. Save the page, and then preview your work in a browser by pressing F12 
(Windows) or Option+F12 (Macintosh).

The browser displays the page with a live link. If you click the link it 
will take you to a new page.

Add a Repeat Region XSLT 
object
The Repeat Region XSLT object lets you display repeating elements from 
an XML data source on a web page. Next you’ll add the Repeat Region 
XSLT object to the table row so that you can display multiple specials on 
the page.

1. In the Document window, click once anywhere inside the table row 
containing the XML data placeholders.

2. In the tag selector, click the rightmost <tr> tag to select the table row.
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If you open the specials.xml file and look at the code, you’ll see that each 
<link> element contains the name of the HTML file containing the picture of 
the corresponding menu item. This is in fact the path to the HTML file, 
because the HTML pages containing the pictures are in the same xml 
directory as the XSLT page you’re working on. The link element is always 
a full path to the linked page, and is often written out in the form of an 
HTTP address.
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3. Select Insert > XSLT Objects > Repeat Region.
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4. In the XPath Expression Builder, select the repeating element 
menu_item. (Repeating elements are indicated by a small plus sign). 

5. Click OK.

In the Document window, a thin, tabbed, gray outline appears around 
the repeated region. (You’ll need to deselect the table to see it.) Later, 
when you preview your work in a browser, the gray outline will 
disappear and the selection will expand to display the specified 
repeating elements in the XML file.
Dreamweaver also shortens the length of the XML data placeholder. 
This is because Dreamweaver updates the XPath for the XML data 
placeholder so that it is relative to the path of the repeating element. 
For more information on this topic, see “About XML data and 
repeating elements” in Using Dreamweaver.

6. Save the page, and then preview your work in a browser by pressing F12 
(Windows) or Option+F12 (Macintosh).

The browser now displays the page showing each menu item.
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Attach the XSLT page to the 
XML page
Once your XSLT page is finished, you must attach it to the XML page. 
When you use Dreamweaver to attach the page, Dreamweaver inserts a 
link to the XSLT page at the top of the XML page.

The XML page is the page to which your site visitors will browse when 
viewing the page online. This is because they must browse to the “content” 
page containing the data (the XML file), instead of the page that contains 
the styles (the XSLT page).

1. With the xml_menu.xsl page open in the Document window, open the 
Bindings panel (Window > Bindings) if it isn’t already open.

2. In the Bindings panel, double-click on Schema for specials.xml to open 
the specials.xml file. (You must double-click the words, and not the 
page icon.)

3. Select Commands > Attach an XSLT Stylesheet.

4. In the Attach an XSLT Stylesheet dialog box, click the Browse button, 
browse to the xml_menu.xsl page, select it, and click OK.

The XML and XSL files you use for client-side transformations must 
reside in the same directory. If they don’t, the browser will read the XML 
file and find the XSLT page for the transformation, but will fail to find 
assets (style sheets, images, and so on) defined by relative links in the 
XSLT page.
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5. Click OK to close the Attach an XSLT Stylesheet dialog box.

Dreamweaver inserts the reference to the XSLT page at the top of the 
XML document.

6. Save the specials.xml page.
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7. Preview the XML page (not the XSLT page) in a browser by pressing 
F12 (Windows) or Option+F12 (Macintosh).

The XML page is displayed in a browser, styled with the XSLT page 
you created.

Remember, your site visitors will browse to the XML page (not the 
XSLT page) once you’ve deployed both pages to your server. For more 
information, see “About client-side XSL transformations” in Using 
Dreamweaver (Help > Using Dreamweaver).
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Learn about other deployment 
options
In this tutorial, you learned how to create an entire XSLT page to use as 
part of a client-side transformation. But you can also use entire XSLT pages 
for server-side transformations. When you use an entire XSLT page for a 
server-side transformation, you build the page in exactly the same way. 

The more common approach to performing server-side transformations, 
however, is to use XSLT fragments. An XSLT fragment is a piece of code, 
used by a separate document, that displays formatted XML data.

For a brief overview of entire XSLT pages and XSLT fragments, see “Learn 
about XSLT pages” on page 178. For a more comprehensive overview of 
how entire XSLT pages and XSLT fragments work, see “About server-side 
XSL transformations” in Using Dreamweaver (Help > Using 
Dreamweaver).

For tutorials and other resources that teach you about working with XSLT 
fragments, visit www.macromedia.com/go/dw_xsl.

Following is the workflow for performing server-side transformations with 
XSLT pages:

■ Set up a Dreamweaver site. See Chapter 2, “Setting Up a Dreamweaver 
Site” in Using Dreamweaver.

■ Choose a server technology and set up an application server. See 
“Setting up an application server” in Using Dreamweaver.

■ Test the application server to make sure it is functioning correctly. For 
example, create a page that requires processing, and make sure that the 
application server processes the page. For a tutorial on how to do this, 
visit www.macromedia.com/go/dw_xsl.

■ Do one of the following:
■ In your Dreamweaver site, create an XSLT fragment or an entire 

XSLT page. See “Creating XSLT pages” in Using Dreamweaver.
■ Convert an existing HTML page to an entire XSLT page. See 

“Converting HTML pages to XSLT pages” in Using Dreamweaver.
■ If you haven’t already done so, attach an XML data source to the page. 

See “Attaching XML data sources” in Using Dreamweaver.
■ Bind your XML data to the XSLT fragment or to the entire XSLT page. 

See “Displaying XML data in XSLT pages” in Using Dreamweaver.
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■ If appropriate, add a Repeat Region XSLT object to the table or table 
row that contains the XML data placeholder(s). See “Displaying 
repeating XML elements” in Using Dreamweaver.

■ Do one of the following:
■ Use the XSL Transformation server behavior to insert a reference to 

the XSLT fragment in your dynamic page. See “Inserting XSLT 
fragments in dynamic pages” in Using Dreamweaver.

■ Delete all of the HTML code from a dynamic page, and then use 
the XSL Transformation server behavior to insert a reference to the 
entire XSLT page in the dynamic page.

■ Post both the dynamic page and the XSLT fragment (or entire XSLT 
page) to your application server. If you are using a local XML file, you 
will need to post that as well.

■ View the dynamic page in a browser. When you do so, the application 
server transforms the XML data, inserts it in the dynamic page, and 
displays it in the browser.
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CHAPTER 11

Tutorial: Developing a 
Web Application 
In this tutorial, you’ll learn how to use Macromedia Dreamweaver 8 to 
quickly begin developing dynamic database-driven web applications, 
allowing you to present information retrieved from a database on your 
web pages.

You’ll display data on web pages for the Cafe Townsend site, using a 
sample database provided with Dreamweaver. You’ll also use Dreamweaver 
to create a record-insertion form to let visitors leave comments. 

In this tutorial, you will complete the following tasks:
Before you begin  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 198

Review your task  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 198

Open a document to work in . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 200

Define a recordset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201

Display the database records  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 204

Add dynamic fields to the table. . . . . . . . . . . . . . . . . . . . . . . . . . . . 206
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Before you begin
You must set up your Dreamweaver work environment for application 
development before you can complete this tutorial. For setup information, 
see the appropriate setup chapter for your application server in the 
following list. If you’re not sure which application server you use, ask your 
system administrator.

■ Appendix C, “Setup for Sample ColdFusion Site,” on page 237
■ Appendix D, “Setup for Sample ASP.NET Site,” on page 255
■ Appendix E, “Setup for Sample ASP Site,” on page 269
■ Appendix F, “Setup for Sample JSP Site,” on page 285
■ Appendix G, “Setup for Sample PHP Site,” on page 301

These setup chapters teach you how to complete the following tasks: 

■ Configure your system.
■ Configure Dreamweaver to work with your chosen application server.
■ Define a connection to the database.

You can’t complete this tutorial until you’ve completed those tasks.

The screen shots in this tutorial show Macromedia ColdFusion dialog 
boxes. However, you can complete the lessons in this tutorial by using any 
of the server models that Dreamweaver supports.

Review your task
Your task is to build the following dynamic pages for the Cafe Townsend 
website:

■ A page that displays the comments already in a database.
■ A page that lets site visitors send comments to the company, where they 

are stored in a database.
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The page that lets Cafe Townsend staff view the comments in the database 
will look as follows:

The page that lets visitors send the comments will look as follows:
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Open a document to work in
A good starting point for developing a database application is to create a 
page that lists records stored in the database. In the application you’re 
building in this tutorial, you’ll create a dynamic web page that lists 
information drawn from the customer comments table of the database. 
Later, you’ll create another dynamic web page that lets a customer insert 
comments or questions directly into the database.

Start by locating the documents you’ll work with as you create these pages.

1. Select Window > Files to open the Files panel.

The Files panel opens. 
2. In the Site pop-up menu, select the Cafe Townsend site you defined 

during the setup process.

For more information, see the setup chapters listed in “Before you 
begin” on page 198.

3. In the Files panel, double-click the file called view to open it.

The document opens in the Document window.
4. If you are currently viewing the document in Code view, click Show 

Design View (labeled “Design”) or Show Code and Design Views 
(labeled “Split”) in the Document toolbar so that you can use the 
provided screen shots as checkpoints while you complete the tutorial. 
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Define a recordset
Now you’ll create a recordset to select the data you want to display. A 
recordset is a set of information extracted from a database by a database 
query. (In ASP.NET, a recordset is known as a DataSet.) A database query 
is a way to request data from a database by using specified search criteria, 
usually in a language called SQL. You then use the information extracted as 
a source of content for your dynamic pages.

Dreamweaver provides an easy-to-use interface for creating simple SQL 
queries (you don’t need to know SQL to create a recordset in 
Dreamweaver).

You’ll create a recordset that selects all of the values from the 
COMMENTS table in the tutorial database.

1. In the Cafe Townsend document open in Dreamweaver, place the 
insertion point below the Customer Comments heading.

2. Open the Recordset dialog box or (for ASP.NET) the DataSet dialog 
box by doing one of the following:

■ In the Insert bar’s Application category, click Recordset or (for 
ASP.NET) click DataSet. 

■ Select Window > Bindings to open the Bindings panel; then click 
Plus (+) and select Recordset or (for ASP.NET) DataSet. 

The Recordset dialog box or (for ASP.NET) DataSet dialog box 
appears.

Before you can complete this procedure, you must set up a connection to 
the database. For more information, see “Before you begin” on page 198.
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3. In the Name text box, enter rs_Comment. 

4. In the Data Source pop-up menu (ColdFusion) or Connection pop-up 
menu (other server page types), select connTownsend.

The Recordset or DataSet dialog box updates with data from the 
database.

5. If a user name and password are associated with the data source or 
connection, enter them. If you didn’t provide a user name or password 
when you set up the data source, leave these boxes blank.

6. In the Table pop-up menu, leave COMMENTS selected.

7. In Columns, make sure All is selected to select all columns of the table.

8. Leave the Filter pop-up menu set to None to select all rows of the table.
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If the dialog box you see looks more complex than the preceding dialog 
box, click Simple.
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9. In the first Sort pop-up menu, select LAST_NAME, and in the second 
pop-up menu, select Ascending.

This step specifies that the retrieved records are listed in alphabetical 
order by customer last name. 

10. Click Test to test the recordset or DataSet. 

The records from the database that match your recordset or DataSet 
selection criteria are displayed in the Test SQL Statement window. In 
this case, you selected all the data in the table.
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11. Click OK to close the Test SQL Statement window.

12. Click OK to close the Recordset or DataSet dialog box and create a 
recordset or DataSet.

The recordset appears in the Bindings panel. The Document window 
doesn’t change.

Display the database records
Next, you’ll create a page that lists the records that currently exist in the 
COMMENTS table. You will dynamically generate the page rather than 
manually entering the information. 

You’ll start by creating a table to structure the data list. 

1. In the Cafe Townsend document, place the insertion point in the blank 
line after the “Customer Comments” heading.

2. Insert a table by doing one of the following:

■ In the Insert bar, select the Common category, and then click the 
Table button or drag the button to the document. 

■ Select Insert > Table.
The Table dialog box appears.

T
IP If you don’t see all of 

the recordset fields in 
the Bindings panel, 
click Plus (+) 
(Windows) or click 
the expander arrow 
(Macintosh) next to 
Recordset 
(rs_Comment) to 
expand the 
recordset’s structure..
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3. In the dialog box, set the following options:

■ In Rows, enter 2.
■ In Columns, enter 4.
■ Leave Table Width set to 100 percent.
■ Leave Border Thickness set to 1.
■ In Cell Padding enter 2.
■ In Cell Spacing, enter 2.
■ In the Header section, select the Top option.
In the Summary text box, provide a textual description of the table for 
the benefit of visitors who use screen readers, as follows:
This table lists all of the comments that visitors to this site have 
entered into the database. 
The completed dialog box should look like the following example:

4. Click OK.

The table is inserted in the document.
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5. In the top row of the table add labels for the table entries:

■ In the first cell of the table, enter First Name.
■ In the next cell, enter Last Name.
■ In the next cell, enter E-mail.
■ In the last cell, enter Comments.

6. Save your page.

Add dynamic fields to the table
You’re now ready to add the recordset fields to the table. 

1. Open the Bindings panel, if it isn’t already open, by doing one of the 
following. 

■ Select Window > Bindings.
■ Click the Application panel group’s expander arrow and select the 

Bindings panel. 
2. Add the FIRST_NAME field to the table, by doing one of the 

following:

■ Place the insertion point in the table cell below the First Name 
label; in the Bindings panel, select FIRST_NAME and click Insert.

■ Drag FIRST_NAME from the Bindings panel to the table cell 
below the First Name label.

3. Repeat step 2 to add LAST_NAME, EMAIL, and COMMENTS (not 
COMMENT_ID) to the table.

Your table should look like the following example. You may have to 
widen your Document window to see all of the table.

4. Save your page.
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Set a repeated region
The table you created contains only one row for data. To display all of the 
records, you must set that table row as a repeated region. When viewed in a 
browser, the table contains a row for each record that matches the recordset 
search requirements.

1. In the Document window, select the bottom table row by doing one of 
the following:

■ Click in one of the cells; in the tag selector, click the last <tr> tag in 
the list.

■ Position the pointer at the left edge of the table row and when the 
pointer changes to an arrow pointing right, click the table row 
border to select the row.

2. Create a repeated region by doing one of the following: 

■ In the Server Behaviors panel, click Plus (+) and select Repeat 
Region. 

■ In the Insert bar’s Application category, click Repeated Region. 
■ Select Insert > Application Objects > Repeated Region.
The Repeat Region dialog box appears.

3. In the dialog box, click OK to accept the default settings.

An outline appears around the table row, and a tab appears above it and 
to the left to indicate that it’s a repeated region. (The tab’s label varies 
depending on the server technology you’re using.)

4. Save your page.
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View your page
Next, you’ll view the page. To view a page in Dreamweaver as it would look 
when the server processes it, you can use Live Data view.

With the Cafe Townsend document still active, do one of the following to 
view the data in your pages:

■ In the Document toolbar, click Live Data View.
■ Select View > Live Data.

The page updates to show data extracted from the database.

Create a record insert form
The next page you’ll create for the Cafe Townsend website allows 
customers to add comments to the database. 

Dreamweaver includes several application objects that help you create web 
application pages quickly and easily. You’ll use an application object to 
create the insert page. The Insert Record application object creates an 
HTML form, data fields that correspond to fields in the database, and the 
necessary server scripts to create a dynamic page.
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Add a Record Insertion Form application 
object
You can use a Record Insertion Form application object to create a form 
that allows visitors to enter data into a database. The application object lets 
you select which fields to include in the form, label the fields, and select the 
types of form objects to insert. When a user enters data in the form fields 
and clicks the submit button, a new record is inserted in a database. You 
can also set a page to open after a record has successfully been submitted so 
that the submitter knows that the database was updated.

1. In the Files panel, locate the file named “send” and double-click the file 
to open it.

The document opens in the Document window.

2. Place the insertion point in the empty table row below the row that 
contains the paragraph. 

The application object is inserted in the empty row. 
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3. To add a record insertion object to your page, do one of the following:

■ In the Insert bar’s Application category, select Record Insertion 
Form Wizard from the Insert Record pop-up menu. 

■ Select Insert > Application Objects > Insert Record > Record 
Insertion Form Wizard.

The Record Insertion Form dialog box appears. 

4. In the Data Source (ColdFusion) or Connection pop-up menu, select 
connTownsend.

5. If a user name and password are associated with the data source or 
connection, enter them. 

If you didn’t provide a user name or password when you set up the data 
source or connection, leave these boxes blank.

6. In the Table pop-up menu, make sure COMMENTS is selected.

7. Click Browse next to the After Inserting, Go To text box or (for 
ASP.NET) next to the On Success, Go To text box.

8. In the dialog box that appears, select the file named “view” and click OK 
to close the dialog box.

For testing purposes, you want to see the page that displays all of the 
comments after you enter a comment. After testing the web 
application, change this setting to show a page that thanks the visitor 
for the comment.

9. Complete the rest of the wizard by following the procedure in the next 
section.
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Create the insert form
In the Form Fields section of the Record Insertion Form Wizard, you 
define the form that a visitor enters data into.

1. In the Record Insertion Form Wizard, remove the fields you don’t want 
included in the form by doing the following:

■ Select COMMENT_ID and click Minus (-).
■ Select TELEPHONE and click Minus (-).
■ Select SUBMIT_DATE and click Minus (-).
■ Select ANSWERED and click Minus (-).

2. If you are creating a page for ASP.NET, change the alphabetical order 
of the form fields by doing the following:

■ In the Column list, select COMMENTS and click the down arrow 
to position COMMENTS below LAST_NAME.

■ In the Column list, select EMAIL and click the down arrow to 
position EMAIL below LAST_NAME.

3. In the Form Fields list, select FIRST_NAME to specify how the field is 
displayed in the form.

4. In the Label text box, type First Name to replace the default text.

This is the label that appears in the HTML form next to the text box.
5. Set the type of form object for the field by doing one of the following:

■ If you are using ASP.NET, in the Display As pop-up menu accept 
the default value Text Field, and in the Submit As pop-up menu 
change the default value from WChar to VARCHAR.

■ If you are using a server technology other than ASP.NET, in the 
Display As pop-up menu accept the default value Text Field, and in 
the Submit As pop-up menu accept the default value Text. 
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6. Leave the Default Value field empty. 

For some web applications, you would use this field to set initial text 
for the field in order to let the user know what kind of information to 
provide. In this case, the field label “First Name” makes clear that the 
visitor is supposed to enter their first name.
The FIRST_NAME entry should look similar to the following 
example when you are done:

7. Repeat steps 3 through 6 for the LAST_NAME form field, with a label 
of Last Name, displaying as a Text Field and submitting as Text.

8. Repeat steps 3 through 6 for the EMAIL form field, with a label of 
Email, displaying as a Text Field and submitting as Text.

9. In the Form Fields list, select COMMENTS.

10. In the Label field, enter Comments. 

11. Set the type of form object for the Comments form field by doing one 
of the following:

■ If you are using ASP.NET, in the Display As pop-up menu, select 
Text Area; in the Submit As pop-up menu, select VARCHAR.

■ If you are using a server technology other than ASP.NET, in the 
Display As pop-up menu, select Text Area, and in the Submit As 
pop-up menu, accept the default value Text. 
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The dialog box should look similar to the following example when you 
are done:

12. Click OK to close the dialog box and create the record insertion form.

The Record Insertion Form application object is inserted in the 
document. 

13. Save your page.
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Copy files to the server
Next, you’ll copy the files you’ve updated to your server. After you copy the 
files, you’ll view the insert record page, add a comment or question, and 
submit the data to test the application.

1. In the Files panel, Control-click (Windows) or Command-click 
(Macintosh) the files named “view” and “send,” and then click the blue 
Put Files arrow icon to upload the files to your server.

2. If Dreamweaver asks whether you want to copy dependent files to the 
server, select Yes.

3. With the file named send as the active document, select File > Preview 
in Browser or press F12 to view your page in a browser. 

4. Enter test data in the form and click Insert Record in the document to 
submit your data.

The application server receives the submitted information, updates the 
database, and displays the comments page with the updated 
information.

Further reading
This tutorial provided information about a small set of tools you can use to 
create dynamic, data-driven pages. You learned how to create recordsets to 
define the data you want to use in your website. You also used a 
Dreamweaver application object to create an effective web application that 
allows you to interact with database-stored data.

For more detailed information about how to develop web applications, see 
the following topics in Using Dreamweaver: 

■ “Obtaining Data for Your Page”
■ “Defining Sources of Dynamic Content”
■ “Adding Dynamic Content to Web Pages”
■ “Displaying Database Records”
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With some server models, Dreamweaver creates a Connections folder in 
your local folder. You must also copy that folder to your remote server for the 
web application to work. In the Files panel, select the Connections folder and 
click Put File (s) to copy the folder to your server. 
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PART 4

Appendices
Part Four of this book contains appendices that provide additional 
information about concepts presented in previous sections.
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APPENDIX A

Understanding Web 
Applications
A web application is a collection of web pages that interact with visitors, 
with each other, and with various resources on a web server, including 
databases. Before you start building your own web applications, you should 
be familiar with the concepts discussed in this chapter. 

The chapter contains the following topics:
About web applications  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 217

How a web application works . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 219

Authoring dynamic pages. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 224

Choosing a server technology. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 226

Web application terminology. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .227

About web applications
A web application is a website that contains pages with partly or entirely 
undetermined content. The final content of a page is determined only 
when the visitor requests a page from the web server. Because the final 
content of the page varies from request to request based on the visitor’s 
actions, this kind of page is called a dynamic page.

Web applications are built to address a variety of challenges and problems. 
This section describes common uses for web applications and gives a 
simple example. 
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Common uses for web applications 
Web applications have many uses for both site visitors and developers, 
including the following: 

■ Let visitors find information quickly and easily on a content-rich 
website. 
This kind of web application gives visitors the ability to search, 
organize, and navigate content as they see fit. Examples include 
company intranets, Microsoft MSDN (www.msdn.microsoft.com), 
and Amazon.com (www.amazon.com).

■ Collect, save, and analyze data provided by site visitors. 
In the past, data entered in HTML forms was sent as e-mail messages 
to employees or CGI applications for processing. A web application can 
save form data directly into a database and also extract the data and 
create web-based reports for analysis. Examples include online banking 
pages, store check-out pages, surveys, and user-feedback forms.

■ Update websites that have constantly changing content.
A web application frees the web designer from continually updating the 
site’s HTML. Content providers such as news editors provide the web 
application with content, and the web application updates the site 
automatically. Examples include the Economist (www.economist.com) 
and CNN (www.cnn.com).

Web application example
Janet is a professional web designer and longtime Dreamweaver user 
responsible for maintaining the intranet and Internet sites of a medium-
sized company of 1000 employees. One day, Chris from Human Resources 
comes to her with a problem. HR administers an employee fitness program 
that gives employees points for every mile walked, biked, or run. Each 
employee must report his or her monthly mile totals in an e-mail to Chris. 
At the end of the month, Chris gathers all the e-mail messages and awards 
employees small cash prizes according to their point totals. 

Chris’s problem is that the fitness program has grown too successful. So 
many employees now participate that Chris is inundated with e-mails at 
the end of each month. Chris asks Janet if a web-based solution exists. 
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Janet proposes an intranet-based web application that performs the 
following tasks:

■ Lets employees enter their mileage on a web page using a simple 
HTML form

■ Stores the employees’ mileage in a database
■ Calculates fitness points based on the mileage data
■ Lets employees track their monthly progress
■ Gives Chris one-click access to point totals at the end of each month

Janet gets the application up and running before lunchtime using 
Dreamweaver, which has the tools she needs to build this kind of 
application quickly and easily.

How a web application works
A web application is a collection of static and dynamic web pages. A static 
web page is one that does not change when a site visitor requests it: The 
web server sends the page to the requesting web browser without 
modifying it. In contrast, a dynamic web page is modified by the server 
before it is sent to the requesting browser. The changing nature of the page 
is why it’s called dynamic. 

For example, you could design a page to display fitness results, while 
leaving certain information (such as employee name and results) to be 
determined when the page is requested by a particular employee.

Processing static web pages
A static website comprises a set of related HTML pages and files hosted on 
a computer running a web server.

A web server is software that serves web pages in response to requests from 
web browsers. A page request is generated when a visitor clicks a link on a 
web page, selects a bookmark in a browser, or enters a URL in a browser’s 
address text box. 
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The final content of a static web page is determined by the page designer 
and doesn’t change when the page is requested. Here’s an example:
<html>

<head>
<title>Trio Motors Information Page</title>

</head>
<body>

<h1>About Trio Motors</h1>
<p>Trio Motors is a leading automobile manufacturer.</p>

</body>
</html>

Every line of the page’s HTML code is written by the designer before the 
page is placed on the server. Because the HTML doesn’t change once it’s on 
the server, this kind of page is called a static page.

When the web server receives a request for a static page, the server reads the 
request, finds the page, and sends it to the requesting browser, as shown in 
the following figure: 
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Strictly speaking, a “static” page may not be static at all. For example, a 
rollover image or Flash content (a SWF file) can make a static page come 
alive. However, this documentation refers to a page as static if it is sent to 
the browser without modifications. 

Web browser

<HTML>
<p>Hi
</HTML>

WEB SERVER

Static page

Request Response

Step 1 - Web 
browser requests 
static page.

Step 2 - 
Web server 
finds page

Step 3 - Web 
server sends page 
to requesting 
browser
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In the case of web applications, certain lines of code are undetermined 
when the visitor requests the page. These lines must be determined by 
some mechanism before the page can be sent to the browser. The 
mechanism is discussed in the following section.

Processing dynamic pages
When a web server receives a request for a static web page, the server sends 
the page directly to the requesting browser. When the web server receives a 
request for a dynamic page, however, it reacts differently: It passes the page 
to a special piece of software responsible for finishing the page. This special 
software is called an application server. 

The application server reads the code on the page, finishes the page 
according to the instructions in the code, and then removes the code from 
the page. The result is a static page that the application server passes back 
to the web server, which then sends the page to the requesting browser. All 
the browser gets when the page arrives is pure HTML. Here’s a view of the 
process:

Application server

Request

Web browser

<HTML>
<code>
</HTML>

Response

<HTML>
<p>Hi
</HTML>

WEB SERVER

Step 1 - Web 
browser requests 
dynamic page.

Step 2 - 
Web server 
finds page 
and passes it 
to application 
server

Step 3- 
Application server 
scans page for 
instructions and 
finishes page.

Step 4- 
Application server 
passes finished 
page back to web 
server

Step 5 - Web 
server sends 
finished page to 
requesting browser
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Accessing a database
An application server lets you work with server-side resources such as 
databases. For example, a dynamic page may instruct the application server 
to extract data from a database and insert it into the page’s HTML. For 
more information, see Appendix A, “Beginner’s Guide to Databases” in 
Using Dreamweaver.

The instruction to extract data from a database is called a database query. A 
query consists of search criteria expressed in a database language called 
SQL (Structured Query Language). The SQL query is written into the 
page’s server-side scripts or tags. 

An application server cannot communicate directly with a database because 
the database’s proprietary format renders the data undecipherable in much 
the same way that a Microsoft Word document opened in Notepad or 
BBEdit may be undecipherable. The application server can communicate 
with the database only through the intermediary of a database driver: 
software that acts like an interpreter between the application server and the 
database. 

After the driver establishes communication, the query is executed against 
the database and a recordset is created. A recordset is a set of data extracted 
from one or more tables in a database. The recordset is returned to the 
application server, which uses the data to complete the page.

Here’s a simple database query written in SQL:
SELECT lastname, firstname, fitpoints
FROM employees

This statement creates a three-column recordset and fills it with rows 
containing the last name, first name, and fitness points of all employees in 
the database. For more information, see Appendix B, “SQL Primer” in 
Using Dreamweaver. 
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Here’s an illustration of the process of querying a database and returning 
data to the browser:

You can use almost any database with your web application, as long as the 
appropriate database driver for it is installed on the server.

Application server

Request

Web browser

<HTML>
<code>
</HTML>

Response

Query

<HTML>
<p>Hi
</HTML>

WEB SERVER

Database

Recordset

Database driver

Step 2 - Web server 
finds page and 
passes it to 
application server. 

Step 5 - Driver 
executes the query 
against the database.

Step 6 - Recordset is 
returned to driver

Step 4 - Application 
server sends query to 
database driver. 

Step 7 - Driver 
passes recordset to 
application server

Step 8 - Application 
server inserts data in 
page, and then 
passes the page to 
the web server

Step 1 - Web browser 
requests dynamic 
page. 

Step 3 - Application 
server scans page for 
instructions.

Step 9 - Web server 
sends finished page 
to requesting 
browser
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If you plan to build small low-cost applications, you can use a file-based 
database, such as one created in Microsoft Access. If you plan to build 
robust, business-critical applications, you can use a server-based database, 
such as one created in Microsoft SQL Server, Oracle 9i, or MySQL. 

If your database is located on a system other than your web server, make 
sure you have a fast connection between the two systems so that your web 
application can operate quickly and efficiently.

Authoring dynamic pages
Authoring a dynamic page consists of writing the HTML first, and then 
adding the server-side scripts or tags to the HTML to make the page 
dynamic. When you view the resulting code, the language appears 
embedded in the page’s HTML. Accordingly, these languages are known as 
HTML embedded programming languages. The following basic example 
uses ColdFusion Markup Language (CFML): 
<html>

<head>
<title>Trio Motors Information Page</title>

</head>
<body>

<h1>About Trio Motors</h1>
<p>Trio Motors is a leading automobile manufacturer.</p>
<!--- embedded instructions start here --->
<cfset department="Sales">
<cfoutput>
<p>Be sure to visit our #department# page.</p>
</cfoutput>
<!--- embedded instructions end here --->

</body>
</html>
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The embedded instructions on this page perform the following actions: 

1. Create a variable called department and assign the string "Sales" to it.

2. Insert the variable’s value, "Sales", in the HTML code. 

The application server returns the following page to the web server:
<html>

<head>
<title>Trio Motors Information Page</title>

</head>
<body>

<h1>About Trio Motors</h1>
<p>Trio Motors is a leading automobile manufacturer.</p>
<p>Be sure to visit our Sales page.</p>

</body>
</html>

The web server sends the page to the requesting browser, which displays it 
as follows:

About Trio Motors

Trio Motors is a leading automobile manufacturer.
Be sure to visit our Sales page.

You choose a scripting or tag-based language to use depending on the 
server technology available on your server. Here are the most popular 
languages for the five server technologies supported by Dreamweaver: 

For more information, see “Choosing a server technology” on page 226.

Dreamweaver can create the server-side scripts or tags necessary to make 
your pages work, or you can write them by hand in the Dreamweaver 
coding environment.

Server technology Language

ColdFusion ColdFusion Markup Language (CFML)

ASP.NET Visual Basic
C#

Active Server Pages (ASP) VBScript
JavaScript

Java Server Pages (JSP) Java

PHP PHP
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Choosing a server technology
You can use Dreamweaver to build web applications using any of five server 
technologies: ColdFusion, ASP.NET, ASP, JSP, or PHP. Each of these 
technologies corresponds to a document type in Dreamweaver. Choosing 
one for your web application depends on several factors, including your 
level of comfort with various scripting languages and the application server 
you plan to use.

If you’re new to web application development or to application 
development in general, you’ll probably prefer ColdFusion because it 
provides an easy-to-learn server scripting environment that’s also tightly 
integrated with Dreamweaver. If you’re familiar with other server 
technologies, such as JSP, PHP, ASP, or ASP.NET, Dreamweaver offers 
great support for these as well.

Which server technology you choose also depends on the application server 
you plan to use for your web application. An application server is software 
that helps a web server process web pages containing server-side scripts or 
tags. For example, if you have ColdFusion MX 7 Server, you can choose 
ColdFusion as your server technology. If you have access to a server 
running Microsoft Internet Information Server 5 (IIS) with the .NET 
Framework, you can choose ASP.NET. PHP is an option if you have access 
to a web server with a PHP application server; JSP is an option if you have 
access to a web server with a JSP application server (such as Macromedia 
JRun).

A developer edition of ColdFusion MX 7 is available on the Dreamweaver 
CD (Windows version only) and on the Macromedia website at 
www.macromedia.com/go/coldfusion/.

For more information, see “Setting up an application server” in 
Using Dreamweaver.

To learn more about ColdFusion, select Using ColdFusion from the Help 
menu.

To learn more about ASP.NET, visit the Microsoft website at http://
msdn.microsoft.com/asp.net/.

To learn more about ASP, visit the Microsoft website at http://
msdn.microsoft.com/library/default.asp?url=/library/en-us/dnanchor/
html/activeservpages.asp.
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To learn more about JSP, visit the Sun Microsystems website at 
java.sun.com/products/jsp/.

To learn more about PHP, visit the PHP website at www.php.net/.

Web application terminology
This section defines frequently used terms relating to web applications.

An application server is software that helps a web server process web pages 
containing server-side scripts or tags. When such a page is requested from 
the server, the web server hands the page off to the application server for 
processing before sending the page to the browser. For more information, 
see “How a web application works” on page 219. 

Common application servers include Macromedia ColdFusion, 
Macromedia JRun Server, the Microsoft .NET Framework, IBM 
WebSphere, and Apache Tomcat. 

A database is a collection of data stored in tables. Each row of a table 
constitutes one record and each column constitutes a field in the record, as 
shown in the following example. 

A database driver is software that acts as an interpreter between a web 
application and a database. Data in a database is stored in a proprietary 
format. A database driver lets the web application read and manipulate 
data that would otherwise be undecipherable.

A database management system (DBMS, or database system) is software 
used to create and manipulate databases. Common database systems 
include Microsoft Access, Oracle 9i, and MySQL.

A database query is the operation that extracts a recordset from a 
database. A query consists of search criteria expressed in a database 
language called SQL. For example, the query can specify that only certain 
columns or only certain records be included in the recordset.

Number LastName FirstName Position Goal

Records
(rows)

Fields (columns)
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A dynamic page is a web page customized by an application server before 
the page is sent to a browser. For more information, see “How a web 
application works” on page 219. 

A recordset is a set of data extracted from one or more tables in a database, 
as in the following example: 

A relational database is a database containing more than one table, with 
the tables sharing data. The following database is relational because two 
tables share the DepartmentID column. 

A server technology is the technology that an application server uses to 
modify dynamic pages at runtime. 

Number

Database table

LastName FirstName Position Goals

Recordset table

LastName FirstName Position
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The Dreamweaver development environment supports the following server 
technologies:

■ Macromedia ColdFusion
■ Microsoft ASP.NET
■ Microsoft Active Server Pages (ASP)
■ Sun Java Server Pages (JSP)
■ PHP: Hypertext Preprocessor (PHP) 

You can also use the Dreamweaver coding environment to develop pages 
for any other server technology not listed.

A static page is a web page that is not modified by an application server 
before the page is sent to a browser. For more information, see “Processing 
static web pages” on page 219. 

A web application is a website that contains pages with partly or entirely 
undetermined content. The final content of these pages is determined only 
when a visitor requests a page from the web server. Because the final 
content of the page varies from request to request based on the visitor’s 
actions, this kind of page is called a dynamic page.

A web server is software that sends out web pages in response to requests 
from web browsers. A page request is generated when a visitor clicks a link 
on a web page in the browser, selects a bookmark in the browser, or enters a 
URL in the browser’s address text box. 

Popular web servers include Microsoft Internet Information Server, 
Microsoft Personal Web Server, Apache HTTP Server, Netscape Enterprise 
Server, and Sun ONE Web Server. 
Web application terminology 229



230 Understanding Web Applications



N
O

T
E

B
APPENDIX B

Installing a Web Server
To develop and test dynamic web pages, you need a functioning web server. 
This chapter describes how most Windows users can install and use a 
Microsoft web server on their local computer.

If you’re a Windows user and you want to develop ColdFusion sites, you 
can use the web server included in the developer edition of the 
Macromedia ColdFusion MX 7 application server, which you can install 
and use for free. For more information, see Appendix C, “Setup for Sample 
ColdFusion Site,” on page 237.

If you’re a Macintosh user, you can use a web server on a network computer 
or a web hosting company. If you want to develop PHP applications, you 
can use the Apache web server already installed on your Macintosh.

This chapter contains the following sections:
Getting started  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 231

Installing Internet Information Server. . . . . . . . . . . . . . . . . . . . . . . 232

Testing IIS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 233

Testing the Macintosh web server (PHP developers) . . . . . . . . 233

Web server basics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 234

Getting started
If you’re a Windows user, you can install and run Internet Information 
Server (IIS) on your system. You can also install the web server on a 
networked Windows computer so other developers on your team can 
use it. 

Macromedia does not provide technical support for third-party software 
such as Microsoft Internet Information Server. If you need assistance with 
a Microsoft product, please contact Microsoft technical support.
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If you’re a Windows user and want to develop ColdFusion applications, 
you can instead use the web server installed with the developer edition of 
the ColdFusion MX 7. For more information, see Appendix C, “Setup for 
Sample ColdFusion Site,” on page 237.

IIS may already be installed on your computer. Check your folder structure 
to see if it contains a C:\Inetpub or D:\Inetpub folder. IIS creates this 
folder during installation. 

If the folder does not exist, install IIS. For more information, see 
“Installing Internet Information Server” on page 232.

If you’re a Macintosh user interested in developing PHP applications, you 
can use the Apache web server already installed on your Macintosh. For 
more information, see “Testing the Macintosh web server (PHP 
developers)” on page 233.

Installing Internet Information 
Server
Windows 2000 and Windows XP Professional users should install Internet 
Information Server (IIS).

If you’re a Windows 2000 or Windows XP Professional user, check 
whether IIS is already installed and running on your system. The way to do 
this is to look for the C:\Inetpub folder. If it doesn’t exist, IIS is probably 
not installed on your system.

To install IIS on Windows 2000 and XP Professional:

1. Select Start > Settings > Control Panel > Add or Remove Programs, or 
Start > Control Panel > Add or Remove Programs.

2. Select Add/Remove Windows Components.

3. Select Internet Information Services (IIS) and click Next. 

4. Follow the installation instructions.

You can test the web server after installing it.
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Testing IIS
To test the web server, create a simple HTML page called myTestFile.html 
and save it in the Inetpub\wwwroot folder on the computer where the web 
server is running. The HTML page can consist of a single line, such as:
<p>My web server is working.</p> 

Next, open the test page in a web browser with an HTTP request. If IIS is 
running on your local computer, enter the following URL in your web 
browser:

http://localhost/myTestFile.html

If IIS is running on a networked computer, use the networked computer’s 
name as the domain name. For example, if the name of the computer 
running IIS is rockford-pc, enter the following URL in your browser:

http://rockford-pc/myTestFile.html

If the browser displays your page, the web server is running normally. 

If the browser fails to display the page, make sure the server is running. If 
the page still fails to open, make sure your test page is located in the 
Inetpub\wwwroot folder and has a .htm or .html file extension.

Testing the Macintosh web 
server (PHP developers)
You can use the Apache web server already installed on your Macintosh to 
develop PHP applications.

To test the server, create a simple HTML page called myTestFile.html and 
save it in the /Users/your_user_name/Sites/ folder on your Macintosh 
(where your_user_name is your Macintosh user name). The HTML page 
can consist of a single line, such as: 
<p>My web server is working.</p> 

For more information on computer names, see “Web server basics” 
on page 234. 
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Next, open the test page in a web browser with an HTTP request by 
entering the following URL in your web browser:

http://localhost/~your_user_name/myTestFile.html

If the browser displays your page, the web server is running normally. If the 
browser fails to display the page, make sure the web server is started by 
opening System Preferences and looking at the Sharing preference panel. 
The Personal Web Sharing option should be enabled.

Your Apache web server won’t work with PHP by default; you must 
configure it before you can use PHP. For more information, see 
“Configuring your system (PHP)” on page 302.

Web server basics
A web server is software that serves web pages in response to requests from 
web browsers. A web server is sometimes called an HTTP server.

Suppose you use IIS to develop web applications. The default name of your 
web server is the name of your computer. You can change the server name 
by changing the name of your computer. If your computer has no name, 
the server uses the word localhost. 

The server name corresponds to the server’s root folder, which (on a 
Windows computer) is most likely C:\Inetpub\wwwroot. You can open 
any web page stored in the root folder by entering the following URL in a 
browser running on your computer:

http://your_server_name/your_file_name 

For example, if the server name is mer_noire and a web page called 
soleil.html is stored in C:\Inetpub\wwwroot\, you can open the page by 
entering the following URL in a browser running on the local computer:

http://mer_noire/soleil.html
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By default the Apache server runs on port 80.
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Remember to use forward slashes, not backslashes, in URLs.
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You can also open any web page stored in any subfolder of the root folder 
by specifying the subfolder in the URL. For example, suppose the 
soleil.html file is stored in a subfolder called gamelan, as follows:

C:\Inetpub\wwwroot\gamelan\soleil.html

You can open this page by entering the following URL in a browser 
running on your computer:

http://mer_noire/gamelan/soleil.html

When the web server is running on your computer, you can replace the 
server name with localhost. For example, the following URLs open the 
same page in a browser:

http://mer_noire/gamelan/soleil.html

http://localhost/gamelan/soleil.html

Another expression you can use instead of the server name or localhost is 
127.0.0.1 (for example, http://127.0.0.1/gamelan/soleil.html).
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APPENDIX C

Setup for Sample 
ColdFusion Site
Macromedia Dreamweaver 8 comes with sample ColdFusion pages to let 
you build a small web application. This chapter describes how to set up the 
sample application. 

Setting up a web application is a three-step process. First, configure your 
system. Second, define a Dreamweaver site. Third, connect the application 
to your database. This setup guide follows this three-step process. 

This chapter contains the following sections:
Setup checklists for ColdFusion developers . . . . . . . . . . . . . . . . .237

Configuring your system (ColdFusion)  . . . . . . . . . . . . . . . . . . . . . 238

Defining a Dreamweaver site (ColdFusion) . . . . . . . . . . . . . . . . . 244

Connecting to the sample database (ColdFusion) . . . . . . . . . . . 250

Setup checklists for ColdFusion 
developers
To set up a web application, you must configure your system, define a 
Dreamweaver site, and connect to a database. This section provides 
checklists for each task. The tasks are described in more detail in the rest of 
the chapter.

Configure your system:

1. Install the ColdFusion application server (which includes a web server).

2. Create a root folder. 
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Define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk.

2. Define the folder as a Dreamweaver local folder.

3. Define a web server folder as a Dreamweaver remote folder.

4. Specify a folder to process dynamic pages.

5. Upload the sample files to the web server.

Connect to the database:

1. If you’re using a remote computer as a server, copy the sample database 
to the remote computer.

2. Create the connection in Dreamweaver.

Configuring your system 
(ColdFusion)
This section provides instructions for two common system configurations: 
one in which ColdFusion is installed on your hard disk, and one in which 
ColdFusion is installed on a remote Windows computer. To use a different 
configuration, see , “Setting up a web application” in Using Dreamweaver. 
238 Setup for Sample ColdFusion Site



N
O

T
E

The following illustration shows the two configurations described in this 
section: 

To configure your system:

1. Install the ColdFusion application server.

2. Create a root folder. 

Network or 
ftp access

WINDOWS PC

Local configuration
(for Windows users only)

Remote server configuration
(for Macintosh or Windows users)

Dreamweaver

ColdFusion Server

Website root folder in
c:\Inetpub\wwwroot\

Website root folder in
c:\Inetpub\wwwroot\

MAC or WINDOWS PC

Dreamweaver

WINDOWS SERVER

ColdFusion Server

Installing the application server is a one-time-only task.
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Installing ColdFusion MX 7
To process dynamic web pages, you need a web server and an application 
server. ColdFusion MX 7 provides both. A web server is software that 
serves web pages in response to requests from web browsers. An application 
server is software that helps a web server process web pages that contain 
server-side scripts or tags. When such a page is requested by a browser, the 
web server hands the page off to the application server for processing before 
sending the page to the browser. For more information, see 
“Understanding Web Applications” on page 217. 

You can download and install a fully functional developer edition of 
ColdFusion MX 7 from the Macromedia website at 
www.macromedia.com/go/coldfusion/. Make sure you select the Windows 
version of the ColdFusion MX 7 Developer Edition. A copy of 
ColdFusion MX 7 Developer Edition is also available on the Dreamweaver 
CD (Windows version only). 
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You can also install ColdFusion on a Mac OS X computer running a J2EE 
server such as JRun or Tomcat. For more information, see the 
Macromedia website at www.macromedia.com/go/cfmx7_mac. The 
installation process is complicated, though, and Dreamweaver was not 
tested with ColdFusion on the Macintosh. Also, it may be difficult to 
connect ColdFusion on the Macintosh to database servers such as 
MySQL.
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To install ColdFusion MX 7:

1. If applicable, log in to your Windows system using the Administrator 
user account.

2. Close all open applications.

3. Double-click the ColdFusion MX 7 installer file.

4. Follow the onscreen installation instructions.

Some screens in the installation wizard are self-explanatory. For the 
following screens, however, select the following options:
■ At the Installer Configuration screen, select the Server 

Configuration option.
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■ At the Select Installation Directory screen, accept the default 
C:\CFusionMX7 folder by clicking Next.

■ At the Configure Web Server screen, select the Built-in Web Server 
option at the bottom of the screen.
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■ At the RDS Password screen, make sure the Enable RDS option is 
selected, and then enter and confirm a password.

For more information, see the ColdFusion documentation in 
Dreamweaver (Help > Using ColdFusion).

After installing and starting ColdFusion, create a root folder for your web 
application. 

Creating a root folder
After the server software is installed, create a root folder for your web 
application on the system running ColdFusion, and make sure the folder 
has the necessary permissions. 

To create a root folder for your web application:

■ Create a folder called MySampleApps in the CFusionMX7\wwwroot 
folder on the system running ColdFusion.

Write down this folder name for later use. When you type it later, be sure to 
use exactly the same capitalization that you used when you created it. 
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By default, ColdFusion sets up its web server to serve pages from the 
CFusionMX7\wwwroot folder. The web server will serve any page in this 
folder or in any of its subfolders in response to an HTTP request from a 
web browser.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site 
(ColdFusion)
After you configure your system, copy the sample files to a local folder and 
define a Dreamweaver site to manage the files. 

To define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk (see “Copying the 
sample files” on page 245).

2. Define the folder as a Dreamweaver local folder (see “Defining a local 
folder” on page 246).

3. Define your root folder on the web server as a Dreamweaver remote 
folder (see “Defining a remote folder” on page 247).

4. Specify a folder to process dynamic pages (see “Specifying where to 
process dynamic pages” on page 248).

5. Upload the sample files to the web server (see “Uploading the sample 
files” on page 249).
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Copying the sample files
If you haven’t already done so, copy the sample files from the Dreamweaver 
application folder to a folder on your hard disk.

To copy the sample files:

1. Create a new folder called local_sites in your user folder on your hard 
disk.

For example, create one of the following folders:
■ C:\Documents and Settings\your_user_name\My 

Documents\local_sites (Windows)
■ /Users/your_user_name/Documents/local_sites (Macintosh).

2. Locate the cafe_townsend folder in the Dreamweaver application folder 
on your hard disk.

If you installed Dreamweaver to its default location, the path to the 
folder is as follows:
■ In Windows: C:\Program Files\Macromedia\Dreamweaver 

8\Tutorial_assets\cafe_townsend\
■ On the Macintosh: Macintosh HD/Applications/Macromedia 

Dreamweaver 8/Tutorial_assets/cafe_townsend
3. Copy the cafe_townsend folder into the local_sites folder. 

The cafe_townsend folder is the folder that you will use as the root 
folder (main folder) for your Dreamweaver site.

After you copy the cafe_townsend folder, define the folder as a 
Dreamweaver local folder.

On the Macintosh, there’s a folder called Sites already in your user folder. 
Don’t use that Sites folder as your local folder; the Sites folder is where 
you place your pages to make them publicly accessible when you’re using 
the Macintosh as a web server.
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Defining a local folder
After you copy the cafe_townsend folder, define the folder that contains 
the ColdFusion sample files as a Dreamweaver local folder. 

To define the Dreamweaver local folder:

1. In Dreamweaver, select Site > Manage Sites. 

In the Manage Sites dialog box, click New, and then select Site.
The Site Definition dialog box appears. 

2. If the Basic tab is showing, click the Advanced tab.

3. In the Site Name text box, enter Cafe Townsend ColdFusion.

The name identifies your site within Dreamweaver. 
4. Click the folder icon next to the Local Root Folder text box and browse 

to the following folder, which contains the ColdFusion sample files:

■ C:\Documents and Settings\your_user_name\My 
Documents\local_sites\cafe_townsend \contact\coldfusion 
(Windows)

■ /Users/your_user_name/Documents/local_sites/cafe_townsend/
contact/coldfusion (Macintosh)

5. Click Select to finish defining the Dreamweaver local folder.

Leave the Site Definition dialog box open. Next, define a web server folder 
as a Dreamweaver remote folder. 
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Defining a remote folder
After you define a local folder, define a web server folder as a Dreamweaver 
remote folder. 

To define the Dreamweaver remote folder:

1. In the Advanced tab of the Site Definition dialog box, select Remote 
Info from the Category list. 

The Remote Info screen appears.
2. In the Access pop-up menu, choose how you want to move your files to 

and from the server: across a local network (the Local/Network option), 
or by using FTP.

3. Enter the path or FTP settings to the web server folder you created in 
“Creating a root folder” on page 243.

The folder may be on your hard disk or on a remote computer. Even if 
you created the folder on your hard disk, that folder is still considered 
to be the remote folder. The following example shows a possible 
Remote Folder path if you chose Local/Network access and your 
remote folder is on your Windows hard disk:
Remote Folder: C:\CFusionMX7\wwwroot\MySampleApps
For more information about FTP, see “Setting Remote options for FTP 
access” in Using Dreamweaver Help. 

Leave the Site Definition dialog box open. Next, define a folder to process 
dynamic pages. 

There are other options in the Access pop-up menu, but this guide doesn’t 
cover them. For information about the other options, see Using 
Dreamweaver.
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Specifying where to process dynamic 
pages
After you define the Dreamweaver remote folder, specify a folder to process 
dynamic pages. Dreamweaver uses this folder to display dynamic pages and 
connect to databases while you’re developing your application. 

To specify the folder to process dynamic pages:

1. In the advanced Site Definition dialog box, click Testing Server in the 
Category list.

The Testing Server screen appears. Dreamweaver needs the services of a 
testing server to generate and display dynamic content while you work. 
The testing server can be your local computer, a development server, a 
staging server, or a production server, as long as it can process 
ColdFusion pages. In many situations, including setting up for the 
Cafe Townsend site, you can use the same settings as the Remote Info 
category (see “Defining a remote folder” on page 247) because they 
point to a server capable of processing ColdFusion pages.

2. Select ColdFusion from the Server Model pop-up menu.

3. In the Access pop-up menu, select the same method (Local/Network or 
FTP) that you specified for accessing your remote folder.

Dreamweaver enters the settings you specified in the Remote Info 
category. Leave the settings unchanged.

4. In the URL Prefix text box, enter the root URL you would enter in a 
web browser to request a page in your web application.

To display live data in your pages while you work, Dreamweaver creates 
a temporary file, copies it to the website’s root folder, and attempts to 
request it by using the URL prefix. 
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Dreamweaver makes a best guess at the URL prefix based on the 
information you provided in the Site Definition dialog box. However, if the 
suggested URL prefix is incorrect, correct the URL or enter a new URL 
prefix. For more information, see “Setting the URL prefix” in Using 
Dreamweaver.
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If the folder specified in the Remote Folder text box is 
c:\CFusionMX7\wwwroot\MySampleApps, the URL prefix should be 
as follows:
http://localhost:8500/MySampleApps/

5. Click OK to define the site and dismiss the Site Definition dialog box, 
and then click Done to dismiss the Manage Sites dialog box.

After you specify a folder to process dynamic pages, upload the sample files 
to the web server.

Uploading the sample files 
After you specify a folder to process dynamic pages, upload the sample files 
to the web server. You must upload the files even if the web server is 
running on your local computer. 

If you don’t upload the files, features such as Live Data view and Preview in 
Browser may not work properly with dynamic pages. For example, image 
links might be broken in Live Data view because the image files are not on 
the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser causes an error if the detail page is missing from 
the server.

To upload the samples files to the web server:

1. In the Files panel (Window > Files), select the root folder of the site in 
the Local View pane.

The root folder is the topmost folder in the list.
2. Click the blue Put Files arrow icon in the Files panel toolbar, and 

confirm that you want to upload the entire site.

Dreamweaver copies all of the files to the web server folder you defined 
in “Defining a remote folder” on page 247. 

The Dreamweaver site is now defined. The next step is to connect to the 
sample database installed with Dreamweaver.

The ColdFusion web server runs on port 8500 by default.
T

IP The URL prefix 
should always 
specify a folder, 
rather than a 
particular page on 
the site. Also, be sure 
to use the same 
capitalization you 
used when you 
created the folder.
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Connecting to the sample 
database (ColdFusion)
During installation, Dreamweaver copies a sample Microsoft Access 
database to your hard disk. This section describes how to create a 
connection to the sample database.

To create a database connection:

1. If you’re using a remote computer as a server, copy the sample database 
to the remote computer. (See “Setting up the database (server on a 
remote computer)” on page 250).

2. Create a ColdFusion data source and view the connection in 
Dreamweaver (see “Connecting to the database” on page 251).

Setting up the database (server on a 
remote computer)
This section applies only if your web server is running on a remote 
computer. If your web server is running on the same computer as 
Dreamweaver, skip to “Connecting to the database” on page 251.

Before you attempt to connect to the sample database, copy the database to 
the remote computer’s hard disk. If you installed Dreamweaver to its 
default location, the path on your local hard disk to the database file 
(tutorial.mdb) is as follows:

■ C:\Program 
Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data
\tutorial.mdb (Windows)

■ /Applications/Macromedia Dreamweaver 8/Tutorial_assets/
cafe_townsend/data/tutorial.mdb (Macintosh)
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For information about connecting to another database, see “Database 
Connections for ColdFusion Developers” in Using Dreamweaver.
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You can place the file in any folder on the remote computer, or you can 
create a new folder for it.

After the database is in place, create a ColdFusion data source. 

Connecting to the database
To connect to the database, you must create a ColdFusion data source 
called connTownsend that points to the sample database file. 

To connect to the database:

1. In Dreamweaver, open a ColdFusion page like send.cfm and view.cfm.

2. In the Databases panel (Window > Databases), click the “RDS login” 
link, enter your RDS password, and click OK.

3. Click Plus (+) on the Databases panel toolbar and select Microsoft 
Access Connection from the pop-up menu.

4. In the CF Data Source Name text box, enter connTownsend.

5. In the Database File text box, enter the path to the tutorial.mdb 
database file. 

If ColdFusion is running on your local computer and you installed 
Dreamweaver to its default location, the path is as follows:
C:\Program Files\Macromedia\Dreamweaver 
8\Tutorial_assets\cafe_townsend\data\tutorial.mdb

There are potential security issues if you place the database file inside the 
Inetpub folder on the remote computer. It’s better to place the file in a 
folder that’s not publicly accessible.

If the Plus button appears on the Databases panel, restart Dreamweaver.
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If ColdFusion is running on a remote computer, enter the path to the 
database file you placed on the remote computer in “Setting up the 
database (server on a remote computer)” on page 250.
For more information, see the ColdFusion documentation in 
Dreamweaver (Help > Using ColdFusion). 

6. Click OK to create the connection.

The connection appears in the Databases panel.

If the connection does not appear in the panel, do one of the following:
■ Check the settings for the folder that Dreamweaver uses to process 

dynamic pages (see “Specifying where to process dynamic pages” 
on page 248).

■ Consult “Troubleshooting Database Connections” in Using 
Dreamweaver (Help > Using Dreamweaver).
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7. Expand the connTownsend branch, and then expand the Tables 
branch. 

If the Tables branch contains three tables as follows, the sample 
ColdFusion application is set up for the Getting Started with 
Dreamweaver tutorials. For more information, see “Tutorial: 
Developing a Web Application” on page 197.

If the Tables branch does not contain the tables, click the Modify Data 
Sources icon in the Databases panel toolbar and double-check the 
connection parameters in Configuring and Administering ColdFusion 
MX. In particular, make sure the path to the database file is correct.
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APPENDIX D

Setup for Sample 
ASP.NET Site
Macromedia Dreamweaver 8 comes with sample ASP.NET pages to let you 
build a small web application. This chapter describes one way to set up the 
sample application.

This chapter applies to ASP.NET developers. For information on ASP, see 
“Setup for Sample ASP Site” on page 269.

Setting up a web application is a three-step process. First, configure your 
system. Second, define a Dreamweaver site. Third, connect the application 
to your database. This setup chapter follows this three-step process. 

This chapter contains the following sections:
Setup checklists for ASP.NET developers. . . . . . . . . . . . . . . . . . 255

Configuring your system (ASP.NET). . . . . . . . . . . . . . . . . . . . . . . 256

Defining a Dreamweaver site (ASP.NET). . . . . . . . . . . . . . . . . . . 260

Connecting to the sample database (ASP.NET)  . . . . . . . . . . . . 265

Setup checklists for ASP.NET 
developers
To set up a web application, you must configure your system, define a 
Dreamweaver site, and connect to a database. This section provides 
checklists for each task. The tasks are described in more detail in the rest of 
the chapter.

Configure your system:

1. Make sure you have a web server.

2. Install the Microsoft .NET Framework.

3. Create a root folder. 
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Define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk.

2. Define the folder as a Dreamweaver local folder.

3. Define a web server folder as a Dreamweaver remote folder.

4. Specify a folder to process dynamic pages.

5. Upload the sample files to the web server.

Connect to the database:

1. If you’re using a remote computer as a server, copy the sample database 
to the remote computer.

2. Create the connection in Dreamweaver.

Configuring your system 
(ASP.NET)
This section provides instructions for two common system configurations: 
one in which Windows 2000 or Windows XP Professional is installed on 
your hard disk, and one in which Windows 2000 or Windows XP 
Professional is installed on a remote computer. If you want to use a 
different configuration, see Chapter 23, “Setting Up a Web Application,” 
in Using Dreamweaver.
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The following illustration shows the two configurations described in this 
section: 

To configure your system:

1. Make sure you have a web server (see “Checking for a web server” 
on page 258).

2. Install the .NET Framework (see “Installing the .NET Framework” 
on page 258).

3. Create a root folder (see “Creating a root folder” on page 259). 

Network or 
ftp access

WINDOWS 2000 or XP

Local configuration
(for Windows 2000 or XP users only)

Remote server configuration
(for Macintosh or Windows users)

Dreamweaver

IIS 5 or higher

.NET Framework

Website root folder in
c:\Inetpub\wwwroot\

Website root folder in
c:\Inetpub\wwwroot\

MAC or WINDOWS PC

Dreamweaver

WINDOWS SERVER

IIS 5 or higher

.NET Framework

Installing the web server and the .NET Framework are one-time-only 
tasks.
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Checking for a web server 
To develop and test dynamic web pages, you need a web server. A web 
server is software that serves web pages in response to requests from web 
browsers.

ASP.NET pages work with only one web server: Microsoft IIS 5 or later. 
IIS 5 is a service of the Windows 2000 and Windows XP Professional 
operating systems, so you can use these two versions of Windows to run 
ASP.NET applications.

Make sure IIS 5 is installed and running on a computer running Windows 
2000 or Windows XP Professional. You can use your local computer as the 
server if you have Windows 2000 or Windows XP Professional.

A quick way to check whether IIS is installed on a computer is to look at 
the folder structure to see whether it contains a C:\Inetpub or D:\Inetpub 
folder. IIS creates this folder during installation.

If IIS is not installed, install it now. For more information, see “Installing 
Internet Information Server” on page 232.

After installing the web server, install the .NET Framework. 

Installing the .NET Framework
To process dynamic web pages, you need an application server. An 
application server is software that helps a web server process web pages 
containing server-side scripts or tags. When such a page is requested by a 
browser, the web server hands the page off to the application server for 
processing before sending the page to the browser. For more information, 
see “Understanding Web Applications” on page 217. 

In ASP.NET, the application server is called the Microsoft .NET 
Framework 1.1. To develop ASP.NET web applications, you also need to 
install the Microsoft .NET Framework 1.1 Software Development Kit 
(SDK). Make sure both the Framework and the SDK is installed and 
running on a Windows 2000 or Windows XP Professional system running 
IIS 5 or higher. 
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To install the .NET Framework and SDK:

1. Check to see if the .NET Framework is installed on your system by 
reviewing the list of applications in the Add or Remove Programs dialog 
box (Start > Control Panel > Add or Remove Programs).

If Microsoft .NET Framework 1.1 is listed, the Framework is already 
installed and you do not need to install it again. Skip to step 3.

2. If the .NET Framework is not installed on your system, install the 
Microsoft .NET Framework 1.1 Redistributable package from the 
Microsoft website at http://msdn.microsoft.com/netframework/
downloads/framework1_1/ and follow the installation instructions on 
the website.

You install the Framework as a Windows update.
3. Download the Microsoft .NET Framework 1.1 Software Development 

Kit (SDK) from the same website and follow the installation 
instructions.

After installing the Framework and SDK, create a root folder for your web 
application. 

Creating a root folder
After the server software is installed, create a root folder for your web 
application on the system running Microsoft IIS, and make sure the folder 
has the necessary permissions. 

To create a root folder for your web application:

1. Create a folder called MySampleApps on the system running IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By 
default, your IIS web server is set up to serve pages from the 
Inetpub\wwwroot folder. The web server will serve any page in this 
folder or in any of its subfolders in response to an HTTP request from 
a web browser.

Write down this folder name for later use. When you type it later, be sure to 
use exactly the same capitalization that you used when you created it.
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2. To make sure the Scripts permission is enabled for the folder, start the 
IIS administrative tool (in Windows XP, select Start > Control Panel or 
Start > Settings > Control Panel, double-click Administrative Tools, and 
then double-click Internet Information Services). Expand the “local 
computer” list, followed by the Web Sites folder, and then the Default 
Web Site folder. Right-click your MySampleApps folder and select 
Properties from the pop-up menu. In the Execute Permissions pop-up 
menu, make sure the Scripts Only option is selected. (For security 
reasons, do not select the Scripts and Executables option.) Then click 
OK. 

The web server is now configured to serve web pages in your root folder in 
response to HTTP requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site 
(ASP.NET)
After configuring your system, copy the sample files to a local folder and 
define a Dreamweaver site to manage the files. 

To define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk (see “Copying the 
sample files” on page 261).

2. Define the folder as a Dreamweaver local folder (see “Defining a local 
folder” on page 262).

3. Define your root folder on the web server as a Dreamweaver remote 
folder (see “Defining a remote folder” on page 262).

4. Specify a folder to process dynamic pages (see “Specifying where 
dynamic pages can be processed” on page 263).

5. Upload the sample files to the web server (see “Uploading the sample 
files” on page 264).
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Copying the sample files
If you haven’t already done so, copy the sample files from the Dreamweaver 
application folder to a folder on your hard disk.

To copy the sample files:

1. Create a new folder called local_sites in your user folder on your hard 
disk.

For example, create one of the following folders:
■ C:\Documents and Setting\your_user_name\My 

Documents\local_sites (Windows)
■ /Users/your_user_name/Documents/local_sites (Macintosh).

2. Locate the cafe_townsend folder in the Dreamweaver application folder 
on your hard disk.

If you installed Dreamweaver to its default location, the path to the 
folder is as follows:
■ In Windows: C:\Program Files\Macromedia\Dreamweaver 

8\Tutorial_assets\ cafe_townsend\.
■ On the Macintosh: Macintosh HD/Applications/Macromedia 

Dreamweaver 8/Tutorial_assets/cafe_townsend.
3. Copy the cafe_townsend folder into the local_sites folder. 

The cafe_townsend folder is the folder that you will use as the root 
folder (main folder) for your Dreamweaver site.

After copying the cafe_townsend folder, define the folder as a 
Dreamweaver local folder.

On the Macintosh, there’s a folder called Sites already in your user folder. 
Don’t use that Sites folder as your local folder; the Sites folder is where 
you place your pages to make them publicly accessible when you’re using 
the Macintosh as a web server.
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Defining a local folder
After copying the cafe_townsend folder, define the folder containing the 
ASP.NET sample files as a Dreamweaver local folder. 

To define the Dreamweaver local folder:

1. In Dreamweaver, select Site > Manage Sites. In the Manage Sites dialog 
box, click the New button, and then select Site.

The Site Definition dialog box appears. 
2. If the Basic tab is showing, click the Advanced tab.

3. In the Site Name text box, enter Cafe Townsend ASP.NET.

The name identifies your site within Dreamweaver. 
4. Click the folder icon next to the Local Root Folder text box and browse 

to the following folder, which contains the ASP.NET sample files:

■ C:\Documents and Setting\your_user_name\My 
Documents\local_sites\cafe_townsend\contact\aspnet (Windows)

■ /Users/your_user_name/Documents/local_sites/cafe_townsend/
contact/aspnet (Macintosh)

5. Click Select to finish defining the Dreamweaver local folder.

Leave the Site Definition dialog box open. Next, define a web server folder 
as a Dreamweaver remote folder. 

Defining a remote folder
After defining a local folder, define a web server folder as a Dreamweaver 
remote folder. 

To define the Dreamweaver remote folder:

1. In the Advanced tab of the Site Definition dialog box, select Remote 
Info from the Category list. 

The Remote Info screen appears.
2. In the Access pop-up menu, choose how you want to move your files to 

and from the server: across a local network (the Local/Network option) 
or using FTP.
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There are other options in the Access pop-up menu, but this guide doesn’t 
cover them. For information about them, see Using Dreamweaver (Help > 
Using Dreamweaver).
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3. Enter the path or FTP settings to the web server folder you created in 
“Creating a root folder” on page 259.

The folder may be on your hard disk or on a remote computer. Even if 
you created the folder on your hard disk, that folder is still considered 
to be the remote folder. The following example shows a possible 
Remote Folder path if you chose Local/Network access and your 
remote folder is on your Windows hard disk:
Remote Folder: C:\Inetpub\wwwroot\MySampleApps
For more information on FTP, see “Setting Remote options for FTP 
access” in Using Dreamweaver Help. 

Leave the Site Definition dialog box open. Next, define a folder to process 
dynamic pages. 

Specifying where dynamic pages can be 
processed
After defining the Dreamweaver remote folder, specify a folder to process 
dynamic pages. Dreamweaver uses this folder to display dynamic pages and 
connect to databases while you’re developing your application. 

To specify the folder to process dynamic pages:

1. In the advanced Site Definition dialog box, click Testing Server in the 
Category list.

The Testing Server screen appears. Dreamweaver needs the services of a 
testing server to generate and display dynamic content while you work. 
The testing server can be your local computer, a development server, a 
staging server, or a production server, as long as it can process ASP.NET 
pages. In many situations, including setting up for the Cafe Townsend 
site, you can use the same settings as the Remote Info category (see 
“Defining a remote folder” on page 262) because they point to a server 
capable of processing ASP.NET pages.

2. Select ASP.NET VB or ASP.NET C# from the Server Model pop-up 
menu.

3. In the Access pop-up menu, select the same method (Local/Network or 
FTP) you specified for accessing your remote folder.

Dreamweaver enters the settings you specified in the Remote Info 
category. Leave the settings unchanged.
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4. In the URL Prefix text box, enter the root URL you would enter in a 
web browser to request a page in your web application. 

To display live data in your pages while you work, Dreamweaver creates 
a temporary file, copies it to the website’s root folder, and attempts to 
request it using the URL prefix. 
Dreamweaver makes a best guess at the URL prefix based on the 
information you provided in the Site Definition dialog box. However, 
the suggested URL prefix may be incorrect. Correct or enter a new 
URL prefix if the suggestion in Dreamweaver is incorrect. For more 
information, see “Setting the URL prefix” in Using Dreamweaver.
If the folder specified in the Remote Folder text box is 
C:\Inetpub\wwwroot\MySampleApps, the URL prefix should be as 
follows:
http://localhost/MySampleApps/

5. Click OK to define the site and dismiss the Site Definition dialog box, 
and then click Done to dismiss the Manage Sites dialog box.

After specifying a folder to process dynamic pages, upload the sample files 
to the web server.

Uploading the sample files 
After specifying a folder to process dynamic pages, upload the sample files 
to the web server. You must upload the files even if the web server is 
running on your local computer. 

If you don’t upload the files, features such as Live Data view and Preview in 
Browser may not work properly with dynamic pages. For example, image 
links might be broken in Live Data view because the image files are not on 
the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing 
from the server.

T
IP The URL prefix 

should always 
specify a directory, 
rather than a 
particular page on 
the site. Also, be sure 
to use the same 
capitalization you 
used when you 
created the folder.
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To upload the samples files to the web server:

1. In the Files panel (Window > Files), select the root folder of the site in 
the Local View pane.

The root folder is the topmost folder in the list. 
2. Click the blue Put Files arrow icon in the Files panel toolbar, and 

confirm that you want to upload the entire site.

Dreamweaver copies all the files to the web server folder you defined in 
“Defining a remote folder” on page 262. 

The Dreamweaver site is now defined. The next step is to connect to the 
sample database installed with Dreamweaver.

Connecting to the sample 
database (ASP.NET)
During installation, Dreamweaver copies a sample Microsoft Access 
database to your hard disk. This section describes how to create a 
connection to the sample database. 

To create a database connection:

1. If you’re using a remote computer as a server, copy the sample database 
to the remote computer. (See “Setting up the database (server on remote 
computer)” on page 265).

2. Create the connection in Dreamweaver (see “Creating a database 
connection” on page 266).

Setting up the database (server on remote 
computer)
This section applies only if your web server is running on a remote 
computer. If your web server is running on the same computer as 
Dreamweaver, skip to “Creating a database connection” on page 266.

For information on connecting to another database, see Chapter 25, 
“Database Connections for ASP.NET Developers,” in Using Dreamweaver 
(Help > Using Dreamweaver).
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Before attempting to connect to the sample database, copy the database to 
the remote computer’s hard disk. If you installed Dreamweaver to its 
default location, the path on your local hard disk to the database file 
(tutorial.mdb) is as follows:

■ C:\Program 
Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\data
\tutorial.mdb (Windows)

■ /Applications/Macromedia Dreamweaver 8/Tutorial_assets/
cafe_townsend/data/tutorial.mdb (Macintosh)

You can place the file in any folder on the remote computer, or you can 
create a new folder for it. In either case, write down the full path to the 
database file on a piece of paper.

After the database is in place, connect to it. 

Creating a database connection 
The final step of the setup process is to create a connection to the database.

To create a database connection in Dreamweaver:

1. Open any ASP.NET page in Dreamweaver, and then open the 
Databases panel (Window > Databases).

2. Click the Plus (+) button in the Databases panel and select OLE DB 
Connection from the pop-up menu.

The OLE DB Connection dialog box appears.
3. Enter connTownsend as the connection name.

4. Click the Templates button.

The Connection String Template dialog box appears.
5. From the list of templates, select Microsoft Access 2000 (Microsoft Jet 

4.0 Provider) and click OK.

Dreamweaver adds a connection string template in the OLE DB 
Connection dialog box. The template contains placeholders for missing 
information in the connection string.
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There are potential security issues if you place the database file inside the 
Inetpub folder on the remote computer. It’s better to place the file in a 
folder that’s not publicly accessible.
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6. In the Data Source text box, enter the full path to the sample database 
file on your hard disk or the remote computer’s hard disk. If ASP.NET 
is running on your local computer and you installed Dreamweaver to its 
default location, use the following path:

C:\Program 
Files\Macromedia\Dreamweaver 8\Tutorial_assets\data\tutorial.mdb

For example, you might enter this path as the value of Data Source for 
a database on your local hard disk:
Data Source=C:\Program Files\Macromedia\Dreamweaver 8\Tutorial_
assets\data\tutorial.mdb;
Or you might enter this path for a database on a remote server: 
Data Source=C:\users\Denman\Sites\data\tutorial.mdb;

7. Delete the User ID and the Password lines.

The Access database does not require a user ID or password.
8. Click Test.

Dreamweaver attempts to connect to the database. If the connection 
fails, do the following:
■ Double-check the path to the database. 
■ Check the settings for the folder Dreamweaver uses to process 

dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 263).

■ Deploy the supporting files by selecting Site > Advanced > Deploy 
Supporting Files.

■ Consult Chapter 29, “Troubleshooting Database Connections,” in 
Using Dreamweaver (Help > Using Dreamweaver).

9. Click OK.

The new connection appears in the Databases panel.

The sample ASP.NET application is now set up for the Getting Started with 
Dreamweaver tutorials. For more information, see “Tutorial: Developing a 
Web Application” on page 197.

The path may vary depending on where you installed Dreamweaver.
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APPENDIX E

Setup for Sample ASP 
Site
Macromedia Dreamweaver 8 comes with sample Microsoft Active Server 
Pages (ASP) web pages to let you build a small web application. This 
chapter describes how to set up the sample application using Microsoft 
Internet Information Server (IIS). For more information on this web 
server, see “Installing a Web Server” on page 231.

This chapter applies to ASP developers only. For information on ASP.NET, 
see “Setup for Sample ASP.NET Site” on page 255.

Setting up a web application is a three-step process. First, configure your 
system. Second, define a Dreamweaver site. Third, connect the application 
to your database. This setup chapter follows this three-step process. 

This chapter contains the following sections:
Setup checklists for ASP developers  . . . . . . . . . . . . . . . . . . . . . . 269

Configuring your system (ASP)  . . . . . . . . . . . . . . . . . . . . . . . . . . . .270

Defining a Dreamweaver site (ASP)  . . . . . . . . . . . . . . . . . . . . . . . .275 

Connecting to the sample database (ASP)  . . . . . . . . . . . . . . . . . 280

Setup checklists for ASP 
developers
To set up a web application, you must configure your system, define a 
Dreamweaver site, and connect to a database. This section provides 
checklists for each task. The tasks are described in more detail in the rest of 
the chapter.
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Configure your system:

1. Make sure you have a web server.

2. Install an application server.

3. Test your installation.

4. Create a root folder. 

Define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk.

2. Define the folder as a Dreamweaver local folder.

3. Define a web server folder as a Dreamweaver remote folder.

4. Specify a folder to process dynamic pages.

5. Upload the sample files to the web server.

Connect to the database:

1. If you’re using a remote computer as a server, copy the sample database 
to the remote computer.

2. Create the connection in Dreamweaver.

Configuring your system (ASP)
This section provides instructions for the two most common system 
configurations for ASP: one in which Microsoft IIS is installed on your 
hard disk, and one in which IIS is installed on a remote Windows 
computer.
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The following illustration shows the two configurations described in this 
section: 

To configure your system:

1. Make sure you have a web server (see “Checking for a web server” 
on page 272).

2. If necessary, install an application server (see “Installing an ASP 
application server” on page 272).

3. Test your installation (see “Testing the installation” on page 273).

4. Create a root folder (see “Creating a root folder” on page 274). 

Network or 
ftp access

WINDOWS PC

Local configuration
(for Windows users only)

Remote server configuration
(for Macintosh or Windows users)

Dreamweaver

IIS

Website root folder in
c:\Inetpub\wwwroot\

Website root folder in
c:\Inetpub\wwwroot\

MAC or WINDOWS PC

Dreamweaver

WINDOWS SERVER

IIS

Installing the web server and application server are one-time-only tasks.
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Checking for a web server
To develop and test dynamic web pages, you need a web server. A web 
server is software that serves web pages in response to requests from web 
browsers.

Make sure Microsoft IIS is installed and running on your hard disk or on a 
remote Windows computer. (Macintosh users need to install Microsoft IIS 
on a remote Windows computer.) A quick way to check whether IIS is 
installed on a computer is to look at the folder structure to see whether it 
contains a C:\Inetpub or D:\Inetpub folder. IIS creates this folder during 
installation.

If IIS is not installed, install it now. For instructions, see “Installing a Web 
Server” on page 231.

After installing the web server, you need to install an application server. 

Installing an ASP application server
To process dynamic web pages, you need an application server. An 
application server is software that helps a web server process web pages 
containing server-side scripts or tags. When such a page is requested by a 
browser, the web server hands the page off to the application server for 
processing before sending the page to the browser. For more information, 
see “Understanding Web Applications” on page 217. 

If you installed IIS on a Windows computer, you don’t need a separate ASP 
application server. IIS also functions as an ASP application server. For more 
information on installing and testing IIS, see “Installing a Web Server” 
on page 231.

You should test the server to make sure it works properly. 
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Testing the installation
You can test the ASP engine of IIS by running a test page.

To test the ASP engine of IIS: 

1. In Dreamweaver or any text editor, create a plain text file and name it 
timetest.asp.

2. In the file, enter the following code:
<p>This page was created at <b>
<%= Time %>
</b> on the computer running ASP.</p>

This code displays the time the page was processed on the server.
3. Copy the file to the C:\Inetpub\wwwroot folder of the Windows 

computer running IIS. 

4. In your web browser, enter the URL of your test page and then press 
Enter.

If IIS is running on your local computer, you can enter the following 
URL:
http://localhost/timetest.asp

The test page should open and display a time of day, as follows: 

The specified time is known as dynamic content because it changes every 
time you request the page. Click your browser’s Refresh button to generate 
a new page with a different time. 
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If the page doesn’t work as expected, check for the following possible 
errors: 

■ The file does not have a .asp extension.
■ You typed the page’s file path (C:\Inetput\wwwroot\timetest.asp) 

instead of its URL (for example, http://localhost/timetest.asp) in the 
browser’s Address text box. 
If you type a file path in the browser (as you might be used to doing 
with normal HTML pages), you bypass the web server and the 
application server. As a result, your page never gets processed by the 
server.

■ The URL contains a typing mistake. Check for errors and make sure 
the filename is not followed by a slash, such as http://localhost/
timetest.asp/.

■ The page code contains a typing mistake. 

After installing and testing the server software, create a root folder for your 
web application. 

Creating a root folder
After the server software is installed, create a root folder for your web 
application on the system running Microsoft IIS, and make sure the folder 
has the necessary permissions. 

To create a root folder for your web application:

1. Create a folder called MySampleApps on the system running IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By 
default, your IIS web server is set up to serve pages from the 
Inetpub\wwwroot folder. The web server will serve any page in this 
folder or in any of its subfolders in response to an HTTP request from 
a web browser.
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Looking at the source code (View > Source in Internet Explorer) will 
confirm that the page does not use any client-side JavaScript to achieve 
this effect.
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Write down this folder name for later use. When you type it later, be sure to 
use exactly the same capitalization that you used when you created it.
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2. Make sure the Read and Scripts permissions are enabled for the folder 
by doing the following:

a. Start the IIS administrative tool (in Windows XP, select Start > 
Control Panel or Start > Settings > Control Panel, then double-
click Administrative Tools, then double-click Internet Information 
Services). 

b. Expand the “local computer” list, followed by the Web Sites folder, 
and then the Default Web Site folder. 

c. Right-click your MySampleApps folder and select Properties from 
the pop-up menu. 

d. In the Execute Permissions pop-up menu, make sure the 
Scripts Only option is selected. (For security reasons, do not select 
the Scripts and Executables option.) 

e. Click OK.

The web server is now configured to serve web pages in your root folder in 
response to HTTP requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site 
(ASP)
After configuring your system, copy the sample files to a local folder and 
define a Dreamweaver site to manage the files. 

To define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk (see “Copying the 
sample files” on page 276).

2. Define the folder as a Dreamweaver local folder (see “Defining a local 
folder” on page 277).

3. Define your root folder on the web server as a Dreamweaver remote 
folder (see “Defining a remote folder” on page 277).

4. Specify a folder to process dynamic pages (see “Specifying where 
dynamic pages can be processed” on page 278).

5. Upload the sample files to the web server (see “Uploading the sample 
files” on page 279).
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Copying the sample files
If you haven’t already done so, copy the sample files from the Dreamweaver 
application folder to a folder on your hard disk.

To copy the sample files:

1. Create a new folder called local_sites in your user folder on your hard 
disk.

For example, create one of the following folders:
■ C:\Documents and Setting\your_user_name\My Documents\ 

local_sites (Windows)
■ /Users/your_user_name/Documents/local_sites (Macintosh).

2. Locate the cafe_townsend folder in the Dreamweaver application folder 
on your hard disk.

If you installed Dreamweaver to its default location, the path to the 
folder is as follows:
■ In Windows: C:\Program Files\Macromedia\Dreamweaver 8\ 

Tutorial_assets\cafe_townsend\.
■ On the Macintosh: Macintosh HD/Applications/Macromedia 

Dreamweaver 8/Tutorial_assets/cafe_townsend.
3. Copy the cafe_townsend folder into the local_sites folder. 

The cafe_townsend folder is the folder that you will use as the root 
folder (main folder) for your Dreamweaver site.
After copying the cafe_townsend folder, define the folder as a 
Dreamweaver local folder.
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On the Macintosh, there’s a folder called Sites already in your user folder. 
Don’t use that Sites folder as your local folder; the Sites folder is where 
you place your pages to make them publicly accessible when you’re using 
the Macintosh as a web server.
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Defining a local folder
After copying the cafe_townsend folder, you define the folder containing 
the ASP sample files as a Dreamweaver local folder. 

To define the Dreamweaver local folder:

1. In Dreamweaver, select Site > Manage Sites. In the Manage Sites dialog 
box, click the New button, and then select Site.

The Site Definition dialog box appears. 
2. If the Basic tab is showing, click the Advanced tab.

3. In the Site Name text box, enter Cafe Townsend ASP.

The name identifies your site within Dreamweaver. 
4. Click the folder icon next to the Local Root Folder text box and browse 

to the following folder, which contains the ASP sample files:

■ C:\Documents and Setting\your_user_name\My 
Documents\local_sites\cafe_townsend\contact\asp (Windows)

■ /Users/your_user_name/Documents/local_sites/cafe_townsend/
contact/asp (Macintosh)

5. Click Select to finish defining the Dreamweaver local folder.

Leave the Site Definition dialog box open. Next, define a web server folder 
as a Dreamweaver remote folder. 

Defining a remote folder
After defining a local folder, you define a web server folder as a 
Dreamweaver remote folder. 

To define the Dreamweaver remote folder:

1. In the Advanced tab of the Site Definition dialog box, select Remote 
Info from the Category list. 

The Remote Info dialog box appears.
2. In the Access pop-up menu, select how you want to move your files to 

and from the server: across a local network (the Local/Network option) 
or using FTP.

There are other options in the Access pop-up menu, but this guide doesn’t 
cover them. For information about them, see Using Dreamweaver.
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3. Enter the path or FTP settings to the web server folder you created in 
“Creating a root folder” on page 274.

The folder may be on your hard disk or on a remote computer. Even if 
you created the folder on your hard disk, that folder is still considered 
to be the remote folder. The following example shows a possible 
Remote Folder path if you chose Local/Network access and your 
remote folder is on your Windows hard disk:
Remote Folder: C:\Inetpub\wwwroot\MySampleApps
For more information on FTP, see “Setting Remote options for FTP 
access” in Using Dreamweaver Help.

Leave the Site Definition dialog box open. Next, define a folder to process 
dynamic pages. 

Specifying where dynamic pages can be 
processed
After defining the Dreamweaver remote folder, specify a folder to process 
dynamic pages. Dreamweaver uses this folder to display dynamic pages and 
connect to databases while you’re developing your application. 

To specify the folder to process dynamic pages:

1. In the advanced Site Definition dialog box, click Testing Server in the 
Category list.

The Testing Server screen appears. Dreamweaver needs the services of a 
testing server to generate and display dynamic content while you work. 
The testing server can be your local computer, a development server, a 
staging server, or a production server, as long as it can process ASP 
pages. In many situations, including setting up for the Cafe Townsend 
site, you can use the same settings as the Remote Info category (see 
“Defining a remote folder” on page 277) because they point to a server 
capable of processing ASP pages.

2. Select ASP JavaScript or ASP VBScript from the Server Model pop-up 
menu.
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3. In the Access pop-up menu, select the same method (Local/Network or 
FTP) you specified for accessing your remote folder.

Dreamweaver enters the settings you specified in the Remote Info 
category. Leave the settings unchanged.

4. In the URL Prefix text box, enter the root URL you would enter in a 
web browser to request a page in your web application. 

To display live data in your pages while you work, Dreamweaver creates 
a temporary file, copies it to the website’s root folder, and attempts to 
request it using the URL prefix. 
Dreamweaver makes a best guess at the URL prefix based on the 
information you provided in the Site Definition dialog box. However, 
the suggested URL prefix may be incorrect. Correct or enter a new 
URL prefix if the suggestion in Dreamweaver is incorrect. For more 
information, see “Setting the URL prefix” in Using Dreamweaver.
If the folder specified in the Remote Folder text box is 
C:\Inetpub\wwwroot\MySampleApps, the URL prefix should be as 
follows:
http://localhost/MySampleApps/

5. Click OK to define the site and dismiss the Site Definition dialog box, 
then click Done to dismiss the Manage Sites dialog box.

After specifying a folder to process dynamic pages, upload the sample files 
to the web server.

Uploading the sample files 
After specifying a folder to process dynamic pages, upload the sample files 
to the web server. You must upload the files even if the web server is 
running on your local computer. 

If you don’t upload the files, features such as Live Data view and Preview in 
Browser may not work properly with dynamic pages. For example, image 
links might be broken in Live Data view because the image files are not on 
the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing 
from the server.

T
IP The URL prefix 

should always 
specify a directory, 
rather than a 
particular page on 
the site. Also, be sure 
to use the same 
capitalization you 
used when you 
created the folder.
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To upload the samples files to the web server:

1. In the Files panel (Window > Files), select the root folder of the site in 
the Local View pane.

The root folder is the topmost folder in the list. 
2. Click the blue Put Files arrow icon in the Files panel toolbar, and 

confirm that you want to upload the entire site.

Dreamweaver copies all the files to the web server folder you defined in 
“Defining a remote folder” on page 277. 

The Dreamweaver site is now defined. The next step is to connect to the 
sample database installed with Dreamweaver.  

Connecting to the sample 
database (ASP)
During installation, Dreamweaver copies a sample Microsoft Access 
database to your hard disk. This section describes how to create a 
connection to the sample database. 

To create a database connection:

1. If you’re using a remote computer as a server, set up the sample database 
on the remote computer (see “Setting up the database (server on remote 
computer)” on page 280).

2. Create the connection in Dreamweaver (see “Creating a database 
connection” on page 282).

Setting up the database (server on remote 
computer)
This section applies only if your web server is running on a remote 
computer. If your web server is running on the same computer as 
Dreamweaver, skip to “Creating a database connection” on page 282.
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For information on connecting to another database, see Chapter 26, 
“Database Connections for ASP Developers,” in Using Dreamweaver.
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Before attempting to connect to the sample database, perform the 
following tasks on the remote computer running your web server: copy the 
sample database to the computer’s hard disk and create a DSN on the 
computer that points to the database.

To set up the sample database on the remote computer: 

1. Copy the database to the remote computer’s hard disk. If you installed 
Dreamweaver to its default location, the path on your local hard disk to 
the database file (tutorial.mdb) is as follows:

■ C:\Program 
Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\
data\tutorial.mdb (Windows)

■ /Applications/Macromedia Dreamweaver 8/Tutorial_assets/
cafe_townsend/data/tutorial.mdb (Macintosh)

You can place the file in any folder on the remote computer, or you can 
create a new folder for it.

2. Make sure the Microsoft Access Driver, version 4.0 or later, is installed 
on the remote computer.

To find out whether the driver is already installed, see “Viewing the 
ODBC drivers installed on a Windows system” in Using Dreamweaver. 
If the driver is not installed, download and install the Microsoft Data 
Access Components (MDAC) 2.5 and 2.7 packages on the remote 
computer. You can download MDAC for free from the Microsoft 
website at http://msdn.microsoft.com/data/mdac/downloads/. These 
packages contain the latest Microsoft drivers, including the Microsoft 
Access Driver.

There are potential security issues if you place the database file inside the 
Inetpub folder on the remote computer. It’s better to place the file in a 
folder that’s not publicly accessible.

Install MDAC 2.5 before installing MDAC 2.7.
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3. Set up a DSN called CafeTownsend pointing to the sample database on 
the remote computer.

For instructions, see the following articles on the Microsoft website:
■ If the remote computer runs Windows 2000, see Article 300596 at 

http://support.microsoft.com/default.aspx?scid=kb;en-us;300596.
■ If the remote computer runs Windows XP, see Article 305599 at 

http://support.microsoft.com/default.aspx?scid=kb;en-us;305599.

After the database, database driver, and DSN are in place, create a database 
connection in Dreamweaver. 

Creating a database connection 
The final step of the setup process is to create a connection to the database. 

If your web server is running on your local computer, you can use the data 
source name (DSN) that Dreamweaver created during installation to 
quickly connect to the sample database. To learn more about DSNs, see 
“Using a DSN” in Using Dreamweaver.

To create a database connection in Dreamweaver:

1. Open any ASP page in Dreamweaver, and then open the Databases 
panel (Window > Databases).

2. Click the Plus (+) button on the panel and select Data Source Name 
(DSN) from the pop-up menu.

The Data Source Name (DSN) dialog box appears. 
3. Enter connTownsend as the connection name.

4. (Windows only) Do one of the following:

■ If your server is on your local computer, select the Using Local 
DSN option.

■ If your server is on a remote system, select the Using DSN on 
Testing Server option.

Macintosh users can ignore this step because all database connections 
use DSNs on the testing server.
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5. Click the DSN button and select CafeTownsend from the list of DSNs.

If you’re using Dreamweaver on a Windows computer, during 
installation, Dreamweaver created a DSN called CafeTownsend, which 
points to the Microsoft Access database in the Dreamweaver 
application folder.

6. Click Test.

Dreamweaver attempts to connect to the database. If the connection 
fails, do the following:
■ Double-check the DSN. 
■ Check the settings for the folder Dreamweaver uses to process 

dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 278).

■ Consult Chapter 29, “Troubleshooting Database Connections” in 
Using Dreamweaver.

7. Click OK.

The new connection appears in the Databases panel.

The sample ASP application is now set up for the Getting Started with 
Dreamweaver tutorials. For more information, see “Tutorial: Developing a 
Web Application” on page 197.
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Setup for Sample JSP 
Site
Macromedia Dreamweaver 8 comes with sample Java Server Pages (JSP) 
web pages to let you build a small web application. This chapter describes 
one way to set up the sample application using Microsoft Internet 
Information Server (IIS). For more information on these web servers, see 
“Installing a Web Server” on page 231. If you’re using a different web 
server, see Chapter 23, “Setting Up a Web Application” in Using 
Dreamweaver (Help > Using Dreamweaver).

Setting up a web application is a three-step process. First, configure your 
system. Second, define a Dreamweaver site. Third, connect the application 
to your database. This setup chapter follows this three-step process. 

This chapter contains the following sections:
Setup checklists for JSP developers. . . . . . . . . . . . . . . . . . . . . . . 285

Configuring your system (JSP) . . . . . . . . . . . . . . . . . . . . . . . . . . . . 286

Defining a Dreamweaver site (JSP). . . . . . . . . . . . . . . . . . . . . . . . 290

Connecting to the sample database (JSP). . . . . . . . . . . . . . . . . . 295

Setup checklists for JSP 
developers
To set up a web application, you must configure your system, define a 
Dreamweaver site, and connect to a database. This section provides 
checklists for each task. The tasks are described in more detail in the rest of 
the chapter.

Configure your system: 

1. Make sure you have a web server.

2. Install the JSP application server.

3. Create a root folder. 
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Define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk.

2. Define the folder as a Dreamweaver local folder.

3. Define a web server folder as a Dreamweaver remote folder.

4. Specify a folder to process dynamic pages.

5. Upload the sample files to the web server.

Connect to the database:

1. Install a JDBC-ODBC bridge driver.

2. If you’re using a remote computer as a server, copy the sample database 
to the remote computer.

3. Create the connection in Dreamweaver.

Configuring your system (JSP)
This section provides instructions for two common system configurations: 
one in which Microsoft IIS is installed on your hard disk, and one in which 
IIS is installed on a remote Windows computer. If you want to use a 
different configuration, see Chapter 23, “Setting Up a Web Application” in 
Using Dreamweaver.
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The following illustration shows the two configurations described in this 
section: 

To configure your system:

1. Make sure you have a web server (see “Checking for a web server” 
on page 288).

2. Install the JSP application server (see “Installing a JSP application 
server” on page 288).

3. Create a root folder (see “Creating a root folder” on page 289). 

Network or 
ftp access

WINDOWS PC

Local configuration
(for Windows users only)

Remote server configuration
(for Macintosh or Windows users)

Dreamweaver

IIS

JSP application server

Website root folder in
c:\Inetpub\wwwroot\

Website root folder in
c:\Inetpub\wwwroot\

MAC or WINDOWS PC

Dreamweaver

WINDOWS SERVER

IIS

JSP application server

Installing the web server and application server are one-time-only tasks.
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Checking for a web server 
To develop and test dynamic web pages, you need a web server. A web 
server is software that serves web pages in response to requests from web 
browsers.

Make sure Microsoft IIS is installed and running on your hard disk or on a 
remote Windows computer. (Macintosh users need to install Microsoft IIS 
on a remote Windows computer.) A quick way to check whether IIS is 
installed on a computer is to look at the folder structure to see whether it 
contains a C:\Inetpub or D:\Inetpub folder. IIS creates this folder during 
installation.

If IIS is not installed, install it now. For instructions, see “Installing a Web 
Server” on page 231.

After installing the web server, install the application server. 

Installing a JSP application server 
To process dynamic web pages, you need an application server. An 
application server is software that helps a web server process web pages 
containing server-side scripts or tags. When such a page is requested by a 
browser, the web server hands the page off to the application server for 
processing before sending the page to the browser. For more information, 
see “Understanding Web Applications” on page 217. 

Make sure a JSP application server is installed and running on the system 
running IIS. (IIS may be located on your local hard disk or on a remote 
computer.)

If you do not have a JSP application server, you can download and install 
the Developer Edition of Macromedia JRun, a full-featured JSP 
application server, from the Macromedia website at 
www.macromedia.com/go/jrun/.

JRun is available for both Windows and Macintosh. However, this guide 
doesn’t cover using JRun on a Macintosh.
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To install JRun: 

1. If applicable, log into your Windows system using the Administrator 
account.

2. Close all open applications.

3. Double-click the JRun Developer Edition installer file.

The splash screen appears.
4. If you do not have a Java Runtime Environment (JRE) on your system, 

select the option on the splash screen to install it.

Because the JRun application server relies on Java, a JRE must first be 
installed on the system that will run your application server. Once the 
JRE is installed, you can install the JRun application server.

5. Select the option on the splash screen to install JRun.

6. Follow the onscreen instructions to finish installing and testing the 
program. 

7. Once the installation is complete, create a JRun connector to your IIS 
web server by selecting Start > Programs > Macromedia JRun 4 > Web 
Server Configuration. 

For instructions, see the JRun documentation.

After installing and starting JRun, create a root folder for your web 
application. 

Creating a root folder 
After the server software is installed, create a root folder for your web 
application on the system running Microsoft IIS, and make sure the folder 
has the necessary permissions. 

To create a root folder for your web application:

1. Create a folder called MySampleApps on the system running IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By 
default, your IIS web server is set up to serve pages from the 
Inetpub\wwwroot folder. The web server will serve any page in this 
folder or in any of its subfolders in response to an HTTP request from 
a web browser.

Write down this folder name for later use. When you type it later, be sure to 
use exactly the same capitalization that you used when you created it.
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2. Make sure the Read and Scripts permissions are enabled for the folder 
by doing the following:

a. Start the IIS administrative tool (in Windows XP, select Start > 
Control Panel or Start > Settings  > Control Panel, double-click 
Administrative Tools, and then double-click Internet Information 
Services). 

b. Expand the “local computer” list, followed by the Web Sites folder, 
and then the Default Web Site folder. 

c. Right-click your MySampleApps folder and select Properties from 
the pop-up menu. 

d. In the Execute Permissions pop-up menu, make sure the 
Scripts Only option is selected. (For security reasons, do not select 
the Scripts and Executables option.) 

e. Click OK.

The web server is now configured to serve web pages in your root folder in 
response to HTTP requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site 
(JSP)
After configuring your system, copy the sample files to a local folder and 
define a Dreamweaver site to manage the files. 

To define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk (see “Copying the 
sample files” on page 291).

2. Define the folder as a Dreamweaver local folder (see “Defining a local 
folder” on page 292).

3. Define your root folder on the web server as a Dreamweaver remote 
folder (see “Defining a remote folder” on page 292).

4. Specify a folder to process dynamic pages (see “Specifying where 
dynamic pages can be processed” on page 293).

5. Upload the sample files to the web server (see “Uploading the sample 
files” on page 294).
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Copying the sample files
If you haven’t already done so, copy the sample files from the Dreamweaver 
application folder to a folder on your hard disk.

To copy the sample files:

1. Create a new folder called local_sites in your user folder on your hard 
disk.

For example, create one of the following folders:
■ C:\Documents and Setting\your_user_name\My 

Documents\local_sites (Windows)
■ /Users/your_user_name/Documents/local_sites (Macintosh).

2. Locate the cafe_townsend folder in the Dreamweaver application folder 
on your hard disk.

If you installed Dreamweaver to its default location, the path to the 
folder is as follows:
■ In Windows: C:\Program Files\Macromedia\Dreamweaver 

8\Tutorial_assets\cafe_townsend\.
■ On the Macintosh: Macintosh HD/Applications/Macromedia 

Dreamweaver 8/Tutorial_assets/cafe_townsend.
3. Copy the cafe_townsend folder into the local_sites folder. 

The cafe_townsend folder is the folder that you will use as the root 
folder (main folder) for your Dreamweaver site.

After copying the cafe_townsend folder, define the folder as a 
Dreamweaver local folder.

On the Macintosh, there’s a folder called Sites already in your user folder. 
Don’t use that Sites folder as your local folder; the Sites folder is where 
you place your pages to make them publicly accessible when you’re using 
the Macintosh as a web server.
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Defining a local folder
After copying the cafe_townsend folder, define the folder containing the 
JSP sample files as a Dreamweaver local folder. 

To define the Dreamweaver local folder:

1. In Dreamweaver, select Site > Manage Sites. In the Manage Sites dialog 
box, click the New button, then select Site.

The Site Definition dialog box appears. 
2. If the Basic tab is showing, click the Advanced tab.

3. In the Site Name text box, enter Cafe Townsend JSP.

The name identifies your site within Dreamweaver. 
4. Click the folder icon next to the Local Root Folder text box and browse 

to the following folder, which contains the JSP sample files:

■ C:\Documents and Setting\your_user_name\My 
Documents\local_sites\cafe_townsend \contact\jsp (Windows)

■ /Users/your_user_name/Documents/local_sites/cafe_townsend/
contact/jsp (Macintosh)

5. Click Select to finish defining the Dreamweaver local folder.

Leave the Site Definition dialog box open. Next, define a web server folder 
as a Dreamweaver remote folder. 

Defining a remote folder
After defining a local folder, define a web server folder as a Dreamweaver 
remote folder. 

To define the Dreamweaver remote folder:

1. In the Advanced tab of the Site Definition dialog box, select Remote 
Info from the Category list. 

The Remote Info screen appears.
2. In the Access pop-up menu, choose how you want to move your files to 

and from the server: across a local network (the Local/Network option) 
or using FTP.
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There are other options in the Access pop-up menu, but this guide doesn’t 
cover them. For information about them, see Using Dreamweaver.
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3. Enter the path or FTP settings to the web server folder you created in 
“Creating a root folder” on page 289.

The folder may be on your hard disk or on a remote computer. Even if 
you created the folder on your hard disk, that folder is still considered 
to be the remote folder. The following example shows a possible 
Remote Folder path if you chose Local/Network access and your 
remote folder is on your Windows hard disk:
Remote Folder: C:\Inetpub\wwwroot\MySampleApps
For more information on FTP, see “Setting Remote options for FTP 
access” in Using Dreamweaver (Help > Using Dreamweaver).

Leave the Site Definition dialog box open. Next, define a folder to process 
dynamic pages. 

Specifying where dynamic pages can be 
processed
After defining the Dreamweaver remote folder, specify a folder to process 
dynamic pages. Dreamweaver uses this folder to display dynamic pages and 
connect to databases while you’re developing your application. 

To specify the folder to process dynamic pages:

1. In the advanced Site Definition dialog box, click Testing Server in the 
Category list.

The Testing Server screen appears. Dreamweaver needs the services of a 
testing server to generate and display dynamic content while you work. 
The testing server can be your local computer, a development server, a 
staging server, or a production server, as long as it can process JSP 
pages. In many situations, including setting up for the Cafe Townsend 
site, you can use the same settings as the Remote Info category (see 
“Defining a remote folder” on page 292) because they point to a server 
capable of processing JSP pages.

2. Select JSP from the Server Model pop-up menu.

3. In the Access pop-up menu, select the same method (Local/Network or 
FTP) you specified for accessing your remote folder.

Dreamweaver enters the settings you specified in the Remote Info 
category. Leave the settings unchanged.
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4. In the URL Prefix text box, enter the root URL you would enter in a 
web browser to request a page in your web application. 

To display live data in your pages while you work, Dreamweaver creates 
a temporary file, copies it to the website’s root folder, and attempts to 
request it using the URL prefix. 
Dreamweaver makes a best guess at the URL prefix based on the 
information you provided in the Site Definition dialog box. However, 
the suggested URL prefix may be incorrect. Correct or enter a new 
URL prefix if the suggestion in Dreamweaver is incorrect. For more 
information, see “Setting the URL prefix” in Using Dreamweaver.
If the folder specified in the Remote Folder text box is 
C:\Inetpub\wwwroot\MySampleApps, the URL prefix should be as 
follows:
http://localhost/MySampleApps/

5. Click OK to define the site and close the Site Definition dialog box; 
then click Done to close the Manage Sites dialog box.

After specifying a folder to process dynamic pages, upload the sample files 
to the web server.

Uploading the sample files 
After specifying a folder to process dynamic pages, upload the sample files 
to the web server. You must upload the files even if the web server is 
running on your local computer. 

If you don’t upload the files, features such as Live Data view and Preview in 
Browser may not work properly with dynamic pages. For example, image 
links might be broken in Live Data view because the image files are not on 
the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing 
from the server.

T
IP The URL prefix 

should always 
specify a directory, 
rather than a 
particular page on 
the site. Also, be sure 
to use the same 
capitalization you 
used when you 
created the folder.
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To upload the samples files to the web server:

1. In the Files panel (Window > Files), select the root folder of the site in 
the Local View pane.

The root folder is the topmost folder in the list.
2. Click the blue Put Files arrow icon in the Files panel toolbar, and 

confirm that you want to upload the entire site.

Dreamweaver copies all the files to the web server folder you defined in 
“Defining a remote folder” on page 292. 

The Dreamweaver site is now defined. The next step is to connect to the 
sample database installed with Dreamweaver.  

Connecting to the sample 
database (JSP)
During installation, Dreamweaver copies a sample Microsoft Access 
database to your hard disk. This section describes how to create a 
connection to the sample database.

To create a database connection:

1. Install the bridge driver (see “Installing the bridge driver” on page 296).

2. If you’re using a remote computer as a server, set up the sample database 
on the remote computer (see “Setting up the database (server on remote 
computer)” on page 297).

3. Create the connection in Dreamweaver (see “Creating a database 
connection” on page 298).

For information on connecting to another database, see Chapter 27, 
“Database Connections for JSP Developers” in Using Dreamweaver.
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Installing the bridge driver
Before attempting to connect to the sample database, install the Sun 
JDBC-ODBC Bridge driver on the computer running your web server. 
The bridge driver lets you use Windows data source names (DSNs) to 
create connections. The driver comes with the Sun Java 2 SDK, Standard 
Edition, for Windows.

To find out if you already have the Java 2 SDK with the driver, check your 
hard disk for any of the following directories:

C:\jdk1.2.x

C:\jdk1.3.x

C:\j2sdk1.4.x

If you don’t have the SDK, download it from the Sun website at http://
java.sun.com/j2se/. After downloading the installation file, double-click it 
to run the installer. Follow the onscreen instructions and make sure the 
Java 2 Runtime Environment component is selected from the Select 
Component dialog box. It should be selected by default. The driver is 
installed automatically when you install the SDK.

Although it is adequate for development use with lower-end database 
systems such as Microsoft Access, the Sun JDBC-ODBC Bridge driver is 
not intended for production use. For example, it lets only one JSP page 
connect to the database at a time (it does not support concurrent use by 
multiple threads). For more information on the driver’s limitations, see 
TechNote 17392 on the Macromedia Support Center at 
www.macromedia.com/go/17392.

After installing the bridge driver, set up the database if necessary, and then 
create a database connection in Dreamweaver. 
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The term “Java 2” refers to Java 1.2 and later versions.
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Setting up the database (server on remote 
computer)
This section applies only if your web server is running on a remote 
computer. If your web server is running on the same computer as 
Dreamweaver, skip to “Creating a database connection” on page 298.

Before attempting to connect to the sample database, perform the 
following tasks on the remote computer running your web server: copy the 
sample database to the computer’s hard disk, create a DSN on the 
computer that points to the database, and install the Sun JDBC-ODBC 
Bridge driver on the computer.

To set up the sample database on the remote computer: 

1. Copy the database to the remote computer’s hard disk. If you installed 
Dreamweaver to its default location, the path on your local hard disk to 
the database file (tutorial.mdb) is as follows:

■ C:\Program 
Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\
data\tutorial.mdb (Windows)

■ /Applications/Macromedia Dreamweaver 8/Tutorial_assets/
cafe_townsend/data/tutorial.mdb (Macintosh)

You can place the file in any folder on the remote computer, or you can 
create a new folder for it.

There are potential security issues if you place the database file inside the 
Inetpub folder on the remote computer. It’s better to place the file in a 
folder that’s not publicly accessible.
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2. Make sure the Microsoft Access Driver, version 4.0 or higher, is 
installed on the remote computer.

To find out whether the driver is already installed, see “Viewing the 
ODBC drivers installed on a Windows system” in Using Dreamweaver. 
If the driver is not installed, download and install the Microsoft Data 
Access Components (MDAC) 2.5 and 2.7 packages on the remote 
computer. You can download MDAC for free from the Microsoft 
website at http://msdn.microsoft.com/data/mdac/downloads/. These 
packages contain the latest Microsoft drivers, including the Microsoft 
Access Driver.

3. Set up a DSN called CafeTownsend pointing to the sample database on 
the remote computer. 

For instructions, see the following articles on the Microsoft website:
■ If the remote computer runs Windows 2000, see Article 300596 at 

http://support.microsoft.com/default.aspx?scid=kb;en-us;300596.
■ If the remote computer runs Windows XP, see Article 305599 at 

http://support.microsoft.com/default.aspx?scid=kb;en-us;305599.
4. Make sure the Sun JDBC-ODBC Bridge driver is installed on the 

remote computer. 

You will use this driver along with the DSN to create a connection to 
the database. For instructions, see “Installing the bridge driver” 
on page 296.

After the database, DSN, and bridge driver are in place, create a database 
connection in Dreamweaver.

Creating a database connection
The final step of the setup process is to create a connection to the database. 

To create a database connection in Dreamweaver:

1. Open any JSP page in Dreamweaver, and then open the Databases panel 
(Window > Databases).
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Install MDAC 2.5 before installing MDAC 2.7.
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2. Click the Plus (+) button on the panel and select ODBC Database (Sun 
JDBC-ODBC Driver) from the pop-up menu.

The ODBC Database (Sun JDBC-ODBC Driver) dialog box appears.
3. Enter connTownsend as the connection name.

4. (Windows only) Do one of the following:

■ If your server is on your local computer, select the Using Driver On 
This Machine option.

■ If your server is on a remote system, select the Using Driver On 
Testing Server option.

Macintosh users can ignore this step because all database connections 
use drivers on the testing server.

5. Replace the [odbc dsn] placeholder in the URL text box with 
CafeTownsend.

The URL text box should look like this:
jdbc:odbc:CafeTownsend

If you’re using Dreamweaver on a Windows computer, during 
installation, Dreamweaver created a DSN called CafeTownsend 
pointing to the Microsoft Access database in the Dreamweaver 
application folder. 

6. Click Test.

Dreamweaver attempts to connect to the database. If the connection 
fails, do the following:
■ Double-check the DSN and the other connection parameters. 
■ Check the settings for the folder Dreamweaver uses to process 

dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 293).

■ Consult Chapter 29, “Troubleshooting Database Connections” in 
Using Dreamweaver (Help > Using Dreamweaver).

7. Click OK.

The new connection appears in the Databases panel.

The sample JSP application is now set up for the Getting Started with 
Dreamweaver tutorials. For more information, see “Tutorial: Developing a 
Web Application” on page 197.
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APPENDIX G

Setup for Sample PHP 
Site
Macromedia Dreamweaver 8 comes with sample PHP pages to let you 
build a small web application. This chapter describes one way to set up the 
sample application using Microsoft Internet Information Server (IIS). For 
more information on this web server, see “Installing a Web Server” 
on page 231. If you’re using a different web server, see Chapter 23, “Setting 
Up a Web Application” in Using Dreamweaver.

If you’re a Macintosh user, you can either connect to a remote PHP server 
or develop PHP sites locally using the Apache web server and PHP 
application server installed with your operating system. For setup 
information, see the following websites:

■ http://developer.apple.com/internet/opensource/php.html 
■ www.entropy.ch/software/macosx/php/ 

Setting up a web application is a three-step process. First, configure your 
system. Second, define a Dreamweaver site. Third, connect the application 
to your database. This setup guide follows this three-step process. 

This chapter contains the following sections:
Setup checklists for PHP developers . . . . . . . . . . . . . . . . . . . . . . 302

Configuring your system (PHP)  . . . . . . . . . . . . . . . . . . . . . . . . . . . 302

Defining a Dreamweaver site (PHP) . . . . . . . . . . . . . . . . . . . . . . . . .311

Connecting to the sample database (PHP) . . . . . . . . . . . . . . . . . . 315
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Setup checklists for PHP 
developers
To set up a web application, you must configure your system, define a 
Dreamweaver site, and connect to a database. This section provides 
checklists for each task. The tasks are described in more detail in the rest of 
the chapter.

Configure your system: 

1. Make sure you have a web server.

2. Install the PHP application server.

3. Test your installation.

4. Create a root folder. 

Define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk.

2. Define the folder as a Dreamweaver local folder.

3. Define a web server folder as a Dreamweaver remote folder.

4. Specify a folder to process dynamic pages.

5. Upload the sample files to the web server.

Connect to the database:

1. Create a sample MySQL database.

2. Create the connection in Dreamweaver.

Configuring your system (PHP)
You must configure your system before you can run PHP pages on it. 
Specifically, you must make sure a web server and a PHP application server 
are installed and running on your system, and then you must create a root 
folder for your PHP files.
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Configuring your Windows system (PHP)
This section provides instructions for two common Windows 
configurations: one in which Microsoft IIS is installed on your hard disk, 
and one in which IIS is installed on a remote Windows computer. If you 
want to use a different configuration, see Chapter 23, “Setting Up a Web 
Application” in Using Dreamweaver.

The following illustration shows the two configurations described in this 
section: 

Network or 
ftp access

WINDOWS PC

Local configuration
(for Windows users only)

Remote server configuration
(for Macintosh or Windows users)

Dreamweaver

IIS

PHP application server

Website root folder in
c:\Inetpub\wwwroot\

Website root folder in
c:\Inetpub\wwwroot\

MAC or WINDOWS PC

Dreamweaver

WINDOWS SERVER

IIS

PHP application server
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To configure your system:

1. Make sure you have a web server (see “Checking for a web server 
(Windows)” on page 304).

2. Install the PHP application server (see “Installing a PHP application 
server (Windows)” on page 304).

3. Test your installation (see “Testing the PHP installation (Windows)” 
on page 306).

4. Create a root folder (see“Creating a root folder (Windows)” 
on page 308). 

Checking for a web server (Windows) 
To develop and test dynamic web pages, you need a web server. A web 
server is software that serves web pages in response to requests from web 
browsers.

Make sure Microsoft IIS is installed and running on your hard disk or on a 
remote Windows computer. A quick way to check whether IIS is installed 
on a computer is to look at the folder structure to see whether it contains a 
C:\Inetpub or D:\Inetpub folder. IIS create this folder during installation.

If IIS is not installed, install it now. For instructions, see “Installing a Web 
Server” on page 231.

After installing the web server, install the application server. 

Installing a PHP application server (Windows) 
To process dynamic web pages, you need an application server. An 
application server is software that helps a web server process web pages 
containing server-side scripts or tags. When such a page is requested by a 
browser, the web server hands the page off to the application server for 
processing before sending the page to the browser. For more information, 
see “Understanding Web Applications” on page 217. 

Make sure the PHP application server is installed and running on the 
system running IIS. (IIS may be located on your hard disk or on a remote 
Windows computer.) You can download and install it from the PHP 
website at www.php.net/downloads.php. 
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Installing the web server and application server are one-time-only tasks.
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With PHP 5, the extension that allows PHP to work with a MySQL 
database server is not installed or enabled by default by the Windows 
installer. You must install and enable it manually. 

To install PHP 5 on a Windows system:

1. If applicable, log into your Windows system using the Administrator 
account.

2. Download the Windows PHP 5.x installer from the PHP website at 
www.php.net/downloads.php.

3. Double-click the installer file you downloaded and follow the onscreen 
installation instructions.

4. After PHP is successfully installed, download the Windows PHP 5.x zip 
package from the PHP website at www.php.net/downloads.php, and 
then extract the package in a temporary folder on your hard disk.

The zip package contains the extension you need to work with 
MySQL.

5. In the temporary folder containing the unzipped files, locate the folder 
called ext and copy it to the C:\PHP\ folder.

The ext folder contains common PHP extensions, including the 
MySQL extension.

6. In the C:\Windows folder, locate the file called php.ini and open it in 
Notepad.

You must edit this file to enable the MySQL extension.
7. Find the following line in the php.ini file:

extension_dir = "./"
This line specifies where PHP looks for extensions.

8. Edit the line as follows:

extension_dir = "C:\PHP\ext\"
9. Find the following line in the php.ini file:

;extension=php_mysql.dll
The semicolon (;) at the start of the line tells PHP to ignore the line.

10. Delete the semicolon at the start of the line to enable the extension.

extension=php_mysql.dll
11. Save and close the php.ini file.

T
IP Don’t omit the final 

slash.
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12. In the temporary folder containing your unzipped PHP files, locate the 
file called libmysql.dll and copy it to the C:\Windows\system32 folder.

This file is required so that IIS can work with PHP 5 and MySQL.
13. Restart IIS.

For more information on enabling the MySQL extension, see the PHP 
website at www.php.net/manual/en/ref.mysql.php. For more information 
on the application server, see the PHP documentation, which you can 
download from the PHP website at www.php.net/download-docs.php.

After installing PHP, you can test the server to make sure it works properly. 

Testing the PHP installation (Windows)
You can test the PHP application server by running a test page.

To test the PHP application server: 

1. In Dreamweaver or any text editor, create a plain text file and name it 
timetest.php.

2. In the file, enter the following code: 
<p>This page was created at <b>
<?php echo date("h:i:s a", time()); ?>
</b> on the computer running PHP.</p>

This code displays the time the page was processed on the server.
3. Copy the file to the C:\Inetpub\wwwroot folder of the Windows 

computer running IIS.

4. In your web browser, enter the URL of your test page, and then press 
Enter.

If you installed PHP on your local computer, you can enter the 
following URL:
http://localhost/timetest.php
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The test page should open and display a time of day, as follows: 

The specified time is known as dynamic content because it changes every 
time you request the page. Click your browser’s Refresh button to generate 
a new page with a different time. 

If the page doesn’t work as expected, check for the following possible 
errors: 

■ The file does not have a .php extension.
■ You typed the page’s file path (C:\Inetput\wwwroot\timetest.php) 

instead of its URL (for example, http://localhost/timetest.php) in the 
browser’s Address text box. 
If you type a file path in the browser (as you might be used to doing 
with normal HTML pages), you bypass the web server and the 
application server. As a result, your page never gets processed by the 
server.

■ The URL contains a typing mistake. Check for errors and make sure 
the filename is not followed by a slash, such as http://localhost/
timetest.php/.

■ The page code contains a typing mistake.

After installing and testing the server software, create a root folder for your 
web application. 

Looking at the source code (View > Source in Internet Explorer) will 
confirm that the page does not use any client-side JavaScript to achieve 
this effect.
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Creating a root folder (Windows)
After the server software is installed, create a root folder for your web 
application on the system running Microsoft IIS, and make sure the folder 
has the necessary permissions. 

To create a root folder for your web application:

1. Create a folder called MySampleApps on the system running IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By 
default, your IIS web server is set up to serve pages from the 
Inetpub\wwwroot folder. The web server will serve any page in this 
folder or in any of its subfolders in response to an HTTP request from 
a web browser.

2. Make sure the Read and Scripts permissions are enabled for the folder 
by doing the following:

a. Start the IIS administrative tool (in Windows XP, select Start > 
Control Panel or Start > Settings > Control Panel, double-click 
Administrative Tools, and then double-click Internet Information 
Services). 

b. Expand the “local computer” list, followed by the Web Sites folder, 
and then the Default Web Site folder. 

c. Right-click your MySampleApps folder and select Properties from 
the pop-up menu. 

d. In the Execute Permissions pop-up menu, make sure the 
Scripts Only option is selected. (For security reasons, do not select 
the Scripts and Executables option.) 

e. Click OK.

The web server is now configured to serve web pages in your root folder in 
response to HTTP requests from web browsers.

After configuring your system, you must define a Dreamweaver site. (See 
“Defining a Dreamweaver site (PHP)” on page 311.)
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Write down this folder name for later use. When you type it later, be sure to 
use exactly the same capitalization that you used when you created it.
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Configuring your Macintosh system (PHP)
If you’re a Macintosh user, you can run PHP pages on your computer using 
the Apache web server and PHP application server installed with your 
operating system. Configuring your system consists of making sure the web 
server and PHP application server are working, and then creating a root 
folder for your PHP files.

This section contains the following topics:

■ “Testing the PHP installation (Macintosh)” on page 309
■ “Creating a root folder (Macintosh)” on page 310

For more information on Apache and PHP on the Macintosh, see the 
following websites:

■ http://developer.apple.com/internet/opensource/php.html 
■ www.entropy.ch/software/macosx/php/ 

Testing the PHP installation (Macintosh)
You can test the Apache web server and PHP application server on your 
Macintosh by running a test page.

However, before you can use the web server to serve PHP pages and 
content from MySQL databases, you must configure the server to work 
with PHP and MySQL. For information on this process, see 
www.macromedia.com/go/php_macintosh.

To test the Apache web server and PHP application server: 

1. Configure the server as described in the article on the Macromedia 
website.

2. In Dreamweaver or any text editor, create a plain text file and name it 
timetest.php.

3. In the file, enter the following code: 
<p>This page was created at <b>
<?php echo date("h:i:s a", time()); ?>
</b> on the computer running PHP.</p>

This code displays the time the page was processed on the server.
4. Copy the file to the /Users/your_user_name/Sites folder on your 

Macintosh.

This Sites folder is your personal root folder for the Apache web server.
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5. In your web browser, enter the following URL and press Return:

http://localhost/~your_user_name/timetest.php

The test page should open and display a time of day.

The specified time is known as dynamic content because it changes every 
time you request the page. Click your browser’s Refresh button to generate 
a new page with a different time. 

If the page doesn’t work as expected, check for the following possible 
errors: 

■ The file does not have a .php extension.
■ The URL contains a typing mistake. Check for errors and make sure 

the filename is not followed by a slash, such as http://localhost/
~your_user_name/timetest.php/. Also make sure you included the tilde 
(~) before your user name.

■ The page code contains a typing mistake.
■ The Apache server is not running. Look in System Preferences, in the 

Sharing category, to see whether Personal Web Sharing is enabled.

After testing and testing the server software, create a root folder for your 
web application. 

Creating a root folder (Macintosh)
After the server software is installed, create a root folder for your web 
application on the Macintosh.

To create a root folder for your web application:

■ Create a folder called MySampleApps in the /Users/your_user_name/
Sites folder.
Apache will process any page in this folder or in any of its subfolders in 
response to an HTTP request from a web browser.

After configuring your system, you must define a Dreamweaver site. 

N
O

T
E

Looking at the source code (View > View Source in Safari) will confirm that 
the page does not use any client-side JavaScript to achieve this effect.
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Defining a Dreamweaver site 
(PHP)
After configuring your system, copy the sample files to a local folder and 
define a Dreamweaver site to manage the files. 

To define a Dreamweaver site:

1. Copy the sample files to a folder on your hard disk (see “Copying the 
sample files” on page 311).

2. Define the folder as a Dreamweaver local folder (see “Defining a local 
folder” on page 312).

3. Define your root folder on the web server as a Dreamweaver remote 
folder (see “Defining a remote folder” on page 313).

4. Specify a folder to process dynamic pages (see “Specifying where 
dynamic pages can be processed (PHP)” on page 313).

5. Upload the sample files to the web server (see “Uploading the sample 
files” on page 315).

Copying the sample files
If you haven’t already done so, copy the sample files from the Dreamweaver 
application folder to a folder on your hard disk.

To copy the sample files:

1. Create a new folder called local_sites in your user folder on your hard 
disk.

For example, create one of the following folders:
■ C:\Documents and Setting\your_user_name\My 

Documents\local_sites (Windows)
■ /Users/your_user_name/Documents/local_sites (Macintosh).

On the Macintosh, there’s a folder called Sites already in your user folder. 
Don’t use that Sites folder as your local folder; the Sites folder is where 
you place your pages to make them publicly accessible when you’re using 
the Macintosh as a web server.
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2. Locate the cafe_townsend folder in the Dreamweaver application folder 
on your hard disk.

If you installed Dreamweaver to its default location, the path to the 
folder is as follows:
■ In Windows: C:\Program Files\Macromedia\Dreamweaver 

8\Tutorial_assets\cafe_townsend\.
■ On the Macintosh: Macintosh HD/Applications/Macromedia 

Dreamweaver 8/Tutorial_assets/cafe_townsend.
3. Copy the cafe_townsend folder into the local_sites folder. 

The cafe_townsend folder is the folder that you will use as the root 
folder (main folder) for your Dreamweaver site.

After copying the cafe_townsend folder, define the folder as a 
Dreamweaver local folder.

Defining a local folder
After copying the cafe_townsend folder, define the folder containing the 
PHP sample files as a Dreamweaver local folder. 

To define the Dreamweaver local folder:

1. In Dreamweaver, select Site > Manage Sites. In the Manage Sites dialog 
box, click the New button, and then select Site.

The Site Definition dialog box appears. 
2. If the Basic tab is showing, click the Advanced tab.

3. In the Site Name text box, enter Cafe Townsend PHP.

The name identifies your site within Dreamweaver. 
4. Click the folder icon next to the Local Root Folder text box and browse 

to the following folder, which contains the PHP sample files:

■ C:\Documents and Setting\your_user_name\My 
Documents\local_sites\cafe_townsend\contact\php (Windows)

■ /Users/your_user_name/Documents/local_sites/cafe_townsend/
contact/php (Macintosh)

5. Click Select to finish defining the Dreamweaver local folder.

Leave the Site Definition dialog box open. Next, define a web server folder 
as a Dreamweaver remote folder. 
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Defining a remote folder
After defining a local folder, define a web server folder as a Dreamweaver 
remote folder. 

To define the Dreamweaver remote folder:

1. In the Advanced tab of the Site Definition dialog box, select Remote 
Info from the Category list. 

The Remote Info screen appears.
2. In the Access pop-up menu, choose how you want to move your files to 

and from the server: across a local network (the Local/Network option) 
or using FTP.

3. Enter the path or FTP settings to the web server folder you created in 
“Creating a root folder (Windows)” on page 308.

The folder may be on your hard disk or on a remote computer. Even if 
you created the folder on your hard disk, that folder is still considered 
to be the remote folder. The following example shows a possible 
Remote Folder path if you chose Local/Network access and your 
remote folder is on your Windows hard disk:
Remote Folder: C:\Inetpub\wwwroot\MySampleApps
On the Macintosh, the folder might be as follows:
Remote Folder: /Users/your_user_name/Sites/MySampleApps
For more information on FTP, see “Setting Remote options for FTP 
access” in Using Dreamweaver Help. 

Leave the Site Definition dialog box open. Next, define a folder to process 
dynamic pages. 

Specifying where dynamic pages can be 
processed (PHP)
After defining the Dreamweaver remote folder, specify a folder to process 
dynamic pages. Dreamweaver uses this folder to display dynamic pages and 
connect to databases while you’re developing your application. 

There are other options in the Access pop-up menu, but this chapter 
doesn’t cover them. For information about them, see Using Dreamweaver.
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To specify the folder to process dynamic pages:

1. In the advanced Site Definition dialog box, click Testing Server in the 
Category list.

The Testing Server screen appears. Dreamweaver needs the services of a 
testing server to generate and display dynamic content while you work. 
The testing server can be your local computer, a development server, a 
staging server, or a production server, as long as it can process PHP 
pages. In many situations, including setting up for the Cafe Townsend 
site, you can use the same settings as the Remote Info category (see 
“Defining a remote folder” on page 313) because they point to a server 
capable of processing PHP pages.

2. Select PHP MySQL from the Server Model pop-up menu.

3. In the Access pop-up menu, select the same method (Local/Network or 
FTP) you specified for accessing your remote folder.

Dreamweaver enters the settings you specified in the Remote Info 
category. Leave the settings unchanged.

4. In the URL Prefix text box, enter the root URL you would enter in a 
web browser to request a page in your web application. 

To display live data in your pages while you work, Dreamweaver creates 
a temporary file, copies it to the website’s root folder, and attempts to 
request it using the URL prefix. 
Dreamweaver makes a best guess at the URL prefix based on the 
information you provided in the Site Definition dialog box. However, 
the suggested URL prefix may be incorrect. Correct or enter a new 
URL prefix if the suggestion in Dreamweaver is incorrect. For more 
information, see “Setting the URL prefix” in Using Dreamweaver 
(Help > Using Dreamweaver).
For the PHP sample content in Windows, the prefix should be as 
follows:
URL Prefix: http://localhost/MySampleApps/
On the Macintosh, the prefix should be as follows:
URL Prefix: http://localhost/~your_user_name/MySampleApps/

5. Click OK to define the site and dismiss the Site Definition dialog box, 
and then click Done to dismiss the Manage Sites dialog box.

After specifying a folder to process dynamic pages, upload the sample files 
to the web server.

T
IP The URL prefix 

should always 
specify a directory, 
rather than a 
particular page on 
the site. Also, be sure 
to use the same 
capitalization you 
used when you 
created the folder.
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Uploading the sample files 
After specifying a folder to process dynamic pages, upload the sample files 
to the web server. You must upload the files even if the web server is 
running on your local computer. 

If you don’t upload the files, features such as Live Data view and Preview in 
Browser may not work properly with dynamic pages. For example, image 
links might be broken in Live Data view because the image files are not on 
the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing 
from the server.

To upload the samples files to the web server:

1. In the Files panel (Window > Files), select the root folder of the site in 
the Local View pane.

The root folder is the topmost folder in the list.
2. Click the blue Put Files arrow icon in the Files panel toolbar, and 

confirm that you want to upload the entire site.

Dreamweaver copies all the files to the web server folder you defined in 
“Defining a remote folder” on page 313. 

The Dreamweaver site is now defined. The next step is to connect to the 
sample database installed with Dreamweaver.

Connecting to the sample 
database (PHP)
During installation, Dreamweaver copies a SQL script to your hard disk. 
You can use this script to automatically create a sample MySQL database. 
This section describes how to create a connection to the sample database. 

This section assumes you have installed and configured MySQL on your 
local or remote computer. To download and install the database system, 
visit the MySQL website at www.mysql.com.
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To create a database connection:

1. Create the sample MySQL database using the SQL script (see “Creating 
the MySQL database” on page 316).

2. Create the connection in Dreamweaver (see “Creating a database 
connection” on page 318).

Creating the MySQL database
The sample files for Dreamweaver include a SQL script capable of creating 
and populating a sample MySQL database.

Before starting, make sure MySQL is installed and configured on your 
local or remote computer. Download the latest version from the MySQL 
website at http://dev.mysql.com/downloads/. For development purposes, 
download and install the Windows Essentials version of the MySQL 
database server.

To create the sample MySQL database:

1. Copy the SQL script file, insert.sql, to an appropriate folder on the 
computer that has MySQL installed.

If you installed Dreamweaver to its default location, the path to the 
script file is as follows:
■ C:\Program 

Files\Macromedia\Dreamweaver 8\Tutorial_assets\cafe_townsend\
data\insert.sql (Windows)

■ /Applications/Macromedia Dreamweaver 8/Tutorial_assets/
cafe_townsend/data/insert.sql (Macintosh)

If the computer running MySQL is a Windows computer, copy the 
insert.sql script to Program Files\MySQL\MySQL Server 4.x\bin. If 
the computer running MySQL is a Macintosh, copy the insert.sql 
script to your Documents folder in your home folder.

2. On the computer that has MySQL installed, start the MySQL 
Command Line Client (Windows) or the Terminal (Macintosh).

■ In Windows, start the MySQL Command Line Client by selecting 
Start > MySQL > MySQL Server 4.x > MySQL Command Line 
Client.

■ On the Macintosh, start the Terminal by going to the Applications 
folder, opening the Utilities folder, and double-clicking Terminal.
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3. In Windows, enter your username (if any) and password, and then press 
Enter.

The MySQL client’s command prompt appears, as follows:
mysql>

4. On the Macintosh, enter the following command:
mysql -uUser -pPassword

For example, if your MySQL user name (also known as an account 
name) and password are Tara and Telly3, enter the following 
command:
mysql -uTara -pTelly3

If you don’t have a password, omit the -p argument as follows:
mysql -uTara

If you didn’t define a user name while configuring your MySQL 
installation, enter root as the user name, as follows:
mysql -uroot

The MySQL client’s command prompt appears, as follows:
mysql>

5. Create a new database by entering the following command at the 
MySQL prompt:
mysql>CREATE DATABASE CafeTownsend;

MySQL creates a new database, but it doesn’t contain any tables or 
records yet.

6. Log out of the MySQL client by entering the following command at the 
prompt:
mysql>quit;

7. (Windows) Open the Windows command prompt by selecting Start > 
Run, and typing cmd in the Run dialog box.
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8. At the system command prompt, populate the new CafeTownsend 
database in MySQL.

In Windows, use the following command:
cd \
cd Program Files\MySQL\MySQL Server 4.x\bin
mysql -uUser -pPassword CafeTownsend < insert.sql

On the Macintosh, use the following command:
mysql -uUser -pPassword CafeTownsend < ~/Documents/

insert.sql

This command uses the insert.sql file to add tables and records to the 
CafeTownsend database you created in step 5.

After creating the MySQL database, create a database connection to it in 
Dreamweaver. 

Creating a database connection
The final step of the setup process is to create a connection to the database. 

To create a database connection in Dreamweaver:

1. Open any PHP page in Dreamweaver and then open the Databases 
panel (Window > Databases).

2. Click the Plus (+) button on the panel and select MySQL Connection 
from the pop-up menu.

The MySQL Connection dialog box appears,
3. Enter connTownsend as the connection name.

4. In the MySQL Server text box, specify the computer hosting MySQL.

Enter an IP address or a server name. If MySQL is running on the same 
computer as Dreamweaver, enter localhost.

5. Enter your MySQL user name and password.

If you didn’t define a user name while configuring your MySQL 
installation, enter root in the Username text box. If you don’t have a 
password, leave the Password text box blank.

6. In the Database text box, enter CafeTownsend.

CafeTownsend is the name of the sample MySQL database you created 
(see “Creating the MySQL database” on page 316).
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7. Click Test.

Dreamweaver attempts to connect to the database. If the connection 
fails, do the following:
■ Double-check the server name, user name, and password. 
■ Check the settings for the folder Dreamweaver uses to process 

dynamic pages (see “Specifying where dynamic pages can be 
processed (PHP)” on page 313).

■ Consult Chapter 29, “Troubleshooting Database Connections” in 
Using Dreamweaver (Help > Using Dreamweaver).

8. Click OK.

The new connection appears in the Databases panel.

The sample PHP application is now set up for the tutorials in Getting 
Started with Dreamweaver. For more information, see “Tutorial: 
Developing a Web Application” on page 197.
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