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ObjectivesObjectives

Introduce MS Excel Visual Basic for Applications (VBA)Introduce MS Excel Visual Basic for Applications (VBA)
Record and runn VBA macros
Introduce the VB Editor (VBE)( )
Edit a VBA macro
Debug and Run macros in VBE
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Visual Basic For ApplicationsVisual Basic For Applications

A macro writing languageA macro writing language
Event-driven programming language

A version of the Visual Basic programming language, 
with tools, functions, and methods customized to 
manipulate the “object model” of an applicationmanipulate the object model” of an application

Standard in MS Office: you already have it !Standard in MS Office: you already have it !
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How Excel VBA WorksHow Excel VBA Works
Record, write, or edit recorded VBA code (macros) to automate a 
complex or repetitive Excel taskcomplex or repetitive Excel task

Macros are saved in your specific Excel workbook or globally

Macros can be associated ith e ents click do ble clickMacros can be associated with events; click, double-click, 
keystroke, etc to fire them

You may add Windows objects (buttons, dropdown lists, check boxes, 
textboxes, dialogue boxes, menus, etc..) then write VBA code for eachtextboxes, dialogue boxes, menus, etc..) then write VBA code for each

The VB editor (VBE) is a part of Excel to view, edit, and run macros
A VB compiler in MS Office executes your codeA VB compiler in MS Office executes your code
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Demonstration TaskDemonstration Task

Goal:Goal:
Fill in the shown table using the given dataset (in an Excel sheet)
Have the table filled automatically using a VBA macro

Process:
Study the data and plan steps to prepare the summary for 2002
Record a VBA macro while performing these steps
Edit the macro to use it for the rest of the years 

2002 2003 2004 2005 2006
UCF
FAMU
FAU

Counts of Female Graduate Students Under 25

FIU
FSU
UF
UNF
USF
UWF
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The VB Tool BarThe VB Tool Bar 

Right-click in the toolbars area in Excel and select the Visual BasicRight click in the toolbars area in Excel and select the Visual Basic 
toolbar from the toolbars list

Run a 
VB 

Editor
Toolbox

macro

Start

Design 
Mode

Start 
Recording

Stop
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Recording a MacroRecording a Macro
Click the Record button
This dialog box appears
Give a name to the macro
Give a shortcut if you wantGive a shortcut, if you want
Specify where Excel saves it:

This Workbook
New WorkbookNew Workbook
Personal Macro Workbook

Saved in the STARTUP folder in 
your Office application directory
Becomes available whenever you 
use Excel
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Record The MacroRecord The Macro

Based on my plan I will do the following while recording:Based on my plan, I will do the following while recording:
Turn on the auto filter in Excel, using the first row of the data
Filter to 2002, graduate, women, under 25 years of age
Copy the filtered records and title row to the table sheet
Add summation formulas for the filtered records
Copy and paste-special (values & transpose) the summation 
cells into the table under the 2002 title
Go back to Data sheet and remove the filter 

End recordingEnd recording

Open VBE to view the recorded macro (next slide)p ( )
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The VB Editor (VBE)The VB Editor (VBE)

Design Mode
Run macro  
Pause running
End  running
Add break point

Project Window 
Properties window
Object model window
Toolbox

Project 
Window

p
Step by step run

Toolbox

Code 
Window

Properties
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The VBA SubroutineThe VBA Subroutine 
Sub SubName()

‘ Comments‘ Comments
…
VBA statements
VBA statements
…

End Sub

VBA statements deal with the Excel object model
Object model: collection of workbooks, sheets, columns, 
rows, ranges, cells, charts, formulas, filters, …etc.

VBA statement basic uses:
Change the properties of an object
Apply methods to the objectApply methods to the object
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Excel Object ModelExcel Object Model

Click (press F2) to start the Object Browser in VBEClick       (press F2) to start the Object Browser in VBE

Functions / 
Methods

Properties 
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Running the MacroRunning the Macro

Click the Run button in the VBA menu bar (Or press Alt + F8)Click the Run button in the VBA menu bar (Or press Alt  F8)
From the Macro dialogue box choose a macro to run then click Run

Step by step 
i i VBErunning in VBE

(debugging)

Start VBE

Change 
shortcut

List of 
macros

You may run the macro using the short cutYou may run the macro using the short cut
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Running the Macro in VBERunning the Macro in VBE

Start VBE from the VBA toolbar (Or press Alt + F11)Start VBE from the VBA toolbar (Or press Alt  F11)
Select the macro module in the Project Window (make sure to click 
inside the macro you want to run)
In VBE you may run edit or debug the macro:In VBE you may run, edit or debug the macro:

Running the macro: 
Use the icons           in VBE toolbar or the Run menu
Keyboard: F5 to run the current macro and Ctrl + Break to 
pause the run

Editing the macro
Debugging the macro

Use the Step Into icon     for step by step running
Keyboard: press F8 repeatedly y p p y
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Step by Step Execution and EditingStep by Step Execution and Editing
Change the following to run the macro for the 2003 year

Change 
to 2003

Replace with: Application.Range("A1").CurrentRegion.Select

Change 
to C3

February 07, 2008 14FAIR 2008: Introduction to VBA Macros in MS Excel



Error MessagesError Messages

An example of an error message:An example of an error message:
Shows if “Application.” is not used in 

Application.Range("A1").CurrentRegion.Select
Sometimes depending on Excel version

End: Stops executing the macro
Debug: takes you to the error in code
Continue: ignore the error if possible

Common errors:
MisspellingMisspelling 
Variables not defined
Missing arguments or options
Referencing non-existing sheet or workbook (named object)Referencing non existing sheet or workbook (named object)
Not using Application. before Range, Rows, Columns, Sheets, and few others
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Some EditingSome Editing
Referring to a cell: Cells(Rowindex,Columnindex)e e g to a ce Ce s( o de ,Co u de )

Cell in row 3 and column 21: Cells(3,21).Select

Referring to a cells range: R (C ll1 [C ll2]) S l tReferring to a cells range: Range(Cell1, [Cell2]).Select
Cell in row 6 and column 4: Range(“D6”).Select
Range across several rows and columns: 

R ( ll (4 6) C ll (12 8)) S l tRange(cells(4,6), Cells(12,8)).Select
Range(“D4”,”H12”).Select

Range of columns: Columns(FirstColIndex, LastColIndex)
Columns 5,6,and 7: Columns(“E”,“G”).Select

Range of rows: Columns(FirstRowIndex, LastRowIndex)g
Rows 2 through 7: Rows(“2:7”).Select
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R1C1 Notations in FormulasR1C1 Notations in Formulas

R1C1 uses numbers for columns instead of lettersR1C1 uses numbers for columns instead of letters
Excel uses this format when recording a macro
Must be inserted as a character in the selected cell range

Ex: Range("C7") FormulaR1C1 = “=SUM(R[ 5]C[1]:R[ 2]C[1])“Ex: Range( C7 ).FormulaR1C1 = =SUM(R[-5]C[1]:R[-2]C[1])
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Context Menus in EditingContext Menus in Editing

Each member of the Excel object model has properties, methods,Each member of the Excel object model has properties, methods, 
functions, and sometimes members of its own
The “.” operator following the object name activates its members list
Lists all that you may do with the objectLists all that you may do with the object 
There can be several levels of membership
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Context Menus in EditingContext Menus in Editing

Many members require arguments and may have optionsMany members require arguments and may have options
When adding a comment in a cell, type “(“ after selecting AddComment:

Add the comment text, e.g. “This is my chosen cell”
Type “)“ to end the statementType “)“ to end the statement

Options do not have to be between parentheses: 
Selection PasteSpecial Paste:=xlPasteValues Operation:=xlNone SkipBlanksSelection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _

:=False, Transpose:=True
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Security SettingsSecurity Settings 

Upon opening an Excel file with a macro the following warningUpon opening an Excel file with a macro the following warning 
appears
To use the macro click “Enable Macros”
If “Disable Macros” clicked Excel will not load the VBA modulesIf Disable Macros  clicked, Excel will not load the VBA modules

If no warning appears then security settings must be adjusted toIf no warning appears, then security settings must be adjusted to 
allow macros
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Setting Security LevelSetting Security Level

From the Tools menu, select Macro then SecurityFrom the Tools menu, select Macro then Security
Set the security level in the Security dialogue box to medium
Restart the Excel file
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Next StepsNext Steps

We have introduced using VBA in MS ExcelWe have introduced using VBA in MS Excel
How to record and run a macro
How to use VBE
How to debug and edit a recorded macro
How to set the security level to allow the saved macros

How to practice:
Record macros while perfoming different Excel tasks and study the code
Modify the code in VBE and watch the results using step by step execution

What do you need:
One or more Excel VBA programming books and the VBA help
Learn some general purpose VB statements

The IF – Then statement
The FOR – Next statement
Defining variablesDefining variables
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Contact InformationContact Information
Magdy Helal; Research Associate, mhelal@mail.ucf.edu g y ; , @
Sandra Archer; Director, archer@mail.ucf.edu

University Analysis and Planning Support
University of Central FloridaUniversity of Central Florida
12424 Research Parkway, Suite 215
Orlando, FL, 32826-3207
Phone: 407-882-0285
http://uaps ucf eduhttp://uaps.ucf.edu

Presentation will be available at http://uaps.ucf.edu

VBA Resources:
MSDN: http://msdn2.microsoft.com/en-us/isv/bb190538.aspx 
John Walkenbach “Excel 2003 Power Programming with VBA” Wiley Publishing Inc 2003John Walkenbach, Excel 2003 Power Programming with VBA , Wiley Publishing Inc., 2003
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VBA in Excel 2007VBA in Excel 2007
The Visual Basic icon bar of 2003 is 
replaced by the Developer tab in 2007

1
replaced by the Developer tab in 2007
If the Developer tab is not shown on 
among Excel menus, add the Developer 
tab as follows:tab as follows:

1. Click the Office Button
2. Click Excel Options
3. Select Popular 
4. Check Show Developer tab in the Ribbon 

23

4
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The VBA Ribbon in 2007The VBA Ribbon in 2007
The Developer tab appears on the Excel ribbon
VBA i d b l k diff f h i 2003VBA icons and buttons look different from those in 2003
Buttons are pointed to
All buttons do the same functions as in 2003

Toolbox and user 

S

interface design 
toolsRecord a 

macro

Start 
VBE

Show macros 
S itdialog box
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Security Settings in 2007Security Settings in 2007

Click Macro Security in the Developer tabClick Macro Security in the Developer tab
Trust Center dialog box appears
Select Macro Settings
Make the settings as shownMake the settings as shown 
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Security Settings in 2007Security Settings in 2007
When you open an Excel file with a macro a security warning appears y p y g pp
below the ribbon with the Options… button
Click Options… to show the Microsoft Office Security Options dialog box
Click “Enable This Content” to all the macro
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