JMatchMap by Agnés Simonet July 2020

JMatch Map

JMM v 2.1
(for Hot Potatoes v7)

The examples in this tutorial are for version 2.0.1.

You can easily adapt them for other versions (2.0.2, 2.1 etc.)
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| What is a Jmatch Map exercise?

It's a JMatch exercise using drag&drop format where you can drag and drop items onto areas
defined in an image (this kind of image with areas is called image map).

Placer les |légendes sur la carte.

Veérifier |

Oceanie
Europe
Ameérique |

Afrique

Il How to install Jmatch Map?

Unzip JMM_201.zip and copy the JMM_201 folder where you want, for example in the source
folder of Hot Potatoes:

'g HotPotatoes7?

r g scorm_schemas

"g source
(] MH_201
& JMM_201
(] “Ms_201
» (] Msv_201

Note: you can copy the folder anywhere on your hard disk and rename it as you like.
Check that the demos, hif and source folders are present:

-F JMM_201

’ g demos_JMM

» (gl hif MM

» (] source_JMM



Il How to load the interface file

You don't necessarily have to do it but if you load the interface file associated with Jmatch Map it will
be easier for you to create your exercise and change the configuration output.

Open JMatch. Click on Options->Interface->Load interface file.

Help

r% Configure Output | a e L5 i

qu.a nght to-Left

. Toolbar Options
Show tooltips | |

F 2 J I]rag

Eg Reload Config Info from File §—

%- Iranslate the Interface

@ Reset DeTault Interface
i

'E'g Set source fite location
E Clear source file location

Browse to the folder JMM_201/hif_JMM and choose the JMM_201_en.hif (or JMM_201_fr.hif) file.

' Load a Hot Potatoes Interface file

Rechercher | hif_] MM ﬂ

[ | JMM_201_en hif
[~ ] JMM_201_fr hif

In the JMM _201/hif_JMM folder you will not find all the existing hif. You will find them, if they exist,
on the hpaddons site.

You can add the translation in your language, if it does not exist, on the Paolo Cutini’s site or
contact me on the hotpotatoesusers Yahoo group (you need to subscribe)

A dialogue box will ask you if you would like to change the interface for all applications. Choose “No".

Confirm m

o Would you like to use this interface file for all the applications in this suite?

[ Yes l [ Mo
You will immediately notice the change:
Title UMatch Map for HP7 - Continents
1:image map code / 2,3 etc. : areas code Draggable {jumbled) items Fix

Other changes can be seen in Options>Configuration output.


mailto:hotpotatoesusers-subscribe@yahoogroups.com?subject=subscribe
mailto:hotpotatoesusers@yahoogroups.com%20?subject=hif%20translation
https://docs.google.com/forms/d/e/1FAIpQLSfyD_kfJY2-I7VYUuKsu-yGw2sePOm8gzLRGk1YT5zWNE4JdA/viewform
http://hpaddons.free.fr/translations/translations.html

lll How to create a Jmatch Map exercise?

The example refers to the exercise continents.jmt in the demos_JMM folder.

1- You need an image (continents.png which must be in your exercise folder) that you will map. It's
very easy to do and there are lots of softwares that can do it, even online. | recommend Gimp as it
is a cross-platform software and very easy to use. Online, image-map.net is a very good site.

If you do it for the first time you will perhaps make it in half an hour but after that it will only take a
few minutes.

See the detailled procedure in image_map_tutorial.pdf

At the end you will have a text file (continents.png.map) whose content is the code for the image
map:

<img src="continents.png" alt="continents" width="536" height="258"
usemap="4#map" />

<map name="map">

<area shape="rect" coords="463,191,475,203" alt="Océanie" href="#" />
<area shape="rect" coords="276,141,288,153" alt="Afrique" href="#" />
<area shape="rect" coords="268,53,280,65" alt="Europe" href="#" />
<area shape="rect" coords="60,66,72,78" alt="Amerique" href="#" />
<area shape="rect" coords="390,53,402,65" alt="Asie" href="#" />
</map>

2- Open JMatch.

3- Copy all the text of continents.png.map and paste it in the first left box.

Left (ordered) items
<img src="continents.png" alt="continents" width="536" height="258"

usemap="#map" />

<map name="map">

<area shape="rect" coords="463,191 475 203" alt="0céanie" href="#" />
<area shape="rect" coords="2VE 141 288 153" alt="Afrique" hret="#" />

<area shape="rect" coords="268 53 280 65" alt="Europe" href="#" /> -

Don't write anything in the corresponding right box.
4- In the others left boxes (2,3 etc.) copy and paste the code for each area.

=area shape="rect" coords="463,191 475 203" alt="Océanie" href="#" /> Océanie
: <area shape="rect" coords="276,141,288 153" alt="Afrique" href="#" /= Afrique

<area shape="rect" coords="268 53 280 65" alt="Europe" href="#" /> Europe

In the corresponding right boxes type the text of the draggable cards.
Note 1: you don't have to use all the areas defined in the first left box.

Note 2: you don't have to use the same word(s) in the right boxes that the one(s) in the alt tag for
areas.


http://image-map.net/
https://www.gimp.org/downloads/

5- As it is, your exercise will be working but will not satisfy the validator (for validation, an area tag must
always be associated with a map tag). So, in the left boxes (2,3 etc.) replace <area by *area (in fact
you have to change < in any other character, so you can replace it by *, £ or & etc).

Be careful: don’t change <area in the first left box.

<img src="continents.png" alt="continents" width="536" height="258" =
usemap="#map" />

1 <map name="map">
| <areashape="ract” coords="463,191 475 203" alt="Océanie" hreF="#" />

-

hape="rect" coords="463 191 475 203" alt="Ccéanie" href="#" /= Océanie
2

(Farea phape="rect" coords="276,141,288,153" alt="Afrique" href="#" /> Afrique
3

hape:"rect" coords="268 53 280 65" alt="Europe" href="#" /> Europe

6- Now it's time to tell JMatch that instead of using the original source files, the special source files
have to be used.

Press the Shift + Control + ALT + S keys simultaneously.
Choose the special source folder where the necessary file(s) are located

=5 source ﬂ

[EyF1a_sm

[F_s01
[5)cdd_s0m
E)Mem_s01 J
EMH_2m1
=HES I MM_201
Edemns_]MM
[ nif_ymm

Eyms_2m
You will see which source folder is in use :

5 *area shape="circle" coords="357 102 14" alt="Stras

ISuurcE: ChProgram Files (x86)\HotPotatoes Msourcey ) MM_201source_| MM‘LI

7- Create your web-exercice using CTRL + F6 or the appropriate file menu item o

Be aware that the next time the JMatch program is loaded, it will use this special source files folder.

If you want to create another exercise with the original Jmatch, press the Shift + Control + ALT + T
keys simultaneously.

If you want to create another type of JMatch exercise (using another add-on), press the Shift +
Control + ALT + S keys simultaneously and choose the adequate source folder.


https://validator.w3.org/

IV Configuration

1- How to modify the opacity?

For some exercises (as continents.htm) you don't want the cards to hide the image. For others
(such as JMM_203_demo2.htm) opaque cards are not a problem.

You can define a value for the opacity of the background of the droppable areas and another
one for the opacity of draggable cards.

'C.'Lliianfiguratinn file: C:\Program Files (x86)\HotPotatoesTYenglish7.cfg
Undo Insert

Titles/Instructions | Prompts/iFeedback | Buttons | Appearance | Timer Other |Custum CGl

User-defined strings

[[Dptiunal] Droppable areas opacity * draggable cards opacity (e.g. : 0.4"0.7) ]

0507

[Optional] Font size (in px,em or %) for text in droppable areas * font size for text in draggable can
160%*20px

[Optional] Auto-highlight of right and wrong items (0: no - 1: yes)
1

The first value (0.5) is for the opacity of the areas (E)

The second value (0.7) is for the opacity of the draggable cards ( . mmr )-
Both values must be between 0 and 1:

° a value of 1 means that the background will be totally opaque.

o a value of 0 means that the background will be totally transparent
The values must be separated by an asterisk (*)

If you keep the box empty the default opacity values will be 1 (totally opaque).
If you use values higher than 1 the opacity values will be set to 1 (totally opaque).



2- How to modify the font sizes?

You can use a font size for the text in droppable areas and the font size for the text in
draggable cards.

Undo Insert

|Titlesrlnstructiuns || Prnmptereedback” Buttons || Appearance || Timer || Other | Custom | CGI

User-defined strings
[Optional] droppable areas opacity * draggable cards opacity (e.g. : 0.4"0.7)
04704

160%"20px

[[Gptiunal] font size (in px,em or %) for text in droppable areas ™ font size for text in draggable card

[Optional] Auto-highlight of right and wrong items (0: no - 1; yes)
1

The first value (160%) is for the font size of the text in the areas ("?")
The second value (20px) is for the font size of the text in the draggable cards.
The values must be separated by an asterisk (*)

You need to specify the unit (px, em or %). For example, if you want a value in px, type
"100px", don’t type "400".

The font size for the text ("?") in the droppable areas determines the height and width of

the droppable area.
‘ 100% (

Opx m

Afrique Afrique

Océanie Oceéanie

Europe Europe

Ameérique Amérique
- ~ * . - *

If you keep the box empty the default font size will be the one defined in hp7.cs_
(usually 100%).



3- How to enable Practice mode and Test mode?

Undo Insert

|Tit|es!lnstructiun5 || F’rumpts!Feedback” Buttons || Appearance || Timer || Other | Custom | CGl

—User-defined strings
[Optional] droppable areas opacity * draggable cards opacity (e.g. : 0.4*0.7)
0.4%0.4

[Optional] font size (in px,em or %) for text in droppable areas * font size for text in draggable card
160%*20px

1

[[Gptiunal] Auto-highlight of right and wrong items (0: no - 1; yes) ]

- Type "1" to enable the Practice mode: in Practice mode the items are automatically
highlighted as soon as they are positioned, using the defined colors (see below, page 9)

Veérifier I

Oceéanie l

- If empty or if you type "0" the default mode is Test mode. Answers will be highlighted after

validation.
o ] \otre score 20%.
Vérifier I Désolée... Corrigez.




4- How to choose the colors for wrongly and rightly positioned items?

You can choose the border color for wrong and right items in Options>Configuration
output>Appearance:

Title Mavigation bar colour: |#008000
Text text text text text text text text text text texd texd text text text text text Page background colour: |7
i Title colour: #0000

Exercise background colour, \#7{77
[ Correctitems + Link colour: [ #b8fd37
|

necorrect items + visited links: | #F08080
[& Preview Text colour. #000060

b AR) LAVRVRD)

5- How to define the width of the reading text container?
If you use a reading text (it's now available with JMatch drag and drop for HP7, thanks to Martin)
you can easily choose the width of the reading text container.
Options>Configuration output>Custom:

Code for insertion into <head= tag

<style> -
div.ReadingContainerflex-grow. 20;}
div.ExerciseContainerflex-grow: 80;}

</style>

The logic is :
width of {ReadingContainer + ExerciseContainer}: 20 + 80 =100
width of ReadingContainer: 20/100 (20%)
width of ExerciseContainer: 80/100 (80%)



So if you want the width of the reading text container to be 40% of the width of the page, use 40
for ReadingContainer and 60 (=100-40) for ExerciseContainer. So type:

<style>
div.ReadingContainer{flex-grow: 40;}
div.ExerciseContainer{flex-grow: 60;}
</style>

Code for insertion into <head= tag

<style= =
div.ReadingContainerdflex-grow: 40;}
div.ExerciseContainer{flex-grow: 60;}

</style>

If empty, the widths will be 50% for ReadingContainer and 50% for ExerciseContainer.

V- Other tips

1- Mini audio button

With Hot Potatoes v7, via "Insert> Insert a media object", you can insert a classic HTMLS5 audio
player:

You can also use the HTML5 audio player button created for my Hot Potatoes add-ons: [fl-.\:]

You can use it everywhere: in the draggable cards, in the reading text, the title etc.
See audio_tutorial.pdf in the tutorials folder that you got when you unzipped JMM_201.zip.

Note : from version 2.1 the tutorial is called audio_tutorial_4.pdf (use of player4.js).
2- Borders of checked cards

They are defined at the beginning of hp7.cs_.

Search for —strBorderWidth_IfChecked, near line 58:

/* added by AS */
--strBorderWidth IfDropped: 3px; /* for JMH */
—--strBorderWidth IfUnDropped: lpx; /* for JMH,JMM */
--strBorderColor IfUnDropped: silver; /* for JMH, JMM */
--strBorderWidth IfChecked: 3px; /* for JMM */

You can modify the values in relation with JMM.
Don't forget to save the modified hp7.cs_.



3- Areas and map styles

The styles of the map and the areas are defined at the beginning of hp7.cs_ near line 61.

--strAreaBGColor: white; /*for JMM */
--strAreaBorderColor: silver; /* for JMM */
--strMapBorderWidth: 5px; /* for JMM */
--strMapBorderColor: silver; /* for JMM */
--strMapPadding: 50px; /* for JMM */

You can modify these values (you can find the names or the HTML hexadecimal codes for colours
on wikipedia ).
Don't forget to save the modified hp7.cs_.

4- Spaces
They are defined at the beginning of the djmatch7.js_ file.

Search for this part near line 51:
JJS=e=ms===s====—====—=————————ooee

// variables : valeurs modifiables ; you can modify these variable values
[) =——————cscoscocoooooooocososoonoooos

// entre les cartes d'une colonne

// between draggable cards

var spacerV = 5;

// entre les colonnes de cartes mobiles
// between rows of draggable cards
var spacerH RIC RIC = 10 ;

// entre image et carte mobile
// between image and draggable cards
var spacer IMG RIC = 30;

// entre div des boutons et image
// between checkbuttondiv and the image
var spacerV_topButtonDiv IMG = 10;

// alpha pour la couleur quand on fait glisser (permet une transparence)
// alpha for color when dragging (transparency)
var alphaDragging = '0.4"';

You can change the values (5, 10 etc.).

Don't forget to save the modified djmatch7.js_.
5- How to change the text in areas

By default the text is a question mark (?).
You can change this, for example use a round (o or e) or any other symbol.

Open djmatch7.js_. Near line 710 you will see

// Affichage des left items (areas)

for (i=0; i<this.LeftItems.length; i++) {
CurrentItem = this.LeftItems[i];
CurrCard = CurrentItem.Card;
CurrCard.style.fontSize = LIC fontSize;
CurrCard.style.backgroundColor = LIC BkgColorRGBA;
CurrCard.innerHTML = '?';

Change CurrCard.innerHTML = '?'; in CurrCard.innerHTML = 'o’; or CurrCard.innerHTML ="e";

Don't forget to save the modified djmatch7.js_.


https://en.wikipedia.org/wiki/Web_colors

6- Modifications of hp7.cs_ and djmatch7.ht_

My modifications of the original hp7.cs_ and djmatch7.ht_ files are described at the beginning of
these files.

So the users who would have modified the original hp7.cs_ and djmatch7.ht_ files can transpose
my modifications in their own files.

hp7.cs_ is the same for all my JMatch add-ons (JMH, JMS and JMM). So if you modify one you
just have to copy your modified files in the source folder of the other add-ons.
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