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Help

Help

The Help facilities in OpenOffice.org (OOo) are very similar to the equivalent in Microsoft 
Office (MSO).

If you pause the mouse pointer over a button, you will see a tooltip describing the button. To 
turn this feature on or off, use Tools > Options > OpenOffice.org > General.

Pressing Shift + F1, selecting Help > What’s This?, or clicking  changes the pointer to a 
question mark. When the question mark pointer is over a button or control on a dialog, a 
more detailed description is displayed until the next mouse click.

Note Pressing Shift + F1 is equivalent to turning on extended tips, Tools > Options > 
OpenOffice.org > General, except that it only stays on until you click again.

Based on whatever is currently selected, pressing F1 displays contextual help.

The equivalent to the MSO “Office Assistant” is called the Help Agent. It 
“lights up”, alerting the user that help is available for an event that has just 
happened. Examples are when a user first saves a file, or when a word gets 
automatically corrected. 

The Help Agent can be turned off and on by using Tools > Options > 
OpenOffice.org > General.

Zoom - the view percentage

To change the size at which the document is displayed on the monitor, select View > Zoom, 
or right-click or double-click the number with a percentage sign next to it on the status bar.

In Writer the Optimal option zooms the display so that the document is displayed between 
left and right margins. The zoom factor is automatically adjusted when side panels are 
displayed.

AutoCorrect and AutoFormat

AutoCorrect and AutoFormat work much the same in OOo as in MSO.

In addition, Writer includes a word completion feature. If it is enabled, Writer tries to guess 
which word you are typing and offers to complete this word for you. To accept the 
suggestion, press Enter. Otherwise continue typing.

Settings for this feature, including turning it off or changing the key that accepts the 
suggestion, are in the Tools > AutoCorrect > Word Completion tab (Figure 1).
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AutoCorrect and AutoFormat

Figure 1: Settings for automatic word completion

Menus

OOo’s menus are similar to MSO’s, but some commands are in different locations. For 
example, OOo considers page layout a format issue, so it is found in the Format menu 
(Format > Page) instead of in the File menu. In addition, OOo includes some features that 
MSO does not (for example, built-in Export to PDF). 

For information on how to customize menus (including adding and removing items), see 
Chapter 8, “Customizing OpenOffice.org” in this guide.

Personalized menus
OOo does not have personalized menus. This feature in MSO reorganizes the menus so that 
your most frequently used options are displayed first and little-used options are removed 
from the list.

In OOo some menu items may be relevant to the current cursor location but are inactive and 
grayed-out. For example, the sort command (Tools > Sort) is not available when nothing is 
selected. By default these menu items are not displayed. To make them visible, use Tools > 
Options > OpenOffice.org > View > Show inactive menu items.
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Toolbars

Toolbars

The default location of some icons may be different from the default location in MSO. The 
icons are also not identical. Many icons can be expanded into submenus or tear-off toolbars.

Most toolbars in OOo can be made floating or can be docked in various positions. To move a 
toolbar, place the mouse pointer over the toolbar handle (or the title bar of a floating toolbar), 
hold down the left mouse button and drag the toolbar to the new location.

Tear-off toolbars area always floating. See Chapter 4, “Menus and Toolbars” in the Getting 
Started guide for more information on moving, docking and customizing toolbars.

For information on how to customize toolbars (including adding and removing icons), see 
Chapter 8, “Customizing OpenOffice.org” in this guide.

Drag and drop

While drag and drop does work in OOo, there is less feedback with pointer changing in OOo 
than in MSO. For example, when moving the pointer onto a selected piece of text, the pointer 
remains the usual I bar rather than changing to an arrow. However, the text can be dragged as 
required. 

There is no equivalent to Shift+Click+drag.

Side panes - docked or floating windows

MSO XP introduced the concept of side panes. These are the closest equivalent to OOo’s 
docked or floating windows. In OOo these windows include:

• Navigator to help move around the document (the closest equivalent in MSO would be 
the Outline view in Word).

• Styles and Formatting for managing styles.

• Gallery, a clip art viewer.

• Function Wizard, which helps you interactively create formulas; available only in Calc.

• Data Source Explorer, from which you can drag and drop fields from registered 
databases into your documents; available in Calc and Writer.

There is no equivalent of the MSO Clipboard for handling multiple copies.
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Side panes - docked or floating windows

Docking and undocking
Some windows in OpenOffice.org, such as the Navigator and the Styles and Formatting 
window, are dockable. You can move, re-size or dock them to an edge. 

To dock a window, do one of the following: 

• Click on the title bar of the floating window and 
drag it to the side until you see the outline of a 
box appear in the main window (see Figure 2), 
then release the window. This method depends 
on your system’s window manager settings, so 
it may not work for you.

• Hold down the Control key and double-click on 
a vacant part of the floating window to dock it 
in its last position. If that does not work, try 
double-clicking without using the Control key.

To undock a window, hold down the Control key and 
double-click on a vacant part of the docked window.

Note The Styles and Formatting window can also 
be docked or undocked by using Control+ 
double-click on the gray area next to the 
icons at the top of the window.

Figure 2: Docking a window

It is possible to have two windows in the same area. For example, the Styles and Formatting 
window and the Navigator can be at the right edge with one above the other rather than side 
by side. Then the show/hide and stick/floating buttons work for both docked windows.

Resizing
Docked windows can be resized by moving the border. When the mouse pointer changes to a 
double-ended arrow, click and drag the window to the desired size.

Navigator

The Navigator (Figure 3) is activated and deactivated by F5, the Navigator button, , in the 
Standard toolbar, or Edit > Navigator. This window shows the different objects in the 
current document and enables you to move quickly among them. Details vary from one 
application to another. For example in Writer it shows the list of headings and has controls 
similar to Outline view in Word. The drop-down list at the bottom of the Navigator is for 
selecting which of the currently open documents has information displayed in the Navigator.

For more information, see “Using the Navigator” in Chapter 4, “Menus and Toolbars” in the 
Getting Started guide, and descriptions of the Navigator in the guides for each of the 
applications.
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Side panes - docked or floating windows

Figure 3. The Navigator in Writer

Styles and Formatting
The Styles and Formatting window (Figure 4) can be activated and deactivated by F11, the 

Styles and Formatting icon  , or Format > Styles and Formatting.

Figure 4: Styles and Formatting window in Writer

To change the category of styles displayed, use the buttons across the top of the window. For 
example, in Writer the buttons are Paragraph, Character, Frame, Page, and List. The drop-
down list at the bottom of the Styles and Formatting window determines which of the style 
types get displayed in the window. For example, in Writer for character styles the options are 
Hierarchical, All, Applied, and Custom.

The style of the current selection is highlighted in the list of styles.
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Side panes - docked or floating windows

See Chapter 6, “Introduction to Styles” and Chapter 7, “Working with Styles” in the Writer 
Guide for more information about style types and how the other icons in the window work.

Gallery

The Gallery (Figure 5) is activated and deactivated by clicking the Gallery button , in the 
Standard toolbar or by selecting Tools > Gallery.

Note There is no default shortcut key to activate the Gallery.

Figure 5: The Gallery in Writer

The Gallery is OOo’s equivalent to MSO’s Media Gallery, except that it does not have ties to 
the Web and there is no search facility. In order to keep the OOo download as small as 
possible, very little clip-art comes with OOo. To download some public domain clip-art, see 
http://www.openclipart.org/.

Media in the Gallery is organized by themes. Themes are displayed down the left side of the 
Gallery window.

For information on how to use the Gallery, see Chapter 14, “Working with the Gallery” in the 
Getting Started guide.
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Side panes - docked or floating windows

Data Source Explorer
The Data Source Explorer is activated and deactivated by pressing F4 or by clicking the Data 

Sources button    in the Standard Toolbar or by selecting View > Data Sources.

Figure 6: The Data Source Explorer in Writer

A common use for this window is in setting up a template for a mail merge letter. You can 
drag and drop fields from data sources in the Explorer to create fields in the current 
document.

The Data Source Explorer can only be docked at the top of the main window.

For more information on how to use data sources, see Chapter 10, “Getting Started with 
Base” in the Getting Started guide.

Page preview

File > Page Preview in OOo is the equivalent of MSO’s Print Preview. You can chose to 
view and print single pages, two pages, multiple pages, or facing pages (called “Book 
Preview”).

The Zoom button in OOo only zooms the view. It does not provide a pointer for you to select 
an area to zoom in on.
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Keyboard shortcuts

Keyboard shortcuts

These standard keyboard shortcuts are the same as in MSO:

• Cut (Control+X) 

• Copy (Control+C) 

• Paste (Control+V) 

• Undo (Control+Z) 

• Redo (Control+Y) 

• Save (Control+S) 

• Open (Control+O) 

• New (Control+N) 

Smart tags

Smart tags are not available in OOo.

Special characters or symbols

The equivalent of insert symbols is Insert > Special Character.

You can not enter special characters in OOo using standard hex codes as you can in MSO.

Note There is no second tab for common special characters such as the em-dash. 
Workarounds are to use AutoFormat/AutoCorrect, AutoText or you can record a 
macro.

File management

Default locations
Use Tools > Options > OpenOffice.org > Paths to set the default locations for file storage. 
The two path settings of interest (at this stage) are My Documents and Templates.

My Documents only allows one location. It is not possible to have a separate folder for each 
of the applications. This folder is the default location for File > Save As and is the folder that 
gets displayed in the OOo Open and Save As dialogs. 

For templates it is possible to have more than one folder specified. These are the folders that 
are shown down the left side of the dialog that gets displayed for File > New > Templates 
and Documents (see “Creating new files” on page 9).
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File management

For more about defining default locations, see Chapter 5, “Setting Up OpenOffice.org” in the 
Getting Started guide.

Creating new files
In OOo, as with MSO, there are a number of different ways of creating new files. What is 
different is that you can initiate the creation of any OOo file type from any OOo application. 
For example, you can start creating a spreadsheet while working in Writer.

Different ways of creating a new document:

• Select File > New.

• Use the New icon on the Function Bar. This icon has a drop-down list on the right to 
select the type of document to be created.

• From a “Quick start” program. Only the Windows version of OOo has a Quickstart 
icon in the system tray.

• Press Control+N.

• Using Wizards: select File > Wizards.

Template folder management
To make it easier to manage your templates, such as creating and deleting folders 
(categories), and importing templates into the folders, use:

File > Templates > Organize > Double-click the desired folder > Commands 

Default templates
Each component of OOo has a unique default template. To change the default template for a 
component:

1) Save the current template using File > Templates > Save.

2) Select File > Templates > Organize,

3) Double-click the folder in which you saved the template in step 1.

4) Click on the template you want to make the default.

5) Either right-click or select Commands > Set As Default Template.

Note The default template in MSO is always a file called Normal.dot. In OOo there is no 
special name for the default template files. They can be called anything. If no 
template has been specified, the properties of the default template are those that are 
coded directly into OOo.
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File management

Open and Save As dialogs
Under Microsoft Windows there is the option to use either the OOo Open and Save As 
dialogs or the ones provided by Windows. To view or change which type of dialog OOo is 
using, select Tools > Options > OpenOffice.org > General > Use OpenOffice.org dialogs.

Note The dialogs provided by Windows are not the dialogs used by MSO!

This section discusses the OpenOffice.org Open and Save As dialogs. See Figure 7 for an 
examples of the Open dialog; the Save As dialog is similar.

The three buttons in the top right are, from left to right:

• Go Up one level in the folder (directory) hierarchy. This is a long-click button if you 
want to go up higher than just one level

• Create New Directory (folder).

• Go to the Default Directory as specified in Tools > Options > OpenOffice.org > Paths.

For OOo documents that have been saved as more than one version, you can use the version 
drop-down to select the version you want to open in read-only mode.

Note For Microsoft Office documents, only the current version can be opened.

Figure 7. The OOo Open dialog.
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File management

The File type field has the same concept in OOo as in MSO; use it to specify the type of file 
to be opened or the format of the file to be saved.

The Read-only checkbox opens the file for reading and printing only. Consequently most of 
the toolbars disappear and most menu options are disabled. An Edit File button is displayed 
on the Function Toolbar to open the file for editing. The opened file cannot be saved over the 
previous filename. 

It is possible to open files from the web using URLs. 

File management within an OpenOffice.org Open or Save As dialog

To rename a file:

1) Right-click on a file name to display a context menu.

2) Click Rename and the file name will be selected.

3) Typing replaces all or part of the selected name.

To delete a file:

1) Right-click on a file name to display a context menu.

2) Click Delete and you will get a confirmation dialog.

Note Instead of Right-click > Delete, you can select the filename and press the Del key.

It is not possible to move files around by copying and pasting them within the dialogs.

Password protection
To protect an entire document from being viewed, there is a checkbox in the Save As dialog 
to Save with password. This option is only available for files saved in OOo formats.

Privacy options
To include or remove personal information (for example, the author’s name) in the Properties 
dialog with the document, go to File > Properties > General. The Delete button removes 
information. The Apply user data checkbox includes or removes information such as 
“Author”.

Digital signatures
OOo provides digital signatures to ensure the integrity of the file, as do recent versions of 
MSO.
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File management

Portable Document Format (PDF) file creation
All of the applications in OOo have the built-in ability to export documents as PDF files. 
Click on the Export Directly as PDF icon on the Standard toolbar, , or use File > Export 
as PDF. The second method provides access to choices that include the print quality and the 
range of pages to be printed to the file.

Creating web pages (HTML files) overview
All of the OOo applications can be used to create web pages. This section introduces their 
HTML capabilities. For more details, see Chapter 16, “Creating Web Pages” in the Getting 
Started guide.

Writer

Writer’s HTML capabilities include saving existing documents in HTML format, creating 
new documents as HTML and creating several different types of web pages using a wizard .

Calc

Calc can save its files as HTML documents. If the file contains more than one sheet the 
additional sheets will follow one another in the HTML file. Links to each sheet will be placed 
at the top of the document. Calc also allows the insertion of links directly into the spreadsheet 
by using the Hyperlink dialog.

Draw

It is possible to export drawings as Macromedia Flash files: File >Export and choose 
Macromedia Flash for the file type.

The drawing program also allows you to turn your drawings into a series of HTML web 
pages. 

Impress

Exporting presentations from OOo’s Impress application is similar to exporting a drawing 
from Draw. Use File > Export and select HTML document as the file type. The only 
difference is that there is an option to display each slide’s notes along with the slide.

Document properties
Some differences in document properties are:

• Summary (MSO) or Description (OOo): OOo does not include fields for manager or 
category.

• Statistics: Writer includes the word count (also available in Tools > Word Count).

• Custom (MSO) or User defined (OOo): OOo provides only four fields. To name the 
fields as you like, click the Info fields button.

• Use the Internet tab to set the refresh and redirect options for an HTML page.
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File management

Searching for files
There is no Find Files command built-in to OOo for finding files that contain specific text. 
However a component has been written that can be installed to provide this functionality. See 
http://qa.openoffice.org/issues/show_bug.cgi?id=41011.

Object linking between files
For information on Object Linking and Embedding (OLE), and what happens with imported 
files containing DDE links, see Chapter 2, “Sharing Files with MSO Users” in this guide.

In the Windows version of OOo you can copy and paste-special cells from a Calc spreadsheet 
into a Writer document as a Dynamic Data Exchange (DDE) link. In the Windows version 
you can create a DDE field. Neither of these options is available in the Linux version. 
Opening a file from the Windows version in a Linux version works, although some 
modification of the file location may be necessary. If you would like to know more, see 
http://www.openoffice.org/issues/show_bug.cgi?id=5317.

Regardless of operating system, it is not possible to have a link to a chart.

AutoRecovery saves
To turn on/off AutoRecovery saving and set the time period between saves, use:

Tools > Options > Load/Save > General > Save AutoRecovery information every

Caution AutoRecovery saves will not allow you to return to the original version of a 
document. AutoRecovery saves save the current document at that instant. If you want 
to save a backup copy that you can return to in case you make a mistake, check the 
Always create backup copy checkbox in the Load/Save options. This will created a 
backup copy every time you click Save. However, it only saves one backup per 
filename.

Version control
With version control you can save more than one version of a file under one file name. In 
MSO each version contains all of the changes that have been made to the document (like fast 
saves). In OOo each version is complete. Use File > Versions.

To save a version of a file, see “Open and Save As dialogs” on page 10.

Working with multiple open files

OpenOffice.org uses a Single Document Interface (SDI). This means that each open 
document has its own window. The Window menu displays all of the currently open 
documents in OOo.
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Working with multiple open files

Two of OOo’s strong points are the accessibility of information about the active document 
and the ease of navigating among open documents. Each OpenOffice.org window provides 
menus, toolbars and other features directly relating to the document in that window. 

When more than one OpenOffice.org document is open, you can switch between the active 
document and other open documents in several ways:

• From the Window menu, select the document you want to become active.

• Use the Minimize button on the titlebar to minimize the active document and reveal 
other open documents.

• Select a document from your desktop’s Panel or Taskbar to activate it.

• Close the current document to access other open documents.

• Use the Alt+Tab shortcut keys to cycle through the open documents.

In MSO Control+F6 switches between documents. In OOo F6 is used to move to the menu 
and each of the toolbars. Control+F6 makes the current document active.

Find and Replace

Find and replace are combined in OOo, unlike MSO. There is no separate menu entry or key 
shortcut for replace. Use Edit > Find & Replace, or Control+F , or click the Find & Replace 
icon   on the Standard toolbar.

Figure 8: The Find & Replace dialog
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Find and Replace

There is no “word forms” search.

Having performed a search, and having closed the dialog box, the keyboard shortcut to repeat 
the search is Control+Shift+F.

Searches are paragraph-based. There is no way to search for text either side of a paragraph 
marker. For example, OOo cannot search for two blank paragraphs. To get around this 
problem, and some other issues, a macro has been developed. See IannzFindReplace (last 
updated 20 March 2006), available from http://homepages.paradise.net.nz/hillview/OOo/. 

Note Manual page breaks are handled internally by changing the paragraph format of the 
first paragraph on the new page. When searching for formats this option is grayed 
out because there is no way to search for “manual” page breaks.

Tips for find and replace
It is common to do several find and replace operations on the same selection, however OOo 
does not “remember” the original selection. Before doing the find and replace you can 
bookmark the selection in Writer, or define a range name for the selection in Calc, so that, by 
using the Navigator, the same range can be quickly reselected.

Doing a “find all” selects all the pieces of text that match the criteria. It is possible to 
perform, on all the selections, most operations that are possible on a single selection.

Attributes
The Attributes button is only available in Writer’s Find & Replace dialog. This button 
displays a dialog with a series of checkboxes to find where a particular attribute has been 
changed from the default for the underlying style. For example, selecting the attribute “Font 
weight” will find text that has been made bold where the underlying font is not bold (and vice 
versa).

Note The attributes settings remain between uses of the Find & Replace dialog. This can 
be frustrating, so always turn off all of the attribute settings after each use.

Formats
This is the same search concept as in MSO. Note that when formats are used, there is an 
option to include searching within styles. For example, searching for bold text would not find 
bold text where the style is bold unless this option is checked.
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Find and Replace

Regular expressions
“Regular expressions” are significantly different in OOo from MSO’s “Use wildcards”. See 
Help > OpenOffice.org help > Index tab > and type in “regular expressions” then move to 
“Searching” and press Display. Some common examples are in Table 1. To use regular 
expressions, click the More Options button of the Find & Replace dialog and make sure the 
Regular expressions checkbox is checked. On reopening the Find & Replace dialog, the 
Regular Expressions checkbox is always unchecked.

Table 1. Sample regular expressions

Problem Search Replace
Replace multiple tabs with just one tab \t* \t
Replace multiple spaces with just one space. “[:space:]” 
finds both non-breaking spaces and normal spaces but not 
tabs. Type a normal space in the Replace field.

[:space:]*  

Remove leading white space (space or tabs in any 
combination) at the start of a paragraph.

^([:space:]|
\t)*

Remove trailing white space (space or tabs in any 
combination at end of paragraph).

([:space:]|
\t)*$

Find paragraphs beginning with the character “a” (the rest 
of the paragraph can vary) and replace the whole paragraph 
with a blank line.

^a.*

Remove a paragraph mark from the end of lines. for 
example, when having pasted text from an e-mail message. $

Replace paragraph marks with a comma so that there is one 
long line rather than many lines. $ ,

Replace commas with a paragraph mark. , \n
Replace line breaks (Shift+Enter) with paragraph markers. 
(Note that \n is used for both the Search and Replace 
fields. In search it is interpreted as a newline and in replace 
as a paragraph mark. There is no ability to have a line 
break in the replace field.)

\n \n

Find the word “the” only (do not find “then” or “bathe”). \<the\>
Find “ing” at the end of a word, for example reading or 
writing but not singer. ing\>

Find whole words that end with “ing”. Note that there is a 
space between the caret and the close-square-bracket 
character.

[^ ]*ing\>

Select all numbers at the start of a line where the numbers 
could include a period, for example 1.1., 1.13.2 and 
4.1.15.9. 

^[0-9.]* 

General Differences in Use between OpenOffice.org and Microsoft Office 16



Find and Replace

Note The asterisk “*” means any number of the preceding character. Where in MSO you 
might have just “*” the equivalent in OOo is “.*” because “.” stands for any single 
character (like MSO’s “?”).

A macro that makes it easier to use regular expressions in Writer, and allows searching for 
“page breaks” and for things such as multiple blank paragraphs, is available in a document 
called IannzFindReplace.sxw available from http://homepages.paradise.net.nz/hillview/OOo/.

Similarity search
The Similarity search option broadens the search so that what is found does not have to be 
exactly the same as what was specified in the Search for field. To specify how different it can 
be, select the Similarity search checkbox in the Find & Replace dialog.

Search for styles
Writer and Calc have an option in the Find & Replace dialog: Search for Styles (which 
changes to Within Styles if Format or Attribute search is used). Check this first if you are 
searching for a particular style. The Search for Styles field changes to a listing of the 
paragraph styles in use.

Grammar checking

There is no grammar checking function in OOo. There are, however, a number of grammar 
checkers under development:

Language Tool is a Python-based grammar checker originally written for German. Rules 
sets for Hungarian and English are also available. More information is available from 
http://tkltrans.sourceforge.net/ and from http://www.danielnaber.de/.

An Gramadóir is a Perl-based grammar checker originally written for Irish. More 
information is available from http://borel.slu.edu/gramadoir/index.html. [This one is 
probably the best suited for languages that use noun classes, or an evidential grammar.]

CoGrOO is a grammar checker for Portuguese that is still in the alpha stage. More 
information is available from http://www.pcs.usp.br/cgi-
bin/jkinoshi/cogroo/experimente.cgi

Cymraeg is a grammar checker for Welsh. This is a commercial product. A 
demonstration copy of it can be obtained from 
http://www.bangor.ac.uk/ar/cb/cymraeg/demo_meddalwedd.php.
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