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File formats

File formats

This section gives a simplified overview of OpenOffice.org’s file format. 

OpenOffice.org stores its files in a compressed (zipped) XML format. This format is humanly 
readable when unzipped. It is openly documented and is publicly available under the GNU 
License (http://www.gnu.org). 

For details about XML formats, see http://books.evc-cit.info/book.php.

Note Some compression utilities only check the file extension and may not recognize the 
file as being compressed. To open an OpenOffice.org file with such a compression 
utility, you can rename the file to have the extension .zip.

By contrast, Microsoft Office files are stored in a proprietary format which is not human 
readable and not publicly documented. This causes problems for software developers writing 
filters for importing and exporting in Microsoft Office formats.

In OpenOffice.org 2.0 there has been a small change in file format and extension from that 
used in OpenOffice.org1.1.x. The change is due to decisions by the open standards committee 
OASIS. Other applications, for example KOffice, are also using the same format.

Table 1. File extensions for OpenOffice.org 2.0. (OOo 1.1.x extensions are shown in brackets).

Document type Application Extension MS Office equiv

Text Writer odt (sxw) doc
Text Template Writer ott (stw) dot
Master Document Writer odm (sxg) doc
HTML document Writer html html
Spreadsheet Calc ods (sxc) xsl
Spreadsheet Template Calc ots (stc) xst
Drawing Draw odg (sxd) N/A
Drawing Template Draw otg (std) N/A
Presentation Impress odp (sxi) ppt
Presentation Template Impress otp (sti) pot
Formula Math odf (sxm) N/A
Chart Chart odc N/A
Database Base odb mdb
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File formats

Note OpenOffice.org can open Microsoft Office files. The reverse is not true: at this time, 
Microsoft Office can not open OpenOffice.org formats.
If you need to send files to someone using Microsoft Office, save your file first in 
the native OpenOffice.org format, then save it to one of the many supported 
Microsoft Office formats. By doing this, you ensure that even if the filter can not 
translate perfectly, you have your original in its native format.
OpenOffice.org can not open or convert Microsoft Access files (.mdb) files directly, 
however it can access the data in the tables using DAO and ODBC. See the 
Database Guide for more information.

Bulk conversion

To use OpenOffice.org to convert a lot of files, click File > Wizards > Document 
Converter.

Before doing a bulk conversion of files, think about whether it is really necessary. Read this 
document right through to get an appreciation of the limitations of the conversion process.

Note Converting a lot of files can take a long time. I recommend you check for sufficient 
disk space first, and start converting when the computer is not going to be used for a 
while. In general, OOo files take up less space than Microsoft Office files, but to be 
safe you might allow for the same amount of space for the converted files.

Opening files

Opening text documents
In addition to the native OpenDocument formats (.odt and .ott), OpenOffice.org Writer 2.0 
can import the following text document formats:

Microsoft Word 6.0/95/97/2000/XP) (.doc, .dot) WordPerfect Document (.wpd)
Microsoft Word 2003 XML (.xml) WPS 2000/Office 1.0 (.wps)
Microsoft Winword 5 (.doc) DocBook (.xml)
StarWriter formats (.sdw, .sgl, .vor) Ichitaro 8/9/10/11 (.jtd, .jtt)
AportisDoc (Palm) (.pdb) Hangul WP 97 (.hwp)
Pocket Word (.psw) .rtf, .txt, .csv

When opening .HTM or .HTML files, OpenOffice.org customizes Writer for working with 
these files.

Sharing Files with Microsoft Office Users 2



Opening files

Opening spreadsheets
In addition to the native OpenDocument formats (.ods and .ots), OpenOffice.org Calc 2.0 can 
open the following spreadsheet formats:

Microsoft Excel 97/2000/XP (.xls, .xlw, .xlt) Rich Text Format (.rtf)
Microsoft Excel 4.x–5/95 (.xls and .xlw, .xlt) Text CSV (.csv and .txt)
Microsoft Excel 2003 XML (.xml) Lotus 1-2-3 (.wk1 and .wk1)
Data Interchange Format (.dif) StarCalc formats (.sdc, .vor)
dBase (.dbf) SYLK (.slk)
.htm and .html files including Web page queries Pocket Excel (pxl)
Quattro Pro 6.0 (.wb2)

Opening presentations
In addition to the native OpenDocument formats (.odp and .otp), OpenOffice.org Impress 2.0 
can open the following presentation formats:

Microsoft PowerPoint 97/2000/XP (.ppt, .pps) Computer Graphics Metafile (.cgm)
Microsoft PowerPoint 97/2000/XP Template 
(.pot)

StarDraw, StarImpress (.sda, .sdd, .sdp, 
.vor)

Opening graphics files
In addition to the native OpenDocument formats (.odg, and .otg), OpenOffice.org Draw 2.0 
can open the following graphic formats:

BMP JPEG, JPG PCX PSD SGV WMF
DXF MET PGM RAS SVM XBM
EMF PBM PLT SDA TGA XPM
EPS PCD PNG SDD TIF, TIFF
GIF PCT PPM SGF VOR

Opening formula files
In addition to OpenDocument Formula files, OpenOffice.org Math 2.0 can open the StarMath 
(.smf) and MathML (.mml) files.

When opening a Word document that contains an embedded equation editor object, select the 
[L] checkbox for MathType to OpenOffice.org Math/OpenOffice.org Math to MathType in 
Tools > Options > Load/Save > Microsoft Office and the object will be automatically 
converted to an OpenOffice.org Math object.
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Saving files

Saving files

Default file format
OpenOffice.org saves files in the OpenDocument format by default unless told otherwise. 
This default can be changed, for example if you always want to save as Microsoft Office 
files. To change the default file formats:

1) Go to Tools > Options > Load/Save > General. (See Figure 4.)

Figure 1. Choosing default formats for saving files

2) In the Standard File Format section of this page, choose a document type (for example, 
“Text document”) and a file format from the Always save as list.

3) Repeat for each document type as necessary.

4) Click OK to save your changes.

Notes If the option “Warn when not saving in OpenDocument or default format” is checked 
on the Options – Load/Save – General dialog (Figure 4), a warning dialog about 
potential loss of formatting may be displayed. In most cases, no loss of formatting 
will occur, so you may find this warning annoying and choose to disable it.
The Java Runtime Environment is required to use the mobile device filters for 
AportisDoc (Palm), Pocket Word and Pocket Excel.
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Saving files

Export to PDF and XHTML
Each application has the ability to directly export to PDF (Portable Document Format). This 
industry-standard format for universal file compression and viewing is ideal for sending the 
file to anyone else to view using Acrobat Reader or any other PDF display program on any 
operating system.

You can export directly to PDF using the button on the toolbar next to the Printer icon, or by 
choosing File > Export as PDF, which allows you to select some detailed options.

To export as XHTML, use File > Export and for File format choose XHTML In the 
dropdown box. 

Saving files in other formats
To save files in different formats, use File > Save As and select a format from the File Type 
dropdown box (Figure 2). 

Figure 2. The OpenOffice.org Save As dialog, showing some of the Save formats
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Saving files

Writer can save to these file formats
In addition to its native formats, Writer can save in these formats:

OpenOffice.org Writer 1.x (.sxw, .stw)
Microsoft Word 97/2000/XP (.doc)
Microsoft Word 95 (.doc)
Microsoft Word 6.0 (.doc)
Microsoft Word 2003 XML (.xml)
Microsoft Pocket Word (.psw)
DocBook (.xml)
Aportis Doc (Palm) (.pdb)
Rich Text Format (.rtf)

StarWriter 5.0 (.sdw)
StarWriter Template (.vor)
StarWriter 4.0 (.sdw)
StarWriter 4.0 Template (.vor)
StarWriter 3.0 (.sdw)
StarWriter Template 3.0 (.vor)
Text (.txt)
Text Encoded (.txt)
HTML (.html; .htm)

Note The .rtf format is commonly used for transferring text files between applications, 
but you are likely to experience loss of formatting and images when the file is 
opened by Microsoft Office. The best way to pass a file in Writer to a Microsoft 
Word user is to save it as Microsoft Word 97/2000/XP (.doc).

Calc can save to these file formats
In addition to its native formats, Calc can save in these formats:

OpenOffice.org Calc 1.x (.sxc, .stc)
Microsoft Excel 97/2000/XP (.xls; .xlw)
Microsoft Excel 97/2000/XP Template (.xlt)
Microsoft Excel 95 (.xls; .xlw)
Microsoft Pocket Excel (.pxl)
Microsoft Excel 2003 XML (.xml)

Data Interchange Format (.dif)
dBase (.dbf)
SYLK (.slk)
Text CSV (.csv; .txt)
StarCalc formats (.sdc, .vor)
HTM and HTML files 

Impress can save to these file formats
In addition to its native formats, Impress can save in these formats:
Microsoft PowerPoint 97/2000/XP (.ppt; .pps)
Microsoft PowerPoint 97/2000/XP Template (.pot)
StarDraw, StarImpress (.sda, .sdd, .vor)

Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats as listed 
below for Draw.
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Saving files

Draw can save to these file formats
Draw can only save in its native and StarDraw formats, but it can export to:

BMP
EMF
EPS
GIF
JPEG

MET
PBM
PCT
PGM
PNG

PPM
RAS
SVG
SVM
TIFF

WMF
XPM

The HTML writer can save in these formats
HTML Document (.html; .htm)
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.0 HTML Template (.oth)
StarWriter/Web 5.0 and 4.0 (.vor)
Text (OpenOffice.org Writer/Web) (.txt)
Text Encoded (OpenOffice.org Writer/Web) (.txt)

Object Linking and Embedding (OLE)

To change the settings for Microsoft Office OLE objects, use Tools > Options > Load/Save 
> Microsoft Office (Figure 3).

Having all of these options checked allows embedded objects to be converted and thus be 
editable in both office suites.

For other OLE objects, it will depend on the machine where the file is being edited just as it 
does with Microsoft Office alone. Thus Windows application based OLE objects will not be 
editable in OpenOffice.org on a Linux machine, although the object will still be displayed 
correctly and can be resized.
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Object Linking and Embedding (OLE)

Figure 3. Choosing Load/Save VBA Properties

Linked files

Cells copied from Excel and pasted special, linked and with RTF format, into Word are 
imported into Writer as a normal table. This means that when the document is imported, the 
link to the Excel file is lost.

Similarly when a chart is copied from Excel and pasted special, linked into Word, and then 
the file imported into Writer, the chart is imported as an embedded OLE object but is not 
converted into a Calc chart. On saving the file in Word format and then opening the file in 
Word and trying to edit the chart by double-clicking, it displays an error message.

Caution Links in Microsoft Office files between Word and Excel are lost when the 
Microsoft office files have been edited by OpenOffice.org.

WordArt and Fontwork

The equivalent to Microsoft Office’s WordArt in OpenOffice.org is Fontwork. WordArt 
objects are imported as Fontwork objects; they may look slightly different on import. 
Fontwork objects are automatically exported to WordArt objects when the document is saved 
in a Microsoft Office format.
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Vector graphics

Vector graphics

The basic shapes (lines, arrows, rectangles, ovals) all import and export without any problem. 
OpenOffice.org provides a greater degree of control over some properties than Microsoft 
Office does, so sometimes there will be changes when going from OpenOffice.org to 
Microsoft Office. Examples include the size of arrow heads, and line styles.

The Microsoft Office autoshapes, such as the smiley face, keep their special characteristics, 
for instance the ability to adjust the degree of the smile or frown on the smiley face.

Microsoft Office provides more shadow options than OpenOffice.org, so sometimes there 
will be a change in shadow appearance. Microsoft Office shadow styles 1, 2, 4, 6, 14, 17 and 
18 are supported in OpenOffice.org. Horizontal and tapered shadows do not get imported and 
any 3D effect on the bottom left is ignored.

Frames and text boxes

When frames or text boxes from Microsoft Office are imported into OpenOffice.org with 
linked text, the links are lost.

Active content controls

These are the controls in Microsoft Office available on the Controls toolbar; they all import 
without a problem. However, as these controls typically require macros to be of use, they will 
be functionally useless in the absence of macros custom built for use in OpenOffice.org.

Macros

OpenOffice.org cannot run Microsoft Office macros. Although the macro language is very 
similar, the underlying objects are quite different. To set whether OpenOffice.org keeps 
attached macros (so that they are still available for use in Microsoft Office) for Word, Excel 
and PowerPoint files, use Tools > Options > Load/Save > VBA Properties.

Note Opening a Microsoft Office file infected with a macro virus is quite safe in 
OpenOffice.org.

OpenOffice.org has the ability to record macros. It is better practice to use the application 
program interface (API).
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Import, export and sharing issues in text documents

Import, export and sharing issues in text 
documents

Good practice in text documents
Some issues can be avoided simply by using good word-processing practice:

• Use character and paragraph styles rather than direct formatting.

• Use paragraph formatting for space before and after rather than hard returns, 
particularly in numbered or bulleted lists.

• Use paragraph text flow properties (for example, keep with next) rather than using 
manual page breaks.

• Do not use multiple tabs or spaces to align text – either set specific tab stops or better 
yet use a table.

• Use only commonly available fonts.

Compatibility settings in OpenOffice.org for the 
current document
The following settings change the way OpenOffice.org works with the current document so 
that it works more like Microsoft Office.

Use Tools > Options > OpenOffice.org Writer > Compatibility (Figure 4).

Figure 4. Choosing compatibility options
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Import, export and sharing issues in text documents

Add paragraph and table spacing at tops of pages (in current 
document)

In Writer, with this setting unchecked, if a paragraph at the top of the page (or column) is 
formatted with space above then that space is ignored; whereas in Word the space above is 
included. Checking this option causes Writer to behave in the same way as Word.

Use OpenOffice.org 1.1 tabstop formatting

This setting specifies whether centered and right-aligned paragraphs containing tabs are 
formatted as a whole in the center or aligned to the right. If this checkbox is checked, only the 
text to the right of the last tab is aligned to the right, while the text to the left remains as is.

Use OpenOffice.org 1.1 line spacing

Writer uses the greater of the two spacings for above and below paragraphs; Word sums the 
two together. Uncheck this box to have Writer behave in the same way as Word.

Font and font spacing
Text effect animations are imported by Writer with the character attribute of blinking from 
Word files. For example “Marching red ants” simply becomes “blinking”.

Typically Word’s character spacing is tighter than Writer’s, so often Word will fit more 
characters to a line. It is also possible that the spacing between lines could be slightly 
different. The end result is that the page breaks may be in different places.

Tables
The author could find no issues with tables.

Mail merge documents
As OpenOffice.org has a different approach to data sources. On importing a Word document 
that is the main document for a mail merge, there is no connection with the data source. It is 
not just a matter of making that connection; each field needs to be reinserted. See the Mail 
Merge section in the chapter titled “Differences in use between Writer and Word”.

Also in Word you can have another Word document as a data source for a mail merge. There 
is no way of specifying a Word (or Writer) document as a data source in OpenOffice.org.

Writer does not have the option of suppressing blank lines when data fields are empty, so you 
need to use conditional fields. 

Writer merge fields export as text with the name of the field between angle brackets, for 
example <Name>.

Summary: To work in a shared environment would require a separate file for each “main 
document”: one in Word format, the other in OpenOffice.org format.  If you have a master 
mail merge document in Word format, it is probably easiest to paste the text into Writer and 
use the Writer mail merge wizard to recreate the mail merge from scratch.
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Import, export and sharing issues in text documents

Forms

Issues with forms created in Microsoft Office

A locked file in Microsoft Office imports unlocked into OpenOffice.org; that is, in design 
mode.

Text form fields import into OpenOffice.org as Input fields and so lose their type. For 
example, a text form field of type “number” or “date” will accept any text for input. In use a 
text form field in OpenOffice.org displays a dialog for entering the text. Exporting back to 
Microsoft Office, text form fields are changed into “Fillin” fields. The current date and time 
and calculation fields import as simple text.

Checkboxes import and export correctly.

Drop-down form fields import as Input List fields. Like text form fields in operation these 
display a dialog from which the user can select an option. On export back to Microsoft Office 
they return to drop-down form fields again.

Issues with forms created in OpenOffice.org

The controls are exported as active controls when there is a Microsoft Office equivalent. As 
Word does not have the same database functionality of OpenOffice.org and as the macros are 
not compatible, it would be very difficult to have one form that works in both environments 
using standard form controls.

Summary: To work in a shared environment with forms is not easy, but one workaround 
would be to use other fields like Input field and Input List. To insert these fields, use Insert > 
Fields > Other > Functions.

Footnotes, endnotes, tables of contents and indexes
Footnotes, endnotes and indexes all import / export correctly. Some issues have been found:

• The location of the endnotes may change (in Word the endnotes are placed before the 
index. In Writer they are always at the end of the document).

• Writer bibliographic entries become text in Word.

• A three-column index exported from Writer to Word as three columns but on re-import 
it was one column.

• On importing a Word file containing index entry fields, the index entry fields are 
imported but as fields to the left of the text rather than the field containing the text.

Summary: Working in a shared environment is possible with some minor issues.
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Import, export and sharing issues in text documents

Numbered paragraphs, outline numbering, cross-
references
Numbered paragraphs, outline numbering, and cross-references import / export without a 
problem, except for references to numbered paragraphs:

• Cross-references to the numbers of numbered paragraphs that are not numbered using 
outline numbering do not work as Writer does not have this ability.

• Writer also does not have the ability to use relative numbering in its cross-references 
to numbers.

• Cross-references to chapter numbers do not have the same format as that displayed.

Page numbering
A quick and dirty approach in Word for having a different first page (like a cover page) and 
then to have the numbering start on the second page but numbered as page 1 is to have a 
layout of different first page and setting the starting page to be zero. Unfortunately, on 
importing such a file into OpenOffice.org the page number on the second page is 2 instead of 
1. To fix this problem in Writer:

1) Create a page style for how the pages after the first page should look. Name it (for 
example) Convert1.

2) Have the cursor in the first paragraph of the second page.

3) Format > Paragraph > Text Flow.

4) In the Breaks portion of the dialog, select the checkbox Insert.

5) Check With Page Style.

6) Choose the page style created in step 1.

7) Leave the position as Before and set the page number to 1.

On exporting this document back to Word it will work, the only difference being that the 
document will have a section break at the end of the first page. Documents created with 
section breaks like this in Word will work fine importing and exporting with Writer. There is 
one difference with Word: now there will be a blank page between the cover page and the 
next page when printed (or print previewed).

In the author’s testing a document with different formats for odd and even page numbering, 
the odd page numbers were imported as the text of the first odd page rather than as a field.

Summary: For some documents a little work maybe required to fix up the page numbering on 
importing to Writer. Once “fixed” the page numbering of the documents will import / export 
without a problem.
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Import, export and sharing issues in text documents

Date and time fields
Word’s CreateDate and SaveDate fields do not get imported with the same formats. For 
example, if the fields in the Word document have a format that includes time, then this 
information is not displayed by default. To include time in the format:

Right-click on the field > Fields > scroll to the bottom of the Formats listbox > Additional 
formats > in format code add HH:MM:SS

On export the SaveDate / DocInformation:Modified is exported as text.

Writer’s Time Fixed and Date Fixed fields get exported as text.

Importing Word fields
Table 2. Imported Word fields conversion

Word field: Writer converts to:
ASK Input field
AUTHOR DocInformation:Created
AUTONUM Number Range AutoNr
AUTONUMLGL Number range AutoNr
AUTONUMOUT Number range AutoNr
COMMENTS DocInfomation:Comments
CREATEDATE DocInformation:Created
DATE Date
EDITTIME DocInformation:Modified
FILENAME File name
FILLIN Input field
HYPERLINK (as a hyperlink)
INFO xxx DocInformation:xxx
KEYWORDS DocInformation:Keywords
LASTSAVEDBY DocInformation:Modified
MACROBUTTON (the name of the macro?)
MERGEFIELD Mail merge fields (displayed as the name of the 

field)
MERGEREC Record number
NEXT Next record
NOTEREF Show variable
NUMCHARS Statistics (with select = Characters)
NUMPAGES Statistics (with select = Pages)
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Import, export and sharing issues in text documents

Word field: Writer converts to:
PAGE Page numbers
PAGEREF Bookmarks (displayed as name of bookmark)
REVNUM DocInformation:Document number
SAVEDATE DocInformation:Modified
SEQ Number range
SET Set variable
SUBJECT DocInformation:Subject
TEMPLATE Templates
TIME Date
TITLE DocInformation:Title
TOC (Displays the table of contents)

The following fields are not imported into OpenOffice.org (only the text that they displayed 
when last saved):  =, IF, DOCPROPERTY, FILESIZE, LINK, LISTNUM, QUOTE, 
SECTION, SECTIONPAGES, STYLEREF, TOA, USERADDRESS, USERINITIALS, 
USERNAME.

The following fields are ignored on import: AUTOTEXT, AUTOTEXTLIST, BARCODE, 
BIDIOUTLINE, DOCVARIABLE, EQ, GOTOBUTTON, INCLUDETEXT, LISTNUM, 
MERGESEQ, PRINT, RD, SKIPIF, SYMBOL, TA, TC.

The Word field EDITTIME is mapped to Writer field DocInformation:Modified on import 
but the meaning has changed to the date and time last saved rather than how long the file has 
been open for editing.

Import, export and sharing issues in 
spreadsheets

Form fields
Combo boxes, list boxes and checkboxes with links to spreadsheet cells all import and export 
properly, although due to font handling the number of rows displayed in list boxes may be 
slightly different. List boxes in Calc can either have multi-selection or not, whereas Excel has 
two multi-selection modes: multi and extend. In Excel a link from a multi-selection listbox to 
a cell is ignored (at least in Excel 2000; the author has not checked Excel XP). In Calc the 
link works, but if more than one item is selected, the cell’s value is set to #N/A.
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Import, export and sharing issues in spreadsheets

Option buttons import into Calc, but the link with cells works differently. In Calc each option 
button has its own link to a cell, setting its value to true or false depending on whether the 
option is selected. In Excel the cell link returns the number of the selected option button. On 
exporting option buttons to Excel, the option buttons lose their radio operation; in other 
words, they are not grouped so that selecting one “unselects” the others.

Scroll bars and spinners are now implemented in Calc, but are not imported yet.

Array constants
Array constants are not available in OpenOffice.org. The workaround is to have the constant 
values in cells on a sheet and refer to them. Array constants used as parameters to a function 
in Excel are omitted when imported into Calc.

Optional parameters in formulas
Some formulas have more than one optional parameter at the end of the parameter list. In 
Excel it is possible to leave an optional parameter blank and specify a later parameter, but 
this is not possible in Calc. Formulas with optional parameters are not correctly imported into 
Calc.

Functions

Statistical, engineering and financial functions

In Excel some of the financial functions accept string parameters for dates; in OpenOffice.org 
they require a serial number, and thus they are not correctly imported into Calc.

Analysis ToolPak Functions

The function EFFECT provided by the Analysis ToolPak for Excel is converted to 
EFFECT_ADD in Calc and returns the same results.

Other functions not implemented / imported

Only three other functions are not imported: INFO, GETPIVOTDATA, and HYPERLINK. 
Hyperlinks are supported but not as a function; use the Hyperlink button on the Function bar.

DataPilot—Pivot Table
DataPilots are Calc’s equivalent to Excel’s Pivot Tables. However there are a number of 
limitations. Pivot tables import from Excel into Calc (although the cells do not have the 
PivotTable shading) but as soon as they are worked on these limitations become apparent. 
The limitations are:

• There is no PivotChart facility, but a DataPilot can be used as the data source for a 
chart.
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Import, export and sharing issues in spreadsheets

• The user interface allows a maximum of 8 fields in the data, row or column areas. (An 
alternative interface which allows more is available from: 
http://homepages.paradise.net.nz/hillview/OOo/ in a document called 
MyDataPilot.sxc.

• There is some ability to group data (for example, a date field grouping by week or 
quarter but not by month). The workaround is to create a new column with a formula 
for calculating the grouping, e.g. =Month().

• You can not define different formats for different fields.

• Calc can have formulas based on things like “Difference From” or “% of”, but can not 
have own custom fields (work around create new columns to calculate the desired 
values).

• The Application Program Interface specification is incomplete for writing macros that 
work with DataPilots—for example, the ability to control through another program, 
such as OpenOffice.org’s own macro language, BASIC, whether the tables have grand 
totals, or having access to DataPilots created from external data.

AutoFilter
AutoFilter imports and exports correctly with the required rows being hidden. However, there 
are a number of differences between Excel and Calc:

• There is only one AutoFilter active for a spreadsheet document at a time. The rows 
remain hidden but the drop-downs in the first row disappear on applying AutoFilter 
elsewhere.

• The remaining visible row numbers do not change color to warn that there is a filter in 
place.

• Error values do not show as an option in the drop down lists when cells in the column 
have errors.

• In the drop down lists, the equivalent to Excel’s “Custom” is called “Standard”.

Charts
Chart types that Excel provides but Calc does not:

• Bar of pie converts to a 2D – columns – normal.

• Pie of pie converts to a 2D – columns – normal.

• Radar filled converts to 3D – columns deep.

• Radar with markers – converts to 2D – net – normal but counterclockwise rather than 
Excel’s clockwise.
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Other charting issues include:

• There are fewer axis options, such as no option for having an inverted y axis (negative 
at top towards positive at bottom).

• The data must be contiguous, with the labels in the first row or column.

Number formats
There is no “accounting” format (with the currency symbol at the left edge of the cell). A 
workaround would be to have another column to the left that contains the currency symbol.

There is no predefined option for bracketing negative numbers. Use a custom format such as 
“$#,##0.00_);[RED]($#,##0.00)”.

Grid lines
In Excel grid lines are a property of a worksheet; in Calc it is an application-wide option:

Tools > Options > OpenOffice.org Calc > View

Import, export and sharing issues in 
presentations

Color gradients and borders
The author had not noticed the following changes, so this is a direct quote from StarOffice 7 
Migration Guide by Sun.

Unlike Microsoft PowerPoint, StarOffice Impress does not support three-color gradients, 
double and triple borders, or round-dotted borders. To improve the results of the import, you 
have to make the necessary adjusts before import. Change three-color presets to similar two-
color gradient fills and change double and triple border lines to a single border line with 
appropriate width. Round-dotted border lines that are mapped to rectangle-border closely 
resemble the original line style in PowerPoint, so manual editing should not be necessary.

Multimedia
Voice-over narration is not supported by Impress.

There appear to be no settings for multimedia custom animations, such as the ability to play a 
sound for the next slides.
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Chart animations
There is no facility in Impress for “chart effects” as there is in PowerPoint, such as presenting 
a series or category at a time. On import the charts simply appear. A workaround is to have 
multiple copies of the chart with each one set up to display as desired.

Pack and Go
The Pack and Go feature in PowerPoint allowed a PowerPoint file to be split over several 
floppy disks and assured that all related files were included. This facility is not included in 
Impress, nor can Impress open such files.

Fields
Date fields are exported as text, so they do not automatically update.

Action settings and interaction
PowerPoint provides action settings for mouseover, but Impress does not have this option, 
only on mouse click, so mouseovers get mapped to mouse clicks. PowerPoint has an option 
for highlighting the object on mouse click or mouse over; Impress does not have this, so it 
gets ignored on import.

PowerPoint custom animations and Impress object 
effects
Table 3 shows how the custom animations and object effects are imported into Impress and 
exported to PowerPoint.
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Table 3. Importing / exporting custom animations between PowerPoint and Impress

PowerPoint Impress
Appear Appear
Blinds Fade Horizontally
Box Fade To Center
Checkerboard Checkerboard
Diamond Appear
Crawl Fly In From bottom
Dissolve Dissolve
Flash once Appear
Peek Short Fly In from Bottom
Random Bars Horizontal lines
Spiral Spiral Outward Clockwise
Split Close Vertical
Stretch Stretch Vertical
Strips Fade From Top Right
Swivel Rotate Horizontally
Wipe Cross-Fade From Top
Zoom Fade From Center
Random effects Vertical Lines

PowerPoint—Impress slide transitions
Table 4 shows how slide transitions are imported into Impress and exported to PowerPoint.

Table 4. Importing / exporting slide transitions between PowerPoint and Impress

PowerPoint Impress
Blinds Horizontal Venitian Blinds Horizontal
Blinds Vertical Venitian Blinds Vertical
Box In Box In
Box Out Box Out
Checkerboard Across Checkerboard Across
Checkerboard Down Checkerboard Down
Cover Down Cover Down
Cover Left Cover Left
Cover Right Cover Right
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PowerPoint Impress
Cover Up Cover Up
Cover Left Down Cover Left-Down
Cover Right Down Cover Right-Down
Cover Left Up Cover Left-Up
Cover Right Up Cover Right-Up
Cut No effect
Cut Through Black No effect
Dissolve Dissolve
Fade Through Black Fade Through Black
Random Bars Horizontally Random Bars Horizontal
Random Bars Vertically Random Bars Vertical
Horizontal In Split Horizontal In
Horizontal Out Split Horizontal Out
Split Vertical In Split Vertical In
Split Vertical Out Split Vertical Out
Strips Left Down Fade From Top Right
Strips Left Up Fade From Bottom Right
Strips Right Down Fade From Top Left
Strips Right Up Fade From Bottom Left
Uncover Down Uncover Down
Uncover Left Uncover Left
Uncover Right Uncover Right
Uncover Up Uncover Up
Uncover Left Down Uncover Left-Down
Uncover Left Up Uncover Left-Up
Uncover Right Down Uncover Right-Down
Uncover Right Up Uncover Right-Up
Wipe Down Wipe Down
Wipe Left Wipe Left
Wipe Right Wipe Right
Wipe Up Wipe Up
Random Transition Random Transition
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