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Managing 3D Objects

Managing 3D Objects

Even though OpenOffice.org does not claim to rival leading 3D image software packages, it
contains a number of tools that let you create powerful 3D drawings.

Rotating 3D objects

The rotation function also works with 3D objects, but differently from flat objects. Rotation
acts in a three-dimensional space as shown in Figure 1.

X-Axis -

Figure 1: Rotation of a 3D object

For 3D objects, the axis of rotation is indicated by the symbol <.

To do this Do this
Rotate the object about the x-axis. Move the left and right (edge) handles.
Rotate the object about the y-axis. Move the top and bottom (edge) handles.
Rotate the object about the z-axis (the axis Move the corner handles.
coming out of the page).
Re-locate the axis of rotation. Move the ¢ symbol.
3D effects

3D objects have their own configuration dialog, called the 3D Effects dialog. The dialog
contains several pages that can be selected through the buttons at the top. This chapter

discusses each of these pages in turn.
To display the 3D Effects dialog, right-click on the object and select 3D Effects.

You can use the Material page of the 3D Effect dialog to apply 3D attributes to any 3D
object (Figure 2).
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3D Effects ]
EIEIFAEE
Material
Fawvarites
Obiect color IUser-defined
Metal
Ilumination color Gold
Chrome
Sip=adles Plastic
Color Wiood
Inkensity 15 . -

Figure 2: The 3D Effects dialog

To apply a 3D attribute to a selected object, choose one of the attributes from the Favorites
zone and click the Assign icon vl

Note Only the attributes are applied; no objects are transformed. For example, a circle
will not turn into a torus if you click on the first defined effect in the Favorites drop-
down menu.

If the selected object is not a 3D object, it will be converted into one. The operation that
converts a 2D object into a 3D object is called an extrusion. This mechanism lets you create a
variety of objects.

To apply a 3D attribute to a 2D object:
1) Choose one of the attributes from the Favorites zone and click on the Assign icon vl

2) If you do not have the 3D Effects dialog open, right-click on your 2D object, and
choose Convert > To 3D, or go to Modify > Convert > To 3D.

An example is shown on the right.
1) Draw a circle.

2) Go to Modify > Convert > To 3D to change the circle to 3D.

|
L

A 4
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Managing 3D Objects

Geometry Management page

Use the Geometry page (Figure 3) to define the geometric settings that are linked to a 3D
object. To access this page, right-click on the object, and select 3D Effects. The 3D Effects
dialog opens, then click on the Geometry icon (e

3D Effects X

(B9 ]=]=]

Geamekry

Rounded edges | 10 %

2l

Scaled depth | 100 % ¥ |
|

|

Depth 0.44" -

Segments

e

Horizontal o Yertical 24 =

Mormals

Figure 3: The Geometry Page

The Rounded edges parameter applies when you turn a 2D shape into a 3D shape. It defines
the degree of rounding of edges during conversion, as shown in Figure 4.

(@) (b)

Figure 4: Rounded edges with (a) 0% rounding and (b) 30% rounding

This parameter is particularly useful for texts that have been extruded into 3D shapes.
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Managing 3D Objects

The Scaled depth parameter defines the dimension ratio between the front face and the back
face of the object. By default, the scale is set to 100%, which means that both faces will have
the same dimensions. If you set the scaled depth to 50%, for example, with the cube above,
you get the object shown in Figure 5.

Figure 5: Scaled depth of 50%

Here you can see that the front face has a length and breadth that is 50% smaller than the
back face. It is even possible to set the scaled depth to more than 100% and thus have a front
face that is larger than the back face.

The Rotation angle parameter is useful for some shapes that are made by revolving a profile
about an axis. Use this parameter to decide whether or not the rotation will be complete
(360°). Figure 6 shows what you can obtain with a half-sphere and a value of 270°.

-

Figure 6: Rotation angle of 270°

Use the Depth parameter to define the depth of a 2D object that has been transformed into a
3D object. This value can be changed at any time. The parameter does not apply to 3D
primitives.

Use the Horizontal and Vertical Segments parameters to define the number of segments for
the rounded shapes. The higher the number is, the smoother the surface of the shape will be,
but the longer it will take to display. In Figure 7 the left-hand sphere is made up of 10
horizontal and vertical segments, whereas the right-hand sphere is made up of 25 segments.

Figure 7: 10 line segments (left)
and 25 line segments (right).

The icons in the Normals zone let you modify the normals of 3D objects. A normal is a
straight line that is directed perpendicularly across the surface of an object.

Managing 3D Objects and Bitmaps 4
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Figure 8 shows a few normals drawn on a sphere with 10 segments.

Figure 8: Object Normals

Normals let you define the exterior aspect of an object and its interactions with textures and
lighting. When you change the normal mode (also known as the projection mode), you act on
the geometry of an object. Here is a description of the functions that act on normals.

Object-Specific: Lets you choose the object-specific rendering that is best suited to
the object.

Flat: Lets you create smooth surfaces. Where a sphere is concerned, we obtain a
perfect sphere:

Sphere with smooth faces

Here in the drawing above the normals have been kept drawn on the shape so that
you will remember that the faces are still present even if they cannot be seen.

13 Invert Normals: Lets you invert the normals.
Y Spherical: Corresponds to the projection mode illustrated above, wherein each of the

faces is visible.
Double-Sided Illumination: Lets you light an object from the inside and outside.

(-9 Double-Sided: Lets you create double or single-sided 3D objects. When the
extrusion function is used, the resulting objects are closed (for example, a square
will give a cube). If you use this function, Draw will produce open objects.

Managing 3D Objects and Bitmaps 5
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Managing 3D Objects

The Shading page (Figure 9) covers the parameters linked to the shading of objects (such as

shading type and shadow).

3D Effects 3]

EXETES B E=)

shading
Mode
Shadow

=

amera
Distance

Eocal length

| ak

Surface angle |IZI degree(s) S |

102"

LIRS

3.94"

Figure 9: The Shading Page

The Shading mode refers to the method that Draw uses to render objects and their
interaction with light. Draw offers three choices: Flat, Phong and Gouraud.

Flat is the quickest technique, but it also gives the worst results (all of the faces are

visible).

Phong is an intermediate technique.

Gouraud renders objects with the highest quality.

In the above drawing, flat shading (left) is clearly less attractive, whereas it is more difficult
to distinguish between Phong (middle) and Gouraud shading (right). One might simply note
that the shading appears to be more realistic with Gouraud shading than with Phong shading.

Managing 3D Objects and Bitmaps
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The Shadow area of the dialog lets you display shadows under 3D objects. By changing the
surface angle, you can obtain shadows that look more elongated or less elongated:

The first 3D sphere has a shadow with a surface angle of 0° (the paper is vertical) and the
second has a surface angle of 45° (paper inclined at 45°).

You can also see that the shadow is displayed in such a way that it corresponds to the angle of
illumination of the sphere.

Use the other parameters on this page to define the focal length and distance of the virtual
camera that displays the 3D object. The closer the camera (focal length, distance)is, the
greater the effect of perspective will be.

Illumination Management page

Use the Illumination page (Figure 10) to define the way in which 3D objects are illuminated.
Contrary to most 3D drawing software, the parameters can be set for each object
independently of the others. However, in order for the drawing to be coherent, set these
parameters the same way for all 3D objects.

(1= ] [T =]

Hlumination

Light source

|0 Riz04 Gio046:20: v | (L)

Ambient light |- Gray 60% “ | @

-

i ! U
] (e -

Figure 10: The Illumination Page
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On this page you can select eight different light sources to illuminate the currently selected
object. For each light source, you can specify its color and position with respect to the object.

To choose the current light source, use the buttons representing a small light bulb. The bulbs
that are lit correspond to an active light source and those that are not correspond to an
inactive light source. Double-click on a button to active or deactivate the corresponding light
source. A button that appears pressed down indicates the currently selected light source.

You can choose the color from the drop-down list or by using the small button on the right of
the list. Define the position of the light source by moving the blank dot with the mouse or the
slider bars on the small inset drawing located in the lower area of the Illumination page.
Then click the Assign icon ¥ to implement the light source setting.

Textures Management page
Before using this page, we will look at the two ways you can apply bitmapped images to an
object.

« Right-click on the object and select Area, then on the Bitmaps tab select a bitmap
motif.

« Use the Gallery (Figure 11). To apply a texture, first display the Gallery (Tools >
Gallery). Then drag and drop the motif with the mouse while pressing the

Shift+Control keys.
@ Untitled1 - OpenOffice.org Draw
Fle Edit View Insert Format Tools Modify Window Help
oo @ as vy B-¢ 52085 @]
\E| iy e | v| [000" #)] [MEoeck v O [color  v|suesn v @ L

Pages x

1

Slide 1

-

— " Layout  Controls {_Dimension Lines [1E3
k] -mM@®T L-u-2-@-0C-@-&-0-0-%- E? EEGIRE =R =

1 12,221 0,45 # 0,00 x 0.00 a0 || * Slide 1/ 1 Defalt

Figure 11: Applying a texture

The first method is better in that you can easily choose the number of tiles of the bitmap
motif to be applied. To open the Bitmap Application settings dialog (Figure 12), select
Format > Area and make your background edits there.
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Figure 12: Bitmap application settings

Note The checkbox Tile in the dialog lets you specify whether you want the motif to be
repeated (as in the cube top left) or not (as in the bottom right cube).

We have just seen how to change the number of tilings of the bitmap pattern. Now we will
look at the method that Draw uses to project the image onto the object. This is done on the
Textures page (Figure 13). The Textures page lets you manage the properties of a bitmap
texture applied to an object.

Textures —

Type @ @
Mode @ @
Projection X @B@
Projection ¥ @B@
Filtering

Figure 13: The Textures Page
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Type lets you choose to project the image in Black & White or in Color.

Mode tells Draw whether you want to manage lighting and shadow on the selected object. In
Figure 14 the first sphere corresponds to the setting Only Texture and the second (more
realistic) to the setting Texture and Shading.

Figure 14: Example of texture settings

The six Projection X /Y icons specify the type of projection used to draw the motif on the
object. The settings on the X and Y axes are Object-Specific, Parallel and Circular.
Generally, the default setting of Object-Specific can be left as it is because it gives the best
results.

Material Management page

The Material page (Figure 15) concerns the use of materials on the surface of 3D objects.
Use this page to give object the appearance of commonly used materials such as plastic or
metal.

3D Effects

= e 2 =]
Material
Eavorites |User-defined W |
Ohject colar |- Magenta & A | @
Tllurnination color |- Black - | @
Specular
Color | ke v| @
Intensiky | 15 =, -~

Figure 15: The Material Page
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Use the drop-down list Favorites to choose a predefined texture. The default choices are
Metal, Gold, Chrome, Plastic and Wood (see Figure 16).

0L 66

Figure 16: Texture examples. From left to right:
Metal, Gold, Chrome, Plastic and Wood.

The parameters you need to define are the default color and the lighting of the object, and the
color and intensity of the spot. The spot shows how the light reacts on the object.

Note that materials are compatible with textures. The use of materials generally lets you
accentuate the effect of any applied textures.

Managing Bitmaps
Up to now, we have only dealt with vector drawings. Draw also includes functions for
managing bitmaps, such as photographs.

We will not deal very much with the bitmap editing tools since other programs (such as The
Gimp) have more advanced functionality.

The Picture Toolbar

When a bitmap image is selected in the workspace, the Picture toolbar is displayed.

File Edit M“iew Insert Format Tools Modify  Window  Help

Ll G R DB DR D,
- x| I Qe 8 O 0 EIE L

w4 3. .. .|. . Wisible Buttons 3 .+ =, Filker

ABC
ey

Pages

Cuskomize Toolbar, . v @ Graphics mode

' m Color

W Q Transparency

1

Lock Toolbar Position

W {ﬁ Line

W & Area

v [ Shadow

w gj Crop

The Bitmap Image toolbar has been replaced with the Picture toolbar in OOo 2.0.
The filters are also located on this toolbar.
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Note Any changes you make to a bitmap will change only a copy of the image file in your
document. The original image will not be modified.

Default *

= IR
0w (3
0w (3
0
o= 2
Vit 2
Plow 2

=y

%

Graphics Mode: The type of display for the image. The four
options are:

Default.
Grayscale: displays the bitmap with 256 levels of gray.

Black/White: transforms the image into a black and white
representation.

Watermark: fades the colors of the bitmap image to make it
extremely pale.

Color: The control menu is visible when you click on the
Color button. Use the color controls to modify the level for
each of the primary colors in the image.

You can set each color level from —100% (no color) to +100%
(full intensity).

Adjust the brightness of the image from —100% (totally black)
to +100% (totally white).

Adjust the contrast of the image from —100% (least contrast)
to +100% (most contrast).

Adjust the gamma level from 0.10 to 10. This control lets you
effectively set the monitor balance for an image created on one
computer when the image is loaded on another computer.

Adjust the transparency of the image from 0% (opaque) to
100% (totally transparent).

Use this tool to crop an image. When you click this button, the
Crop dialog (Figure 17) appears.

Managing 3D Objects and Bitmaps
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In the Crop dialog (Figure 17) you can do the following:

« Cut out a part of the contour of the image. To do this, change the values in the Crop
section (such as Left and Right). The preview display area shows the new image frame.

+ Change the scale of the image up to 100%.

+ Change the size of the bitmap in the current measurement unit.

Crop

Crop
@ Keep scale;
(0 Keep image size Cancel

I
3

Left Tp (000 -
Right gottom (000" %

Scale

Width 100%: &

Height 100%, I

Image size

Width 4.15" e 4,15" % 4,78"

Height 475" = Original Size

Figure 17: Cropping an image

Bitmap Image Management Palette

Use the leftmost button on the Picture toolbar to display and pick the bitmap filters.
OpenOffice.org offers 11 filters.

n Inverts the colors in an image. The result looks like a color negative. This filter
is useful for resetting the colors in a scanned negative.

Managing 3D Objects and Bitmaps 13
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& Smooths an image.

ﬂ Sharpens an image.

Managing 3D Objects and Bitmaps 14
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48 Applies a solarization effect to an image. You can choose the degree of
o solarization for the image using a dialog box.

| Applies an aging effect to the image. You can set the degree of aging using a
' dialog box.

The Posterize filter lets you reduce the number of colors in an image. You can
choose the number of colors in the dialog box. The result is an image that looks
a bit like a drawing.

U
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m The pop art filter applies an effect that transforms the image into something
resembling a pop art drawing:

.ﬁ? Simulates a charcoal drawing effect

Managing 3D Objects and Bitmaps 16
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El:i The mosaic filter transforms the image into a pixellated mosaic.
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