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Toolbars and menus

Toolbars and menus

To change an object’s attributes (such as color, border width, etc) you can use the Line and 
Filling toolbar or the context menu.

Line and Filling toolbar
If the Line and Filling toolbar is not visible, you can display it using View > Toolbars > Line 
and Filling. From here you can edit the most common object attributes. You can also open 
the Line dialog by clicking on the   icon and the Area dialog by clicking on the  icon to 
see more options.

1  Styles & Formatting 4  Line Style 7      Area dialog
2  Line dialog 5  Line Width 8–9  Area Style/Filling 
3  Arrow Style 6  Line Color 10    Shadow

When you select text, this toolbar changes to show text formatting options.

The context menu
When an object is selected, you can right-click on the object to bring up a context menu. The 
context menu provides another way to change an object’s attributes. The entries with an 
arrow contain a submenu.

Figure 1: Right-click on an object to see the context menu.

Chapter Title 1



Editing lines and borders

Editing lines and borders

Lines (like arrows) and the borders of an object are managed through the same dialog. An 
object’s border is just one type of line.

Figure 2: Lines and borders

You can change some properties from the Line and Filling toolbar. To see more options, 
select the object and click on the  icon or right-click and choose Line. This opens the Line 
dialog.

Figure 3: Line dialog (right-click on an object and choose Line).

Common line properties
Most often the property you want to change is the line’s style (solid, dashed, invisible, etc), 
its color or width. These options are all available from the Line and Filling toolbar.

Figure 4: Common line options (style, width, color).

You can also edit these properties from the Line dialog. They are on the first tab, left column. 
In addition, from the Line dialog you can also change the line’s transparency.

Chapter Title 2



Editing lines and borders

Figure 5: The blue lines have different levels of  
transparency (0%, 25% and 50%).

Drawing arrows

Arrowheads are a line property. Select a line and click on the  button. This opens the 
Arrowheads dialog. There are several types of arrowheads available. Each end of the line can 
have a different arrowhead (or no arrowhead).

Note Arrowheads are only applicable to lines. They have no effect on an object’s border.

With the Line dialog you can fine tune the arrow properties.

Figure 6: Line dialog.
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Editing lines and borders

Synchronize ends forces the two arrow ends to be the same. The Center option is easier to 
see than to explain. It makes the arrow head move outwards to be centered around the end 
point (see below).

Figure 7: Default arrowheads (left) vs  
Centered arrowheads (right).

Customizing line and arrow styles
You are not constrained to only using the line and arrow styles provided by default. You can 
modify the styles, and create your own.

Customizing line styles

On the Line dialog, click on the Line Styles tab. From here you can customize the line styles 
or create your own (click on the Add button to create your own). You can change the length 
of the dashes, the space between them, and other attributes.

Figure 8: Editing line styles.

Use the Load Line Style and Save Line Style buttons to save a new definition or read one 
from disk (file extension .sod).
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Editing lines and borders

Customizing arrow styles

You can also create your own arrowheads to create some interesting effects, such as:

The first step is to draw a curve with the shape you want for the arrowhead.

Figure 9: To create your own arrowhead 
you must first draw a curve.

Note The arrowhead must be a “curve”. A curve is something you could draw without 
lifting a pencil. For example,  is a curve but  is not a curve.

Select the curve, open the Line dialog, and go to the Arrow Styles tab. Click on Add, enter a 
name for the arrow style and click OK.

Figure 10: Adding an arrow style.

Now you can access the new style from the Arrow style list (Figure 11).
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Editing lines and borders

Figure 11: Arrow Styles list.

Editing the inside (fill) of an object

The OpenOffice.org term for the inside of an object is Area fill. The area fill of an object can 
be a uniform color, a gradient, or an image.

Figure 12: Different types of area fill.

Common fill properties
Most often you will want to use one of the standard fill options, whether it is a color, a 
gradient or an image. These options are all available from the Line and Filling toolbar.

Figure 13: Common fill options.
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Editing the inside (fill) of an object

Fill with a uniform color

Select the object you wish to edit. On the Line and Filling toolbar, select Color and then 
choose a color from the right-hand menu.

Fill with a gradient

Select the object you wish to edit. On the Line and Filling toolbar, select Gradient and then 
choose a gradient from the right-hand menu.

Fill with a line pattern

The OpenOffice.org term for line patterns is Hatching. Select the object you wish to edit. On 
the Line and Filling toolbar, select Hatching and then choose an option from the menu.
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Editing the inside (fill) of an object

Fill with an image

You can fill an object with a bitmap image (as opposed to a vector graphic image). Select the 
object you wish to edit. On the Line and Filling toolbar, select Bitmap and then choose an 
option from the menu.

Adding a shadow

In OpenOffice.org shadows are considered an area property. Click on the  icon on the Line 
and Filling toolbar (next to the area fill functions).

Advanced area fill options

Click on the Area button  to bring up the Area dialog. From this dialog you can fine tune 
the area fill of an object in greater detail.

Creating your own fill color

Click on the Colors tab. From here you can modify existing colors or create your own.

Chapter Title 8



Editing the inside (fill) of an object

Figure 14: Customizing the color palette.

Every color is specified by a combination of the three primary colors (Red, Green and Blue), 
hence the notation RGB. Change these values and click on Add.

Creating your own gradient

On the Area dialog, click on the Gradients tab. From here you can modify existing gradients 
or create your own.

Figure 15: Customizing gradients.

First you need to choose two colors. A gradient works by creating a smooth transition from 
one color to another.
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Editing the inside (fill) of an object

Then choose a type of gradient. There are several available (Linear, Axial, Radial, etc) and 
each has different options. For example, a radial gradient has a center you can specify.

Figure 16: Center option in a radial gradient.

Creating your own line pattern

On the Area dialog, click on the Hatching tab. From here you can modify existing hatchings 
(line patterns) or create your own.

Figure 17: Modifying line patterns (hatchings).

You can customize options like the spacing between lines, the angle and the color of the 
lines. There is no way to edit the line thickness.
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Editing the inside (fill) of an object

Creating your own bitmap fill

You can add your own bitmap images to the area fill. First you need to create the bitmap 
image. For example, draw something with Draw and export it to PNG.

Now open the Area dialog and click on the Bitmaps tab. From here you can add new bitmap 
images to serve as area fill.

Figure 18: You can add your own bitmap images.

Click on Import and choose the file you saved. Now you can use that image as an area fill.
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Editing the inside (fill) of an object

Customizing shadows

First select the object you want to apply a custom shadow to. Open the Area dialog and go to 
the Shadow tab. Here you can customize the shadow’s position, distance and color.

Figure 19: Customizing shadows.

Shadows can also have transparency, so that the shadow will not hide objects behind it.

Figure 20: Shadow with 50% transparency.

Adding transparency

You can make objects semi-transparent. On the Transparency tab, choose Transparency (for 
a uniform transparency) or Gradient for a gradient transparency.
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Editing size and position precisely

Editing size and position precisely

You can move and resize objects using a mouse, but this method is not very precise. There is 
a tool for setting an object’s size and position precisely. Right-click on an object and choose 
Position and Size (or press the F4 key).

Position and size

Open the Position and Size dialog. On the first tab you can specify the size and position of an 
object. The position is specified as the (x,y) coordinate of the base point. By default, the base 
point is the top-left corner of the object, but you can change that too on this tab.

TIP The Keep ratio checkbox is your friend. Use it to keep the right object proportion.

To “Protect” the position means that the object is fixed in place and cannot be changed. This 
is useful to avoid moving the object accidentally. Un-protect it to move it again.

TIP Cannot move an object? Check that the position is not “protected”.

Figure 21: Object size and position.
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Editing size and position precisely

Rotate objects

Under the Rotation tab you can rotate the object. Set the angle and center of rotation (pivot).

Figure 22: Rotating an object.

Rounded corners and shear (slant)

OpenOffice.org considers rounded corners and shear a “position and size” property. Both are 
configured on the Position and Size dialog, under the Slant & Corner Radius tab.

The corner radius gives rounded corners (the greater radius the more rounded). The Slant 
angle gives a shear. 0 degrees means “no change”, and higher degrees give more shear.
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Using styles

Using styles

Suppose that you want to apply the same area fill and border to a set of objects. You can 
define a style with this combination and apply that style to multiple objects. For an 
introduction to styles, see the chapter titled “Introduction to Styles” in the Writer Guide. 
Click on the  icon on the Function Bar or press the F11 key to open the Styles and 
Formatting window.

Creating a new style

Select an object and customize the area fill and border. When you are satisfied, click on the 
 icon on the Styles and Formatting window. This defines a new style based on the selected 

object. Type a name for the new style and click OK.

Applying a style

Once the new style is defined, select another object and double-click on the style name you 
defined. The new object will acquire the area fill and line properties of that style.

TIP What happens if I modify a style after it has been applied?
Then every object with that style is updated automatically.

How to modify a style

Modifying a style is similar to creating a new style. Select an object with that style and 
change the area and line properties. When satisfied, click on the Update Style icon  .
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Special effects

Special effects

First make sure that the Drawing toolbar is selected (View > Toolbars > Drawing). On the 
Drawing toolbar, locate the Effects icon . Click on the arrow next to that icon. This 
opens a submenu with all the special effect tools (see below).

1  Effects 4  3D Rotation Object 7  Distort
2  Rotate 5  Set in Circle (Perspective) 8  Transparency
3  Flip 6  Set to Circle (Slant) 9  Gradient

Rotating an object

Click on the  icon to select the rotate tool. Then select an object. The selected object will 
have red handles instead of the usual green handles.

Grab one of the handles and move it to rotate the object. The black circle in the middle of the 
object is the pivot (center of rotation). You can move the pivot with the mouse.

Flip an object
Select an object and click on the flip icon . You will see a red line through the middle.
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Special effects

This red line is the axis of symmetry. The object will be reflected about this line. You can 
move the ends of the line with your mouse.

Then grab one of the green handles and move it across to the other side of the red line.

3D rotations
Imagine that you take a 2D object and rotate it around an axis to create a 3D object. Like this:

Start by drawing the 2D “profile” of the object.
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Special effects

Click on the 3D rotation icon . You will see a red axis with a handle at each end. This will 
be the axis of rotation for the 3D figure.

Move the ends of the axis line (the handles).

Click outside the image to complete the rotation.

To complete the effect, change the area fill to some color and add some transparency. The 
transparency makes the object look like it is made of glass.
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Special effects

Distorting an image
There are two tools that let you drag the corners and edges of an object to distort the image.

Distort tool  

Slant tool    

Select an object and click on the distort icon  or the Set to circle (slant) icon . If these 
icons are not visible, you can display them using View > Toolbars > Mode. OpenOffice.org 
will ask you if you want to transform the object to a curve. This is a necessary step before 
distortion, click Yes. Then you can move the object handles to stretch it.

Note Transforming an object into a curve is a safe operation, but it cannot be reversed 
other than by clicking the Undo button.

Dynamic gradients
A “transparency gradient” is something like this. The direction and degree of an object’s fill 
color changes from opaque to transparent. In a regular gradient, the fill changes from one 
color to another, but the degree of transparency remains the same.

   

Figure 23: Transparency gradient (left) vs regular gradient (right).

To define a transparency gradient, select an object with a color fill, and then click on the 
transparency icon . A dashed line connecting two small squares appears on top of the 
object, as shown in Figure 24. Click outside the object to set the gradient.
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Special effects

Figure 24: To modify a transparency gradient, move the squares.

To define a regular gradient, select an object, choose a gradient fill from the Line and Filling 
toolbar, The gradient icon  is now active. When you click on the gradient icon, a dashed 
line connecting two squares appears on the object, just as it does for a transparency gradient.

Move the two squares to modify the gradient. You can define the direction of the gradient 
(vertical, horizontal, or at any angle) and the spot at which the transparency begins.

Note If the transparency and gradient  icons are not visible, you can display them using 
View > Toolbars > Mode.
Moving the squares will have different effects depending on the type of gradient. 
For example, for a linear gradient, the start and end squares of the gradient will 
always be situated to either side of the center point of the object.
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