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Introduction

Introduction

In this chapter, we shall look at the tools and functions that let you modify existing drawings. 
All of the functions apply to the selected object or group of objects. The selected object 
differentiates itself from any others by small colored squares or circles located around the 
object (this is also true when several objects are selected simultaneously). In the rest of this 
document, we call these points handles.

These handles form a rectangular frame that is just big enough to contain the object. Where 
several objects are selected, the frame around them corresponds to the smallest rectangle that 
can contain all of the objects. This frame is called the selection rectangle.

If the Options Bar is displayed, you can change the size of the handles using two buttons: 
Simple Handles shows the handles as flat squares, and Large Handles shows the handles in 
a larger size. You can combine the effects obtained by pressing on both buttons. You can thus 
have large handles having a 3D shape or small handles having no 3D shape. This illustration 
shows the location of the handles and other buttons.

Selection modes
There are three selection modes: moving and changing size, rotating, and editing points.

To set the default mode for selecting objects, click on the Points button  on the Drawing 
Toolbar.

When the Points button is not active, the default mode is for selections to be moved or 
changed in size; these selections are indicated by small green squares.

When the Points button is active, the default mode is for selections to be edited; these 
selections are indicated by blue squares. Some objects will have one or more extra handles, 
which are larger or colored differently. This is explained in more detail in “Editing object
points” on page 6.
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Selection modes

Selections for rotating objects are indicated by small red circles and a symbol representing 
the center of rotation. To choose these selections click on the Effects drop-down button   
from the Drawing Toolbar.

Changing the selection mode
To go from one mode to another, you can do one of the following:

Choose the Points button  from the Drawing Toolbar to switch from simple selection 
mode to Points mode. You can also use the keyboard shortcut F81 (Points).

Choose the Effects drop-down button from the Drawing Toolbar  to activate the 
Rotation mode for a selected object.

By choosing the Rotation Mode after Clicking Object button  from the Options bar, 
you can cycle through normal and rotation modes just by clicking on the object. This can 
be more convenient than clicking the object, then clicking the Rotate button from the 
Drawing Toolbar.

Selecting objects

Direct selection
To select an object, the easiest way is to click directly on it. For objects that are not filled, you 
have to click directly on the object's outline to select it.

Selection by framing
You can select several objects by dragging a large rectangle around 
the objects with the select button, as shown.

For an object to be selected, it must be entirely within the rectangle.

1 Keyboard shortcuts can be configured by the user (Tools  > Configure > Keyboard). See Chapter 1 for more 
information.
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Selecting objects

Selecting hidden objects
When objects are located behind others, they can still be selected. To select an object that is 
covered by another object, hold down the Alt key and click the object. To select an object that 
is covered by several objects, hold down the Alt key and click through the objects until you 
reach the required underlying object. To cycle through the objects in reverse order, hold down 
the Alt+Shift keys when you click. To help in making accurate selections, you can check the 
number and type of the selected objects, shown at the left of the status bar.

Note There may be some variation in the use of the Alt key on different operating systems. 

To select an object that is covered by another object using the keyboard, press Tab to cycle 
through the objects. To cycle through the objects in reverse order, press Shift+Tab.

The easiest method is to use the Tab key to cycle through the objects, stopping at the object 
you wish to select. (This may not be practical if you have a large number of objects in your 
drawing). When you click on your selected object, its outline will appear briefly through the 
objects on top of the selected object.

In the illustration below, the square located beneath the circle was selected in this way (the 
circle was made transparent in order to see the square).

Arranging objects
In a complex drawing, you may have objects stacked up, one on top of the other. You can 
rearrange stacked objects by clicking Modify > Arrange and selecting the appropriate Bring 
Forward or Send Backward options, or by right-clicking the object and selecting Arrange 
from the context menu, then selecting the appropriate Bring Forward or Send Backward 
options. A keyboard shortcut is Shift+Ctrl++ to bring an object to the top, and Shift+Ctrl+− 
to send an object to the bottom.

Selecting several objects
To select or deselect several objects one by one, press the Shift key and click on the various 
objects to be selected or deselected. 
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Moving and dynamically adjusting an object’s size

Moving and dynamically adjusting an object’s 
size

There are several ways of moving or changing the size of an object. The method described 
here will be called dynamic in the sense that it is carried out using the mouse.

When you dynamically change an object, remember to check the right hand area of the status 
bar at the bottom of your screen. This shows detailed information about the ongoing 
manipulation. For example, during a resizing manipulation, you will see the following 
information displayed.

The information displayed changes when the mouse is moved.

Dynamic movement of objects
To move an object, select it and then click within the object’s border and hold down the left 
mouse button while moving the mouse. To drop the object at its new location, let go of the 
mouse button. During movement, the shape of the object appears as dotted lines to help with 
repositioning.

                    

Dynamic size modification of objects
To change the size of an object (or group of selected objects) with the mouse, you need to 
move one of the handles located around the selection. As shown in the following illustration, 
the outline of the resulting new object appears as a dotted line.

The results will differ depending on which handle you use. If you choose a corner handle, 
you will resize the object along two axes at the same time. If you use a side handle, the 
objects will only be resized along one axis.
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Moving and dynamically adjusting an object’s size

Note If you press the Shift key at the same time as you carry out the resizing operation, 
the size change will be carried out symmetrically with respect to the two axes, 
which enables you to keep the height/length ratio of the object.

Rotating an object
Rotating an object lets you slant the object along an axis. To do this dynamically, use the red 
handles, as you do when changing the size of the object.

Note Rotation works in a slightly different way for 3D objects, since the rotation occurs 
in 3D space and not in one plane. See also page 11 regarding rotation when Edit 
Points mode is active.

To rotate an object (or a group of objects), drag the red corner handle points of the selection 
with the mouse. The mouse cursor takes the shape of an arc of a circle with two arrows at 
each end. A dotted outline of the object being rotated appears and the current angle of rotation 
is dynamically shown in the status bar.

Rotations are made about an axis which is displayed as a small symbol. You can move the 
axis of rotation with the mouse, as shown below.

If you hold down the Shift key during the rotation, the operation will be carried out in 
increments of 15°. 

Inclination
To incline or slant an object, use the red handles located on one of the edges of the selected 
object. The inclination axis is shown as the nearest handle to the opposite edge.

As with rotation, you can set the inclination to occur as steps of 15° by pressing the Shift key 
while moving the handle.
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Figure 2 - Rounded rectangle

Figure 3 - Pie Figure 4 - Moving control 
points in the pie

Figure 5 - Circular 
segment

Figure 6 - Moving 
control points of the 

segment

Figure 1 - Simple rectangle

Editing object points

Editing object points

Draw offers a complete set of tools that let you accurately edit the contour of an object. As we 
shall see, the functions related to editing points work substantially in the same way as on 
curves. To make the most of these tools, you need to convert your objects into curves. To do 
this, select the object, then right-click and choose Convert > To Curve or choose Modify > 
Convert > To Curve  from the menu bar.

Direct operation
Some objects can be manipulated in Points mode without converting them into curves. When 
you do this, you act directly on the properties of the object. The objects involved are defined 
by the presence of one or more extra handle points. When you manipulate this handle (which 
is generally larger than the other selection handles), you will obtain various effects. The 
mouse cursor takes the shape of a pointing hand when it passes over one of these points. Here 
is the complete list of the objects concerned.

Rectangle or square. 

You can make the corners more 
or less rounded.

Arc or ellipse. 

You can change the associated 
angles. Arcs have two control 
handles.

Circular or elliptical segments. 

You can change the position of 
the edge of the segment.
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Figure 7 - Definition of a 
tangent

Editing object points

How curves work
Editing curves works on the basis of a method called Bezier curves1. The complete study of 
such curves goes beyond this particular work. We shall cover only the basics of this powerful 
method of editing the contour of an object.

Editing a point in a Bezier curve uses several mechanisms as 
represented in the drawing on the left: The main point is called 
the junction point. Two tangents project from this point, 
enabling manipulation of the curve that passes through the 
junction point. The basic idea is that, around the junction point, 
the two sides of the curve flatten out more or less along the 
tangent depending upon the size and position of the tangent.

You can create many different shapes by moving either the junction point itself, or one or 
both of the round handle points at either end of the tangent. 

The Bezier Curve Toolbar
When you work in Edit Points mode, use the Edit Points Toolbar as shown in Figure 8. 

Figure 8 - Edit Points Toolbar

On this toolbar, depending upon the selected object some buttons can be selected or not. 
When selected, their behavior is different. The role of the three buttons enabling you to 
choose the type of tangent will be described in the following chapter. The functioning of the 
other buttons will be described in relation to working examples.

The three kinds of tangent
Three buttons in the Edit Points Toolbar let you select the type of tangent and convert from 
one type to another. Only one of these buttons can be active at any given time.

1 Bezier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who 
developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles 
easier.
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Figure 10 - 
Asymmetrical tangent

Figure 11 - Inflexion 
point

Figure 9 - Symmetrical 
transition

Figure 12 - Moving a junction point

Editing object points

The Symmetric Transition button   lets you work with a 
symmetrical tangent. Any movement of one or the other of the 
handles will be carried over symmetrically to the other one.

The Smooth Transition button   lets you separate the 
lengths of the two parts of a tangent. In the drawing opposite, 
you can clearly see that the curve is flatter on the longest side 
of the tangent. This kind of tangent is known as a smooth 
junction. This button should not to be confused with the 
preceding one, since their representations are fairly similar.

It is also possible to completely detach both sides of the 
tangent. In this case, the central point is known as the 
inflexion point. Using this technique, you can draw spikes and 

troughs in objects. Use the Corner Point button   to create 
an inflexion point around the selected point.

Examples
The following examples start from a filled circle. As mentioned earlier, in order to use Edit 
Points mode, you first need to convert the object to a curve. 

You will notice that after conversion, the handles located in the corners of the rectangle have 
disappeared. This behavior is normal in that the handles which are used in Edit Points mode 
are located along the trace of the drawn object.

The Move Points button  is the default mode when editing 
points. If it has not been activated, click on the button. When 
this mode is active, the mouse cursor has the following shape 
when it is hovered over an edit point:

Movement of a point is one of the easiest manipulations to do. 
Figure 12 illustrates how an egg can be drawn very easily by 
starting from a circle and dragging the the top point upwards.
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Figure 13 - Rotating a tangent

Figure 14 - Adding an edit point to 
a curve

 

Figure 15 - Deleting points from a 
curve

Editing object points

To change the location of the tangents, just move the circular 
handles at each end. The mouse cursor then looks like this:

Use the Add Points button  to add an extra edit point to an 
existing curve. Click on the curve at the spot where you want 
to insert a point and then move the mouse slightly, in any 
direction, while holding down the button. If you just click, the 
new point will not be added. 

The tangent attributes associated with the new point depend 
on the buttons that are selected on the toolbar.

The Delete Points button  has the opposite effect: it 
subtracts one or more points from the curve. The resulting 
curve stretches itself automatically around the remaining 
points after subtraction.

Select one or more points to delete. You can select several 
points by holding down the Shift key (➊).

Then click the Delete Points   button. The selected points 
disappear from the curve, which then reforms around the 
remaining points (➋).

You can also delete the selected points by pressing the Del 
key on the keyboard.
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Figure 17 - Moving a segment

Figure 18 - Closing an open 
curve

Editing object points

 

Figure 16 - Cutting a curve

Use the Split Curve button  to split or cut a curve at the 
location of the selected handle. If the object is filled, it will be 
emptied, because the curve that represented the edge is no 
longer closed.

Check that you have selected the correct handle (➊), click the 

Split Curve button  (➋) and notice that the object is no 
longer filled. You can then check, by moving the point, that 
the curve has indeed been separated (➌).

If you have an open curve, the start point of the curve is larger 
than the others.

You can also separate a curve at several points 
simultaneously. Just keep the Shift key pressed down and 
select all of the points at which the cut should occur. 

To close an existing curve, select an open curve and click on 

the Close Bézier button  . 
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Figure 20 - Moving a point on a 
curve

Editing object points

The Select button  on the Drawing Toolbar functions as a 
switch. It works as follows.

If you have two points linked together by a straight line (you 
do not need to have a curve between the points) and you insert 
a new point between them that is set at an angle to the initial 
straight line (and hence the two endpoints), then:

• If the Select button is active, you will have a drawing 
similar to that illustrated in ➊.

• If the Select button is not active, and you move the point 
you have just inserted to bring it back close to its initial 
position in the straight line, you will have a drawing 
similar to that illustrated in ➋.

The Effects drop-down button  on the Drawing Toolbar 
and the Rotation Mode after Clicking Object button  on 
the Options Toolbar can be used in Edit Point mode. In this 
case, it can be used to move a point around the contour of an 
object.

Switch into Rotation mode by clicking on either of the 
rotation buttons. Notice that in rotation mode, all of the 
tangent points become red dots.

Select the point to be moved and then drag it around the 
contour while keeping the left mouse button pressed down 
(➊). When you let go of the mouse button, the point will be 
moved to the new position (➋). 

If you move one of the handles located at the end of the 
tangents during rotation, you will make the object rotate in 
exactly the same way as with the usual rotation operations.
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