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Drawing Basic Shapes

Drawing Basic Shapes

This chapter describes how to draw simple shapes. All shapes, whether they are simple lines, 
rectangles, or more complicated shapes, are objects. This is common notation in vector 
drawing software.

The following sections illustrate how to draw three basic shapes: a line, a rectangle and an 
ellipse. Figure 1 shows the buttons on the Drawing toolbar that correspond to the next three 
sections.

In previous versions of OOo, several toolbar buttons expanded by a long-click on a 
button with an arrow . In OOo 2.0 the expanded toolbars are separate. To see 
other button options, select View > Toolbars and choose the toolbar you need.

Figure 1: The Drawing toolbar

Note The Drawing toolbar can be positioned anywhere on or around the screen. 

Drawing a line

Click on the Line button  on the Drawing toolbar  and place the mouse cursor at the point 
where you wish to start drawing.

Click to start the line, then drag to where you want the line to end. A handle will appear at 
each end of the line, showing that this is the currently selected object. 

Figure 2: Drawing a line
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Hold down the Shift key while drawing the segment to force the line to be drawn at a multiple 
of 45° from the horizontal. 

Hold down the Alt key to draw the line symmetrically from the start point (the line extends 
out to both sides of the start point equally). This lets you draw lines by starting from the 
middle of the line.

The line you draw will have the default attributes (such as color and line type). To change the 
line attributes, click on the line to select it, right-click and change the attribute from the Line 
dialog.

Drawing a rectangle

Drawing rectangles is similar to drawing lines, except that you use the Rectangle tool  
from the Drawing toolbar. The (imaginary) line drawn with the mouse corresponds to the 
diagonal of the rectangle.

Figure 3: Drawing a rectangle

Hold down the Shift key to draw a square. Hold down the Alt key to draw a rectangle starting 
from its center.

Drawing a circle or ellipse

To draw an ellipse, use the Ellipse Button  from the Drawing toolbar. The ellipse drawn is 
the largest ellipse that would fit inside the (imaginary) rectangle drawn with the mouse.

Figure 4: Drawing a circle

Other shapes are available on the Drawing toolbar. In previous versions of OOo, 
these shapes were extended functions shown by long-clicking the Ellipse button.
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There are three other ways to draw an ellipse or circle:

• Hold down the Shift key while drawing to force the ellipse to be a circle.

• Hold down the Alt key to draw a symmetrical ellipse or circle from the center instead 
of dragging corner to corner. 

• Hold down the Ctrl key while drawing to snap the ellipse or circle to grid lines.

Note If you first press (and hold) the Control key before clicking on any of these buttons 
(Line, Rectangle, Ellipse, and Text), the chosen object appears directly on the page 
with a default size, shape and color. All of these attributes can then be changed.

The Basic Drawing Shapes

This section provides a complete overview of the basic objects in the Draw module. These 
objects can be edited, combined, and manipulated to create more complex shapes. We have 
already seen how to use some of these.

All of the tool palettes described here can be displayed from the Drawing toolbar (View > 
Toolbars > Drawing).

Text

Use the Text tool  to write text and select the font, color, size, and other attributes. Click 
on an empty space in the workspace to write the text at that spot. Press Enter to drop to the 
next line. 

When you have finished typing text, click outside the text frame. Double-click on the text at 
any time to edit it.

To add text to an object, double-click on the object, or click on the object to select it and then 
click the text tool.

When you type text, the upper toolbar includes the usual paragraph attributes: indents, first 
line and tab stops.

You can change the style of all or part of the text. The Styles and Formatting window also 
works here (select Format > Styles and Formatting or press F11), so you can create styles 
that you can reuse in other text frames exactly as you would with Writer.

Text frames can also have fill colors, shadows and other attributes, just like any other Draw 
object. You can rotate the frame and write the text at any angle. These options are available 
by right-clicking on the object.

Use the Callout tool, located on the Drawing toolbar, to create captions (also known as 
callouts or figure labels).
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Rectangles and Squares

The toolbar palette previously had 8 tools. In OOo 2.0 the rectangle is located on the 
Drawing toolbar. The other rectangle and square tools are located under the Basic 
Shapes button on the Drawing toolbar.

Circles, Ellipses and Arcs

The toolbar palette previously had 14 tools. In OOo 2.0 the Ellipse is located on the 
Drawing toolbar. The other circles, ellipses and arcs are located under the Basic 
Shapes button on the Drawing toolbar.

3D Objects
The 3D Objects palette (Figure 5) has 8 primitives that can be used to create more complex 
three-dimensional objects through merging or combination.

In OOo 2.0 the 3D Objects palette is located on the Drawing toolbar. The palette is 
not loaded by default. To load it:

1) Click on the shaded area at the far end of the Drawing toolbar  .

2) Select Visible Buttons > 3D Objects.
3) The 3D Objects button appears in the Drawing toolbar.

Figure 5: 3D objects palette

All 3D objects work in the same way: click on the button and draw a rectangle on the work 
area. You will see a boundary box (Figure 6). The final object will be drawn inside this box.
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Figure 6: 3D boundary box

Draw includes a wide variety of 3D effects (right-click on the object and select 3D Effects 
from the pop-up menu). These include the geometry, shading, texture, color, material and 
lighting of the object. For more information, see Chapter 6, “Managing 3D Objects and 
Bitmaps” in this guide.

Curves
The Curves palette (Figure 7) offers 8 tools for drawing non-linear profiles.

In OOo 2.0 the Curve palette is located on the Drawing toolbar. If you tear off this 
palette, the title bar on the palette shows Lines, as shown in Figure 7.

Figure 7: The curves palette (incorrectly titled “Lines” in OOo 2.0)

Lines and Arrows
The Arrows palette (Figure 8) offers 10 tools for drawing lines (with or without arrows).

In OOo 2.0 the Arrows palette is located on the Drawing toolbar. If you tear off this 
palette, the title bar on the palette shows Arrows, as shown in Figure 8.
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Figure 8: The Arrows palette

Connectors
Connectors are a type of line or arrow whose ends stick to glue points on other objects. When 
you move the other object, the connector moves with it.

Connectors are particularly useful for making organizational charts. You can reorganize the 
blocks of your chart and all the connectors stay connected.

Draw has a range of advanced connector functions. 

Connector drawing basics

All objects have invisible glue points associated with them. Connectors attach themselves 
automatically to the glue points of an object. Draw sets the default number of glue points for 
an object to 4. We will see later how you can add new glue points.

The default glue points are located at the midpoints of the sides of the square bounding the 
object, as shown in Figure 9. 

Figure 9: 4 glue points

When you move one of the ends of a connector over an object, its glue points become visible. 
You can drop the end of the connector onto one of the glue points. Afterwards, whenever 
either the connector or the object is moved, the end of the connector will remain attached to 
the object glue point.
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Note Glue points are different from handles (the small blue or green squares around an 
object). Use the handles to move or resize an object; use the glue points to attach 
connectors to an object.

Figure 10: Selecting a connector

You can also drop the end of the connector onto the object. In this case, when you move the 
object or the connector, Draw will automatically choose the best glue point to minimize the 
length of the connector:

Figure 11: Selecting a gluepoint

Draw will try to avoid drawing the connector on top of the object. 

You can always break the link between a connector and an object by moving the end of the 
connector away from the glue point to which it was attached.

As with all objects, connectors have control points to make drawing easier. The main control 
point is located in the middle of the connector and lets you set the length of the segments on 
either side of the control point.

The Connectors toolbar

In OOo 2.0 the Connectors palette is located on the Drawing toolbar. If you cannot 
see it, you can launch it by clicking on the shadowed arrow at the end of the toolbar 
and choosing Visible Buttons > Connectors.

The connector toolbar (Figure 12) contains a large number of buttons. 
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Figure 12: The Connectors palette

Connectors can be grouped into four categories: 

• Traditional Connectors are like the ones you have seen so far.

• Line Connectors are made up of a line segment and two smaller segments at the 
horizontal or vertical ends.

• Straight Connectors are made up of a simple straight line.

• Curved Connectors are based on Bezier curves (Bezier curves are discussed in another 
chapter).

Editing Glue points
Glue point management is handled by a special toolbar. This toolbar is not visible by default. 
Select View > Toolbars > Gluepoints to display it.
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Here is a brief description of the way these buttons work.

This button lets you insert a new glue point. Draw a new object. If the object is 
filled, the point can be inserted anywhere within the object, not only on its contour. 
Choose the Glue Points button  on the Drawing Toolbar. After you have chosen 
this button, click on the object to add the glue points. 

The glue points remain visible for as long as the button appears as “pressed down”. 
They are displayed as little blue crosses and the selected glue point is highlighted. 
You can move the glue points with the mouse and delete them with the Del key.

These four buttons let you choose the directions of movement that are allowed 
around the junction of a connector glue point. You can select several of these 
buttons for any given glue point.  They specify from which directions a connector 
can arrive at the glue point.

If you click on the   button, any connector placed on the glue point is forced to 
come in from the left as shown in the following drawing.

When in glue point edit mode, if you click on the   button, you can add a new 
possible direction to a glue point. If we keep the preceding example, this would 
give:

The addition of this extra direction enabled OOo to draw a shorter connector.
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When this button (“Glue Point Relative”) is active (which it is by default), resizing 
an object causes glue points to move too. The glue point moves relatively, as shown 
in the following example.

        

      If this button is deactivated, the glue point will not move.

When the button is deactivated, the last six buttons on the toolbar that were grayed 
out become usable. These buttons let you choose how the glue points will be 
rearranged when the object is resized.

These three buttons let you choose the horizontal position of the glue point. You 
can choose to maintain the same position with respect to the left edge (first button), 
the center (second button) or the right edge (third button).

As an example, in the following figures you see a glue point Horizontal left. The 
distance from the glue point to the left edge will always remain the same, unless the 
distance is larger than the object itself.

These three buttons let you choose the vertical positioning of the glue point. You 
can choose to maintain the same position with respect to the upper edge (first 
button), the center (second button) or the lower edge (third button).
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