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Introduction

Introduction

One of the features of OpenOffice.org (OOo) that received many rave reviews is its ability to 
use styles to format documents. OOo is not the first office program to allow its users to 
implement styles in a document, but OOo is one of the first to make it an understandable and 
easy process. 

A style is a set of formats that you can apply to selected elements in a document to quickly 
change their appearance. When you apply a style, you apply a whole group of formats at the 
same time.

The beauty of stylesis that you can define certain elements of a document to be a certain style, 
and every element that is defined as the same style will have exactly the same formatting. 
This can save a lot of headaches in document creation.

Even more powerful is the ability to change the formatting of all instances of an element in 
your document in one step. If you determine that you want all subtotals in your spreadsheet to 
be 8 pt. Courier font instead of 10 pt. Times New Roman after you have created a 15 page 
spreadsheet, you can change all of the subtotals in the document by simply changing the 
properties for the subtotal style..

This chapter describes the styles OOo Calc has to offer, what they might be used for, and how 
to apply styles, change existing styles, and create new styles. Finally, this document covers 
some how to import styles and manage them.

Types of styles in Calc

While some components of OOo offer many style types, Calc only offers two:

• Cell styles include fonts, alignment, borders, background, number formats (for 
example, currency, date, number), and cell protection.

• Page styles include margins, headers and footers, borders and backgrounds, and the 
sequence for printing sheets.

Accessing styles

Accessing styles in OOo Calc is the same as accessing styles in other OOo components. The 
main way to access styles is through the Styles and Formatting window (shown in Figure 1). 
You can open the Styles and Formatting window in several ways.

• Keyboard: Press the F11 key.

• Menu: Select Format > Styles and Formatting.

• Toolbar: Next to the font name drop down box in Calc there is an icon with a finger on 

it, . Click this to open the window.
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Accessing styles

This window can be docked at the left or right of the main Calc window. To dock or undock 
the window, hold down the Ctrl key and double-click a gray part of the window next to the 
icons at the top.

The first button on the top left of the window, , is for cell styles and the second, ,  is for 

page styles.

In OOo 2.0, what used to be called the Stylist in OOo1.x is now called the Styles 
and Formatting window.  

Figure 1: Styles and Formatting window

Applying styles

OOo Calc provides several ways for you to apply cell styles:

• Using the Styles and Formatting window

• Using Fill Format mode

• Using the Apply Style list

• Assigning styles to shortcut keys

Using the Styles and Formatting window
1) Ensure the Styles and Formatting window is open by pressing F11 or by selecting 

Format > Styles and Formatting.

2) Highlight the cell or group of cells to which the styles should be applied.

3) Double-click on the cell style name.
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Applying styles

Using Fill Format mode
This method is quite useful when you need to apply the same style to many scattered cells.

1) Open the Styles and Formatting window and select the style you want to apply.

2) Click the Fill Format mode icon . The mouse pointer changes to this icon.

3) Position the moving icon on the cell to be styled and click the mouse button.

4) To quit Fill Format mode, click the Fill Format mode icon again or press the Esc key.

When this mode is active, a right-click anywhere in the document undoes the last Fill Format 
action. Be careful not to accidentally right-click and thus undo actions you want to keep.

Using the Apply Style list
You can also add an Apply Style dropdown list to the Formatting toolbar and select a style 
from the list to apply it to the selected cells. 

To add an Apply Style dropdown list to the Formatting toolbar:

Click the down-arrow at the right-hand end of the Formatting toolbar. On the drop-down 
menu, click Visible Buttons. (See Figure 2.)

On the submenu, click Apply Style. The menus close and the Apply Style list now appears 
on the toolbar between the Styles and Formatting icon and the Font Name list.

Figure 2: Adding an Apply Style list to the Formatting toolbar

Assigning styles to shortcut keys
OOo provides a set of predefined keyboard shortcuts which allow you to quickly apply styles 
while typing in a document. You can redefine these shortcuts or define your own.

1) Click Tools > Customize > Keyboard. 
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Applying styles

2) On the Keyboard tab of the Customize dialog (Figure 3), choose the shortcut keys you 
want to define.

3) In the Functions section at the bottom of the dialog, scroll down in the Category list to 
Styles and click the + sign.

4) Choose the type of style. The Function list will display the names of the available 
styles for the selected type. The example shows OOo’s predefined styles.

5) Let’s say you want to set Ctrl+9 to be the shortcut key combination for the Result2 
style. To do this, select Result2 in the Function list, and then click Modify. Ctrl+9 
now appears in the Keys list.

6) Make any other required changes and then click OK to save these settings and close 
the dialog.

Figure 3: Assigning a cell style to shortcut keys
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Style organizer

Style organizer

When you double-click on the name of a style in the Styles and Formatting window, a Style 
dialog similar to the one shown in Figure 4 opens. 

The Style dialog has several tabs. The Organizer tab, shown in Figure 4, is found in all 
components of OOo). It provides basic information about the style.

Figure 4: Organizer tab of Cell Style dialog

Name

This is the style’s name. You cannot change the name of a built-in style. 

Linked with

In Calc this option is only available for cell styles. You can use this option to link styles. If 
you link styles, then when you change the base style (for example, by changing the font from 
Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what 
you want; other times you do not want the changes to apply to all the linked styles. It pays to 
plan ahead.

For example, you can make a new style called red, in which the only change you want to 
make is for the cell text to be red. In order to make sure that the rest of the text characteristics 
are the same as the default style, you can link red with default. Then, any changes you make 
to default will be automatically applied to red.

Category

In Calc, the only option in this drop-down box is Custom styles, but in other OOo 
components it is used to specify the category of the style.
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Cell styles

Cell styles

Similar to paragraph styles in OOo Writer, cell styles are the most basic type of style in Calc. 
You can apply a cell styles to a cell and that cell will follow the formatting rules of the style. 
Five cell styles are supplied with OOo: Default, Heading, Heading1,Result, and Result2.

Initially, the styles are configured so that if you change the font family of Default, then all of 
the other styles will change to match. We will discuss how to set this up in “Creating new
styles” on page 9. The five standard styles can be seen in use in Figure 5.

Figure 5: Calc cell style types

Cell style options
When editing or creating cell styles, you can set several options, which are similar to those 
for directly formatting cells. A more detailed coverage of cell formatting is given in 
Chapter 2, “Entering, Editing, and Formatting Data”. A brief summary is provided here. 

Numbers

On the Numbers tab, you can control the behavior of the data in a cell with this style. This 
includes specifying the type of data, the number of decimal places, and the language.

Font

On the Font tab, you can choose the font for the cell’s contents..

Font effects

The Font Effects tab offers more font options including underlining, strikethrough, and color.

Alignment

On the Alignment tab, you can set the horizontal and vertical alignment for the data in the 
cells, and rotate the text.

Borders

On the Borders tab, you can set the borders for the cells, along with a shadow.
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Cell styles

Background

On the Background tab, you can choose the background color for a cell.

Cell Protection

The Cell Protection options allow you to protect cells against certain types of editing.

Page styles

Page styles in Calc are applied to sheets. In fact, they might be more aptly called sheet styles, 
but to maintain consistency between components, they are not. Furthermore, only one page 
style can be applied to all the sheets in a file.

There are two default page styles: Default and Report. The major difference between these 
two styles is that Report is portrait oriented and Default is landscape oriented. You can adjust 
many settings using page styles. 

Page style options

Page

This is the area were you can edit the overall appearance of the page and its layout. The 
available options are shown in Figure 6.

Figure 6: Page Style Tab
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Page styles

Paper Format

Here you can set a generic paper type to be used. Letter or A4 are most common but you can 
also use legal, tabloid, envelope sizes, or user-defined paper types. You can also define the 
orientation of the page and which print tray for the paper to come from.

Margins

Here you can set the margins for the page.

Layout Settings

Here you can specify whether to apply the formatting to right (odd) pages only, left (even) 
pages only, or both right and left pages that use the current page style.

Mirrored formats the pages as if you want to bind the printed pages like a book.

The first page of a document is assumed to be an odd page.

Format

This area specifies the page numbering style for this page style.

Table alignment

This option specifies the alignment options for the cells on a printed page, either horizontal 
or vertical.

Borders

Similar to formatting a cell style, this tab gives you options about whether or not the page 
should have borders, how large the borders should be, and how far the text will be from the 
borders.

Background

This tab allows you to specify how the background for this page style will appear. You can 
apply either a solid color or a picture as a background.

Header

Here you can to design and apply the header for this page style. For more detailed 
instructions on how to format the header, please see Chapter 5, “Printing in Calc.”

Footer

Here you can design and apply the footer for this page style. For more detailed instructions on 
how to format the footer, please see Chapter 5, “Printing in Calc.”

Sheet

The sheet tab provides several options regarding how the document will be printed. Please 
see Chapter 5, “Printing in Calc” for more on this tab.
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Modifying styles

Modifying styles

To modify a style, right-click on its name in the Styles and Formatting window and select 
Modify. Make the changes in the Style dialog and click OK to save the changes.

You can also modify a current cell style by selecting an already formatted cell and clicking 
the Update Style button on the top right hand corner of the Styles and Formatting window.

Creating new styles

You can create a new style in one of these ways:

• Link to a current style

• Create an unlinked style

• Create a style from an already formatted object

• Drag and drop a selection

Creating a linked style

In the Styles and Formatting window, right-click on the style you want to link to and select 
New.

Creating an unlinked style

Right-click in the white area of the Styles and Formatting window and select New.

Creating a style from an already formatted object

Select the object whose properties you wish to copy and the click the New Style from 
Selection button, , on the top right of the Styles and Formatting window.

Dragging and dropping a selection to create a style

Select a cell and drag it to the Styles and Formatting window.

Copying and moving styles

Occasionally there is a fantastic style in one spreadsheet that you want to copy over to your 
current spreadsheet. You can do this using the Template Management window.

1) Select File > Template > Organize, The Template Management window (shown in 
Figure 7) opens.

2) By default, on the left is a list of available templates and on the right is a list of open 
documents. If you double-click on a template or a document, a Styles icon will appear 
under the name of the template or document. 
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Copying and moving styles

Figure 7: Template Management window

3) Now double-click on the Styles icon. to list all of the styles in that document or 
template . Hold down the Ctrl key and click and drag the styles you want from one 
side to the other, one style at a time.

Caution

   

If you do not hold down the Ctrl key when dragging a style in step 3 above, the 
style will be moved from one place to the other. You must hold down Ctrl in oder to 
copy the style.

Deleting styles

You cannot remove (delete) any of OOo’s predefined styles, even if you are not using them.

You can remove any user-defined (custom) styles; but before you do, you should make sure 
the styles are not in use. If an unwanted style is in use, you will want to replace it with a 
substitute style.

Replacing styles (and then deleting the unwanted ones) can be very useful if you are dealing 
with a spreadsheet that has been worked on by several people.

To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting 
window and click Delete on the pop-up menu.
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