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Graphics in Calc

Graphics in Calc

Graphics can be very useful aids to presenting data in OpenOffice.org (OOo) Calc. In this 
chapter, and in OOo as a whole, the word graphics includes both pictures and drawings. Calc 
is often used to present data and to make forecasts and predictions. Adding graphics can turn 
an average document into a memorable one.

This chapter covers adding graphics, pictures, and drawings in Calc. In most aspects, using 
graphics in Calc is very similar to using graphics in any other OOo component. This chapter 
explains some of the differences in their use. It also covers some of the more advanced 
graphics functions and how they can enhance spreadsheets further.

Inserting pictures

Pictures, including corporate logos and photographs of products and people, are probably the 
most common type of graphic added to a Calc document.

Graphics can be inserted in three ways:

• From a file

• From the gallery

• From another application by copying and pasting

From a file
The most common way to insert a picture is from an existing file. To insert a picture from a 
file:

1) Select Insert > Picture > From File from the menu bar.

Note The Insert Picture window can also be launched from the Draw toolbar by clicking 

on the  button.

2) In the Insert Picture window (Figure 1), navigate to and select the file to insert.

3) Select Open. The selected file is inserted into the spreadsheet.

Note The picture is inserted into Calc floating above the cells. See “Anchoring” on page 
13 for an explanation of how to anchor graphics.
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Inserting pictures

Figure 1: Insert Picture window

From the Gallery
The Gallery provides a convenient way to group reusable objects such as graphics and sounds 
that can be inserted into documents. The Gallery is explained in more depth in the chapter 
titled “Working with the Gallery” in the Getting Started guide.

This section explains the basics of inserting a picture into Calc from the Gallery.

1) To open the Gallery, choose Tools > Gallery, or click on the Gallery icon  . (See 
Figure 2.)

Figure 2: Gallery open in Calc
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Inserting pictures

2) Navigate through the Gallery to find the desired picture. 

3) To insert the picture, either right-click and choose Insert > Copy or click and drag the 
picture into the spreadsheet 

Note You can also insert a picture using Insert > Link. The difference between a copy 
and a link is that a copy saves the image into the file so that any changes to the 
original file don’t affect the document. A link is the opposite. A link is essentially a 
pointer to the original image. That means if you change the image file, the image in 
the document will change as well.

4) To close the Gallery, choose Tools > Gallery and uncheck the Gallery entry, or click 

on the Gallery icon  again.

From another application – copying and pasting
Pictures can be copied into Calc from other applications, both from other components of 
OOo and from non-OOo applications. To do this:

1) In the other application, copy the image to the clipboard.

2) Switch into Calc.

3) Right-click and choose Paste or select Edit > Paste to insert the graphic.

Caution

 

If the application from which the graphic was copied  is closed before the graphic is 
pasted into Calc, the image stored on the clipboard may be lost.

Drawing in Calc

Calc, like the other components of OOo, has a range of tools to create custom drawings. This 
chapter covers the default options in Calc. For a more detailed explanation of the drawing 
tools and their uses, please see the Draw Guide.

To access the drawing tools:

1) Select View > Toolbars > Drawing.

2) The drawing toolbar appears at the bottom of the screen (Figure 3).

Figure 3: Drawing toolbar

Table 1 describes the tools in this toolbar (left to right).
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Drawing in Calc

Table 1: Draw toolbar options

Toolbar 
button

Default behavior

Select Selects objects.

Line Draws lines.

Rectangle Draws a rectangle with a black border and blue background.

Ellipse Draws an ellipse with a black border and a blue background.

Freeform Line Draws a freeform line.

Text Draws a text box with no border.

Callouts Draws a square callout with a line connecting to one location.

Basic Shapes Clicking on the icon draws a diamond with a black border and blue 
background. Clicking on the drop down arrow displays other shapes.

Symbol Shapes Clicking on the icon draws a smiley face with a black border and 
blue background. Clicking on the drop down arrow displays other 
shapes.

Block Arrow Clicking on the icon draws a double sided block arrow with a black 
border and blue background. Clicking on the drop down arrow 
displays other arrows.

Flowcharts Clicking on the icon draws a table like symbol with a black border 
and blue background. Clicking on the drop down arrow displays 
other flowchart shapes.

Callouts Clicking on the icon draws a curved rectangular callout with a black 
border and blue background. Clicking on the drop down arrow 
displays other callout shapes.

Stars Clicking on the icon draws a 5 pointed star with a black border and 
blue background. Clicking on the drop down arrow displays other 
stars.

Points Allows editing of the points of a selected polygon.

Fontwork Gallery Opens the fontwork gallery.

From File (Insert) Opens the Insert Picture dialog box.

Extrusion On/Off Opens the 3-D Setting toolbar and converts the selected shape (if 
any) to 3-D.

Working with graphics in Calc

Now that the graphic, whether it is a picture or a drawing, is in Calc we need to be able to 
work with it so that it appears correctly. As in the other OOo components there are different 
settings for graphic files. This section explains the more commonly used ones in Calc.

We will look at options that come from two places when dealing with graphics: the Picture 
toolbar and the context menu. Some of the tools can be accessed in both places.
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Working with graphics in Calc

There is also a Drawing Object Properties toolbar; its features are described in the Draw 
Guide.

Picture toolbar
The Picture toolbar, by default, only shows when a picture is selected. It can be set to always 
be present (View > Toolbars > Picture) or picture control buttons can be added to the 
Standard toolbar. Those features are covered in the “Menus and Toolbars” chapter in the 
Getting Started guide.

The default Picture toolbar looks like Figure 4. Examples of the results of using these tools 
are given in the Draw Guide.

 

Figure 4: Picture toolbar

From File

The use of this icon is described “Inserting pictures” on page 1.

Filter

Clicking on the drop down arrow next to the Filter icon displays the toolbar shown in Figure
5.
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Working with graphics in Calc

Figure 5: Picture filter toolbar

Table 2: Picture filter toolbar buttons

Button Purpose

Invert Inverts the colors in the picture like a negative. 

Smooth Softens the contrast in an image.

Sharpen Increases the contrast in an image.

Remove Noise Removes single pixels from an image.

Pop Art Converts any image to a pop-art format.

Posterize Opens a dialog to determine the number of poster colors. This effect 
is based on the reduction of the number of colors. It makes photos 
look like paintings.

Mosaic Joins small groups of pixels into rectangular areas of the same color. 
The larger the individual rectangles are, the fewer details the graphic 
image has. 

Relief Displays a dialog for creating reliefs. The position of the imaginary 
light source that determines the type of shadow can be chosen.

Aging Makes a photo appear aged. The higher the aging degree, the older 
the picture will look.

Charcoal 
Sketch

Displays the image as a charcoal sketch. The contours of the image 
are drawn in black, and the original colors are suppressed. This 
function can be applied to the whole image or to a part of it.

Solarization Opens a dialog for defining solarization. Solarization refers to an 
effect that looks like what can happen when there is too much light 
during photo development. The colors become partly inverted. 
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Working with graphics in Calc

Graphics Mode

Use the graphics mode drop down box to change the colors of the selected picture. There are 
four options, as listed in Table 3.

Table 3: Graphics Mode options

Option Purpose

Default Keeps the picture the same as it was when inserted.

Grayscale Shows the picture as a grayscale image.

Black/White Shows only black and white in the image.

Watermark Make the picture into a watermark that blends into the background.

Color

Clicking on this button pops up a toolbar (Figure 6.) Use these tools to edit the different color 
hues in the picture and adjust the brightness, contrast, and gamma.

Figure 6: Color toolbar

Transparency

Adjusts the transparency of the picture.

Line

Opens a dialog box (Figure 7) where you can apply a border to a picture. 
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Working with graphics in Calc

Figure 7: Line dialog box

Area

You can apply a background to an area, but this is not particularly useful with working with 
pictures.

Shadow

Adds a shadow to a picture. The picture casts a shadow on the spreadsheet, rather than 
shadows within the picture being affected. 

Crop

Opens a dialog box where you can crop the image. Cropping removes part of a picture and is 
often used in photo editing.

Note It is not possible to use the mouse to select the area to be cropped. Instead, in the 
crop dialog, specify how far from the top, bottom, left and right borders the crop 
should be. The cropped shape will always be a rectangle; more complex cropped 
shapes are not possible with this tool in Calc.

Change Anchor

Toggles the anchor from To Page to To Cell and vice versa.

Bring to Front/Send to Back

These buttons quickly change the arrangement of the pictures. If two or more graphics are 
overlapping, this changes which graphic appears at the top and the bottom of the pile.
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Working with graphics in Calc

To Foreground/To Background

These buttons quickly change the location of the image to the background if it is in the 
foreground or to the foreground if it is in the background.

Note Bring to Front and Send to Back rearrange the order of a group of overlapping 
graphics, all of which remain floating on top of the cells. To Background pushes a 
graphic behind the cells. The section below on Positioning Graphics has more 
information.

Alignment

If two or more pictures are selected, click the drop down arrow next to this button to adjust 
the horizontal and vertical alignment of the pictures in relation to each other (tops aligned, 
bottoms aligned, centers aligned, and so on.

Picture context menu
Many of the same options accessible from the picture toolbar are also accessible from the 
context menu. There are some additional options only available from the context menu that 
are discussed here. The context menu is shown in Figure 8 and is accessible by right-clicking 
on a graphic. 

Opening the context menu has changed in OOo 2.0. In previous versions of OOo, 
right-clicking always opened a context menu for the highlighted object(s) and did 
not change the focus. In OOo 2.0, right-clicking changes the focus and then opens 
the context menu.

Figure 8: Picture context menu
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Working with graphics in Calc

Text

Opens a dialog box where you can set the options for text that goes over a picture. To write 
text over a graphic, click on the graphic to select it, and then press Enter. There should be a 
cursor inside the graphic. Any text entered is part of the graphic, so if the graphic is moved 
the text will move with it.

Position and Size

Opens a dialog (Figure 9) where you can change the size, location, rotation, slant, and corner 
radius of the graphic.

Figure 9: Position and size dialog

Flip

Flips the picture horizontally or vertically.

Name Object

Opens a dialog box where you can name the picture. This name is used in the Navigator (F5) 
to help identify the picture, but does not appear in the spreadsheet itself. If there are many 
graphics, it can make finding them easier if, for example, a graphic is called beach scene 
rather than graphic 23.

Group

Groups several different objects together so that they behave as one. For example, grouping 
four objects would allow you to move them as one. To group objects together:

1) Hold down Shift and left-click on each object until they are all selected. 
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Working with graphics in Calc

2) When all are selected, right-click and from the context menu select Group > Group.

3) If an existing group is selected, this menu may include options to Ungroup, Edit Group 
and Exit Group.

Once objects are grouped, they cannot be moved relative to each other; they have to move as 
a group. 

If you want to change their position, right-click and choose Group > Edit Group from the 
context menu. Editing the group allows you to change the objects’ relative position without 
first ungrouping them (you can also edit other individual properties). 

When you are done editing the group, you have to exit the group to do anything else. Right-
click and choose Group > Exit Group from the context menu.

Note If, having worked with groups, you cannot select certain objects, try selecting 
Group > Exit Group from the context menu.

Positioning graphics

Graphics can be positioned in Calc to work together and build more complex features.

Arrangement
By changing the arrangement of graphics, you can create layers of graphics, and create a type 
of 3-D effect. Figure 10 shows a series of arranged ellipses.

Figure 10: Arranged drawing

The Calc arrange options are shown in Figure 11.
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Positioning graphics

Figure 11: Calc arrange options

If you select an object and choose Bring Forward the object will move up one level. If 
Bring to Front is chosen, the object will become the top object.

Foreground and background

A graphic can be sent to the background as well. This is not the same as Bring Forward and 
Bring Back, which set the order of a number of overlapping graphics. This feature pushes a 
graphic to the back of the spreadsheet, behind the cells, allowing cells to be edited without 
affecting the graphic. One potential application of this feature is to create a form out of a 
graphic file; for example, to edit a tax form in Calc.

Figure 12 is an example of a tax form that was made into a graphic file and then had cells 
adjusted to allow text to be typed into specific locations. The grid lines below are blue for 
clarity.
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Positioning graphics

Figure 12: Empty tax return

Note A graphic that is in the background cannot be selected with the mouse. To select the 
graphic, use the Navigator (F5): all the graphics will be listed.. (If the graphic is 
named, selecting it will be even easier.)

Anchoring
Anchors are OOo’s way of telling a graphic where to stay. In Calc, graphics can be anchored 
in two ways: to a cell or to a page.

Anchor to page

Anchoring a graphic to the page allows it to be positioned in a specific place on the page. The 
graphic does not move when cells are added or deleted. This is equivalent to an absolute 
reference. The graphic will always stay by cell B10 if that is where it is placed.

Anchor to cell

Anchoring a graphic to a cell ensures that the graphic always stays with the content it is 
originally anchored to. If a graphic is anchored to cell B10, and a new row is inserted, the 
graphic will then be anchored to cell B11. This is equivalent to a relative reference.

For example in Figure 13 the normal Otto and Tux picture is anchored To Cell B10 (XXX 
shows where the picture is anchored.) The inverse Otto and Tux picture is anchored to the 
page.
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Figure 13: Anchoring 1

If two rows are inserted above the pictures, the normal picture will shift down two rows and 
the anchor will change. The inverse picture will not move. This is illustrated in Figure 14.

Figure 14: Anchoring 2

The final result can be seen in Figure 15.

Figure 15: Anchoring 3

Note that the anchor symbol and the XXX have moved down to cell B12.
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