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What is Calc?

What is Calc?

Calc is the spreadsheet component of OpenOffice.org (OOo). You can enter data, usually 
numerical data, in a spreadsheet and then manipulate this data to produce certain results.

Alternatively you can enter data and then use Calc in a ‘What If...’ manner by changing some 
of the data and observing the results without having to retype the entire spreadsheet or sheet.

A major advantage of electronic spreadsheets is that the data is easier to alter. If the correct 
functions and formulas have been used, the program will apply these changes automatically.

Spreadsheets, sheets and cells

Calc works with elements called spreadsheets. Spreadsheets consist of a number of 
individual sheets, each containing a block of cells arranged in rows and columns.

These cells hold the individual elements—text, numbers, formulas etc.—which make up the 
data to be displayed and manipulated.

Each spreadsheet can have many sheets and each sheet can have many individual cells. In 
version 2.0 of OOo, each sheet can have a maximum of 65,536 rows (1 through 65536) and a 
maximum of 245 columns (A through IV). This gives 16,056,320 individual cells per sheet.

The number of rows increased from OOo 1.x to 2.0. In 1.0 there were only 32,000 
rows.
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Parts of the main Calc window

Parts of the main Calc window

When Calc is started, the main window looks similar to Figure 1.

Figure 1. Parts of the Calc window

Title bar and Menu bar
The Title bar, at the top, shows the name of the current spreadsheet. If the spreadsheet is new, 
then its name is Untitled X, with X being a number. When you save a new spreadsheet for the 
first time, you will be prompted to enter a name.

In OOo 2.0 the file name is displayed in the title bar instead of the title of the 
document. Also, the OOo version is no longer displayed in the title bar.

Under the Title bar is the Menu bar. When you choose one of the menus, a submenu appears 
with other options. The Menu bar can be modified, as discussed in the chapter titled “Menus 
and Toolbars” in the Getting Started guide.
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Parts of the main Calc window

Toolbars
Under the Menu bar by default are three toolbars: the Standard toolbar, the Formatting 
toolbar, and the Formula toolbar.

No toolbars run vertically in OOo 2.0 as they did in 1.x. However, toolbars can be 
placed vertically on either side of the screen manually by dragging them.

The icons on these toolbars provide a wide range of common commands and functions. The 
toolbars can be modified, as discussed in the chapter titled “Menus and Toolbars” in the 
Getting Started guide.

Placing the mouse pointer over any of the icons displays a small box, called a tooltip It gives 
a brief explanation of the icon’s function. For a more detailed explanation, select Help > 
What's This? and hover the mouse pointer over the icon you need more help with.

The extended tips option in OOo 2.0 can no longer be accessed from the Help 
menu. Tips and extended tips can now be turned on or off from Tools > Options > 
OpenOffice.org > General. What's This? help is a new feature in OOo 2.0.

In the Formatting toolbar, there are two rectangular areas on the left. They are the Font Name 
and Font Size menus. (See Figure 2).  If there is something already in the box, it tells what 
the current setting for the selected area is.

Figure 2. Font name, and font size

Click the little button with an inverted triangle to the right of the box to open a menu. From 
the Font Name and Font Size menus, you can change the font and its size in selected cells.
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Parts of the main Calc window

Formula bar
On the left of the Formula bar (see Figure 3) is a small text box, called the Name box, with a 
letter and number combination in it, such as D7. This is the column letter and row number, 
called the cell reference, of the current cell. 

Figure 3. Formula Bar

To the right of the Name box are the the Function Wizard, Sum, and Function buttons.

Clicking the Function Wizard button opens a dialog box from which you can search through 
a list of available functions. This can be very useful, because it also shows how the functions 
are formatted.

The Sum button inserts a formula into the current cell that totals the numbers in the cells 
above, or to the left if there are no numbers above, the current cell.

The Function button inserts an equals sign into the selected cell and the Input Line, thereby 
setting the cell ready to accept a formula.

When you enter new data into a cell that already contains something, the Sum and Equals 
buttons change to Cancel and Accept buttons  .

The contents of the current cell (data, formula, or function) are displayed in the Input Line, 
the remainder of the Formula bar. You can edit the cell contents of the current cell here, or 
you can do that in the current cell. To edit inside the Input Line area, left-click the appropriate 
part of the Input Line area, then type your changes. To edit within the current cell, just 
double-click the cell.

Individual cells
The main section of the screen displays the individual cells in the form of a grid, with each 
cell being at the intersection of a particular column and row.

At the top of the columns and at the left-hand end of the rows are a series of gray boxes 
containing letters and numbers. These are the column and row headers. The columns start at 
A and go on to the right and the rows start at 1 and go on downwards.

These column and row headers form the cell references that appear in the Sheet Area box on 
the Formula Bar (see Figure 3). These headers can also be turned off by selecting View > 
Column & Row Headers.
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Parts of the main Calc window

Sheet tabs
At the bottom of the grid of cells are the sheet tabs (see Figure 4). These tabs enable access to 
each individual sheet, with the visible, or active, sheet having a white tab.

Clicking on another sheet tab displays that sheet and its tab turns white. You can also select 
multiple sheet tabs at once by holding down the Control key while you click the names.

Figure 4. Sheet tabs

File management

Starting new spreadsheets
A new spreadsheet can be opened regardless of which other component of OOo you are using 
at the time. For example, a new spreadsheet can be opened from Writer or Draw.

From the File menu

Click on the File menu and then select New > Spreadsheet.

From the toolbar

Use the New Document  button on the Standard toolbar. (This button is always a page 
of text from the current component with a black arrow to the right.) A long-click (click and 
hold) on the New Document button opens a submenu from which you can choose 
Spreadsheet (or any other type of OOo document). This submenu can also be opened by 
single-clicking on the black arrow next to the New Document button.

From the keyboard

If you already have a spreadsheet open, you can press Control+N to open a new spreadsheet.

Opening existing spreadsheets

From the File menu

Click on the File menu and then select Open.

From the toolbar

Click the Open button  on the Standard toolbar.

From the keyboard

Use the key combination Control+O.

Introducing Calc 5



File management

Each of these options displays the Open dialog box (Figure 5), where you can locate the 
spreadsheet that you want to open.

Figure 5. Open File dialog

TIP You can also open a spreadsheet that has been recently worked on using the 
Recently Opened Files list. This list can be accessed from the File menu, directly 
below Open. The list displays the last 10 files that were opened in any of the OOo 
components.

Opening from a template
Calc documents can also be created from templates, if you have any spreadsheet templates 
available. Follow the above procedures, but instead of selecting Spreadsheet from the menu, 
select Templates and Documents. On the Templates and Documents window, navigate to 
the appropriate folder and double-click on the required template. A new spreadsheet, based on 
the selected template, opens.
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Saving spreadsheets

Saving spreadsheets

Spreadsheets can be saved in three ways.

From the File menu

Click on the File menu and then select Save.

From the toolbar

Click on the Save button  on the Function bar. This button will be greyed-out and 
unselectable if the file has been saved and no subsequent changes have been made.

From the keyboard

Use the key combination Control+S.

If the spreadsheet has not been saved previously, then each of these actions will open the 
Save As dialog box (Figure 6). Here you can specify the spreadsheet name and the location in 
which to save the spreadsheet.

Figure 6. Save As dialog 

Note If the spreadsheet has been previously saved, then saving will overwrite the existing 
copy without opening the Save As dialog box. If you want to save the spreadsheet in 
a different location or with a different name, then select File > Save As.
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Navigating within spreadsheets

Navigating within spreadsheets

Going to a particular cell

Using the mouse

Place the mouse pointer over the cell and left-click.

Using a cell reference

Click on the little inverted black triangle just to the right of the Name box (Figure 3). The 
existing cell reference will be highlighted. Type the cell reference of the cell you want to go 
to and press Enter. Or just click into the Name box, backspace over the existing cell reference 
and type in the cell reference you want.

Using the Navigator

Click on the Navigator button  in the Standard toolbar (or press F5) to display the 
Navigator. Type the cell reference into the top two fields, labeled Column and Row, and press 
Enter. In Figure 7 the Navigator would select cell F5.

Figure 7. Calc Navigator
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Navigating within spreadsheets

Moving from cell to cell
In the spreadsheet, one cell, or a group of cells, normally has a darker black border. This 
black border indicates where the focus is (see Figure 8).

 
Figure 8. (Left) One selected cell and (right) a group of selected cells

Using the Tab and Enter keys

• Pressing Enter or Shift+Enter moves the focus down or up, respectively.

• Pressing Tab or Shift+Tab moves the focus right or left, respectively.

Using the cursor keys

Pressing the cursor keys on the keyboard moves the focus in the direction of the arrows.

Using Home, End, Page Up and Page Down

• Home moves the focus to the start of a row.

• End moves the focus to the column furthest to the right that contains data.

• Page Down moves the display down one complete screen and Page Up moves the 
display up one complete screen.

• Combinations of Control and Alt with Home, End, Page Down, Page Up, and the 
cursor keys move the focus of the current cell in other ways. Table 1 describes all the 
keyboard shortcuts for moving about a spreadsheet.

TIP Holding down Alt+Cursor key resizes a cell.
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Navigating within spreadsheets

Table 1. Moving from cell to cell using the keyboard

Key Combination Movement

→ Right one cell
← Left one cell
↑ Up one cell
↓ Down one cell
Control+→ To last column containing data in that row or to Column IV
Control+← To first column containing data in that row or to Column A
Control+↑ To first row containing data in that column or to Row 1
Control+↓ To last row containing data in that column or to Row 32000
Control+Home To Cell A1
Control+End To lower right hand corner of the square area containing data
Alt+PgDn One screen to the right (if possible)
Alt+PgUp One screen to the left (if possible)
Control+PgDn One sheet to the right (in Sheet Tabs)
Control+PgUp One sheet to the left (in Sheet Tabs)
Tab To the cell on the right
Shift+Tab To the cell on the left
Enter Down one cells
Shift+Enter Up one cell

Moving from sheet to sheet
Each sheet in a spreadsheet is independent of the others though they can be linked with 
references from one sheet to another. There are three ways to navigate between different 
sheets in a spreadsheet.

Using the keyboard

Pressing Control+PgDn moves one sheet to the right and pressing Control+PgUp moves one 
sheet to the left.

Using the mouse

Clicking one of the Sheet Tabs (see Figure 4) at the bottom of the spreadsheet selects that 
sheet.

If you have a lot of sheets, then some of the sheet tabs may be hidden behind the horizontal 
scroll bar at the bottom of the screen. If this is the case, then the four buttons at the left of the 
sheet tabs can move the tabs into view. Figure 9 shows how to do this.
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Navigating within spreadsheets

Figure 9. Sheet tab arrows

Notice that the sheets here are not numbered in order. Sheet numbering is arbitrary – you can 
name a sheet as you wish.

Note The sheet tab arrows that appear in Figure 9 only appear if you have some sheet 
tabs that can not be seen. Otherwise they will appear faded as in Figure 4.
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Selecting items in a sheet or spreadsheet

Selecting items in a sheet or spreadsheet

Selecting cells
Cells can be selected in a variety of combinations and quantities.

Single cell

Left-click in the cell. The result will look like the left side of Figure 4. You can verify your 
selection by looking in the Name box.

Range of contiguous cells

A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse:

1) Click in a cell.

2) Press and hold down the left mouse button.

3) Move the mouse around the screen.

4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.

2) Move the mouse to the opposite corner of the range of cells.

3) Hold down the Shift key and click.

To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.

2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

The result of any of these methods will look like the right side of Figure 4.

TIP You can also directly select a range of cells using the Name box. Click into the 
Name box as described in “Using a cell reference” on page 8. To select a range of 
cells, enter the cell reference for the upper left hand cell, followed by a colon (:), 
and then the lower right hand cell reference. For example, to select the range that 
would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells

1) Select the cell or range of cells using one of the methods above.

2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the Control key and click or click-and-drag to select a range. 

4) Repeat as necessary.
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Selecting items in a sheet or spreadsheet

In OOo v2.0 when you are selecting non-contiguous cells, the first part of your set 
does not have to be multiple cells. In OOo 1.x you had to select more than one cell 
as the first part of a non-contiguous range.

Selecting columns and rows
Entire columns and rows can be selected very quickly in OOo.

Single column

To select a single column, click on the column identifier letter (see Figure 1).

Single row

To select a single row, click on the row identifier number (see Figure 1).

Multiple columns or rows

To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.

2) Hold down the Shift key.

3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:

1) Click on the first column or row in the group.

2) Hold down the Control key.

3) Click on all of the subsequent columns or rows while holding down the Control key.

Entire sheet

To select the entire sheet, click on the small box between the A column header and the 1 row 
header (see Figure 10). 

Figure 10. Select all box

You can also use the keyboard to select the entire sheet by pressing Control+A.

Selecting sheets
You can select either one or multiple sheets. It can be advantageous to select multiple sheets 
at times when you want to make changes to many sheets at once.

Introducing Calc 13
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Selecting items in a sheet or spreadsheet

Single sheet

Click on the sheet tab for the sheet you want to select. The active sheet will become white 
(see Figure 4).

Multiple contiguous sheets

To select multiple contiguous sheets:

1) Click on the sheet tab for the first sheet.

2) Move the mouse pointer over the last sheet tab.

3) Hold down the Shift key and click on the sheet tab.

All the tabs between these two sheets will turn white. Any actions that you perform will now 
affect all highlighted sheets.

Multiple non contiguous sheets

To select multiple non contiguous sheets:

1) Click on the sheet tab for the first sheet.

2) Move the mouse pointer over the second sheet tab.

3) Hold down the Control key and click on the sheet tab.

4) Repeat as necessary.

The selected tabs will turn white. Any actions that you perform will now affect all highlighted 
sheets.

All sheets

Right-click over any one of the sheet tabs and select Select All Sheets from the popup menu

Working with columns and rows

Inserting columns and rows
Columns and rows can be inserted in several different way and quantities.

Single column or row

A single column or row can be added using the Insert menu:

1) Select the column or rows where you want the new column or row inserted.

2) Select either Insert > Columns or Insert > Rows.

Note When you insert a single new column, it is inserted to the left of the highlighted 
column. When you insert a single new row, it is inserted above the highlighted row.

A single column or row can also be added using the mouse:
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Working with columns and rows

1) Select the column or rows where you want the new column or row inserted.

2) Right-click the header.

3) Select Insert Rows or Insert Columns.

In OOo 2.0 when you open a context menu using the right mouse button, it opens at 
the location of the mouse pointer. In previous versions of OOo the context menu 
was always for the selected object, but now it opens for the object the mouse is 
currently over.

Multiple columns or rows

Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse 
button on the first one and then dragging across the required number of identifiers.

2) Proceed as for inserting a single column or row above. 

Deleting columns and rows
Columns and rows can be deleted individually or in groups.

Single column or row

A single column or row can only be deleted by using the mouse:

1) Select the column or row to be deleted.

2) Right-click on the column or row header.

3) Select Delete Columns or Delete Rows from the popup menu.

Multiple columns or rows

Multiple columns or rows can be deleted at once rather than deleting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse 
button on the first one and then dragging across the required number of identifiers.

2) Proceed as for deleting a single column or row above.
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Working with sheets

Working with sheets

Like any other Calc element, sheets can be inserted, deleted and renamed.

Inserting new sheets
There are many ways to insert a new sheet. The first step for all of the methods is to select the 
sheets that the new sheet will be inserted next to. Then any of the following options can be 
used.

• Click on the Insert menu and select Sheet, or

• Right-click on its tab and select Insert Sheet, or

• Click into an empty space at the end of the line of sheet tabs (see Figure 11).

Figure 11. Creating a new sheet

Each method will open the Insert Sheet dialog (Figure 12). Here you can select whether the 
new sheet is to go before or after the selected sheet and how many sheets you want to insert.

Figure 12. Insert Sheet dialog
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Working with sheets

Deleting sheets
Sheets can be deleted individually or in groups.

Single sheet

Right-click on the tab of the sheet you want to delete and select Delete Sheet from the popup 
menu.

Multiple sheets

To delete multiple sheets, select them as described earlier, right-click over one of the tabs and 
select Delete Sheet from the popup menu.

Renaming sheets
The default name for the a new sheet is “SheetX”, where X is a number. While this works for 
a small spreadsheet with only a few sheets, it becomes awkward when there are many sheets. 

To give a sheet a more meaningful name, you can:

• Enter the name in the name box when you create the sheet, or

• Right-click on a sheet tab and select Rename Sheet from the popup menu and replace 
the existing name with a better one.

Note Sheet names must start with either a letter or a number; other characters including 
spaces are not allowed, although spaces can be used between words. Attempting to 
rename a sheet with an invalid name will produce an error message.
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Viewing Calc

Viewing Calc

Using the zoom function
The zoom function allows you to change the view in order to see more or less cells in the 
window.

The zoom function can be activated by either:

• Going to the View menu and selecting Zoom, or

• Double-clicking on the percentage figure in the status bar at the bottom of the window.

Figure 13. Zoom dialog

Both methods will open the Zoom dialog (Figure 13). This dialog has the following options 
listed on the left side. 

• Entire Page – this option changes the view so that an entire page fits within the height 
and width of the window. The page is defined by the page format that has been applied 
to the sheet. This can be modified through Format > Page > Page tab or through 
Format > Styles and Formatting > Page Styles. In general, OOo will show at least 
one page within the window.

• Page Width – this option changes the view so that the width of the page fits within the 
width of the screen. The page is defined as above. Where Entire Page can make cells 
appear quite small, Page Width will show the width of the page while possibly 
sacrificing the view of the entire height of the page.

• Optimal – this option zooms the selected range to fit the screen and is normally 
greyed out to show that it is not available. To use this option, you must first highlight a 
range of cells. 

• Percentages – these options zoom the screen to a particular size, 100% being full size.
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Viewing Calc

• Variable – this option allows you to set a zoom percentage of your choice. Either use 
the up and down arrows to the right of the entry field or click three times in the field to 
select the current amount and type in your desired zoom level.

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the 
left of a spreadsheet or both. Then when scrolling around within the sheet, any frozen 
columns and rows remain in view. 

Figure 14 shows some frozen rows and columns. The heavier horizontal line between rows 3 
and 14 and the heavier vertical line between columns C and H denote the frozen areas.. Rows 
4 through 13 and columns D through G have been scrolled off the page. Because the first 
three rows and columns are frozen into place, they remained.

Figure 14. Frozen rows and columns

You can set the freeze point at one row, one column, or both a row and a column as in Figure
14.

Freezing single rows or columns

1) Click on the header for the row below where you want the freeze or for the column to 
the right of where you want the freeze.

2) Select Window > Freeze.

A dark line will appear to indicate where the freeze is put.
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Viewing Calc

Freezing a row and a column

1) Click into the cell that is immediately below the row you want frozen and immediately 
to the right of the column you want frozen.

2) Select Window > Freeze.

You will see two lines appear on the screen, a horizontal line above this cell and a vertical 
line to the left of this cell. Now as you scroll around the screen everything above and to the 
left of these lines will remain in view.

Unfreezing

To unfreeze rows or columns, select Window > Freeze. The checkmark by Freeze should 
vanish.

Splitting the window
Another way to change the view is by splitting the window – otherwise known as splitting the 
screen.  The screen can be split either horizontally or vertically or both. This allows you to 
have up to four portions of the spreadsheet in view at any one time.

Why would you want to do this? Imagine you have a large spreadsheet and one of the cells 
has a number in it which is used by three formulas in other cells. Using the split screen 
technique, you can position the cell containing the number in one section and each of the 
cells with formulas in the other sections. Then you can change the number in the cell and 
watch how it affects each of the formulas.

Figure 15. Split screen example
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Viewing Calc

Splitting the screen horizontally

To split the screen horizontally:

1) Move the mouse pointer into the vertical scroll bar, on the right-hand side of the 
screen, and place it over the small button at the top with the black triangle.

Figure 16. Split screen bar on vertical scroll bar

2) Immediately above this button you will see a thick black line (Figure 16). Move the 
mouse pointer over this line and it will turn into a line with two arrows (Figure 17).

Figure 17. Split screen bar on vertical scroll bar with  
cursor

3) Hold down the left mouse button and a grey line will appear, running across the page. 
Drag the mouse downwards and this line will follow.

4) Release the mouse button and the screen will split into two views, each with its own 
vertical scroll bar. 

Notice in Figure 15, the ‘Beta’ and the ‘A0’ values are in the upper part of the window and 
other calculations are in the lower part. You may scroll the upper and lower parts 
independently. Thus you can make changes to the Beta and A0 values and watch their affects 
on the calculations in the lower half of the window.

You can also split the window vertically as described below—with the same results, being 
able to scroll both parts of the window independently. With both horizontal and vertical 
splits, you have four independent windows to scroll.

Splitting the screen vertically

To split the screen vertically:

1) Move the mouse pointer into the horizontal scroll bar at the bottom of the screen and 
place it over the small button on the right with the black triangle.
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Viewing Calc

Figure 18: Split bar on horizontal scroll  
bar

2) Immediately to the right of this button you will see a thick black line (Figure 18). 
Move the mouse pointer over this line and it will turn into a line with two arrows.

3) Hold down the left mouse button and a grey line will appear, running up the page. 
Drag the mouse to the left and this line will follow.

4) Release the mouse button and the screen will be split into two views, each with its 
own horizontal scroll bar. 

Note Splitting the screen horizontally and vertically at the same time will give four 
views, each with its own vertical and horizontal scroll bars.

Removing split views

• Double-click on each split line, or

• Click on and drag the split lines back to their places at the ends of the scroll bars, or

• Select Window > Split. This will remove all split lines at the same time.

TIP You can also split the screen following the same procedure as freezing rows and 
columns on page 19. Follow those steps, but instead of choosing Window > Freeze, 
choose Window > Split.

Entering data into a sheet

Entering numbers
Select the cell and type in the number using either the top row of the keyboard or the numeric 
keypad. 

To enter a negative number, either type a minus (–) sign in front of it or enclose it in brackets 
( ).

By default numbers are right-aligned and negative numbers have a leading minus symbol.

Entering text
Select the cell and type the text. Text is left-aligned by default.

Introducing Calc 22

Split Screen Bar



Entering data into a sheet

Entering numbers as text
If a number is entered in the format 01481, Calc will drop the leading 0. To preserve the 
leading zero, in the case of telephone area codes for example, precede the number with an 
apostrophe, like this: '01481. However, the data is now regarded as text by Calc. Arithmetic 
operations will not work on it. It will either be ignored or will produce an error of some kind.

TIP Numbers can have leading zeros and be regarded as numerical entries if the the cell 
is formatted appropriately. Right-click on the cell and chose the Format Cells > 
Numbers. Adjusting the leading zeros setting can add leading zeros to numbers.

Entering dates and times
Select the cell and type the date or time. You can separate the date elements with a slant (/) or 
a hyphen (–) or use text such as 10 Oct 03. Calc recognizes a variety of date formats. You can 
separate time elements with colons such as 10:43:45.
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