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Introduction

Introduction

A template is a model that you use to create other documents. For example, you can create a 
template for business reports that has your company’s logo on the first page. New documents 
created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a 
set of styles, and user-specific setup information such as measurement units, language, the 
default printer, and toolbar and menu customization. 

All documents in OpenOffice.org (OOo) are based on templates. If you do not specify a 
template when you start a new Writer document, the document is based on the default 
template for text documents. If you have not specified a default template, Writer uses the 
blank template for text documents that is installed with OOo. See “Setting a default
template” on page 6 for more information.

This chapter shows you how to:

• Use a template to create a document.

• Create a template.

• Edit a template.

• Set a default template.

• Organize templates.

Using a template to create a document

To use a template to create a document:

1) From the main menu, choose File > New > Templates and Documents. The 
Templates and Documents dialog box opens. (See Figure 1.)

2) In the box on the left, click the Templates icon if it is not already selected. A list of 
template folders appears in the center box.

3) Double-click the folder that contains the template that you want to use. A list of all the 
templates contained in that folder appears in the center box.

4) Click the template that you want to use. You can preview the selected template or view 
the template’s properties:

• To preview the template, click the Preview icon. (For the location of the Preview 
icon, see Figure 1.) A preview of the template appears in the box on the right.

• To view the template’s properties, click the Document Properties icon. (For the 
location of the Document Properties icon, see Figure 1.) The template’s properties 
appear in the box on the right.

Working with Templates 1



Using a template to create a document

5) Click Open. The Templates and Documents dialog box closes and a new document 
based on the selected template opens in Writer. You can then edit and save the new 
document just as you would any other document.

Figure 1. Templates and Documents window

Creating a template

You can create your own templates in two ways:

• From a document

• Using a wizard

Creating a template from a document
To create a template from a document:

1) Open a new or existing document you want to make into a template.

2) Add the content and styles that you want.

3) From the main menu, choose File > Templates > Save. The Templates dialog box 
opens (see Figure 2).

4) In the New template field, type a name for the new template.
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Creating a template

5) In the Categories list box, click the category to which you want to assign the template. 
(The category is simply the template folder in which you want to save the template. 
For example, to save the template in the “My Templates” folder, click the My 
Templates category.)

To learn more about template folders, see “Organizing templates” on page 7.

6) Click OK. Writer saves the new template and the Templates dialog box closes. 

OOo 1.X previously used a “Default” folder in place of the new “My Templates” 
folder.

Figure 2. Saving a new template

Any settings that can be added to or modified in a document can be saved in a template. For 
example, below are some of the settings (although not exhaustive) that can be included in a 
Writer document and then saved as a template for later use:

• Printer settings: which printer, single-sided or double-sided, paper size, etc.

• Styles to be used, including character, page, frame, numbering, and paragraph styles.

• Format and settings regarding indexes, tables, bibliographies, table of contents.

Creating a template using a wizard
You can use wizards to create these types of Writer templates:

• Letter

• Fax

• Agenda
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Creating a template

For example, the Fax Wizard steps you through the following choices:

• Type of fax (business or personal)

• Document elements like the date, subject line (business fax), salutation, and 
complimentary close

• Options for sender and recipient information (business fax)

• Text to include in the footer (business fax)

To create a template using a wizard:

1) From the main menu, choose File > Wizards > type of template required (Figure 3).

Figure 3: Creating a template using a wizard

2) Follow the instructions on the pages of the wizard. This process is slightly different for 
each type of template, but the format is similar for all of them.

3) In the last section of the wizard, you can specify the name and location for saving the 
template. The default location is your user templates directory, but you can choose a 
different location if you prefer. 

4) Finally, you have the option of creating a new document from your template 
immediately, or manually changing the template. For future documents, you can re-use 
the template created by the wizard, just as you would use any other template.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the 
template’s styles to documents that were created from that template. 

Note You can only reapply styles. You cannot reapply content.
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Editing a template

To edit a template:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window opens (see Figure 4).

Figure 4. Template management window

2) In the box on the left, double-click the folder containing the template that you want to 
edit. A list of all the templates contained in that folder appears underneath the folder 
name.

3) Click the template that you want to edit.

4) Click the Commands button. 

5) From the drop-down menu, choose Edit. The Template Management window closes 
and the selected template opens in Writer.

6) Edit the template just as you would any other document. To save your changes, choose 
File > Save from the main menu.

The next time that you open a document that was created from the changed template, the 
following message appears.

Figure 5. Apply current styles message 

Click Yes to apply the template’s changed styles to the document. Click No if you do not 
want to apply the template’s changed styles to the document. Whichever option you choose, 
the message box closes and the document opens in Writer.
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Editing a template

Note Automatic updating from a template did not work in OOo2.0.2. This bug was fixed 
in OOo 2.0.3. To re-enable updating in files created using OOo 2.0.2:

1) Use Tools > Macros > Organize Macros > OpenOffice.org Basic. Select the 
document from the list, click the +, and select Standard. If Standard has a + 
beside it, click that and select a module.

2) Name the macro. For example, you could call it FixDocument. If the Edit button is 
active, click it. If the Edit button is not active, click New, type a module name in 
the pop-up dialog, and click OK.

3) In the Basic window, enter the following:
Sub FixDocument
TemplateName = ThisComponent.DocumentInfo.Template
  if TemplateName <> "" then
  ThisComponent.DocumentInfo.Template = TemplateName
  end if
End Sub

4) Click the Run BASIC icon, then close the Basic window.

5) Save the document.

Next time when you open this document you will have the update from template 
feature back.

Setting a default template

If you create a document by choosing File > New > Text Document from the main menu, 
Writer creates the document from the Default template. You can, however, set a custom 
template to be the default. You can reset the default later if you choose.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in 
the Template Management window. 

To save a template in one of these folders, do one of the following:

• Create and save the template as described in “Creating a template” on page 2.

• Import the template into the desired folder as described in “Importing a template” on 
page 8.

To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window (Figure 4) opens.

2) In the box on the left, double-click the folder that contains the template that you want 
to set as the default.

3) Click the template that you want to set as the default.

4) Click the Commands button. 
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Setting a default template

5) From the drop-down menu, choose Set as Default Template. The next time that you 
create a document by choosing File > New > Text Document, the document will be 
created from this template.

Resetting Writer’s Default template as the default
To reset Writer’s Default template as the default:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window (Figure 4) opens.

2) In the box on the left, click any folder.

3) Click the Commands button.

4) From the drop-down menu, choose Reset Default Template > Text Document. The 
next time that you create a document by choosing File > New > Text Document, the 
document will be created from Writer’s Default template.

Organizing templates

Writer can only use templates that are in OOo template folders. You can, however, create new 
OOo template folders and use them to organize your templates. For example, you might have 
one template folder for report templates and another for letter templates. You can also import 
and export templates. 

To begin, choose File > Templates > Organize from the main menu. The Template 
Management window (Figure 4) opens.

Creating a template folder
To create a template folder:

1) In the Template Management window, click any folder.

2) Click the Commands button. 

3) From the drop-down menu, choose New. A new folder called Untitled appears.

4) Type a name for the new folder, and then press Enter. Writer saves the folder with the 
name that you entered.

5) To close the Template Management window, click Close.

Deleting a template folder
To delete a template folder:

1) In the Template Management window, click the folder that you want to delete.

2) Click the Commands button. 
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Organizing templates

3) From the drop-down menu, choose Delete. A dialog box appears and asks you to 
confirm the delete.

4) Click Yes. The dialog box closes and the selected folder is deleted.

Moving a template
To move a template from one template folder to another template folder:

1) In the Template Management window, double-click the folder that contains the 
template that you want to move. A list of all the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to move and drag it to the desired folder.

Deleting a template
To delete a template:

1) In the Template Management window, double-click the folder that contains the 
template that you want to delete. A list of all the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to delete.

3) Click the Commands button.

4) From the drop-down menu, choose Delete. A dialog box appears and asks you to 
confirm the delete.

5) Click Yes. The dialog box closes and the selected template is deleted.

Importing a template
If the template that you want to use is in a different location, you must import it into an OOo 
template folder.

TIP When you download a template from a website or CD, you can save it anywhere on 
your computer and then import it into OOo as described here. 

To import a template into a template folder:

1) In the Template Management window, double-click the folder into which you want to 
import the template.

2) Click the Commands button.

3) From the drop-down menu, choose Import Template. The Open dialog box opens.

4) Find the template that you want to import and click Open. The Open dialog box closes 
and the template appears in the selected folder. 

5) If you want, type a new name for the template, and then press Enter.
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Organizing templates

Exporting a template
To export a template from a template folder to another location:

1) In the Template Management window, double-click the folder that contains the 
template that you want to export. A list of all the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to export.

3) Click the Commands button.

4) From the drop-down menu, choose Export Template. The Save dialog box opens.

5) Find the folder into which you want to export the template and click Save. Writer 
exports the template to the selected folder, and the Save dialog box closes.

Note All the actions made by the Commands button in the Template Management window 
can be made as well by simply right-clicking on the templates or the folders.
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