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Introduction

Introduction

General information about printing and faxing documents from OOo is provided in the 
Getting Started guide. This chapter describes some items of particular interest to users of 
Writer.

Quick printing

Click the Print File Directly icon  to send the entire document to the default printer 
defined for your computer.

Controlling printing

For more control over printing, use File > Print to display the Print dialog box (Figure 1).

Figure 1. The Print dialog box

On the Print dialog box, you can choose:

• Which printer to use (if more than one are installed on your system) and the properties 
of the printer—for example, orientation (portrait or landscape), which paper tray to 
use, and what paper size to print on. The properties available depend on the selected 
printer; consult the printer’s documentation for details.

• What pages to print, how many copies to print, and in what order to print them.

• Use dashes to specify page ranges and commas or semicolons to separate ranges; 
for example: 1, 5, 11-14, 34-40. 

• Selection is the highlighted part of a page or pages.
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Controlling printing

• What items to print. Click the Options button to display the Printer Options dialog 
box (Figure 2). 

Selecting print options for a document
Selections on the Printer Options dialog box (Figure 2) apply to this printing of this 
document only. To specify default printing options for Writer, see “Selecting default print
options” on page 3.

Some items of interest on the Printer Options dialog box include:

• In the Contents section, you might choose not to print graphics or page background in 
drafts, for example (to save toner or ink)

• In the Pages section, you can choose:

• Print only left (even-numbered) pages or only right (odd-numbered) pages. These 
settings are useful when you want to print on both sides of the page, but do not 
have a printer that handles this automatically.

• Print in reversed page order. 

• Brochure—the results of this selection are discussed in “Printing a brochure” on 
page 5.

• In the Notes section, you can choose whether to print any notes that have been added 
to your document (using Insert > Note), and where to print the notes.

Figure 2. Printer Options dialog box
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Controlling printing

Selecting default print options
Selections on the Printer Options dialog box over-ride any default settings. To specify default 
settings for printing, use Tools > Options > OpenOffice.org Writer > Print. The page 
displayed contains the same choices as the Printer Options dialog box.

Other printer settings are found in Tools > Options > OpenOffice.org > Print, as shown in 
Figure 3. Use this page to specify quality settings for printing, and whether to have OOo warn 
you if the paper size or orientation of your document does not match the printer settings.

Figure 3. Printer options for OpenOffice.org 

Printing in black and white on a color printer
You may wish to print documents in black and white on a color printer, to save expensive 
color ink or toner. Common uses are for drafts or documents to be photocopied in black and 
white. Several choices are available.

To print the current document in black and white or grayscale:

1) Click File > Print to open the Print dialog box (Figure 1).

2) Click Properties to open the properties dialog box for the printer. The available 
choices vary from one printer to another, but you should find an option for Color. See 
your printer’s help or user manual for more information.

3) The choices for color may include black and white or grayscale. Choose one of these. 
Grayscale is best if you have any graphics in the document. Click OK to confirm your 
choice and return to the Print dialog box, then click OK again to print the document.
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Controlling printing

To set up OOo to print all color text and graphics as grayscale:

1) Click Tools > Options > OpenOffice.org > Print to display the dialog box shown in 
Figure 3.

2) Select the Convert colors to grayscale checkbox. Click OK to save the change.

To set up OOo Writer to print all color text as black, and all graphics as grayscale:

1) Click Tools > Options > OpenOffice.org Writer > Print.

2) Under Contents, select the Print black checkbox. Click OK to save the change.

Previewing pages before printing
The normal page view in Writer shows you what each page will look like when printed, but it 
shows only one page at a time. If you are designing a document to be printed double-sided, 
you may want to see what facing pages look like. OOo provides a way to do this in Page 
Preview.

1) Click File > Page Preview, or click the Page Preview button .

The Writer window changes to display the current page and the following page, and 
shows the Page Preview toolbar (Figure 4) in place of the Formatting toolbar.

Figure 4. Page Preview toolbar

2) Click the Book Preview icon  to display left and right pages in their correct 
orientation.

3) To print the document in this page view, click the Print Page View icon  to open 
the Print dialog box (Figure 1). Choose your options and click OK to print as usual.

4) To choose margins and other options for the printout, click the Print Options Page 

View icon  to display the Print Options dialog box (Figure 5).

Figure 5. Print Options dialog box
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Printing a brochure

Printing a brochure

You can print a document with two pages on each side of a sheet of paper, arranged so that 
when the printed pages are folded in half, the pages are in the correct order to form a booklet 
or brochure.

To print a brochure on a single-sided printer:

1) Plan your document so it will look good when printed half size (choose appropriate 
margins, font sizes, and so on).Click File > Print. In the Print dialog box (Figure 1), 
click Properties and be sure the printer is set to the same orientation (portrait or 
landscape) as specified in the page setup for your document. (Usually the orientation 
does not matter, but it does for brochures.)

2) Click Options. In the Pages section of the Printer Options dialog box (Figure 2), 
choose Brochure and Right pages. Click OK twice to print the first side of each page.

3) Flip the pages and put them back into the printer, new side up, and in the correct 
orientation. You may need to experiment a bit to find out what the correct arrangement 
is for your printer.

4) Click File > Print and check Properties to make sure the printer setup is still correct.

5) Click Options again. In the Pages section of the Printer Options dialog box, choose 
Brochure and Left page. Click OK twice to print those second sides.

6) If your printer can do double-sided, then click on the checks for both left and right 
along with Brochure and it should not only do those but collate too.

Printing envelopes

Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with your document:

1) Click Insert > Envelope from the menu bar.

2) In the Envelope dialog box, start with the Envelope tab (Figure 6). Verify, add, or edit 
the information in the Addressee and Sender boxes (the “from” on the envelope). 

You can use the right-hand dropdown lists to select the database or table from which 
you can draw the envelope information, if desired. See “Setting up envelope details
from a database” on page 8 for details.

3) On the Format tab (Figure 7), verify or edit the positioning of the addressee and the 
sender information. The preview area on the lower right shows the effect of your 
positioning choices.
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Printing envelopes

Figure 6. Choosing addressee and sender information for an envelope

Figure 7. Choosing positioning and size of elements for an envelope 
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Printing envelopes

To format the text of these blocks, click the Edit buttons to the right.

• In Character, you can choose fonts, sizes, underlines or color, rotating/scaling, 
backgrounds and more.

• In Paragraph, you can choose indenting, alignment, flow, tabs and more.

4) In the lower left of this tab, choose the envelope format from the dropdown list. The 
width and height of the selected envelope then show in the boxes below the selected 
format. If you chose a pre-existing format, just verify these sizes. If you chose User 
defined in the Format list, edit the sizes.

5) After formatting, select the Printer tab (Figure 8) to choose printer options such as 
envelope orientation and shifting. You may need to experiment a bit to see what works 
best for your printer.

You can also choose a different printer or alter printer setup (for example, specify the 
tray that holds envelopes) for this print job.

Figure 8. Choosing printer options for an envelope

6) When you have finished formatting and are ready to print, click either the New Doc or 
Insert button to finish. New Doc makes only an envelope or starts a new document 
with the envelope. Insert inserts the envelope into your existing document as page 1.

To not proceed with this envelope, click Cancel or press the Esc key. You can also 
click Reset to remove your changes and return to the original settings when the dialog 
box opened.

When the Envelope dialog box closes, you are returned to your document, which now has the 
envelope in the same file as the document. Save this file before you do anything else.

To print the envelope:

1) Choose File > Print from the menu bar.

2) On the Print dialog box, under Print range, choose Pages and type 1 in the box. Click 
OK to print.
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Printing envelopes

Setting up envelope details from a database
You can use a database as a source of name and address details for printing one or a series of 
envelopes, either alone or with accompanying letters. Mozilla address books, dBase 
databases, spreadsheets, databases created by OOo Base, and others can be used as data 
sources.

After you have set up a data source (see Chapter 10, “Getting Started with Base” in the 
Getting Started guide), you need to register it with OOo so OOo can access it.

To register a data source, select File > New > Database, select Connect to an existing 
database, and select the type of data source to connect to. The exact source can then be 
chosen in the wizard.

For more details on how to set up a database or address book as a data source, see the chapter 
titled “Getting Started with Base” in the Getting Started guide.

To use the database when printing envelopes:

1) Click Insert > Envelope from the menu bar.

2) On the Envelope dialog box (Figure 9), select from the Database list the name of the 
data source. In the Table list, select the database table or sheet containing the address 
data that you want to insert. The Database field list will now show a list of the fields in 
the selected database.

Figure 9: Choosing a database and table from which to use addressee details
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3) Select the field containing the first piece of data (for example, first name) that you 
want to insert, then click the left arrow button to add the data to the Addressee box. 

4) To put another field on the same line in the Addressee box, select that field and click 
the left arrow button again. Be sure to include punctuation or spaces between fields in 
the Addressee box as needed. 

5) To put a field (for example, the address) on a new line, press Enter at the end of the 
previous line in the Addressee box. When you are finished selecting fields, the 
Envelope dialog box will look something like Figure 10.

Figure 10: The Envelope dialog box after choosing database fields for addressee

6) Click Insert or New Doc. A formatted envelope is now visible in your document.

7) Click File > Print from the menu bar. The dialog box shown in Figure 11 appears. 
Click Yes.

Figure 11: Confirmation dialog box for merging database fields

Printing with Writer 9
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8) The Mail Merge dialog box (Figure 12) appears. Here you can choose to print 
envelopes addresses to one, several or all address records in the database. For more 
about using mail merge, see the chapter titled “Using Mail Merge” in this Writer 
Guide.

9) Make your selections and then click OK to begin printing.

Figure 12: Choosing records to use when printing envelopes

Printing labels

To print labels:

1) Choose File > New > Labels on the menu bar. The Labels dialog box opens.

2) On the Labels tab (Figure 13), fill in your own label text in the Inscription box, or use 
the Database and Table dropdown lists to choose the required information as described 
in “Setting up envelope details from a database” on page 8.

3) Select the label stock in the Brand dropdown list. The types for that brand then appear 
in the Type dropdown list. Select the size and type of labels required. You can also 
select User type and then make specific selections on the Format tab (Figure 14).

4) Click the Format tab (Figure 14) to choose the pitch, sizes, margins and columns for 
user-defined labels, or just verify with a brand of label stock you have loaded into the 
printer.

5) Click Save to save your new format. 

6) On the Options tab (Figure 15), choose to print the entire page of labels or one single 
label, then select which one by the column and row. You can also change printer setup.

7) When you have finished formatting and you are ready, click New Document to make 
your sheet of labels or click Cancel (or press the Esc key). You can also click Reset to 
remove your changes and return to the original settings when the dialog box opened.
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Printing labels

Figure 13. Labels dialog box, Labels tab 

Figure 14. Labels dialog box, Format tab 

8) You can print right away using the Print File Directly button on toolbar or by choosing 
File > Print from the menu bar, or you can save the file to print later. 
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Printing labels

Figure 15. Labels dialog box, Options tab

Sending a fax

To send a fax directly from OpenOffice.org, you need a fax modem and a fax driver that 
allows applications to communicate with the fax modem.

Sending a fax through the Print dialog box
1) Open the Print dialog box (Figure 1) by choosing File > Print and select the fax driver 

in the Name list box.

2) Click OK to open the dialog box for your fax driver, where you can select the fax 
recipient.

Adding a Fax icon to the toolbar (advanced)
You can configure OpenOffice.org so that a single click on an icon automatically sends the 
current document as a fax.

1) Be sure the fax driver is installed. Consult the documentation for your fax modem for 
more information.

2) Choose Tools > Options > OpenOffice.org Writer > Print. The dialog box shown in 
Figure 16 opens.
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Sending a fax

Figure 16: Setting up OOo for sending faxes

3) Select the fax driver from the Fax list box and click OK.

4) Click the arrow icon at the end of the Standard toolbar. In the drop-down menu, 
choose Customize Toolbar. The Toolbars page of the Customize dialog box appears 
(Figure 17). Click Add.

Figure 17: Customizing a toolbar

5) On the Add Commands dialog box (Figure 18), select the Documents category, then 
select the Send Default Fax command. Click Add and then click Close.

6) On the Toolbars page, click the down arrow button to position the new icon where you 
want it. Click OK.

Your toolbar now has a new icon to send the current document as a fax.

Printing with Writer 13



Sending a fax

Figure 18: Adding a command to a toolbar

Exporting to PDF

OpenOffice.org can export documents to PDF (Portable Document Format). This industry-
standard file format for file viewing is ideal for sending the file to someone else to view 
using Acrobat Reader or other PDF viewers. 

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire document using the default 
PDF settings. You are asked to enter the file name and location for the PDF file, but you do 
not get a chance to choose a page range or the print quality.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as 
PDF. You are asked to enter the location and file name of the PDF to be created, and then the 
PDF Options dialog box opens. This dialog box has four pages. Make your selections, and 
then click Export.

General page of PDF Options dialog box

On the General page (Figure 19), you can choose which pages to include in the PDF, the type 
of compression to use for images (which affects the quality of images in the PDF), and other 
options.
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Exporting to PDF

Pages section

• All: Exports the entire document.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single 
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of 
page ranges and single pages, by using a format like 3-6;8;10;12.

• Selection: Exports whatever material is selected.

Figure 19: General page of PDF Options dialog box

Images section

• Lossless compression:  Images are stored without any loss of quality. Tends to make 
large files when used with photographs. Recommended for other images.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% tends to 
work well with photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower-DPI (dots per inch) images have lower quality.

Note EPS images with embedded previews are exported only as previews. EPS images 
without embedded previews are exported as empty placeholders.

Printing with Writer 15



Exporting to PDF

General section

• Tagged PDF: Includes special tags into the corresponding PDF tags. Some tags that 
are exported are table of contents, hyperlinks, and controls. This option can increase 
file sizes significantly.

• Export notes: Exports notes in Writer and Calc documents as PDF notes. You may not 
want this!

• Use transition effects: Not available in Writer; in Impress, this option exports slide 
transition effects in their respective PDF effects.

• Submit forms in format: Choose the format of submitting forms from within the PDF 
file. This setting overrides the control’s URL property that you set in the document. 
There is only one common setting valid for the whole PDF document: PDF (sends the 
whole document), FDF (sends the control contents), HTML, and XML. Most often 
you will choose the PDF format.

• Export automatically inserted blank pages: If selected, automatically inserted blank 
pages are exported to the PDF. This is best if you are printing the PDF double-sided. 
For example, books usually have chapters set to always start on an odd-numbered 
(right-hand) page. When the previous chapter ends on an odd page, OOo inserts a 
blank page between the two odd pages. This option controls whether to export that 
blank page.

Initial View page of PDF Options dialog box

On the Initial View page (Figure 20), you can choose how the PDF opens by default in a PDF 
viewer. The selections should be self-explanatory.

Figure 20: Initial View page of PDF Options dialog box
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Exporting to PDF

User Interface page of PDF Options dialog box

On the User Interface page (Figure 21), you can choose more settings to control how a PDF 
viewer displays the file. Some of these choices are particularly useful when you are creating a 
PDF to be used as a presentation or a kiosk-type display.

Figure 21: User Interface page of PDF Options dialog box

Window options section

• Resize window to initial page. Causes the PDF viewer window to resize to fit the 
first page of the PDF.

• Center window on screen. Causes the PDF viewer window to be centered on the 
computer screen.

• Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a 
smaller window.

• Display document title. Causes the PDF viewer to display the document’s title in the 
title bar.

User interface options section

• Hide menubar. Causes the PDF viewer to hide the menu bar.

• Hide toolbar. Causes the PDF viewer to hide the toolbar.

• Hide window controls. Causes the PDF viewer to hide other window controls.
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Security page of PDF Options dialog box

As of OOo 2.0.4, PDF export includes options to encrypt the PDF (so it cannot be opened 
without a password) and apply some digital rights management (DRM) features.

Figure 22: Security page of PDF Options dialog box

• With an open password set, the PDF can only be opened with the password. Once 
opened, there are no restrictions on what the user can do with the document (for 
example, print, copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its 
permissions can be restricted. See Figure 22.

• With both the open password and permission password set, the PDF can only be 
opened with the correct password, and its permissions can be restricted.

Note Permissions settings are effective only if the user’s PDF viewer respects the settings.

Figure 23 shows the pop-up dialog box displayed when you click the Set open password 
button on the Security page of the PDF Options dialog box.

After you set a password for permissions, the other choices on the Security page (shown in 
Figure 22) become available. These selections should be self-explanatory. 
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Figure 23: Setting a password to encrypt a PDF

E-mailing Writer documents

OOo provides several ways to quickly and easily send a Writer document as an e-mail 
attachment in one of three formats: .ODT (OpenDocument Text, OOo’s default format), 
.DOC (Microsoft Word format), or PDF.

To send the current document in .ODT format:

1) Choose File > Send > Document as E-mail. OpenOffice.org opens the e-mail 
program specified in Tools > Options > Internet > E-mail. The document is attached.

2) In your e-mail program, enter the recipient, subject and any text you want to add, then 
send the e-mail.

File > Send > E-mail as OpenDocument Text has the same effect.

If you choose E-mail as Microsoft Word, OOo first creates a .DOC file and then opens your 
e-mail program with the .DOC file attached. Similarly, if you choose E-mail as PDF, OOo 
first creates a PDF using your default PDF settings (as when using the Export Directly as 
PDF toolbar button) and then opens your email program with the .PDF file attached.

E-mailing a document to several recipients

To e-mail a document to several recipients, you can use the features in your e-mail program 
or you can use OOo’s mail merge facilities to extract email addresses from an address book.

You can use OOo’s mail merge to send e-mail in two ways:

• Use the Mail Merge Wizard to create the document and send it. See Chapter 11, 
“Using Mail Merge” for details.

• Create the document in Writer without using the Wizard, then use the Wizard to send 
it. This method is described here.

To use the Mail Merge Wizard to send a Writer document:
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E-mailing Writer documents

1) Click Tools > Mail Merge Wizard. On the first page of the wizard (Figure 24), select 
Use the current document and click Next.

Figure 24:  Select starting document

2) On the next page (Figure 25), select E-mail message and click Next.

Figure 25:  Choose document type

3) On the next page (Figure 26), click Select Address List. Select the required address 
list (even if only one is shown) and then click OK. (If the address list you need is not 
shown here, you can click Add to find and add it to the list.)
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Figure 26: Selecting an address list

4) Back on the Select address list page, click Next. On the Create salutation page (Figure
27), deselect the checkbox by This document should contain a salutation.

Figure 27: Deselecting a salutation

5) In the left-hand list, click 8 Save, print or send. OOo displays a “Creating 
documents” message and then displays the Save, print or send page of the Wizard.

6) Select Send merged document as E-Mail. The lower part of the page changes to show 
e-mail settings choices (see Figure 28).

7) Type a subject for your email and click Send documents. OOo sends the e-mails.

Printing with Writer 21



E-mailing Writer documents

Figure 28: Sending a document as an email message

Digital signing of documents

To sign a document digitally, you need a personal key, the certificate. A personal key is stored 
on your computer as a combination of a private key, which must be kept secret, and a public 
key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the 
document’s content plus your personal key. The checksum and your public key are stored 
together with the document. 

When someone later opens the document on any computer with a recent version of 
OpenOffice.org, the program will compute the checksum again and compare it with the 
stored checksum. If both are the same, the program will signal that you see the original, 
unchanged document. In addition, the program can show you the public key information from 
the certificate. You can compare the public key with the public key that is published on the 
web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the digital 
signature. 
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On Windows operating systems, the Windows features of validating a signature are used. On 
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are 
used. For a more detailed description of how to get and manage a certificate, and signature 
validation, see “Using Digital Signatures” in the OOo Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If you have not saved the document since the last change, a message box appears. 
Click Yes to save the file.

3) After saving, you see the Digital Signatures dialog box. Click Add to add a public key 
to the document.

4) In the Select Certificate dialog box, select your certificate and click OK. 

5) You see again the Digital Signatures dialog box, where you can add more certificates if 
you want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon to view 
the certificate.
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