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Introduction

Introduction

This chapter covers the basics of working with text in Writer, the word-processing 
component of OpenOffice.org (OOo). It assumes that you are familiar with the use of a 
mouse and keyboard and that you have read about Writer’s menus and toolbars and other 
topics covered in Chapter 1 of this book, “Introducing Writer”.

We recommend that you also follow the suggestions in Chapter 2, “Setting up Writer”, about 
displaying formatting aids such as end-of-paragraph marks, and selecting other setup options.

When you have read this chapter, you should know how to:

• Select, cut, copy, paste, and move text

• Find and replace text

• Insert special characters

• Format paragraphs and characters

• Create numbered or bulleted lists

• Check spelling, use the thesaurus, and choose hyphenation options

• Use the autocorrection, word completion, autotext, and line numbering features

• Track changes and undo and redo changes

Selecting text

Before you can do anything with text, you need to select it. Selecting text in Writer is similar 
to selecting anything in other applications. In addition to selecting blocks of text, you can 
select items that are not consecutive.

Selecting items that are not consecutive
To select non-consecutive items (as shown in Figure 1) using the mouse:

1) Select the first piece of text.

2) Hold down the Control key and use the mouse to select the next piece of text.

3) Repeat as often as needed.

4) Now you can work with the selected text (copy it, delete it, change the style, or 
whatever).

Note Macintosh users: substitute the Command key when instructions in this chapter say 
to use the Control key.
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Selecting text

To select non-consecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, 
see the topic “Navigating and Selecting With the Keyboard” in the Help.)

2) Press Shift+F8. This puts Writer in “ADD” mode. The word ADD appears on the 
Status Bar.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold 
down the Shift key and select the next piece of text.

4) Repeat as often as needed. Now you can work with the selected text.

5) Press Esc to exit from this mode.

Figure 1: Selecting items that are not next to each other

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. 
After selecting text, you can use the mouse or the keyboard for these operations.

Cut: Use Edit > Cut or the keyboard shortcut Control+X or the Cut icon on the toolbar.

Copy: Use Edit > Copy or the keyboard shortcut Control+C or the Copy icon.

Paste: Use Edit > Paste or the keyboard shortcut Control+V or the Paste icon.

If you simply click on the Paste icon, any formatting the text has (such as bold or italics) is 
retained. To make the pasted text take on the formatting of the surrounding text where it is 
being pasted, click the triangle to the right of the Paste icon and select Unformatted text 
from the menu. See Figure 2.

Figure 2: Paste menu
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Moving paragraphs quickly

Moving paragraphs quickly

1) Put the cursor anywhere in the paragraph.

2) Press Control+Alt.

3) Holding the Control+Alt keys down, press the up-arrow or down-arrow key.

The paragraph will move to before the previous paragraph or after the next paragraph in your 
document. To move more than one paragraph at a time, select at least part of both paragraphs 
before pressing the Control+Alt+arrow keys.

If you are using Solaris, the key combination is Control+AltGr+arrow keys.

TIP If your paragraphs suddenly jumped from one place to another, the most likely 
reason is that you have accidentally pressed one of these key combinations.

Finding and replacing text

When looking for certain words in a 3000-word essay, it would be inefficient (and close to 
impossible!) to go through every word manually. Writer has a Find and Replace feature that 
automates the process of searching for text inside a document.

In addition to finding and replacing words and phrases, you can:

• Use wildcards and regular expressions to fine-tune a search.

• Find and replace specific formatting.

• Find and replace paragraph styles.

To display the Find & Replace dialog box (Figure 3), use the keyboard shortcut Control+F or 
select Edit > Find & Replace.

1) Type the text you want to find in the Search for box. 

2) To replace the text with different text, type the new text in the Replace with box.

3) You can select various options such as matching the case, matching whole words only, 
or doing a search for similar words. (See below for some other choices.)

4) When you have set up your search, click Find. To replace text, click Replace instead. 

TIP If you click Find All, Writer selects all instances of the search text in the document. 
Similarly, if you click Replace All button, Writer will replace all matches. 

Caution Use Replace All with caution; otherwise, you may end up with some hilarious (and 
highly embarrassing) mistakes. A mistake with Replace All might require a manual, 
word-by-word search to fix.
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Finding and replacing text

Figure 3: The Find & Replace dialog box

Use wildcards (regular expressions)
Wildcards (also known as regular expressions) are combinations of characters that instruct 
OOo how to search for something. Regular expressions are very powerful but not very 
intuitive. They can save time and effort by combining multiple finds into one.

Table 1 shows a few of the regular expressions used by OOo.

TIP The online help describes many more regular expressions and their uses.

Note To search for a character that is defined as a wildcard, type a backslash (\) before 
the character. For example, to find the text $5.00, you would search for \$5\.00.

To use wildcards and regular expressions when searching and replacing:

1) On the Find & Replace dialog box, click More Options to see more choices. On this 
expanded dialog box (Figure 4), select the Regular expressions checkbox.

2) Type the search text, including the wildcards, in the Search for box and the 
replacement text (if any) in the Replace with box. Not all regular expressions work as 
replacement characters; the line break (\n) is one that does work.

3) Click Find, Find All, Replace, or Replace All (not recommended).
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Finding and replacing text

Table 1. Examples of search wildcards (regular expressions)

To find Use this 
expression

Examples and comments

Any single character . b.d finds bad, bud, bid, and bed.

Any string of characters .* b.*d finds bad, brand, and board.

One of the specified 
characters

[ ] b[iu]n finds bin and bun.

Any single character in 
this range

[-] [r-t]eed finds reed, seed, and teed; ranges must 
be in alphabetically ascending order.

Any single character 
except the characters 
inside the brackets

[^] p[^a]st finds post and pest, but not past.

The beginning of a word \< \<log finds logbook and logistics, but not 
catalog.

The end of a word \> log\> finds catalog, but not logistics.

A paragraph marker $ Does not work as a replacement character. Use \n 
instead.

A line break \n Finds a line break that was inserted with 
Shift+Enter. When used as a replacement 
character, it inserts a paragraph marker.

Find and replace specific formatting
A very powerful use of Find & Replace takes advantage of the format option. For example, 
you might want to replace underlined words with italics.

On the Find & Replace dialog box (with More Options displayed, as in Figure 4):

1) To search for text with specific formatting, enter the text in the Search for box. To 
search for specific formatting only, delete any text in the Search for box.

2) Click Format to display the Text Format (Search) dialog box. The tabs on this dialog 
box are similar to those on the Paragraph format and Paragraph Style dialog boxes. 
Choose the formats you want to search for and then click OK. The names of selected 
formats appear under the Search for box. For example, you might search for all text in 
14-point bold Helvetica.

3) To replace text, enter the replacement text in the Replace with box.

To search for specific text with specific formatting (for example, the word “hello” in 
bold), specify the formatting, put the text in the Search for box and leave the Replace 
with box blank.

To remove specific character formatting, click Format, select the Font tab, then select 
the opposite format (for example, No Bold). The No Format button on the Find & 
Replace dialog box clears all previously selected formats.

Working with Text 5



Finding and replacing text

4) Click Find, Find All, Replace, or Replace All.

Figure 4: Expanded Find & Replace dialog box

TIP Unless you plan to search for other text using those same attributes, click No 
Format to remove the attributes after completing your search. If you forget to do 
this, you may wonder why your next search fails to find words you know are in the 
document.

Find and replace paragraph styles
If you combine material from several sources, you may discover that lots of unwanted 
paragraph styles have suddenly shown up in your document. To quickly change all the 
paragraphs of one (unwanted) style to another (preferred) style:

1) On the expanded Find & Replace dialog box (Figure 4), select Search for Styles. (If 
you have attributes specified, this checkbox is labeled Including Styles.) The Search 
for and Replace with boxes now contain a list of styles.

2) Select the styles you want to search for and replace.

3) Click Find, Find All, Replace, or Replace All.
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Inserting special characters

Inserting special characters

A “special” character is one not found on a standard English keyboard. For example, © ¾ æ ç 
ñ ö ø ¢ are all special characters. To insert a special character:

1) Place the cursor in your document where you want the character to appear.

2) Click Insert > Special Character to open the Special Characters dialog box (Figure
5).

3) Select the characters you wish to insert, in order, then click OK. The selected 
characters are shown in the lower left of the dialog box. As you select each character, it 
is shown on the lower right, along with the numerical code for that character.

Note Different fonts include different special characters. If you do not find a particular 
special character you want, try changing the Font selection.

Figure 5: The Special Characters dialog box, where you can  insert special characters.

TIP Notice that the characters selected appear in the bottom-left corner of the dialog box.

Inserting dashes and non-breaking spaces

Non-breaking spaces

To prevent two words from being separated at the end of a line, press Control+spacebar after 
the first word.
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Inserting special characters

Non-breaking hyphen

You can use a non-breaking hyphen in cases where you do not want the hyphen to appear at 
the end of a line. Examples of non-breaking hyphens are: in a range such as A-Z or the 
hyphens in a telephone number, such as 123-4567. To insert a non-breaking hyphen, press 
Shift+Ctrl+minus sign.

En and em dashes

To enter en and em dashes, use the Replace dashes option under Tools > AutoCorrect > 
Options (Figure 11). This option replaces two hyphens, under certain conditions, with the 
corresponding dash.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. 
Figure 6 shows the Formatting toolbar as a floating toolbar, customized to show only the 
buttons for paragraph formatting.

TIP It is highly recommended that you use paragraph styles rather than manually 
formatting paragraphs, especially for long or standardized documents. For 
information on the advantages of styles and how to use them, see Chapter 6, 
“Introduction to Styles”.

1  Open Styles and 5  Align Right 10  Numbering On/Off
    Formatting window 6  Justified 11  Bullets On/Off
2  Apply Style 7  Line Spacing: 1 12  Decrease Indent
3  Align Left 8  Line Spacing: 1.5 13  Increase Indent
4  Centered 9  Line Spacing: 2 14  Paragraph format dialog

Figure 6: Formatting toolbar, showing buttons for paragraph formatting

Figure 7 shows examples of the different alignment options.

Figure 7: Different text alignment options
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Formatting paragraphs

Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any that you have defined. To set 
the measurement unit and the spacing of default tab stops, go to Tools > Options > 
OpenOffice.org Writer > General.

You can also set or change the measurement unit by right-clicking on the ruler to open a list 
of units, as shown in Figure 8. Click on one of them to change the ruler to that unit.

Figure 8: Ruler showing default tab stops

Double-click on a blank part of the ruler to open the 
Indents & Spacing tab of the Paragraph dialog box. 
Double-click on the ruler itself to open the Tabs tab 
of the Paragraph dialog box (Figure 9).

To fine-tune tab stop settings, use the Tabs page of the Paragraph dialog box (Figure 9).

Figure 9: Specifying tab stops and fill characters
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Formatting characters

Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar. 
Figure 10 shows the Formatting toolbar as a floating toolbar, customized to show only the 
buttons for character formatting.

TIP It is highly recommended that you use character styles rather than manually 
formatting characters. For information on the advantages of styles and how to use 
them, see Chapter 6, “Introduction to Styles”.

1 Open Styles and 5 Bold 10 Increase Font 15 Open Character
   Formatting window 6 Italic 11 Reduce Font      Format dialog
2 Apply Style 7 Underline 12 Font Color
3 Font Name 8 Superscript 13 Highlighting
4 Font Size 9 Subscript 14 Background Color

Figure 10: Formatting toolbar, showing buttons for character formatting

TIP To remove manual formatting, select the text and click Format > Default 
Formatting, or right-click and select Default Formatting from the pop-up menu.

Autoformatting
Writer can be set to automatically format parts of a document according to the choices made 
on the Options tab of the AutoCorrect dialog box (Tools > AutoCorrect > Options). See 
Figure 11.

The online help describes each of these choices and how to activate the autoformats. Some 
common unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal 
signs (===) on a line and then press Enter the paragraph is replaced by a horizontal 
line as wide as the page. The line is actually the lower border of the preceding 
paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star 
(*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A 
numbered list is created when you type a number followed by a period (.), followed by 
a space or tab at the beginning of a paragraph. Automatic numbering is only applied to 
paragraphs formatted with the Default, Text body or Text body indent paragraph styles.

TIP If you notice unexpected formatting changes occurring in your document, this is the 
first place to look for the cause.
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Autoformatting

Figure 11: Autoformat choices on the Options tab of the AutoCorrect dialog box

To turn autoformatting on or off, go to Format > AutoFormat (Figure 12) and select or 
deselect the items on the submenu.

Figure 12: Turning autoformatting on or off

• While Typing automatically formats the document while you type.

• If While Typing is deselected, you can select Apply to automatically format the file.
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Autoformatting

• Apply and Edit Changes automatically formats the file and then opens a dialog box 
where you can accept or reject the changes.

Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.

• Use list styles, as described in Chapter 7, “Working with Styles”.

• Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure
6). This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list and then click on the 
appropriate icon on the toolbar.

Note It is a matter of personal preference whether you type your information first, then 
apply Numbering/Bullets or apply these as you type. 

Using the Bullets and Numbering toolbar
You can create a nested list (where one or more list items has a sublist under it, as in an 
outline) by using the buttons on the Bullets and Numbering toolbar (Figure 13). You can 
move items up or down the list, create subpoints, and even change the style of bullets.

1  Bullets On/Off   8  Insert Unnumbered Entry
2  Numbering On/Off   9  Move Up
3  Numbering Off 10  Move Down
4  Up One Level 11  Move Up with Subpoints
5  Down One Level 12  Move Down with Subpoints
6  Move Up (One Level) with Subpoints 13  Restart Numbering
7  Move Down (One Level) with Subpoints 14  Bullets and Numbering

Figure 13: Bullets and Numbering toolbar

TIP It is possible to move a list entry up, together with all of its sub-entries. You can do 
this by clicking the Move Up with Subpoints button, which is located next to the 
standard move buttons. 
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Using footnotes and endnotes

Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are 
collected at the end of a document.

To work effectively with footnotes and endnotes, you need to:

• Insert footnotes.

• Define the format of footnotes.

• Define the location of footnotes on the page (see Chapter 4, “Formatting Pages”).

Inserting footnotes
To insert a footnote, put the cursor where you want the footnote marker to appear. Then click 
Insert > Footnote or click the Insert Footnote Directly icon on the Insert toolbar (see 
Figure 14).

Figure 14: Using the Insert Footnote Directly icon on the toolbar

A footnote marker is inserted in the text, and the cursor is relocated to the footnote area at the 
bottom of the page (or to the endnote area at the end of the document). Type the footnote 
content in this area.

If you use Insert > Footnote, the Insert Footnote dialog box (Figure 15) is displayed. Here 
you can choose whether to use the automatic numbering sequence specified in the footnote 
settings and whether to insert the item as a footnote or endnote.

Figure 15: Inserting a footnote directly
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Using footnotes and endnotes

If you use the Insert Footnote Directly icon, the footnote automatically takes on the 
attributes previously defined in the Footnote Settings dialog box (Figure 16).

You can edit an existing footnote the same way you edit any other text.

To delete a footnote, delete the footnote marker. The contents of the footnote are deleted 
automatically, and the numbering of other footnotes is adjusted automatically.

Defining the format of footnotes
To format the footnotes themselves, click Tools > Footnotes. On the Footnote Settings dialog 
box (Figure 16), choose settings as required. The Endnotes tab has similar choices.

Figure 16: Defining footnote formatting

Checking spelling

Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a wavy red line under any 
misspelled words. Once the word is corrected, the red wavy line disappears.

 To perform a separate spellcheck on the document (or a text selection) click the 
Spellcheck button. This checks the document or selection and opens the Spellcheck 
dialog box (Figure 17) if any misspelled words are found.

Here are some more features of the spelling checker:

• You can change the dictionary language (for example, to Spanish, French, or German) 
on the Spellcheck dialog box.

• You can add a word to a dictionary. Click Add in the Spellcheck dialog box and pick 
the dictionary to add it to.
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Checking spelling

• The Options dialog box of the Spellcheck tool has a number of different options such 
as whether to check uppercase words and words with numbers. It also allows you to 
manage custom dictionaries, that is, add or delete dictionaries and add or delete words 
in a dictionary.

• On the Font tab of the Paragraph Styles dialog box, you can set paragraphs to spell-
check in a specific language (different from the rest of the document). See Chapter 7, 
“Working with Styles” for more information.

Figure 17: Selecting a word from dictionary using the Spellcheck dialog box

Using the thesaurus

The thesaurus offers alternative words and phrases. Select the word or phrase you want to 
find alternatives for and select Tools > Language > Thesaurus or press Control+F7. Click 
on a meaning to show alternative words and phrases for that meaning of the word. For 
example, when given the word “house”, the thesaurus offers several meanings, including 
“dwelling”, “legislature” and “sign of the zodiac”. If you click on “dwelling”, you will see 
“dwelling”, “home”, “domicile”, “abode”, and other alternatives, as shown in Figure 18.

Note If the current language does not have a thesaurus installed, this feature is disabled.

Working with Text 15



Using the thesaurus

Figure 18: The thesaurus offers alternatives to words

Hyphenating words

To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window (Figure 19). 

Figure 19: Modifying a style

2) On the Paragraph Styles page of the Styles and Formatting window, right-click on 
Default and select Modify.

3) On the Paragraph Style dialog box, go to the Text Flow tab (Figure 20).

4) Under Hyphenation, select or deselect the Automatically checkbox.

5) Click OK to save.
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Hyphenating words

Figure 20: Turning on automatic hyphenation

Note Turning on hyphenation for the Default paragraph style affects all other paragraph 
styles that are based on Default. You can individually change other styles so that 
hyphenation is not active; for example, you might not want headings to be 
hyphenated. Any styles that are not based on Default are not affected. For more on 
paragraph styles, see Chapter 6, “Introduction to Styles” and Chapter 7, “Working 
with Styles”.

You can also set hyphenation choices through Tools > Options > Language Settings > 
Writing Aids. In Options, near the bottom of the dialog box, scroll down to find the 
hyphenation settings (see Figure 21).

Figure 21: Setting hyphenation options

To change the minimal number of characters for hyphenation, the minimum number of 
characters before a line break, or the minimum number of characters after a line break, select 
the item, and then click Edit.

Hyphenate without inquiry specifies that you will never be asked for to manually hyphenate 
words that the hyphenation dictionary does not recognize. If this box is not selected, when a 
word is not recognized, a dialog box will open where you can manually enter hyphens.

Hyphenate special regions specifies that hyphenation will also be carried out in footnotes, 
headers, and footers.

Notes Hyphenation options set on the Writing Aids dialog box are effective only if 
hyphenation is turned on through paragraph styles.

Choices on the Writing Aids dialog box for “characters before line break” and 
“characters after line break” override settings in paragraph styles for “characters at 
line end” and “characters at line begin”. This is a bug.
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Hyphenating words

To enter a conditional hyphen inside a word, press Control+minus sign. The word is 
hyphenated at this position when it is at the end of the line, even if automatic hyphenation for 
this paragraph is switched off.

Using AutoCorrect

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, 
which it corrects automatically. For example, “hte” will be changed to “the”. Select Tools > 
AutoCorrect to open the AutoCorrect dialog box. There you can define what strings of text 
are corrected and how. In most cases, the defaults are fine.

TIP AutoCorrect is automatically turned on. To turn it off, uncheck Format > 
Autoformat > While Typing.

• To stop Writer replacing a specific spelling, use Tools > AutoCorrect > Replace, 
highlight the word pair and click Delete.

• To add a new spelling to correct, type it into the Replace and With boxes and click 
New.

• See the different tabs of the dialog box for the wide variety of other options available 
to fine-tune AutoCorrect.

TIP AutoCorrect can be used as a quick way to insert special characters. For example, 
(c) will be autocorrected to ©. You can add your own special characters.

Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to 
complete this word for you. To accept the suggestion, press Enter. Otherwise, continue 
typing.

TIP Many people prefer not to use Word Completion. If you do not want to use it, select 
Tools > AutoCorrect > Word Completion and uncheck Enable word completion.

You can customize word completion from the Tools > AutoCorrect > Word Completion tab 
(Figure 22):

• Add (append) a space automatically after an accepted word.

• Show the suggested word as a tip (hovering over the word) rather than completing the 
text as you type.

• Change the maximum number of words remembered for word completion and the 
length of the smallest words to be remembered.

• Delete specific entries from the word completion list.
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Using word completion

• Change the key that accepts a suggested entry—the options are right arrow, End key, 
Return (Enter), and Space bar.

Note Automatic word completion only occurs after you type a word for the second time 
in a document.

Figure 22: Customizing word completion

Using AutoText

AutoText allows you to assign text, tables, graphics, and other items to a key combination. 
For example, rather than typing out “Senior Management”, you just have to type “sm” and 
press F3. Or you can save a formatted Tip (like the one on the next page) as AutoText and 
then inserting a copy by typing “tip” and pressing F3.

To insert AutoText, type the shortcut and press F3.

To assign some text to an AutoText shortcut:

1) Type the text into your document.

2) Select the text.

3) Go to Edit > AutoText (or press Control+F3).
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Using AutoText

4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you 
can change.

5) Click the AutoText button on the right of the AutoText dialog box and select New 
(text only) from the menu.

6) Click Close to return to your document.

TIP If the only option under the AutoText button is Import, either you have not entered 
a name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 14, “Working with 
Fields” for more information.

Line numbering

Line numbering puts line numbers in the margin. The line numbers are displayed on screen 
and are printed.

Click Tools > Line Numbering and select the Show numbering checkbox in the top left 
corner. Then click OK.

Figure 23 shows an example with numbering on every line.

Figure 23: Line numbering example

You can choose how many lines are numbered (for example, every line or every tenth line), 
the numbering type and whether numbers restart on each page. In addition, a text separator 
(any text you choose) can be set on a different numbering scheme (one every 12 lines, for 
example). See Figure 24.

Working with Text 20



Line numbering

Figure 24: The Line Numbering dialog box

Undoing and redoing changes

To undo the most recent change, press Control-Z, click the Undo icon  on the Standard 
toolbar, or select Edit > Undo from the menu bar. 

The Edit menu shows the latest change that can be undone, as shown in Figure 25.

Figure 25: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all the changes that can 
be undone (Figure 26). You can select multiple changes and undo them at the same time.

Figure 26: List of actions that can be undone
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Undoing and redoing changes

After changes have been undone, Redo becomes active. To redo a change, select Edit > 
Redo, or press Control+Y or click on the Redo icon . As with Undo, click on the 

triangle to the right of the arrow to get a list of the changes that can be reapplied.

To modify the number of changes OpenOffice.org remembers, select Tools > Options > 
OpenOffice.org > Memory and change Undo ─ Number of steps. Be aware that asking 
OOo to remember more changes makes it consume more memory.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

• Make your changes to a copy of the document (stored in a different folder, under a 
different name, or both), then use Writer to combine the two files and show the 
changes you made. Click Edit > Compare Document. This technique is particularly 
useful if you are the only person working on the document, as it avoids the increase in 
file size and complexity caused by the other methods.

• Save versions that are stored as part of the original file. However, this method can 
cause problems with documents of non-trivial size or complexity, especially if you 
save a lot of versions. Avoid this method if you can.

• Use Writer’s change marks (often called “redlines” or “revision marks”) to show 
where you have added or deleted material or changed formatting. Later, you or another 
person can review and accept or reject each change.

TIP Not all changes are recorded. For example, changing a tab stop from align left to 
align right and changes in formulas (equations) or linked graphics are not recorded.

Preparing a document for review
When you send a document to someone else to review or edit, you may want to prepare it 
first so that the editor or reviewer does not have to remember to turn on the revision marks. 
After you have protected the document, any user must enter the correct password in order to 
turn off the function or accept or reject changes.

1) Open the document. To check whether it contains multiple versions, click File > 
Versions. If multiple versions are listed, save the current version as a separate 
document with a different name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is turned on. The Edit > 
Changes > Record menu item has a check mark next to it when recording is turned 
on.

3) Click Edit > Changes > Protect Records. On the Enter Password dialog box, type a 
password (twice) and click OK.

Note Passwords must contain at least five characters. It is not necessary to password 
protect the document while preparing it for review.
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Recording changes
See Chapter 2, “Setting up Writer” for instructions on setting up how your changes will be 
displayed.

1) To begin tracking (recording) changes, click Edit > Changes > Record.

To show or hide the display of changes, click Edit > Changes > Show. 

TIP Hold the mouse pointer over a marked change; you will see a Help Tip showing the 
type of change, the author, date, and time of day for the change. If Extended Tips are 
enabled, you will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the change and 
then click Edit > Changes > Comment. (See Figure 27.) In addition to being 
displayed as an extended tip, the comment is also displayed in the list in the Accept or 
Reject Changes dialog box.

Figure 27: Inserting a comment during change recording

To move from one marked change to the next, use the arrow buttons. If no comment 
has been recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Changes > Record again.

Inserting notes
To insert a note that is not associated with a recorded change:

1) Place the cursor at the text you want to comment on, then click Insert > Note.

2) On the Insert Note dialog box (Figure 28), type your note. Click the Author button to 
insert your initials and the date and time.
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Tracking changes to a document

To view a note, move the mouse pointer over the note marker (displayed as a small yellow 
rectangle). Writer displays the note in a Tip above the text. You can also double-click on the 
note to see it inside the Edit Note dialog box. If you have trouble viewing or selecting notes 
this way, you can use the Navigator instead: expand the list of notes, select the one you want, 
right-click on it, select Note, and then select Edit to display the Edit Note dialog box.

The Edit Note dialog box looks much like the Insert Note dialog box, with the addition of 
forward and back arrow buttons if the document contains more than one note.

TIP You can change the color of the note marker using the Tools > Options > 
OpenOffice.org > Appearance dialog box. (In the Text Document section ─ Note  
Indicator.)

Figure 28: Inserting a note

Accepting or rejecting changes and comments
1) Click Edit > Changes > Accept or Reject. The Accept or Reject Changes dialog box 

(Figure 29) opens.

2) When you select a change in the dialog box, the actual change is highlighted in the 
document, so you can see what the editor changed. 

3) Click Accept or Reject to accept or reject the selected change. You can also click 
Accept All or Reject All if you do not want to review the changes individually.

Changes that have not yet been accepted or rejected are displayed in the list. Accepted 
changes are removed from the list and appear in the text without any marking.
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Tracking changes to a document

Figure 29: The List tab of the Accept or Reject Changes dialog box

To show only the changes of certain people or only the changes on specific days or various 
other restrictions, use the Filter tab (Figure 30) on the Accept or Reject Changes dialog box. 
After specifying the filter criteria, return to the List tab to see those changes that meet your 
criteria.

Figure 30: The Filter tab of the Accept or Reject Changes dialog box
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Merging modified documents
The processes discussed to this point are effective when you have one reviewer at a time. 
Sometimes, however, multiple reviewers all return edited versions of a document at the same 
time. In this case, it may be quicker to review all of these changes at once, rather than one 
review at a time. For this purpose, you can merge documents in Writer.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open one copy.

2) Click Edit > Changes > Merge Document and select and insert another copy of the 
document to be merged with the first.

3) After the documents merge, the Accept or Reject Changes dialog box opens, as in 
Figure 29, showing changes by more than one reviewer. If you want to merge more 
documents, close the dialog box and then repeat step 2.

4) Repeat until all copies are merged.

All recorded changes are now included in the open copy. Save this file under another name.

Comparing documents
Sometimes reviewers may forget to record the changes they make. This is not a problem with 
Writer because you can find the changes if you compare documents.

In order to compare documents, you need to have the original document and the one that is 
edited. To compare them:

1) Open the edited document.

2) Select Edit > Compare Document.

3) The Insert dialog box appears. Select the original document and click Insert.

Writer finds and marks the changes and displays the Accept or Reject Changes dialog box. 
From this point, you can go through and accept or reject changes procedure as described 
earlier.

Tips and tricks

Switching between insert and overwrite mode
With the keyboard, press Insert to toggle between overwrite mode and insert mode. In insert 
mode, any text after the cursor position moves forward to make room for the text you type; in 
overwrite mode, text after the cursor position is replaced by the text you type. The current 
mode is displayed on the Status Bar.

With the mouse, click in the area on the Status Bar that indicates the current mode in order to 
switch to the other mode.
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Tips and tricks

Counting the words in a selection
Select a block of text and choose Tools > Word Count. OOo displays the number of words 
and characters in the selection as well as the number of words in the document. You can also 
see the number of words and characters (and other information) in the entire document in 
File > Properties > Statistics.
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