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Choosing options that affect all of OOo

Choosing options that affect all of OOo

This section covers some of the settings that apply to all the components of OOo and are 
particularly important when using Writer. Other general options are discussed in Chapter 5, 
“Setting Up OpenOffice.org” in the Getting Started guide.

1) Click Tools > Options. The list in the left-hand box varies depending on which 
component of OOo is open. The illustrations in this chapter show the list as it appears 
when Writer is open.

2) Click the + sign by OpenOffice.org in the left-hand section of the Options – 
OpenOffice.org dialog box. A list of subsections drops down.

Note The Back button resets options to the values that were in place when you opened 
OOo. This button has the same behavior on all the Options dialog box pages.

User Data options
Because Writer’s revision features mark your changes and comments with the name or 
initials stored in the User Data page, you will want to ensure that your name and initials 
appear there. To do this:

1) In the Options dialog box, click OpenOffice.org > User Data.

2) Fill in the form on the OpenOffice.org – User Data page (Figure 1) or delete any 
existing incorrect information.

Figure 1. Filling in User Data

Setting up Writer 1



Choosing options that affect all of OOo

General options
1) In the Options dialog box, click OpenOffice.org > General.

2) On the OpenOffice.org – General page (Figure 2), the options are as described below.

Figure 2. Setting General options for OpenOffice.org 

Help - Tips

When Help: Tips are active, one or two words will appear when you hold the cursor over an 
icon or field on the main OOo window, without clicking. This setting also affects the display 
of notes: if both Help: Tips and Extended Tips are turned off, then you won’t see the 
contents of a note when you hold the cursor over the note.

Help - Extended tips

When Extended tips are active, a brief description of the function of a particular icon or 
menu command or a field on a dialog box appears when you hold the cursor over that item.

Help Agent

To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this checkbox. 
To restore the default Help Agent behavior, click Reset Help Agent.

Help formatting

High contrast is an operating system setting that changes the system color scheme to improve 
readability. To display Help in high contrast (if your computer’s operating system supports 
this), choose one of the high-contrast style sheets from the pull-down list. For Windows XP, 
the high-contrast style options are as described below.
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High-contrast style Visual effect

Default Black text on white background

High Contrast #1 Yellow text on black background

High Contrast #2 Green text on black background

High Contrast Black White text on black background

High Contrast White Black text on white background

Open/Save dialog boxes

To use the standard Open and Save dialog boxes for your operating system, deselect the Use 
OpenOffice.org dialogs checkbox. When this checkbox is selected, the Open and Save 
dialog boxes supplied with OpenOffice.org will be used. (See Chapter 3, “File Management” 
in the Getting Started guide for more about the OOo Open and Save dialog boxes.)

Document status

Choose whether printing a document counts as changing the document. If this option is 
selected, then the next time you close the document after printing, the print date is recorded 
in the document properties as a change and you will be prompted to save the document again, 
even if you did not make any other changes.

Year (two digits)

Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as 
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is, 
1/1/20 is interpreted as 1/1/2020.
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View options
The choices of View options affect the way the document window looks and behaves.

1) In the Options dialog box, click OpenOffice.org > View.

2) On the OpenOffice.org – View page (Figure 3), set the options to suit your personal 
preferences. Some options are described below.

Figure 3. Choosing View options for the OpenOffice.org applications

User Interface – Scaling

If the text in the help files or on the menus of the OOo user interface is too small or too large, 
you can change it by specifying a scaling factor. Sometimes a change here can have 
unexpected results, depending on the screen fonts available on your system. However, it does 
not affect the actual font size of the text in your documents.

User Interface – Icon size and style

The first box specifies the display size of toolbar icons (Automatic, Small, or Large); the 
Automatic icon size option uses the setting for your operating system. The second box 
specifies the icon style (theme); here the Automatic option uses an icon set compatible with 
your operating system and choice of desktop: for example, KDE, or Gnome on Linux.

User Interface – Use system font for user interface

If you prefer to use the system font (the default font for your computer and operating system) 
instead of the font provided by OOo for the user interface, select this checkbox.
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Menu – Show icons in menus

Select this option if you want icons as well as words to be visible in menus.

Font Lists - Show preview of fonts

When you select this option, the font list looks like Figure 4, Left, with the font names shown 
as an example of the font; with the checkbox deselected, the font list shows only the font 
names, not their formatting (Figure 4, Right). The fonts you will see listed are those that are 
installed on your system.

Figure 4. (Left) Font list showing preview; (Right) Font list without preview

Font Lists - Show font history

When you select this option, the last five fonts you have assigned to the current document are 
displayed at the top of the font list.

3D view – Use OpenGL

Specifies that all 3D graphics from OpenOffice.org Draw and OpenOffice.org Impress will be 
displayed in your system using OpenGL-capable hardware. If your system does not have 
OpenGL-capable hardware, this setting will be ignored.

3D view – Use OpenGL – Optimized output

Select this option for optimized OpenGL output. Disable the optimization in case of graphical 
errors of 3D output.

3D view – Use dithering

The Use dithering option uses dithering to display more colors with few colors available. 
Dithering creates the illusion of new colors and shades by varying the pattern of color pixels. 
Varying the patterns of black and white dots, for instance, produces different shades of gray.

Note Internally, 3-D graphics are always created with 16 million colors (24-bit color 
depth). They are used to dither portrayals with fewer colors. Without dithering, 
several bits of color information are omitted, making the grading distinctly visible. 
The fewer colors available, the poorer the quality.

Setting up Writer 5
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3D view – Object refresh during interaction

Specifies that if you rotate or move a 3-D object, the full display is rotated or moved and not 
a grid frame.

TIP Press Shift+Ctrl+R to restore or refresh the view of the current document.

Mouse positioning

Specifies if and how the mouse pointer will be positioned in newly opened dialog boxes.

Middle mouse button

Defines the function of the middle mouse button.

• Automatic scrolling – dragging while pressing the middle mouse button shifts the 
view.

• Paste clipboard – pressing the middle mouse button inserts the contents of the 
“Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit > 
Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard” 
can contain different contents at the same time.

Function Clipboard Selection clipboard 

Copy content Edit > Copy Ctrl+C Select text, table, or object.

Paste content Edit > Paste Ctrl+V pastes 
at the cursor position.

Clicking the middle mouse button 
pastes at the mouse pointer position.

Pasting into another 
document

No effect on the clipboard 
contents.

The last marked selection is the 
content of the selection clipboard.
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Print options
Set the print options to suit your default printer and your most common printing method. You 
can change these settings at any time, either through this dialog box or during the printing 
process (by clicking the Options button on the Print dialog box).

1) In the Options dialog box, click OpenOffice.org > Print.

2) On the OpenOffice.org – Print page (Figure 5), look at the Printer warnings section 
near the bottom.

3) Here you can choose whether to be warned if the paper size or orientation specified in 
your document does not match the paper size or orientation available for your printer. 
Having these warnings turned on can be quite helpful, particularly if you work with 
documents produced by people in other countries where the standard paper size is 
different from yours.

Figure 5. Choosing general printing options to apply to all OOo components

Tip If your printouts are coming out incorrectly placed on the page or chopped off at the 
top, bottom, or sides or the printer is refusing to print, the most likely cause is page- 
size incompatibility.
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Appearance options
Writing, editing, and page layout are often easier to do when you can see as much as possible 
of what's going on in your document. You may wish to make visible such items as text, table, 
and section boundaries, and grid lines (see “Grid options” on page 12). In addition, you might 
prefer different colors (from OOo’s defaults) for such items as note indicators or field 
shadings.

On the OpenOffice.org – Appearance page (Figure 6), you can specify which items are 
visible and the colors used to display various items.

1) In the Options dialog box, click OpenOffice.org > Appearance.

2) To show or hide items such as text boundaries, select or deselect the checkboxes next 
to the names of the items.

3) To change the default colors for items, click the down-arrow in the Color setting 
column by the name of the item and select a color from the pop-up box.

4) To save your color changes as a color scheme, type a name in the Scheme box and 
click Save.

Figure 6. Showing or hiding text, object, and table boundaries
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Choosing options for Writer

Settings chosen on the pages in the OpenOffice.org Writer section of the Options dialog box 
determine how your Writer documents look and behave while you are working on them.

1) If the Options dialog box is not already open, click Tools > Options.

2) Click the + sign by OpenOffice.org Writer in the left-hand section of the Options – 
OpenOffice.org dialog box. A list of subsections drops down.

General options
The choices on the OpenOffice.org Writer – General page affect the updating of links and 
fields, the units used for rulers and other measurements, whether captions are automatically 
added to selected objects such as tables or figures, paragraph spacing, and tab stop behavior.

1) Choose OpenOffice.org Writer > General on the Options dialog box (Figure 7).

2) Keep in mind the following considerations when selecting options on this page.

Figure 7. Choosing general options for Writer

Update links when loading

Depending on your work patterns, you may not want links to be updated when you load a 
document. For example, if your file links to other files on a network, you won’t want those 
links to update when you are not connected to the network.
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Update fields and charts automatically

You may not want fields or charts to update automatically when you are working, because 
that slows down performance.

Settings – Tab stops

The Tab stops setting is also used for the indent distance applied by the Increase Indent and 
Decrease Indent buttons on the Formatting Bar.

View options
Two pages of options set the defaults for viewing Writer documents: View and Formatting 
Aids (described on page 11).

Choose OpenOffice.org Writer > View on the Options dialog box (Figure 8).

If the items on this page are not self-explanatory, you can easily test their effects in a blank 
document.

This is a good page to check if, for example, you cannot see graphics on the screen or you see 
field codes instead of the text or numbers you are expecting.

Figure 8. Choosing View options for Writer
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Formatting Aids options
The display of symbols such as paragraph ends and tabs help you when writing, editing, and 
doing page layout. For example, you might want to know if any blank paragraphs or tabs are 
included or if any tables or graphics are too wide and intrude into the margins of the page.

On the OpenOffice.org Writer – Formatting Aids page (Figure 9), select the required 
checkboxes.

Figure 9. Choosing Formatting Aids options

Note Direct cursor lets you enter text, images, tables, frames, and other objects in any 
blank area in your document. OOo inserts blank paragraphs and tabs to position the 
text or objects.

This feature is incompatible with rigorous use of styles and can lead to many 
formatting oddities, so it should be avoided by professional writers.

The AutoCorrect tool automatically removes empty paragraphs, tabs, and spaces 
that are inserted by the direct cursor. If you want to use the direct cursor, then 
disable the AutoCorrect tool.
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Grid options
Specifying “snap to grid” can be very helpful when you are trying to align several objects 
such as graphics or tables. If the grid intervals (subdivisions) are too large, you may find that 
you do not have enough control in placing the objects.

On the OpenOffice.org Writer – Grid page (Figure 10), you can choose whether to enable this 
feature and what grid intervals to use.

Figure 10. Choosing Grid options
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Default fonts
The default fonts specified on the OpenOffice.org Writer – Basic Fonts (Western) page apply 
to both Writer documents and HTML (Web) documents.

1) If you want to change the defaults, do so on the OpenOffice.org Writer – Basic Fonts 
(Western) page (Figure 11). You can, of course, choose other fonts for use in specific 
documents, either by applying direct formatting or by defining and applying styles in 
those documents.

2) When choosing fonts on this page, you are not limited to single fonts or to the ones 
shown in the drop-down list. You can specify a “font family”as a set of fonts that 
includes those suitable for Windows, Macintosh, Linux, and other operating systems. 
These choices are particularly important in HTML documents.

3) If the document is viewed on a system that does not have the first font specified, it will 
use one of the other fonts if that one is available. Otherwise, it will substitute a font 
that is available on the system.

4) Type the list of fonts, separated by commas, in the boxes. If you want these defaults to 
apply to the current document only, select that checkbox. The Default button resets the 
values on this page to the defaults installed with OpenOffice.org.

Figure 11. Choosing default fonts
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Print options
On the OpenOffice.org Writer – Print page (Figure 12), you can choose which items are 
printed with the document by default. These options are in addition to those on the 
OpenOffice.org – Print page (Figure 5).

Some considerations:

• When you are working on drafts and you want to save printer ink or toner, you might 
want to deselect some of the items in the Contents section.

• The Print black selection causes color text (but not graphics) to print as black on a 
color printer; on a black-and-white printer, this option causes color text to print as 
solid black instead of shades of gray (dithered).

• Contrast Print black with Convert colors to grayscale on the Options – 
OpenOffice.org – Print page (Figure 5),which prints all graphics as grayscale on color 
printers. (On black-and-white printers, color in graphics normally prints as grayscale.)

• If you are printing double-sided on a non-duplexing printer, you might choose to print 
only left or right pages, then turn the stack over and print the other pages.

• Depending on how your printer ejects pages (face up or face down), you might need to 
print the pages in reverse order so they stack in the correct order as they are printed.

TIP You can override any of these defaults when printing a document. Click File > 
Print, then click the Options button on the Print dialog box. The Printer Options 
dialog box that appears is similar to the one shown in Figure 12.

Figure 12. Choosing Print options for Writer
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Default table options
On the OpenOffice.org Writer – Table page (Figure 13), you can specify the default table 
behavior.

Some considerations:

• If most of your tables will require borders or headings, select those checkboxes. If 
most of your tables are used for page layout, deselect borders and headings.

• Number recognition can be very useful if most of your tables contain numerical data; 
Writer will recognize dates or currency, for example, and format the numbers 
appropriately. However, if you want the numbers to remain as ordinary text, this 
feature can be quite irritating, so you’ll want to deselect it.

• The Keyboard handling section specifies the distances that cells move when you use 
keyboard shortcuts to move them and the size of rows and columns inserted using 
keyboard shortcuts.

• The choices in the Behavior of rows/columns section determine the effects that 
changes to rows or columns have on adjacent rows or columns and the entire table. 
You might need to test these selections to fully understand the effects.

Figure 13. Choosing default Table options
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Change tracking options
If you plan to use the change-tracking feature of Writer, use the OpenOffice.org Writer – 
Changes page (Figure 14) to choose the way inserted and deleted material is marked, whether 
and how attribute changes are marked, and whether and how change bars are marked in the 
margins.

Figure 14. Choosing options for tracking changes

Compatibility options
Do you need to import Microsoft Word documents into OOo Writer? If so, you might want to 
select some or all of the settings on the OpenOffice.org Writer – Compatibility page (Figure
15). If you’re not sure about the effects of these settings, leave them as the defaults provided 
by OOo. For information about the settings not described below, see the Help.

Use printer metrics for document formatting

If this checkbox is selected, the printer specified for the document determines how the 
document is formatted for viewing on screen. The line breaks and paragraph breaks you see 
on screen match those that apply when the document is printed on that printer.

This setting can be useful when several people are reviewing a document that will eventually 
be printed on a specific printer or when the document is exported to PDF (a process that uses 
“Adobe PDF” as the printer).

If this checkbox is not selected, a printer-independent layout will be used for screen display 
and printing.
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Figure 15. Choosing compatibility options

Add spacing between paragraphs and tables (in current document)

In OpenOffice.org Writer, paragraph spacing is defined differently than it is in MS Word 
documents. If you have defined spacing between two paragraphs or tables, spacing is also 
added in the corresponding MS Word documents.

If this checkbox is selected, MS Word-compatible spacing is added between paragraphs and 
tables in OpenOffice.org Writer documents.

Add paragraph and table spacing at tops of pages (in current 
document)

You can define paragraphs to have space appear before (above) them. If this checkbox is 
selected, any space above a paragraph will also appear if the paragraph is at the beginning of 
a page or column, if the paragraph is positioned on the first page of the document, or after a 
manual page break.

If you import an MS Word document, the spaces are automatically added during the 
conversion.

Add paragraph and table spacing at bottom of table cells

Specifies that the bottom spacing is added to a paragraph, even when it is the last paragraph 
in a table cell.

Use as Default button

Click this button to use the current settings on this page as the default in OpenOffice.org.
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AutoCaption options
Do you want OOo to automatically insert captions for tables, pictures, frames, and OLE 
objects that have been inserted in a Writer document?

Note You may not always want captions for every table, for example, if you use tables for 
layout as well as for tables of data. You can always add captions to individual 
tables, graphics, or other objects (right-click > Caption).

If you do want automatic captions on one or more object types:

1) Choose OpenOffice.org Writer > AutoCaption on the Options dialog box.

2) On the OpenOffice.org Writer – AutoCaption page (Figure 16), select the checkbox 
next to an object you want to be automatically captioned (Picture in the example 
shown).

Figure 16. Setting up a new category for automatic captions on graphics

3) With the item highlighted, specify the characteristics of the caption. The supplied 
categories for captions are Drawing, Illustration, Table, and Text. However, you are 
not limited to the supplied categories. If you want to use another name (for example, 
Figure) for the caption label, type the required term in the box. In the example shown, 
I have added the category “Figure” to the list.

For more information about numbering captions by chapter, character styles, frame styles, 
and other items on the AutoCaption page, see other chapters in the Writer Guide.
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Mail Merge E-mail options
You can produce form letters using Writer and then use the mail merge function to 
personalize those letters and send them to a number of addresses taken from a data source, 
such as an address book. Mail merged documents can be printed and mailed, or you can send 
them by e-mail.

Use the Options – OpenOffice.org Writer – Mail Merge E-mail page (Figure 17) to set up the 
user and server information for sending form letters by e-mail. If you are not sure what 
information to put in any of the fields, consult your e-mail program or your Internet service 
provider.

Figure 17: Specifying settings for use when e-mailing mail-merged form letters
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Choosing language settings

You may need to do several things to set the language settings to what you want:

• Install the required dictionaries

• Change some locale and language settings

• Choose spelling options

Install the required dictionaries
OpenOffice.org 2.0 automatically installs several dictionaries with the program. To add other 
dictionaries, use File > Wizards > Install new dictionaries.

Change some locale and language settings
You can change some details of the locale and language settings that OOo uses for all 
documents or for specific documents.

1) In the Options dialog box, click Language Settings > Languages.

2) On the right-hand side of the Language Settings – Languages page (Figure 18), change 
the Locale setting, Default currency, and Default languages for documents as required. 
In the example, English (Australia) has been chosen as the locale, and the Australian 
dollar (AUD) for the currency. Although an English (Australia) dictionary exists, the 
English (UK) dictionary has been selected as the default language.

3) If you want the language (dictionary) setting to apply to the current document only, 
instead of being the default for all new documents, select the checkbox labeled For 
the current document only.

4) If necessary, select the checkboxes to enable support for Asian languages (Chinese, 
Japanese, Korean) and support for CTL (complex text layout) languages such as Hindi, 
Thai, Hebrew, and Arabic. If you choose either of these checkboxes, the next time you 
open this page, you will see some extra choices under Language Settings, as shown in 
Figure 19. These choices (Searching in Japanese, Asian Layout, and Complex Text 
Layout) are not discussed here.

5) Click OK to save your changes and close the dialog box.

Note If you need to use non-Western languages, and especially if you need to use more 
than one non-Western language in the same document, refer to the tutorial, “OOo in 
a Multi-Lingual Environment.”
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Figure 18. Choosing language options

Figure 19. Extra language setting choices when enhanced language support options are 
selected
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Choose spelling options
To choose the options for checking spelling:

1) In the Options dialog box, click Language Settings > Writing Aids.

2) In the Options section of the Language Settings – Writing Aids page (Figure 20), 
choose the settings that are useful for you. Some considerations:

• If you don’t want spelling checked while you type, deselect Check spelling as 
you type and select Do not mark errors. (To find the second item, scroll down in 
the Options list.)

• If you use a custom dictionary that includes words in all uppercase and words with 
numbers (for example, AS/400), select Check uppercase words and Check 
words with numbers.

• Check special regions includes headers, footers, frames, and tables when 
checking spelling.

• Here, you can also check which of the user-defined (custom) dictionaries are 
active, or you can add or remove dictionaries by clicking the New or Delete 
buttons.

Figure 20. Choosing languages, dictionaries, and options for checking spelling
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Controlling Writer’s AutoCorrect functions

Some people find some or all of the items in Writer’s AutoCorrect feature annoying because 
they change what you type when you don’t want it changed. Many people find some of the 
AutoCorrect functions quite helpful; if you do, then select the relevant checkboxes. But if 
you find unexplained changes appearing in your document, this is a good place to look to find 
the cause.

To open the AutoCorrect dialog box, click Tools > AutoCorrect/AutoFormat. (You need to 
have a document open for this menu item to appear.)

In Writer, this dialog box has five tabs, as shown in Figure 21.

Figure 21. The AutoCorrect dialog box in Writer, showing the five tabs and some of the 
choices on the Options tab
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