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Introduction

Introduction

This chapter describes how to save documents as web pages from Writer, Calc, Draw and
Impress. For more details about using Writer as a web page creator and editor, see the Writer
Guide.

Saving Writer documents as web pages

Writer’s HTML capabilities include saving existing documents in HTML format, creating
new documents as HTML and creating several different types of web pages using a wizard.

The easiest way to create HTML documents is to start with an existing Writer document. You
can view it as it will appear on a web page by using View > Web Layout.

Inserting hyperlinks

You can insert and modify links using the hyperlink dialog. Display the dialog by clicking the
Hyperlink icon & | on the Function Bar or Insert > Hyperlink. Writing or pasting a URL

into a document will (depending on AutoCorrect settings) automatically convert to
hyperlink.

To edit an existing link:

1) Either move the cursor into the link using the keyboard arrow keys, or toggle the
“HYP” to “SEL” in the Status Bar (by clicking on the letters HYP or SEL in the status
bar, as shown in Figure 1) and use the mouse to position the cursor.

100% | | INSRT || 5TD | | HyP | |*

HYP or SEL

Figure 1. Writer status bar

Note If the status bar says HYP and you left-click on a link, OOo will try to open the link
in your default web browser. It has to say SEL in the status bar for you to be able to
click and position the cursor.

2) Click Edit > Hyperlink. The Hyperlink dialog (Figure 2) opens.

3) From the Hyperlink dialog, you can choose the type of link, as well as specify the
link’s address, text and how it should be displayed (for example, in a new window).
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Saving Writer documents as web pages

Hyperlink
l Hyperlink type
- i) web I ETP ) Telnet
. X ©
Mzl & Mews
Copy
[
=] Further settings
= F E -
Drocurment il [ FOrm Text il
Text http:ffoonauthors, argf
S
= Marne
=1
Mew Document
[ Apply ] [ Close l [ Help l [ Back ]

Figure 2. Hyperlink dialog

To turn existing text into a link, highlight it, then open the Hyperlink dialog. Copy the text
into the Target field. Click Apply to insert the link into the document before closing the
dialog.

Note Cross references do not become hyperlinks in an HTML document.

Saving a document as a single web page

To save a document as a single web page (HTML format), select Save As from the File menu
and specify HTML Document as the file type.

Note Writer does not replace multiple spaces in the original document with the HTML
code for non-breaking spaces. If you want to have extra spaces in your HTML file or
web page, you need to insert non-breaking spaces in OOo. To do this, press
Control+Spacebar instead of just Spacebar.

Saving a document as a series of web pages

Writer can save a large document as a series of web pages (HTML files) with a table of
contents page. To do this:

1) Decide which headings in the document should start on a new page and make sure all
those headings have the same style (for example, Heading 1).

2) Select File > Send and click on Create HTML Document.

3) In the dialog (Figure 3), enter the file name to save the pages under. Also specify
which style indicates a new page (as decided in step 1).
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Saving Writer documents as web pages

4) Click Save to create the multi-page HTML document. (For those who may be
interested, the resulting HTML files conform to the HTML 4 Transitional.)

Mame and Path of the HTML Document
Save in: |_;I 001.5.100 testdocs ﬂ =% Ef-
-] ,Q webpage. html
My Recent
Documents
_ — D e —
Desktop
-
fely Mebwork,
Pl
A File: narme: |webpage2 ﬂ Save |
Save as type: | HTML Document ﬂ Cancel
Styles: |Heading 1 |
Dretault
Figure
Heading 1

Figure 3. Creating a series of web pages from one document

Creating web pages using a Wizard
00o0’s Web wizard allows you to create several types of standard web pages. To use it:

1) Select File > Wizards > Web Page. This wizard looks like Figure 4.

Web Wizard

Skeps Introduction

This Web “Wizard is ko aid vou in publishing documents on the Internet,

2. Docurnents It will conwert the documents so that they can be wiewed by & web browser, In addition, it
will generate a Table of Contents page with links for easy access to the documents. The
Web Wizard will also allows wou bo customize the design and layout of vour web site,

‘tou will be able to keep the documents wou have published on the web up-to-date and add
or remoyve documents at any time,

Choose settings for the Web Wizard

<default = M|

Figure 4. Web page wizard step 1
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Saving Writer documents as web pages

Note

settings is Default. Click Next.

If this is your first web page, the only option you will have for the Web Wizard

2) Choose or browse to the document you would like to format and add the 7itle,
Summary and Author information as shown in Figure 5. Click Next.

Web Wizard

Steps

1. Introduction

2, Documents

3. Main layout

4, Layout details

5. Style

6. ‘Web site information

7. Preview

Select the documents you want to publish

Wweh site content
0117iE5-CreatingWebPages. sxm

|

Rermove ]

T

Mext =

Export to File Farmat:
HTML M

Document information
Title:

Creating Web Pages
Summary:

Fields to edit:
Chapter Title Description
kab = Title

i“hanter SuhtitHe

Authar:

| lear Mefined

Cancel

Figure 5. Web page wizard step 2

3) Chose a layout for the web site by clicking on the layout boxes shown in Figure 6.

Click Next.

Web Wizard

Steps

1. Introduction

Z. Documents

3. Main layout

4, Layout details

5, Style

6. "Web site information

7. Preview

Choose a layout for the table of contents of your web site

Layauks:

Sirple

[ < Back ] [

Mext =

Cancel

Figure 6. Web page wizard step 3
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Saving Writer documents as web pages

4) Chose the information to be listed and the screen resolution, as shown in Figure 7.

Click Next.
Web Wizard
Steps Customize the selected layout
1. Introduction Include the Fallowing information for each document in the table of conkents:
2. Documents
. [ Fil= name [ File Format
3. Main layout Descripkion File Farmat icon
4 i [ authar [] Mumber of pages
) [] creation date Size in KB
5. Shyle [ Last change date
. Web site information
7. Preview Cptimize the layout for screen resolution:
) 640480
(%) 800x600
() 1024x768

[ < Back ] [ Mext =

Cancel

Figure 7. Web page wizard step 4

5) Select a style for the page. Use the drop-down list, shown in Figure 8, to choose
different styles and color combinations. You can browse to a background image and
icon set from the Gallery. Click Next.

Web Wizard

Steps

1.

Introduction

Select a style for the table of contents

Style: Waker

page

2. Documents Background image:

3. Main layout
Icon set:

4, Lavout details

<no background image = Choose, .,

<no icon sek = Choose, ..

II“ ﬂ

The icon set is used For presentations in HTML Farmat.

&, Web site information

7. Preview

Document
Creation Date
Last Change Date
Filenarme

[ < Back

J

Mext =

Cancel

Figure 8. Web page wizard step 5
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Saving Writer documents as web pages

6) Enter general information such as Title and HTML Metadata information, as shown in

Figure 9. Click Next.

Web Wizard

Steps Enter general information for your web site

1. Inkroduction Title: Test Website

2. Dacuments

3, Main lavout HTML Metadata
4, Layout details Description: Test Data
5. Style E-mail:

&, ‘Web site information
Copyright notice:

7. Preview
Created: 26jsfos |

Modified: 26jsfos |

(e [

Figure 9. Web page wizard step 6

7) Chose where to save the file and preview the page if you wish, as shown in Figure 10.

Web Wizard

Steps Yhere do you want to publish your web site?
1. Introduction Click 'Preview' bo see a preview in vour browser:
3. Main lavaouk Publish the new web site:

To a local Folder
C:hDocuments and SettingstJean Hollis Weberity Docurmentsi My Websites

4, Layout details
5, Style

[ ] To a ZIP archive
&, Web site information

7. Preview

Publishing wia FTP Prosxy is not supparted,

Save settings (recommended)
Save as: Wweb Wizard Settings1

dE

r— ———

Figure 10. Web page wizard step 7

To edit or view the document’s underlying HTML code, click View > HTML Source or click

the HTML Source icon on the Main toolbar.
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Saving Calc spreadsheets as web pages

Saving Calc spreadsheets as web pages

Calc can save files as HTML documents. As for Writer, use File > Save As and select HTML
Document, or File > Wizards > Web Page.

If the file contains more than one sheet, the additional sheets will follow one another in the
HTML file. Links to each sheet will be placed at the top of the document. Calc also allows
the insertion of links directly into the spreadsheet using the Hyperlink dialog.

Saving Impress presentations as web pages

You can export presentations as Macromedia Flash files: select File > Export and choose
Macromedia Flash for the file type.

You can also convert presentations into a series of web pages.
1) To begin, select File > Export and choose HTML Document as the file type.

2) Choose a location for the file, supply a name for the resulting HTML file, and click
Save. The HTML Export Wizard opens.

=

L

HTML Export

Assign design

3) Choose the design for all of the
pages, either from an existing
design or by creating a new one.

+ New design

If you have not previously saveda | -
design, the Existing Design |
choice is not available.

Select an existing design or create a new one

Cancel | | Next>> | Create |

4) Click Next to select the type of " i HTML Export R
web pages to create. E)\ E - @& \ » . I““{ !
. Standal’d HTML: one page fOI‘ Publication type Options
: . . : " Standard HTML format W Create title page
e,aCh Shde’ with naVlg,atlon @ Standard HTML with frames:
links to move from slide to ¢ Automatic
slide. Ll
. Aqtoma{ic: one page for eaf:h = [~ »a
slide, with each page set with | @V
the Refresh meta tag so a
browser automatically cycles Hep |  Cancl | <<Back |[ News» | creme |

from one page to the next.

- WebCast generates an ASP or Perl application to display the slides. Unfortunately
OOo has no direct support for PHP as yet.
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Saving Impress presentations as web pages

5) Decide how the images will be i HTML Export
saved (GIF or JPG) and what [ K e
resolution to use.

Save graphics as Monitor resolution
 GIF & Low resolution (640x480 pixels)
« JPG " Medium resolution (800x600 pixels)
75% | Quality " High resolution (1024x768 pixels)
Effects

[ Export sounds when slide advances

Help 1 Cancel << Back Create |

6) If Create title page was chosen in e AL £

step 4, supply the information for ‘ ?\ 1O/7 T3 o

it on the next page. The title

Information for the title page

contains an author name, e-mail Author [Vichel Pimauier
address and home page, along E-mail address Pooouoex@xoooufi
with any additional information o hameran: |

Additional information

you want to include.

Help 1 Cancel << Back | Next s> | Create |

7) Choose the navigation button 22 T )
style to use to move from one j\ I s LLL L
page to another. If you do not e s
choose any, OOo will create a @ Textonly
text navigator.

Help

Create |

8) Select the color scheme for the
web pages. Available schemes
include the document’s existing

Select color scheme

scheme, one based upon browser # Aoply color scheme from document
colors, and a completely user- Sl Sy
Use custom color scheme
defined scheme. You can save a — — ST
new scheme so that it will appear etk | Hyperiink
on the first page of the HTML e Lk Active link
export wizard. Visited Link Wil

Help 1 Cancel | << Back
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Saving Impress presentations as web pages

9) Click Create to generate the HTML files. On the export page, if you do not use the
default option, OOo will suggest several vector or bitmap formats.

Note The HTML and image files are placed in the same directory, so it is advisable to
create unique directories for each presentation.

Saving Draw documents as web pages

Exporting drawings from OpenOffice.org’s Draw application is similar to exporting a
presentation from Impress. Use File > Export and select HTML Document as the file type.

When using the wizard, you can choose to create the web page at any time by clicking the
Create button.
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