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What is Math?

What is Math?

Math is OpenOftice.org (O0O0)’s component for writing mathematical equations. It is most
commonly used as an equation editor for text documents, but it can also be used with other
types of documents or stand-alone. When used inside Writer, the equation is treated as an
object inside the text document.

Note The equation editor is for writing equations in symbolic form (as in equation 1). If
you want to evaluate a numeric value, see the Calc Guide.

(1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Selection window
appears. You will also see a small box (with a gray border) in your document, where the
formula will be displayed.

~][o] Ugsialzell - Ogangifies,oryg Wriiar [ [o](x]
File Edit View Format Tools Window Help
f-=cH=2 as B @ =,
Selection
M:M asb aea -F(::) >a
I (N4
_ )

+4 -4 4 F4a -da T

4 3

a+b a-b axb axb arb

a-b % azb a/b avb

asb

Figure 1. Equation Editor, Selection window, and location of resulting equation.

The equation editor uses a markup language to represent formulas. For example, %beta
creates the Greek character beta ( B ). This markup is designed to read similar to English

. . a
whenever possible. For example, a over b produces a fraction: 5
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Entering a formula

Entering a formula

There are three ways to enter a formula:
Select a symbol from the Selection window.
- Right-click on the equation editor and select the symbol from the context menu.
- Type markup in the equation editor.

The context menu and the Selection window insert the markup corresponding to a symbol.
Incidentally, this provides a convenient way to learn the OOoMath markup.

Note Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

The Selection window

The simplest method for entering a formula is the Selection window, shown in Figure 2.

|« [+ [SSSETECEOnT | x|
% asb aed Tl Za

a & () %

+4 -4 fa Fa -4

a-b axb axb asb
Symbols

a-b % azb a/b avb
ash

Figure 2. Symbols are divided into categories

The Selection window is divided into two main portions.
« The top shows the symbol categories. Click on these to change the list of symbols.

+ The bottom shows the symbols available in the current category.

TIP You can hide (or unhide) the Selection window with View > Selection.
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Entering a formula

Example 1: 5x4

For this example we will enter a simple formula: 5X4 On the Selection window:
1) Select the top-left button of the categories (top) section (Figure 3).
2) Click on the multiplication symbol (shown in Figure 3).

\Unary/binary operators\
/

BB A-ol-ki00 B
%{Sb ash -F(:) Sa

Multiplicatioﬂ

+04 -0 *a 3

axb arb

a-b % azb a/b avb

Figure 3. Unary/binary operators

When you select the multiplication symbol on the Selection window, two things happen:
 The equation editor shows the markup: <?> times <?>

+ The body of the document shows a gray box with the figure: XU

ST

A kA

4 3

<7 times <7 | -

4 3

Figure 4. The multiplication symbol

The “ <?> " symbols (Figure 4) are placeholders that you can replace by other text. The
equation will update automatically, and the result should resemble Figure 5.

15%4

A kA

4 3

5 times 4| -

-

4 3

Figure 5. Result of entering "5" and "4" next to the "times" operator
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Entering a formula

TIP To keep the equation from updating automatically, select View >AutoUpdate

display.

To update a formula manually, press 9 or select View > Update.

Right-click menu

Another way to access mathematical symbols is to right-click on the equation editor. This

produces a menu as shown in Figure 6.

5 times 4 =
— P +a
Relations 3 -a
Set Operations 3 +-a
Functions 3 -+a
Operators s
Attributes ' a-b
Brackets '  acdotb
Formats e —————
Others e
aaoverb
adivb
alb
acirc b

a wideslash b
a widebslash b

Figure 6. Right-click menu

Note The entries in this menu correspond exactly to those in the Selection window.
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Entering a formula

Markup

You can type the markup directly on the equation editor. For example, you can type “5 times
4” to obtain 5X4 . If you know the markup, this can be the fastest way to enter a formula.

TIP As a mnemonic, the formula markup resembles the way the formula reads in
English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command
a=b a=b Ja sqrt {a}
a’ a"2 a, an
f f(x)dx int f(x) dx Z a, suma n
a<b a<=b o0 infinity
axb a times b Xy x cdot y

Greek characters

Greek characters ( «, B,y ,0 , etc) are common in mathematical formulas. These characters
are not available in the selection box or the right-click menu. Fortunately, the markup for
Greek characters is simple: Type a % sign followed the name of the character, in English.

- To type a lowercase character, write the name of the character in lowercase.
- To type an uppercase character, write the name of the character in uppercase.

See the table below for some examples:

Lowercase Uppercase

%l pha —» « YALPHA — 4
Y%beta — B YBETA — B
‘Ygamma — vy YGAMWA — T
Ypsi - Y %S| = 4
%phi - ¢ %PHI - @
% heta —» 0 YIHETA — O
Note A complete table of Greek characters is included in the chapter titled “Math

Objects” in the Writer Guide..
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Entering a formula

Another way to enter Greek characters is by using the catalog window. Go to Tools >
Catalog. The catalog window is shown in Figure 7. Under “Symbol Set” select “Greek” and
double-click on a Greek letter from the list.

[~][+] By bol5] B
Symbol set Insert
Greek =

Close

A B X AEHTD I K A *
MNQO®IDV PXET Edit...
oy = zs x 5 ¢ g

Ltk A pov o wo ¢
g op or 0 v o @ w@p
¢ £

alpha

Figure 7. Catalog - used for entering Greek characters

Example 2: ™ =~ 3.14159

For this example we will suppose that:
- We want to enter the above formula (the value of pi rounded to 5 decimal places).
«  We know the name of the Greek character (“pi”).
But we do not know the markup associated with the =~ symbol.
Step 1: Type “%” followed by the text “pi”. This displays the Greek character 7t .

Step 2: Open the Selection window (View > Selection).

Step 3: The = symbol is a relation, so we click on the relations button asb 1f you hover the
mouse over this button you see the tooltip “Relations” (Figure 8).

BB su=-i00 B
%aeA £t Sa
- =] a A

aAa a = 4

+04 -4 X4 F4a -d

a+b a-b axb axb aab
a-b % azb a/b avb
aob

Figure 8. Tooltip indicates the "Relations" button.

Step 4: Delete the <?> text and add “3.14159” at the end of the equation. Hence we end up
with the markup “ %pi si meq 3. 14159 ”. The result is shown in Figure 9.
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Entering a formula

{m=314150-

AR

4 F

2epi simeq 3.14159] -

4 4

Figure 9. Final result

Customizations

Formula editor as a floating window

As seen in Figure 1, the formula editor can cover a large part of the Writer window. To turn
the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 10.

2) Hold down the Control key and double-click.

=mc™2

Figure 10. Hold down the Control key and double-click on the border of
the math editor to turn it into a floating window.

Figure 11 shows the result. You can make the floating window back into an embedded frame,
using the same steps. Hold down the Control key and double-click the window frame.

u Seppriatiziniels E B

=mc"2 -

Figure 11. Equation editor as a floating window
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Customizations

How can | make a formula bigger?

This is one of the most common questions people ask about OOoMath. The answer is simple,
but not intuitive:

1) Start the formula editor and go to Fonts > Font size.

(~|[o][+] L PrOUESU PENUITICEROT G WIITETS HEER
File Edit Wiew | Format | Tools Window Help
B - = = Fonts... 5 - @ . "’
—| Font Size... I =
LZ"'IL"EILI 7-08:9-.10 11+ 12
—————— Spacing...
. . . Alignment...
ar=3.14150«
. . . Text Mode
)
4 L3
vapl simeq 3.14159 -
4 »

Figure 12. Changing the font size for a formula

2) Select a larger font size under “Base Size” (top-most entry), as shown in Figure 13.

[v][+] FORIGIonE x]

Base size hept = oK

Relative sizes e
L=t 100% -
Indexes 60% = Default
Functions 100% =
Operators 100% s
Limits 60% =

Figure 13. Edit "Base size" (top) to make a formula bigger.

The result of this change is illustrated in Figure 14.

Before: m=2314159

After: m=3.14159

Figure 14. Result of changing the base font size.

Getting Started with Math 8



Formula layout

Formula layout

The most difficult part of using OOoMath comes when writing complicated equations. This
section provides some advice about writing complex formulas.

Brackets are your friends

OOoMath knows nothing about order of operation. You must use brackets to state order of
operations explicitly. Consider the following example:

Result

2 over Xx + 1 2

2 over {x + 1}

Equations over more than one line

x=3

Suppose you want to type an equation covering more than one line. For example: y=1

Your first reaction would be to simply press the Enter key. However, if you press the Enter
key, though the markup goes to a new line, the resulting equation does not. You must type the
newline command explicitly. This is illustrated in the table below.

Result

3 new i ne
y =1

X
1
Il
—_

‘ﬁk
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Common problem areas

Common problem areas

How do | add limits to my sum/integral?

The “sum” and “int” commands can (optionally) take in the parameters “from” and “to”.
These are used for lower and upper limits respectively. These parameters can be used singly

or together.

Markup ‘ Result
sumfromk =1 to n a_ k n
Z Ay
k=1
int fromO to x f(t) dt j‘
f2)dt
0
int fromRe f ff
SR
sumto infinity 2°{-n} i _
2 n
Note For more details on integrals and sums, see “Math Objects” in the Writer Guide.

Brackets with matrices look ugly!

For background, we start with an overview of the matrix command:

matrix { a # b ## c # d } a b
c d
Note Rows are separated by two #’s and entries within each row are separated by one #.

The first problem people have with matrices is that brackets do not “scale” with the matrix:

Result

( matrix { a# b ##t c #d} ) a b
)
c d

OOoMath provides ‘“scalable” brackets. That is, the brackets grow in size to match the size of
their contents. Use the commands /eft( and right) to make scalable brackets.

10
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Common problem areas

left( matrix { a# b ## c # d } right) (a b)

TIP Use /left[ and right] to obtain square brackets.

How do | make a derivative?
Making derivatives essentially comes down to one trick: 7el/l OQo it’s a fraction.

In other words, you have to use the “over” command. Combine this with either the letter “d”
(for a total derivative) or the “partial” command (for a partial derivative) to achieve the effect
of a derivative.

Markup Result

{df} over {dx} df
dx
{partial f} over {partial y} of
oy
{partial~2 f} over {partial t~2} 6‘2f
ot

Note Notice that we had to use squiggly brackets to make the derivative.

Numbering equations

Equation numbering is one of OOoMath’s best hidden features. The steps are simple, but
obscure:

1) Start a new line.
2) Type “fn” and then press F3.

The “fn” is replaced by a numbered formula:

E=mc’ )
Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta
function:
0 1 3
clz)=3 ®
n=1
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Common problem areas

You can reference an equation (“as shown in Equation (2)’) with these steps:
1) Insert > Cross-reference..
2) Click on the References tab (Figure 15).
3) Under Type, select Text.
4) Under Selection, pick the equation number.
5) Under Format, choose Reference.

6) Click Insert.

Done! If you later add more equations to the paper before the referenced equation, all the
equations will automatically renumber and the cross-references will update.

] Ridlels B
Document References Functions | Docinformation | Variables | Database
Type Selection Format
Set Reference (1 Page
Insert Reference (2 Chapter
Text Reference
Bookmarks Above/Below
As Page Style

Category and Number
Caption Text
Numbering

Insert Close Help

Figure 15. Inserting a cross-reference to an equation number.

TIP To insert the equation number without parenthesis around it, choose Numbering
under Format instead of Reference.
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