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Introduction

Introduction

A data source, or database, is a collection of information which can be accessed or managed 
by OpenOffice.org (OOo). For example, a list of names and addresses is a data source which 
could be used for producing a mail merge letter. A shop stock list could be a data source 
managed through OOo.

Note OpenOffice.org uses the terms “Data Source” and “Database” to refer to the same 
thing, which could be a database such as MySQL or dBase or a spreadsheet or text 
document holding data.

This chapter is an introduction to the use of data sources. For further information, see the 
Database Guide.

This chapter covers creating a database, showing what is contained in a database and how the 
different parts are used by OOo. It also covers using the Base component of OOo to register 
other data sources. A data source can be a database, spreadsheet or text document. 

Caution

   

The database in OOo requires Sun’s Java Runtime Environment (JRE). If you do 
not have it on your computer, download it from www.java.com and install it 
following the instructions on the site. It should be Java 5.0 or higher. In OOo, use 
Tools > Options > OpenOffice.org > Java to register Java.

Creating a database

In this example, we are going to step through the creation of a new database. This database 
will contain two address books: one for acquaintances and one for relatives and two 
information sections: one for acquaintances and one for relatives.

Creating a new database

Figure 1: Creating a new database

To create a new database, click the New icon. In the drop-down menu select Database 
(Figure 1). This opens the Database Wizard. You may also open the Database Wizard using 
File > New > Database.
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Creating a database

The first step of the Database Wizard has one question with two choices: Create a new 
database or Connect to an existing database. For this example, select Create a new 
database and then click Next.

The second step has two questions with two choices each. The default choice for the first 
question is Yes, register the database for me and the default choice for the second question 
is Open the database for editing. Make sure these choices are selected and click Finish. 

Note If the database is not registered, it will not be accessible to the other OOo 
components such as Writer and Calc. If the database is registered, other components 
can access it. 

Save the new database with the name Information. This opens the Information – 
OpenOffice.org Base window. 

TIP Every time the Information database is opened, the Information –  OpenOffice.org 
Base window opens. Changes can then be made to the database. 

Creating database tables

Note In a database, a table is where information about one group of things is stored. For 
example, a table might hold an address book, a stock list, a phone book or a price 
list. A database can have from one to several tables.

When the Information – OpenOffice.org Base window opens, Forms is highlighted. Click on 
Tables to highlight it, as shown in Figure 2. We will create the Acquaintance Addresses table 
using the Table Wizard, and the Acquaintance Information table using the Design Mode 
method. We will create the Relatives Addresses and Information tables by copying and 
pasting.

Similarly, both Information tables have several fields containing the months of the year in 
them. By making a table for the months of the year, we can make our work easier when we 
enter data into each form. This will be obvious after we have created the forms. (This table is 
only a source for the list to be inserted into the two Information forms we will create, so we 
do not need to create additional forms.)

Figure 2: Creating tables
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Creating a database

Using the Wizard to create a table 

Caution

   

Every table requires a Primary key field. (What this field does will be explained 
later.) We will use this field to number our entries and want that number to 
automatically increase as we add each entry. 

First table to be created: an address book for acquaintances.

Click Use Wizard to Create Table. This opens the Table Wizard. 

Note A field in a table is one bit of information. For example, in a price list table, there 
might be one field for item name, one for the description and a third for the price. 
More fields may be added as needed.

Step 1: Select fields.

You have a choice of two categories of suggested tables: Business and Personal. Each 
category contains its own suggested tables from which to choose. Each table has a list of 
available fields. We will use the Addresses table in the Personal category to select the fields 
we need.

1) Category: Select Personal. The Sample Tables 
drop down list changes to a list of personal 
sample tables.

2) Sample Tables: Select Addresses. The Available 
fields window changes to a list of available fields 
for this table.

3) Selected Fields: Using the > button, move these 
fields from the Available fields window to the 
Selected fields window in this order: AddressID, 
FirstName, LastName, SpouseName, Address,  
City, StateOrProvince, PostalCode, 
CountryOrRegion, PhoneNumber,  
MobileNumber (cell phone), and EmailAddress.

4) If a mistake is made in the order as listed above, 
click on the field name that is in the wrong order 
to highlight it. Use the Up or Down arrow on the 
right side of the Selected Fields list (see Figure 3) 
to move the field name to the correct position. 
Click Next.

Caution

   

Below the Selected Fields list are two buttons: one with a +, and one with a –. 
These buttons are used to add or to remove fields from the Selected Fields list. Be 
careful when using these buttons until well acquainted with how to create tables 
(Figure 3).
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Creating a database

Step 2: Set field types and formats.

In this step you give the fields their properties. As each field is selected, the information on 
the right changes. You can then make changes to meet your needs. (See Figure 4.)

Figure 4: Changing field types

Note If any of these fields requires an entry, set Entry required to Yes. If Entry required is 
set to Yes, this field must have something in it. For example if FirstName has Entry  
required set to Yes, having an entry with the first name missing will not be allowed. 
In general, only set Entry required to Yes if something must always be put in that 
field. By default, Entry required is set to No.

• AddressID: Change AutoValue from No to Yes.

• FirstName: 

• Entry required: If a FirstName will be entered for every person, change Entry 
required to Yes. Otherwise, leave Entry required as No.

• Length: The length must be at least as large as the number of characters in the 
longest name in your list. If you are not sure what this value should be, look at 
the longest name you have and count the number of letters in the name. Add 5 
to that number in case a name added later might be longer. For example, if the 
longest first name you have has 12 letters, use the value 17. (Suggestion: since 
most first names are shorter than 20 letters, you could use 20 as the value. 
Unless you know some people with long first names, this value should be 
sufficient.)

Note In Base the maximum length of each field must be specified on creation. It is not 
easy to change this later, so if in doubt specify a greater length.

• LastName: Length=20 should be sufficient.

• SpouseName: Length=20 should be sufficient. Entry required should be No. (Not 
everyone has a spouse.)

4



Creating a database

• Address: Change Length to 50 unless someone’s address is longer. In such cases, 
adjust Length accordingly.

• City: Length=20 should be sufficient.

• StateOrProvince: Length for this depends upon your location. In USA, 2 is 
sufficient. Select the number which is appropriate for the addresses of the people 
in your list.

• PostalCode: Length should match your local area and preferences. Even in the 
USA, some use only five digits  (#####) and others use nine (#####-####). These 
require a Length of 5 and 10 respectively. 

• CountryOrRegion: Entry required should be No. Use the Length that is appropriate 
for you.

• PhoneNumber: Entry required should be No. Adjust Length according to your 
needs. Make sure to count all the signs, spaces, parentheses, dashes, and digits. For 
example, (555) 333-2222 needs a Length of 14. If the phone number includes an 
extension, make sure you include the number of letters and digits in your Length.

• MobileNumber: Make the same adjustments as PhoneNumber. This could also be 
used for a pager number. In such cases, make sure to include enough space for all 
of the needed information.

• EmailAddress:  Since there are some long email addresses, change only Entry 
required to No. Some people may not have an email address.

When you have finished, click Next.

Note Each field also has a Field Type. In Base the field type must be specified. These types 
include text, integer, date and decimal. If the field is going to have general 
information in it (for example a name or a description) then you want to use text. If 
the field will always contain a number (for example a price) the type should be 
decimal or another appropriate numeric field. The wizard picks the right field type, so 
to get an idea of how this works, see what the wizard has chosen for different fields.

Step 3: Set primary key.

1) Create a  primary key should be checked. 

2) Select option Use an existing field as a primary key.

3) In Fieldname drop down list, select AddressID.

4) Check Auto value.

5) Click Next.
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Creating a database

Note A primary key uniquely identifies an item (or record) in the table. For example, you 
might know two people called “Randy Herring” or three people living at the same 
address and the database needs to distinguish between them.
The simplest method is to assign a unique number to each one: number the first 
person 1, the second 2 and so on. Each entry has one number and every number is 
different, so it is easy to say “record ID 172”. This is the option chosen here: 
AddressID has nothing to do with a real address; it is just a number assigned 
automatically by Base to each record.
There are more complex ways of doing this, all answering the question “How do I 
make sure that every single record in my database can be uniquely identified?”

Step 4: Create the table.

1) If desired, rename the table at this point. If you rename it, make the name meaningful 
to you. For this example, rename the table to Acquaintance Addresses. 

2) Leave the option Insert data immediately checked. 
3) Click Finish to complete the table wizard. Close the window created by the table 

wizard. You are now back to the main window of the database with the listing of the 
tables, queries, forms, and reports.

Creating a table by copying an existing table

Now create a second table which will be the address book for relatives. Since the Relative 
Addresses table is similar to the Acquaintance Addresses table, we will create it by making a 
copy of the Acquaintance Addresses table and modifying it.

1) Click on the Tables icon in the Database pane to see the existing tables.

2) Right-click on the Acquaintance Addresses table icon. Select Copy from the context 
menu. 

3) Move the mouse pointer below this table, right-click, and select Paste from the 
context menu. The Copy table window opens.

4) Change the table name to Relative Addresses and click Next.

5) Click the >> button to move all the Fields from the left window to the right window 
and click Next.

6) Since all the Fields already have the proper File Type formating, no changes should be 
needed. However, this is the time and place to make these changes if they are needed. 
(See Caution below for the reason why.)  Click Create. The new table is created.

Caution

   

Once tables have been created using the wizard, editing them is limited. The 
Primary key can not be changed in any way. It is possible to add new fields and 
remove fields. It is possible to change the field type when creating the field as well 
as later as long as it is not the primary key. Once data has been added to the 
database, deleting a field will also delete any data contained in that field. When 
creating a new table, it pays to create the fields with the correct names, length and 
format before data is added.
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Creating a database

Creating tables in Design View

Design View is a more advanced method for creating a new table. It allows you to directly 
enter information about each field in the table.

Note While the Field type and formatting are different in Design View, the concepts are 
the same as in the Wizard.

Both the Acquaintance Information and Relative Information tables will be created with this 
method. Both tables use the same fields: ID, FirstName, LastName, SpouseName, WedDateM 
(month married), WedDateD (date married), WedDateY (year married), HusBDM (his birth 
month), HusBDD (his birth date), HusBDY (year of his birth), WifeBDM (her birth month), 
WifeBDD (day of her birth), WifeBDY (year of her birth), Ch1 (oldest child), Ch1BDM 
(month of Ch1’s birth), Ch1BDD (day of Ch1’s birth), and Ch1BDY (year of Ch1’s birth). 

TIP For purposes of an example we are only using one child in the family. Additional 
fields can be created in the table for those having relatives and acquaintances with 
more than one child. Those additional fields need to be in the same order as I have 
them above. For example, for two children the added fields would be: Ch2, Ch2BDM, 
Ch2BDD, and Ch2BDY. 
If you prefer to have the day precede the month, as in 1 January instead of January 1, 
put each field containing the day before the corresponding field containing the month. 
For example, put WedDateD just before WedDateM and Ch1BDD just before 
Ch1BDM.

1) Click Create Table in Design View.

2) ID entries:

 a) Enter ID as the first Field Name.

 b)Select Integer[INTEGER] as the Field Type.

 c) Change the Field Properties in the bottom section.

• Change AutoValue from No to Yes (Figure 5).

Figure 5: Field Properties section (AutoValue)

 d)Set ID as the Primary key. 

• Right-click on the green triangle to the left of ID.

• Click Primary Key in the context menu. This places a key icon in front of  ID.
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Creating a database

Note The primary key serves only one purpose. Any name can be used for this field. It is 
not necessary to use ID as the name of the primary key field.

3) All other entries:

 a) Enter the next field name in the first column (Field Name column).

 b)Select the Field Type for each field.

• For field names ending with D or Y (for example, WedDateD or WedDateY), 
select Small Integer[SMALLINT].

• All other fields use the default setting (Text[VARCHAR].

 c) Select the Field Properties (Figure 6).

Figure 6: Field Properties section

• Change Entry required from No to Yes only for fields which will always have 
an entry.

• Change the Length to match the longest entry expected for the field. (20 should 
be sufficient for most name fields unless one of your names is longer.)

• For more detailed formating, click the Format example button (Figure 7).

Figure 7: Field Format options
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Creating a database

4) Repeat these steps for each field in the table.

To access additional formatting options, click the button to the right of the Format 
example panel (Format example button).

5) Description can be anything, or can be left blank. (Figure 8 is an example of this.)

6) To save and close the table, select File > Close. The suggested Table Name can be left 
as it is. Our example uses Acquaintance Information as its name.

The fourth table, Relative Information, can be created by following the same steps as when 
you created the Acquaintance Information table. Or, you can right-click on Acquaintance 
Information, and select Copy from the context menu. Right-click just below Relative 
Addresses, and select Paste from the context menu. Follow the directions on page 6.

Figure 8: Example of Description entries

Creating tables for the list box

When the same information can be used in several fields, design a table for each type of 
information. Each table will contain two fields: the information field, and ID in this order. 

1) Follow the directions in “Creating tables in Design View” on page 7. In the table we will 
create, the two fields can be name and ID. Make sure that the AutoValue is set to Yes for 
the ID field.  Also make sure to select the ID field as the primary key. (See Figure 9.)

2) Save the table using the name Months.

Figure 9: Table in Design View

Note: If you have several tables to create with the same fields, design one table and 
produce the other tables by cutting and pasting. (See “Creating a table by copying
an existing table” on page 6.) 

9



Creating a database

Adding data to the list table
List tables do not require a form. Instead, add their data directly to the table. In our example, 
add the months of the year in the name field of the Months table. The AutoValue selection of 
the AddressID field automatically adds consecutive numbers to this field.

We will use the abbreviations for the months of the year found in the Number Format for 
Dates: Jan., Feb., Mar., Apr., May, Jun., Jul., Aug., Sep., Oct., Nov., and Dec. as in Figure 10.

Figure 10: Available date formats

1) In the main database window, click on the Tables icon (Figure 11). Right-click on 
Months and select Open from the context menu.

2) Enter the name of the first month in the Name field. (Use 
abbreviations for the months.) Use the Down Arrow to move to 
the second row of the Name field. Enter the name of the second 
month. Continue until you have added all twelve months.

3) Save and close the table window.

Tip The Enter key can also be used to move from field entry  to field 
entry. For this example, enter Jan. in the first Name field. Enter 
moves the cursor to the ID field. Enter then moves the cursor to 
the second Name field.

Note The ID field contains <AutoField> until you use the Down 
Arrow to move to the second row. Then it becomes a 1. As you 
add the names of the months and move down another row, the 
rows of the ID field change to consecutive positive numbers.

Creating a database form
A form is a front end for data entry and editing. Instead of a list of records, a form can include 
additional text, graphics, selection boxes and many other elements.
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Creating a database

Using the Wizard to create forms

Click on Tables in the Database pane, as in Figure 11, then right-click Acquaintance 
Addresses in the Table section of the window and select Form Wizard from the context 
menu. (The same wizard can be accessed by clicking on Forms in the Database pane and 
selecting Use Wizard to Create Form.)

Step 1: Create the form.

1) Under Tables or queries select Acquaintance Addresses  from the drop-down list 
(Figure 12). This creates the fields in the Available Fields list.

2) Since these fields are already in the correct order, click >> to move all these fields 
to the Fields in the Form list. 

Tip The arrow buttons between the Available Fields and Fields in the Form lists move 
fields between these two windows. The up and down arrows on the right side of the 
Fields in the Form window move a selected field up or down.

Figure 12: Form Wizard

3) Click Next.

4) This form will not have any subform. Click Next.

5) Arrange Controls: Choices for Arrangement of the main form are from left to right: 
Columnar-Labels Left, Columnar-Labels Top, Data Sheet, and In Blocks-Labels  
Above. Select Columnar-Labels Top and then click Next.

6) Set Data Entry: Use the default selection: The form is to display all data. Click 
Next.

7) Apply Styles: The Apply styles window contains ten backgrounds. Select the one 
you desire. Suggestion: leave it Beige. Select the Field border also. Suggestion: 
3D look. Click Next.

11



Creating a database

Tip By moving the top of the Form Wizard window down enough to view the top of the 
form, you can see what a given style will look like by selecting it. Select as many as 
you want until you see the one that best suits you. This works for selecting the Field 
border also.

8) Set Name: Sometimes the Form Name should be different from the Table Name it 
is linked with. It is your choice. Suggestion: Acquaintance Addresses. Since 
modifications to this form will be made next, select Modify the Form under the 
question How do you want to proceed after creating the form? Click Finish.

Step 2: Modify the form.

Shorten and then move the fields. The final form contains four rows. Row 1 contains Address 
ID. Row 2 contains FirstName, LastName and SpouseName. Row 3 contains Address, City,  
StateOrProvince, PostalCode and CountryOrRegion. Row 4 contains PhoneNumber,  
MobileNumber and EmailAddress. Finally set the Tab order of the fields if necessary. 

Note When you click a field, it is selected. It has eight green squares (called 
handles)around it. Control+mouse click only the Field or its Label to select one but 
not both. Figure 13 shows the AddressID Field selected but not the AddressID 
Label.

Figure 13: Selected field

1) Control+click on the AddressID Field. Move the mouse pointer to the middle handle 
on the right side. It becomes Figure 14. Drag the handle to the left to shorten the field. 
Suggestion: Reduce the size of the field to the same length as the AddressID label.

Figure 14: Single arrow

2) Repeat the process for each of the other fields. Adjust the length of a field to what is 
reasonable for it. (For example, the StateOrProvince field can be shortened 
considerably while the Address field might need to remain as it is.) 

Note Control + click on the label of a field selects it. This allows changes to be made for 
it. (More details on this are found in the Design View Form creation section.)

3) To move a field and its label, click on it to select it. Move the mouse pointer inside the 
field or its label. The mouse arrow becomes Figure 15. Drag the selected area to the 
desired place in the form. 

12
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Figure 15: Double arrow

Note Hold down the left mouse button while dragging the selected area.

Caution

   

Do not use Control+click when moving a field. It moves either the field or the 
label but not both. To move both, use a mouse click and drag to the desired spot.

4) To change the background of the form, right-click on the background to open a context 
menu and choose Page > Background. Select Color from the As dropdown list. The 
color can be changed by clicking on the desired color. Suggestion: select Orange 4. 
Click OK.

5) By changing the As window from Color to Graphic, a graphic file can be used as the 
background. (Figure 16 uses flower.gif as its background.) 

 a) Click Cancel at the bottom of the Page style: Default window to close it.

 b)Use Tools > Options > OpenOffice.org > Paths > graphics to locate the folder 
containing flower.gif. (Write it down if necessary.)

 c) Reopen the Page Style: Default window. (Right-click one the page and select Page 
> Background from the context menu.)

 d)Select As > Graphic, and click the Browse button. 

• Browse to the folder containing flower.gif, and select it.

• Click Open, and then click OK in the Page Style: Default window.

6) The finished form should look something like Figure 16.

Figure 16: Addresses form
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7) If the words in the Labels of the form are too small, increase the font size. 

 a) Control+click on a label to select it.

 b)Right-click on the selected label. Select Control from the context menu.

 c) Click on the Font button to open the Font Character window (Figure 17). Here you 
can change the font, its size, typeface, and font effects (use the Font Effects tab for 
this last one). Make the changes you desire.

 d)Repeat a) through c) for the other labels.

 e) The fonts for the fields can be changed in the same way.

Figure 17: Changing Font characteristics

8) Check the tab order. The tab order should be correct, but we need to make sure.

 a) Click on the AddressID field to highlight it. 

 b)Click on the Activation Order icon in the Form toolbar. (See Figure 18.)

Figure 18: Form toolbar

 c) Make sure the order of the fields matches the listing in Figure 19. If a field in in 
the wrong place in the list, click on the field to highlight it.

• If it needs moving up, click the Move Up button to put it where you want it.

• If it needs moving down, click the Move Down button to put it where you 
want it.

• When you have the correct order, click OK closing the Tab Order Window.

9) The Acquaintance Addresses form is completed. Save and close the Acquaintance 
Addresses OpenOffice.org Writer window to return to the Information – 
OpenOffice.org Base window.

To create the Relative Addresses form, follow the same nine steps as you just did for the 
Acquaintance Addresses form.

14
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Figure 19: Order of fields

Caution

   

Do not use the copy and paste method to create new forms from already created 
ones.  When a form is created, a link is formed between it and the table for which 
it was created. Copying and pasting preserves this link to the original table. Each 
form created needs to be linked a separate table.

Creating forms in Design View

This method requires using the Database Controls and Database Form Design Toolbars 
extensively. These techniques are beyond the scope of this document. Instructions for 
creating forms using Design view will be described in the Database Guide.

Creating subforms

Again, this is beyond the scope of this document. Creation of subforms will be described in 
the Database Guide.

Creating a view of multiple tables
In the main database window (Information – OpenOffice.org Base), click on the Table icon to 
highlight it. In the Task section, there are three icons. The first two we have used to create 
tables. The third icon is labeled Create View. Clicking on this icon opens the View1 – 
OpenOffice.org View Design. While it has a different name, its functions and appearance are 
similar to when you create a query using the Design View.

Queries can be created from this window following the directions given in “Creating queries” 
on page 21. I advise reading the entire section on creating queries first.

15
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Creating a database

You can also create a table from this window which is a combination of the already created 
tables. Since the steps are the same as those used when creating a query in Design View, wait 
until you have read the entire section on creating queries.

To create such a table, follow the first three steps in “Using the Design View to create a
query” on page 25. At the end of step 3, a cross-reference returns you to this section. Save the 
table with a name of your choosing, and then close the window.

Accessing other data sources

OpenOffice.org allows data sources to be accessed and then linked into OOo documents. For 
example, a mail merge links an external document containing a list of names and addresses 
into a letter, with one copy of the letter being generated for each entry.

In OpenOffice.org 1.x, the option Tools > Data Sources allowed a new data source 
(or database) to be registered so any OOo component could use it. This option does 
not exist in OOo2.0. 
To register a data source in OOo2.0, select File > New > Database, select Connect 
to an existing database, and select the type of data source to connect to. The exact 
source can then be chosen in the wizard.

Once a data source has been registered, it can be used in any other OOo component (for 
example Writer or Calc) by selecting View > Data Sources or pressing the F4 key. 

New > Database opens the Database Wizard window. Select Connect to an existing 
database. This allows access to the list of data sources that can be registered with OOo. 
These data sources can be accessed similarly to a dBase database as explained in the next 
section.

Tip Mozilla Address Books and dBase databases (among others) can be accessed, and 
entries can be added or changed. Spreadsheets can be accessed, but no changes can 
be made in the spreadsheet entries.

Accessing a dBase database
1) File > New > Database  opens the Database Wizard window. 

Note Clicking the New icon and Database in the drop-down menu also open the 
Database Wizard window. (See Figure 1.)

2) Select Connect to an existing database. Pressing the TAB key highlights the 
Database type drop-down list. Typing D selects dBase. Click Next. 

Note Clicking the arrows opens a menu from which you can select dBase (Figure 20).
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Figure 20: Database type selection

3) Click Browse and select the folder containing the database. Click Next.

4) Accept the default settings: Register the database for me, and Open the database for 
editing. Click Finish. Name and save the database in the location of your choice.

5) Create the Form using the Form Wizard as explained in “Creating a database form” 
beginning on page 10.

Accessing a Mozilla address book
Accessing a Mozilla Address Book is very similar to accessing a dBase database. 

1) Select File > New > Database. 

2) Select Connect to an existing database. Select Mozilla Address Book as the database 
type (Figure 20).

3) Register this data source. 

These are steps 1, 2 and 4 of Accessing a dBase Database above.

Accessing spreadsheets
Accessing a spreadsheet is also very similar to accessing a dBase database. 

1) Select File > New > Database.

2) Select Connect to an existing database. Select Spreadsheet as the Database type 
(Figure 20).

3) Click Browse to locate the spreadsheet you want to access. If the spreadsheet is 
password protected, check the Password required box. Click Next.

4) If the spreadsheet requires a user’s name, enter it. If a password is also required, check 
its box. Click Next.

Registering databases created by OOo2.0
This is a simple procedure. Tools > Options > OpenOffice.org Base > Databases. Under 
Registered databases,there is a list of these databases. Below this list are three buttons: 
New..., Delete, Edit... To register a database created by OOo2.0:

1) Click New.

2) Browse to where the database is located.
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3) Make sure the registered name is correct. 

4) Click OK.

Using data sources in OpenOffice.org

Having registered the data source, whether a spreadsheet, text document, external database or 
other accepted data source, you can use it in other OpenOffice.org components including 
Writer and Calc.

Viewing data sources
Open a document in Writer or Calc. To view the data sources available, press F4 or select 
View > Data Sources from the pull-down menu. This brings up a list of registered databases, 
which will include Bibliography and any other database registered.

To view each database, click on the + to the left of the database’s name. (This has been done 
for the Information database in Figure 21.) This brings up Tables and Queries. Click on the + 
next to Tables to view the individual tables created. Now double-click on a table to see all the 
records held in it.

Figure 21: Databases

Editing data sources
Some data sources can be edited in the View Data Sources dialog. A spreadsheet can not. A 
record can be edited, added or deleted.

The data is displayed on the right side of the screen. Click in a field to edit the value. 

Beneath the records are five tiny buttons. The first four move backwards or forwards through 
the records, or to the beginning or end. The fifth button, with a small star, inserts a new 
record (Figure 22).

Figure 22: View Data Sources navigation buttons
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To delete a record, right-click on the gray box to the left of a row to highlight the entire row, 
and select Delete Rows to remove the selected row.

Launching Base to work on data sources
You can launch OOo Base at any time from the View Data Source pane. Just right-click on a 
database or the Tables or Queries icons and select Edit Database File. Once in Base, you can 
edit, add and delete tables, queries, forms and reports.

Using data sources in OOo documents
To insert a field from a table into a document (for example a Calc spreadsheet or Writer 
document), click on the field name (the gray square at the top of the field list) and, with the 
left mouse button held down, drag the field onto the document. In a Writer document, it will 
appear as <FIELD> (where FIELD is the name of the field you dragged). In Calc it will 
appear as a text box.

One common way to use a data source is to perform a mail merge. Selecting Tools > Mail 
Merge Wizard or clicking on the Mail Merge icon (a small paper-and-envelope icon on the 
View Data Source pane) launches the Mail Merge wizard which steps through creating a mail 
merge document. This is covered in the chapter titled “Using Mail Merge” in the Writer 
Guide.

Entering data in a form

Records are used to organize the data we enter into a form. Enter all the data concerning each 
person that you want to be a part of the database. When you press the Tab key after entering 
the data in the last field of the form for the first person, all the fields are cleared except 
possibly the AddressID field. You have just completed making the first record for the 
Acquaintance Addressees form of your database.  Each time you do this, you are adding 
another record. (For example, the record in Figure 23. If the cursor is in in the EmailAddress 
field, pressing the Tab key clears all of the fields in the form except for the AddressID field. 
The number in the box at the bottom left changes from the number 1 to the number 2.)

At the bottom left of the form is the word Record. After it is information as to which record is 
showing and how many records there are. In this case, record 1 of  3 records is showing. To 
the right of this are additional icons which allow you to move from one record to another (the 
arrows), add a new record, delete a record, plus more functions.

The purpose of a database is to store information in a way that can be accessed later when 
needed. This section describes how to enter your data so that it can be used later. You need to 
be in the Information – OpenOffice.org Base window. In our example we will be entering 
data in the Acquaintance Information form. Adding data to the other forms should be done 
the same way.
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Figure 23: Single Record 

If you do not want to use your own data to fill in the fields of this form, use the following 
information for five fictitious families. Each field entry is separated by a semi-colon (;). If the 
ID field contains <AutoField>, begin entering the data with in the FirstName field. 
Otherwise, enter the numbers in the ID field: the number 1 in the first record, the number 2 in 
the second record, and continue through the number 5 in the fifth record. (Not all records will 
all the fields filled in. For example, Sam & Alice do not have any children.)

1; Sam; Spade; Alice; Aug.; 22; 2000; Apr.; 1; 1980; May; 31; 1982

2; Billy; Appleseed; Ruth; Jul.; 4; 1996; Dec.; 25; 1974;  Jan.; 1; 1975; Chad; Feb.; 2; 1998

3; Junior; Salesman; Deloris; Jul.; 31; 1992; Apr.; 1; 1973; Sep.; 22; 1975; Samantha; Jan.; 5; 
1993

4; Jamie; Spencer; Alice;  Jan.; 1; 2004; Apr.; 22; 1985; Jun.; 15; 1985

5; Webster; Callahan; Betty; Nov.; 22; 1990; Aug.; 16; 1968; Dec.; 25; 1970; Ed; Jan.; 10; 
1991

1) If the Forms icon is not highlighted, select the Forms icon on the left, or use Alt+m. 
Double-click on the Acquaintance Information icon.

2) ID field:

• If <AutoField> is not present in the ID field, click inside this field and enter a 
number. (Suggestion: enter 1.) Then press the Tab key.

• If <AutoField> is present, click in the FirstName field.

3) For the rest of the fields in the form beginning with FirstName:

• If a field should be left empty, press the Tab key to move to the next field.

• Otherwise, enter the data and press the Tab key to move to the next field.
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• To move backwards through the fields, use the Shift+Tab combination.

• Pressing the Tab key in the last field enters all the data for that record (saves it) 
and begins the next record. (Shift+Tab while the cursor is in the first field of a 
record enters the data for that record (saves it) and moves the cursor to the last 
field of the previous record. This only works for record number 2 and above.)

4) When you have entered all the data you need, close the Acquaintance Information – 
OpenOffice.org Writer window.

Enter data in the Acquaintance Addresses form the same way. Note that the first three fields 
of this form are to be the same as in the Acquaintance Information form. Enter the other data 
as appropriate following the same steps as for the Acquaintance Information form. 

Creating queries

Queries are used to get specific information from a database. In our example database, a 
simple query could  create a list of all the wedding anniversaries in a given month. We will 
do this using a wizard. A more complex query could  create a list of all the birthdays in a 
given month. We will do this using the Design View. We will create a query searching the 
Acquaintance Addresses Information tables for all wedding anniversaries in July and the 
addresses of the couples for which this applies. This query will include the following 
information: FirstName, LastName, SpouseName, Address, City, StateOrProvince, 
PostalCode, CountryOrRegion, and the wedding date (month, day, and year). This way we 
can find out who has a wedding anniversary in July, what day of July it is, and the couple’s 
address so we can send them a card.

Note Queries blur the differences between a database and a data source. A database is 
only one type of data source. However, searching for usable information from a data 
source requires a query. Since the query, one part of a database, does this, the data 
source appears to become one part of that database: its table or tables. Query 
results, themselves, are special tables within the database.

Using the Wizard to create a query
Make sure you are in the Information – OpenOffice.org Base window. Click the Queries icon 
to highlight it. In the Task section of this window, double-click on the Use Wizard to create  
Query... icon. This opens the Query Wizard window (Figure 24).

Note When working with a query, more than one table can be used. Since different tables 
may contain the exact same field names, the format for naming fields in a query is 
Table name and field name. A period (.) is placed between the table name and the 
field name.  In our example, the table name is two words, so the period comes after 
the second word of the table name and before the field name. (For example, the 
FirstName field of the Acquaintance Addressees table is named Acquaintance 
Addressees.FirstName. The FirstName field of the Acquaintance Information table 
is named Acquaintance Information.FirstName.)
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Figure 24: First page of the Query Wizard

Step 1: Select the fields.

1) Since most of the information we want is in the Acquaintance Addresses, make 
sure this table is listed under Tables. All the fields of the Acquaintance Addresses 
table are listed in the Available fields window.

Using the arrow (>), move these Available fields over to the Fields in the Query 
window: Acquaintance Addresses.FirstName, Acquaintance Addresses.LastName, 
Acquaintance Addresses.SpouseName, Acquaintance Addresses.Address, 
Acquaintance Addresses.City, Acquaintance Addresses.StateOrProvince, 
Acquaintance Addresses.PostalCode, and Acquaintance 
Addresses.CountryOrRegion.

2) Change the Tables drop down entry from Acquaintance Addresses to Acquaintance 
Information.

Using the arrow (>), move these Available fields over to the Fields in the Query 
window: Acquaintance Information.WedDateM, Acquaintance 
Information.WedDateD, and Acquaintance Information.WedDateY. These three 
fields will appear below the Acquaintance Addresses.CountryOrRegion field.

3) Click Next.
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Step 2: Select the sorting order.

Up to four fields can be used to sort the information of our query. A little simple logic helps 
at this point. Which field is most important? I suggest listing the date of the month first 
(WedDateD). The LastName could come second. The FirstName or SpouseName could be 
the third field to sort by. You might want to sort them in a different way. Feel free to do so.

1) In the drop-down list under Sort by, select Acquaintance Information.WedDateD.

2) In the drop-down list under the first Then by, select Acquaintance 
Addresses.LastName.

3) In the drop-down list under the second Then by, select Acquaintance 
Addresses.FirstName.

4) Click Next.

Step 3: Select the search conditions.

1) Since we are only searching for information in one field, the default setting of 
Match all of the following will work. 

Note Match any of the following setting could be used in a query looking for all the 
birthdays in April for example. This will be done in the next section: Create a report 
using the Design View.

2) Select Acquaintance Information.WedDateM from the top Fields drop down list. 
Set the condition to is equal to. Enter 7 as the value. (July is the seventh month of 
the calendar year.) Click Next at the bottom of the window.

Step 4: Select type of query.

We want simple information, so the default setting: Detailed query is what we want. Click 
Next at the bottom of the window.

Note Since we have a simple query, the Grouping and Grouping conditions are not 
needed. Those two steps are skipped in our query.

Step 5: Assign aliases if desired.

We want the default settings. Click Next at the bottom of the window.

Step 6: Overview.

Name the query (suggestion: Query_Weddings). To the right of this are two choices. Select 
Modify Query. Click Finish.

Step 7: Modifying the query.

The Query_Weddings window opens. The tables used in our query are shown in Figure 25. 
We want to link these two tables so that they act as one.
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Figure 25: Tables used in Query

If the two tables are not linked, the first three columns look like Figure 26. All of the entries 
of the first table are listed.

Figure 26: Query results with unlinked tables

To link the two tables, click on the AddressID field of the Acquaintance Addressees table 
(Figure 25) and drag the mouse cursor over to the ID field of the Acquaintance Information 
table of Figure 25. A line will appear connecting the AddressID and ID fields. 

Once we have linked the two tables, we can run the query again. To do so, click the Run 
Query icon. (The one with the green check in Figure 27.) The first three columns of the result 
are in Figure 28. Two couples were married in July, and only these two are listed using the 
linked tables.

Figure 27: Run Query icon

Figure 28: Query results with linked tables

Note When editing a Query, you can change the size and position of the tables. 
Click+drag on the heading of the table to move it. Moving the mouse cursor to an 
edge cause the cursor to change to a double arrow; increase or decrease the size of 
the table the same way you increase or decrease the size of a window.
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Tip By editing the Query_Weddings we can get a list of the wedding anniversaries for 
any given month. In the Information – OpenOffice.org Base window, select Queries. 
Right click on the Query_Weddings icon and select Edit from the context menu. In 
the Query_Weddings window, replace the '7' with the number of  whatever month 
you want. (The 7 is in the Criterion row and WedDateM column.) Make sure to put 
an apostrophe before and after the number. Then rerun the Query. (Figure 27).
You can create a form for the Query_Weddings query. Right-click on the 
Query_Weddings icon, and select Form Wizard from the context menu. See 
“Creating a database form” on page 10 for directions.

Using the Design View to create a query
Creating a query using Design View is not as hard as it may first seem. For our query, we 
want to know who has a birthday in August. Go to the Task section of the Information – 
OpenOffice.org Base window. Select Create Query in Design View. The Query1 – 
OpenOffice.org Query Design and  Add Table windows open.

Step 1: Add tables.

1) Click on Acquaintance Addressees, and then click Add.

2) Click on Acquaintance Information, and then click Add.

3) Click Close.

This opens these two tables. (See Figure 25.)

Step 2: Link the two tables.

Click on AddressID in the Acquaintance Addresses table and drag the mouse cursor to Id in 
the Acquaintance Information table. A line segment now connects these two fields.

Step 3: Fill in the names of the fields of the query.

Double-click on the fields you want to use in the order you want to use them. Some of the 
fields will come from the Acquaintance Addressees table, and some of the fields will come 
from the Acquaintance Information table. If you accidentally put a field in the wrong order, 
click on the gray rectangle above that field and drag its entire column to the correct position.

1) From the Acquaintance Addressees table, double-click on these fields in this order: 
FirstName, LastName, SpouseName.

2) From the Acquaintance Information table, double-click on these fields in this 
order: HusBDM, HusBDD, HusBDD, WifeBDM, WifeBDD, WifeBDY, Ch1, 
Ch1BDM, Ch1BDD, and Ch1BDY.

3) From the Acquaintance Addressees table, double-click on these fields in this order: 
Address, City, StateOrProvince, PostalCode, CountryOrRegion.

Tip The above steps can also be used to create a single table from the fields of two or 
more tables. If this is what you are doing with these three steps, please now return 
to “Creating a view of multiple tables” on page 15. Otherwise ignore this tip.
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Step 4: Enter the criteria for the query.

We enter the information we will be searching for in the Criterion row of our query (Figure
29). How we place this information determines what our results will be. If we want two or 
more fields to have specific information in them at the same time, we enter all of this 
information in the Criterion row. This is referred to as the And condition. The sought for 
information is all placed in the Criterion row in the columns with the proper field names. 

In our example, we are looking for all families in which at least one of its members has a 
birthday in August. This is the Or condition. (The husband Or the wife Or the child was born 
in August.)

Note To fully use queries requires a knowledge of mathematics and specifically set 
operations (unions, intersections, complements, and any combinations of these). 

Figure 29: Query setup table

1) All entries in the Query setup table must be in this form: 'entry' (an apostrophe, the 
entry, and another apostrophe). 

2) Since August is the eighth month, an 8 will be entered in the fields. In Figure 29, 
the four rows below the Criterion row are labeled Or. When an entry exists in the 
Criterion row and another in the first Or row, a search is made for all record which 
fit either the information in the Criterion row or the Or row.

3) The fields we are concerned with are HusBDM, WifeBDM, and Ch1BDM.

• In the Criterion row and HusBDM column, enter '8' (apostrophe 8 apostrophe).

• In the first Or row and WifeBDM column enter '8'.

• In the second Or row and Ch1BDM column enter '8'. 

• The results should look somewhat like Figure 30. (The figure does not show 
the FirstName, LastName, and SpouseName fields. Your table will have these 
three fields between the column  containing the row names and the HusBDM 
column.) 
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Figure 30: Using the Or condition over three fields

4) Click the Run Query icon (Figure 27 on page 24).

5) Save the Query, name it Query_Birthdays and close the window.

Tip This query can be used for finding what people have birthdays in any given month. 
Change the 8’s to the number of a different month. Make sure that an apostrophe 
comes before and after the number.

Creating reports

Reports provide information found in the database in a useful way. In this they are similar to 
queries. Reports are generated from the database’s tables or queries. They can contain all of 
the fields of the table or query or just a selected group of fields. Reports can be static or 
dynamic in nature. Static reports contain the data in the selected fields at the time the report 
was created. Dynamic reports can be updated to show the latest data. 

We will create a dynamic report of the wedding anniversaries of a given month. The 
Query_Weddings query is the basis for our report: Monthly Wedding Anniversaries. Editing 
the query for the month we seek and saving the query changes updates the report at the same 
time.

Step 1: Access the report generating wizard in one of two ways. 

• Click on the Reports icon in the Information – OpenOffice.org Base window, and 
click on Use Wizard to Create Report.
or

• Right-click on a query or table and select Report Wizard in the context menu.

Step 2: The Report Wizard (Figure 31).

In the Tables or Queries drop down list, select Query: Query_Weddings.
• Use the double arrow (>>) to move all the fields from Available fields to Fields 

in report.
• Click Next.
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2) Change the labels for part of the fields.
• For labels containing more than one word, put a space between words. (For 

example, FirstName becomes First Name, LastName becomes Last Name, and 
CountryOrRegion becomes Country Or Region.)

• Change PostalCode to Postal Code, WedDateM to Month, WedDateD to Date, 
and WedDateY to Year.

• Click Next.

3) Grouping. We will group items in this report by the LastName field. 
• Click on LastName in the Fields list and use the arrow (>) to move it to the 

Groupings list.
• Click Next.

Figure 31. The first page of the Report Wizard

4) Layout of the report: We will use the default settings. This includes the Landscape 
orientation at the bottom of the Report Wizard. Click Next.

Note It might be worthwhile spending some time selecting the different layout choices 
available in reports just to see which ones can meet your needs.
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5) Creating the report: 

• Name the report Query_Weddings.

• What kind of report do you want to create? Select Dynamic.

• How do you want to proceed after creating the report? Select Modify report  
layout.

• Click Finish.

6) Modifying the report. The report contains a table with the information from the 
Query. It may contain some unrecognizable words (Figure 32). We will be 
changing the vertical alignment of the second row.

• Click on the cell below label First Name and drag the mouse cursor to the right 
to highlight the second row. 

• Right-click anywhere in a highlighted cell. Select Cell > Center to set the 
correct alignment.

• If you desire, you can change the widths of any of the cells at this point.

• Save and Close the Query_Weddings – OpenOffice.org Writer window.

Figure 32: First part of Report table

Note Queries can be changed from the Information – OpenOffice.org Base window by 
right-clicking on the desired Query and selecting Edit from the context menu.

Tip If a report is created as dynamic and the report is based upon a query, the report will 
change every time the query changes. (For example, you change the 
Query_Birthdays query to search for April instead of August. The next time the 
Query_Birthdays report is accessed, it will list the information for the people with 
birthdays in April instead of August.)
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