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What is Draw?

What is Draw?

Draw is a vector graphics drawing tool. It offers a series of powerful tools that enable you to 
quickly create all sorts of graphics. Vector graphics store and display an image as vectors 
(two points and a line) rather than a collections of pixels (dots on the screen). Vector graphics 
allows for easier storage and scaling of the image.

Draw is perfectly integrated into the OpenOffice.org suite, and this makes exchanging 
graphics with all components of the suite very easy. For example, if you create an image in 
Draw, reusing it in a Writer document is as simple as copy and paste. You can also work with 
drawings directly from within Writer and Impress, using a subset of the functions and tools 
from Draw.

Draw’s functionality is very extensive and complete. Even though it was not designed to rival 
high-end graphics applications, Draw still possesses more functions than the majority of 
drawing tools that are integrated into office productivity suites.

A few examples of drawing functions might whet your appetite: layer management, magnetic 
grid point system, dimensions and measurement display, connectors for making organization 
charts, 3D functions enabling small three-dimensional drawings to be created (with texture 
and lighting effects), drawing and page style integration, and Bezier curves, just to name a 
few.
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The Workplace

The Workplace

The main components of the Draw interface are shown in Figure 1.

Figure 1. Initial Draw window

The large area in the center of the window is where the drawings are made. It is surrounded 
by toolbars and information areas. You can vary the number and position of the visible tools, 
so your setup may look a bit different. For example, many people put the main Drawing 
toolbar on the left-hand side of the workspace, not at the bottom as shown here.
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The Toolbars

The Toolbars

The various Draw toolbars can be displayed or hidden according to your needs.

Many of the floating toolbars in OOo 1.x have become main toolbars in OOo 2.0.

To display or hide the toolbars, simply click View > Toolbars. On the menu that appears, 
choose which toolbars to display.

You can also select the buttons that you wish to appear on the corresponding toolbar. On the 
View > Toolbars menu, select Customize, click on the Toolbars tab (see Figure 2), and then 
select the desired buttons for that toolbar. Each toolbar has a different list of buttons.

Figure 2. Customizing a toolbar

Many toolbar buttons are marked with a small arrow beside the button. The arrow indicates 
that this button has additional functions. Click the arrow and a submenu or floating toolbar 
appears, showing its additional functions (see Figure 3).
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The Toolbars

Figure 3 An arrow next to a button 
indicates additional functions

Similarly, click on the arrow on the title bar of a floating toolbar to display additional 
functions (see Figure 4).

Figure 4. An arrow on a floating toolbar indicates additional functions

You may wish to keep this submenu displayed on your screen, but in a different position than 
the default location. You can make this submenu into a floating toolbar. To do so, click the 
submenu title bar, drag it across the screen, and then release the mouse button.

Note Most buttons marked with the small arrow can become floating toolbars. The floating 
toolbar capability is common to all components of the OpenOffice.org suite.

The tools available in the various toolbars are explained in the following sections.
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The Toolbars

The Standard Bar
The Standard Bar looks like this:

It is the same for all parts of OpenOffice.org.

The Line and Filling Bar
The Line and Filling Bar (called the Object Bar in OOo 1.x) lets you modify the main 
properties of a drawing object. 

In the example above, the available functions enable you to change the color of the line 
drawn, the fill color, and so on, of a selected object. If the selected object is text, the toolbar 
changes to the one below, which is very similar to the Formatting toolbar in Writer.

The Drawing Toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary 
functions for drawing various geometric and freehand shapes and organizing them on the 
page.

Drawing a straight line

Let’s start by drawing the simplest of shapes: a straight line. Click on the Line button on the 
Drawing Toolbar  and place the mouse cursor at the point where you wish to start drawing.

Drag the mouse while keeping the button pressed down. Let go of the mouse button when 
you want to stop drawing the line. A blue or green handle point will appear at each end of the 
line, showing that this is the currently selected object. The colors depend on the default 
selection mode (they will be green for simple selection and blue when in point edit mode). 
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The Toolbars

Figure 5: Drawing a straight line

Hold down the Shift key while drawing the segment to force the line to be drawn at a multiple 
of 45° from the horizontal. 

If you hold down the Control key (Ctrl in PCs), the constraining angle will be 15°. You can 
set this angle in Tools > Options > OpenOffice.org Draw > Grid.

Hold down the Alt key to draw the line symmetrically from the start point (the line extends 
out to both sides of the start point equally). This lets you draw straight lines by starting from 
the middle of the line.

The line you draw will have the default attributes (such as color and line type). To change the 
line attributes, click on the line to select it and then use the tools in the Line and Filling Bar; 
or for more control, right-click on the line and choose Line to open the Line dialog.

Drawing a rectangle

Drawing rectangles is similar to drawing straight line segments, except that you use the 
Rectangle button   from the Drawing Toolbar. The (imaginary) line drawn with the mouse 
corresponds the diagonal of the rectangle.

Figure 6: Drawing a rectangle

Hold down the Shift key to draw a square. Hold down the Alt key to draw a rectangle starting 
from its center.
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The Toolbars

Drawing a circle

To draw an ellipse or circle, use the Ellipse Button  from the Drawing Toolbar (a circle is 
simply an ellipse where the two axes are the same length). The ellipse drawn is the largest 
ellipse that would fit inside the (imaginary) rectangle drawn with the mouse.

Figure 7: Drawing a circle

Other shapes are available on the Drawing Toolbar.  In previous versions of OOo, 
these shapes were extended functions shown by long-clicking the Ellipse button.

There are three other ways to draw an ellipse or circle:

• Hold down the Shift key while drawing to force the ellipse to be a circle.

• Hold down the Alt key to draw a symmetrical ellipse or circle from the center instead 
of dragging corner to corner. 

• Hold down the Ctrl key while drawing to snap the ellipse or circle to grid lines.

Note If you first press (and hold) the Control key before clicking on any of these buttons 
(Line, Rectangle, Ellipse, and Text), the chosen object appears directly on the page 
with a default size, shape and color. All of these can then be changed.

Writing text

Use the Text tool  to write text and select the font, color, size, and other attributes. Click 
on an empty space in the workspace to write the text at that spot. If you click on an object, the 
text is written in the center of the object and remains within the object.  The border of the 
object becomes the text's frame.

When you have finished typing text, click inside the text frame. Press Enter to drop to the 
next line. Double-click on the text at any time to edit it.

When you type text, the upper toolbar includes the usual paragraph attributes: indents, first 
line and tab stops.
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The Toolbars

You can change the style of all or part of the text. The Styles and Formatting window also 
works here (select Format > Styles and Formatting or press F11 to launch), so you can 
create styles that you can reuse in other text frames exactly as you would with Writer.

Text frames can also have fill colors, shadows and other attributes, just like any other Draw 
object. You can rotate the frame and write the text at any angle. These options are available 
by right-clicking on the object.

Use the Callout tool, located on the Drawing toolbar, to create callouts (also known as 
captions or figure labels).

The Color Bar
To display the Color Bar, use View > Toolbars > Color Bar. The toolbar then appears at the 
bottom of the workspace.

This toolbar lets you rapidly choose the color of the objects in your drawing. The first box in 
the panel corresponds to transparency (no color). 

The color palette that is shown by default can be changed using Format > Area as shown in 
Figure 8. Choose the tab marked Colors.

Figure 8. Changing the color palette

If you click on the Load Color List button (circled), the file selector asks you to choose a 
palette file (bearing the file extension .soc). Several palettes are supplied as standard with 
OpenOffice.org. For example, web.soc is a color palette that is particularly adapted to 
creating drawings that are going to appear in web pages, because the colors will be correctly 
displayed on workstations with screens displaying at least 256 colors.
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The Toolbars

The color selection box also lets you individually change any color by modifying the 
numerical values in the fields provided to the right of the color palette. You also can click on 
Edit to display a dialog box (shown in Figure 9), making the choice of colors easier.

Figure 9. Defining color schemes

You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black), RGB 
(Red, Green, Blue) or HSB (Hue, Saturation, Brightness).

The Options Bar
This toolbar lets you activate or deactivate various drawing aids. The Options Bar is not 
displayed by default. To display it, select View > Toolbars > Options.
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The Toolbars

The snap tools are divided into 3 groups: the magnetic grid, snap lines, and snap points. 
Snapping to grid, lines or points requires three steps:

1) Display the grid, guides or points.
2) Click the correct snap-to button.
3) Drag the object near the point to be snapped to.

Using the grid

Draw provides a grid of points to which objects can be snapped. Click on the Display Grid 
button in the Options Bar to display the grid, and then click on the Snap to Grid button to 
activate it. The work area will be filled with a grid, as shown in Figure 10. This grid will not 
be printed or appear in exported files such as PDF.

When the grid is active, shapes can be positioned easily by using the dots as a guide. In the 
following example, the object handles are positioned exactly on the dots in the grid.

The spacing between the dots is defined in the Grid options dialog under the Drawing area of 
the OOo options (Tools > Options > OpenOffice.org Draw > Grid).

Figure 10. Example of grid

With the dialog shown in Figure 11, you can set the following parameters:

• Vertical and horizontal spacing of the dots in the grid. You can also change the unit of 
measurement used.

• The resolution is the size of the squares or rectangles in the grid.  If the resolution is 
Horizontal 1cm, Vertical 2cm, the grid consists of rectangles 2cm high and 1cm wide.

• Subdivisions are additional points that appear along the sides of each rectangle or 
square in the grid. Objects snap to subdivisions as well as to the corners of the grid.

• The pixel size of the snap area defines how close you need to bring an object to a snap 
point or line before it will snap to it.
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The Toolbars

Figure 11. Setting grid options

The Rulers
You should see rulers on the upper and left-hand side of the workspace (see Figure 12). These 
show the size of the objects on the page. The rulers show the location of the mouse to help 
you position objects more precisely. The rulers also are used to manage handle points and 
capture lines that make positioning objects easier. 

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. To modify the units of 
measurement of the rulers, right-click on one of the rulers. The two rulers can have different 
units.

Figure 12. Rulers in a drawing
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The Status Bar

The Status Bar

The Status Bar is located at the bottom of the screen. The middle part of this area (shown 
below) is particularly relevant to the Draw module.

The sizes are given in the current unit (not to be confused with the ruler units). This unit is 
defined in Tools > Options > OpenOffice.org Draw > General, where you can also change 
the scale of the page. Another way to change the scale is to double-click on the number 
shown in the status bar.

Advanced Functions

Draw contains several advanced functions that are useful in certain specific instances (web 
images and data exchange).

Duplication
This function duplicates a given shape while enabling you to change the options applied to 
the duplicates.

To start duplication, click on an object (or on a group of selected objects), then choose Edit > 
Duplicate.

The following dialog box appears.
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Advanced Functions

You can choose:

• The number of copies.

• The displacement along the X and Y axes between two copies.

• The angle of rotation between two copies.

• The change in size between each copy.

• The colors of the start and end copies..

The options above applied to a blue rectangle produce the following result:

The end result of a duplication is a new group.

Cross-fading
Cross-fading transforms a shape from one form to another, with OpenOffice.org handling all 
of the intermediate transitions. The result is a new group of objects.

To carry out a cross-fade, select both objects (hold the Shift key while selecting each object in 
turn) and then choose Edit > Cross-fading The following dialog will appear:

Here is an example of its use.
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Advanced Functions

We start with  two shapes...

 ...and carry out the cross-fade to obtain the following drawing:

Exchanging objects with other programs
To save a Draw image in a foreign format, use File > Export. Draw can save to many graphic 
file formats, as listed in Chapter 3, “File Management” in this book.

You can also export Draw files to HTML, PDF, and Flash. PDF export is the same as for any 
part of OpenOffice.org, as described in Chapter 3, “File Management” in this book. Flash 
export creates a .swf file.

HTML export uses a conversion wizard that creates as many web pages as there are pages in 
your Draw document. You can optionally choose to display the pages in frames with a 
navigator and can set an index page1. For more information, see Chapter 16, “Creating Web 
Pages: Saving Documents as HTML Files” in this book.

1 This wizard is exactly the same as in OpenOffice.org Impress.
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