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Opening files

Opening files

To open an existing document, choose File > Open or click the Open File icon on the 
Standard Toolbar or press Control+O.

The Open dialog box appears. Figure 1 shows the Windows XP version of this dialog box.

Figure 1. Open dialog box in Windows XP

Choose the file and then click Open.

Note Under Microsoft Windows you can use either the OpenOffice.org Open and Save As 
dialog boxes or the ones provided by Microsoft Windows. See “Using the Open and
Save As dialog boxes” on page 12.
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File formats
OpenOffice.org can import Microsoft Office files. However, Microsoft Office cannot import 
files in the OpenDocument format used by OpenOffice.org. If you want to send a file to a 
Microsoft Office user, you must save it in a Microsoft Office format or in .rtf.  Below is a 
chart for quick reference.

OpenDocument type Application Extension MS Office equiv

Text Writer odt doc
Text Template Writer ott dot
Master Document Writer odm doc
Spreadsheet Calc ods xsl
Spreadsheet Template Calc ots xst
Drawing Draw odg N/A
Drawing Template Draw otg N/A
Presentation Impress odp ppt
Presentation Template Impress otp pot
Formula Math odf N/A
Chart Chart odc N/A
Database Base odb mdb

Default file formats
OpenOffice.org saves files in the default OpenDocument format, unless told otherwise. This 
default can be changed, for example, if you always want to save as Microsoft Office files. To 
change the default file formats:

1) Go to Tools > Options > Load/Save > General. (See Figure 2.)

2) In the Default file format section of this page, choose a document type (for example, 
“Text document”) and a file format from the Always save as list.

3) Repeat for each document type, as necessary.

4) Click OK to save your changes.

Notes If the option “Warn when not saving in OpenDocument or default format” is checked 
on the Options – Load/Save – General dialog box (Figure 2), a warning dialog about 
potential loss of formatting may be displayed. In most cases, no loss of formatting 
will occur, so you may find this warning annoying and choose to disable it.
The Java Runtime Environment is required to use the mobile device filters for 
AportisDoc (Palm), Pocket Word, and Pocket Excel.
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Figure 2. Choosing default formats for saving files

Opening text documents
In addition to OpenDocument formats (.odt, .ott, .oth, and .odm), Writer 2.0 can open the 
formats used by OOo 1.x (.sxw, .stw, and .sxg) and the following text document formats: 

Microsoft Word 6.0/95/97/2000/XP) (.doc and .dot) WordPerfect Document (.wpd)
Microsoft Word 2003 XML (.xml) WPS 2000/Office 1.0 (.wps)
Microsoft WinWord 5 (.doc) DocBook (.xml)
StarWriter formats (.sdw, .sgl, and .vor) Ichitaro 8/9/10/11 (.jtd and .jtt)
AportisDoc (Palm) (.pdb) Hangul WP 97 (.hwp)
Pocket Word (.psw) .rtf, .txt, and .csv

When opening .htm or .html files (used for web pages), OpenOffice.org customizes Writer 
for working with these files.

Opening spreadsheets
In addition to OpenDocument formats (.ods and .ots), Calc 2.0 can open the formats used by 
OOo 1.x (.sxc and .stc) and the following spreadsheet formats:

Microsoft Excel 97/2000/XP (.xls, .xlw, and .xlt) Rich Text Format (.rtf)
Microsoft Excel 4.x–5.0/95 (.xls, .xlw, and .xlt) Text CSV (.csv and .txt)
Microsoft Excel 2003 XML (.xml) Lotus 1-2-3 (.wk1, .wks, and .123)
Data Interchange Format (.dif) StarCalc formats (.sdc and .vor)
dBase (.dbf) SYLK (.slk)
.htm and .html files including Web page queries Pocket Excel (pxl)
Quattro Pro 6.0 (.wb2)
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Opening presentations
In addition to OpenDocument formats (.odp, .odg, and .otp), Impress 2.0 can open the 
formats used by OOo 1.x (.sxi and .sti) and the following presentation formats:

• Microsoft PowerPoint 97/2000/XP (.ppt, .pps, and .pot)
• StarDraw and StarImpress (.sda, .sdd, .sdp, and .vor)
• CGM – Computer Graphics Metafile (.cgm)

Opening graphic files
In addition to OpenDocument formats (.odg and .otg), Draw 2.0 can open the formats used by 
OOo 1.x (.sxd and .std) and the following graphic formats:

BMP JPEG, JPG PCX PSD SGV WMF
DXF MET PGM RAS SVM XBM
EMF PBM PLT SDA TGA XPM
EPS PCD PNG SDD TIF, TIFF
GIF PCT PPM SGF VOR

Opening formula files
In addition to OpenDocument Formula files, OpenOffice.org 2.0 can open the format used by 
OOo 1.x (*StarMath (.smf), and MathML (.mml) files.

When opening a Word document that contains an embedded equation editor object, if the 
option for it is checked in Tools > Options > Load/Save > Microsoft Office, the object will 
be automatically converted to an OpenOffice.org Math object.

Saving files

To save a new file:

1) Choose File > Save As. 

2) When the Save As dialog box appears, enter the file name and verify the file type (if 
applicable). 

To save an open document with the current file name, choose File > Save.  This will 
overwrite the last saved state of the file.

Password protection
To protect an entire document from being viewable without a password, there is an option on 
the Save As dialog box to enter a password. This option is only available for files saved in 
OpenDocument formats or the older OpenOffice.org 1.x formats. 
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1) On the Save As dialog box, select the checkbox beside Save with password, and then 
click Save. You will receive a prompt:

2) Type the same password in the Password field and the Confirm field, and then click 
OK.  If the passwords match, the document is saved password protected.  If the 
passwords do not match, you receive the prompt to enter the password again.

Note Passwords must contain a minimum of 5 characters. Until you have entered 5 
characters, the OK button remains inactive.

Saving a document automatically
You can choose to have OpenOffice.org save files for you automatically. Automatic saving, 
like manual saving, will overwrite the last saved state of the file. To set up automatic file 
saving:

1) Choose Tools > Options > Load/Save > General. (See Figure 2.)

2) Mark Save AutoRecovery information every, and set the time interval.

Writer can save to these file formats
In addition to OpenDocument formats (.odt and .ott), Writer 2.0 can save in these formats:

• OpenOffice.org 1.x Text Document(.sxw)
• OpenOffice.org 1.x Text Document Template (.stw)
• Microsoft Word 6.0, 95, and 97/2000/XP (.doc)
• Microsoft Word 2003 XML (.xml)
• Rich Text Format (.rtf)
• StarWriter 3.0, 4.0, and 5.0 (.sdw)
• StarWriter 3.0, 4.0, and 5.0 Template (.vor)
• Text (.txt)
• Text Encoded (.txt)
• HTML Document (OpenOffice.org Writer) (.html and .htm)
• DocBook (.xml)
• AportisDoc (Palm) (.pdb)
• Pocket Word (.psw)
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Note The .rtf format is a common format for transferring text files between applications, 
but you are likely to experience loss of formatting and images. For this reason, other 
formats should be used.

Calc can save to these file formats
In addition to OpenDocument formats (.ods and .ots), Calc 2.0 can save in these formats:

• OpenOffice.org 1.x Spreadsheet (.sxc)
• OpenOffice.org 1.x Spreadsheet Template (.stc)
• Microsoft Excel 97/2000/XP (.xls and .xlw)
• Microsoft Excel 97/2000/XP Template (.xlt)
• Microsoft Excel 5.0 and 95 (.xls and .xlw)
• Microsoft Excel 2003 XML (.xml)
• Data Interchange Format (.dif)
• dBase (.dbf)
• SYLK (.slk)
• Text CSV (.csv and .txt)
• StarCalc 3.0, 4.0, and 5.0 formats (.sdc and .vor)
• HTML Document (OpenOffice.org Calc) (.html and .htm)
• Pocket Excel (.pxl)

Note The Java Runtime Environment is required to use the mobile device filters for 
AportisDoc (Palm), Pocket Word, and Pocket Excel.

Impress can save to these file formats
In addition to OpenDocument formats (.odp, .otp, and .odg), Impress 2.0 can save in these 
formats:

• OpenOffice.org 1.x Presentation (.sxi)
• OpenOffice.org 1.x Presentation Template (.sti)
• Microsoft PowerPoint 97/2000/XP (.ppt and .pps)
• Microsoft PowerPoint 97/2000/XP Template (.pot)
• StarDraw, StarImpress (.sda, .sdd, and .vor)

Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats as listed 
below for Draw.
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Draw can save to these file formats
Draw can only save in the OpenDocument Drawing formats (.odg and .otg), the 
OpenOffice.org 1.x formats (.sxd and .std) and StarDraw format (.sda, .sdd, and .vor). 

However, it can export to BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG, PPM, 
RAS, SVG, SVM, TIFF, WMF, and XPM.

Writer/Web can save in these formats
HTML document (.html and .htm)
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.0 HTML Template (.oth)
StarWriter/Web 4.0 and 5.0 (.vor)
Text (OpenOffice.org Writer/Web) (.txt)
Text Encoded (OpenOffice.org Writer/Web) (.txt)

Exporting files

Export to XHTML
OpenOffice.org can export files to XHTML. Choose File > Export. On the Export dialog, 
select XHTML in the File format list.

Export to PDF
Each application can directly export to PDF. This industry-standard file format for file 
viewing is ideal for sending the file to someone else to view using Acrobat Reader or other 
PDF viewers.

You can export directly to PDF using a button on the toolbar  or by choosing File > 
Export as PDF. 

If you use File > Export as PDF, you are asked to enter the filename for the PDF file, and 
then the PDF Options dialog box (Figure 3) opens.

Note If you use the Export Directly as PDF button, you are asked to enter the filename 
for the PDF file, but you cannot choose a page range, the image compression, or 
other export options. 
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Figure 3. Specifying the PDF export options

PDF options

Range

• All: Exports the entire document.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single 
pages, use the format 7;9;11 (pages 7, 9, and 11). 

Images

• Lossless compression:  Images are stored without any loss of quality. Tends to make 
large files when used with photographs. Recommended for other images.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% tends to 
work well with photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower-DPI (dots per inch) images have lower quality.

General

• Tagged PDF: Includes special tags into the corresponding PDF tags. This can increase 
file sizes significantly. Some tags that are exported are table of contents, hyperlinks, 
and controls.

• Export notes: Exports notes of Writer and Calc documents as PDF notes.

• Use transition effects: Includes Impress slide transition effects in their respective PDF 
effects.
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• Submit forms in format: Selects the format of submitting forms from within the PDF 
file. There is only one common setting valid for the whole PDF document: PDF (sends 
the whole document), FDF (sends the control contents), HTML, and XML. Most often 
you will choose the PDF format.

Deleting and renaming files

You can rename or delete files within the OpenOffice.org dialog boxes, just as you can in 
your usual file manager. However, you cannot copy or paste files within the dialog boxes. 

Renaming a file
To rename a file while using OpenOffice.org: 

1) Choose File > Open and browse to the required file. 

2) Right-click on the file name and choose Rename. The file name will be selected.

3) Typing replaces the selected name, or use a left or right arrow key to move the 
insertion point to modify the existing name.

Deleting a file
To delete a file while using this dialog: 

1) Right-click on the file name to display a context menu. 

2) Click Delete, and you will get a confirmation dialog. 

Note Instead of Right-click > Delete, you can simply press the Delete key.
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File associations

File associations are used to open certain types of files automatically with OpenOffice.org. 
You can choose to associate Microsoft Office files with OOo. If you do this, the files remain 
as Microsoft Office files, but the icon for the files changes to the OOo icon, and double-
clicking on the icon opens the files in OOo. (You can still open the files in Microsoft Office 
by starting MS Office and then choosing File > Open.)

When installing OOo, you are prompted to associate file types, as shown in Figure 4. If you 
want to continue to open your Microsoft Office files in Office by double-clicking them, do 
not check these boxes. (You can open MS Office files in OOo by starting OOo and then 
choosing File > Open.) 

Figure 4. Choosing file associations when installing OpenOffice.org

If during installation you chose not to have OpenOffice.org automatically open Microsoft 
Word files, you can change this later.

1) In Windows, go to Settings > Add or Remove Programs. Scroll down to 
OpenOffice.org 2.0 and click once on it. Two buttons should be visible: Change and 
Remove, as shown in Figure 5. This may appear different on your system. 

2) Click Change to start the Installation Wizard. 

3) Continue through the Installation Wizard until you reach the page shown in Figure 4. 
Select the file types you want OOo to open (put a mark in each checkbox) and click 
OK.
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Figure 5: Changing the OOo installation on Windows XP

Creating new files

Different ways of creating a new document:

• Use File > New and choose the type of document.

• Use the arrow next to the New button on the main toolbar. A menu of choices (Figure
6) drops down; select the type of document to be created.

Figure 6. The New menu from the toolbar

• Use a “Quick start” program. For example, the Microsoft Windows version of 

OpenOffice.org has a Quickstart icon  in the system tray. (See the chapter titled 
“Starting OpenOffice.org” for more information on the Quickstart icon.)

• Press Control+N on the keyboard.

• Use File > Wizards for some types of documents. (See Figure 7.)
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Figure 7. Creating a file using a Wizard

Using the Open and Save As dialog boxes

If you are using Microsoft Windows, you can choose whether to use the OpenOffice.org 
Open and Save As dialog boxes or the ones provided by Windows. To view or change which 
type of dialog box OpenOffice.org uses:

1) Choose Tools > Options > OpenOffice.org > General.

2) Select the Use OpenOffice.org dialogs checkbox.

This section discusses the OpenOffice.org Open and Save As dialog boxes. See Figures 8 and 
9 for examples of these dialog boxes.

The three buttons in the top right of the OOo Open dialog box (Figure 8) are, from left to 
right:

• Go Up One Level in the folder (directory) hierarchy. This is a long-click button if you 
want to go up higher than just one level.

• Create New Folder.

• View Menu.

For OpenOffice.org documents that have been saved with more than one version, use the 
version drop-down to select which version you wish to open in read-only mode.

Note For Microsoft Office documents, only the current version can be opened.
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Figure 8. The OOo Open dialog box, showing some of the file formats that can be opened

Use the Files of type field to specify the type of file to be opened or the format of the file to 
be saved.

The Read-only checkbox opens the file for reading and printing only. Consequently, most of 
the toolbars disappear, and most menu options are disabled. An Edit File button is displayed 
on the Function Toolbar to open the file for editing.

It is possible to open files from the web using URLs. 
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Figure 9. The OpenOffice.org Save As dialog box, showing some of the Save formats
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