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Chapter 11
  What is OpenOffice.org?

OpenOffice.org (OOo) is a freely-available, full-featured office suite. This chapter 
describes:

• The components of OpenOffice.org.
• Some of the enhancements and new features in version 2.
• How OpenOffice.org compares to other office suites.
• How to get help.
• How OpenOffice.org is licensed.
• Answers to some common questions.

Note Because someone else owns the trademark “OpenOffice” the correct name 
for both the open-source project and its software is “OpenOffice.org”.

OpenOffice.org (OOo) is both a software product and a community of volunteers 
that produces and supports the software.

Everyone is free to redistribute OOo, thanks to its open source license (see “How is
OpenOffice.org licensed?” on page 13).

If you are new to OOo, its open source development, and the community that 
produces and supports it, you should read this chapter.

OOo 2.0 is a major upgrade of an already feature-rich office suite. If you have used 
previous versions of OOo, please look over the section “New features in version 2” 
on page 6.
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What does OpenOffice.org include?

The OpenOffice.org 2.0 office suite includes the following components.

Writer (word processor)

Writer is a feature-rich tool for creating letters, books, reports, 
newsletters, brochures, and other documents. You can insert graphics 
and objects from other components into Writer documents. Writer can 
export files to HTML, XHTML, XML, Adobe’s Portable Document 
Format (PDF), and several versions of Microsoft Word files. It also 
connects to your email client.

Calc (spreadsheet)

Calc has all of the advanced analysis, charting and decision-making 
features expected from a high-end spreadsheet. It includes over 300 
functions for financial, statistical and mathematical operations among 
others. The Scenario Manager provides “what if” analyses. Calc 
generates 2-D and 3-D charts, which can be integrated into other OOo 
documents. You can also open and work with Microsoft Excel 
workbooks and save them in Excel format. Calc can export spreadsheets 
to Adobe’s Portable Document Format (PDF) and to HTML.

Impress (presentation graphics)
Impress provides all the common multi-media presentation tools, such 
as special effects, animation, and drawing tools. It is integrated with 
the advanced graphics capabilities of the Draw and Math components. 
Slideshows can be further enhanced with Fontwork’s special effects 
text, as well as sound and video clips. Impress is compatible with 
Microsoft’s PowerPoint file format, and can save your work in 
numerous graphics formats including Macromedia Flash (SWF).

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple 
diagrams or flowcharts to 3-D artwork. Its Smart Connectors feature 
allows you to define your own connection points. You can use Draw to 
create drawings for use in any of OOo’s other components, and you can 
create your own clipart and add it to the Gallery. Draw can import 
graphics from many common formats and save them in over 20 formats 
including PNG, HTML, PDF and Flash.
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Base (database)
Base offers all the tools you need for day-to-day database work within a 
simple interface. It can create and edit forms, reports, queries, tables, 
views and relations, so managing a connected database is much the 
same as in other popular database applications. Base provides many 
new features, such as the ability to analyze and edit relationships from a 
diagram view. Base incorporates HSQLDB as its default relational 
database engine. It can also use dBASE, Microsoft Access, MySQL or 
Oracle, or any ODBC or JDBC compliant database. Base also provides 
support for a subset of ANSI-92 SQL.Base. 

Math (formula editor)
Math is OOo’s formula or equation editor. You can use it to create 
complex equations that include symbols or characters not available in 
standard font sets. While it is most commonly used to create formulas 
in other documents, such as Writer and Impress files, Math can also 
work as a stand-alone tool. You can save formulas in the standard 
Mathematical Markup Language (MathML) format for inclusion in 
webpages and other documents not created by OOo.

The advantages of OpenOffice.org

Here are some of the advantages of OpenOffice.org over other office suites:

• No licensing fees. OOo is free for anyone to use and distribute at no cost. 
Many features that are available as extra cost add-ins in other office suites 
(like PDF export) are free with OOo. There are no hidden charges now or in 
the future.

• Open source. You can distribute, copy, and modify the software as much as 
you wish, in accordance with either of OOo's Open Source licenses.

• Cross-platform. OOo 2.0 runs on several hardware architectures and under 
multiple operating systems, such as Microsoft Windows, Mac OS X, Linux, 
and Sun Solaris.

• Extensive language support. OOo’s user interface is available in over 40 
languages and the OOo project provides spelling, hyphenation and thesuarus 
dictionaries in over 70 languages and dialects. OOo also provides support 
for both Complex Text Layout (CTL) and  Right to Left (RTL) layout 
languages (such as Hindi, Hebrew and Arabic).

• Consistent user interface. All the components have a similar “look and 
feel”, making them easy to use and master.
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• Integration. The components of OpenOffice.org are well integrated with 
one another.
• All the components share a common spelling checker and other tools, 

which are used consistently across the suite. For example, the drawing 
tools available in Writer are also found in Calc, with similar but 
enhanced versions in Impress and Draw.

• You do not need to know which application was used to create a 
particular file (for example, you can open a Draw file from Writer).

• Granularity. Usually, if you change an option, it affects all components. 
However,  options can be set at a component level or even document level.

• File compatibility. OOo includes PDF and Flash export capabilities, as well 
as support for opening and saving files in many common formats including 
Microsoft Office, HTML, XML, WordPerfect and Lotus 123 formats.

• No vendor lock-in. OOo 2.0 uses OpenDocument, an XML (eXtensible 
Markup Language) file format developed as an industry standard by OASIS 
(Organization for the Advancement of Structured Information Standards). 
These files can easily be unzipped and read by any text editor, and their 
framework is open and published.

• You have a voice. Enhancements, software fixes and release dates are 
community-driven. You can join the community and affect the course of the 
product you use.

You can read more about OpenOffice.org, its mission, history, licensing and other 
organizational information here: http://www.openoffice.org/about.html

How does OpenOffice.org compare?
OpenOffice.org can match and exceed the feature set of competing office suites. The 
following table lists the main components of OOo and compares them with their 
equivalents in two leading office suites, Microsoft Office 2003 (MSO) and 
WordPerfect Office 12 (WP).

FunctionFunction OOoOOo MSOMSO WPWP

Word processor Writer Word® WordPerfect®

Spreadsheet Calc Excel® Quattro Pro®

Vector Graphics Draw no no

Presentation Graphics Impress PowerPoint® Presentations®

Database Base Access® 1 Paradox® 2

Math or Formula Editor Math yes no
1 Professional version only.
2 Professional and Student and Teacher editions only.
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Features
The following tables list some important features of OpenOffice.org and compare 
them with two leading office suites, Microsoft Office 2003 (MSO) and WordPerfect 
12 (WP).

Styles and formatting

FeatureFeature OOoOOo MSOMSO WPWP

Navigator yes limited1 no

Styles and Formatting window yes yes no

Keyboard support for paragraph styles yes yes no

Support for page, frame, and list styles yes no no

Word completion yes Excel only no

Spelling and language proofing modules 70+ 50+2 25

Formula or equation tools yes yes no
1 “Outline View” in Word offers a subset of the features of OOo’s Navigator.
2 Requires an additional license for the the Multilingual User Interface Pack.

Interoperability

FeatureFeature OOoOOo MSOMSO WPWP

PDF export capability yes no yes
Flash export capability yes no yes
XML export capability yes yes yes
OpenDocument XML format yes no no
Import/Export Microsoft Office files yes yes yes
Import WordPerfect files yes yes yes
Import Lotus 123 files yes yes yes
Connect to external databases 
(MySQL, Oracle, Access, etc.)

yes yes yes

Languages available (localizations) 40+ 35+ 24
Supported operating systems Windows, 

Mac OS X, 
Linux, Solaris

Windows 
only1

Windows 
only

Unicode language support yes yes no
1 Microsoft Office: Mac is not feature compatible with Microsoft Office 2003.
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Programmability
Macros are programs which automate tasks and can be embedded in a document. 
The following table lists the languages available for macro development in each 
office suite.

LanguageLanguage OOoOOo MSOMSO WPWP

Basic-derived language OpenBasic VBA VBA

Beanshell yes no no

Java yes no no

JavaScript yes no no

Python yes no no

Beyond simple macros, some office suites can be extended to include new features. 
This capability usually takes the form of plug-ins. In the case of OpenOffice.org, it 
can also be done through changes to the source code.

FeatureFeature OOoOOo MSOMSO WPWP

C and C++ yes yes yes

Java yes no no

Python yes no no

Source code available! yes no no

Security

FeatureFeature OOoOOo MSOMSO WPWP

Digital signatures yes yes yes

Strong encryption yes yes yes

Secure paths for macro execution yes yes no

New features in version 2
OpenOffice.org 2.0 delivers hundreds of improvements and new features. Here are 
some of the major enhancements.

• Simplified installation. Installations are now performed by platform-native 
installers with no need to use command-line switches (or flags) for multi-
user installations. You can also specify which version of Java (if any) is to 
be used by OOo from the installation interface.
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• New database component. In the new stand-alone database component, 
you can create forms, reports, queries, tables, views and relations. OOo now 
includes HSQLDB, a small, fast, relational database engine that supports a 
subset of ANSI-92 SQL, along with an easy to use interface. Additionally, it 
is now easier than ever to use other databases (dBASE, MySQL, Oracle, 
among others).

• New file format. OOo 2.0 uses the new OpenDocument standard XML file 
format (standardized by OASIS, http://www.oasis-open.org/home/index.php) 
as its default file format. This new file format is also used in StarOffice, IBM 
Workspace and KOffice, and will be used by other products in the future. 
OOo 2.0 can still read and save files in formats previously supported by 
OOo 1.x, including Microsoft Office formats.

• Native system theme integration. To further integrate OpenOffice.org with 
the underlying operating system, all user interface elements (such as buttons 
and scrollbars)  have the same look as those used in other native 
applications for each platform.

• Digital signatures. Digital signatures provide authentication of the true 
author or editor of a document. This feature provides further security with 
running macros.

• Enhanced encryption. Implementation of the new XML (eXtensible 
Markup Language) encryption algorithm offers additional document 
security.

• Usability improvements. Redesigned toolbars are more usable, and display 
only selected default tools and related options. The usability of the Menus 
tab of the Tools > Customize dialog has been improved. Several features 
have been renamed to conform with common office suite terminology (for 
example, “AutoPilot” is now a “Wizard”).

• Thumbnails. The new plug-in for the the native file explorer provides a 
thumbnail preview of an OOo file. Some of the more common file system 
explorers that can use this new feature are Nautilus (Gnome), Konqueror 
(KDE), and Microsoft Windows Explorer.

• Import and export filters
• Improved PDF export filter now includes PDF bookmarks, PDF notes, 

and more.

• Import and export of Microsoft Office 95 and Office 97 spin buttons 
and scrollbars have been added to the Word filters.

• The import filter for Microsoft PowerPoint documents now creates text 
objects having font-independent line spacing enabled.
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• Enhanced export to HTML  produces valid “XHTML 1.0 Strict” 
documents. XHTML export has been enabled for Calc, Draw and 
Impress.

• You can now open Microsoft Office password-protected documents.

• New import filters for WordPerfect and Lotus 123.

• Send document as email. OOo 2.0 makes it easier to use your email client 
to send the active document as an attachment.

• Enhanced mail merge feature. Enhancements include better management 
of databases and saving into one single file.

• Drag and drop selections to create styles. Drag and drop a text selection 
into the Styles and Formatting window to create a new paragraph style or 
character style.

• Form controls. Form controls can be embedded in all OOo documents that 
support a form layer.

• New keyboard shortcuts. You can now use the keyboard to perform the 
actions found under Edit > Paste Special. Multiple selected sheets in a 
spreadsheet can be deselected using the keyboard. Paragraph and other 
styles can be assigned to key combinations.

• Auto recovery of files and the workspace environment. The OOo Error 
Reporting tool and the document recovery features have been combined. 
Now if OOo crashes, the active documents are saved. You can recover the 
documents, and send an error report.

• Enhanced features in Calc. These enhancements include improved number 
recognition, an improved hyperlink function, conditional arrays, a greater 
selection of predefined headers and footers, more options for defining how 
to print sheets, new options for the DataPilot feature, and support for right-
to-left languages.

• Calc row limit increased. The number of spreadsheet rows has been 
increased to 65536, the same number of rows as Microsoft Excel.

• Enhanced multimedia. The multimedia presentation model uses the W3C’s 
Synchronized Multimedia Integration Language (SMIL) standard. Now 
Impress can render nearly all of the Microsoft PowerPoint animation effects. 
Two new task panels provide access to shape and slide transition effects.
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• Programmatic control of menu and toolbar items. Third-party 
developers can write plugins to manipulate menu bar and toolbar layouts to 
their needs. Developers can now insert, remove, and modify menu items, 
context menus, and toolbar items at runtime.

• Scripting framework. The scripting framework allows you to write macros 
in a number of languages other than OOo Basic. You can assign these 
macros to menu items, keyboard combinations, application and document 
events, form controls within documents, and various objects within 
documents.

For a complete, detailed listing, go to the OpenOffice.org 2.0 Office Suite, Guide to 
New Features located at 
http://marketing.openoffice.org/2.0/featureguide.html#enduser

Minimum requirements

OpenOffice.org 2.0 requires one of the following operating systems:

• Microsoft Windows 98, Windows ME, Windows 2000 (Service Pack 2 or 
higher), Windows XP or Windows 2003

• GNU/Linux Kernel version 2.2.13 and glibc 2.2.0 or newer

• Mac OS X 10.3.x (10.3.5 recommended), Mac OS X 10.4.x, plus X11
• Solaris version 8 or higher

More operating systems will be supported in the future. 

Some OpenOffice.org features (wizards and the database component) require that 
the Java Runtime Environment (JRE) be installed on your computer.  Although OOo 
will work fine without Java support, some features will not be available. You can 
download the latest version from http://www.java.com.

For a more detailed (and up-to-date) listing of requirements, see: 
http://www.openoffice.org/dev_docs/source/sys_reqs_20.html 

Getting the software

You can get the OpenOffice.org installation package in any of these ways:

• Download a copy from the project’s home page: http://www.openoffice.org.

• Download a copy using the Peer to Peer client, BitTorrent. The instructions 
are here: http://distribution.openoffice.org/p2p/download.html.
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• Purchase a copy on a CD-ROM or other digital form from a third party 
distributor. The project maintains a listing of distributors; however these 
distributors are not connected with, nor endorsed by OpenOffice.org:
http://distribution.openoffice.org/cdrom/sellers.html.

• The OpenOffice.org Porting Project has links to versions of the software 
that have been, or are currently being “ported” to run under various 
operating systems.  http://porting.openoffice.org/index.html.

Installing the software

Information on installing and setting up OpenOffice.org on the various supported 
operating systems is given here: 
http://download.openoffice.org/2.0.2/instructions.html

You can also download the more detailed Setup Guide (in several languages) from: 
http://documentation.openoffice.org/setup_guide2/index.html 

How to get help

Help system
OOo comes with an extensive Help system. This is your first line of support for 
using OOo. 

To display the full Help system, press F1 or select OpenOffice.org Help from the 
Help menu. In addition, you can choose whether to activate tooltips, extended tips, 
and the Help Agent (using Tools > Options > General).

If tooltips are enabled, place the mouse pointer over any of the icons to see a small 
box (“tooltip”) with a brief explanation of the icon’s function. For a more detailed 
explanation, select Help > What's This? and hold the pointer over the icon.

The Help menu
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Free online support
The OpenOffice.org community not only develops software, but provides free, 
volunteer-based support. Users of OOo can get comprehensive online support from 
community venues such as newsgroups, forums or mailing lists. There are also 
numerous websites run by users that offer free tips and tutorials.

Free OpenOffice.org supportFree OpenOffice.org support

User Help – FAQ Project FAQs, information, knowledge base.
http://user-faq.openoffice.org/new-faq/index.html

Users Mailing List

Free community support provided by a network of 
hundreds of experienced users. You must be 
subscribed to post messages.
To subscribe, send a blank email to 
users-subscribe@openoffice.org
List archives are here:
http://www.openoffice.org/servlets/SummarizeList? 
listName=users

Documentation Project Templates, user guides, how-tos, and other 
documentation. http://documentation.openoffice.org/

Native Language Project
Information, resources, and mail lists in your 
language. 
http://projects.openoffice.org/native-lang.html

Mac Support
Support for installing and using the Mac OS X (X11 
based) port. 
http://porting.openoffice.org/mac/support.html

The OpenOffice.org Forum
Extensive discussion forum for OpenOffice.org 
issues from setup to advanced programming features. 
http://www.oooforum.org/

OOo KnowledgeBase A collection of questions and answers that users can 
query. http://mindmeld.cybersite.com.au/

Read more about the support options for OpenOffice.org at:
http://support.openoffice.org/index.html

Paid support and training
Alternatively, you can pay for support services. Service contracts can be purchased 
from a vendor or consulting firm specializing in OpenOffice.org. 
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OOo is supported by Sun Microsystems, Inc. under the Sun Software Support 
program, which includes two levels of support that cover extended business hours or 
around-the-clock service for mission-critical deployments. 
http://www.sun.com/service/support/software/openoffice/index.html

A list of independent consultants and the services they offer, listed alphabetically by 
region and then by country, is provided on the OpenOffice.org website. 
http://bizdev.openoffice.org/consultants.html

Other resources and addons
Several websites provide additional free resources and addons to enhance 
OpenOffice.org. The following table lists a few of these websites.

Free OOo templates, artwork and other addonsFree OOo templates, artwork and other addons

OOExtras Provides templates, samples and macros in several 
languages. http://ooextras.sourceforge.net/

OOoMacros
A repository for OOo macros and addons, and 
documentation about writing macros and/or extending 
OOo. http://www.ooomacros.org/

Open Clip Art Library An archive of clip art that can be used for free for any 
use.  http://www.openclipart.org/

OpenOffice.org Macro 
Information

Andrew Pitonyak, the author of OpenOffice.org 
Macros Explained, maintains this site which provides 
extensive documentation on  OOo's macro capability. 
Many good referral links are also provided at: 
http://www.pitonyak.org/oo.php

A short history of OpenOffice.org

The OpenOffice.org project began when Sun Microsystems released the source code 
(“blueprints”) for its StarOffice® software to the open source community in 2000. 
This allowed Sun to use the technical expertise and rapid development times of an 
open-source project in the development of its own software products. All recent 
versions of Sun’s StarOffice use source code developed by the OpenOffice.org 
community. However, the products do not provide exactly the same features due to 
the copyrights of third parties which are not compatible with open-source licensing.

Read more about OpenOffice.org’s history and organization at: 
http://www.openoffice.org/about.html

Information about StarOffice can be found at: 
http://wwws.sun.com/software/star/staroffice
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How is OpenOffice.org licensed?

How is OpenOffice.org licensed?

OpenOffice.org is distributed under the Open Source Initiative (OSI) approved 
Lesser General Public License (LGPL). The LGPL can be viewed on the OOo 
website at: http://www.openoffice.org/licenses/lgpl_license.html

For more general information on OOo’s licensing, please refer to: 
http://www.openoffice.org/license.html.

What is “open source”?

The ideals of open-source software can be explained by the four essential rights, 
which are embodied within the Free Software Foundation’s General Public License 
(GPL):

• The right to use the software for any purpose.

• Freedom to redistribute the software for free or for a fee.

• Access to the complete source code of the program (that is, the “blueprints”).

• The right to modify any part of the source, or use portions of it in other 
programs.

Another view of this philosophy comes from the Open Source Definiton:

“The basic idea behind open source is very simple: When programmers can 
read, redistribute, and modify the source code for a piece of software, the 
software evolves. People improve it, people adapt it, people fix bugs. And 
this can happen at a speed that, if one is used to the slow pace of 
conventional software development, seems astonishing.”

For more information on Free and Open Source software, visit these websites:

Open Source Initiative (OSI):  http://www.opensource.org
Free Software Foundation (FSF):  http://www.gnu.org

Frequently asked questions

Is this software a “demo” version? No, this is a fully functioning software suite.

Can I distribute OOo to anyone? Yes.

How many computers can I install 
it on?

As many as you like.

Can I sell it? Yes.
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Frequently asked questions

Can I use OpenOffice.org in a 
business?

Yes.

Is OpenOffice available in my 
language?

OpenOffice.org has been translated (localized) into 
over 40 languages, so your language probably is 
supported. Additionally, there are over 70 spelling, 
hyphenation, and thesaurus dictionaries available 
for languages and dialects that do not have a 
localized program interface. The dictionaries are 
available from the OpenOffice.org website at: 
http://lingucomponent.openoffice.org/download_di
ctionary.html

How can you make it for free? A large share of the development, and much of the 
support for the project is currently supplied or 
sponsored by Sun Microsystems. There are also 
many other people who work on OOo as 
volunteers.

What if I need technical support? Read the section titled “How to get help”.

Who owns the software? The copyright is shared by Sun Microsystems and 
all the volunteers who have contributed.

Does that mean that they can take 
away the software?

No. The licenses under which OOo is developed 
and distributed can never be revoked, so it cannot 
be taken away.

I am writing a software application. 
Can I use programming code from 
OpenOffice.org in my program?

You may, within the parameters set in the LGPL. 
Read the license: 
http://www.openoffice.org/license.html

Why is my favorite feature from 
StarOffice not available in 
OpenOffice.org?

That feature is probably a third party add-on that 
Sun cannot distribute with OpenOffice.org.

Why do I need Java to run 
OpenOffice.org? Is it written in 
Java?

OpenOffice.org is not written in Java; it is written 
in the C++ language. Java is one of several 
languages that can be used to extend OOo. The 
Java JDK/JRE is only required for some features. 
The most notable one is the HSQLDB relational 
database engine.
Note: Java is available at no cost. If you don't want 
to use Java, you can still use nearly all of the 
features of OOo.

How can I contribute to 
OpenOffice.org?

You can help with the development of OOo in 
many ways, and you do not need to be a 
programmer. To start, check out this webpage: 
http://www.openoffice.org/contributing.html

What’s the catch? There really is none; read the licenses: 
http://www.openoffice.org/license.html
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Chapter 22
  Starting OpenOffice.org

This chapter describes several ways to start OpenOffice.org:

• From the system menu

• From an existing document

• Using the Quickstarter under Windows

• Preloading OOo under Linux/KDE

• From the command line

Starting OOo from the system menu

Using the system menu is the most common way to launch OpenOffice.org. The 
system menu is the standard menu from which most applications are started. On 
Windows, it is called the Start menu. On GNOME, it is called the Applications 
menu. On KDE it is identified by the KDE logo. On Mac OS X, it is the 
Applications menu.

When OpenOffice.org was installed, a menu entry was added to your system menu. 
The exact name and location of this menu entry will depend on the graphical user 
interface. This chapter looks at Windows, GNOME and KDE on Linux, and Mac 
OS X). The concepts should easily be applicable to another operating system.

Windows
On Windows, the OpenOffice.org menu is located in Programs > OpenOffice.org 
2.0. See Figure 1. For example, to start Writer with a blank document, select 
OpenOffice.org 2.0 Writer.
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Starting OOo from the system menu

Figure 1: Starting OOo from the Windows Start menu

Linux/GNOME
GNOME installations will differ from one distribution to the next. Most modern 
distributions come with OpenOffice.org already installed. You will find 
OpenOffice.org under Applications > Office. See Figure 2.

Figure 2: Starting OOo from the GNOME Applications menu
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Starting OOo from the system menu

Fedora/Red Hat Enterprise Linux comes with OpenOffice.org installed. On the 
GNOME desktop, OOo can be found under Main Menu > Office. If you have 
installed a newer version of OOo, you will find it under Main Menu > Office > 
More Office Applications.

If OOo was downloaded from the http://www.openoffice.org website, OOo is under 
Applications > Other.

Linux/KDE
On KDE, OpenOffice.org is installed in its own menu, called “Office” (see Figure 3).

Figure 3: Starting OOo from the KDE start menu

Some Linux distributions install OpenOffice.org in the Office sub-menu. Mandrake 
is such a distribution. In this case, to launch Writer (for example), choose Office > 
Word processors > OpenOffice.org Writer. Figure 4 illustrates this.
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Starting OOo from the system menu

Figure 4: Starting OOo Writer from Mandrake's KDE menu.

Mac OS X
Go to the folder where you installed OpenOffice.org. You should see its icon in the 
Applications folder (Figure 5). To start OpenOffice.org, double-click its icon.

Figure 5: Starting OpenOffice.org from the Mac Applications folder
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Starting from an existing document

Starting from an existing document

You can start OOo automatically simply by double-clicking the filename of an OOo 
document in a file manager. The appropriate component of OOo will start and the 
document will be loaded.

Using the Quickstarter under Windows

The Quickstarter is an icon that is placed in the Windows system tray during system 
startup. It indicates that OpenOffice.org has been loaded and is ready to use. (The 
Quickstarter loads  library .DLL files required by OOo, thus shortening the startup 
time for OOo components by about half.)

Using the Quickstarter icon
Right-click the Quickstarter icon in the system tray to open a popup menu from 
which you can open a new document, open the Templates and Documents dialog, or 
choose an existing document to open. (See Figure 6.) You can also double-click the 
Quickstarter icon to display the Templates and Documents dialog.

Figure 6: Quickstarter popup menu

Disabling the Quickstarter
To close the Quickstarter, right-click on the icon in the system tray, and then click 
Exit Quickstarter on the popup menu. The next time the computer is restarted, the 
Quickstarter will be loaded again.
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Using the Quickstarter under Windows

To prevent OpenOffice.org from loading during system startup, deselect the Load 
OpenOffice.org During System Start-Up item on the popup menu. You might 
want to do this if your computer has insufficient memory, for example.

Reactivating the Quickstarter
If the Quickstarter has been disabled, you can reactivate it in these ways:

• Select the Load OpenOffice.org during system start-up checkbox in Tools > 
Options > OpenOffice.org > Memory.

• Activate the Quickstarter without restarting the system, by running the 
program quickstart.exe in the directory {installpath}\program.

Preloading OOo under Linux/KDE

In KDE/Linux, you can use KDocker to have OOo loaded and ready for use at 
startup. KDocker is not part of OOo; it is a generic “systray app docker” that is 
helpful if you open OOo often.

Starting from the command line

You may want to start OOo from the command line, because you have more control 
over what happens when OOo is started. For example, using the command line, you 
can tell Writer to load a document and print it immediately, or to start without 
showing the splash screen.

Note Most users will never need to do this.

There is more than one way to start OOo from the command line, depending on 
whether a customized version or  the standard download from the OpenOffice.org 
website has been installed.

If installation was using the downloads on the OpenOffice.org website, you can start 
Writer by typing at the command line:

     soffice -writer
or         swriter
Writer will start and create a new document. 
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Starting from the command line

Likewise, you can start other OOo components from the command line:

Type of documentType of document ComponentComponent Command-line optionCommand-line option

Text Writer -writer
Spreadsheet Calc -calc
Drawing Draw -draw
Presentation Impress -impress
Formula Math -math
Web page Writer -web

Below is a list of some of the more popular options.

OptionOption DescriptionDescription

-help Get a complete list of options.
-nologo Do not show the startup screen.
-show <sxi-file> Start presentation immediately.
-view <documents ...> Open documents in viewer (read-only) mode.
-minimized Start OOo minimized.
-norestore Suppress restart/restore after fatal errors.
-invisible No startup screen, no default document and 

no UI. This is useful for third-party 
applications that use functionality provided 
by OOo.
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Chapter 33
  File Management in 

OpenOffice.org

This chapter describes basic file management techniques and the file formats that 
OpenOffice.org can open, save to, and export to.

Opening files

To open an existing document, choose File > Open or click the Open File icon on 
the Standard Toolbar, or press Control+O.

The Open dialog appears. Choose the file, then click Open.

Note Under Microsoft Windows you can use either the OpenOffice.org Open 
and Save As dialogs or the ones provided by Microsoft Windows. See 
“Using the Open and Save As dialogs” on page 33.

File formats
OpenOffice.org can import Microsoft Office files. However, Microsoft Office 
cannot import files in the OpenDocument format used by OpenOffice.org. If you 
want to send a file to a Microsoft Office user, you must save it in a Microsoft Office 
format or in .rtf.  Below is a chart for quick reference.
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Opening files

OpenDocument typeOpenDocument type ApplicationApplication ExtensionExtension MS Office equivMS Office equiv

Text Writer odt doc

Text Template Writer ott dot

Master Document Writer odm doc

Spreadsheet Calc ods xsl

Spreadsheet Template Calc ots xst

Drawing Draw odg N/A

Drawing Template Draw otg N/A

Presentation Impress odp ppt

Presentation Template Impress otp pot

Formula Math odf N/A

Chart Chart odc N/A

Database Base odb mdb

Default file formats
OpenOffice.org saves files in the OpenDocument format by default unless told 
otherwise. This default can be changed, for example if you always want to save as 
Microsoft Office files. To change the default file formats:

1) Go to Tools > Options > Load/Save > General. (See Figure 7.)

2) In the Standard File Format section of this page, choose a document type 
(for example, “Text document”) and a file format from the Always Save As 
list.

3) Repeat for each document type as necessary.

4) Click OK to save your changes.

Notes If the option “Warn when not saving in OpenDocument or default 
format” is checked on the Options – Load/Save – General dialog 
(Figure 7), a warning dialog about potential loss of formatting may be 
displayed. In most cases, no loss of formatting will occur, so you may 
find this warning annoying and choose to disable it.
The Java Runtime Environment (JRE) is required to use the mobile 
device filters for AportisDoc (Palm), Pocket Word and Pocket Excel.
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Opening files

Figure 7. Choosing default formats for saving files

Opening text documents
In addition to OpenDocument formats (.odt and .ott), Writer 2.0 can open the format 
used by OOo 1.x (.sxw, .stw) and the following text document formats: 

Microsoft Word 6.0/95/97/2000/XP) (.doc, .dot) WordPerfect Document (.wpd)
Microsoft Word 2003 XML (.xml) WPS 2000/Office 1.0 (.wps)
Microsoft Winword 5 (.doc) DocBook (.xml)
StarWriter formats (.sdw, .sgl, .vor) Ichitaro 8/9/10/11 (.jtd, .jtt)
AportisDoc (Palm) (.pdb) Hangul WP 97 (.hwp)
Pocket Word (.psw) .rtf, .txt, .csv

When opening .htm or .html files (used for web pages), OpenOffice.org customizes 
Writer for working with these files.

Opening spreadsheets
In addition to OpenDocument formats (.ods and .ots), Calc 2.0 can open the format 
used by OOo 1.x (.sxc, .stc) and the following spreadsheet formats:

Microsoft Excel 97/2000/XP (.xls and .xlw) Rich Text Format (.rtf)
Microsoft Excel 97/2000/XP Template (.xlt) Text CSV (.csv and .txt)
Microsoft Excel 95 (.xls and .xlw) Lotus 123 (.wk1 and .wk1)
Data Interchange Format (.dif) StarCalc formats (.sdc, .vor)
dBase (.dbf) SYLK (.slk)
.htm and .html files including Web page queries Pocket Excel (pxl)
Quattro Pro 6.0 (.wb2)
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Opening presentations
In addition to OpenDocument formats (.odp and .otp), OpenOffice.org 2.0 Impress 
can open the format used by OO.o 1.x (.sxi, .sti) and the following presentation 
formats:

• Microsoft PowerPoint 97/2000/XP (.ppt, .pps, .pot)
• StarDraw, StarImpress (.sda, .sdd, .sdp, .vor)
• CGM – Computer Graphics Metafile (.cgm)

Opening graphic files
In addition to OpenDocument formats (.odg and .otg), Draw 2.0 can open the 
format used by OOo 1.x (.sxd .std) and the following graphic formats:

BMP JPEG, JPG PCX PSD SGV WMF
DXF MET PGM RAS SVM XBM
EMF PBM PLT SDA TGA XPM
EPS PCD PNG SDD TIF, TIFF
GIF PCT PPM SGF VOR

Opening formula files
In addition to OpenDocument Formula files, OpenOffice.org 2.0 can open the 
format used by OOo 1.x (.sxm), StarMath (.smf) and MathML (.mml) files.

When opening a Word document that contains an embedded equation editor object, 
if the option for it is checked in Tools > Options > Load/Save > Microsoft Office 
the object will be automatically converted to an OpenOffice.org Math object.

Saving files

To save a new file:

1) Choose File > Save As. 

2) When the Save As dialog appears, enter the file name and verify the file 
type (if applicable). 

To save an open document with the current file name, choose File > Save.  This will 
overwrite the last saved state of the file.
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Saving files

Password protection
To protect an entire document from being viewable without a password, there is an 
option on the Save As dialog to enter a password. This option is only available for 
files saved in OpenDocument formats or the older OpenOffice.org 1.x formats. 

1) On the Save As dialog, select the checkbox beside Save with password, 
and then click Save. You will receive a prompt:

2) Type the same password in the Password field and the Confirm field, and 
then click OK. If the passwords match, the document is saved password-
protected.  If the passwords do not match, you receive a prompt to enter the 
password again.

Note Passwords must contain a minimum of 5 characters. Until you have 
entered 5 characters, the OK button remains inactive.

Saving a document automatically
You can choose to have OpenOffice.org save files for you automatically. Automatic 
saving, like manual saving, will overwrite the last saved state of the file. To set up 
automatic file saving:

1) Choose Tools > Options > Load/Save > General. (See Figure 7.)

2) Mark Save AutoRecovery information every, and set the time interval.

Writer can save to these file formats
In addition to OpenDocument formats (.odt and .ott), Writer 2.0 can save in these 
formats:

• OpenOffice.org 1.x Text (.sxw)
• OpenOffice.org 1.x Text Template (.stw)
• Microsoft Word 6.0, 95, and 97/2000/XP (.doc)
• Microsoft Word 2003 XML (.xml)
• Rich Text Format (.rtf)
• StarWriter 3.0, 4.0, 5.0 Text (.sdw)
• StarWriter 3.0, 4.0, 5.0 Template (.vor)
• Text (.txt)
• Text Encoded (.txt)
• HTML (.html; .htm)
• DocBook (.xml)
• AportisDoc (Palm) (.pdb)
• Pocket Word (.psw)
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Note The .rtf format is a common format for transferring text files between 
applications but you are likely to experience loss of formatting and 
images. For this reason, other formats should be used.

Calc can save to these file formats
In addition to OpenDocument formats (.ods and .ots), Calc 2.0 can save in these 
formats:

• OpenOffice.org 1.x Spreadsheet (.sxc)
• OpenOffice.org 1.x Spreadsheet Template (.stc)
• Microsoft Excel 97/2000/XP (.xls and .xlw)
• Microsoft Excel 97/2000/XP Template (.xlt)
• Microsoft Excel 5.0, 95 (.xls and .xlw)
• Microsoft Excel 2003 XML (.xml)
• Data Interchange Format (.dif)
• dBase (.dbf)
• SYLK (.slk)
• Text CSV (.csv and .txt)
• StarCalc 3.0, 4.0, 5.0 formats (.sdc and .vor)
• HTML (.html, .htm)
• Pocket Excel (.pxl)

Note The Java Runtime Environment is required to use the mobile device 
filters for AportisDoc (Palm), Pocket Word and Pocket Excel.

Impress can save to these file formats
In addition to OpenDocument formats (.odp, .otp, .odg), Impress 2.0 can save in 
these formats:

• OpenOffice.org 1.x Impress (.sxi)
• OpenOffice.org 1.x Impress Template (.sti)
• Microsoft PowerPoint 97/2000/XP (.ppt and .pps)
• Microsoft PowerPoint 97/2000/XP Template (.pot)
• StarDraw, StarImpress (.sda, .sdd, .vor)

Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats 
as listed below for Draw.

Draw can save to these file formats
Draw can only save in the OpenDocument Drawing formats (.odg and .otg), the 
OpenOffice.org 1.x formats (.sxd and .std) and StarDraw format (.sda, .sdd, .vor). 
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However, it can export to BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, 
PNG, PPM, RAS, SVG, SVM, TIFF, WMF, and XPM.

Writer/Web can save in these formats
HTML document (.html and .htm)
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.0 HTML Template (.oth)
StarWriter/Web5.0 and 4.0 (.vor)
Text (OpenOffice.org Writer/Web) (.txt)
Text Encoded (OpenOffice.org Writer/Web) (.txt)

Exporting files

Export to XHTML
OpenOffice.org can export files to XHTML. Choose File > Export. On the Export 
dialog, select XHTML in the File format list.

Export to PDF
Each application can directly export to PDF. This industry-standard file format for 
file viewing is ideal for sending the file to someone else to view using Acrobat 
Reader or other PDF viewers.

You can export directly to PDF using a button on the toolbar  or by choosing 
File > Export to PDF. 

If you use File > Export to PDF, you are asked to enter the filename for the PDF 
file and then the PDF Options dialog (Figure 8) opens.

Note If you use the Export Directly as PDF button, you are asked to enter 
the filename for the PDF file, but you can not choose a page range or 
the image compression. 

28 Chapter 3  File Management in OpenOffice.org



Exporting files

PDF options

Figure 8. Specifying the PDF export options

Range
• All: Exports the entire document.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To 
export single pages, use the format 7;9;11 (pages 7, 9 and 11). 

Images
• Lossless compression:  Images are stored without any loss of quality. Tends 

to make large files when used with photographs. Recommended for other 
images.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% 
tends to work well with photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower DPI (dots per inch) images have lower 
quality.

General
• Tagged PDF: Includes special tags into the corresponding PDF tags. This 

can increase file sizes significantly. Some tags that are exported are table of 
contents, hyperlinks, and controls.
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• Export notes: Export notes of Writer and Calc documents as PDF notes.

• Use transition effects: Includes Impress slide transition effects in the 
respective PDF effects.

• Submit forms in format: Select the format of submitting forms from within 
the PDF file. There is only one common setting valid for the whole PDF 
document: PDF (sends the whole document), FDF (sends the control 
contents), HTML and XML.  Most will choose the PDF format.

Deleting and renaming files

You can rename or delete files within the OpenOffice.org dialogs, just as you can in 
your usual file manager. However, you cannot copy or paste files within the dialogs.

Renaming a file
To rename a file while using OpenOffice.org: 

1) Choose File > Open and browse to the required file. 
2) Right-click on the file name and choose Rename. The file name will be 

selected.
3) Typing replaces the selected name, or use a left or right arrow keys to move 

the insertion point to modify the existing name.

Deleting a file
To delete a file while using this dialog: 

1) Right-click on the file name to display a context menu. 
2) Click Delete and you will get a confirmation dialog. 

Note Instead of Right-click > Delete, you can simply press the Delete key.
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File associations

File associations are used to open certain types of files automatically with 
OpenOffice.org. You can choose to associate Microsoft Office files with OOo.  If 
you do this, the files remain as Microsoft Office files, but the icon for the files 
changes to the OOo icon and double-clicking on the icon opens the files in OOo. 
(You can still open the files in Microsoft Office by starting MS Office and then 
choosing File > Open.)

When installing OpenOffice.org you are prompted to associate file types, as shown 
in Figure 9. If you want to continue to open your Microsoft Office files in Office by 
double-clicking them, do not check these boxes. (You can open MS Office files in 
OOo by starting OOo and then choosing File > Open.) 

Figure 9. Choosing file associations when installing OpenOffice.org

If during installation you chose not to have OpenOffice.org automatically open 
Microsoft Word files, you can change this later by modifying the installation. To do 
this:

1) Go to the folder in which OpenOffice.org is installed and start Setup.exe.
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2) On the Program Maintenance page of the Installation Wizard, choose 
Modify and click Next.

3) Continue through the Installation Wizard until you reach the page shown in 
Figure 9. Select the file types you want OOo to open (put a mark in each 
checkbox) and click OK.

Creating new files

Different ways of creating a new document:

• Use File > New and choose the type of document.

• Use the arrow next to the New button on the main toolbar. A menu of 
choices (Figure 10) drops down; select the type of document to be created.

Figure 10. The New menu from the toolbar

• Use a “Quick start” program. For example, the Microsoft Windows version 

of OpenOffice.org has a Quickstart icon  in the system tray. (See the 
chapter titled “Starting OpenOffice.org” for more information on the 
Quickstart icon.)

• Press Control+N on the keyboard.
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• Use File > Wizard for some types of documents. (See Figure 11.)

Figure 11. Creating a file using a Wizard

Using the Open and Save As dialogs

If you are using Microsoft Windows, you can choose whether to use the 
OpenOffice.org Open and Save As dialogs or the ones provided by Windows. To 
view or change which type of dialog OpenOffice.org uses:

1) Choose Tools > Options > OpenOffice.org > General.

2) Select the Use OpenOffice.org dialogs checkbox.

This section discusses the OpenOffice.org Open and Save As dialogs. See Figure 12 
for an example of the OOo Open dialog.

The three buttons in the top right of the OOo Open dialog are, from left to right:

• Go up one level in the folder (directory) hierarchy. This is a long-click 
button if you want to go up higher than just one level.

• New folder (directory)

• Default Directory.
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Using the Open and Save As dialogs

Figure 12. The OOo Open dialog, showing some of the file formats that can be opened

For OpenOffice.org documents that have been saved with more than one version, 
use the version drop-down to select which version you wish to open in read-only 
mode.

Note For Microsoft Office documents, only the current version can be opened.

Use the File type field to specify the type of file to be opened or the format of the 
file to be saved.

The Read-only checkbox opens the file for reading and printing only. Consequently 
most of the toolbars disappear and most menu options are disabled. An Edit File 
button is displayed on the Function Toolbar to open the file for editing.

It is possible to open files from the web using URLs. 
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Chapter 44
  Menus and Toolbars

Menus

Menus are located across the top of the screen, just below the Title bar.  The main 
menu selections are File, Edit, View, Insert, Format, Table, Tools, Window, and 
Help. When you choose one of the menus, a submenu drops down to show other 
options.

Figure 13. Menu bar

• File contains commands that apply to the entire document such as Open, 
Save, and Export as PDF.

• Edit contains commands for editing the document such as Undo and Find 
& Replace.

• View contains commands for controlling the display of the document such 
as Zoom and  Web Layout.

• Insert contains commands for inserting elements into your document such 
as Headers, Footers, and Picture.

• Format contains commands, such as Styles and Formatting and 
AutoFormat, for formatting the layout of your document.

• Table shows all commands to insert and edit a table in a text document.

• Tools contains functions such as Spellcheck, Customize, and Options.

• Window contains commands for the display window.

• Help contains links to the Help file, What’s This help, and information 
about the version of OpenOffice.org you have installed. 
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Customizing the menu font
If you want to change the menu font:

1) Choose Tools > Options > OpenOffice.org Writer > Basic Fonts 
(Western).

2) Change the font settings and check Current Document Only if you wish 
the changes to apply for the current document.

Customizing menu content
It is possible to customize menus in OpenOffice.org.  To customize menus:

1) Choose Tools > Customize.

2) On the Customize dialog, pick the Menus tab (Figure 14). 

Figure 14. The Menus tab of the Customize dialog
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3) In OpenOffice.org Writer Menus, select the menu you want to customize 
in the Menu drop-down list.

4) You can customize each menu by using the Menu and Modify list buttons.

5) You can add commands in a menu by clicking on the Add button.

6) You can create a new menu by clicking on the New button.

Toolbars

The top toolbar (default position) is called the Standard Bar. The Standard Bar is 
consistent across the OpenOffice.org applications.

The second toolbar across the top (default location) is the Formatting Bar. The 
Formatting Bar is a context-sensitive bar which shows the relevant toolbars in 
response to the cursor’s current position or selection. For example, when the cursor 
is in a table, the formatting bar provides both a floating Table Bar and a Text Bar. 

Long-click buttons and tear-off toolbars
Buttons with a small black triangle will display submenus, tear-off toolbars, and 
other ways of selecting things with a long click, depending on the button.

Figure 15 shows the Paste submenu.

Figure 16 shows a tear-off toolbar 
from the main Draw toolbar.

The tear-off toolbars are always 
floating and cannot be docked on 
any edge. To move a tear-off toolbar, 
drag it by the title bar.
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Figure 16: Example of a tear-off toolbar

Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a 
toolbar in the list. An active toolbar shows a checkmark beside its name. 

Moving toolbars
To move a docked toolbar, place the mouse pointer over the toolbar handle, hold 
down the left mouse button and drag the toolbar to the new location. To move a 
floating toolbar, click on its title bar and drag it to a new location. Figure 17 shows 
examples.

To dock the toolbar in another area, place the mouse pointer over the toolbar handle, 
hold down the left mouse button and drag the toolbar to the new location, then 
release the mouse button. The toolbar will dock in the new location.

Customizing a toolbar
There are three main ways to get to the toolbar customization dialog:

• On the toolbar, click the arrow at the end of the toolbar and choose 
Customize Toolbar. 

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize from the menu bar. On the Toolbars tab (Figure
18), choose the toolbars you want to modify and click the Toolbar or 
Modify button. 
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Toolbars

Figure 17: Moving toolbars

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.

2) Click New. This will create a toolbar called “New Toolbar1”.

3) Customize the toolbar as above.

Note There is no in-built tool button editor. To use a custom icon, save it to the 
{install path}/share/config/symbol directory in *.bmp 
format. OOo automatically searches this directory for new icons each time 
the Customize Buttons dialog is opened. Custom icons must be 16 x 16 or 
26 x 26 pixels in size and cannot contain more than 256 colors.
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Toolbars

Figure 18. The Toolbars tab of the Customize window

Using dockable/floating windows

Some windows in OpenOffice.org are dockable.  You can move, re-size or dock 
them to an edge. To dock a window, do one of the following: 

• Click on the title bar of the floating window and drag it to the side until you 
see the outline of a box appear in the main window (see Figure 19), then 
release the window. This method depends on your system’s window 
manager settings, so it may not work for you.

• Hold down the Control key and double-click on a vacant part of the floating 
window to dock it in its last position. If that does not work, try double-
clicking without using the Control key.

To undock a window, hold down the Control key and double-click on a vacant part 
of the docked window.
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Figure 19: Docking a window

Using the Navigator

The Navigator displays all objects contained in a document. It provides a very 
convenient way to move around a document and find items in it. The Navigator 
button is located on the Standard Toolbar. You can also display the Navigator by 
choosing Edit > Navigator from the menu bar, or by pressing F5.

The Navigator (Figure 20) displays lists of Headings, Tables, Text frame, Graphics, 
Bookmarks and other items. Click the + sign by any of the lists to display the 
contents of the list.

If you only want to see the content in a certain category, highlight the category and 
click the Content View icon. 

Note The Navigator looks somewhat different in a master document. See the 
chapter on Master Documents in the Writer Guide for more details.
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Figure 20. The Navigator

Note The Navigator looks somewhat different in a master document. See the 
chapter on Master Documents in the Writer Guide for more details.

The Navigator helps you to reach objects quickly. Double-click on the object in the 
Navigator to jump directly to that object’s location in the document, as shown in 
Figure 21.

Figure 21. Using the Navigator to jump quickly to a heading in Writer
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Arranging chapters using the Navigator
You can arrange chapters and move headings in a Writer document by using the 
Navigator.

1) Click the Content View icon.

2) Click on the heading in question.

3) Drag the heading to a new location on the Navigator or click the heading in 
the Navigator list, then click Promote Chapter or Demote Chapter.
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  Setting up OpenOffice.org

Choosing options to suit the way you work

Choosing options that affect all of OOo

This section covers some of the settings that apply to all the components of OOo. 
For information on settings not discussed here, see the online help.

1) Click Tools > Options. The list in the left-hand box varies depending on 
which component of OOo is open. The illustrations in this chapter show the 
list as it appears when no document is open. (For example, when a Writer 
document is open, additional options for OpenOffice.org Writer and 
OpenOffice.org Writer/Web appear on the list.)

2) Click the + sign to the left of OpenOffice.org in the left-hand section. A list 
of subsections drops down.

Note The Back button has the same effect on all pages of the Options dialog. 
It resets the options to the values that were in place when you opened 
OpenOffice.org.

User Data options
Because OOo’s revision features mark your changes and comments with the name or 
initials stored in User Data, you will want to ensure that your name and initials 
appear there. To do this:

1) In the Options dialog, click OpenOffice.org > User Data. 
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2) Fill in the form on the OpenOffice.org User Data page, or delete any 
existing incorrect information.

Figure 22. Filling in user data

General options
1) In the Options dialog, click OpenOffice.org > General. 

2) On the OpenOffice.org – General page (Figure 23), the options are as 
described below.

Figure 23. Setting general options for OpenOffice.org 
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Help - Tips
When Help Tips are active, one or two words will appear when you hover the cursor 
over an icon or field on the main OOo window. This setting also affects the display 
of notes: if both Help Tips and Extended Tips are turned off, then you will not see 
the contents of a note when you hover the cursor on the note.

Help - Extended tips
When Extended tips are active, a brief description of the function of a particular 
icon or menu command, or a field on a dialog appears when you hover the cursor on 
that item.

Help Agent
To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this 
checkbox. To restore the default Help Agent behavior, click Reset Help Agent.

Help formatting
High contrast is an operating system setting that changes the system color scheme to 
improve readability. To display Help in high contrast (if your computer’s operating 
system supports this), choose one of the high-contrast style sheets from the list. 

Open/Save dialogs
To use the standard Open and Save dialogs for your operating system, deselect the 
Use OpenOffice.org dialogs checkbox. When this checkbox is selected, the Open 
and Save dialogs supplied with OpenOffice.org will be used. (See the “File 
Management” chapter for more about the OOo Open and Save dialogs.)

Document status
Choose whether printing a document counts as changing the document. If this option 
is selected, then the next time you close the document after printing, the print date is 
recorded in the document properties as a change and you will be prompted to save 
the document again, even if you did not make any other changes.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is 
set to 1930, and you enter a date of 1/1/30 or later into your document, the date is 
interpreted as 1/1/1930 or later. An “earlier” date is interpreted as being in the 
following century; that is, 1/1/20 is interpreted as 1/1/2020.
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Memory options
1) In the Options dialog, click OpenOffice.org > Memory.

2) On the OpenOffice.org – Memory dialog (Figure 24):

• More memory can make OpenOffice.org faster and more convenient 
(for example, more undo steps require more memory); but the trade-off 
is less memory available for other applications and you could run out of 
memory altogether.

• To load the Quickstarter (an icon on the desktop or in the system tray – 
Windows only) when you start your computer, select the checkbox near 
the bottom of the dialog. This makes OpenOffice.org start faster; the 
trade-off is OOo uses some memory when not being used. 

Figure 24. Choosing Memory options for the OpenOffice.org applications

View options
The choices of View options affect the way the document window looks and 
behaves.

1) In the Options dialog, click OpenOffice.org > View.

2) On the OpenOffice.org – View page (Figure 25), set the options to suit your 
personal preferences. Some options are described below.
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Figure 25. Choosing View options for the OpenOffice.org applications

User Interface - Scaling
If the text in the help files and on the menus of the OOo user interface is too small or 
too large, it can be changed by specifying a scaling factor. Sometimes a change here 
can have unexpected results, depending on the screen fonts available on your 
system. It does not affect the actual font size of the text.

User Interface – Icon size and style
The first box specifies the display size of toolbar icons (small, large or automatic); 
the Automatic option uses the icon size setting for your operating system. The 
second box specifies the icon set (theme); here the Automatic option uses an icon set 
compatible with your operating system and choice of desktop: for example, KDE or 
Gnome on Linux.

User Interface -  Use system font for user interface
If you prefer to use the system font (the default font for your computer and operating 
system), instead of the font provided by OOo, for the user interface, select this 
checkbox.

Menu - Show inactive menu items
Select this option if you want inactive menu items to be visible but grayed out. 
Deselect it to prevent inactive menu items from appearing on the menu.
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Font Lists - Show preview of fonts
When you select this option, the font list looks like Figure 26, left, with the font 
names shown as an example of the font; with the checkbox deselected, the font list 
shows only the font names, not their formatting (Figure 26, right). The fonts you will 
see listed are those that are installed on your system.

Figure 26. (Left) Font list showing preview; (Right) Font list without preview

Font Lists - Show font history
When you select this option, the last five fonts you have assigned to the current 
document are displayed at the top of the font list.

Restore – Editing view
Select this option if you want to open documents at the place the cursor was located 
when you previously closed the document. Deselect this option to always open 
documents at the first page.

Restore – Open windows
Select this option if you want any floating windows (such as the Navigator or  Styles 
and Formatting) that are open when you close OpenOffice.org to be restored when 
you restart it.

3D view
These options are for use with Draw and Impress. For more information, see the 
online help or other documentation on these applications.

Mouse
Use these options to choose how the mouse is positioned in newly opened dialogs 
and to select the function of the middle mouse button.
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Print options
Set the print options to suit your default printer and your most common printing 
method. You can change these settings at any time, either through this dialog or 
during the printing process (by clicking the Options button on the Print dialog).

1) In the Options dialog, click OpenOffice.org > Print.

2) On the OpenOffice.org – Print dialog (Figure 27), look at the Printer 
warnings section near the bottom. 

3) Here you can choose whether to be warned if the paper size or orientation 
specified in your document does not match the paper size or orientation 
available for your printer. Having these warnings turned on can be quite 
helpful, particularly if you work with documents produced by people in 
other countries where the standard paper size is different from yours.

Figure 27. Choosing general printing options to apply to all OOo components

Tip If your printouts are coming out incorrectly placed on the page or 
chopped off at the top, bottom, or sides, or the printer is refusing to 
print, the most likely cause is page size incompatibility.
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Path options
You can change the location of files associated with, or used by, OpenOffice.org to 
suit your working situation. In a Windows system, for example, you might want to 
store documents by default somewhere other than My Documents.

1) In the Options dialog, click OpenOffice.org > Paths.

2) To make changes, select an item in the list shown in Figure 28 and click 
Edit. On the Select Paths dialog (not shown), add or delete folders as 
required, and then click OK to return to the Options dialog. Note that many 
items have at least two paths listed: one to a shared folder (which might be 
on a network) and one to a user-specific folder (normally on the user’s 
personal computer).

Tip You can use the entries in the OpenOffice.org – Paths dialog to compile 
a list of files, such as those containing AutoText, that you need to back 
up or copy to another computer.

Figure 28. Viewing the paths of files used by OpenOffice.org 

Color options
In the OpenOffice.org – Colors dialog (Figure 29), you can specify colors to use in 
OOo documents. You can select a color from a color table, edit an existing color, or 
define new colors. These colors will then be available in color selection palettes in 
OOo.
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Figure 29. Defining colors to use in color palettes in OOo

Font options
You can define replacements for any fonts that might appear in your documents. If 
you receive from someone else a document containing fonts that you do not have on 
your system, OpenOffice.org will substitute fonts for those it does not find.  You 
might prefer to specify a different font from the one the program chooses.

1) In the Options dialog, click OpenOffice.org > Fonts.

2) On the OpenOffice.org – Fonts dialog (Figure 30):

• Select the Apply Replacement Table checkbox.

• Select or type the name of the font to be replaced in the Font box. (If 
you don’t have this font on your system, it will not appear in the drop-
down list in this box, so you need to type it in.)

• In the Replace with box, select a suitable font from the drop-down list 
of fonts installed on your computer.

3) The checkmark to the right of the Replace with box turns green. Click on 
this checkmark. A row of information now appears in the larger box below 
the input boxes. Select the checkboxes under Always and Screen.

4) In the bottom section of the dialog, you can change the typeface and size of 
the font used to display source code such as HTML and Basic (in macros).
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Figure 30. Defining a font to be substituted for another font

Security options
Use the OpenOffice.org – Security page (Figure 31) to choose security options for 
saving documents and for opening documents that contain macros.

Figure 31. Choosing security options for opening and saving documents

Chapter 5  Setting up OpenOffice.org 53



Choosing options that affect all of OOo

Appearance options
Writing, editing, and page layout are often easier to do when you can see as much as 
possible of what is going on in your document. You may wish to make visible such 
items as text, table, and section boundaries (in Writer documents), page breaks in 
Calc, and grid lines in Draw or Writer. In addition, you might prefer different colors 
(from OOo’s defaults) for such items as note indicators or field shadings.

On the OpenOffice.org – Appearance page (Figure 32), you can specify which items 
are visible and the colors used to display various items.

1) In the Options dialog, click OpenOffice.org > Appearance.

2) To show or hide items such as text boundaries, select or deselect the 
checkboxes next to the names of the items.

To change the default colors for items, click the down-arrow in the Color 
Setting column by the name of the item and select a color from the pop-up 
box.

3) To save your color changes as a color scheme, click Save, type a name in 
the Scheme box; then click OK.

Figure 32. Showing or hiding text, object, and table boundaries
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Accessibility options
Accessibility options include whether to allow animated graphics or text, how long 
help tips remain showing, some options for high contrast display, and a way to change 
the font for the user interface of the OpenOffice.org program (see Figure 33).

1) In the Options dialog, click OpenOffice.org > Accessibility.

2) Select or deselect the options as required.

Figure 33. Choosing accessibility options

Java options
If you install or update a Java Runtime Environment (JRE) after you install 
OpenOffice.org, or if you have more than one JRE installed on your computer, you 
can use the Java options page (Figure 34) to choose the JRE for OOo to use.

If you are a system administrator, programmer, or other person who customizes JRE 
installations, you can use the Parameters and Class Path pages (reached from the 
Java page) to specify this information.

1) In the Options dialog, click OpenOffice.org > Java.

2) If you do not see anything listed in the middle of the page, wait a few 
minutes while OOo searches for JREs on the hard disk.

3) If OOo finds one or more JREs, it will display them there. You can then 
select the Use a Java runtime environment checkbox and (if necessary) 
choose one of the JREs listed.
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Figure 34. Choosing a Java runtime environment

Choosing options for loading and saving 
documents

You can set the Load/Save options to suit the way you work.

General Load/Save options
1) If the Options dialog is not already open, click Tools > Options. Click the + 

sign to the left of Load/Save.

2) Choose Load/Save > General.

Most of the choices on the Options – Load/Save – General dialog (Figure 35) are 
familiar to users of other office suites. Some items of interest are described below.

Load user-specific settings with the document
When you save a document, certain settings are saved with it. For example, your 
choice (in the options for OOo Writer) of how to update links is affected by the 
Load user-specific settings option. Some settings (printer name, data source linked 
to the document) are always loaded with a document, whether or not this checkbox 
is selected.

If you select this option, these document settings are overruled by the user-specific 
settings of the person who opens it. If you deselect this option, users’ personal 
settings do not overrule the settings in the document. 
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Figure 35. Choosing Load and Save options

Edit document properties before saving
When you select this option, the Document Properties dialog pops up to prompt you 
to enter relevant information the first time you save a new document (or whenever 
you use Save As).

Save AutoRecovery information every
Note that AutoRecovery in OpenOffice.org overwrites the original file. If you have 
also chosen Always create backup copy, the original file then overwrites the backup 
copy.  If you have this set, recovering your document after a system crash will be 
easier; but recovering an earlier version of the document may be harder.

Size optimization for XML format (no pretty printing)
OpenOffice.org documents are XML files. When you select this option, OOo writes 
the XML data without indents and line breaks. If you want to be able to read the 
XML files in a text editor in a structured form, deselect this option.

Default file format
If you routinely share documents with users of Microsoft Word, you might want to 
change the Always save as attribute for text documents in the Standard file format 
section to one of the Word document types.
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VBA Properties Load/Save options
1) Choose Load/Save > VBA Properties. 

2) On the Options – Load/Save – VBA Properties dialog (Figure 36), you can 
choose whether to keep any macros in MSOffice documents that are opened 
in OOo.

• If you choose Save original Basic code, the macros will not work in 
OOo but are retained if you save the file into Microsoft Office format. 

• If you choose Load Basic code to edit, the changed code is saved in an 
OOo document but is not retained if you save into an MSOffice format.

Figure 36. Choosing Load/Save VBA Properties

Microsoft Office Load/Save options
1) Choose Load/Save > Microsoft Office.

2) On the Options – Load/Save – Microsoft Office dialog (Figure 37), you can 
choose what to do when importing and exporting Microsoft Office OLE 
objects (linked or embedded objects or documents such as spreadsheets or 
equations).

Select the [L] checkboxes to convert Microsoft OLE objects into the 
corresponding OpenOffice.org OLE objects when a Microsoft document is 
loaded into OOo (mnemonic: “L” for “load”).

Select the [S] checkboxes to convert OpenOffice.org OLE objects into the 
corresponding Microsoft OLE objects when a document is saved in a 
Microsoft format (mnemonic: “S” for “save”).
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Figure 37. Choosing Load/Save Microsoft Office options

HTML compatibility Load/Save options
Choices made on the Load/Save – HTML Compatibility dialog (Figure 38) affect 
HTML pages imported into OpenOffice.org and those exported from OOo.

Figure 38. Choosing HTML compatibility options
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Choosing language settings

You may need to do several things to set the language settings to what you want:

• Install the required dictionaries

• Change some locale and language settings

• Choose spelling options

Install the required dictionaries
OOo 2.0 automatically installs several dictionaries with the program. To add other 
dictionaries, use File > Wizards > Install new dictionaries. An OOo document will 
open with links to different languages that you can install. Follow the prompts to 
install them.

Change some locale and language settings
You can change some details of the locale and language settings that OOo uses for 
all documents, or for specific documents.

1) In the Options dialog, click Language Settings > Languages.

2) On the right-hand side (as shown in Figure 39), change the Locale setting, 
Default currency, and Default languages for documents as required. In the 
example, English (Australia) has been chosen as the locale setting, and the 
Australian dollar (AUD) for the default currency. Although an English 
(Australia) dictionary exists, the English (UK) dictionary has been selected 
in the Default languages for documents.

3) If you want the language (dictionary) setting to apply to the current 
document only, instead of being the default for all new documents, select the 
checkbox labelled For the current document only.

4) If necessary, select the checkboxes to enable support for Asian languages 
(Chinese, Japanese, Korean) and support for CTL (complex text layout) 
languages such as Hindi, Thai, Hebrew, and Arabic. If you choose either of 
these checkboxes, the next time you open this dialog, you will see some 
extra choices under Language Settings, as shown in Figure 40. These 
choices (Searching in Japanese, Asian Layout, and Complex Text Layout) 
are not discussed here.

5) Click OK to save your changes and close the dialog.
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Figure 39. Choosing language options

Figure 40. Extra language setting choices when enhanced language support options are 
selected

Choose spelling options
To choose the options for checking spelling:

1) In the Options dialog, click Language Settings > Writing Aids.

2) In the Options section of the Language Settings – Writing Aids dialog 
(Figure 41), choose the settings that are useful for you. Some considerations:
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• If you do not want spelling checked while you type, deselect Check 
spelling as you type and select Do not mark errors. (To find the second 
item, scroll down in the Options list.)

• If you use a custom dictionary that includes words in all uppercase and 
words with numbers (for example, AS/400), select Check uppercase 
words and Check words with numbers.

• Check special regions includes headers, footers, frames, and tables 
when checking spelling.

• Here you can also check which user-defined (custom) dictionaries are 
active by default, and add or remove dictionaries, by clicking the New 
or Delete buttons. 

Figure 41. Choosing languages, dictionaries, and options for checking spelling

Internet options
Use the Internet Options pages to define search engines and save proxy settings for 
use with OpenOffice.org. If you are using a Netscape or Mozilla browser (such as 
Firefox), you can enable the Mozilla Plug-in so you can open OOo files in your 
browser, print them, save them, and work with them in other ways.
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Controlling OOo’s AutoCorrect functions

Some people find some or all of the items in OOo’s AutoCorrect function annoying 
because they change what you type when you do not want it changed. Many people 
find some of the AutoCorrect functions quite helpful; if you do, then select the 
relevant checkboxes. But if you find unexplained changes appearing in your 
document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect. (You need to have a 
document open for this menu item to appear.)

In Writer, this dialog has five tabs, as shown in Figure 42. In other components of 
OOo, where the dialog has only four tabs, the contents of the Options tab is as 
shown in Figure 43.

Figure 42. The AutoCorrect dialog in Writer, showing the five tabs and some of the choices
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Figure 43. The AutoCorrect dialog in Calc, showing four tabs and the Options choices
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  Getting Started with Writer

OpenOffice.org's Word Processor

Writer is the word processor component of OpenOffice.org (OOo). In addition to the 
usual features of a word processor (spell checking, thesaurus, hyphenation, 
autocorrect, find and replace, automatic generation of tables of contents and indexes, 
mail merge and others), Writer provides these important features:

• Templates and styles

• Powerful page layout methods, including frames, columns, and tables

• Embedding or linking of graphics, spreadsheets, and other objects

• Built-in drawing tools

• Master documents

• Change tracking during revisions

• Database integration, including a bibliography database

• Export to PDF, including bookmarks

• And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 44. The menus and toolbars are 
described in the chapter titled “Menus and Toolbars” in this book.

Other features of the Writer interface are covered in this chapter.
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Figure 44: The main Writer workspace in Print Layout view

Changing document views

Writer has several ways to view a document: Print Layout, Web Layout, Full Screen, 
and Zoom. To access these choices, go to the View menu. The only document view 
option with a submenu is Zoom. 

Creating a new document

You can create a new, blank document in Writer in a number of ways:

• Press the Control+N keys. When you press Control+N, you get a new empty 
document . If you already have a document open, the new document appears 
in a new window.

• Use File > New > Text Document. The result is similar to using the 
Control+N keystroke.

• Click the New button on the main toolbar .
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Creating a document from a template
You can use templates to create new documents in Writer. Templates serve as the 
foundation of a series of documents, making sure they all have a similar layout. For 
example, all the documents of this User Guide are based on the same template. By 
doing this, all the documents look alike; they have the same headers and footers, use 
the same fonts, and so on.

Unfortunately, a brand-new OpenOffice.org installation does not contain many 
templates. It is possible for you to add new templates to your installation and use 
them for new documents. This is explained in the chapter titled “Working with 
Templates”.  Many more templates can be downloaded from the internet.

Once you do have templates on your system, you can create new documents based 
on them by using File > New > Templates and Documents. This opens a window 
where you can choose the template you want to use for your document.

The example shown in Figure 45 uses a template called “book” in the My Templates 
folder. Select it, then click the Open button. A new document is created based on the 
formats defined in the template.

Figure 45. Creating a document from a template
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Saving a document

Save Writer documents the same way you save other documents. For more 
information, see the chapter titled “File Management”.

Saving as a Microsoft Word document
You may need to share your documents with other people who do not use OOo, but 
use Microsoft Word instead. Fortunately, OOo can read and write Word files. To 
save a document as a Microsoft Word file:

1) First save your document in OOo’s format (.ODT). If you do not, any 
changes you made since the last time you saved will only appear in the 
Microsoft Word version of the document.

2) Then click File > Save As. The Save As window (Figure 46) appears.

3) In the Save as type drop-down menu, select the type of Word format you 
need.

4) Click Save.

From this point on, all changes you make to the document will occur only in 
the Microsoft Word document. You have actually changed the name of your 
document. If you want to go back to working with the OOo version of your 
document, you must open it again.

TIP To have OOo save documents by default in the Microsoft Word file 
format, go to Tools > Options > Load/Save. There is a section named 
“Default file format”. Under “Document Type”, select “Text Document”, 
then under “Always save as”, select the preferred file format. 
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Figure 46. Saving a file in Microsoft Word format

Working with text

Working with text (selecting, copying, pasting, moving) in Writer is similar to 
working with text in any other program. OOo also has some convenient ways to 
select items that are not next to each other, move paragraphs quickly, and paste 
unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 47) using the mouse:

1) Select the first piece of text.

2) Hold down the Control key and use the mouse to select the next piece of 
text.

3) Repeat as often as needed.
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4) Now you can work with the selected text (copy it, delete it, change the style, 
or whatever).

Note Macintosh users: substitute the Command key when instructions in this 
chapter say to use the Control key.

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection 
of text, see the topic “Navigating and selecting with the keyboard” in the 
Help.)

2) Press Shift+F8. This puts Writer in “ADD” mode. The word ADD appears 
on the status bar.

3) Use the arrow keys to move to the start of the next piece of text to be 
selected. Hold down the Shift key and select the next piece of text.

4) Repeat as often as needed.

5) Now you can work with the selected text.

6) Press Esc to exit from this mode.

Figure 47: Selecting items that are not next to each other
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Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text in other 
applications. You can use the mouse or the keyboard for these operations.

Cut: Use Edit > Cut or the keyboard shortcut Control+X or the Cut icon on 
the toolbar.

Copy: Use Edit > Copy or the keyboard shortcut Control+C or the Copy 
icon.

Paste: Use Edit > Paste or the keyboard shortcut Control+V or the Paste icon.

If you simply click on the Paste icon, any formatting the text has (such as bold or 
italics) is retained. To make the pasted text take on the formatting of the surrounding 
text where it is being pasted, click the triangle to the right of the Paste icon and 
select Unformatted text from the menu (Figure 48).

Figure 48: Paste menu

Moving paragraphs quickly
1) Put the cursor anywhere in the paragraph.

2) Press and hold the Control key and then press the up-arrow or down-arrow 
key.

The paragraph will move to before the previous paragraph or after the next 
paragraph in your document. To move more than one paragraph at a time, select at 
least part of both paragraphs before pressing the Control+arrow keys.

If you are using the Solaris operating system, the key combination is 
Control+AltGr+arrow keys.

TIP If your paragraphs suddenly jump from one place to another, the most 
likely reason is that you have accidentally pressed one of these key 
combinations.
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Finding and replacing text and formatting
Writer has a Find and Replace feature that automates the process of searching for 
text inside a document. In addition to finding and replacing words and phrases, you 
can:

• Use regular expressions (wildcards) to fine-tune a search (see the Help for 
details).

• Find and replace specific formatting (see the Writer Guide for more 
information).

• Find and replace paragraph styles (see the Writer Guide for more 
information).

To display the Find & Replace dialog (Figure 49), use the keyboard shortcut 
Control+F or select Edit > Find & Replace. 

1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the Replace with 
box.

3) You can select various options such as matching the case, matching whole 
words only, or doing a search for similar words. (See below for some other 
choices.)

4) When you have set up your search, click Find. To replace text, click 
Replace instead. 

TIP If you click Find All, OOo selects all instances of the search text in the 
document. Similarly, if you click Replace All button, OOo will replace 
all matches. 

Caution Use Replace All with caution; otherwise, you may end up with 
some hilarious (and highly embarrassing) mistakes. A mistake with 
Replace All might require a manual, word by word, search to fix.
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Figure 49: Expanded Find & Replace dialog

Inserting special characters
A “special” character is one not found on a standard English keyboard. For example, 
© ¾ æ ç ñ ö ø ¢ are all special characters. To insert a special character:

1) Place the cursor where you want the character to appear.

2) Click Insert > Special Character to open the Special Characters window 
(Figure 50).

3) Select the characters you wish to insert, in order, then click OK. The 
selected characters are shown in the lower left of the dialog. As you select a 
character, it is shown on the lower right, along with its numerical code.

Note Different fonts include different special characters. If you do not find a 
particular special character, try changing the Font selection.
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Figure 50: The Special Characters window, where you can  insert special characters.

TIP Notice that the characters selected appear in the bottom-left corner of 
the window.

Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any that you have defined. 
To set the measurement unit and the spacing of default tab stops, go to Tools > 
Options > OpenOffice.org Writer > General.

You can also set or change the measurement unit by right-clicking on the ruler to 
open a list of units, as shown in Figure 51. Click on one of them to change the ruler 
to that unit.

Figure 51: Ruler showing default tab stops

Double-click on a blank part of the ruler to open 
the Indents & Spacing tab of the Paragraph 
dialog. Double-click on the ruler itself to open 
the Tabs tab of the Paragraph dialog and fine-
tune tab stop settings. 
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Checking spelling
Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a wavy red line 
under any misspelled words. Once the word is corrected, the line disappears.

 To perform a separate spelling check on the document (or a text selection) 
click the Spellcheck button. This checks the document or selection and opens 
the Spellcheck dialog if any misspelled words are found.

Here are some more features of the spelling checker:

• You can change the dictionary language (for example, to Spanish, French or 
German) on the Spellcheck dialog.

• You can add a word to the dictionary. Click Add in the Spellcheck dialog 
and pick the dictionary to add it to.

• The Options dialog of the Spellcheck tool has a number of different options 
such as whether to check uppercase words and words with numbers. It also 
allows you to manage custom dictionaries, that is, add or delete dictionaries, 
and add or delete words in a dictionary.

• On the Font tab of the Paragraph Styles dialog, you can set paragraphs to be 
checked in a specific language (different from the rest of the document). See 
the “Working with Styles” chapter in the Writer Guide for more information.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing 
errors, which it corrects automatically. For example, “hte” will be changed to “the”. 
Select Tools > AutoCorrect to open the AutoCorrect dialog. There you can define 
which strings of text are corrected and how. In most cases, the defaults are fine.

TIP AutoCorrect is turned on by default. To turn it off, uncheck Format > 
AutoFormat > While Typing.

• To stop Writer replacing a specific spelling, use Tools > AutoCorrect > 
Replace, highlight the word pair and click Delete.

• To add a new spelling to correct, type it into the Replace and With boxes and 
click New.

• See the different tabs of the dialog box for the wide variety of other options 
available to fine-tune AutoCorrect.
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TIP AutoCorrect can be used as a quick way to insert special characters. For 
example, (c)  will be autocorrected to ©. You can add your own special 
characters.

Using word completion
If Word Completion is enabled, Writer tries to guess which word you are typing and 
offers to complete the word for you. To accept the suggestion, press Enter. 
Otherwise continue typing.

TIP Many people prefer not to use Word Completion. If you don’t want to 
use it, select Tools > AutoCorrect > Word Completion and uncheck 
Enable Word Completion.

You can customize word completion from the Tools > AutoCorrect > Word 
Completion tab:

• Add (append) a space automatically after an accepted word.

• Show the suggested word as a tip (hovering over the word) rather than 
completing the text as you type.

• Change the maximum number of words remembered for word completion 
and the length of the smallest words to be remembered.

• Delete specific entries from the word completion list.

• Change the key that accepts a suggested entry—the options are Right arrow, 
End key, Return (Enter), and Space bar.

Note Automatic word completion only occurs after you type a word for the 
second time in a document.

Using AutoText
AutoText allows you to assign text, tables, graphics and other items to a key 
combination. For example, rather than typing “Senior Management” every time you 
use that phrase, you might just type “sm” and press F3. Or you can save a formatted 
Note (like the one on this page) as AutoText and then insert a copy by typing “note” 
and pressing F3. 
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To assign some text to an AutoText shortcut:
1) Type the text into your document.
2) Select the text so it is highlighted.
3) Select Edit > AutoText (or press Control+F3).
4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, 

which you can change.
5) Click the AutoText button on the right and select New (text only) from the 

menu.
6) Click Close to return to your document.

TIP If the only option under the AutoText button is Import, either you have 
not entered a name for your AutoText or there is no text selected in the 
document.

AutoText is especially powerful when assigned to fields. See the chapter “Working 
with Fields” in the Writer Guide for more information.

Inserting dashes and non-breaking spaces
You can insert a dash by using the Special Characters window or by using 
AutoCorrect. (For more about AutoCorrect, see “Controlling OOO’s AutoCorrect 
functions” in Chapter 5, “Setting up OpenOffice.org” and “Using AutoCorrect” on 
page 75 in this chapter).

– is an en-dash; that is, a dash the width of the letter “n” in the font you are using. 
It is U+2013 (scroll down to the General Punctuation section in the Special 
Characters window). To enter an en-dash using AutoCorrect, type at least one 
character, a space, two hyphens, another space, and at least one more letter, then 
a space. The two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are 
using. It is U+2014. To enter it using AutoCorrect, type at least one character, 
two hyphens, and at least one more character, then a space. The two hypens will 
be replaced by an em-dash.

To insert a non-breaking space (to keep characters together, for example in a 
telephone number), press Control+Space on the keyboard.
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Using styles
Styles are central to using Writer. Styles enable you to easily format your document 
consistently, and to change the format with minimal effort. Often, when you format 
your document in Writer, you are using styles whether you realize it or not. A style is 
a named set of formatting options. Writer defines several types of styles, for 
different types of elements: characters, paragraphs, pages, frames, and lists. The use 
of styles is described in detail in the chapters titled “Introduction to Styles” and 
“Working with Styles” in the Writer Guide.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the Formatting 
toolbar. Figure 52 shows the Formatting toolbar as a floating toolbar, customized to 
show only the buttons for paragraph formatting.

TIP It is highly recommended that you use paragraph styles rather than 
manually formatting paragraphs, especially for long or standardized 
documents. For information on the advantages of styles, and how to use 
them, see the chapter titled “Working with Styles”in this book and the 
chapters on styles in the Writer Guide.

Figure 52: Formatting toolbar, showing buttons for paragraph formatting

Figure 53 shows examples of the different alignment options.
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Figure 53: Different text alignment options

Formatting characters
You can apply many formats to characters using the buttons on the Formatting 
toolbar. Figure 54 shows the Formatting toolbar as a floating toolbar, customized to 
show only the buttons for character formatting.

TIPs It is highly recommended that you use character styles rather than 
manually formatting characters. For information on the advantages of 
styles, and how to use them, see the chapter titled “Introduction to Styles” 
in the Writer Guide.
To remove manual formatting, select the text and click Format > Default 
Formatting, or right-click and select Default Formatting from the pop-
up menu.

Figure 54: Formatting toolbar, showing buttons for character formatting

Autoformatting
You can set Writer to automatically format parts of a document according to the 
choices made on the Options page of the AutoCorrect dialog (Tools > AutoCorrect 
> Options).

TIP If you notice unexpected formatting changes occurring in your document, 
this is the first place to look for the cause. 

Chapter 6  Getting Started with Writer 79



Formatting text

Some common unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) 
or equal signs (===) on a line and then press Enter, the paragraph is 
replaced by a horizontal line as wide as the page. The line is actually the 
lower border of the preceding paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a 
hyphen (-), star (*), or plus sign (+), followed by a space or tab at the 
beginning of a paragraph. A numbered list is created when you type a 
number followed by a period (.), followed by a space or tab at the beginning 
of a paragraph. Automatic numbering is only applied to paragraphs 
formatted with the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, go to Format > AutoFormat and select or delete 
the items on the submenu.

Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.

• Use list (numbering) styles, as described in the chapter titled “Working with 
Styles” in the Writer Guide.

• Use the Numbering and Bullets icons on the paragraph formatting toolbar 
(see Figure 55). This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list, and then 
click the appropriate icon on the toolbar.

Note It is a matter of personal preference whether you type your information 
first, then apply Numbering/Bullets, or apply them as you type. 

Using the Bullets and Numbering toolbar
You can create nested lists (where one or more list items has a sublist under it, as in 
an outline) by using the buttons on the Bullets and Numbering toolbar (Figure 55). 
You can move items up or down the list, or create subpoints, and even change the 
style of bullets. Use View > Toolbars > Bullets and Numbering to see the toolbar.
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Figure 55: Bullets and Numbering toolbar

Hyphenating words
To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window (Figure 56). 

2) On the Paragraph Styles page of the Styles and Formatting window, right-
click on Default and select Modify.

3) On the Paragraph Style dialog, go to the Text Flow tab (see Figure 57).

4) Under Hyphenation, select or deselect the Automatically checkbox. Click 
OK to save.

Note Turning on hyphenation for the Default paragraph style affects all other 
paragraph styles that are based on Default. You can individually change 
other styles so that hyphenation is not active; for example, you might not 
want headings to be hyphenated. Any styles that are not based on Default 
are not affected. For more on paragraph styles, see the chapters titled 
“Introduction to Styles” and “Working with Styles” in the Writer Guide.
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Figure 56: Modifying a style

Figure 57: Turning on automatic hyphenation

You can also set hyphenation choices through Tools > Options > Language 
Settings > Writing Aids. In Options, near the bottom of the dialog, scroll down to 
the find the hyphenation settings (see Figure 58).

Figure 58: Setting hyphenation options
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Notes Hyphenation options set on the Writing Aids dialog are effective only if 
hyphenation is turned on through paragraph styles.
Choices on the Writing Aids dialog for “characters before line break” 
and “characters after line break” override settings in paragraphs styles 
for “characters at line end” and “characters at line begin”. This is a 
bug.

To enter a conditional hyphen inside a word, press Control+minus sign. The word is 
hyphenated at this position when it is at the end of the line, even if automatic 
hyphenation for this paragraph is switched off.

To insert a non-breaking hyphen, press Control+Shift+minus sign.

Undoing and redoing changes

To undo the most recent change, press Control+Z, or click the Undo icon  on 
the Standard toolbar, or select Edit > Undo from the menu bar. 

The Edit menu shows the latest change that can be undone, as shown in Figure 59.

Figure 59: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all the changes 
that can be undone (Figure 60). You can select multiple changes and undo them at 
the same time.

Figure 60: List of actions that can be undone
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After changes have been undone, Redo becomes active. To redo a change, select 
Edit > Redo, or press Control+Y or click on the Redo icon . 

As with Undo, click on the triangle to the right of the arrow to get a list of the 
changes that can be reapplied.

To modify the number of changes OpenOffice.org remembers, select Tools > 
Options > OpenOffice.org > Memory and change Undo number of steps. Be 
aware that asking OOo to remember more changes consumes more computer 
memory.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

1) Make your changes to a copy of the document (stored in a different folder, 
or under a different name, or both), then use Writer to combine the two files 
and show the differences. Click Edit > Compare Document. This 
technique is particularly useful if you are the only person working on the 
document, as it avoids the increase in file size and complexity caused by the 
other methods.

2) Save versions that are stored as part of the original file. However, this 
method can cause problems with documents of non-trivial size or complexity, 
especially if you save a lot of versions. Avoid this method if you can.

3) Use Writer’s change marks (often called “redlines” or “revision marks”) to 
show where you have added or deleted material, or changed formatting. 
Later, you or another person can review and accept or reject each change.

TIP Not all changes are recorded. For example, changing a tab stop from 
align left to align right, and changes in formulas (equations) or linked 
graphics are not recorded.

Recording changes
See the chapter titled “Setting up Writer” in the Writer Guide for instructions on 
setting up how changes will be displayed.

1) To begin tracking (recording) changes, click Edit > Changes > Record.

To show or hide the display of changes, click Edit > Changes > Show. 
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TIP Hover the mouse pointer over a marked change; you will see a Help Tip 
showing the type of change, the author, date, and time of day for the 
change. If Extended Tips are enabled, you will also see any comments 
recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the 
change and then click Edit > Changes > Comment. (See Figure 61.) In 
addition to being displayed as an extended tip, the comment is also 
displayed in the list in the Accept or Reject Changes dialog.

You can move from one marked change to the next by using the arrow 
buttons. If no comment has been recorded for a change, the Text field is 
blank.

3) To stop recording changes, click Edit > Changes > Record again.

Figure 61: Inserting a comment during change recording

Inserting notes
To insert a note that is not associated with a recorded change:

1) Place the cursor at the text you want to comment on, then click Insert > 
Note.

2) On the Insert Note dialog (Figure 62), type your note. Click Author to insert 
your initials and the date and time.
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Figure 62: Inserting a note

To view a note, move the mouse pointer over the note marker (displayed as a small 
yellow rectangle). Writer displays the note in a Tip above the text. You can also 
double-click on the note to see it inside the Edit Note dialog. If you have trouble 
viewing or selecting notes this way, you can use the Navigator instead: expand the 
list of notes, select the one you want, right-click on it, and select Edit to display the 
Edit Note dialog.

The Edit Note dialog looks much like the Insert Note dialog, with the addition of 
forward and back arrow buttons if the document contains more than one note.

TIP You can change the color of the note marker using the Tools > Options 
> OpenOffice.org > Appearance dialog.

Accepting or rejecting changes and comments
1) Click Edit > Changes > Accept or Reject. The Accept or Reject Changes 

dialog (Figure 63) opens.

2) When you select a change in the dialog box, the actual text is highlighted in 
the document, so you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also 
click Accept All or Reject All if you do not want to review the changes 
individually.
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Figure 63: The List tab of the Accept or Reject Changes dialog

Changes that have not yet been accepted or rejected are displayed in the list. 
Accepted changes are removed from the list and appear in the text without any 
marking.

To show only the changes of certain people, or only the changes made on specific 
days, or various other restrictions, use the Filter tab on the Accept or Reject Changes 
dialog. After specifying the filter criteria, return to the List tab to see 
those changes that meet your criteria.

Formatting pages

Writer provides several ways for you to control page layouts: 

• Page styles
• Columns
• Frames
• Tables
• Sections

For more information, see the chapter titled “Formatting Pages” in the Writer Guide.

TIP Page layout is usually easier if you show text, object, table, and section 
boundaries in Options > OpenOffice.org > Appearance, and 
paragraph ends, tabs, breaks, and other items in Options > 
OpenOffice.org Writer > Formatting Aids.
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Which layout method to choose?
The best layout method varies depending on what the final document should look 
like and what sort of information will be in the document. Here are some examples.

For a book similar to this 
user guide, with one column 
of text, some figures without 
text beside them, and some 
other figures with descriptive 
text, use page styles for basic 
layout, and tables to place 
figures beside descriptive text 
when necessary.

For an index or other 
document with two columns 
of text, where the text 
continues from the left-hand 
column to the right-hand 
column and then to the next 
page, all in sequence (also 
known as “snaking columns” 
of text), use page styles (with 
two columns). If the title of 
the document (on the first 
page) is full-page width, put 
it in a single-column section.
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For a newsletter with 
complex layout, two or three 
columns on the page, and 
some articles that continue 
from one page to some place 
several pages later, use page 
styles for basic layout. Place 
articles in linked frames and 
anchor graphics to fixed 
positions on the page if 
necessary.

For a document with terms 
and translations to appear 
side-by-side in what appear 
to be columns, use a table to 
keep items lined up, and so 
you can type in both 
“columns”.
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Creating headers and footers

Creating headers and footers

A header is an area that appears at the top of a page. A footer appears at the bottom 
of the page. Information —such as page numbers inserted into a header or footer 
displays on every page of the document with that page style.

To insert a header, click  Insert > Header > Default (or the page style, if not 
Default).

Figure 64: Inserting headers and footers

Other information such as document titles and chapter titles is often put into the 
header or footer. These items are best added as fields. That way, if something 
changes, the headers and footers are updated automatically. Here is one common 
example.

To insert the document title into the header:

1) Click File > Properties > Description and enter a title for your document.

2) Add a header (Insert > Header > Default).

3) Place the cursor in the header part of the page.

4) Select Insert > Fields > Title.  The title should appear on a gray 
background (which does not show when printed and can be turned off).

5) To change the title for the whole document, go back to File > Properties > 
Description.

Fields are covered in detail in the chapter titled “Working with Fields” in the Writer 
Guide. 

For more about headers and footers, see the chapters titled “Formatting Pages” and 
“Introduction to Styles” in the Writer Guide.
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Numbering pages

To automatically number pages:

1) Insert a header or footer, as described in “Creating headers and footers” on 
page 90.

2) Place the cursor in the header or footer where you want the page number to 
appear and click Insert > Fields > Page Number. 

Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):

1) Type the word “page” and a space, then insert the page number as above

2) Press the spacebar once, type the word “of” and a space, then click Insert > 
Fields > Page Count.

Note The Page Count field inserts the total number of pages in the document, 
as shown on the Statistics tab of the document’s Properties window 
(File > Properties). If you restart page numbering anywhere in the 
document, then the total page count may not be what you want. See the 
chapter titled “Formatting Pages” in the Writer Guide for more 
information.

Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page 
following a title page or a table of contents. In addition, many documents have the 
“front matter” (such as the table of contents) numbered with Roman numerals and 
the main body of the document numbered in arabic numerals, starting with 1. 

You can restart page numbering in two ways.

Method 1 (recommended):

1) Place the cursor in the first paragraph of the new page.

2) Click Format > Paragraph.

3) On the Text Flow tab of the Paragraph dialog (Figure 57 on page 82), select 
Breaks.

4) Select With Page style and specify the page style to use.

5) Specify the page number to start from, and then click OK.
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TIP Method 1 is also useful for numbering the first page of a document with 
a page number greater than 1. For example, you may be writing a book, 
with each chapter in a separate file. Chapter 1 may start with page 1, but 
Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Method 2:

1) Insert > Manual break. 

2) By default, Page break is selected on the Insert Break dialog (Figure 65).

Figure 65: Restarting page numbering after a manual page break

3) Choose the required page Style.

4) Select Change page number.

5) Specify the page number to start from, and then click OK.

Changing page margins

You can change page margins in two ways:

• Using the page rulers—quick and easy, but does not have fine control.

• Using the Page Style dialog—can specify margins to two decimal places.

Note If you change the margins using the rulers, the new margins affect the 
page style and will be shown in the Page Style dialog the next time you 
open it.
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To change margins using the rulers:

1) The gray sections of the rulers are the margins (see Figure 66). Put the 
mouse cursor over the line between the gray and white sections. The pointer 
turns into a double-headed arrow.

2) Hold down the left mouse button and drag the mouse to move the margin.

Figure 66: Moving the margins

TIP The small arrows on the ruler are used for indenting paragraphs. They are 
often in the same place as the page margins, so you need to be careful to 
move the margin marker, not the arrows. Place the mouse pointer between 
the arrows and, when the pointer turns into a double-headed arrow, you 
can move the margin (the indent arrows will move with it).

To change margins using the Page Style dialog:

1) Right-click anywhere on the page and select Page from the pop-up 
menu.

2) On the Page tab of the dialog, type the required distances in the Margins 
boxes.
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  Getting Started with Calc

OpenOffice.org’s Spreadsheet

Calc is the spreadsheet component of OpenOffice.org (OOo). You can enter data, 
usually numerical data, in a spreadsheet and then manipulate this data to produce 
certain results.

Alternatively you can enter data and then use Calc in a ‘What If...’ manner by 
changing some of the data and observing the results without having to retype the 
entire spreadsheet or sheet.

Spreadsheets, sheets, and cells

Calc works with elements called spreadsheets. Spreadsheets consist of a number of 
individual sheets, each containing a block of cells arranged in rows and columns.

These cells hold the individual elements—text, numbers, formulas etc.—which 
make up the data to be displayed and manipulated.

Each spreadsheet can have many sheets and each sheet can have many individual 
cells. Each sheet in Calc can have a maximum of 65,536 rows and a maximum of 
245 columns (A through IV). This gives 16,056,320 individual cells per sheet.

The number of rows increased from OOo 1.x to 2.0. In 1.0 there were 
only 32,000 rows.
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Parts of the main Calc window

Parts of the main Calc window

When Calc is started, the main window looks similar to Figure 67.

Figure 67. Parts of the Calc window

Formula bar
On the left of the Formula bar (see Figure 68) is a small text box, called the Name 
box, with a letter and number combination in it, such as D7. This is the column letter 
and row number, called the cell reference, of the current cell. 

Figure 68. Formula Bar
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Parts of the main Calc window

To the right of the Name box are the the Function Wizard, Sum, and Function 
buttons.

Clicking the Function Wizard button opens a dialog box from which you can 
search through a list of available functions. This can be very useful, because it also 
shows how the functions are formatted.

The Sum button inserts a formula into the current cell that totals the numbers in the 
cells above, or to the left if there are no numbers above, the current cell.

The Function button inserts an equals sign into the selected cell and the Input Line, 
thereby setting the cell ready to accept a formula.

When you enter new data into a cell that already contains something, the Sum and 
Equals buttons change to Cancel and Accept buttons  .

The contents of the current cell (data, formula, or function) are displayed in the 
Input Line, the remainder of the Formula bar. You can edit the cell contents of the 
current cell here, or you can do that in the current cell. To edit inside the Input Line 
area, left-click the appropriate part of the Input Line area, then type your changes. 
To edit within the current cell, just double-click the cell.

Individual cells
The main section of the screen displays the individual cells in the form of a grid, 
with each cell being at the intersection of a particular column and row.

At the top of the columns and at the left-hand end of the rows are a series of gray 
boxes containing letters and numbers. These are the column and row headers. The 
columns start at A and go on to the right and the rows start at 1 and go on 
downwards.

Sheet tabs
At the bottom of the grid of cells are the sheet tabs (see Figure 69). These tabs 
enable access to each individual sheet, with the visible, or active, sheet having a 
white tab.

Clicking on another sheet tab displays that sheet and its tab turns white. You can also 
select multiple sheet tabs at once by holding down the Control key while you click 
the names.

Figure 69. Sheet tabs
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Navigating within spreadsheets

Going to a particular cell

Using the mouse
Place the mouse pointer over the cell and left-click.

Using a cell reference
Click on the little inverted black triangle just to the right of the Name box (Figure
68). The existing cell reference will be highlighted. Type the cell reference of the 
cell you want to go to and press Enter. Or just click into the Name box, backspace 
over the existing cell reference and type in the cell reference you want.

Using the Navigator

Click on the Navigator button  in the Standard toolbar (or press F5) to display 
the Navigator. Type the cell reference into the top two fields, labeled Column and 
Row, and press Enter. In Figure 70 the Navigator would select cell F5.

Figure 70. Calc Navigator
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Navigating within spreadsheets

Moving from cell to cell
In the spreadsheet, one cell, or a group of cells, normally has a darker black border. 
This black border indicates where the focus is (see Figure 71).

 

Figure 71. (Left) One selected cell and (right) a group of selected cells

Using the Tab and Enter keys
• Pressing Enter or Shift+Enter moves the focus down or up, respectively.

• Pressing Tab or Shift+Tab moves the focus right or left, respectively.

Using the cursor keys
Pressing the cursor keys on the keyboard moves the focus in the direction of the 
arrows.

Using Home, End, Page Up and Page Down
• Home moves the focus to the start of a row.

• End moves the focus to the column furthest to the right that contains data.

• Page Down moves the display down one complete screen and Page Up 
moves the display up one complete screen.

• Combinations of Control and Alt with Home, End, Page Down, Page Up, 
and the cursor keys move the focus of the current cell in other ways.

TIP Holding down Alt+Cursor key resizes a cell.
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Moving from sheet to sheet
Each sheet in a spreadsheet is independent of the others though they can be linked 
with references from one sheet to another. There are three ways to navigate between 
different sheets in a spreadsheet.

Using the keyboard
Pressing Control+PgDn moves one sheet to the right and pressing Control+PgUp 
moves one sheet to the left.

Using the mouse
Clicking one of the Sheet Tabs at the bottom of the spreadsheet selects that sheet.

If you have a lot of sheets, then some of the sheet tabs may be hidden behind the 
horizontal scroll bar at the bottom of the screen. If this is the case, then the four 
buttons at the left of the sheet tabs can move the tabs into view. Figure 72 shows 
how to do this.

Figure 72. Sheet tab arrows

Notice that the sheets here are not numbered in order. Sheet numbering is arbitrary – 
you can name a sheet as you wish.

Note The sheet tab arrows that appear in Figure 72 only appear if you have 
some sheet tabs that can not be seen. Otherwise they will appear faded 
as in Figure 69.
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Selecting items in a sheet or spreadsheet

Selecting items in a sheet or spreadsheet

Selecting cells
Cells can be selected in a variety of combinations and quantities.

Single cell
Left-click in the cell. The result will look like the left side of Figure 71. You can 
verify your selection by looking in the Name box.

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse:

1) Click in a cell.

2) Press and hold down the left mouse button.

3) Move the mouse around the screen.

4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.

2) Move the mouse to the opposite corner of the range of cells.

3) Hold down the Shift key and click.

To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.

2) While holding down the Shift key, use the cursor arrows to select the rest of 
the range.

The result of any of these methods will look like the right side of Figure 71.

TIP You can also directly select a range of cells using the Name box. Click 
into the Name box as described in “Using a cell reference” on page 97. To 
select a range of cells, enter the cell reference for the upper left hand cell, 
followed by a colon (:), and then the lower right hand cell reference. For 
example, to select the range that would go from A3 to C6, you would 
enter A3:C6.
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Selecting items in a sheet or spreadsheet

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.

2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the Control key and click or click-and-drag to select a range. 

4) Repeat as necessary.

In OOo 2.0 when you are selecting non-contiguous cells, the first part 
of your set does not have to be multiple cells. In OOo 1.x you had to 
select more than one cell as the first part of a non-contiguous range.

Selecting columns and rows
Entire columns and rows can be selected very quickly in OOo.

To select a single column, click on the column identifier letter (see Figure 67).

To select a single row, click on the row identifier number (see Figure 67).

To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Control key.
3) Click on all of the subsequent columns or rows while holding down the 

Control key.

To select the entire sheet, click on the small box between the A column header and 
the 1 row header. 

You can also use the keyboard to select the entire sheet by pressing Control+A.

Figure 73. Select All box
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Working with columns and rows

Inserting columns and rows
Columns and rows can be inserted in several different way and quantities.

Single column or row
A single column or row can be added using the Insert menu:

1) Select the column or rows where you want the new column or row inserted.

2) Select either Insert > Column or Insert > Row.

Note When you insert a single new column, it is inserted to the left of the 
highlighted column. When you insert a single new row, it is inserted 
above the highlighted row.

A single column or row can also be added using the mouse:

1) Select the column or rows where you want the new column or row inserted.

2) Right-click the header.

3) Select Insert Row or Insert Column.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a 
time.

1) Highlight the required number of columns or rows by holding down the left 
mouse button on the first one and then dragging across the required number 
of identifiers.

2) Proceed as for inserting a single column or row above. 

Deleting columns and rows
Columns and rows can be deleted individually or in groups.

Single column or row
A single column or row can only be deleted by using the mouse:

1) Select the column or row to be deleted.
2) Right-click on the column or row header.
3) Select Delete Column or Delete Row from the popup menu.
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Multiple columns or rows
Multiple columns or rows can be deleted at once rather than deleting them one at a 
time.

1) Highlight the required number of columns or rows by holding down the left 
mouse button on the first one and then dragging across the required number 
of identifiers.

2) Proceed as for deleting a single column or row above.

Working with sheets
Like any other Calc element, sheets can be inserted, deleted and renamed.

Inserting new sheets
There are many ways to insert a new sheet. The first step for all of the methods is to 
select the sheets that the new sheet will be inserted next to. Then any of the 
following options can be used.

• Click on the Insert menu and select Sheet, or
• Right-click on its tab and select Insert Sheet, or
• Click into an empty space at the end of the line of sheet tabs (see Figure 74).

Figure 74. Creating a new sheet

Each method will open the Insert Sheet dialog (Figure 75). Here you can select 
whether the new sheet is to go before or after the selected sheet and how many 
sheets you want to insert.

Deleting sheets
Sheets can be deleted individually or in groups.

To delete a single sheet, right-click on the tab of the sheet you want to delete and 
select Delete from the popup menu.

To delete multiple sheets, select them as described earlier, right-click over one of the 
tabs and select Delete from the popup menu.
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Working with sheets

Figure 75. Insert Sheet dialog

Renaming sheets
The default name for the a new sheet is “SheetX”, where X is a number. While this 
works for a small spreadsheet with only a few sheets, it becomes awkward when 
there are many sheets. 

To give a sheet a more meaningful name, you can:
• Enter the name in the name box when you create the sheet, or
• Right-click on a sheet tab and select Rename Sheet from the popup menu 

and replace the existing name with a better one.

Note Sheet names must start with either a letter or a number; other characters 
including spaces are not allowed, although spaces can be used between 
words. Attempting to rename a sheet with an invalid name will produce 
an error message.
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Viewing Calc

Freezing rows and columns
Freezing locks a number of rows at the top of a sheet or a number of columns on the 
left of a sheet or both. Then when scrolling around within the sheet, any frozen 
columns and rows remain in view. 

Figure 76 shows some frozen rows and columns. The heavier horizontal line 
between rows 3 and 14 and the heavier vertical line between columns C and H 
denote the frozen areas. Rows 4 through 13 and columns D through G have been 
scrolled off the page. Because the first three rows and columns are frozen into place, 
they remained.

You can set the freeze point at one row, one column, or both a row and a column as 
in Figure 76.

Figure 76. Frozen rows and columns

Freezing single rows or columns
1) Click on the header for the row below where you want the freeze or for the 

column to the left of where you want the freeze.
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Viewing Calc

2) Select Window > Freeze.

A dark line will appear to indicate where the freeze is put.

Freezing a row and a column
1) Click into the cell that is immediately below the row you want frozen and 

immediately to the right of the column you want frozen.

2) Select Window > Freeze.

You will see two lines appear on the screen, a horizontal line above this cell and a 
vertical line to the left of this cell. Now as you scroll around the screen everything 
above and to the left of these lines will remain in view.

Unfreezing
To unfreeze rows or columns, select Window > Freeze. The checkmark by Freeze 
should vanish.

Splitting the window
Another way to change the view is by splitting the window—otherwise known as 
splitting the screen. The screen can be split either horizontally or vertically or both. 
This allows you to have up to four portions of the sheet in view at any one time.

Why would you want to do this? Imagine you have a large sheet and one of the 
cells has a number in it which is used by three formulas in other cells. Using the split 
screen technique, you can position the cell containing the number in one section and 
each of the cells with formulas in the other sections. Then you can change the 
number in the cell and watch how it affects each of the formulas.

Figure 77. Split screen example
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Splitting the screen horizontally
To split the screen horizontally:

1) Move the mouse pointer into the vertical scroll bar, on the right-hand side of 
the screen, and place it over the small button at the top with the black 
triangle.

Figure 78. Split screen bar on vertical scroll bar

2) Immediately above this button you will see a thick black line (Figure 78). 
Move the mouse pointer over this line and it will turn into a line with two 
arrows (Figure 79).

3) Hold down the left mouse button and a grey line will appear, running across 
the page. Drag the mouse downwards and this line will follow.

4) Release the mouse button and the screen will split into two views, each with 
its own vertical scroll bar. 

Figure 79. Split screen bar on vertical scroll bar with cursor

Notice in Figure 77, the ‘Beta’ and the ‘A0’ values are in the upper part of the 
window and other calculations are in the lower part. You may scroll the upper and 
lower parts independently. Thus you can make changes to the Beta and A0 values 
and watch their affects on the calculations in the lower half of the window.

You can also split the window vertically as described below—with the same results, 
being able to scroll both parts of the window independently. With both horizontal 
and vertical splits, you have four independent windows to scroll.
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Splitting the screen vertically
To split the screen vertically:

1) Move the mouse pointer into the horizontal scroll bar at the bottom of the 
screen and place it over the small button on the right with the black triangle.

Figure 80: Split bar on horizontal scroll bar

2) Immediately to the right of this button you will see a thick black line (Figure
80). Move the mouse pointer over this line and it will turn into a line with 
two arrows.

3) Hold down the left mouse button and a grey line will appear, running up the 
page. Drag the mouse to the left and this line will follow.

4) Release the mouse button and the screen will be split into two views, each 
with its own horizontal scroll bar. 

Note Splitting the screen horizontally and vertically at the same time will 
give four views, each with its own vertical and horizontal scroll bars.

Removing split views
• Double-click on each split line, or

• Click on and drag the split lines back to their places at the ends of the scroll 
bars, or

• Select Window > Split. This will remove all split lines at the same time.

TIP You can also split the screen following the same procedure as freezing 
rows and columns on page 105. Follow those steps, but instead of 
choosing Window > Freeze, choose Window > Split.
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Entering data into a sheet

Entering numbers
Select the cell and type in the number using either the top row of the keyboard or the 
numeric keypad. To enter a negative number, type a minus (–) sign in front of it or 
enclose it in brackets ( ).

By default numbers are right-aligned and negative numbers have a leading minus 
symbol.

Entering text
Select the cell and type the text. Text is left-aligned by default.

Entering numbers as text
If a number is entered in the format 01481, Calc will drop the leading 0. To preserve 
the leading zero, in the case of telephone area codes for example, precede the 
number with an apostrophe, like this: '01481. However, the data is now regarded as 
text by Calc. Arithmetic operations will not work on it. It will either be ignored or 
will produce an error of some kind.

TIP Numbers can have leading zeros and be regarded as text if the the 
cell is formatted appropriately. Right-click on the cell and chose the 
Format Cells > Numbers. Adjusting the leading zeros setting can 
add leading zeros to numbers.

Caution Even if you declare a variable as text, you can still perform 
arithmethic operations on it; however, the results of those operations 
will not be what you might expect. In some cases Calc will perform 
arithmetic operations on a cell that contains text, whether characters 
(for example, ABCD) or numbers that you have formatted explicitly 
as a text cell. For more information, see the Calc Guide.

Entering dates and times
Select the cell and type the date or time. You can separate the date elements with a 
slant (/) or a hyphen (–) or use text such as 10 Oct 03. Calc recognizes a variety of 
date formats. You can separate time elements with colons such as 10:43:45.
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Printing

OpenOffice.org Calc offers a powerful and highly configurable printing system. 
Many different details can be selected to print or not to print. The order the sheets 
will print in can be specified, as well as their size. Particular rows or columns can be 
specified to print on all sheets and the print range can be specified.

To print a spreadsheet either to a printer or a file, choose File > Print.  The Print 
dialog (Figure 81) allows printer settings to be changed.  What to print can be set 
quickly here: the whole document, specific sheets or a group of selected cells.  The 
number of copies, and whether to collate the copies, are also set in this dialog. 
Choose OK to start printing.

Print options
Printer options can be set for the current document only or for all spreadsheets.  To 
select for the current document, on the Print dialog, click the Options button in the 
bottom left. To set print options permanently, go to Tools > Options > 
OpenOffice.org Calc > Print.  The dialog boxes for both are very similar. See 
Figure 82.

Selecting sheets to print
One or more sheets can be selected for printing. This can be useful if you have a 
large spreadsheet with multiple sheets and only want a certain sheet to print. An 
example would be an accountant recording costs over time where there was one 
sheet for each month. If only the November sheet were to be printed, this is the 
procedure to follow.

1) Select the sheets to be printed. (Hold down the Control key as you click on 
each sheet tab.)

2) Go to File > Print and select Options (see Figure 81).

Note The Options button is different from the Properties button. Properties 
deals with the settings of the printer, whereas Options deals with OOo’s 
settings.
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Figure 81. The Print dialog

3) On the Printer Options dialog (Figure 82), check the Print only selected 
sheets checkbox.

4) Click OK.

Figure 82. Printer Options dialog
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Adjusting the print range

Printing rows or columns on every page
If a sheet will be printed on multiple pages, certain rows or columns can be set up to 
repeat on each printed page.

As an example, if the top two rows of the sheet as well as column A need to be 
printed on all pages, do the following:

1) Choose Format > Print Ranges > Edit Print Range.

2) The Edit Print Ranges dialog (Figure 83) appears. Click on - none - to the 
left of the Rows to repeat area, and change it to - user defined -.

3) In the text entry box in the center, type in the rows to repeat.  For example, 
to repeat rows one and two, type $1:$2.

4) Columns can also repeat; click on  - none - to the left of the Columns to 
repeat area, and change it to - user defined -..

5) In the text entry box in the center, type in the columns to repeat.  For 
example, to repeat column A, type $A.

6) Click OK.

Figure 83. Edit Print Ranges dialog

Note The entire range of the rows to be repeated does not need to be selected. 
Just selecting one cell in each row will work.
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Defining a print range
Use this option to modify or set a defined print range. This could be useful if, in a 
large spreadsheet, only a specific area of data needs to be printed. 

To define a print range:
1) Highlight the range of cells that comprise the print range.
2) Choose Format > Print Ranges > Define Print Range.

The page break lines will display on screen.

Note You can check the print range by using File > Page Preview. OOo will 
only display the cells in the print range.

Adding to the print range

After defining a print range, you can add more cells to it. This allows you to print 
multiple, non-contiguous areas of the same sheet, while not printing the whole sheet. 
Once you have defined a print range:

1) Highlight the range of cells that should be added to the print range.
2) Choose Format > Print Ranges > Add Print Range.

This will add the extra cells to the print range.

The page break lines will no longer show up on the screen.

Note The additional print range will print as a separate page, even if both 
ranges are on the same sheet.

Removing a print range

It may become necessary to remove a defined print range, for example if the whole 
sheet needs to be printed at a later time. 

To remove the print range, choose Format > Print Ranges > Clear Print Range.

This will remove all defined print ranges on the sheet.

After the print range is removed, the default page break lines will appear on the 
screen.
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  Getting Started with Draw
OpenOffice.org’s Vector Graphics Drawing Tool

Draw is a vector graphics drawing tool. It offers a series of powerful tools that 
enable you to quickly create all sorts of graphics. Vector graphics store and display 
an image as vectors (two points and a line) rather than a collections of pixels (dots 
on the screen). Vector graphics allows for easier storage and scaling of the image.

Draw is perfectly integrated into the OpenOffice.org suite, and this makes 
exchanging graphics with all components of the suite very easy. For example, if you 
create an image in Draw, reusing it in a Writer document is as simple as copy and 
paste. You can also work with drawings directly from within Writer and Impress, 
using a subset of the functions and tools from Draw.

Draw’s functionality is very extensive and complete. Even though it was not 
designed to rival high-end graphics applications, Draw still possesses more 
functions than the majority of drawing tools that are integrated into office 
productivity suites.

A few examples of drawing functions might whet your appetite: layer management, 
magnetic grid point system, dimensions and measurement display, connectors for 
making organization charts, 3D functions enabling small three-dimensional drawings 
to be created (with texture and lighting effects), drawing and page style integration, 
and Bezier curves, just to name a few.

114 Chapter 8  Getting Started with Draw



The Workplace

The Workplace

The main components of the Draw interface are shown in Figure 84.

Figure 84. Initial Draw window

The large area in the center of the window is where the drawings are made. It is 
surrounded by toolbars and information areas. You can vary the number and position 
of the visible tools, so your setup may look a bit different. For example, many 
people put the main Drawing toolbar on the left-hand side of the workspace, not at 
the bottom as shown here.
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The Toolbars

The various Draw toolbars can be displayed or hidden according to your needs.

Many of the floating toolbars in OOo 1.x have become main toolbars 
in OOo 2.0.

To display or hide the toolbars, simply click View > Toolbars. On the menu that 
appears, choose which toolbars to display.

You can also select the buttons that you wish to appear on the corresponding toolbar. 
On the View > Toolbars menu, select Customize, click on the Toolbars tab, and 
then select the desired buttons for that toolbar. Each toolbar has a different list of 
buttons. See Chapter 4, “Menus and Toolbars” for more information.

Many toolbar buttons are marked with a small arrow beside the button. The arrow 
indicates that this button has additional functions. Click the arrow and a sub menu or 
floating toolbar appears, showing its additional functions (see Figure 85).

Figure 85 An arrow next to a button  
indicates additional functions

Similarly, click on the arrow on the title bar of a floating toolbar to display 
additional functions (see Figure 86).

You may wish to keep this submenu displayed on your screen, but in a different 
position than the default location. You can make this submenu into a floating 
toolbar. To do so, click the submenu title bar, drag it across the screen, and then 
release the mouse button.

Note Most buttons marked with the small arrow can become floating toolbars. 
The floating toolbar capability is common to all components of the 
OpenOffice.org suite.

The tools available in the various toolbars are explained in the following sections.
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Figure 86. An arrow on a floating toolbar indicates additional functions

The Standard Bar
The Standard Bar looks like this:

It is the same for all parts of OpenOffice.org.

The Line and Filling Bar
The Line and Filling Bar (called the Object Bar in OOo 1.x) lets you modify the 
main properties of a drawing object. 

In the example above, the available functions enable you to change the color of the 
line drawn, the fill color, and so on, of a selected object. If the selected object is 
text, the toolbar changes to the one below.

The Drawing Toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains all the 
necessary functions for drawing various geometric and freehand shapes and 
organizing them on the page.
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Drawing a straight line
Let’s start by drawing the simplest of shapes: a straight line. Click on the Line button 

on the Drawing Toolbar  and place the mouse cursor at the point where you wish 
to start drawing.

Drag the mouse while keeping the button pressed down. Let go of the mouse button 
when you want to stop drawing the line. A blue or green handle point will appear at 
each end of the line, showing that this is the currently selected object. The colors 
depend on the default selection mode (they will be green for simple selection and 
blue when in point edit mode). 

Figure 87: Drawing a straight line
Hold down the Shift key while drawing the segment to force the line to be drawn at a 
multiple of 45° from the horizontal. 

If you hold down the Control key (Ctrl in PCs), the constraining angle will be 15°. 
You can set this angle in Tools > Options > OpenOffice.org Draw > Grid.

Hold down the Alt key to draw the line symmetrically from the start point (the line 
extends out to both sides of the start point equally). This lets you draw straight lines 
by starting from the middle of the line.

The line you draw will have the default attributes (such as color and line type). To 
change the line attributes, click on the line to select it and then use the tools in the 
Line and Filling Bar; or for more control, right-click on the line and choose Line to 
open the Line dialog.

Drawing a rectangle
Drawing rectangles is similar to drawing straight line segments, except that you use 
the Rectangle button   from the Drawing Toolbar. The (imaginary) line drawn 
with the mouse corresponds the diagonal of the rectangle.
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Figure 88: Drawing a rectangle

Hold down the Shift key to draw a square. Hold down the Alt key to draw a 
rectangle starting from its center.

Drawing a circle

To draw an ellipse or circle, use the Ellipse Button  from the Drawing Toolbar 
(a circle is simply an ellipse where the two axes are the same length). The ellipse 
drawn is the largest ellipse that would fit inside the (imaginary) rectangle drawn with 
the mouse.

Figure 89: Drawing a circle

Other shapes are available on the Drawing Toolbar.  In previous 
versions of OOo, these shapes were extended functions shown by 
long-clicking the Ellipse button.
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There are three other ways to draw an ellipse or circle:

• Hold down the Shift key while drawing to force the ellipse to be a circle.

• Hold down the Alt key to draw a symmetrical ellipse or circle from the 
center instead of dragging corner to corner. 

• Hold down the Ctrl key while drawing to snap the ellipse or circle to grid 
lines.

Note If you first press (and hold) the Control key before clicking on any of 
these buttons (Line, Rectangle, Ellipse, and Text), the chosen object 
appears directly on the page with a default size, shape and color. All of 
these can then be changed.

Writing text

Use the Text tool  to write text and select the font, color, size, and other 
attributes. Click on an empty space in the workspace to write the text at that spot. If 
you click on an object, the text is written in the center of the object and remains 
within the object.  The border of the object becomes the text's frame.

When you have finished typing text, click inside the text frame. Press Enter to drop 
to the next line. Double-click on the text at any time to edit it.

When you type text, the upper toolbar includes the usual paragraph attributes: 
indents, first line and tab stops.

You can change the style of all or part of the text. The Styles and Formatting 
window also works here (select Format > Styles and Formatting or press F11 to 
launch), so you can create styles that you can reuse in other text frames exactly as 
you would with Writer.

Text frames can also have fill colors, shadows and other attributes, just like any 
other Draw object. You can rotate the frame and write the text at any angle. These 
options are available by right-clicking on the object.

Use the Callout tool, located on the Drawing toolbar, to create callouts (also known 
as captions or figure labels).

The Color Bar
To display the Color Bar, use View > Toolbars > Color Bar. The toolbar then 
appears at the bottom of the workspace.
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This toolbar lets you rapidly choose the color of the objects in your drawing. The 
first box in the panel corresponds to transparency (no color). 

The color palette that is shown by default can be changed using Format > Area as 
shown in Figure 90. Choose the tab marked Colors.

Figure 90. Changing the color palette

If you click on the Load Color List button (circled), the file selector asks you to 
choose a palette file (bearing the file extension .soc). Several palettes are supplied as 
standard with OpenOffice.org. For example, web.soc is a color palette that is 
particularly adapted to  creating drawings that are going to appear in Web pages, 
because the colors will be correctly displayed on workstations with screens 
displaying at least 256 colors.

The color selection box also lets you individually change any color by modifying the 
numerical values in the fields provided to the right of the color palette. You also can 
click on Edit to display a dialog box (shown in Figure 91), making the choice of 
colors easier.

You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black), 
RGB (Red, Green, Blue) or HSB (Hue, Saturation, Brightness).
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Figure 91. Defining color schemes

The Options Bar
This toolbar lets you activate or deactivate various drawing aids. The Options Bar is 
not displayed by default. To display it, select View > Toolbars > Options.
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The snap tools are divided into 3 groups: the grid, snap lines, and snap points. 
Snapping to grid, lines or points requires three steps:

1) Display the grid, guides or points.

2) Click the correct snap-to button.

3) Drag the object near the point to be snapped to.

Using the grid
Draw provide a grid of points to which objects can be snapped. Click on the Display 
Grid button in the Options toolbar to display the grid, and then click on the Snap to 
Grid button to activate it. The work area will be filled with a grid, as shown in 
Figure 89. This grid will not be printed or appear in exported files such as PDF.

When the grid is active, shapes can be positioned easily by using the lines as a 
guide. In the following example, the object handles are positioned exactly on the 
lines in the grid.

The spacing between the lines is defined in the Grid options dialog under the 
Drawing area of the OOo options (Tools > Options > OpenOffice.org Draw > 
Grid).

Figure 92. Example of grid
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With the dialog shown in Figure 93, you can set the following parameters:

• Vertical and horizontal spacing of the dots in the grid. You can also change 
the unit of measurement used.

• The resolution is the size of the squares or rectangles in the grid.  If the 
resolution is Horizontal 1cm, Vertical 2cm, the grid consists of rectangles 
2cm high and 1cm wide.

• Subdivisions are additional points that appear along the sides of each 
rectangle or square in the grid. Objects snap to subdivisions as well as to the 
corners of the grid.

• The pixel size of the snap area defines how close you need to bring an 
object to a snap point or line before it will snap to it.

Figure 93. Setting grid options

The Rulers
You should see rulers on the upper and left-hand side of the workspace (see Figure 
94). These show the size of the objects on the page. The rulers show the location of 
the mouse to help you position objects more precisely. The rulers also are used to 
manage handle points and capture lines that make positioning objects easier. 

The page margins in the drawing area are also represented on the rulers. You can 
change the margins directly on the rulers by dragging them with the mouse. To 
modify the units of measurement of the rulers, right-click on one of the two rulers. 
The two rulers can have different units.
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Figure 94. Rulers in a drawing

The Status Bar

The Status Bar is located at the bottom of the screen. The middle part of this area 
(shown below) is particularly relevant to the Draw module.

The sizes are given in the current unit (not to be confused with the ruler units). This 
unit is defined in Tools > Options > OpenOffice.org Draw > General, where you 
can also change the scale of the page. Another way to change the scale is to double-
click on the number shown in the status bar.

Advanced Functions

Draw contains several advanced functions that are useful in certain specific 
instances (web images and data exchange).

Duplication
This function duplicates a given shape while enabling you to change the options 
applied to the duplicates.

To start duplication, click on an object (or on a group of selected objects), then 
choose Edit > Duplicate.
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The following dialog box appears.

You can choose:
• The number of copies.
• The displacement along the X and Y axes between two copies.
• The angle of rotation between two copies.
• The change in size between each copy.
• The colors of the start and end copies..

The options above applied to a blue rectangle produce the following result.

The end result of a duplication is a new group.
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Cross-fading
Cross-fading transforms a shape from one form to another, with OpenOffice.org 
handling all of the intermediate transitions. The result is a new group of objects.

To carry out a cross-fade, select both objects (hold the Shift key while selecting each 
object in turn) and then choose Edit > Cross-fading. The following dialog will 
appear.

Here is an example of its use.

We start with  two shapes... ...and carry out the cross-fade to obtain 
the following drawing.

Exchanging objects with other programs
To save a Draw image in a foreign format, use File > Export.  Draw can save to 
many graphic file formats, as listed in Chapter 3, “File Management” in this book.

You can also export Draw files to HTML, PDF, and Flash. PDF export is the same 
as for any part of OpenOffice.org, as described in Chapter 3, “File Management” in 
this book. Flash export creates a .swf file.

HTML export uses a conversion wizard that creates as many web pages as there are 
pages in your Draw document. You can choose to display the pages in frames with a 
navigator and can set an index page1. See Chapter 16, “Creating Web Pages”.

1 This wizard is exactly the same as in OpenOffice.org Impress.
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  Getting Started with Impress

OpenOffice.org’s Presentations

What is Impress?

Impress is OpenOffice.org’s slide show (presentations) program. You can create 
slides that contain many different elements, including text, bulleted and numbered 
lists, tables, charts, clip art, and a wide range of graphic objects. Impress also 
includes a spelling checker, a thesaurus, prepackaged text styles, attractive 
background styles, and a handy help menu.

This chapter includes instructions, screen shots, and helpful hints to guide you 
through the Impress environment while designing the easier presentations. Although 
more difficult designs are mentioned throughout this chapter, explanations for 
creating them are in the Impress Guide. If you have a working knowledge of how to 
create slide shows, we recommend you use the Impress Guide for your source of 
information.

Note To use Impress for more than very simple slide shows requires some 
knowledge of the elements which the slides contain. Slides containing 
text use styles to determine the appearance of that text. Slides containing 
objects are created the same way drawings are created in Draw.  For this 
reason, we recommend that you study the chapters “Working with Styles” 
and “Getting Started with Draw” in this book.
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Creating a new presentation

This section shows how to set up a new presentation. The settings selected here are 
general: they apply to all the slides. The section “Working with slides” on page 144 
explains how to apply settings to specific slides. These explanations can also apply 
to some of the general settings.

Planning a presentation
The first thing to do is to decide what you are going to do with the presentation. For 
example, putting a group of digital photos together in a presentation requires very 
little planning. However, using a presentation to increase the knowledge of others 
about your topic requires much more planning. 

Note This chapter has been put into presentation form and is available for 
download from 
http://oooauthors.org/en/authors/user_howtos/Simple_Presentation.odp. 
It was developed by using the steps in this chapter.

You need to ask and answer many questions before you begin creating a 
presentation. If you are not acquainted with creating presentations, the answers will 
be more general. Those who have created a variety of presentations in the past will 
want to have more specific answers.

Who is to see the presentation? How will it be used? What is the subject matter? 
What should be in its outline? How detailed should the outline be? Will an audio file 
be played? Is animation desirable? How should the transition between slides be 
handled? These are some of the many questions that should be asked, answered, and 
written down before creating the presentation. Sound and animation are more 
advanced topics and will be explained in the Impress Guide.

Again, it is not always necessary at this point to have specific answers to every 
question. Making an outline is extremely important. You may already know exactly 
what some of the slides will contain. You may only have a general idea of what you 
want on some of the slides. That is alright. You can make some changes as you go. 
Change your outline to match the changes you make in your slides.

The important part is that you have a general idea of what you want and how to get 
it. Put that information on paper. That makes it much easier to create the 
presentation.
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Starting the Presentation Wizard
Start OpenOffice.org (OOo) Impress. The Presentation Wizard appears (Figure 95). 
You can start Impress in either of two ways: 

• Click the triangle to the right of the New Icon and select Presentation from 
the drop-down menu.

• Choose File > New > Presentation from the menu bar.

Figure 95. Using the Presentation Wizard to choose the type of presentation 

1) Select Empty Presentation under Type. It creates a presentation from 
scratch.

TIP Leave the Preview checkbox selected, so templates, slide designs, and 
slide transitions appear in the preview box as you choose them.  If you 
do not want the wizard to start every time you launch Impress, select the 
Do not show this wizard again checkbox.

Note From Template uses a template design already created as the basis for a 
new presentation. The wizard changes to show a list of available 
templates. Choose the template you want.
Open Existing Presentation continues work on a previously created 
presentation. The wizard changes to show a list of existing presentations. 
Choose the presentation you want. Both of these are covered in the 
Impress Guide.
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2) Click Next. The Presentation Wizard step 2 window appears. Figure 96 
shows the Wizard as it appears if you selected Empty Presentation on 
window 1. If you selected one of the other choices, an example slide is 
shown in the Preview box.

Figure 96. Selecting a slide design using the Presentation Wizard

3) Choose a design under Select a slide design.  The slide design section gives 
you two main choices: Presentation Backgrounds and Presentations. Each 
one has a list of choices for slide designs.  If you want to use one of these 
other than <Original>, click it to select it.

The types of Presentation Backgrounds are shown in Figure 96. By clicking 
a choice, you will see a preview of that slide design in the Preview window. 
Impress contains three choices under Presentations: <Original>, 
Introducing a New Product, and Recommendation of a Strategy.

• <Original> is for a blank presentation slide design.

• Both Introducing a New Product and Recommendation of a Strategy 
have their own prepackaged slide designs. Each design appears in the 
Preview window when its name is clicked.

Note Introducing a New Product and Recommendation of a Strategy are 
prepackaged presentation templates. They can be used to create a 
presentation by choosing From template in the first window (Figure 
95). See the Impress Guide for instructions to do this.

Chapter 9  Getting Started with Impress 131



Creating a new presentation

4) Select how the presentation will be used under Select an output medium. 
Most often, presentations are created for computer screen display. Select 
Screen.

Note See the Impress Guide for creating presentations with the other output 
media.

5) Click Next. The Presentation Wizard step 3 window appears (Figure 97).

Figure 97. Selecting a slide transition effect and speed 

6) Choose the desired option from the Effect drop-down menu.

Tip You might want to accept the default values for both Effect and Speed 
unless you are skilled at doing this. Both of these values can be changed 
later while working with Slide transitions and animations. These two 
are explained in more detail later in this chapter.
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7) Select the desired speed for the transition between the different slides in the 
presentation from the Speed drop-down menu. Medium is a good choice for 
now.

8) Click Create. A new presentation is created.

Note If you selected  “From template” on step 1 of the Wizard, the Next 
button will be active on step 3 and other pages will be available. These 
pages are not described here.

Formatting a presentation

Now comes the part where you put your presentation together based upon your 
outline. This is done using the Main window of Impress (Figure 98). We will first 
describe the purpose of each part of this window. Afterwards, we will describe how 
to use them in putting your presentation together.

Figure 98: Main window of Impress
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Main window of Impress
The Main window has three parts: the Slides pane, Workspace, and Tasks pane. The 
Slides pane allows you to do specific things to individual slides. The Workspace is 
where most of the work is done to create individual slides. The Tasks pane contains 
a group of four tasks which affect styles, the layout, animation, and transitions 
between slides in your presentation. 

Tip You can remove either the Slides pane or Task pane from view by 
clicking the x to close it like any other window. This can also be done 
by View > Slide Pane or  View > Task Pane. To view the Slide or Task 
panes, View >Side Pane or View > Task Pane.

Slides pane

The Slides pane contains the thumbnail pictures of the slides in your presentation. 
They are in the order they will be shown. Clicking a slide selects it and places it in 
the Workspace. While it is there, you can apply any changes desired to that 
particular slide.

Note The order of the slides can be changed in the Workspace. Changing the 
order of the slides in Workspace changes the order of the slides in the 
Slide pane also.

Several additional operations can be performed on one or more slides in the Slides 
pane:

• Add new slides at any place within the presentation after the first slide.

• Hide a slide so that it will not be shown as part of the slide show.

• Delete a slide from the presentation if it is no longer needed.

• Rename a slide.

• Copy or move the contents of one slide to another. (Copy and paste, or cut 
and paste respectively.)

• Change the slide transition following the selected slide or after each slide in 
a group of slides.

• Change the slide design. (A window opens allowing you to load your own 
design.)

• Change slide layout. (This requires using the Layouts section of the Tasks 
pane.)
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Workspace
The Workspace has five tabs: Normal, Outline, Notes,  Handout, and Slide Sorter. 
These five tabs are called View Buttons (Figure 99). There are also many toolbars 
which can be used to create a slide. View > Toolbars shows a list of what is 
available. The Slide Design section is below the View Buttons. This is where you 
put the various parts of your selected slide together.

Figure 99: View Buttons

Each view is designed to make completing certain tasks easier. 

• Normal view is the main view for creating individual slides. Use this view to 
format and design and to add text, graphics, and animation effects. Many of 
the other sections in this chapter describe how to create and edit slides in 
Normal view. Additional information is available in the Impress Guide.

• Outline view shows topic titles, bulleted lists, and numbered lists for each 
slide in outline format. Use this view to rearrange the order of slides, edit 
titles and headings, rearrange the order of items in a list, and add new slides.

• Notes view lets you add notes to each slide that are not seen when the 
presentation is shown. Just click on the words “Click to add notes” and 
begin typing. You can resize the notes text box using the green resizing 
handles and move it by placing the pointer on the border, then clicking and 
dragging. Changes can also be made in the text style using the F11 key.

• Slide Sorter view shows a thumbnail of each slide in order. Use this view to 
rearrange the order of slides, produce a timed slide show, or add transitions 
between selected slides. 

• Handout view lets you print your slides for a handout. You may choose one, 
two, three, four, or six slides per page from Task pane > Layouts. This 
choice determines how many thumbnails are visible. You can rearrange the 
thumbnails in this view by simply dragging and dropping them. 

Task pane
The Task pane has four sections:

• Master Pages: Here you define the Page Style you will be using for your 
presentation. OOo Impress contains five prepackaged Master Pages. One of 
them is blank, and the rest have a background. Help refers to Master Pages 
as Slide Masters.
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Tip F11 can be used to open the Styles and Formating Window. The styles 
of any Master Page can be modified to suit your purpose. This can be 
done at any time.

• Layout: 20 prepackage layouts are shown. You can choose the one you want, 
or you can choose the first one (the blank one) and modify it as you see fit.

• Custom Animation: A variety of animations for selected elements of a slide 
are listed. Animation can be added to a slide, and it can also be changed or 
removed later. 

• Slide Transition: 56 different transitions are available including None. You 
can select the transition speed (slow, medium, fast). You can choose between 
an automatic transition or manual, and how long you want the selected slide 
to be shown (automatic transition only).

Building a presentation
This process begins with the decision as to what basic characteristics you want all 
the slides to have. These characteristics determine which Master Page you will use 
for your slides and what modifications if any you will make to it.

Choosing a Master Page 

Tip OOo defines Master Page as the slide master for a presentation. For a 
given presentation, there is normally only one slide master or Master 
Page. All slides are created by adding elements to the slide master. 
Another slide master can be used for  some of the slides if you want to 
do so. If you decide later that the master slide you chose does not meet 
your needs, you can still choose a different master slide. Or you can 
change parts of your master slide. All the slides created with this master 
slide will be changed the same way.
As you are developing your Master Page (slide master) and then 
succeeding slides, use F5 or F9 regularly to see what the slide you are 
working on looks like full screen. Then use the Esc key to return to your 
work of creating your slide show. You can spot problems sooner and 
easier this way.

You should first determine the styles you want to use for your presentation. There 
are five prepackage Master Pages from which to choose (Figure 100). Pick the one 
that comes closest to what you want. We look at how to make changes in the Master 
Page later.
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Figure 100: Available Master Pages

Note The Default Master Page is a blank slide with specific page styles. The 
other four Master Pages contain designs as well as specific page styles.

To see what is possible, look at how the prepackaged Master Pages were made. To 
do this, View > Master > Master Slide. Choose the Blank Slide in the Layout 
section of the Task pane. Open the Master Pages section. Since the Default Master 
Page is blank, consider only the other four available Master Pages.

Tip View > Master > Master Slide allows you to make changes in the 
Master Slide. Whatever changes made to the Master Slide will be made 
on all the slides of the presentation.
View > Normal allows you to only work on individual slides. With this 
selection, you can make changes to all of the slides. But none of these 
changes will change the Master Slide, itself,  in any way.

The  first two steps to building a presentation are: Select the slide master which 
comes closest to meeting your needs, and save the presentation. Then you need to 
modify the slide master.

Caution Remember to save frequently while working on the presentation, to 
prevent any loss of information should something unexpected occur. 
You might also want to activate the AutoRecovery function.  (Tools 
> Options > Load/Save > General). Make sure Save AutoRecovery 
information every is selected and that you have entered a number of 
minutes. (I usually select 3 minutes.)
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Make changes to the Master Page you have chosen by selecting View > Master > 
Master Slide. Most of this is done using styles. F11 opens the Styles and Formating 
window. The Presentation Styles icon should already be selected. (If it is not,  select 
it at this time.) Fourteen styles are listed, and all can be modified. But, no new styles 
can be added. To change any of these styles, right-click the style name and choose 
Modify from the context menu.

Beginning with 2.0.1, View > Master >Master Slide also opens the 
Master View toolbar (Figure 101). See the Impress Guide for 
instructions on the use of this toolbar.

Figure 101: Master View toolbar

1) Background styles:

• None means all slide backgrounds will be white.

• Color allows you to select your own background color.

• Gradient has 15 prepackaged backgrounds. The increments between 
one color and the other is automatically set by default, but you can set it 
manually if you desire.

• Hatching has 10 prepackaged patterns. More can be created using 
Format > Area > Hatching (tab). A background color can be added to 
the hatching.

• Bitmap has 20 prepackaged patterns. More bitmaps can be added to this 
list if they are one of the graphic formats OOo recognizes.  Format > 
Area > Bitmaps allows you to do this. If you have a graphic that you 
want to use with your slides, make sure it is in an acceptable format. 
(See the note below for how to find the list of acceptable formats.) Use 
the Import button to locate it and give it a name. Using F11 and 
selecting Bitmaps from Background styles, you should see your 
imported bitmap at the bottom of the list.
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Note Tools > Options > OpenOffice.org > Colors allows you to create your 
own custom colors. Once you create a color this way, it will be listed in 
the selection of colors available for the background.
New Gradients can be created, and these gradients can be modified. To 
do so, Format > Area > Gradient (tab). Doing this is beyond the scope 
of this chapter.
To see all of the graphic formats OOo will accept as a bitmap, select 
Format > Area > Bitmaps. Click Import. File types contains the entire 
list of acceptable graphic formats. You can also create your own bitmap 
using in the upper left corner of Format > Area > Bitmaps.

2) Background objects style: Use this to set the characteristics of all objects 
you add to the Master Page (Master Slide). Make any changes you need. 
Remember to use F5 after making a change to make sure that is what you 
want. Using the Esc key afterwards will return you to your work.

Note Just like Paragraph and Character styles in Writer, Background objects 
styles can be overridden by applying manual formating. So it is possible 
to have two background objects with different formating.
The use of background objects requires a knowledge of OOo’s Draw 
component and is beyond the scope of this chapter.

3) Notes: If you want to have notes attached to your slides, right click the 
Notes style, select Modify, and set the formating you want your notes to 
have. Make sure you make the font size large enough to be readable. Just 
remember that this formatting will be applied to the note of every slide using 
the same slide master. The bottom part of the Notes window contains an 
example of what any of your choices looks like.

Note At the present time, you cannot view your notes while you are running 
your slide show. Your notes can be included in a printed handout of the 
slide show.

4) Outline 1 through Outline 9: These styles set the formatting for each level of 
text in the text boxes of the slides. All of these have default values that are 
fairly good. You would probably want to leave most if not all of these values 
as they are. Since in a simple presentation, only one master slide is used, any 
changes made will affect all slides containing the affect style. For example, 
five slides have text with the Outline 2 style. When you change the Outline 2 
font size from 20 to 18, this change will be made on all five slides to every 
paragraph using the Outline 2 style.

5) Title and Subtitle: Set these styles the same way you set the styles for 
Outline 1 through Outline 9. Most of these styles work very well as they are. 
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The parts that you might want to change are the Font, Typeface,  Font size, 
and Font color (Font Effects tab).

6) When you are finished making your changes, use View > Normal. Or, you 
could click Close Master View in the Master View toolbar. 

Creating the first slide
The first slide is normally the Title Page. Decide which of the layouts will suit your 
purposes for your first slide. I suggest that you keep it rather simple. Some simple 
layouts are Title Slide (also contains a section for a subtitle), or Title Only slide. The 
rest of the layouts seem to be better suited for later slides in the presentation, or for 
more complex presentations.

Note For very simple presentations, you may not need a title. For example, 
sometimes I put a group of pictures together for someone to see. But in 
most cases, you will need to use the title as the first slide.

Adding elements to the Title Page
All three suggested slides contain a title section at their top. To create the title, click 
the phrase Click to add title. Type the title. Adjustments to the formating of the title 
can be done by using the F11 key, right-clicking the Title style, and selecting 
Modify from the context menu.

If you are using the Title Slide layout slide, click the phrase Click to add text. Type 
the subtitle. Make any adjustments in the formating you desire. Do this the same 
way as if you are changing the title formating: use the F11 key, right-click the 
Subtitle style, select Modify from the context menu, and make your changes. Click 
OK to apply your changes to the subtitle.

The Title, Object layout slide can also be used. To do this requires knowledge of 
how to move and resize graphic images (objects). Insert the object as an OLE 
Object. To do so:

 1) Double-click the graphic. 
 2) Select Create from file and click OK. 

Caution Click Link to file only if you are going to keep the presentation 
and the file in the same directory in which they were originally 
saved. Otherwise, you may not be able to access your OLE Objects 
from your slide show when you need them.

 3) Click Search to browse to the file’s location. Select the file, and click Open. 
Then click OK.

 4) Resize and center the object to fit the slide as needed.
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Inserting additional slides
The steps for inserting additional slides are basically the same as for selecting the 
title page. It is a process that has to be repeated for each individual slide. Since you 
are going to be using only one slide master, your only concern right now is the 
Layouts section of the Tasks pane on the right. 

First, you should insert all of the slides your outline indicates you will need. Only 
after this should you begin adding special effects such as custom animation and slide 
transitions. (These are covered in the next section.)

Step 1: Insert a new slide. This can be done in a variety of ways: take your pick.

• Insert > Slide.

• Right-click on the present slide, and select New Slide from the context 
menu.

• Click the Slide icon in the Presentation toolbar (Figure 102).

Figure 102: Presentation toolbar

Step 2: Select the layout slide that bests fits your needs.

If your slide consists only of a title with a graphic, chart, or spreadsheet, inserting it 
as an OLE Object is the simplest. But be advised, doing this for a chart or 
spreadsheet is not simple. This is an advanced technique.

Step 3: Modify the elements of the slide. At this stage, the slide consists of 
everything contained in the slide master as well as the chosen layout slide. This 
includes removing unneeded elements, adding needed elements (pictures and OLE 
Objects), and inserting text.

Caution Changes to any of the prepackaged layouts can only be made using 
View > Normal which is the default. Attempting to do this by 
modifying a slide master will result in an error message. (The slide 
master is modify using View > Master > Master Slide.)

1) Remove any element on the slide you do not need (Figure 103).

a) Click the element to highlight it. (The green squares show it is 
highlighted.)

b) Press the Delete key to remove it.
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Figure 103: Deleting an element of a slide

Tip Sometimes you will accidentally select the wrong layout slide. If you 
remove the element or elements you do not want, you can then click the 
correct layout slide and continue your work.

2) Add any elements to the slide you do need.

a) Adding pictures to the clipart frame:

i. Double-click the picture within the frame.

ii. Browse to the location of the picture. 

iii. Select the picture and click Open.

iv. Resize the picture as necessary. Follow the directions in the 
Caution note below.

b) Adding pictures from graphic files to places other than the clipart 
frame:

i. Insert > Picture > From File.

ii. Browse to the graphic file, select it, and click Open.

iii. Move the picture to its location.

iv. Resize the picture if necessary.

c) Adding OLE Objects is an advanced technique covered in the Impress 
Guide.
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Caution When resizing a graphic, right-click the picture. Select Position 
and Size from the context menu. Make sure Keep ratio is selected. 
Then adjust the height or width to the size you need. (As you 
adjust one dimension both dimensions will change.) Failure to do 
so will cause the picture to become distorted.

3) Adding text to a slide: If the slide contains text, click the phrase Click to 
add an outline in the text frame. Type the text into the text frame.

Note Text in the slide is in an outline format: each level is indented more than 
the previous level as you move from level 1 to level 10.

4) To change Outline Levels as you type, use the left and right arrow keys 
(Figure 104).

• The left arrow changes it to the previous Outline Level. (level 3 to level 
2 for example)

• The right arrow changes to the next Outline Level. (level 2 to level 3 
for example)

Figure 104: Text moving arrows

5) To change the order of the paragraphs (lines), use the up and down arrow 
keys.

• The up arrow moves the paragraph higher in the text (Figure 105).

• The down arrow moves the paragraph lower in the text. 

Note Moving text around usually requires using a combination of these keys. 
For example, a paragraph needs to be moved higher and its Outline 
level needs to be changed to a lower level (closer to 1) or a higher level 
(closer to 10).

Step 4: To create additional slides repeat steps 1–3.
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Figure 105: Moving text higher or lower

Working with slides
This is the time to review the entire presentation and answer some questions. Run 
the slide show at least once before answering them. You might want to add some 
questions of your own.

1) Are the slides in the correct order? If not, some of them will need to be 
moved.

2) Would an additional slide make a particular point clearer? The slide needs to 
be created.

3) Would some custom animations help some of the slides? (Advanced 
technique)

4) Should some of the slides have a different slide transition than others? The 
transition of these slides should be changed.

5) Do some of the slides seem unnecessary? Delete the slide or slides after 
checking if they are indeed unnecessary.

Caution If  one or more slides seems to be unnecessary, hide the slide or 
slides, and view the slide show a few more times to make sure. To 
hide a slide, right-click the slide in the Slides pane. Select Hide 
Slide in the context menu. Do not delete a slide until you have 
done this. Otherwise you may have to create that slide again.

Once you have answered these and your own questions, you should made the 
necessary changes. This is done the easiest in the Slide Sorter view and will be 
explained there. If you need one or more new slides, create them using the steps 
listed in “Inserting additional slides” on page 141.
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Custom animations
If you know how to add a custom animation to a slide, do it now. This is an 
advanced technique and is explained in the Impress Guide.

Slide transitions
Your first slide show should probably have the same slide transition for all slides. 
Setting Advance slide to On mouse click is the default and a simple setting. If you 
want each slide to be shown for a specific amount of time, click Automatic after and 
enter the number of seconds. Click Apply to all slides.

Tip The Slide transition section has a very useful choice: Automatic 
preview. Select its checkbox. Then when you make any changes in a 
slide transition, the new slide is previewed in Slide Design area 
including its transition effect.

Changes that can be made to slide transitions:

1) Apply to selected slides has a list of slide transitions. 

a) Make sure Automatic preview is checked.

b) Click one of the members of the Apply to selected slides list.

c) Watch the effects of this slide transition.

d) Select the slide transition you want.

2) Modify transition has two drop down lists.

• Select the Speed: slow, medium, and fast.

• Select a Sound from the list if you want one.

3) Once you have made your selections, if any, click Apply to all slides to give 
all slides the same transition.

4) Play and Slide Show are used to play one or more slides in the presentation.

• Clicking Play has the same effect as having Automatic Preview checked 
(ticked): a single slide is shown along with its slide transition.

• Slide Show begins the slide show at the selected slide and continues 
until the end. 

TIP If you want to use this button to play the entire slide show, click the top 
slide in the Slides pane. Then click Slide Show in the Slides transitions 
section of the Task pane.
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Workspace
You already know about the first view of Workspace: Normal. All of your work so 
far has been done in that view, one slide at at time. These other views of Workspace 
allow you to perform other tasks.

Normal
There are two ways to place a slide in the Slide Design area of the Normal view: 
clicking the slide thumbnail in the Slides pane, or using the Navigator. To open the 
Navigator, click the Navigator button in the Standard Toolbar (Figure 106). To 
select a slide, scroll down the Navigator list until you find it and the double click it.

Figure 106: Navigator button

Note One of the purposes of naming the slides is to match them with the 
outline you created in the beginning. Another purpose is to help find a 
particular slide that you want to change using the Navigator.

Outline
The Outline view contains all of the slides of the presentation in their numbered 
sequence. Only the text in each slide is shown. Slide names are not included.

The Outline view serves at least two purposes. 

1) Making changes in the text of a slide:

• You can add and delete the text in a slide just as you would in the 
Normal view.

• You can move the paragraphs of text in the selected slide up or down by 
using the up and down arrows (Figure 107).

Figure 107: Arrows

• You can change the Outline Level for any of the paragraphs in a slide 
using the left and right arrows.

• You can both move a paragraph and change its Outline Level using a 
combination of these four arrow. 
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2) The slides can be compared with your outline. If you notice from your 
outline that another slide is needed, you can return to the Normal view to 
create the slide. Then return to reviewing all the slides against your outline 
in the Outline view.

• If a slide is not in the correct sequence, you can move it to its proper 
place.

• Click the slide icon of the slide you are moving.

• Drag and drop it where you want it.

Figure 108: Moving slides in Outline view
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Notes
The Notes view is used to add notes to a slide. At the present time, they are not 
visible to the person running the slide show. They can be printed out as part of a 
handout, but this is not an easy task.

To add notes to a slide:

1) Click the Notes tab in the Workspace (Figure 109).

2) Select the slide to which you will add notes.

• Double-click the slide in the Slide pane, or

• Double-click the slide’s name in the Navigator.

3) Type the notes in the text box below the slide.

Figure 109: Notes view
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Slide Sorter
Slide Sorter view contains all of the slide thumbnails (Figure 110). Use this view for 
selecting a group of slides. Or you can work with only one slide. 

Figure 110: Slide Sorter view

Change the number of slide per row if desired (Figure 111).

1) Check View > Toolbars > Slide View make the Slide view toolbar visible. 

2) Adjust the number of slides.

3) When you have adjusted the number of slide per row, View > Toolbars > 
Slide View will remove this toolbar from view.

To move a slide in a presentation in the Slide Sorter:

1) Click the slide. It becomes a little larger.
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2) Drag and drop it to the location you want.

• As you move the slide, a black vertical line appears to the right of the 
slide. 

• Drag the slide until this black vertical line is located where you want the 
slide.

To select a group of slides:

1) Click the number of the first slide.

2) Hold down the left mouse button.

3) Drag the cursor to the last slide thumbnail. A dashed outline of a rectangle 
forms as you drag the cursor through the slide thumbnails. Make sure the 
rectangle includes all the slides you want to select. 

To move a group of slides:

1) Select the group. 

2) Drag and drop the group to their new location. The same vertical black line 
appears to show you where the group of slides will go.

Note Selection of a group of slides works in a rectangular fashion. For 
example: slides 1, 2 ,3, 5, 6, and 7 can be selected, but slides 1, 2, 5, 6, 
and 7 can not.

You can work with individual slides in the Slide Sorter view (Figure 110) just as 
you can in the Slide pane. 

To make changes, right-click a slide and do the following using the context menu 
(Figure 112):

1) Add a new slide after the selected slide.

2) Delete the selected slide.

3) Change the Slide Layout.

4) Change the Slide Transition.

• For one slide, click the slide to select it. Then add the desired transition.

• For more than one slide, select the group of slides and add the desired 
transition.

5) Hide the selected slide. It will be shown in the slide show.

6) Copy and paste a slide.
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7) Cut and paste a slide.

Figure 112: Working with a slide  

Handouts
This view is for setting up the layout of your slide for a printed handout. Layout 
contains five choices: one, two, three, four, and six slides per page (Figure 113). If 
you want to include slide notes with your hand out, consult the Impress Guide. This 
involves advanced techniques.

Figure 113: Handout layouts

To print a handout:

1) Select the slides using the Slide Sorter. (Use the steps listed in selecting a 
group of slides on page 150.)

2) Select File > Print or press Control+P.

3) Select Options in the bottom left corner.

4) Check Handout and click OK.

5) Select Print Range.

6) Click OK in the Print window.
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Note By selecting a single slide, it is possible to print it and any notes it 
contains. Printing the entire presentation and all of its notes is beyond 
the scope of this document.

Running the presentation

To run the slide show, do one of the following:

• Click Slide Show > Slide Show.

• Click the Slide Show button (Figure 114).

Figure 114: Presentation Toolbar

• Press F5 or F9 to start a slide show.

If the slide transition is Automatic after x seconds, let the slide show run by itself.

If the slide transition is On mouse click, do one of the following to move from one 
slide to the next.

• Use the arrow keys on the keyboard to go to the next slide or to go back to 
the previous one. 

• You can also click the mouse.
• Press the spacebar on the keyboard to advance to the next slide.

To exit the slide show at any time including at the end, press the Esc key.

In 1.1.x, slide shows had two ways to be closed. If the slide transition 
was set at manual, the slide show ended with a black screen with the 
phrase “Click to exit presentation. A mouse click or pressing any key 
would then end the slide show. However, if the slide transition was set 
to automatic, only the Esc key would end the slide show. Using any 
other key on the keyboard would start the slide show again.
In 2.0, only the Esc key will end a slide show. All other keys with 
cause the slide show to begin again.
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  Getting Started with Base

Introduction to data sources

A data source, or database, is a collection of information which can be accessed or 
managed by OpenOffice.org (OOo). For example, a list of names and addresses is a 
data source which could be used for producing a mail merge letter. A shop stock list 
could be a data source managed through OOo.

Note OpenOffice.org uses the terms “Data Source” and “Database” to refer to 
the same thing, which could be a database such as MySQL or dBase or 
a spreadsheet or text document holding data.

This chapter is an introduction to the use of data sources. For further information, 
see the Database Guide.

This chapter covers creating a database, showing what is contained in a database and 
how the different parts are used by OOo. It also covers using the Base component of 
OOo to register other data sources. A data source can be a database, spreadsheet or 
text document. 

Caution
 

The database in OOo requires Sun’s Java JRE. If you do not have it 
on your computer, download it from www.java.com and install it 
following the instructions on the site. It should be Java 5.0 or 
higher. In OOo, use Tools > Options > OpenOffice.org > Java to 
register Java.
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Creating a database

In this example, we are going to step through the creation of a new database. This 
database will contain two address books: one for acquaintances and one for relatives 
and two information sections: one for acquaintances and one for relatives.

Creating a new database

Figure 115: Creating a new database

To create a new database, click the New icon. In the drop-down menu select 
Database (Figure 115). This opens the Database Wizard. You may also open the 
Database Wizard using File > New > Database.

The first step of the Database Wizard has one question with two choices: Create a 
new database or Connect to an existing database. For this example, select Create 
a new database and then click Next.

The second step has two questions with two choices each. The default choice for the 
first question is Yes, register the database for me and the default choice for the 
second question is Open the database for editing. Make sure these choices are 
selected and click Finish.

Note If the database is not registered, it will not be accessible to the other 
OOo components such as Writer and Calc. If the database is registered, 
other components can access it.

Save the new database with the name Information. This opens the Information – 
OpenOffice.org Base window. 

TIP Every time the Information database is opened, the Information – 
OpenOffice.org Base window opens. Changes can then be made to the 
database. 
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Creating database tables

Note In a database, a table is where information about one group of things is 
stored. For example, a table might hold an address book, a stock list, a 
phone book or a price list. A database can have from one to several 
tables.

When the Information – OpenOffice.org Base window opens, Forms is highlighted. 
Click on Tables to highlight it, as shown in Figure 116. We will create the 
Acquaintance Addressses table using the Table Wizard, and the Acquaintance 
Information table using the Design Mode method. We will create the Relatives 
Addresses and Information tables by copying and pasting.

Similarly, both Information tables have several fields containing the months of the 
year in them. By making a table for the months of the year, we can make our work 
easier when we enter data into each form. This will be obvious after we have created 
the forms. (This table is only a source for the list to be inserted into the two 
Information forms we will create, so we do not need to create additional forms.)

Figure 116: Creating Tables

Using the Wizard to create a table

Caution

   

Every table requires a Primary key field. (What this field does will 
be explained later.) We will use this field to number our entries and 
want that number to automatically increase as we add each entry. 

First table to be created: an address book for acquaintances.
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Click Use Wizard to Create Table. This opens the Table Wizard. 

Note A field in a table is one bit of information. For example, in a price list 
table, there might be one field for item name, one for the description and 
a third for the price. More fields may be added as needed.

Step 1: Select fields.

You have a choice of two categories of suggested tables: Business and Personal. 
Each category contains its own suggested tables from which to choose. Each table 
has a list of available fields. We will use the Addresses table in the Personal category 
to select the fields we need.

1) Category: Select Personal. The Sample Tables drop down list changes to a 
list of personal sample tables.

2) Sample Tables: Select Addresses. The 
Available fields window changes to a list of 
available fields for this table.

3) Selected Fields: Using the > button, move 
these fields from the Available fields window 
to the Selected fields window in this order: 
AddressID, FirstName, LastName, 
SpouseName, Address, City, StateOrProvince,  
PostalCode, CountryOrRegion, 
PhoneNumber, MobileNumber (cell phone),  
and EmailAddress.

4) If a mistake is made in the order as listed 
above, click on the field name that is in the 
wrong order to highlight it. Use the Up or 
Down arrow on the right side of the Selected 
Fields list (see Figure 117) to move the field 
name to the correct position.

5) Click Next.

Caution

   

Below the Selected Fields list are two buttons: one with a +, and one 
with a –. These buttons are used to add or to remove fields from the 
Selected Fields list. Be careful when using these buttons until well 
acquainted with how to create tables (Figure 117).
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Step 2: Set field types and formats.

In this step you give the fields their properties. As each field is selected, the 
information on the right changes. You can then make changes to meet your needs. 
(See Figure 118.)

Figure 118: Changing Field Types

Note If any of these fields requires an entry, set Entry required to Yes. If 
Entry required is set to Yes, this field must have something in it. For 
example, if FirstName has Entry required set to Yes, having an entry 
with the first name missing will not be allowed. In general, only set 
Entry required to Yes if something must always be put in that field. By 
default, Entry required is set to No.

• AddressID: Change AutoValue from No to Yes.

• FirstName: 

• Entry required: If a FirstName will be entered for every person, change 
Entry required to Yes. Otherwise, leave Entry required as No.

• Length: Suggestion: Change Length to 20. This must be longer than 
any FirstName to be entered. Make it smaller or larger than 20 based 
upon the length of the longest FirstName.

Note In Base the maximum length of each field must be specified on creation. 
It is not easy to change this later, so if in doubt specify a greater length.

• LastName: Length=20 should be sufficient.

• SpouseName: Length=20 should be sufficient. Entry required should be 
No. (Not everyone has a spouse.)

• Address: Change Length to 50 unless someone’s address is longer. In 
such cases, adjust Length accordingly.
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• City: Length=20 should be sufficient.

• StateOrProvince: Length for this depends upon your location. In USA, 
2 is sufficient. Select the number which is appropriate for where your 
addressees live.

• PostalCode: Length should match your local area and preferences. 
Even in the USA, some use only five digits  (#####) and others use nine 
(#####-####). These require a Length of 5 and 10 respectively. 

• CountryOrRegion: Entry required should be No. Use the Length that is 
appropriate for you.

• PhoneNumber: Entry required should be No. Adjust Length according 
to your needs. Make sure to count all the signs, spaces, parentheses, 
dashes, and digits. For example, (555) 333-2222 needs a Length of 14. 
If the phone number includes an extension, make sure you include the 
number of letters and digits in your Length.

• MobileNumber: Make the same adjustments as PhoneNumber. This 
could also be used for a pager number. In such cases, make sure to 
include enough space for all of the needed information.

• EmailAddress:  Since there are some long email addresses, change only 
Entry required to no. Some people may not have an email address.

When you have finished, click Next.

Note Each field also has a Field Type. In Base the field type must be specified. 
These types include text, integer, date and decimal. If the field is going to 
have general information in it (for example a name or a description) then 
you want to use text. If the field will always contain a number (for 
example a price) the type should be decimal or another appropriate 
numeric field. The wizard picks the right field type, so to get an idea of 
how this works, see what the wizard has chosen for different fields.

Step 3: Set primary key.

1) Create a  primary key should be checked. 

2) Select option Use an existing field as a primary key.

3) In Fieldname drop down list, select AddressID.

4) Check Auto value.

5) Click Next.
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Note A primary key uniquely identifies an item (or record) in the table. For 
example, you might know two people called “Randy Herring” or three 
people living at the same address and the database needs to distinguish 
between them.
The simplest method is to assign a unique number to each one: number 
the first person 1, the second 2 and so on. Each entry has one number 
and every number is different, so it is easy to say “record ID 172”. This 
is the option chosen here: Address ID has nothing to do with a real 
address; it is just a number assigned automatically by Base to each 
record.
There are more complex ways of doing this, all answering the question 
“How do I make sure that every single record in my database can be 
uniquely identified?”

Step 4: Create the table.

1) If desired, rename the table at this point. If you rename it, make the name 
meaningful to you. For this example, rename the table to Acquaintance 
Addresses. 

2) Leave the option Insert data immediately checked. 

3) Click Finish to complete the table wizard. Close the window created by the 
table wizard. You are now back to the main window of the database with the 
listing of the tables, queries, forms, and reports.

Creating a table by copying an existing table
Here we will create a second table which will be the address book for relatives. 
Since the Relative Addresses table is similar to the Acquaintance Addresses table, 
we will create it by making a copy of the Acquaintance Addresses table and 
modifying it.

1) Click on the Tables icon in the Database pane to see the existing tables.

2) Right-click on the Acquaintance Addresses table icon. Select Copy from the 
context menu. 

3) Move the mouse pointer below this table, right-click, and select Paste from 
the context menu. The Copy table window opens.

4) Change the table name to Relative Addresses and click Next.

5) Click the >> button to move all the Fields from the left window to the right 
window and click Next.
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6) Since all the Fields already have the proper Field Type formating, no 
changes should be needed. However, this is the time and place to make these 
changes if they are needed. (See Caution below for the reason why.)  Click 
Create. The new table is created.

Caution

   

Once tables have been created using the wizard, editing them is 
limited. The Primary key can not be changed in any way. It is 
possible to add new fields and remove fields. It is possible to change 
the field type when creating the field as well as later as long as it is 
not the primary key. Once data has been added to the database, 
deleting a field will also delete any data contained in that field. When 
creating a new table, it pays to create the fields with the correct 
names, length and format before data is added.

Creating tables in Design View
Design View is a more advanced method for creating a new table. It allows you to 
directly enter information about each field in the table.

Note While the Field type and formatting are different in Design View, the 
concepts are the same as in the Wizard.

Both the Acquaintance Information and Relative Information tables will be created 
with this method. Both tables use the same fields: ID, FirstName, LastName, 
SpouseName, WedDateM (month married), WedDateD (date married), WedDateY 
(year married), HusBDM (his birth month), HusBDD (his birth date), HusBDY (year 
of his birth), WifeBDM (her birth month), WifeBDD (day of her birth), WifeBDY 
(year of her birth), Ch1 (oldest child), Ch1BDM (month of Ch1’s birth), Ch1BDD 
(day of Ch1’s birth), and Ch1BDY (year of Ch1’s birth). 

TIP For purposes of an example we are only using one child in the family. 
Additional fields can be created in the table for those having relatives and 
acquaintances with more than one child. Those additional fields need to 
be in the same order as I have them above. For example, for two children 
the added fields would be: Ch2, Ch2BDM, Ch2BDD, and Ch2BDY. 
If you prefer to have the day precede the month, as in 1 January instead of 
January 1, put each field containing the day before the corresponding field 
containing the month. For example, put WedDateD just before WedDateM 
and Ch1BDD just before Ch1BDM.

1) Click Create Table in Design View.

2) ID entries:

 a) Enter ID as the first Field Name.

160 Chapter 10  Getting Started with Base



Creating a database

 b) Select Integer[INTEGER] as the Field Type.

 c) Change the Field Properties in the bottom section.

• Change AutoValue from No to Yes (Figure 119).

Figure 119: Field Properties section (AutoValue)

 d) Set ID as the Primary key. 
• Right-click on the green triangle to the left of ID.
• Click Primary Key in the context menu. This places a key icon in 

front of  ID.

Note The primary key serves only one purpose. Any name can be used for this 
field. It is not necessary to use ID as the name of the primary key field.

3) All other entries:

 a) Enter the next field name in the first column (Field Name column).

 b) Select the Field Type for each field.
• For field names ending with D or Y (for example, WedDateD or 

WedDateY), select Small Integer[SMALLINT].
• All other fields use the default setting (Text[VARCHAR].

 c) Select the Field Properties (Figure 120).

Figure 120: Field Properties section

• Change Entry required from No to Yes only for fields which will 
always have an entry.

• Change the Length to match the longest entry expected for the 
field. (20 should be sufficient for most name fields unless one of 
your names is longer.)
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• For more detailed formating, click the Format example button 
(Figure 121).

Figure 121: Field Format options

4) Repeat these steps for each field in the table.

To access additional formatting options, click the button to the right of the 
Format example panel (Format example button).

5) Description can be anything, or can be left blank. (Figure 122 is an example 
of this.)

Figure 122: Example of Description entries
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6) To save and close the table, select File > Close. The suggested Table Name 
can be left as it is. Our example uses Acquaintance Information as its name.

The fourth table, Relative Information, is created by following the same steps as 
when you created the Acquaintance Information table.  Or, you can right-click on 
Acquaintance Information, and select Copy from the context menu. Right-click just 
below Relative Addresses, and select Paste from the context menu. Follow the 
directions on page 159.

TIP If you want your primary key field of the Relative Information table to 
have an Autovalue, create the entire table as you did the Acquaintance 
Information table. Otherwise you can follow the steps for copying a 
table as found on page 159.

Creating tables for the list box
When the same information can be used in several fields, design a table for each 
type of information. Each table will contain two fields: the information field, and ID 
in this order. 

1) Follow the directions in “Creating tables in Design View” on page 160. In 
the table we will create, the two fields can be name and ID. Make sure that 
the AutoValue is set to Yes for the ID field.  Also make sure to select the ID 
field as the primary key. (See Figure 123.)

2) Save the table using the name Months.

Figure 123: Table in Design View

Note: If you have several tables to create with the same fields, design one table 
and produce the other tables by cutting and pasting. (See “Creating a table
by copying an existing table” on page 159.) 

Adding data to the list table
List tables do not require a form. Instead, add their data directly to the table. In our 
example, add the months of the year in the name field of the Months table. The 
AutoValue selection of the AddressID field automatically adds consecutive numbers 
to this field.

We will use the abbreviations for the months of the year found in the Number 
Format for Dates: Jan., Feb., Mar., Apr., May, Jun., Jul., Aug., Sep., Oct., Nov., and 
Dec. as in Figure 124.
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Figure 124: Available date formats

1) In the main database window, click on the Tables icon (Figure 125). Right-
click on Months and select Open from the context menu.

2) Enter the name of the first month in the Name field. (Use 
abbreviations for the months.) Use the Down Arrow to 
move to the second row of the Name field. Enter the name 
of the second month. Continue until you have added all 
twelve months.

3) Save and close the table window.

Tip The Enter key can also be used to move from field 
entry  to field entry. For this example, enter Jan. in 
the first Name field. Enter moves the cursor to the 
ID field. Enter then moves the cursor to the second 
Name field.

Note The ID field contains <AutoField> until you use the 
Down Arrow to move to the second row. Then it 
becomes a 1. As you add the names of the months 
and move down another row, the rows of the ID 
field change to consecutive positive numbers.

Creating a database form
A form is a front end for data entry and editing. Instead of a list of records, a form 
can include additional text, graphics, selection boxes and many other elements.

Using the Wizard to create forms
Click on Tables in the Database pane as in Figure 125, right-click on a table in the 
Table section of the window and select Form Wizard from the menu. (The same 
wizard can be accessed by clicking on Forms in the Database pane and selecting 
Use Wizard to Create Form.)
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Step 1: Create the form.

1) Under Tables or queries select Relative Addresses Table from the drop down 
list (Figure 126). This creates the fields in the Available Fields list.

2) Since these fields are already in the correct order, click >> to move all these 
fields to the Fields in the Form list. 

Tip The arrow buttons between the Available Fields and Fields in the Form 
lists move fields between these two windows. The up and down arrows 
on the right side of the Fields in the Form window move a selected field 
up or down.

Figure 126: Form Wizard

3) Click Next.

4) This form will not have any subform. Click Next.

5) Arrange Controls: Choices for Arrangement of the main form are from left 
to right: Columnar-Labels Left, Columnar-Labels Top, Data Sheet, and In 
Blocks-Labels Above. Select Columnar-Labels Top and then click Next.

6) Set Data Entry: Use the default selection: The form is to display all data. 
Click Next.

7) Apply Styles: The Apply styles window contains ten backgrounds. Select the 
one you desire. Suggestion: leave it Beige. Select the Field border also. 
Suggestion: 3D look. Click Next.

Tip By moving the top of the Form Wizard window down enough to view the 
top of the form, you can see what a given style will look like by selecting 
it. Select as many as you want until you see the one that best suits you. 
This works for selecting the Field border also.
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8) Set Name: Sometimes the Form Name should be different from the Table 
Name it is linked with. It is your choice. Suggestion: Relative Addresses 
Form. Since modifications to this form will be made next, select Modify the 
Form under the question How do you want to proceed after creating the 
form? Click Finish.

Step 2: Modify the form.

Shorten and then move the fields. The final form contains four rows. Row 1 contains 
Address ID. Row 2 contains FirstName, LastName and SpouseName. Row 3 
contains Address, City, StateOrProvince, PostalCode and CountryOrRegion. Row 4 
contains PhoneNumber, MobileNumber and EmailAddress. Finally set the Tab order 
of the fields if necessary. 

Note When you click a field, it is selected. It has eight green squares (called 
handles)around it. Control+mouse click only the Field or its Label to 
select one but not both. Figure 127 shows the AddressID Field selected 
but not the AddressID Label.

Figure 127: Selected field

1) Control+click on the AddressID Field. Move the mouse pointer to the 
middle handle on the right side. It becomes Figure 128. Drag the handle to 
the left to shorten the field. Suggestion: Reduce the size of the field to half 
its length.

Figure 128: Single arrow

2) Repeat the process for each of the other fields. Adjust the length of a field to 
what is reasonable for it. (For example, the StateOrProvince field can be 
shortened considerably while the Address field might need to remain as it is.) 

Note Control+click on the label of a field selects it. This allows changes to 
be made for it. (More details on this are found in the Design View Form 
creation section.)

3) To move a field and its label, click on it to select it. Move the mouse pointer 
inside the field or its label. The mouse arrow becomes Figure 129. Drag the 
selected area to the desired place in the form. 
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Figure 129: Double arrow

Note Hold down the left mouse button while dragging the selected area.

Caution

   

Do not use Control+click when moving a field. It moves either the 
field or the label but not both. To move both, use a mouse click and 
drag to the desired spot.

4) To change the background of the form, right-click on the background to 
open a context menu and choose Page > Background. Select Color from 
the As dropdown list. The color can be changed by clicking on the desired 
color. Suggestion: select Orange 4. Click OK.

5) By changing the As window from Color to Graphic, a graphic file can be 
used as the background.  (Figure 130 uses flower.gif as its background.) 

 a) Click Cancel at the bottom of the Page style: Default window to close 
it.

 b) Use Tools > Options > OpenOffice.org > Paths > graphics to locate 
the folder containing flower.gif. (Write it down if necessary.)

 c) Reopen the Page Style: Default window. (Right-click one the page and 
select Page > Background from the context menu.)

 d) Select As > Graphic, and click the Browse button. 

• Browse to the folder containing flower.gif, and select it.

• Click Open, and then click OK in the Page Style: Default window.

6) The finished form should look something like Figure 130.
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Figure 130: Addressees form

7) If the words in the Labels of the form are too small, increase the font size. 

 a) Control+click on a label to select it.

 b) Right-click on the selected label. Select Control from the context 
menu.

 c) Click on the Font button to open the Font Character window (Figure
131). Here you can change the font, its size, typeface, and font effects 
(use the Font Effects tab for this last one). Make the changes you desire.

 d) Repeat a) through c) for the other labels.

 e) The fonts for the fields can be changed in the same way.

Figure 131: Changing Font characteristics

8) Check the tab order. The tab order should be correct, but we need to make 
sure.

 a) Click on the AddressID field to highlight it. 

 b) Click on the Activation Order icon in the Form toolbar. (See Figure 132.)
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Figure 132: Form toolbar

 c) Make sure the order of the fields matches 
the listing in Figure 146. If a field in in 
the wrong place in the list, click on the 
field to highlight it.

• If it needs moving up, click the Move 
Up button to put it where you want it.

• If it needs moving down, click the 
Move Down button to put it where 
you want it.

• When you have the correct order, 
click OK closing the Tab Order 
Window.

9) The Acquaintance Addresses form is 
completed. Save and close the Acquaintance 
Addresses OpenOffice.org Writer window to 
return to the Information – OpenOffice.org 
Base window.

To create the Relative Addressees form, follow the same nine steps as you just did 
for the Acquaintance Addressees form.

Caution

   

Do not use the copy and paste method to create new forms from 
already created ones.  When a form is created, a link is formed 
between it and the table for which it was created. Copying and 
pasting preserves this link to the original table. Each form created 
needs to be linked a separate table.

Creating forms in Design View
This method requires using the Database Controls and Database Form Design 
Toolbars extensively. These techniques are beyond the scope of this document. 
Instructions for creating forms using Design view will be described in the Database 
Guide.

Creating subforms
Again, this is beyond the scope of this document. Creation of subforms will be 
described in the Database Guide.
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Creating a view of multiple tables
In the main database window (Information – OpenOffice.org Base), click on the 
Table icon to highlight it. In the Task section, there are three icons. The first two we 
have used to create tables. The third icon is labeled Create View. Clicking on this 
icon opens the View1 – OpenOffice.org View Design. While it has a different name, 
its functions and appearance are similar to when you create a query using the Design 
View.

Queries can be created from this window following the directions given in “Creating
queries” on page 176. I advise reading the entire section on creating queries first.

You can also create a table from this window which is a combination of the already 
created tables. Since the steps are the same as those used when creating a query in 
Design View, wait until you have read the entire section on creating queries.

To create such a table, follow the first three steps in “Using the Design View to
create a query” on page 180. At the end of step 3, a cross-reference returns you to 
this section. Save the table with a name of your choosing, and then close the 
window.

Accessing other data sources

OpenOffice.org allows data sources to be accessed and then linked into OOo 
documents. For example, a mail merge links an external document containing a list 
of names and addresses into a letter, with one copy of the letter being generated for 
each entry.

In OpenOffice.org 1.x, the option Tools > Data Sources allowed a 
new data source (or database) to be registered so any OOo component 
could use it. This option does not exist in OOo2.0. 
To register a data source in OOo2.0, select File > New > Database, 
select Connect to an existing database, and select the type of data 
source to connect to. The exact source can then be chosen in the 
wizard.

Once a data source has been registered, it can be used in any other OOo component 
(for example Writer or Calc) by selecting View > Data Sources or pressing the F4 
key. 

New > Database opens the Database Wizard window. Select Connect to an 
existing database. This allows access to the list of data sources that can be 
registered with OOo. These data sources can be accessed similarly to a dBase 
database as explained in the next section.
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Tip Mozilla Address Books and dBase databases (among others) can be 
accessed, and entries can be added or changed. Spreadsheets can be 
accessed, but no changes can be made in the spreadsheet entries.

Accessing a dBase database
1) File > New > Database  opens the Database Wizard window. 

Note Clicking the New icon and Database in the drop-down menu also open 
the Database Wizard window. (See Figure 115.)

2) Select Connect to an existing database. Pressing the TAB key highlights 
the Database type drop-down list. Typing D selects dBase. Click Next. 

Note Clicking the arrows opens a menu from which you can select dBase 
(Figure 134).

Figure 134: Database type selection

3) Click Browse and select the folder containing the database. Click Next.

4) Accept the default settings: Register the database for me, and Open the 
database for editing. Click Finish. Name and save the database in the 
location of your choice.

5) Create the Form using the Form Wizard as explained in “Creating a database
form” beginning on page 164.

Accessing a Mozilla address book
Accessing a Mozilla Address Book is very similar to accessing a dBase database. 

1) Select File > New > Database. 

2) Select Connect to an existing database. Select Mozilla Address Book as the 
database type (Figure 134).

3) Register this data source. 

These are steps 1, 2 and 4 of Accessing a dBase Database above.
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Accessing spreadsheets
Accessing a spreadsheet is also very similar to accessing a dBase database. 

1) Select File > New > Database.

2) Select Connect to an existing database. Select Spreadsheet as the Database 
type (Figure 134).

3) Click Browse to locate the spreadsheet you want to access. If the 
spreadsheet is password protected, check the Password required box. Click 
Next.

4) If the spreadsheet requires a user’s name, enter it. If a password is also 
required, check its box. Click Next.

Registering databases created by OOo2.0
This is a simple procedure. Tools > Options > OpenOffice.org Base > Databases. 
Under Registered databases,there is a list of these databases. Below this list are 
three buttons: New..., Delete, Edit... To register a database created by OOo2.0:

1) Click New.

2) Browse to where the database is located.

3) Make sure the registered name is correct. 

4) Click OK.

Using data sources in OpenOffice.org

Having registered the data source, whether a spreadsheet, text document, external 
database or other accepted data source, you can use it in other OpenOffice.org 
components including Writer and Calc.

Viewing data sources
Open a document in Writer or Calc. To view the data sources available, press F4 or 
select View > Data Sources from the pull-down menu. This brings up a list of 
registered databases, which will include Bibliography and any other database 
registered.

To view each database, click on the + to the left of the database’s name. (This has 
been done for the Information database in Figure 135.) This brings up Tables and 
Queries. Click on the + next to Tables to view the individual tables created. Now 
double-click on a table to see all the records held in it.
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Figure 135: Databases

Editing data sources
Some data sources can be edited in the View Data Sources dialog. A spreadsheet can 
not. A record can be edited, added or deleted.

The data is displayed on the right side of the screen. Click in a field to edit the value.

Beneath the records are five tiny buttons. The first four move backwards or forwards 
through the records, or to the beginning or end. The fifth button, with a small star, 
inserts a new record (Figure 136).

Figure 136: View Data Sources Navigation Buttons

To delete a record, right-click on the gray box to the left of a row to highlight the 
entire row, and select Delete Rows to remove the selected row.

Launching Base to work on data sources
You can launch OOo Base at any time from the View Data Source pane. Just right-
click on a database or the Tables or Queries icons and select Edit Database File. 
Once in Base, you can edit, add and delete tables, queries, forms and reports.

Using data sources in OOo documents
To insert a field from a table into a document (for example a Calc spreadsheet or 
Writer document), click on the field name (the gray square at the top of the field list) 
and, with the left mouse button held down, drag the field onto the document. In a 
Writer document, it will appear as <FIELD> (where FIELD is the name of the field 
you dragged). In Calc it will appear as a text box.
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One common way to use a data source is to perform a mail merge. Selecting Tools > 
Mail Merge Wizard or clicking on the Mail Merge icon (a small paper-and-
envelope icon on the View Data Source pane) launches the Mail Merge wizard 
which steps through creating a mail merge document. This is covered in the chapter 
titled “Using Mail Merge” in the Writer Guide.

Entering data in a form

Records are used to organize the data we enter into a form. Enter all the data 
concerning each person that you want to be a part of the database. When you press 
the Tab key after entering the data in the last field of the form for the first person, all 
the fields are cleared except possibly the AddressID field. You have just completed 
making the first record for the Acquaintance Addressees form of your database. 
Each time you do this, you are adding another record. (For example, the record in 
Figure 137. If the cursor is in in the EmailAddress field, pressing the Tab key clears 
all of the fields in the form exept for the AddressID field. The number in the box at 
the bottom left changes from the number 1 to the number 2.)

At the bottom left of the form is the word Record. After it is information as to which 
record is showing and how many records there are. In this case, record 1 of  3 
records is showing. To the right of this are additional icons which allow you to move 
from one record to another (the arrows), add a new record, delete a record, plus 
more functions.

The purpose of a database is to store information in a way that can be accessed later 
when needed. This section describes how to enter your data so that it can be used 
later. You need to be in the Information – OpenOffice.org Base window. In our 
example we will be entering data in the Acquaintance Information form. Adding 
data to the other forms should be done the same way.

Figure 137: Single Record 

174 Chapter 10  Getting Started with Base



Entering data in a form

If you do not want to use your own data to fill in the fields of this form, use the 
following information for five fictitious families. Each field entry is separated by a 
semi-colon (;). If the ID field contains <AutoField>, begin entering the data with in 
the FirstName field. Otherwise, enter the numbers in the ID field: the number 1 in 
the first record, the number 2 in the second record, and continue through the number 
5 in the fifth record. (Not all records will all the fields filled in. For example, Sam & 
Alice do not have any children)

1; Sam; Spade; Alice; Aug.; 22; 2000; Apr.; 1; 1980; May; 31; 1982

2; Billy; Appleseed; Ruth; Jul.; 4; 1996; Dec.; 25; 1974;  Jan.; 1; 1975; Chad; Feb.; 
2; 1998

3; Junior; Salesman; Deloris; Jul.; 31; 1992; Apr.; 1; 1973; Sep.; 22; 1975; 
Samantha; Jan.; 5; 1993

4; Jamie; Spencer; Alice;  Jan.; 1; 2004; Apr.; 22; 1985; Jun.; 15; 1985

5; Webster; Callahan; Betty; Nov.; 22; 1990; Aug.; 16; 1968; Dec.; 25; 1970; Ed; 
Jan.; 10; 1991

1) If the Forms icon is not highlighted, select the Forms icon on the left, or use 
Alt+m. Double-click on the Acquaintance Information icon.

2) ID field:

• If <AutoField> is not present in the ID field, click inside this field and 
enter a number. (Suggestion: enter 1.) Then press the Tab key.

• If <AutoField> is present, click in the FirstName field.

3) For the rest of the fields in the form beginning with FirstName:

• If a field should be left empty, press the Tab key to move to the next field.

• Otherwise, enter the data and press the Tab key to move to the next field.

• To move backwards through the fields, use the Shift+Tab combination.

• Pressing the Tab key in the last field enters all the data for that record 
(saves it) and begins the next record. (Shift+Tab while the cursor is in the 
first field of a record enters the data for that record (saves it) and moves 
the cursor to the last field of the previous record. This only works for 
record number 2 and above.)

4) When you have entered all the data you need, close the Acquaintance 
Information – OpenOffice.org Writer window.

Enter data in the Acquaintance Addresses form the same way. Note that the first 
three fields of this form are to be the same as in the Acquaintance Information form. 
Enter the other data as appropriate following the same steps as for the Acquaintance 
Information form. 
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Creating queries

Queries are used to get specific information from a database. In our example 
database, a simple query could  create a list of all the wedding anniversaries in a 
given month. We will do this using a wizard. A more complex query could  create a 
list of all the birthdays in a given month. We will do this using the Design View. We 
will create a query searching the Acquaintance Addresses Information tables for all 
wedding anniversaries in Julyand the addresses of the couples for which this applies. 
This query will include the following information: FirstName, LastName, 
SpouseName, Address, City, StateOrProvince, PostalCode, CountryOrRegion, and 
the wedding date (month, day, and year). This way we can find out who has a 
wedding anniversary in July, what day of July it is, and the couple’s address so we 
can send them a card.

Note Queries blur the differences between a database and a data source. A 
database is only one type of data source. However, searching for usable 
information from a data source requires a query. Since the query, one 
part of a database, does this, the data source appears to become one part 
of that database: its table or tables. Query results, themselves, are 
special tables within the database.

Using the Wizard to create a query
Make sure you are in the Information – OpenOffice.org Base window. Click the 
Queries icon to highlight it. In the Task section of this window, double-click on the 
Use Wizard to create Query icon. This opens the Query Wizard window (Figure
138).

Note When working with a query, more than one table can be used. Since 
different tables may contain the exact same field names, the format for 
naming fields in a query is Table name and field name. A period (.) is 
placed between the table name and the field name. In our example, the 
table name is two words, so the period comes after the second word of the 
table name and before the field name. (For example, the FirstName field 
of the Acquaintance Addressees table is named Acquaintance 
Addressees.FirstName. The FirstName field of the Acquaintance 
Information table is named Acquaintance Information.FirstName.)

Step 1: Select the fields.

1) Since most of the information we want is in the Acquaintance Addresses, 
make sure this table is listed under Tables. All the fields of the Acquaintance 
Addresses table are listed in the Available fields window.
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Figure 138: First page of the Query Wizard

Using the arrow (>), move these Available fields over to the Fields in the 
Query window: Acquaintance Addressees.FirstName, Acquaintance 
Addresses.LastName, Acquaintance Addressees.SpouseName, Acquaintance 
Addresses.Address, Acquaintance Addresses.City, Acquaintance 
Addresses.StateOrProvince, Acquaintance Addresses.PostalCode, and 
Acquaintance Addressees.CountryOrRegion.

2) Change the Tables drop down entry from Acquaintance Addresses to 
Acquaintance Information.

3) Using the arrow (>), move these Available fields over to the Fields in the 
Query window: Acquaintance Information.WedDateM, Acquaintance 
Information.WedDateD, and Acquaintance Information.WedDateY. These 
three fields will appear below the Acquaintance 
Addressees.CountryOrRegion field.

4) Click Next.
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Step 2: Select the sorting order.

Up to four fields can be used to sort the information of our query. A little simple 
logic helps at this point. Which field is most important? I suggest listing the date of 
the month first (WedDateD). The LastName could come second. The FirstName or 
SpouseName could be the third field to sort by. You might want to sort them in a 
different way. Feel free to do so.

1) In the drop-down list under Sort by, select Acquaintance 
Information.WedDateD.

2) In the drop-down list under the first Then by, select Acquaintance 
Addresses.LastName.

3) In the drop-down list under the second Then by, select Acquaintance 
Addresses.FirstName.

4) Click Next.

Step 3: Select the search conditions.

1) Since we are only searching for information in one field, the default setting 
of Match all of the following will work. 

Note Match any of the following setting could be used in a query looking for 
all the birthdays in April for example. This will be done in the next 
section: Create a report using the Design View.

2) Select Acquaintance Information.WedDateM from the top Fields drop down 
list. Set the condition to is equal to. Enter 7 as the value. (July is the seventh 
month of the calendar year.) Click Next at the bottom of the window.

Step 4: Select type of query.

We want simple information, so the default setting: Detailed query is what we want. 
Click Next at the bottom of the window.

Note Since we have a simple query, the Grouping and Grouping conditions 
are not needed. Those two steps are skipped in our query.

Step 5: Assign aliases if desired.

We want the default settings. Click Next at the bottom of the window.

Step 6: Overview.

Name the query (suggestion: Query_Weddings). To the right of this are two choices. 
Select Modify Query. Click Finish.
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Step 7: Modifying the query.

The Query_Weddings window opens. The tables used in our query are shown in 
Figure 139. We want to link these two tables so that they act as one.

Figure 139: Tables used in Query

If the two tables are not linked, the first three columns look like Figure 140. All of 
the entries of the first table are listed.

Figure 140: Query results with unlinked tables

To link the two tables, click on the AddressID field of the Acquaintance Addressees 
table (Figure 139) and drag the mouse cursor over to the ID field of the 
Acquaintance Information table of Figure 139. A line will appear connecting the 
AddressID and ID fields. 

Once we have linked the two tables, we can run the query again. To do so, click the 
Run Query icon. (The one with the green check in Figure 141.) The first three 
columns of the result are in Figure 142. Two couples were married in July, and only 
these two are listed using the linked tables.

Figure 141: Run Query icon

Figure 142: Query results with linked tables
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Note When editing a Query, you can change the size and position of the 
tables. Click+drag on the heading of the table to move it. Moving the 
mouse cursor to an edge cause the cursor to change to a double arrow; 
increase or decrease the size of the table the same way you increase or 
decrease the size of a window.

Tip By editing the Query_Weddings we can get a list of the wedding 
anniversaries for any given month. In the Information – OpenOffice.org 
Base window, select Queries. Right click on the Query_Weddings icon 
and select Edit from the context menu. In the Query_Weddings window, 
replace the '7' with the number of  whatever month you want. (The 7 is in 
the Criterion row and WedDateM column.) Make sure to put an 
apostrophe before and after the number. Then rerun the Query (Figure
141).
You can create a form for the Query_Weddings query. Right-click on 
the Query_Weddings icon, and select Form Wizard from the context 
menu. See “Creating a database form” on page 164 for directions.

Using the Design View to create a query
Creating a query using Design View is not as hard as it may first seem. For our 
query, we want to know who has a birthday in August. Go to the Task section of the 
Information – OpenOffice.org Base window. Select Create Query in Design View. 
The Query1 – OpenOffice.org Query Design and  Add Table windows open.

Step 1: Add tables.
1) Click on Acquaintance Addressees, and then click Add.

2) Click on Acquaintance Information, and then click Add.

3) Click Close.

This opens these two tables. (See Figure 139.)

Step 2: Link the two tables.
Click on AddressID in the Acquaintance Addresses table and drag the mouse cursor 
to Id in the Acquaintance Information table. A line segment now connects these two 
fields.

Step 3: Fill in the names of the fields of the query.
Double-click on the fields you want to use in the order you want to use them. Some 
of the fields will come from the Acquaintance Addressees table, and some of the 
fields will come from the Acquaintance Information table. If you accidentally put a 
field in the wrong order, click on the gray rectangle above that field and drag its 
entire column to the correct position.
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1) From the Acquaintance Addressees table, double-click on these fields in this 
order: FirstName, LastName, SpouseName.

2) From the Acquaintance Information table, double-click on these fields in 
this order: HusBDM, HusBDD, HusBDY, WifeBDM, WifeBDD, WifeBDY, 
Ch1, Ch1BDM, Ch1BDD, and Ch1BDY.

3) From the Acquaintance Addressees table, double-click on these fields in this 
order: Address, City, StateOrProvince, PostalCode, CountryOrRegion.

Tip The above steps can also be used to create a single table from the fields of 
two or more tables. If this is what you are doing with these three steps, 
please now return to “Creating a view of multiple tables” on page 170. 
Otherwise ignore this tip.

Step 4: Enter the criteria for the query.

We enter the information we will be searching for in the Criterion row of our query 
(Figure 143). How we place this information determines what our results will be. If 
we want two or more fields to have specific information in them at the same time, 
we enter all of this information in the Criterion row. This is referred to as the And 
condition. The sought for information is all placed in the Criterion row in the 
columns with the proper field names. 

Figure 143: Query setup table

In our example, we are looking for all families in which at least one of its members 
has a birthday in August. This is the Or condition. (The husband Or the wife Or the 
child was born in August.)

Note To fully use queries requires a knowledge of mathematics and 
specifically set operations (unions, intersections, complements, and any 
combinations of these). 
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1) All entries in the Query setup table must be in this form: 'entry' (an 
apostrophe, the entry, and another apostrophe). 

2) Since August is the eighth month, an 8 will be entered in the fields. In , the 
four rows below the Criterion row are labeled Or. When an entry exists in 
the Criterion row and another in the first Or row, a search is made for all 
record which fit either the information in the Criterion row or the Or row.

3) The fields we are concerned with are HusBDM, WifeBDM, and Ch1BDM.

• In the Criterion row and HusBDM column, enter '8' (apostrophe 8 
apostrophe).

• In the first Or row and WifeBDM column enter '8'.

• In the second Or row and Ch1BDM column enter '8'. 

• The results should look somewhat like Figure 144. (The figure does not 
show the FirstName, LastName, and SpouseName fields. Your table will 
have these three fields between the column containing the row names 
and the HusBDM column.) 

Figure 144: Using the Or condition over three fields

4) Click the Run Query icon (Figure 141 pn page 179).

5) Save the Query, name it Query_Birthdays and close the window.

Tip This query can be used for finding what people have birthdays in any 
given month.  Change the 8’s to the number of a different month. Make 
sure that an apostrophe comes before and after the number.
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Creating reports

Reports provide information found in the database in a useful way. In this they are 
similar to queries. Reports are generated from the database’s tables or queries. They 
can contain all of the fields of the table or query or just a selected group of fields. 
Reports can be static or dynamic in nature. Static reports contain the data in the 
selected fields at the time the report was created. Dynamic reports can be updated to 
show the latest data. 

We will create a dynamic report of the wedding anniversaries of a given month. The 
Query_Weddings query is the basis for our report: Monthly Wedding Anniversaries. 
Editing the query for the month we seek and saving the query changes updates the 
report at the same time.

Step 1: Access the report generating wizard in one of two ways. 

• Click on the Reports icon in the Information – OpenOffice.org Base 
window, and click on Use Wizard to Create Report.

or

• Right-click on a query or table and select Report Wizard in the context 
menu.

Step 2: The Report Wizard (Figure 145).

1) In the Tables or Queries drop down list, select Query: Query_Weddings.

• Use the double arrow (>>) to move all the fields from Available fields 
to Fields in report.

• Click Next.

2) Change the labels for part of the fields.

• For labels containing more than one word, put a space between words. 
(For example, FirstName becomes First Name, LastName becomes Last 
Name, and CountryOrRegion becomes Country Or Region.)

• Change PostalCode to Postal Code, WedDateM to Month, WedDateD to 
Date, and WedDateY to Year.

• Click Next.

3) Grouping. We will group items in this report by the LastName field. 

• Click on LastName in the Fields list and use the arrow (>) to move it to 
the Groupings list.

• Click Next.
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Figure 145. The first page of the Report Wizard

4) Layout of the report: We will use the default settings. This includes the 
Landscape orientation at the bottom of the Report Wizard. Click Next.

Note It might be worthwhile spending some time selecting the different layout 
choices available in reports just to see which ones can meet your needs.

5) Creating the report: 

• Name the report Query_Weddings.

• What kind of report do you want to create? Select Dynamic.

• How do you want to proceed after creating the report? Select Modify 
report layout.

• Click Finish.

6) Modifying the report. The report contains a table with the information from 
the Query. It may contain some unrecognizable words (Figure 146). We will 
be changing the vertical alignment of the second row.

• Click on the cell below label First Name and drag the mouse cursor to 
the right to highlight the second row. 
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• Right-click anywhere in a highlighted cell. Select Cell > Center to set 
the correct alignment.

• If you desire, you can change the widths of any of the cells at this point.

• Save and Close the Query_Weddings – OpenOffice.org Writer window.

Figure 146: First part of Report table

Note Queries can be changed from the Information – OpenOffice.org Base 
window by right-clicking on the desired Query and selecting Edit from 
the context menu.

Tip If a report is created as dynamic and the report is based upon a query, 
the report will change every time the query changes. (For example, you 
change the Query_Birthdays query to search for April instead of 
August. The next time the Query_Birthdays report is accessed, it will 
list the information for the people with birthdays in April instead of 
August.)
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Chapter 1111
  Getting Started with Math

OpenOffice.org’s Equation Editor

OpenOffice.org (OOo) has a component for mathematical equations.  It is most 
commonly used as an equation editor for text documents, but it can also be used 
with other types of documents or stand-alone.  When used inside Writer, the 
equation is treated as an object inside the text document.

Note The equation editor is for writing equations in symbolic form (as in 
equation 1). If you want to evaluate a numeric value, see the Calc Guide.

df x
dx

= ln x tan−1x2  
(1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Selection 
window appears. You will also see a small box (with a gray border) in your 
document, where the formula will be displayed. See Figure 147.

The equation editor uses a markup language to represent formulas. For example, 
%beta creates the Greek character beta (  ). This markup is designed to read 
similar to English whenever possible. For example, a over b produces a fraction: 
a
b

.
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Figure 147. Equation Editor, Selection window, and location of resulting equation.

Entering a formula

There are three ways to enter a formula:

• Select a symbol from the Selection window.

• Right-click on the equation editor and select the symbol from the context 
menu.

• Type markup in the equation editor.

The context menu and the Selection window insert the markup corresponding to a 
symbol.  Incidentally, this provides a convenient way to learn the OOoMath markup.

Note Click on the document body to exit the formula editor.
Double-click on a formula to enter the formula editor again.
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The Selection window
The simplest method for entering a formula is the Selection window, shown in 
Figure 148.

Figure 148. Symbols are divided into categories

The Selection window is divided into two main portions.

• The top shows the symbol categories. Click on these to change the list of 
symbols.

• The bottom shows the symbols available in the current category.

TIP You can hide (or unhide) the Selection window with View > Selection.

Example 1: 5×4
For this example we will enter a simple formula: 5×4 On the Selection window:

1) Select the top-left button of the categories (top) section (Figure 149).

2) Click on  the multiplication symbol (shown in Figure 149).
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Figure 149. Unary/binary operators

When you select the multiplication symbol on the Selection window, two things 
happen:

• The equation editor shows the markup: <?> times <?>

• The body of the document shows a gray box with the figure: ×

Figure 150. The multiplication symbol

The “ <?> ” symbols (Figure 150) are placeholders that you can replace by other 
text. The equation will update automatically, and the result should resemble Figure
151.
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Figure 151. Result of entering "5" and "4" next to the "times" operator

TIP To keep the equation from updating automatically, select View 
>AutoUpdate display. 
To update a formula manually, press F9 or select View > Update.

Right-click menu
Another way to access mathematical symbols is to right-click on the equation editor. 
This produces a menu as shown in Figure 152.

Figure 152. Right-click menu

Note The entries in this menu correspond exactly to those in the Selection 
window.
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Markup
You can type the markup directly on the equation editor. For example, you can type 
“5 times 4” to obtain 5×4 . If you know the markup, this can be the fastest way to 
enter a formula.

TIP As a mnemonic, the formula markup resembles the way the formula 
reads in English.

Below is a short list of common equations and their corresponding markup.

DisplayDisplay CommandCommand DisplayDisplay CommandCommand

a=b a = b a sqrt {a}

a2 a^2 an
a_n

∫ f xdx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Greek characters
Greek characters (  , , , , etc) are common in mathematical formulas. These 
characters are not available in the selection box or the right-click menu. 
Fortunately, the markup for Greek characters is simple: Type a % sign followed the 
name of the character, in English.

• To type a lowercase character, write the name of the character in lowercase.

• To type an uppercase character, write the name of the character in 
uppercase.

See the table on the next page for some examples:
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LowercaseLowercase UppercaseUppercase

%alpha
 

%ALPHA  A

%beta 
 

%BETA  B

%gamma
 

%GAMMA  

%psi 
 

%PSI   

%phi 
 

%PHI   

%theta
 

%THETA  

Note A complete table of Greek characters is included in the chapter titled 
“Math Objects” in the Writer Guide..

Another way to enter Greek characters is by using the catalog window. Go to Tools 
> Catalog. The catalog window is shown in Figure 153. Under “Symbol Set” select 
“Greek” and double-click on a Greek letter from the list.

Figure 153. Catalog - used for entering Greek characters
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Example 2:  ≃ 3.14159
For this example we will suppose that:

• We want to enter the above formula (the value of pi rounded to 5 decimal 
places).

• We know the name of the Greek character (“pi”).

• But we don’t know the markup associated with the ≃  symbol.

Step 1: Type “%” followed by the text “pi”. This displays the Greek character  .

Step 2: Open the Selection window (View > Selection).

Step 3: The ≃  symbol is a relation, so we click on the relations button . If you 
hover the mouse over this button you see the tooltip “Relations” (Figure 154).

Figure 154. Tooltip indicates the "Relations" button.

Step 4: Delete the <?> text and add “3.14159” at the end of the equation. Hence we 
end up with the markup “ %pi simeq 3.14159 ”. The result is shown in Figure
155.

Figure 155. Final result
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Formula editor as a floating window
As seen in Figure 147, the formula editor can cover a large part of the Writer 
window. To turn the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 156.

2) Hold down the Control key and double-click.

Figure 156. Hold down the Control key and double-click on the border of the math editor  
to turn it into a floating window.

Figure 157 shows the result. You can make the floating window back into an 
embedded frame, using the same steps. Hold down the Control  key and double-
click the window frame.

Figure 157. Equation editor as a floating window
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How can I make a formula bigger?
This is one of the most common questions people ask about OOoMath. The answer 
is simple, but not intuitive.

1) Start the formula editor and go to Fonts > Font size.

Figure 158. Changing the font size for a formula

2) Select a larger font size under “Base Size” (top-most entry), as shown in 
Figure 159.

Figure 159. Edit "Base size" (top) to make a formula bigger.

The result of this change is illustrated in Figure 160.
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Figure 160. Result of changing the base font size.

Formula layout

The most difficult part of using OOoMath comes when writing complicated 
equations. This section provides some advice about writing complex formulas.

Brackets are your friends
OOoMath knows nothing about order of operation. You must use brackets to state 
order of operations explicitly. Consider the following example:

MarkupMarkup ResultResult

2 over  x + 1 2
x
1

2 over {x + 1} 2
x1

Equations over more than one line
Suppose you want to type an equation covering more than one line. For example:

x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the 
Enter key, though the markup goes to a new line, the resulting equation does not. 
You must type the newline command explicitly. This is illustrated in the table below.

MarkupMarkup ResultResult

x = 3
y = 1

x=3 y=1

x = 3 newline
y = 1

x=3
y=1
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How do I add limits to my sum/integral?
The “sum” and “int” commands can (optionally) take in the parameters “from” and 
“to”. These are used for lower and upper limits respectively. These parameters can 
be used singly or together.

MarkupMarkup ResultResult

sum from k = 1 to n a_k
∑
k=1

n

ak

int from 0 to x f(t) dt
∫
0

x

f t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n}
∑
∞

2−n

Note For more details on integrals and sums, see “Math Objects” in the 
Writer Guide.

Brackets with matrices look ugly!
For background, we start with an overview of the matrix command:

MarkupMarkup ResultResult

matrix { a # b ## c # d } a b
c d

Note Rows are separated by two #’s and entries within each row are separated 
by one #.
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The first problem people have with matrices is that brackets don’t “scale” with the 
matrix:

MarkupMarkup ResultResult

(  matrix { a # b ## c # d }  ) 
a b
c d



OOoMath provides “scalable” brackets. That is, the brackets grow in size to match 
the size of their contents. Use the commands left( and right) to make scalable 
brackets.

MarkupMarkup ResultResult

left(  matrix { a # b ## c # d } 
right) a b

c d
TIP Use left[ and right] to obtain square brackets.

How do I make a derivative?
Making derivatives essentially comes down to one trick: Tell OOo it’s a fraction.

In other words, you have to use the “over” command. Combine this with either the 
letter “d” (for a total derivative) or the “partial” command (for a partial derivative) 
to achieve the effect of a derivative.

MarkupMarkup ResultResult

{df} over {dx} df
dx

{partial f} over {partial y} ∂ f
∂ y

{partial^2 f} over {partial 
t^2} ∂2 f

∂ t 2

Note Notice that we had to use squiggly brackets to make the derivative.
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Numbering equations
Equation numbering is one of OOoMath’s best hidden features. The steps are 
simple, but obscure:

1) Start a new line.

2) Type “fn” and then press F3.

The “fn” is replaced by a numbered formula:

E=mc2  (2)
Now you can double-click on the formula to edit it. For example, here is the 
Riemann Zeta function:

 z =∑
n=1

∞ 1
nz

 (3)

You can reference an equation (“as shown in Equation (2)”) with these steps:

1) Insert > Cross-reference..

2) Click on the References tab (Figure 161).

3) Under Type, select Text.

4) Under Selection, pick the equation number.

5) Under Format, choose Reference.

6) Click Insert.

Done! If you later add more equations to the paper before the referenced equation, 
all the equations will automatically renumber and the cross-references will update.
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Figure 161. Inserting a cross-reference to an equation number.

TIP To insert the equation number without parentheses around it, choose 
Numbering under Format instead of Reference.

200 Chapter 11  Getting Started with Math



Chapter 1212
  Working with Templates

A template is a model that you use to create other documents. For example, you can 
create a template for business reports that has your company’s logo on the first page. 
New documents created from this template will all have your company’s logo on the 
first page.

Templates can contain anything that regular documents can contain, such as text, 
graphics, a set of styles, and user-specific setup information such as measurement 
units, language, the default printer, and toolbar and menu customization. 

All documents in OpenOffice.org (OOo) are based on templates. You can create a 
specific template for any document type (text, spreadsheet, drawing, presentation). If 
you do not specify a template when you start a new document, then the document is 
based on the default template for that type of document. If you have not specified a 
default template, OOo uses the blank template for that type of document that is 
installed with OOo. See “Setting a default template” on page 207 for more 
information.

This chapter shows you how to:
• Use a template to create a document.
• Create a template.
• Edit a template.
• Set a default template.
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Using a template to create a document

To use a template to create a document:

1) From the main menu, choose File > New > Templates and Documents. 
The Templates and Documents window opens. (See Figure 162.)

2) In the box on the left, click the Templates icon if it is not already selected. A 
list of template folders appears in the center box. 

3) Double-click the folder that contains the template that you want to use. A list 
of all the templates contained in that folder appears in the center box. 

4) Click the template that you want to use. You can preview the selected 
template or view the template’s properties:

• To preview the template, click the Preview icon. (For the location of the 
Preview icon, see Figure 162.) A preview of the template appears in the 
box on the right.

• To view the template’s properties, click the Document Properties icon. 
(For the location of the Document Properties icon, see Figure 162.) The 
template’s properties appear in the box on the right.

5) Click Open. The Templates and Documents window closes and a new 
document based on the selected template opens in OOo. You can then edit 
and save the new document just as you would any other document.

Figure 162. Templates and Documents window
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Creating a template

You can create your own templates in two ways:
• From a document.
• Using a wizard.

Creating a template from a document
To create a template from a document:

1) Open a new or existing document of the type you want to make into a 
template (text document, spreadsheet, drawing, presentation).

2) Add the content and styles that you want.

3) From the main menu, choose File > Templates > Save. The Templates 
window opens (See Figure 163).

4) In the New template field, enter a name for the new template.

5) In the Categories list box, click the category to which you want to assign 
the template.  (The category is simply the template folder in which you want 
to save the template. For example, to save the template in the “My 
Templates” folder, click the My Templates category.)

To learn more about template folders, see “Organizing templates” on page 208.

6) Click OK. OOo saves the new template and the Templates window closes. 

OOo 1.X previously used a “Default” folder in place of the new 
“My Templates” folder.

Figure 163. Saving a new template
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Any settings that can be added to or modified in a document can be saved in a 
template. For example, below are some of the settings (although not exhaustive) that 
can be included in a Writer document and then saved as a template for later use:

• Printer settings: which printer, single sided / double sided, and paper size, etc.
• Styles to be used, including character, page, frame, numbering and 

paragraph styles.
• Format and settings regarding indexes, tables, bibliographies, table of 

contents.

Creating a template using a wizard
You can use wizards to create these types of templates:

• Letter
• Fax
• Agenda
• Presentation
• Web page

For example, the Fax Wizard steps you through the following choices:
• Type of fax (business or personal)
• Document elements like the date, subject line (business fax), salutation, and 

complementary close
• Options for sender and recipient information (business fax)
• Text to include in the footer (business fax)

To create a template using a wizard:
1) From the main menu, choose File > Wizards > type of template required 

(Figure 164).

Figure 164. Creating a template using a wizard
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2) Follow the instructions on the pages of the wizard. This process will be 
slightly different for each type of template, but the format is very similar.

3) In the last section of the wizard, the template should be saved. The default 
location is your user templates directory, but you can choose a different 
location if you prefer. 

4) Finally, you have the option of creating a new document from your template 
immediately, or manually changing the template. For future documents, you 
can re-use the template created by the wizard, just as you would use any 
other template.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply 
the template’s styles to documents that were created from that template. (Note that 
you can only reapply styles. You cannot reapply content.)

To edit a template:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window opens. (See Figure 165.)

Figure 165. Template management window

2) In the box on the left, double-click the folder that contains the template that 
you want to edit. A list of all the templates contained in that folder appears 
underneath the folder name.

3) Click the template that you want to edit. 
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4) Click the Commands button.

5) From the drop-down menu, choose Edit. The Template Management 
window closes and the selected template opens.

6) Edit the template just as you would any other document. To save your 
changes, choose File > Save from the main menu. 

The next time that you open a document that was created from the changed template, 
the following message appears:

Figure 166. Apply current styles message 

Click Yes to apply the template’s changed styles to the document. Click No if you do 
not want to apply the template’s changed styles to the document. Whichever option 
you choose, the message box closes and the document opens in OOo.

Note Automatic updating from a template (as described above) does not work 
in OOo 2.0.2. This is a known bug, which will be fixed in 2.0.3. To re-
enable updating in files created using OOo 2.0.2:
1) Use Tools > Macros > Organize Macros > OpenOffice.org Basic. 

Select the document from the list, click the +, and select Standard. 
If Standard has a + beside it, click that and select a module.

2) Name the macro. For example, you could call it FixDocument. If the 
Edit button is active, click it. If the Edit button is not active, click 
New, type a module name in the pop-up dialog, and click OK.

3) In the Basic window, enter the following:
Sub FixDocument
TemplateName = 
ThisComponent.DocumentInfo.Template
  if TemplateName <> "" then
  ThisComponent.DocumentInfo.Template = 
TemplateName
  end if
End Sub

4) Click the Run BASIC icon, then close the Basic window.
5) Save the document.
Next time when you open this document you will have the update from 
template feature back.
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Setting a default template

If you create a document by choosing File > New > Text Document (or 
Spreadsheet, Presentation, or Drawing) from the main menu, OOo creates the 
document from the Default template for that type of document. You can, however, 
set a custom template to be the default. You can reset the default later if you choose.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders 
displayed in the Template Management window. To save a template in one of these 
folders, do one of the following:

• Create the template as described in “Creating a template” on page 203.

• Import the template into the desired folder as described in “Importing a
template” on page 209.

To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window (Figure 165) opens.

2) In the box on the left, double-click the folder containing the template that 
you want to set as the default.

3) Click the template that you want to set as the default.

4) Click the Commands button. 

5) From the drop-down menu, choose Set As Default Template. The next time 
that you create a document by choosing File > New, the document will be 
created from this template. 

Resetting OOo’s Default template as the default
To reset OOo’s Default template for a document type as the default:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window (Figure 165) opens.

2) In the box on the left, click any folder.

3) Click the Commands button.
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4) From the drop-down menu, choose Reset Default Template > Text 
Document. The next time that you create a document by choosing File > 
New, the document will be created from OOo’s Default template for that 
document type.

Organizing templates

OOo can only use templates that are in OOo template folders. You can, however, 
create new OOo template folders and use them to organize your templates. For 
example, you might have one template folder for report templates and another for 
letter templates. You can also import and export templates. 

To begin, choose File > Templates > Organize from the main menu. The Template 
Management window (Figure 165) opens.

Creating a template folder
To create a template folder:

1) In the Template Management window (Figure 165), in the box on the left, 
click any folder.

2) Click the Commands button.

3) From the drop-down menu, choose New. A new folder called Untitled 
appears.

4) Type a name for the new folder and then press the Enter key on your 
keyboard. OOo saves the folder with the name that you entered.

5) To close the Template Management window, click Close.

Deleting a template folder

To delete a template folder:

1) In the Template Management window, click the folder that you want to 
delete.

2) Click the Commands button. 

3) From the drop-down menu, choose Delete. A dialog box appears and asks 
you to confirm the delete.

4) Click Yes. The dialog box closes and the selected folder is deleted.
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Moving a template
To move a template from one template folder to another template folder:

1) In the Template Management window, in the box on the left, double-click 
the folder containing the template that you want to move. A list of all the 
templates contained in that folder appears underneath the folder name.

2) Click the template that you want to move and drag it to the desired folder.

Deleting a template
To delete a template:

1) In the Template Management window, double-click the folder that contains 
the template that you want to delete. A list of all the templates contained in 
that folder appears underneath the folder name.

2) Click the template that you want to delete. 

3) Click the Commands button. 

4) From the drop-down menu, choose Delete. A dialog box appears and asks 
you to confirm the deletion.

5) Click Yes. The dialog box closes and the selected template is deleted.

Importing a template
If the template that you want to use is in a different location, you must import it into 
an OOo template folder. 

To import a template into a template folder:

1) In the Template Management window, double-click the folder into which 
you want to import the template.

2) Click the Commands button.

3) From the drop-down menu, choose Import Template. The Open window 
opens.

4) Find the template that you want to import and click Open. The Open 
window closes and the template appears in the selected folder. 

5) If you want, type a new name for the template and then press the Enter key.
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Exporting a template
To export a template from a template folder to another location:

1) In the Template Management window, double-click the folder that contains 
the template you want to export. A list of all the templates contained in that 
folder appears underneath the folder name.

2) Click the template that you want to export.

3) Click the Commands button.

4) From the drop-down menu, choose Export Template. The Save As window 
opens.

5) Find the folder into which you want to export the template and click Save. 
OOo exports the template to the selected folder, and the Save As window 
closes. 

Note
All the actions made by the Commands button in the Template 
Management window can be made as well by simply right-clicking on 
the templates or the folders.

210 Chapter 12  Working with Templates



Chapter 1313
  Working With Styles

Introduction to Styles in OpenOffice.org

What are styles?

A style is a set of formats that you can apply to selected pages, text, frames, and 
other elements in your document to quickly change their appearance. When you 
apply a style, you apply a whole group of formats at the same time.

OpenOffice.org supports the following types of styles:

• Page styles include margins, headers and footers, borders and backgrounds. 
In Calc, page styles also include the sequence for printing sheets.

• Paragraph styles control all aspects of a paragraph’s appearance, such as 
text alignment, tab stops, line spacing, borders, and character formatting. 

• Character styles affect properties of selected text within a paragraph, such 
as the font and size of text, or bold and italic formats.

• Frame styles are used to format graphic and text frames, including borders, 
backgrounds, columns, and how text wraps around the frame.

• List styles apply similar alignment, numbering or bullet characters, and fonts 
to numbered or bulleted lists.

• Cell styles include fonts, alignment, borders, background, number formats 
(for example, currency, date, number), and cell protection.

• Graphics styles in drawings and presentations include line, area, shadowing, 
transparency, font, connectors, dimensioning, and other attributes.

• Presentation styles include attributes for font, indents, spacing, alignment, 
and tabs.
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What are styles?

Different styles are available in the various components of OOo, as listed in Table 1.

Table 1. Styles available in OOo components
Style TypeStyle Type WriterWriter CalcCalc DrawDraw ImpressImpress

Page X X

Paragraph X

Character X

Frame X

Numbering X

Cell X

Presentation X X

Graphics (included in 
Frame styles)

X X

OpenOffice.org comes with many predefined styles. You can use the styles as 
provided, modify them, or create new styles, as described in this chapter.

Why use styles?

Many people manually format paragraphs, words, tables, page layouts, and other 
parts of their documents without paying any attention to styles. They are used to 
writing documents according to physical attributes. For example, you might specify 
the font family, font size, and any formatting such as bold or italic 

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, 
Times New Roman, bold, centered”, and you start saying “Title” because you have 
defined the “Title” style to have those characteristics.  In other words, styles means 
that you shift the emphasis from what the text (or page, or other element) looks like, 
to what the text is. 

Styles help improve consistency in a document.  They also make major formatting 
changes easy.  For example, you may decide to change the indentation of all 
paragraphs, or change the font of all titles.  For a long document, this simple task 
can be prohibitive.  Styles make the task easy.

In addition, styles are used by OpenOffice.org for many processes, even if you are 
not aware of them. For example, OOo relies on heading styles (or other styles you 
specify) when it compiles a table of contents.
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Applying styles

OpenOffice.org provides several ways for you to select styles to apply.

Using the Styles and Formatting window
1) To open the Styles and Formatting window (Figure 167), do any one of the 

following:

• Click on the  icon located at the left-hand end of the object bar.

• Choose Format > Styles and Formatting.
• Press F11.

TIP You can move the Styles and Formatting window to a convenient 
position on the screen or dock it to an edge.

2) Click on one of the icons at the top left of the Styles and Formatting window 
to display a list of styles in a particular category.

3) To apply an existing style (except for character styles), put the cursor in the 
paragraph, frame, or page, and then double-click on the name of the style in 
one of these lists. To apply a character style, select the characters first.

TIP At the bottom of the Styles and Formatting window is a dropdown list 
(in Figure 167 the window shows Automatic, meaning the list includes 
only styles applied automatically by OOo). You can choose to show all 
styles or other groups of styles, for example only custom styles .

Figure 167. The Styles and Formatting window for Writer, showing paragraph styles
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Using Fill Format mode
Use Fill Format to apply a style to many different areas quickly without having to go 
back to the Styles and Formatting window and double-click every time. This method 
is useful for formatting many scattered paragraphs, words, or other items with the 
same style, and may be easier to use than making multiple selections first and then 
applying a style to all of them.

1) Open the Styles and Formatting window (Figure 167) and select a style.

2) Click the Fill Format mode icon . 

3) Hover the pointer over the paragraph, page or frame and click.

4) To apply a character style, hold down the mouse button while selecting the 
characters.

5) To quit Fill Format mode, click the icon again or press the Esc key.

Caution When this mode is active, a right-click anywhere in the document 
undoes the last Fill Format action. Be careful not to accidentally 
right-click and mistakenly undo actions you want to keep.

Using the Apply Style list
When a style is in use in a document, the style name appears on the Apply Style list 
(Figure 168) at the left end of the object bar, next to the Styles and Formatting icon.

To apply a style from this list, click on the desired style or use the up and down 
arrow keys to move through the list, then press Enter to apply the highlighted style.

TIP Select More... at the bottom of the list to open the Styles and Formatting 
window.
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Figure 168. The Apply Style list on the Object Bar

Assigning styles to shortcut keys

In OOo 2.0 you can configure shortcut keys to assign styles in your 
document.  Some shortcuts are pre-defined, such as Ctrl+1 for the 
Heading 1 paragraph style and Ctrl+2 for Heading 2.

OOo provides a set of predefined keyboard shortcuts that allow you to quickly apply 
styles. You can modify these shortcuts and create your own.

1) Click Tools > Customize > Keyboard. 

2) On the Keyboard tab of the Customize dialog (Figure 169), choose the 
shortcut keys you want to assign a style to. In this example we have chosen 
Ctrl+9.

3) In the Functions section at the bottom of the dialog, scroll down in the 
Category list to Styles. Click the + sign to expand the list of styles.

4) Choose the type of style. The Function list will display the names of the 
available styles for the selected type. The example in Figure 169 shows 
some of OOo’s predefined styles.

5) To set Ctrl+9 to the Text Body style, select Text Body in the Function list, 
and then click Modify. Ctrl+9 now appears in the Keys list.

6) When you are done assigning shortcuts, click Save and close the dialog.
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Figure 169. Defining keyboard shortcuts for applying styles

Modifying styles

OpenOffice.org provides two ways to modify styles (both the predefined styles and 
custom styles that you create):

• Changing a style using the Style dialog.
• Updating a style from a selection.

TIP Any changes made to a style are effective only in the current document. To 
change styles in more than one document, change the template (see  the 
chapter titled “Working with Templates”) or copy the styles into the other 
documents as described in “Copying and moving styles“ on page 220.
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Changing a style using the Style dialog
To change an existing style using the Style dialog, right-click on it in the Styles and 
Formatting window and select Modify from the popup menu.

The dialog displayed depends on the type of style selected. Each style dialog has 
several tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection
Let’s use paragraph styles as an example.

1) Open the Styles and Formatting window.

2) Create a new paragraph and edit all the properties you want to go into the 
style (like indentation, font properties, alignment, etc).

3) Select the paragraph.

4) In the Styles and Formatting window, select the style you want to update 
(single-click, not double-click), and then click on the triangle next to the 
New Style from Selection icon and select Update Style (see Figure 170).

Figure 170. Updating a style from a selection

The procedure to update another type of style (like character, page or frame styles) 
is the same. Just select the item in question, select the style you want to update, and 
choose Update Style.

Using AutoUpdate (paragraph and frame styles only)
If the AutoUpdate checkbox is selected on the Organizer page of the Paragraph Style 
or Frame Style dialog, applying direct formatting to a paragraph or frame using this 
style in your document automatically updates the style itself.

TIP If you are in the habit of manually overriding styles in your document, 
be sure that AutoUpdate is not enabled. 
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Updating styles from another document or template
You can update styles by copying or loading them from a template or another 
document. See “Copying and moving styles” on page 220.

Creating new (custom) styles

In addition to using the predefined styles provided by OOo, you can add new custom 
(user-defined) styles. OOo provides three ways to add styles.

• Create a new style using the Style dialog.
• Create a new style from a selection.
• Drag and drop a selection to create a new style.

Creating a new style using the Style dialog
Open the Styles and Formatting window (Figure 167). Right-click on a style and 
select New. The style that you choose will be the basis for this new style. If you do 
not want too many of the options preset for you, choose the default style.

The dialog displayed depends on the type of style selected. See the chapters on 
styles in the user guides for details. The dialogs and choices for defining new styles 
are the same as for modifying existing styles.

Linking styles
You can link a new style to an existing style. For example, suppose that the style 
mystyle specifies a font size of12. Then you create another style (mysyle2) linked to 
mystyle and specifies underlined text. If you modify mystyle to font size 20, 
mystyle2 inherits the new font size but still underlines the text.

TIP If styles are linked, changing the base style, changes all the linked styles. 
Sometimes this is exactly what you want; other times it is not. It pays to 
plan ahead. Many predefined styles are already linked to other styles.

Creating a new style from a selection
You can create a new style from the formatting of an object in the current document. 
For instance, you can change the formatting of a paragraph or frame until it appears 
as you like, and then you can turn that object’s formatting into a new style. This 
procedure can save time, because you do not have to create a new style as described 
above and remember all of the formatting settings.
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1) Change the formatting of the object (paragraph, frame, etc) to your liking.
2) Open the Styles and Formatting window. From the drop-down list at the 

bottom of the window, choose the type of style to create (paragraph, 
character, and so on).

3) In the document, select the item to save as a style.
4) In the Styles and Formatting window, click the New Style from Selection 

icon and select New Style from Selection from the options.
5) In the Create Style dialog (Figure 171), type a name for the new style. The 

list shows the names of existing custom styles of the selected type. Click 
OK to save the new style.

Figure 171. Creating a new style from a selection

Dragging and dropping a selection to create a style

You can drag and drop a text selection into the Styles and Formatting 
window to create a new style.

Writer
Select some text and drag it to the Styles and Formatting window. If Paragraph 
Styles are active, the paragraph style will be added to the list. If Character Styles are 
active, the character style will be added to the list.

Calc
Drag cell selection to the Styles and Formatting window to create cell styles.

Draw/Impress
Select and drag drawing objects to the Styles and Formatting window to create 
graphics styles.
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Copying and moving styles

When you create a style in a document, it is available only within that document. 
Styles always stay with a document. So, for example, if you e-mail a document to 
another person, the styles go with it.

Having created a style, you may want to transfer the style to another document. You 
can copy or move styles from one template or document to another in two ways:

• Using the Template Management dialog
• Loading styles from a template or document

Using the Template Management dialog
To copy or move styles using the Template Management dialog:

1) Click File > Templates > Organize.

2) At the bottom of the Template Management dialog (Figure 172), choose 
either Templates or Documents, as needed. For example, if you are copying 
styles between two documents, both entries should say Document.

Figure 172. Copying styles using the Template Management dialog

3) To load styles from a file, click the File button. When you return to this 
window, both lists show the selected file as well as all the currently open 
documents.

4) Double-click on the name of the template or document, and then double-
click the Styles icon to show the list of individual styles.
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5) To copy a style, hold down the Ctrl key and drag the name of the style from 
one list to the other.

To move a style, do not use the Ctrl key while dragging. The style will be 
deleted from the list you are dragging it from.

6) Repeat for each style you want to copy. or move. When you are finished, 
click Close.

Loading styles from a template or document
You can copy styles by loading them from a template or another document:

1) Open the document you want to copy styles into.

2) In the Styles and Formatting window, click on the triangle next to the New 
Style from Selection icon, and then click on Load Styles (see Figure 170).

3) On the Load Styles dialog (Figure 173), find and select the template you 
want to copy styles from.

4) Select the checkboxes for the categories of styles to be copied. Select 
Overwrite if you want the styles being copied to replace any styles of the 
same names in the document you’re copying them into.

5) Click OK to copy the styles. You will not see any change on screen.

Figure 173. Copying styles from a template into the open document

Note To copy the styles from another document, click the From File button to 
open a window from which you can select the required document.
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Deleting styles

You cannot remove (delete) any of OOo’s predefined styles from a template, even if 
you are not using them.

You can remove any user-defined (custom) styles; but before you do, you should 
make sure the styles are not in use. If an unwanted style is in use, you’ll want to 
replace it with a substitute style.

Replacing styles (and then deleting the unwanted ones) can be very useful if you are 
dealing with a document that has been worked on by several writers or has been 
formed by combining several documents from different sources. 

To delete unwanted styles, right-click on them (one at a time) in the Styles and 
Formatting window and click Delete on the pop-up menu.

If the style is in use, you receive the message shown in Figure 174.

Figure 174. Deleting an applied style

If the style is not in use, you receive the message shown in Figure 175.

Figure 175. Deleting a style that is not in use
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The Gallery contains objects (graphics and sounds) that you can insert into your 
documents. The default Gallery menu contains 3D Effects, Backgrounds, Bullets, 
Homepage, My Theme, Rulers, and Sounds. You can create other groups or 
“themes” as you wish.

To open the Gallery, choose Tools > Gallery, or click the Gallery icon  . If the 
Gallery is open, these choices close it.

Figures 176 and 177 show two views of one of the themes supplied with 
OpenOffice.org.

You have the option of Icon view or Detailed view for the Gallery, and you can hide 
or show the Gallery by clicking on the Hide button. 

Figure 176. Icon View of one theme in the Gallery
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Figure 177. Detailed view of the same theme in the Gallery

Inserting objects into a document

You can copy or link an object from the Gallery into a document. The difference is 
that a linked object can be updated in your document if the object is changed in the 
Gallery, simply by updating the link.

To insert an object:

1) Choose Tools > Gallery and select a theme. 

2) Select an object with a single click, then drag and drop the object into the 
document. (See Figure 178.)

You also can right-click on the object to open the context menu and select Insert 
and Copy.

Inserting objects as links
To insert an object as a link:

1) Choose Tools > Gallery and select a theme. 

2) Select an object with a single click, then while pressing the Shift and Ctrl 
keys, drag and drop the object into the document.

Inserting an object as a background 
To insert an object as the background to a page or paragraph:

1) Choose Tools > Gallery and select a theme. 

2) Select an object with a single click, right-click on the object and choose 
Insert > Background > Page or Paragraph.
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Figure 178. Copying a graphic object from the Gallery into a document

Adding graphics to the Gallery

To add graphics to the Gallery from a document:

1) Display the Gallery theme you wish to add the graphic to. 

2) Position the mouse pointer over the graphic in the document and left-click 
one time.

3) Release the mouse button, then left-click again, holding the mouse button 
down for more than two seconds (this copies the graphic into internal 
memory). 

4) Without releasing the mouse button, drag the graphic from the document 
into the Gallery theme, then release the mouse button.  The graphic is now 
in the theme list.
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Deleting graphics from the Gallery

1) Right-click on the name of the graphics file or its thumbnail in the Gallery.

2) Click Delete on the pop-up menu.

Note Deleting the name of a file from the list in the Gallery does not delete 
the file from the hard disk or other location.

Creating a new theme

To create a new theme in the Gallery:

1) Choose Tools > Gallery > New Theme button > Files tab (see Figure 179).

Figure 179. Setting up a new theme in the Gallery  

2) Click Find Files. The Select Path dialog opens. Browse to the folder that 
contains the files for the new theme and click OK.

3) Back on the Files tab, use File Type and/or select a file from the list 
displayed, to choose to add a file or all files. (See Figure 180.)
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Figure 180. Choosing files to add to the new theme

4) Then click the General tab and name your theme, as shown in Figure 181. 
Click OK to finish.

Figure 181. Naming the new theme

Chapter 14  Working with the Gallery 227



Location of Gallery and the objects in it

Location of Gallery and the objects in it

Graphics and other objects shown in the Gallery can be located anywhere on your 
computer’s hard disk, on a network drive, or on a CD-ROM. Listings in the Gallery 
refer to the location of each object. When you add graphics to the Gallery, the files 
are not moved or copied; only the location of each new object is added as a 
reference.

In a workgroup situation, you may have access to a shared Gallery (where you 
cannot change the contents unless authorized to do so) and a user Gallery, where you 
can add, change, or delete objects.

The location of the Gallery is specified in Tools > Options > OpenOffice.org > 
Paths. 
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Creating Graphical Text Art Objects

With Fontwork you can create graphical text art objects for making your work more 
attractive. There are many different settings (line, area, position, size, and more), so 
you have a large choice. You will surely find one that fits your document. 

Fontwork is available with each component of OpenOffice.org (OOo), but you will 
notice small differences in the way that each component displays it.

Fontwork changed dramatically with OOo 2.0, with many new 
features.

The Fontwork toolbars

You can use two different toolbars for creating and editing a Fontwork object.

• Go to View > Toolbars > Fontwork.

Figure 182. The floating Fontwork toolbar

• If you click on an existing Fontwork object, the Formatting toolbar changes 
to display the Fontwork options as in Figure 183. The contents of this 
toolbar vary depending on the OOo component.

Figure 183. The Formatting toolbar in Writer when a Fontwork object is selected
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Creating a Fontwork object

1) On the Drawing or Fontwork toolbar, click the Fontwork Gallery 
icon. If the Drawing toolbar is not visible, go to View > Toolbars > 
Drawing to display it.

2) In the Fontwork Gallery dialog (Figure 184), select a Fontwork style, then 
click OK. The Fontwork object will appear in your document. Notice the 
blue squares around the edge (indicating that the object is selected) and the 
yellow dot; these are discussed in “Moving and resizing Fontwork objects” 
on page 236.

Figure 184. The Fontwork Gallery

3) Double-click the object to edit the Fontwork text 

4) Type your own text in place of the black “Fontwork” text that appears over 
the object (Figure 185).
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Figure 185. Editing Fontwork text

5) Click anywhere in a free space or press Esc to apply your changes.

Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do 
this, you can use the Fontwork toolbar, the Formatting toolbar, or menu options as 
described in this section.

Using the Fontwork toolbar
1) Click on the Fontwork object. The Fontwork toolbar is displayed (Figure

182). If you do not see it, go to View > Toolbars > Fontwork.

2) Click on the different icons to edit Fontwork objects:

• Fontwork Gallery: Adds another Fontwork object to the document.

• Fontwork Shape: Edits the shape of the selected object. You can choose 
from a palette of shapes, as shown in Figure 186.

Figure 186. Fontwork toolbar showing palette of  
shapes
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• Fontwork Same Letter Heights: Changes the height of characters in the 
object. Toggles between normal height (some characters taller than 
others, for example capital letters, d, h, l and others) and all letters the 
same height. See Figure 187.

Figure 187. Left: normal letters; right: same letter heights

• Fontwork Alignment: Changes the alignment of characters. Choices are 
left align, center, right align, word justify, and stretch justify.

• Fontwork Character Spacing: Changes the character spacing and 
kerning in the object.

Using the Formatting toolbar
Now let us go further and customize the Fontwork object with several more 
attributes.

Click on the Fontwork object. The Formatting toolbar changes to show all the 
options for editing the object. (For example, the toolbar shown in Figure 188 will 
appear when you use Fontwork in Writer.)

On the Formatting toolbar you have a large choice of options for customizing your 
object. These choices are the same as the ones for other drawing objects. You can 
read about them in more detail in the chapter titled “Editing Objects Part II” in the 
Draw Guide.

Figure 188. Formatting toolbar with a Fontwork object selected in Writer
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Editing a Fontwork object

Line options
Line icon: Opens a dialog (Figure 189) with three tabs: Line, Line Styles, 
Arrow Styles. 

• Use the Line tab to edit the most common properties of the line around the 
selected Fontwork object, by choosing from previously-defined attributes 
including line style, line color, and arrow styles.

• Use the Lines Styles and Arrow Styles tabs to edit the properties of line 
and arrow styles, and define new styles.

Arrow Style icon: Choose from the different arrow styles.

Line Style box: Choose from the available line styles.

Line Width box: Set the width of the line.

Line Color box: Select the color of the line.

Figure 189. Line options dialog
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Area options
Area icon: Opens a dialog (Figure 190) with seven tabs: Area, Shadow, 
Transparency, Colors, Gradients, Hatching, Bitmaps. 

• Area tab: Choose from the predefined list a color, bitmap, gradient or 
hatching pattern to fill the selected object.

• Shadow tab: Set the shadow properties of the selected object.

• Transparency tab: Set the transparency properties of the selected object.

• Colors tab: Modify the available colors or add new ones to appear on the 
Area tab.

• Gradients tab: Modify the available gradients or add new ones to appear on 
the Area tab.

• Hatching tab: Modify the available hatching patterns or add new ones to 
appear on the Area tab.

• Bitmaps tab: Create simple bitmap patterns and import bitmaps, to make 
them available on the Area tab.

Area Style / Filling boxes: Select the type of the fill of the selected object. For more 
detailed settings, use the Area icon.

Figure 190. Area options dialog
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Positioning options
Rotate icon: Rotate the selected object manually using the mouse to drag the object. 

To Foreground icon: Moves the selected object in front of the text.

To Background icon: Moves the selected object behind the text.

Alignment icon: Modifies the alignment of the selected objects.

Bring to front icon: Moves the selected object in front of the others.

Send to back icon: Moves the selected object behind the others.

Change Anchor icon: Switch between anchoring options:

• To Page - The object keeps the same position in relation to the page 
margins. It does not move as you add or delete text.

• To Paragraph - The object is associated with a paragraph and moves with 
the paragraph. It may be placed in the margin or another location.

• To Character - The object is associated with a character but is not in the text 
sequence. It moves with the paragraph but may be placed in the margin or 
another location. This method is similar to anchoring to a paragraph.

• As Character - The object is placed in the document like any character and 
moves with the paragraph as you add or delete text before the object.

Ungroup icon: Ungroups the selected objects, so you can manage them individually.

Group icon: Groups the selected objects, so you can manage them as a single object.

Using menu options
You can use some the choices on the Format menu to anchor, align, arrange and 
group selected Fontwork objects, wrap text around them, and flip them horizontally 
and vertically.

You can also right-click on a Fontwork object and choose many of the same options 
from the pop-up menu. In addition, the pop-up menu provides quick access to the 
Line, Area, Text, and Position and Size dialogs. The Line and Area dialogs are 
described on pages 233 and 234. The Text dialog offers only a few options for 
Fontwork objects and is not discussed here.

On the Position and Size dialog (Figure 191), you can enter precise values 
concerning size and position. For more information, see the Draw Guide.
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Figure 191. Position and Size dialog

Moving and resizing Fontwork objects

When you select a Fontwork object, eight blue squares (known as handles) appear 
around the edge of the object, as shown in Figure 192. You can drag these handles to 
resize the object.

A yellow dot also appears on the object. This dot 
may be along an edge of the object, or it may be 
somewhere else; see Figure 192 for an example. If 
you hover the pointer over this yellow dot, the 
pointer turns into a hand symbol. You can drag the 
dot in different directions to distort the object.

Hovering the pointer over other parts of the object 
turns the pointer into the usual symbol for 
dragging the object to another part of the page.

For precise control of the location and size of the 
object, use the Position and Size dialog (Figure
191).
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  Creating Web Pages

Saving Documents as HTML Files

This chapter describes how to save documents as web pages from Writer, Calc, 
Draw and Impress. For more details about using Writer as a web page creator and 
editor, see the Writer Guide.

Saving Writer documents as web pages

Writer’s HTML capabilities include saving existing documents in HTML format, 
creating new documents as HTML and creating several different types of web pages 
using a wizard.

The easiest way to create HTML documents is to start with an existing Writer 
document. You can view it as it will appear on a web page by using View > Web 
Layout.

Inserting hyperlinks
You can insert and modify links using the hyperlink dialog. Display the dialog by 

clicking the Hyperlink icon  on the Function Bar or Insert > Hyperlink. 
Writing or pasting a URL into a document will (depending on AutoCorrect settings) 
automatically convert to  hyperlink.

To edit an existing link:

1) Either move the cursor into the link using the keyboard arrow keys, or 
toggle the “HYP” to “SEL” in the Status Bar (by clicking on the letters HYP 
or SEL in the status bar, as shown in Figure 193) and use the mouse to 
position the cursor.
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Figure 193. Writer status bar

Note If the status bar says HYP and you left-click on a link, OOo will try to 
open the link in your default web browser. It has to say SEL in the status 
bar for you to be able to click and position the cursor.

2) Click Edit > Hyperlink. The Hyperlink dialog (Figure 194) opens.

3) From the Hyperlink dialog, you can choose the type of link, as well as 
specify the link’s address, text and how it should be displayed (for example, 
in a new window).

Figure 194. Hyperlink dialog

To turn existing text into a link, highlight it, then open the Hyperlink dialog. Copy 
the text into the Target field. Click Apply to insert the link into the document before 
closing the dialog.

Note Cross references do not become hyperlinks in an HTML document.
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Saving a document as a single Web page
To save a document as a single Web page (HTML format), select Save As from the 
File menu and specify HTML Document as the file type.

Note Writer does not replace multiple spaces in the original document with the 
HTML code for non-breaking spaces. If you want to have extra spaces in 
your HTML file or web page, you need to insert non-breaking spaces in 
OOo. To do this, press Control+Spacebar instead of just Spacebar. 

Saving a document as a series of Web pages
Writer can save a large document as a series of Web pages (HTML files) with a table 
of contents page. To do this:

1) Decide which headings in the document should start on a new page and 
make sure all those headings have the same style (for example, Heading 1).

2) Select File > Send and click on Create HTML Document.

3) In the dialog (Figure 195), enter the file name to save the pages under. Also 
specify which style indicates a new page (as decided in step 1).

4) Click Save to create the multi-page HTML document. (For those who may 
be interested, the resulting HTML files conform to the HTML 4 
Transitional.)

Figure 195. Creating a series of Web pages from one document

Chapter 16  Creating Web Pages 239



Saving Writer documents as web pages

Creating Web pages using a Wizard
OOo’s Web wizard allows you to create several types of standard Web pages.

1) Select File > Wizards > Web Page. On the first page of the Wizard (Figure
196), choose settings and click Next.

Figure 196. Web page wizard step 1

Note If this is your first web page, the only settings option is Default. 

2) Choose or browse to the document you would like to format and add the 
Title, Summary and Author information as shown in Figure 197. Click Next.

Figure 197. Web page wizard step 2

240 Chapter 16  Creating Web Pages



Saving Writer documents as web pages

3) Chose a layout for the web site by clicking on the layout boxes shown in 
Figure 198. Click Next.

Figure 198. Web page wizard step 3

4) Chose the information to be listed and the screen resolution, as shown in 
Figure 199. Click Next.

Figure 199. Web page wizard step 4
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5) Select a style for the page. Use the drop-down list, shown in Figure 200, to 
choose different styles and color combinations. You can browse to a 
background image and icon set from the Gallery. Click Next.

Figure 200. Web page wizard step 5

6) Enter general information such as Title and Metadata information, as shown 
in Figure 201. Click Next.

Figure 201. Web page wizard step 6
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7) Chose where to save the file and preview the page if you wish, as shown in 
Figure 202.

Figure 202. Web page wizard step 7

To edit or view the document’s underlying HTML code, click View > 

HTMLSource or click the HTML Source icon  on the Main toolbar.

Saving Calc spreadsheets as web pages

Calc can save files as HTML documents. As for Writer, use File > Save As and 
select HTML Document, or File > Wizards > Web Page.

If the file contains more than one sheet, the additional sheets will follow one another 
in the HTML file. Links to each sheet will be placed at the top of the document. 
Calc also allows the insertion of links directly into the spreadsheet using the 
Hyperlink dialog.

Saving Impress presentations as web pages

You can export presentations as Macromedia Flash files: select File > Export and 
choose Macromedia Flash for the file type.

You can also convert presentations into a series of Web pages.

1) To begin, select File > Export and choose HTML Document as the file 
type. 
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2) Choose a location for the file, supply a name for the resulting HTML file, 
and click Save. The HTML Export Wizard opens.

3) Choose the design for all of the pages, either from an existing design or by 
creating a new one. If you have not previously saved a design, the Existing 
Design choice is not available.

4) Click Next to select the type of web pages to create. 

• Standard HTML: one page for each slide, with navigation links to move 
from slide to slide.

• Automatic: one page for each slide, with each page set with the Refresh 
meta tag so a browser automatically cycles from one page to the next.

• WebCast generates an ASP or Perl application to display the slides. 
Unfortunately OOo has no direct support for PHP as yet. 
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5) Decide how the images will be saved (GIF or JPG) and what resolution to 
use. 

6) If Create a title page was chosen in step 4, supply the information for it on 
the next page. The title contains an author name, e-mail address and home 
page, along with any additional information you want to include.

7) Choose the navigation button style to use to move from one page to another. 
If you do not choose any, OOo will create a text navigator.
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8) Select the color scheme for the web pages. Available schemes include the 
document’s existing scheme, one based upon browser colors, and a 
completely user-defined scheme. You can save a new scheme so that it will 
appear on the first page of the HTML export wizard.

9) Click Create to generate the HTML files. On the export page, if you do not 
use the default option, OOo will suggest several vector or bitmap formats.

Note The HTML and image files are placed in the same directory, so it is 
advisable to create unique directories for each presentation.

Saving Draw documents as web pages
Exporting drawings from OpenOffice.org’s Draw application is similar to exporting 
a presentation from Impress. Use File > Export and select HTML Document as the 
file type.
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Appendix
  PDF and ODT copies of this book

The PDF version of this Getting Started book includes one more chapter:

• Chapter 17, Getting Started with Macros 

The PDF version is available through the OpenOffice.org Documentation Project’s 
website (http://documentation.openoffice.org/manuals/) and the OOoAuthors 
website (http://oooauthors.org/en/authors/userguide2/published/). It is formatted for 
US letter-size paper.

Individual chapters of this book, including the extra chapter, are also available from 
those sources, in two formats: ODT and PDF.
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